برگه تقلب اچتمل به فارسي در اينترنت - HTML Cheatsheet

﻿
HTML Cheatsheet
تگهای اصلی (Basic Tags)
<html></html> | ايجاد سندی اچتمل
<head></head> | ایجاد اطلاعات شناسنامه ای سند مانند عنوان و ...
<body></body> | ایجاد بدنه و قسمت قابل مشاهده سند اچتمل
تگهای ناحيه Header
<title></title> | تعيين عنوان سند
شناسه های مهم تگ body
<body bgcolor=?> | تعيين رنگ زمينه بر اساس نام رنگ يا معادل هگز
<body text=?> | تعيين رنگ نوشته بر اساس نام رنگ يا معادل هگز
<body link=?> | تعيين رنگ پیوندها بر اساس نام رنگ يا معادل هگز
<body vlink=?> | تعيين رنگ پیوندهای بازدیدشده بر اساس نام رنگ
<body alink=?> | تعيين رنگ پیوند فعال بر اساس نام رنگ يا معادل هگز
تگهای متن و نوشته
<pre></pre> | نمایش متن های از قبل فرمت شده (preformatted)
<hl></hl> | ایجاد بزرگترین سر تیتر
<h6></h6> | ایجاد کوچکترین سر تیتر
<b></b> | ایجاد متن توپر
<i></i> | ایجاد متن مورب و ایتالیک
<tt></tt> | ایجاد متن از نوع تله تایپی
<cite></cite> | ایجاد citation معمولا ایتالیک
<em></em> | نمایش تاکید شده متن (توپر یا مورب)
<strong></strong> | نمایش تاکید شده متن (توپر یا مورب)
<font size=?></font> | تعیین اندازه قلم از 1 تا 7
<font color=?></font> | تعیین رنگ قلم بر اساس نام رنگ یا مقدار هگز آن
پیوندها
<a href="URL"></a> | ایجاد پیوند
<a href="mailto:EMAIL"></a> | ایجاد پیوندی از نوع mailto
<a name="NAME"></a> | ایجاد پیوندی نامگذاری شده در یک سند
<a href="#NAME"></a> | ارجاع به یک پیوند نامگذاری شده
فرمت دهی
<p></p> | ایجاد پاراگرافی جدید
<p align=?> | ترازبندی پاراگراف در سمت left, right, or center
<br> | رفتن سر سطر جدید
<blockquote> </blockquote> | عنوان سازی متن
<dl></dl> | ایجاد فهرستهای تعریفی
<dt> | ایجاد عنصری از یک فهرست تعریفی
<dd> | ایجاد شرح و توصیف یک عنصر فهرست تعریفی
<ol></ol> | ایجاد فهرستهای مرتب
<li></li> | ایجاد یک قلم اطلاعاتی از یک فهرست
<ul></ul> | ایجاد فهرستی نامرتب
<div align=?> | تگی برای فرمت دهی بلوکی بزرگ از کدهای اچتمل
المانهای گرافیکی
<img src="name"> | ایجاد یک تصویر
<img src="name" align=?> | تراز بندی تصویر (left, right, center; bottom, top, middle)
<img src="name" border=?> | تعیین ضخامت مرز یک تصویر
<hr> | درج خطی افقی
<hr size=?> | تعیین ارتفاع خط افقی
<hr width=?> | تعیین عرض خط بر اساس مقدار واقعی یا درصدی
<hr noshade> | ایجاد خطی افقی بدون سایه
جداول
<table></table> | ایجاد جدول
<tr></tr> | ایجاد ردیف در جداول
<td></td> | ایجاد خانه های جداول
<th></th> | ایجاد عنوان ستونهای یک جدول
شناسه های جداول
<table border=#> | تعیین مقدار ضخامت مرزهای یک جدول
<table cellspacing=#> | تعیین فاصله بین خانه های جدول
<table cellpadding=#> | تعیین فاصله بین محتوای یک خانه و مرزهای آن
<table width=# or %> | تعیین عرض جدول بر اساس پیکسل و یا درصدی
<tr align=?> or <td align=?> | تعیین ترازبندی خانه های جدول (left, center, right)
<tr valign=?> or <td valign=?> | ترازبندی عمودی خانه های جدول (top, middle, bottom)
<td colspan=#> | تعیین تعداد ستون هائی که باید یکی شوند.
<td rowspan=#> | تعیین تعداد سطر هائی که باید یکی شوند.
<td nowrap> | باعث جلوگیری از شکسته شدن متن در خانه جدول میشود.
فریمها
<frameset></frameset> | تعریف و ایجاد مجموعه ای از فریمها
<frameset rows="value,value"> | شناسه ای برای تعریف ردیفهای یک مجموعه فریم بر اساس اندازه واقعی بر حسب پیکسل و یا ابعاد درصدی
<frameset cols="value,value"> | شناسه ای برای تعریف ستونها یک مجموعه فریم بر اساس اندازه واقعی بر حسب پیکسل و یا ابعاد درصدی
<frame> | تعریف فریمی از مجموعه فریمها
<noframes></noframes> | تعیین متنی که باید در صورت عدم پشتیبانی مرورگر از فریمها باید نمایش داده شود.
شناسه های فریمها
<frame src="URL"> | تعیین سند اچتمل داخل فریم
<frame name="name"> | تعیین نام برای یک فریم
<frame marginwidth=#> | تعیین عرض حاشیه راست و چپ فریم
<frame marginheight=#> | تعریف طول حاشیه بالا و پایین فریم بر اساس پیکسل
<frame scrolling=VALUE> | تعیین اینکه فریمی از Scroll bar استفاده کند یا نه. مقادیر ممکن: yes، no و auto (حالت پیش فرض)
<frame noresize> | سبب جلوگیری از تغییر اندازه یک فریم میشود.
فرمها
<form></form> | ایجاد یک فرم
<select multiple name="NAME" size=?></select> | ايجاد یک منوی کرکره ای و تعیین تعداد اقلامی که قبل از scrolling نمایش داده خواهند شد.
<option> | تعیین هر یک از اقلام منو کرکره ای
<select name="NAME"></select> | ایجاد منوی کرکره ای
<option> | تعیین هر یک از اقلام منو کرکره ای
<textarea name="NAME" cols=40 rows=8></textarea> | ایجاد المانی برای ورود متن در بیش از یک خط با تعیین تعداد سطر و ستون ناحیه
<input type="checkbox" name="NAME"> | ایجاد چک باکسی با تعیین متن و عنوان آن
<input type="radio" name="NAME" value="x"> | ایجاد رادیو باتن با تعیین متن و عنوان آن
<input type=text name="foo" size=20> | ایجاد المانی برای ورود متن با حداکثر یک سطر به همراه تعیین ابعاد بر اساس نویسه
<input type="submit" value="NAME"> | ایجاد دکمه ای از نوع ارسال و Submit
<input type="image" border=0 name="NAME" src="name.gif"> | ایجاد دکمه ای از نوع ارسال با کمک یک تصویر
<input type="reset"> | ایجاد دکمه خلاصی !! یا Reset

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


جدول رنگهای اچتمل به فارسي در اينترنت - HTML color codes in Persian / Farsi

﻿
رنگها در اچتمل:
در زبان اچتمل رنگها بر اساس ترکیب سه منبع نوری قرمز(Red)، سبز(Green) و آبی(Blue) تعریف میشوند و هر منبع نوری شدتی بین 0 تا 255 را میتواند داشته باشد. در این استاندارد نور سفید رنگی است حاصل از تداخل سه منبع نوری با شدت کامل یعنی 255 و رنگ سیاه حاصل تداخل سه نور با شدت 0 خواهد بود.(در واقع هر نقطه رنگی يا پیکسل بر روی صفحه مانیتور حاصل برخورد سه اشعه نوری قرمز، سبز و آبی ساخته شده توسط لامپ تصویر میباشد.)

توجه داشته باشید که مطابق تعریف ذکر شده امکان استفاده از 256 x 256 x 256 یا حدود 16 میلیون (16,777,216) رنگ مختلف وجود داشته و در شناسه های مختلف به یکی از سه روش زیر قادر به تعیین رنگ متن یا ناحیه ای خواهید بود:

  1. استفاده از مقادیر شدت نور در مبنای 16 با فرمت #RRGGBB که RR، GG, BB مقادیر مبنای شانزده نورهای قرمز، سبز و آبی میباشند.
  2. استفاده از مقادیر شدت نور در مبنای 10 با فرمت rgb(RRR,GGG,BBB) که RRR، GGG, BBB مقادیر مبنای ده نورهای قرمز، سبز و آبی میباشند.
  3. استفاده از نامهای استاندارد رنگها مانند red ، green و ... مطابق جدول انتهائی این صفحه
جدول زیر حاوی جندین مثال و رنگ ترکیبی در مبنای ده و شانزده میباشد:

Color | مبنای 16 (Color HEX) | مبنای 10 (Color RGB) | نام رنگ
 | #000000 | rgb(0,0,0) | Black
 | #FF0000 | rgb(255,0,0) | Red
 | #00FF00 | rgb(0,255,0) | Lime
 | #0000FF | rgb(0,0,255) | Blue
 | #FFFF00 | rgb(255,255,0) | Yellow
 | #00FFFF | rgb(0,255,255) | Cyan
 | #FF00FF | rgb(255,0,255) | Fuchsia
 | #FFFFFF | rgb(255,255,255) | White
 | #C0C0C0 | rgb(192,192,192) | Silver

مثالهائی از نحوه استفاده از رنگها در اچتمل:
<p style="color:#FF00FF">Hello!</p> | استفاده از مقدار در مبنای 16
<p style="color:rgb(255,0,255)">Hello!</p> | استفاده از مقدار در مبنای 10
<p style="color:Fuchsia">Hello!</p> | استفاده از نام رنگ
body{ color: #444400; } | تعیین رنگ نوشته المان body در Style sheet ها
body{ background-color:#FFFFFF; } | تعیین رنگ زمینه صفحه در Style sheet ها
HR { color : #EEEECC;} | تعیین رنگ خطوط افقی در Style sheet ها
a:link {color:#c00B09;} | تعیین رنگ پیوندها در Style sheet ها
p {color:Yellow;} | تعیین رنگ متون پاراگرافها در Style sheet ها

جدول رنگهای پايه اچتمل بر اساس مقادير هگز

#EEEEEE | #DDDDDD | #CCCCCC | #BBBBBB | #AAAAAA | #999999
#888888 | #777777 | #666666 | #555555 | #444444 | #333333
#000000 | #000033 | #000066 | #000099 | #0000CC | #0000FF
#330000 | #330033 | #330066 | #330099 | #3300CC | #3300FF
#660000 | #660033 | #660066 | #660099 | #6600CC | #6600FF
#990000 | #990033 | #990066 | #990099 | #9900CC | #9900FF
#CC0000 | #CC0033 | #CC0066 | #CC0099 | #CC00CC | #CC00FF
#FF0000 | #FF0033 | #FF0066 | #FF0099 | #FF00CC | #FF00FF
#003300 | #003333 | #003366 | #003399 | #0033CC | #0033FF
#333300 | #333333 | #333366 | #333399 | #3333CC | #3333FF
#663300 | #663333 | #663366 | #663399 | #6633CC | #6633FF
#993300 | #993333 | #993366 | #993399 | #9933CC | #9933FF
#CC3300 | #CC3333 | #CC3366 | #CC3399 | #CC33CC | #CC33FF
#FF3300 | #FF3333 | #FF3366 | #FF3399 | #FF33CC | #FF33FF
#006600 | #006633 | #006666 | #006699 | #0066CC | #0066FF
#336600 | #336633 | #336666 | #336699 | #3366CC | #3366FF
#666600 | #666633 | #666666 | #666699 | #6666CC | #6666FF
#996600 | #996633 | #996666 | #996699 | #9966CC | #9966FF
#CC6600 | #CC6633 | #CC6666 | #CC3399 | #CC66CC | #CC66FF
#FF6600 | #FF6633 | #FF6666 | #FF6699 | #FF66CC | #FF66FF
#009900 | #009933 | #009966 | #009999 | #0099CC | #0099FF
#339900 | #339933 | #339966 | #339999 | #3399CC | #3399FF
#669900 | #669933 | #669966 | #669999 | #6699CC | #6699FF
#999900 | #999933 | #999966 | #999999 | #9999CC | #9999FF
#CC9900 | #CC9933 | #CC9966 | #CC9999 | #CC99CC | #CC99FF
#FF9900 | #FF9933 | #FF9966 | #FF9999 | #FF99CC | #FF99FF
#00CC00 | #00CC33 | #00CC66 | #00CC99 | #00CCCC | #00CCFF
#33CC00 | #33CC33 | #33CC66 | #33CC99 | #33CCCC | #33CCFF
#66CC00 | #66CC33 | #66CC66 | #66CC99 | #66CCCC | #66CCFF
#99CC00 | #99CC33 | #99CC66 | #99CC99 | #99CCCC | #99CCFF
#CCCC00 | #CCCC33 | #CCCC66 | #CCCC99 | #CCCCCC | #CCCCFF
#FFCC00 | #FFCC33 | #FFCC66 | #FFCC99 | #FFCCCC | #FFCCFF
#00FF00 | #00FF33 | #00FF66 | #00FF99 | #00FFCC | #00FFFF
#33FF00 | #33FF33 | #33FF66 | #33FF99 | #33FFCC | #33FFFF
#66FF00 | #66FF33 | #66FF66 | #66FF99 | #66FFCC | #66FFFF
#99FF00 | #99FF33 | #99FF66 | #99FF99 | #99FFCC | #99FFFF
#CCFF00 | #CCFF33 | #CCFF66 | #CCFF99 | #CCFFCC | #CCFFFF
#FFFF00 | #FFFF33 | #FFFF66 | #FFFF99 | #FFFFCC | #FFFFFF

جدول رنگهای نامگذاری شده و مقادير معادل هگز آن به ترتیب حروف الفباء

Aliceblue #F0F8FF | Antiquewhite #FAEBD7 | Aqua #00FFFF
Aquamarine #7FFFD4 | Azure #F0FFFF | Beige #F5F5DC
Bisque #FFE4C4 | Black #000000 | Blanchedalmond #FFEBCD
Blue #0000FF | Blueviolet #8A2BE2 | Brown #A52A2A
Burlywood #DEB887 | Cadetblue #5F9EA0 | Chartreuse #7FFF00
Chocolate #D2691E | Coral #FF7F50 | Cornflowerblue #6495ED
Cornsilk #FFF8DC | Crimson #DC143C | Cyan #00FFFF
Darkblue #00008B | Darkcyan #008B8B | Darkgoldenrod #B8860B
Darkgray #A9A9A9 | Darkgreen #006400 | Darkkhaki #BDB76B
Darkmagenta #8B008B | Darkolivegreen #556B2F | Darkorange #FF8C00
Darkorchid #9932CC | Darkred #8B0000 | Darksalmon #E9967A
Darkseagreen #8FBC8F | Darkslateblue #483D8B | Darkslategray #2F4F4F
Darkturquoise #00CED1 | Darkviolet #9400D3 | Deeppink #FF1493
Deepskyblue #00BFFF | Dimgray #696969 | Dodgerblue #1E90FF
Firebrick #B22222 | Floralwhite #FFFAF0 | Forestgreen #228B22
Fuchsia #FF00FF | Gainsboro #DCDCDC | Ghostwhite #F8F8FF
Gold #FFD700 | Goldenrod #DAA520 | Gray #808080
Green #008000 | Greenyellow #ADFF2F | Honeydew #F0FFF0
Hotpink #FF69B4 | Indianred #CD5C5C | Indigo #4B0082
Ivory #FFFFF0 | Khaki #F0E68C | Lavender #E6E6FA
Lavenderblush #FFF0F5 | Lawngreen #7CFC00 | Lemonchiffon #FFFACD
Lightblue #ADD8E6 | Lightcoral #F08080 | Lightcyan #E0FFFF
Lightgoldenrodyellow #FAFAD2 | Lightgreen #90EE90 | Lightgrey #D3D3D3
Lightpink #FFB6C1 | Lightsalmon #FFA07A | Lightseagreen #20B2AA
Lightskyblue #87CEFA | Lightslategray #778899 | Lightsteelblue #B0C4DE
Lightyellow #FFFFE0 | Lime #00FF00 | Limegreen #32CD32
Linen #FAF0E6 | Magenta #FF00FF | Maroon #800000
Mediumaquamarine #66CDAA | Mediumblue #0000CD | Mediumorchid #BA55D3
Mediumpurple #9370D8 | Mediumseagreen #3CB371 | Mediumslateblue #7B68EE
Mediumspringgreen #00FA9A | Mediumturquoise #48D1CC | Mediumvioletred #C71585
Midnightblue #191970 | Mintcream #F5FFFA | Mistyrose #FFE4E1
Moccasin #FFE4B5 | Navajowhite #FFDEAD | Navy #000080
Oldlace #FDF5E6 | Olive #808000 | Olivedrab #688E23
Orange #FFA500 | Orangered #FF4500 | Orchid #DA70D6
Palegoldenrod #EEE8AA | Palegreen #98FB98 | Paleturquoise #AFEEEE
Palevioletred #D87093 | Papayawhip #FFEFD5 | Peachpuff #FFDAB9
Peru #CD853F | Pink #FFC0CB | Plum #DDA0DD
Powderblue #B0E0E6 | Purple #800080 | Red #FF0000
Rosybrown #BC8F8F | Royalblue #4169E1 | Saddlebrown #8B4513
Salmon #FA8072 | Sandybrown #F4A460 | Seagreen #2E8B57
Seashell #FFF5EE | Sienna #A0522D | Silver #C0C0C0
Skyblue #87CEEB | Slateblue #6A5ACD | Slategray #708090
Snow #FFFAFA | Springgreen #00FF7F | Steelblue #4682B4
Tan #D2B48C | Teal #008080 | Thistle #D8BFD8
Tomato #FF6347 | Turquoise #40E0D0 | Violet #EE82EE
Wheat #F5DEB3 | White #FFFFFF | Whitesmoke #F5F5F5
Yellow #FFFF00 | YellowGreen #9ACD32 |

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


HTML in Persian, Basic Tags, Tables, Frames, Javascript, DHTML - Stock Photos

﻿
لطفا با کمک فرم زیر نظرات، انتقادات و پيشنهادات خود را نوشته و هر گونه سؤال مرتبط با وب را فقط در تالارهای مدرسه وب مطرح کنید :
نـــــــام :
آدرس ايميل :
موضوع:
فارسي English

Farsi Keyborad

راهنماي صفحه کليد فارسي

﻿

Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


تگ های اچتمل - HTML Elements, Tag Attributes

﻿
عناصر ( Elements )

يک فايل اچتمل متنی از نوع text است که از عناصر يا element ها تشکيل ميشود و برای ايجاد عناصر از تگ ها يا tags استفاده ميشود. در اين فصل با عناصر و تگ ها اچتمل آشنا خواهيد شد.

درس قبلی، درس بعدی
تگ های اچتمل (HTML Tags)
  • با کمک تگ های اچتمل عناصر و يا Elements ساخته ميشوند.
  • در زبان اچتمل حدود 80 عنصر تعريف شده است.
  • تگ های اچتمل بوسيله دو نويسه (char) > و < ساخته ميشوند.
  • تگ های اچتمل معمولا بصورت زوج ظاهر ميشوند، مانند <b>test</b>
  • تگ اول در يک زوج تگ مثلا <b> تگ شروع و تگ دوم مثلا <b/> تگ پايانی نام دارد.
  • متن بين تگ اول و تگ دوم در يک زوج تگ محتوای عنصر يا element content ناميده ميشود، مثلا "test"
  • تگ های اچتمل را ميتوانيد بوسيله حروف لاتين کوچک (lower case) و يا بزرگ (upper case) بنويسيد و case sensitive نيستند. برای مثال دو تگ <b> و <B> معادل هم هستند ولی شديدا توصيه ميشود که به خاطر سازگاری با XHTML از حروف کوچک استفاده شود.
عناصر اچتمل (HTML Elements)

مثال بخش مقدمه را در نظر بگيريد:

<html>
<head>
<title>Title of page</title>
</head>
<body>
This is my first html page. <b>This text is bold</b>
</body>
</html>

*** نمونه ای از يک عنصر اچتمل:

<b>This text is bold</b>
عنصر اچتمل بالا با تگ <b> شروع شده و با تگ <b/> پايان می يابد. محتوای اين عنصر عبارت "This text is bold" است. لازم به ذکر است که کاربرد تگ <b> نمايش توپر يا bold متون است.

*** مثال دوم از يک عنصر اچتمل :

<body>
This is my first homepage. <b>This text is bold</b>
</body>
عنصر اچتمل بالا با تگ <body> شروع شده و با تگ <body/> پايان می يابد. همانطور که ميبينيد گاهی يک عنصر حاوی يک يا چند تگ ديگر ميباشد.وظيفه تگ <body> تعيين بدنه اصلی يا body يک متن اچتمل است.لازم به يادآوری است که تنها اطلاعات بخش <body> يک فايل اچتمل در صفحه مرورگر نمايش داده خواهد شد.
شناسه های يک تگ (Tag Attributes)

تگ ها ميتوانند حاوی اطلاعات اضافی ديگر باشند، به اين اطلاعات شناسه يا Attribute ميگويند و وظيفه آنها بيان ديگر اطلاعات يک عنصر يا Element ميباشد. مثلا در مورد تگ <body> شناسه ای به نام bgcolor وجود دارد که رنگ زمينه متن (background) را تعيين ميکند برای نمونه اگر ميخواهيد که رنگ زمينه صفحه اچتملتان سياه باشد کافی است که به شکل زير عمل کنيد :

<body bgcolor="black">

در مثال زير تگ <body> دارای چهار شناسه مختلف با نامهای width، height ، align و border و مقادير center، 60، 100 و 0 ميباشد.
<table border="0" width="100" height="60" align="center" >
......
</table>

شناسه ها به صورت کلی "مقدار=نام" يا "name=value" نوشته ميشوند و هميشه به تگ شروع يک عنصر يا Element اضافه ميشوند و نهايتا اگر در يک عنصر يا Element شناسه ها قيد نشوند از مقادير قراردادی يا default آنها استفاده خواهد شد مثلا در تگ body اگر شناسه bgcolor نوشته نشود از رنگ سفيد برای زمينه صفحه استفاده خواهد شد.
مقدار يک شناسه را ميتوانيد داخل نويسه های " و يا ' بنويسيد و اختيار دست شما است فقط در مواردی که مقدار يک شناسه شامل نويسه " هم ميشود بايد از نويسه ' استفاده شود.

درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


تگ های اصلی - hr, br, h1, h6,comment, p Elements

﻿
تگ های اصلی ( Basic Tags )

تگ ها ( tags ) اجزا تشکيل دهنده عناصر يا elements های اچتمل هستند و در اين فصل با عناصر و تگ های پايه و مهم:
<hr> , <br> , <h1> .... <h6> , <!-- comment --> , <p>
آشنا خواهيد شد . يکی از بهترين روش های يادگيری تگ های اچتمل ديدن مثالها و تغيير آنها ميباشد و با کمک اديتور اختصاصی ما و با استفاده از امکانات فارسی نويسی آن به صورت آنلاين ميتوانيد به مطالعه و يادگيری مثالها پرداخته، کدهای اچتمل را تغییر داده و با کليک روی دکمه "نمايش نتايج" به مشاهده نتايج بپردازيد.

درس قبلی، درس بعدی

مثالها :

مثالی ساده از يک صفحه اچتمل
در اين مثال بسيار ساده جمله "!Hellow World" در صفحه مرور گر نمايش داده ميشود و در واقع محتوا و متن عنصر body تماما نمايش داده خواهد شد.

پاراگرافهای ساده:
چگونگی نمايش متون با کمک تگ <p> و بصورت پاراگرافی

نمايش متون فارسی:
چگونگی نمايش متون فارسی. برای جزئيات بيشتر به فصل فارسی نويسی مراجعه کنيد.

مثالهای بيشتر:

سر تيترها (Headings)
سر تيترها با کمک تگ های <h1> تا <h6> تعيين ميشوند. <h1> معرف بزرگترين سر تيتر و <h6> معرف کوچکترين سر تيتر است. مرورگر به هنگام نمايش يک سر تيتر بصورت اتوماتيک يک سطر خالی قبل و بعد از هر سر تيتر اضافه خواهد کرد.
<h1>This is a heading</h1>
<h2>This is a heading</h2>
<h3>This is a heading</h3>
<h4>This is a heading</h4>
<h5>This is a heading</h5>
<h6>This is a heading</h6>
مثال بالا در صفحه مرورگر بدين شکل نمايش داده خواهد شد.
پاراگرافها (Paragraphs)
پاراگرافها با کمک تگ <p> معرفی ميشوند.مرورگر به هنگام نمايش يک پاراگراف بصورت اتوماتيک يک سطر خالی قبل و بعد از آن اضافه خواهد کرد.
<p>This is a paragraph</p>
<p>This is another paragraph</p>
مثال بالا در صفحه مرورگر بدين شکل نمايش داده خواهد شد.

سطر جديد (Line Breaks)

برای رفتن سر سطر جديد از تگ <br> استفاده ميشود.در اينحالت يک پاراگراف جديد ايجاد نميشود. تگ <br> از نوع تگ های خالی بوده و دارای تگ انتهائی (مثلا <br/> ) نميباشد.

<p>This <br> is a para<br>graph with line breaks</p>
مثال بالا در صفحه مرورگر بدين شکل نمايش داده خواهد شد.
کامنت ها در اچتمل (Comments)

برای نوشتن شرح و توضيحات در مورد کدهای اچتمل بايد از تگ خاصی استفاده کنيد. برای اينکار بايد متن و شرحتان را درون علائم <-- و --!> قرار دهيد. مرور تگ های comment را در نظر نگرفته و محتوی آنها را نمايش نخواهد داد و فقط شرح و توضيحات برای برنامه نويس و ديگر افرادی که احتمالا در آينده با کد اچتمل کار خواهند کرد مفيد خواهد بود. (به محل نويسه "!" توجه کنيد! فقط يکی و آنهم در ابتدا)

<!-- This is a comment -->
مثالی در مورد comments و نحوه استفاده از آن
چند نکته کاربردی:

توجه داشته باشيد که بدليل وجود مرورگرهای متفاوت (اکسپلورر، نت اسکيپ، ..) و به دليل تفاوت دقت نمايش صفحه نمايش کامپيوترها، صفحات اچتمل با اندکی تفاوت در حالتهای مختلف نمايش داده ميشوند و هميشه سعی کنيد که صفحاتتان را نه تنها با اکسپلورر که معروفترين مرورگر است بلکه با نت اسکيپ و حتی مرورگرهای کامپيوترهای مکينتاش چک کرده و همچنين در دقت های نمايش 800x600 و 1024X768 آن را امتحان کنيد.

از نظر فاصله و سطر بندی، متنی که در صفحه اديتورتان تايپ ميکنيد با چيزی که مرورگر نمايش خواهد داد متفاوت خواهد بود.هميشه به ياد داشته باشيد که فاصله های اضافی (space) و خطهای خالی متن در صفحه اديتور توسط مرورگر در نظر گرفته نشده و نمايش داده نخواهد شد.

برای نمايش بيش از يک فاصله خالی بايد از نويسها يا ترکيب کاراکتری خاصی (None Breaking Space) استفاده کنيد. در بخش ( Entities ) نهادها به اين مطلب بيشتر پرداخته خواهد شد.

فاصله های اضافی بين کلمات در يک متن اچتمل توسط مرورگرها ديده نخواهد شد و در نمايش هميشه تبديل به يک فاصله (space) خواهد شد. در ضمن يک خط خالی در متن اديتور بصورت يک فاصله يا space نمايش داده خواهد شد.

برای ايجاد يک سطر جديد هيچگاه از يک تگ <p> خالی استفاده نکنيد و به جای آن از تگ <br> استفاده کنيد..

مرورگرها به هنگام نمايش بعضی عناصر بصورت اتوماتيک يک سطر خالی قبل و بعد از آن عنصر نمايش خواهند داد. برای نمونه اين گروه از عنصرها ميتوان از پاراگراف (<p>) و سرتيترها (<h..>) نام برد.

تگ <hr> يا Horizontal Roler سبب نمايش يک خط افقی خواهد شد و در واقع بخش های مختلف مطالب اين صفحات با کمک اين تگ از هم جدا شده اند.

مثالهای بيشتر:

باز هم مثال پاراگرافها
اين مثال بعضی از مقادير قراردادی عناصر پاراگراف را شرح ميدهد.

ترازبندی پاراگراف ها
اين مثال نحوه تراز بندی يک پاراگراف را با کمک شناسه يا attribute ای به نام align نشان ميدهد. در اين حالت پاراگراف در وسط ناحيه نمايش داده خواهد شد.
( "align="center )

رفتن سر سطر جديد
اين مثال نحوه استفاده از تگ <br> را در يک متن اچتمل نشان ميدهد.

سر تيترها
اين مثال نحوه استفاده از تگهای <h1> .... <h6> را در يک متن اچتمل نشان ميدهد.

ترازبندی سر تيترها
اين مثال نحوه تراز بندی يک سر تيتر را با کمک شناسه يا attribute ای به نام align نشان ميدهد. در اين حالت سر تيتر در وسط ناحيه نمايش داده خواهد شد.
( "align="center )

نمايش خطوط افقی
اين مثال نحوه نمايش خطوط افقی با استفاده از تگ <br> ميباشد.

استفاده از comment
اين مثال نحوه استفاده از comment در کدهای اچتمل را نمايش ميدهد.

تعيين رنگ زمينه صفحه
اين مثال نحوه تعيين رنگ زمينه صفحه را با کمک يکی از شناسه های (attribute ) عنصر body با نام bgcolor نشان ميدهد. (Background Color)
( "bgcolor ="blue )

تگهای اصلی
در جدول زير عناصر معرفی شده در اين فصل به همراه لينکهای مربوطه جهت مطالعه بيشتر آورده شده است. توجه داشته باشيد که برای هر عنصر فهرستی از شناسه ها يا Attributes موجود است و همچنين به شناسه های کنارگذاشته شده (Deprecated) در نسخه های آينده اچتمل توجه داشته باشيد و سعی کنيد که از آنها استفاده نکنيد.

:

Start Tag | Purpose | کاربرد
<html> | Defines a html document | نشان شروع متن اچتمل
<body> | Defines the document's body | تعيين بدنه و قسمت اصلی صفحه اچتمل
<h1>-<h6> | Defines heading 1 to heading 6 | تعريف سر تيترهای h1 تا h6
<p> | Defines a paragraph | تعريف پاراگراف
<br> | Inserts a single line break | رفتن سر خط جديد
<hr> | Defines a horizontal rule | نمايش خط افقی
<!--> | Defines a comment in the HTML source code | نوشتن شرح و comment

مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


فارسی نويسی - UFT-8 روش کدگزاری

﻿
فرمت دهی ( Formatting )

وظيفه گروهی از تگ های اچتمل فرمت دهی و تعيين شکل نمايش متون ( مثلا ضخیم یا bold بودن , مورب یا ايتاليک بودن ) ميباشد. در اين درس با اين گروه از تگهای formating آشنا خواهيد شد:

<b> , <big> , <code> , <del> , <em> , <i> , <ins> , <kbd> , <pre> , <s> , <samp> , <small> , <strike> , <strong> , <sub> , <sup> , <tt> , <u> , <var>

درس قبلی، درس بعدی

مثالهای شکل دهی متون (Text Formatting)
در مثالهای زير نحوه استفاده از عناصر و تگهای شکل دهی متون شرح داده شده اند:

شکل دهی متون
شکلهای مختلف نمايش متون با کمک عناصر b , strong , big , em , i , small , sub , sup

متون از قبل شکل دهی شده
نمايش متون از قبل شکل دهی شده با کمک عنصر pre يا pre Formatted
برای نمايش اشعار فارسی استفاده از عنصر pre بهترين انتخاب ميباشد.

عناصر ديگر شکل دهی متن
نمايش متون deleted، underline و ... با کمک عناصر code , kbd , tt , samp , var , del , ins

نحوه ديدن سورس کدهای اچتمل (HTML Source)

  • اگر ميخواهيد که سورس کدهای اچتمل صفحات وب را ببينيد کافی است که در منوی View مرورگرتان حالت Source يا Page Source را انتخاب کرده و مرورگر کد اچتمل را درون اديتوری باز کرده و قابل ذخيره توسط شما برای استفاده های بعدی ميباشد.
  • اگر صفحه مورد نظر از مجموعه فريمها (Frameset) استفاده کرده باشد برای ديدن سورس کد اصلی فريمها کافی است که ابتدا با کمک روش بالا به مشاهده سورس کدهای اچتمل پرداخته (لازم به توضيح است که در اين حالت فقط تعاريف کلی فريمها قرار دارند.) و سپس برای ديدن کد اچتمل اختصاصی هر صفحه بايد پس از "Right Click" روی هر صفحه "View Source" کرده و کد اچتمل هر فريم را جداگانه ببينيد.
  • اگر طراح سايت با کمک Java Script مانع ديدن سورس توسط شما ميشود، ابتدا در منوی Tools/Internet Options.../Security/Custom Level مرورگرهای اکسپلورر امکانات جاواسکريپت مرورگر را غير فعال کرده (disable) و سپس مراحل بالا را تکرار کنيد!!!

چند نکته کاربردی:

  1. در استفاده از Underline دقت كنيد چون در اكثر مرورگرها، پيوندها با اين خطوط نشان داده مي شوند و اين مساله ميتواند كاربران را دچار اشتباه كند .
  2. به كارگيري تگهاي EM و STRONG كه جايگزين تگهاي I و B هستند ، اين اطمينان را مي دهد كه صفحه شما توسط همه مرورگرها بصورت صحيح نمايش داده خواهد شد .
  3. به ترتيب بسته شدن تگهاي پاياني در مثال زير دقت كنيد، همان گونه كه مشاهده مي كنيد عنصر STRONG بعد از عنصر U شروع شده است ، به همين خاطر تگ خاتمه دهنده آن قبل از تگ خاتمه دهنده U قرار مي گيرد.
    <U>version <STRONG>2.0</STRONG></U>
تگهای فرمت دهی متون
Start Tag | Purpose | کاربرد
<b> | Defines bold text | نمايش توپر
<big> | Defines big text | نمايش در اندازه بزرگ
<em> | Defines emphasized text | نمايش بصورت تاکيد شده
<i> | Defines italic text | نمايش ايتاليک يا کج
<small> | Defines small text | نمايش در اندازه کوچک
<strong> | Defines strong text | نمايش قوی ؟!
<sub> | Defines subscripted text | نمايش پايين تر از خط افقی
<sup> | Defines superscripted text | نمايش بالاتر از خط افقی
<ins> | Defines inserted text | نمايش به صورت خط زير
<del> | Defines deleted text | نمايش به صورت خط خورده
<s> | Deprecated. Use <del> instead | از رده خارج
<strike> | Deprecated. Use <del> instead | از رده خارج
<u> | Deprecated. Use styles instead | از رده خارج

Start Tag | Purpose | کاربرد
<code> | Defines computer code text | نمايش کدهای برنامه نويسی
<kbd> | Defines keyboard text | نمايش متن بصورت صفحه کليدی
<samp> | Defines sample computer code | نمايش کدهای نمونه برنامه نويسی
<tt> | Defines teletype text | نمايش تله تايپ
<var> | Defines a variable | نمايش متغييرها
<pre> | Defines preformatted text | نمايش متون از قبل فرمت شده

مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


Character Entities - مدرسه وب - HTML آموزش Khaterat - Learn HTML in Persian, Farsi School

﻿
Character Entities

در استاندارد اچتمل گروهی از نويسه ها (Character) دارای معنی خاصی بوده ( مثلا نويسه < شروع يک تگ و نويسه > انتهای يک تگ را نشان ميدهد. ) و برای نمايش آنها در صفحاتتان مستقيما قابل مصرف نميباشند. در اين فصل با فهرست اين نويسه ها آشنا شده و نحوه درج آنها را با کمک Character Entities فرا خواهيد گرفت.

درس قبلی، درس بعدی

Character Entities
در اچتمل بعضی از نويسه ها دارای معنی خاصی بوده و برای نمايش آنها در صفحاتتان بايد از character entities ها استفاده کنيد. يک character entities از سه قسمت تشکيل ميشود:

1- نويسه ampersand (&)
2- نام entity يا نويسه # و سپس شماره عددی entity
3 - و نهايتا نويسه semicolon (;)
برای مثال برای نمايش نويسه > دو روش وجود دارد، بايد از &lt; يا از &#60; استفاده کنيد. در اين مثال lt نام entity و 60 شماره عددی آن ميباشد.

مزيت استفاده از نام entity در مقابل استفاده از شماره عددی آن سهولت يادآوری آن از روی نامش ميباشد و عيب آن اين است که تمامی مرورگرها نام گذاريهای موجود برای Entity ها را قبول ندارند ولی در عوض همگی شماره های عددی entity ها را بخوبی ميشناسند. توجه داشته باشيد که entity ها به کوچک و بزرگي حروف حساس هستند و در واقع Case Sensitive ميباشند.

پر کاربردترين character entity در اچتمل، نويسه فاصله يا Space يا Blank ميباشد و نام رسمی آن non-breaking space ميباشد. همانطور که ميدانيد مرورگرها فاصله های اضافی را در نظر نگرفته (truncate spaces) و مثلا از 10 نويسه فاصله، 9 تای آنرا ناديده ميگيرند و برای نمايش فاصله های اضافی بايد از &nbsp; استفاده کنيد.

فهرست پرکاربردترين Character Entities ها

Result (نمايش) | Description (شرح) | Entity Name (نام) | Entity Number (شماره عددی)
 | non-breaking space | &nbsp; | &#160;
< | less than | &lt; | &#60;
> | greater than | &gt; | &#62;
& | ampersand | &amp; | &#38;
" | quotation mark | &quot; | &#34;
' | apostrophe |  | &#39;

چند Character Entitie با کاربردهای کمتر

Result | Description | Entity Name | Entity Number
¢ | cent | &cent; | &#162;
£ | pound | &pound; | &#163;
¥ | yen | &yen; | &#165;
§ | section | &sect; | &#167;
© | copyright | &copy; | &#169;
® | registered trademark | &reg; | &#174;
× | multiplication | &times; | &#215;
÷ | division | &divide; | &#247;

برای ديدن فهرست کل character entities ها سری به اين صفحه بزنيد.

درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


پيوندهای اچتمل - HTML Links, learn html in Persian

﻿
پيوندهای اچتمل ( HTML Links )

در اين درس با پيوندها ( Links ) ، تگ های مربوطه مخصوصا تگ Anchor يا A و نحوه به کار گيری آنها آشنا خواهيد شد. همچنين شناسه های بسيار مهم href ،target و name تشريح خواهند شد.

درس قبلی، درس بعدی

در محيط وب، صفحات اچتمل با کمک پيوندها به يکديگر متصل (Link) ميشوند. اصطلاح ابرمتن (Hyper Text) در مقابل متن خطی (Linear) قرار دارد. در يک متن معمولی خواندن به شکل خطی و از ابتدا به انتها ميباشد و در مقابل در يک متن مختلط (Hyper) با کمک پيوندها ميتوان از يک متن به هر صفحه ديگر در وب متصل شد.اين کار با کمک عنصری معلوم الحال! به نام A يا Anchor ميسر ميگردد.

مثالها

ايجاد پيوندها با کمک متن
اين مثال چگونگی ايجاد يک پيوند، لينک يا Link را در يک متن اچتمل نشان ميدهد.

ايجاد پيوندها با کمک تصاوير
اين مثال چگونگی ايجاد يک پيوند، لينک يا Link را با کمک يک تصوير (image) نشان ميدهد.

مثالهای بيشتر

تگ Anchor و شناسه href

برای ايجاد پيوند به صفحات ديگر از تگ <a> استفاده ميشود. پيوندها ميتوانند به بخش ديگری از همان صفحه، صفحات ديگر وب، تصاوير، فايلهای صوتی يا حتی فيلم ها و ... اشاره کنند.
فرم کلی يک پيوند به قرار زير است:

<a href="url">Some Text</a>

در مثال بالا تگ <a> برای ايجاد پيوندی به صفحه ای ديگر که آدرس اينترنتی آن url ميباشد بکار رفته است. برای تعيين مقصد و يا آدرس صفحه جديد از شناسه ای به نام href که همان hyerlink reference ميباشد، استفاده ميشود و مقدار اين شناسه در واقع همان آدرس اينترنتی صفحه مقصد است. بخش قابل رويت پيوند و در واقع متــنــی (و يا تصويری ) که توسط مرورگر نمايش داده خواهد شد و بازديدکننده روی آن کليک خواهد کرد ميان تگهای <a> و </a> قرار داده ميشود و هر چند که در مثال بالا اين بخش متن "Some Text" است ولی ميتواند حتی يک تصوير باشد.

برای نمونه کد اچتمل زير پيوندی به سايت google.com ايجاد خواهد کرد:

<a href="http://www.google.com/">Visit Google Site</a>

و مرورگر پيوند بالا را به شکل زير نمايش داده و در اثر کليک روی پيوند توسط بازديدکننده، مرورگر به سايت Google خواهد رفت.
Visit Google Site

شناسه target در پيوندها:

با کمک شناسه target امکان تعيين مقصد پيوند جديد فراهم ميشود. در مثال بالا پس از کليک روی پيوند، مرورگر سايت google.com را باز کرده و جايگزين سایت فعلی خواهد شد. اگر ميخواهيد که مرورگر پيوند را در صفحه ای جديد باز کند بايد از شناسه target و مقدار "_blank" برای آن استفاده کنيد . مثال زير سبب باز شدن سايت google.com در پنجره جديدی خواهد شد:

<a href="http://www.google.com/" target="_blank">Visit Google Site</a>

خوتان آزمايش کنيد : Visit Google Site

شناسه Name :

با کمک شناسه name ميتوانيد پيوندها را نام گذاری کنيد.پيوندهای نامگذاری شده امکان حرکت ميان قسمتهای مختلف يک صفحه يا page را فراهم ميکنند. در اينصورت مثلا برای رفتن به آخر يک متن ديگر نيازی به Scrool down کردن تمامی صفحه نيست و کافی است که بازديدکننده روی پيوندی که به آخر صفحه اشاره ميکند کليک کند.
استفاده از پيوندهای نامگذاری شده شامل دو مرحله است:
1- ايجاد يک پيوند نامگذاری شده (اين قسمت به عنوان لنگر کار خواهد کرد.) :
فرم کلی يک پيوند نام گذاری شده به قرار زير است:

<a name="label">Text to be displayed</a>

وظيفه شناسه name تعيين نام برای پيوند است و مقدارآن همان نام پيوند ميباشد. نام پيوند هم هر نام لاتينی ميتواند باشد. در فرم کلی بالا، نام پيوند label و متنی که بعنوان پيوند نمايش داده ميشود عبارت "Text to be displayed" خواهد بود. مثال زير به ايجاد يک پيوند نامگذاری شده با نام top ميپردازد:

<a name="top">Here is top of my page!</a>

2- ايجاد يک پيوند به پيوند نامگذاری شده ديگر:

برای دادن لينک به پيوندی نام گذاری شده، کافی است که پيوندی معمولی ايجاد کرده و در قسمت href آن ابتدا url مقصد و سپس نويسه # و در نهايت نام پيوند نامگذاری شده را درج کنيد. مثال زير ايجاد پيوندی است که به لينک نامگذاری شده ای به نام top اشاره ميکند:

<a href="http://www.khaterat.com/www/index.cgi#top"> Goto Top! </a>

در اثر کليک روی پيوند بالا مرورگر مستقيما به ابتدای بخش top صفحه http://www.khaterat.com/www/index.cgi خواهد رفت.

لگر مقصد پيوند در همان صفحه قرار دارد نيازی به قيد url نيست و فقط نويسه # و سپس نام پيوند کافی است:

<a href="#top"> Goto Top! </a>
چند نکته کاربردی در مورد پيوندها:

* يکی از کاربردهای رايج پيوندهای نام گذاری شده در صفحات و متونی ميباشد که فهرست و يا ليستی از اقلام نمايش داده شده است، مانند بخش سرفصل مطالب، فهرست FAQ و يا ... در همين صفحه در دو مورد از پيوندهای نامگذاری شده استفاده شده است، آيا ميتوانيد آنها را بيابيد؟!

* اگر مرورگر نتواند يک پيوند نامگذاری شده را بيابد ابتدای صفحه مقصد را نمايش خواهد داد.

مثالهای بيشتر

باز کردن پيوند در پنجره ای جديد
اين مثال نحوه ايجاد پيوندهائی که در پنجره ای جديد باز ميشوند را نشان ميدهد. در اين حالت بازديدکنندگان سايتتان را از دست نخواهيد داد.

ارجاع به قسمت ديگری از صفحه
با کمک اين مثال نحوه تعريف پيوندهای نام گذاری شده را فراگرفته و چگونگی ارجاع به قسمتهای مختلف يک صفحه اچتمل را فرا خواهيد گرفت.

رهائی از شر فريم ها
اين مثال کاربرد شناسه target و مقدار top_ و نحوه رهائی از فريم ها را شرح خواهد داد.

نحوه ايجاد يک پيوند mailto
اين مثال نحوه ايجاد يک پيوند از نوع mailto برای باز کردن برنامه مديريت ايميل ها را نشان ميدهد. در اين حالت اگر بازديدکننده سايت برنامه های مربوط به ارسال و مديريت ايميل ها را نصب کرده باشد ميتواند به ارسال ايميل بپردازد.

مثالی کاملتر در مورد mailto
مثال از ارسال ايميل با امکان تعيين مقادير cc ، bcc، subject و body

Start Tag | Purpose | کاربرد عنصر Anchor
<a> | Defines an anchor | تعريف يک پيوند يا Anchor در يک صفحه اچتمل

Target Attributes | کاربرد حالتهای مختلف شناسه target
target="_blank" | مرورگر پيوند را در يک پنجره جديد باز ميکند.
target="_self" | مرورگر پيوند را همان پنجره باز ميکند. (حالت پيش فرض يا default)
target="_parent" | مرورگر پيوند را فريم parent باز ميکند. (کاربرد در مبحث فريمها)
target="_top" | مرورگر پيوند را در فريم مادر و اصلی باز ميکند.(روشی خوب برای نجات از شر فريمها )

برای مطالعه بيشتر در مورد شناسه target سری به اين صفحه بزنيد.

مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


فريمها در وب و اچ تی ام ال - Frames in HTML in Farsi / Persian

﻿
فريمها ( Frames )

با کمک فريمها قادر به نمايش همزمان بيش از يک صفحه وب در پنجره مرورگر خواهيد شد. در اين درس با مفاهيم فريم ( Frame ) و تگ های مربوطه مخصوصا تگهای Frame و Frameset آشنا خواهيد شد.

درس قبلی، درس بعدی
مثالها:

مجموعه فريمهای عمودی
مثالی در مورد ايجاد مجموعه فريمهای عمودی توسط تگ های frameset و frame

مجموعه فريمهای افقی
مثالی در مورد ايجاد مجموعه فريمهای افقی توسط تگ های frameset و frame

مثالهای بيشتر

فريمها (Frames)

با کمک فريمها قادر به نمايش همزمان بيش از يک صفحه وب در پنجره مرورگر خواهيد شد. هر صفحه يا دريچه، فريم (frame) ناميده شده و فريمها کاملا مستقل از هم ميباشند. محتوای هر فريم هم ميتواند هر صفحه يا وب سايتی باشد. هر چند که فريمها طراحی سايتهای کوچک و متوسط را بسيار آسان ميکنند ولی استفاده از آنها در کارهای حرفه ای توصيه نميشود.(به جز در موارد خاص)

معايب استفاده از فريمها:

  • موتورهای جستجو با صفحات طراحی شده با فريمها مشکل دارند.
  • چاپ و print صفحاتی که از فريمها استفاده ميکنند مشکل است.
  • صفحاتی که از فريمها استفاده ميکنند معمولا مبتدی بودن طراح سايت را نشان ميدهد!!
تگ فريم ست (Frameset)
  • تگ <frameset> به تعريف فريمها و تقسيم بندی پنجره مرورگر ميپردازد.
  • هر تگ <frameset> مجموعه ای از رديفها يا ستونها را تعريف ميکند.
  • داخل هر فريم ميتواند frameset ديگری قرار دهيد.
  • با کمک شناسه های rows و cols ابعاد و نسبت هر فريم تعيين ميگردد.
  • تگ <frameset> درون تگهای <html> و <html/> قرار ميگيرد.(نيازی به قيد تگ body هنگام معرفی يک frameset نيست.)
تگ فريم (Frame)
  • کاربرد اصلی تگ <frame> تعيين source يا نام صفحه ای است که بايد در فريم ها نمايش داده شود.

مثال زير مجموعه ای از فريمها را که شامل دو فريم عمودی ميباشند معرفی ميکند. از سمت چپ فريم اول 75 درصد و فريم دوم 25 درصد از عرض پنجره مرورگر را به خود نمايش خواهند داد. در ادامه تعريف محتويات هر فريم، درون فريم اول فايل "frame_left.html" و درون فريم دوم فايل "frame_right.html" نمايش داده خواهد شد.

<html>
<frameset cols="75%,25%">
   <frame src="frame_left.html">
   <frame src="frame_right.html">
</frameset>
</html>

برای نمايش مثال بالا به سه فايل نياز داريد، frame_left.html ،frame_right.html و فايل کد اچتمل بالا.

شناسه های cols و rows در تگ frameset

شناسه | مقدار شناسه | کارکرد
cols | عرض پنجره بر اساس پيکسل، درصد يا علامت * | تعيين تعداد و اندازه ستونها در فريم ست
rows | عرض پنجره بر اساس پيکسل، درصد يا علامت * | تعيين تعداد و اندازه رديفها در فريم ست

مثالهای زير را در نظر بگيريد:

مثال 2 مثال 1
<html>
<frameset cols="25%,50%,25%">
   <frame src="frame_3.html">
   <frame src="frame_2.html">
   <frame src="frame_1.html">
</frameset>
</html>

<html>
<frameset cols="*,200">
   <frame src="frame_2.html">
   <frame src="frame_1.html">
</frameset>
</html>
نمايش توسط مرورگر نمايش توسط مرورگر

در مثال يک عرض فريم اول از سمت راست 200 پيکسل تعيين شده و بقيه عرض پنجره که با علامت * مشخص ميشود به فريم دوم اختصاص خواهد يافت.
در مثال دوم عرض پنجره با مقادير درصدی به فريمها اختصاص يافته است.
در مورد شناسه rows دقيقا قراردادهای بالا برقرارند.

نکات کاربردی:

* اگر فريمهای طراحی شده مرزهای قابل مشاهده دارند توسط کاربر قابل تغيير اندازه (resize) خواهند بود و برای جلوگيری از تغيير اندازه فريمها توسط کاربر بايد از شناسه ای به نام noresize در داخل تگ <frame> استفاده شود. در اين مثال noresize نميتوانيد که فريمها را تغيير اندازه بدهيد.

* اگر ميخواهيد که فريمها scroll نشوند (بالا و پايين بردن صفحه توسط ماوس) بايد در تگ frame مقدار شناسه scrolling را برابر "no" قرار دهيد. (مقادير ممکن "yes" ، "no" و "auto" ميباشند.) در اين مثال scrolling صفحات قابل scroll نيستند.

* اگر ميخواهيد که مرز بين فريمها نمايش داده نشوند بايد در تگ frame مقدار شناسه frameborder را برابر "0" قرار دهيد. (مثال frameborder )

* درصد بسيار کمی از مرورگرها از تگهای مربوط به frame و frameset پشتيبانی نميکنند. برای اين موارد بايد از تگ <noframes> جهت نمايش صفحه جايگزين استفاده شود.

مثالهای بيشتر

مجموعه فريمهای مرکب
مثالی در مورد ايجاد مجموعه ای مرکب از فريمهای عمودی و افقی

مثالی کاربردی در مورد فريمها
در اين مثال کاربردی با کمک سه فريم امکان نمايش صفحات مختلف به آسانی فراهم ميشود. فريم افقی و بالائی سرتيتر و نام اصلی سايت را نمايش خواهد داد و فريم سمت راست لينکهای مهم صفحه را در بر گرفته و امکان navigation را فراهم ميسازد و نهايتا فريم اصلی و سمت چپ صفحات مختلف سايت را به نمايش خواهد گذاشت. توجه داشته باشيد که برای اين مثال حداقل به يک فايل برای معرفی مجموعا فريمها(frameset) و سه صفحه اچتمل برای فريمهای بالائی، سمت چپ و راست احتياج خواهد بود.

فريمهای شناور و يا درجا (Inline frame)
مثالی در مورد فريمهای شناور و درجا (iframe)، فريمی درون يک صفحه اچتمل

مثالی کاربردی در مورد فريمهای درجا (Inline frame)
مثالی کاربردی در مورد فريمهای شناور و درجا (iframe) با کمک 7 صفحه اچتمل مختلف

شوخی با فريم های شناور
مثالی در مورد نمايش درايو لوکال (مثلا c:\ بازديدکنندگان سايت به آنها

فريمها و پيوندهای نامگذاری شده
مثالی کامل در مورد فريمها و پيوندهای نامگذاری شده و نحوه استفاده از آنها در طراحی سايتی ساده متشکل از چهار فايل اچتمل

فريمها و پيوندهای نامگذاری شده کامل
همان مثال بالا در صفحه کامل مرورگر با شناسه های کامل در تگ frame

تگ های فريم

Start Tag | Purpose | کاربرد
<frameset> | Defines a set of frames | تعريف مجموعه ای از فريم ها
<frame> | Defines a sub window (a frame) | تعريف يک فريم
<noframes> | Defines a noframe section for browsers that do not handle frames | تعريف جايگزين برای مرورگرهائي که از فريم ها پشتيبانی نميکنند.
<iframe> | Defines an inline sub window (frame) | تعريف فريم های درجا (inline)

مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


جداول يا آرايه ها در وب و اچ تی ام ال - HTML Tables in farsi / Persian

﻿
جداول ( Tables)

در اين درس با المان جدول ( Table ) ، سلولها يا خانه ها، مرز و border در جداول و تگ های مربوطه مخصوصا تگهای TABLE ، TD , TR آشنا خواهيد شد. توجه داشته باشید که جداول یکی از مهمترین المانهای آرایش و layout میباشند.

درس قبلی، درس بعدی

مثالها:

جداول، آرايه ها
مثال ساده ای برای ايجاد جداول

مرز جداول
نقش شناسه border در تعيين مرز جداول

مثالهای بيشتر

جدولها

برای تعريف جداول از تگ <table> استفاده ميشود. يک جدول از يک يا چند سطر که با کمک تگ <tr> تعريف ميشوند، تشکيل ميشود. هر رديف يا row از يک يا چند سلول، خانه يا cell تشکيل گرديده که با کمک تگ <td> ايجاد ميشوند. نام های td و tr به ترتيب خلاصه شده table row و table data ميباشند.
محتوی يک سلول ميتواند متن، تصوير، فهرستها، جداول ديگر، پاراگرافها و ... باشد.

مثال زير جدولی است با دو سطر و سه ستون :

کد اچتمل جدولی با دو سطر و سه ستون نمايش جدول روبرو توسط مرورگر
<table border="1" dir="rtl">
<tr>
<td>رديف 1، سلول 1</td>
<td>رديف 1، سلول 2</td>
<td>رديف 1، سلول 3</td>
</tr>
<tr>
<td>رديف 2، سلول 1</td>
<td>رديف 2، سلول 2</td>
<td>رديف 2، سلول 3</td>
</tr>
</table>

رديف 1، سلول 1 | رديف 1، سلول 2 | رديف 1، سلول 3
رديف 2، سلول 1 | رديف 2، سلول 2 | رديف 2، سلول 3

جدولها و شناسه border و dir :

  • در مثال بالا شناسه border مرز جدول را مشخص ميکند، مقدار 1 مرزی با ضخامت يک پيکسل را نمايش خواهد داد و مقدار صفر جدول را بدون مرز نمايش خواهد داد. توجه داشته باشيد که حالت پيش فرض يعنی جدولی بدون شناسه border ، جداول بدون مرز را نمايش خواهد داد.
  • در مثال بالا شناسه dir يا direction و مقدار rtl برای آن، سبب تعيين نمايش جهت متون از راست به چپ خواهد شد و چو ن در داخل تک table تعريف شده است به تمامی سلولهای جدول اعمال خواهذ شد.
  • ساده ترين جدول ممکن در اچتمل، جدولی است با يک سطر و يک ستون!

    سرستون در جداول (Headings)

    سرستونها در جداول با کمک تگ <th> تعريف ميشوند. مثال زير نحوه تعريف سرستونها را در جداول نمايش ميدهد:

    • کد اچتمل جدولی با سه سطر و سه ستون نمايش جدول روبرو توسط مرورگر
    <table border="1" dir="rtl">
<tr>
<th>سرستون ا</th>
<th>سرستون 2</th>
<th>سرستون 3</th>
</tr>
<tr>
<td>رديف 1، سلول 1</td>
<td>رديف 1، سلول 2</td>
<td>رديف 1، سلول 3</td>
</tr>
<tr>
<td>رديف 2، سلول 1</td>
<td>رديف 2، سلول 2</td>
<td>رديف 2، سلول 3</td>
</tr>
</table>

    سرستون ا | سرستون 2 | سرستون 3
رديف 1، سلول 1 | رديف 1، سلول 2 | رديف 1، سلول 3
رديف 2، سلول 1 | رديف 2، سلول 2 | رديف 2، سلول 3

    همانطوريکه مشاهده ميکنيد سر ستونها مانند سلولهای معمولی جداول تعريف ميشوند و فقط به جای td از th استفاده شده و لی در نمايش محتوای سر ستونها bold يا توپر نمايش داده خواهند شد.

    خانه های خالی در جداول (Empty Cells)

    اگر محتوای خانه ای از يک جدول خالی باشد چه چيزی بايد نمايش داده شود؟ بسته به مرورگری که استفاده ميکنيد نتيجه نمايش متفاوت است و مثلا در مثال زير خانه خالی جدول بدون مرز نمايش داده خواهد شد:

    کد اچتمل جدولی با دو سطر و دو ستون نمايش جدول روبرو توسط مرورگر
    <table border="1" dir="rtl">
<tr>
<td>رديف 1، سلول 1</td>
<td>رديف 1، سلول 2</td>
</tr>
<tr>
<td>رديف 2، سلول 1</td>
<td></td>
</tr>
</table>

    رديف 1، سلول 1 | رديف 1، سلول 2
رديف 2، سلول 1 |

    در اينگونه موارد برای رفع مشکل کافی است که از non-breaking space (&nbsp;) يا همان نويسه و کاراکتر قاصله و بلانک استفاده شود و در مورد مثال ذکر شده مرورگر جدول را به شکل زير نمايش خواهد داد:

    کد اچتمل جدولی با دو سطر و دو ستون نمايش جدول روبرو توسط مرورگر
    <table border="1" dir="rtl">
<tr>
<td>رديف 1، سلول 1</td>
<td>رديف 1، سلول 2</td>
</tr>
<tr>
<td>رديف 2، سلول 1</td>
<td>&nbsp;</td>
</tr>
</table>

    رديف 1، سلول 1 | رديف 1، سلول 2
رديف 2، سلول 1 |

    توجه داشته باشيد که اينبار مرزهای خانه خالی جدول بدرستی ترسيم گرديده اند.

    چند نکته اساسی در مورد جداول:

  • در جداول، رديفها، خانه ها و سر ستونها از تعداد زيادی از شناسه ها ميتوانيد استفاده کنيد که شرح همگی آنها از حوصله اين دوره مقدماتی خارج است و توصيه ميشود که از مثالهای زير و جدول واقع در انتهای اين صفحه برای مطالعه هر چه بيشتر در مورد جزئيات شناسه ها استفاده شود.
  • شناسه dir قابل استفاده در بسياری از تگها ( مثلا table ، tr ، td ، th ) ميباشد. با کمک شناسه dir و مقدار rtl برای آن، جهت نمايش متون فارسی از "راست به چپ" تعيين ميگردد. توجه داشته باشيد که مقدار شناسه dir به صورت موروثی از table به tr و th و از tr و th به td خواهد رسيد.مثلا برای تعيين مقدار rtl برای تمامی خانه های يک جدول کافی است که فقط شناسه مزبور را در تگ table قيد کنيد و نيازی به قيد آن در تمامی خانه های جدول نيست. البته ميتوانيد که در مورد يک رديف خاص و يا يک خانه خاص شناسه dir را موردی تعيين کنيد.

    مثالهای بيشتر

    مرز در جداول
    اين مثال کاربرد شناسه border را در نمايش جداول نشان ميدهد.

    تعيين جهت نمايش متن در خانه های يک جدول
    اين مثال کاربرد شناسه dir است در تعيين جهت نمايش متن در خانه های يک جدول.

    عنوان جداول و تگ caption
    مثالی در مورد تگ caption در تعريف جداول

    توسعه سطری يا ستونی در جداول
    مثالی در مورد شناسه های colspan و rowspan در جداول

    جدولی با محتويات مختلف
    محتوی يک خانه جدول تقريبا ميتواند هر عنصر اچتملی باشد.

    فاصله گذاری بين خانه های جداول
    اين مثال نحوه ايجاد فاصله بين خانه های جدول را نشان ميدهد.(cellspacing)

    لايه گذاری خانه های جدول
    اين مثال نحوه ايجاد فاصله خالی بين خانه های جدول و مرز آنها را نشان ميدهد.(cellpadding)

    تعيين رنگ زمينه يا تصوير زمينه کل يک جدول
    تعيين رنگ زمينه يا تصوير زمينه سراسری جداول با کمک شناسه های bgcolor و background

    تعيين رنگ زمينه يا تصوير زمينه يک يا چند خانه از جدول
    تعيين رنگ زمينه يا تصوير زمينه در خانه های جداول با کمک شناسه های bgcolor و background

    تراز بندی محتوا در خانه های جداول
    اين مثال نحوه ترازبندی محتوای خانه های جداول با کمک شناسه "align" را نشان ميدهد.

    شناسه frame در جداول
    مثالی در مورد کاربرد شناسه "frame" در المان table جهت تعيين شکل مرز جداول.

    تراز بندی محتوا در خانه های جداول
    اين مثال نحوه ترازبندی محتوای خانه های جداول با کمک شناسه "align" و "valign" را نشان ميدهد.

    • تگهای جداول

    Start Tag | Purpose | کاربرد
<table> | Defines a table | تعريف جدول
<th> | Defines a table header | تعريف سرستون در جداول
<tr> | Defines a table row | تعريف رديف ها در جداول
<td> | Defines a table cell | تعريف سلول يا خانه های يک جدول
<caption> | Defines a table caption | تعريف عنوان جدول

    مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

    درس قبلی، درس بعدی

    ^^ بالای صفحه ^^

    ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


فهرستها در اينترنت و وب - Lists in HTML in Persian . Farsi

﻿
فهرستها ( Lists )

اين درس شما را با نحوه نمايش انواع فهرستها شامل فهرستهای مرتب(ordered) ، نامرتب(unordered) و فهرستهای تعريفی(definition lists) و تگ های مربوطه يعنی li ، ol ، ul ، dl ، dt و dd آشنا خواهد کرد.

درس قبلی، درس بعدی
مثالها:

فهرستهای نامرتب
مثالی بسيار ساده در مورد فهرستهای نامرتب

فهرستهای مرتب
مثالی در مورد فهرستهای مرتب و نحوه نمايش متون فارسی

مثالهای بيشتر

فهرستهای نامرتب(unordered list)

فهرستهائی هستند از يک يا چند قلم اطلاعات که معمولا با دايرهای کوچک و سياه رنگ در شروع نمايش داده ميشوند. يک فهرست از نوع نامرتب با تگ <ul> شروع شده و هر رقم اطلاعات با تگ <li> مشخص ميگردد.

HTML code نمايش توسط مرورگر
<ul>
<li>Red</li>
<li>Blue</li>
<li>Green</li>
</ul>
  • Red
  • Blue
  • Green

<ul dir="rtl" >
<li>قهوه</li>
<li>شير</li>
<li>چای</li>
</ul>
  • قهوه
  • شير
  • چای

داخل تگهای <li> ميتوانيد از پاراگرافها، تگهای br ، تصاوير و حتي فهرستهای ديگر استفاده کنيد. به شناسه dir در مثال بالا توجه کنيد، امکان تعيين سمت و جهت نمايش متون در تمامی تگهای مربوط به فهرستها ممکن ميباشد.

فهرستهای مرتب(ordered list)

اين نوع فهرست بسيار شبيه فهرستهای نامرتب بوده و فقط مرورگر به هنگام نمايش اقلام اطلاعاتی از اعداد به جای دايره های کوچک سياه رنگ استفاده ميکند. يک فهرست از نوع مرتب با تگ <ol> شروع شده و همانند فهرستهای نامرتب هر رقم اطلاعات با تگ <li> مشخص ميگردد.

HTML code نمايش توسط مرورگر
<ol>
<li>Red</li>
<li>Blue</li>
<li>Green</li>
</ol>
  1. Red
  2. Blue
  3. Green

<ol dir="rtl" >
<li>قهوه</li>
<li>شير</li>
<li>چای</li>
</ol>
  1. قهوه
  2. شير
  3. چای

داخل تگهای <li> ميتوانيد از پاراگرافها، تگهای br ، تصاوير و حتي فهرستهای ديگر استفاده کنيد. به شناسه dir در مثال بالا توجه کنيد، امکان تعيين سمت و جهت نمايش متون در تمامی تگهای مربوط به فهرستها ممکن ميباشد.

فهرستهای تعريفی(definition list)

فهرست تعريفی فهرستی است از اصطلاح ها و تشريح و توصيف آنها.

فهرستهای تعريفی با <dl> شروع شده و هر ذوج اصطلاح و تعريف مربوط به آن با تگهای <dt> و <dd> تعريف ميشوند.

HTML code نمايش توسط مرورگر
<dl>
<dt>HTTP</dt>
<dd>Hypertext Transfer Protocol</dd>
<dt>FTP</dt>
<dd>File Transfer Protocol</dd>
<dt>IP</dt>
<dd>Internet Protocol</dd>
</dl>
HTTP
Hypertext Transfer Protocol
FTP
File Transfer Protocol
IP
Internet Protocol

<dl dir="rtl"  >
<dt >مقدمه</dt>
<dd>خلاصه ای از مقدمه</dd>
<dt>فصل 2</dt>
<dd>خلاصه ای از فصل 1</dd>
<dt>فصل 2</dt>
<dd>خلاصه ای از فصل 2</dd>
</dl>
مقدمه
خلاصه ای از مقدمه
فصل 1
خلاصه ای از فصل 1
فصل 2
خلاصه ای از فصل 2

داخل تگهای تشريح يعنی <dd> ميتوانيد از پاراگرافها، تگهای br ، تصاوير و حتي فهرستهای ديگر استفاده کنيد. به شناسه dir در مثال بالا توجه کنيد، امکان تعيين سمت و جهت نمايش متون در تمامی تگهای مربوط به فهرستها ممکن ميباشد.

مثالهای بيشتر

انواع فهرستهای مرتب
مثالی در مورد فهرستهای مرتب به همراه استفاده از شناسه type جهت تعيين نوع نمايش فهرست

انواع فهرستهای نامرتب
مثالی در مورد فهرستهای نامرتب به همراه استفاده از شناسه type جهت تعيين نوع نمايش فهرست

فهرستهای تودرتو
مثالی در مورد فهرستهای ترکيبی. اعضای فهرست ميتوانند از فهرستهای ديگر تشکيل شوند.

فهرستهای تعريفی
مثالی در مورد فهرستهای تعريفی به همراه استفاده از شناسه dir

تگهای فهرست

Start Tag | Purpose | کاربرد
<ol> | Defines an ordered list | تعريف فهرستهای مرتب
<ul> | Defines an unordered list | تعريف فهرستهای نامرتب
<li> | Defines a list item | تعريف يک آيتم و قلم از يک فهرست
<dl> | Defines a definition list | تعريف فهرستهای تعريفی
<dt> | Defines a definition term | تعريف اصطلاح در فهرستهای تعريفی
<dd> | Defines a definition description | تعريف معنی و شرح اصطلاح در فهرستهای تعريفی

مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


فرمها در اينترنت و اچتمل - Text Fields, Input , Forms, Radio Buttons, Checkboxes, Submit, action

﻿
فرمها ( Forms )

از طريق استفاده از عنصر <form> و چند تگ مرتبط قادر به دريافت اطلاعات از بازديدکنندگان صفحاتتان و يا تبادل اطلاعات بين صفحات مختلف خواهيد شد. با کمک اين گروه از تگ ها قادر به نمايش باکسهای ورود اطلاعات متن (text fields) ، چک باکسها (check-boxes) ، راديو باتونها (radio-buttons) و ... شده و همچنين امکان گذاشتن دکمه های ارسال (submit button) و يا حذف (reset) را خواهيد داشت. اين فصل با شرح تگ های form و input و ... به چگونگی ايجاد ارتباط با بازديدکنندگان و گرفتن اطلاعات از آنها بصورت لاتين و يا فارسی خواهد پرداخت.

توجه داشته باشيد که برای پردازش اطلاعات دريافتی از کاربر بايد با يکی از زبانهای cgi از قبيل ASP، perl، PHP، CFM ، JSP يا Java آشنائی داشته باشيد. مثالهای cgi مدرسه وب از ربان اسکريپت Perl استفاده ميکنند.

درس قبلی، درس بعدی
مثالها:

وروديهای متن يا Text fields
مثالی ساده در مورد ايجاد text field ها . با کمک text field ها کاربران قادر به وارد کردن و تايپ متن خواهند شد.

وروديهای رمز عبور يا Password fields

مثالی ساده در مورد ايجاد password field ها . با کمک password field ها کاربران قادر به ورود رمز عبور يا پسورد خواهند شد.

مثالهای بيشتر

فرمها (Forms)

تمامی عناصر و تگهائی که تاکنون ديده ايد فقط به نمايش اطلاعات پرداخته اند و هيچکدام به گرفتن و اخذ اطلاعات از کاربر نپرداخته اند. فرمها که با تگ <form> معرفی ميشوند، طراح سايت را قادر به جمع آوری و اخذ اطلاعات از بازديدکننده سايت خواهند کرد. عنصر فرم و گروهی از عناصر و تگهای درون آن به دريافت و ارسال اطلاعات به سمت وب سرور کمک خواهند کرد و لازم به ذکر است که تمامی تگهای مربوط به فرمها بايد درون تگهای <form> و <form/> قرار ميگيرند.

درون تگ فرم گروه زيادی از عناصر و تگهای مختلف قابل استفاده هستند از قبيل عناصر ورود متن يک سطری(text fields)، عناصر ورود متنهای چند سطری (Textarea)، منوهای drop-down و radio buttons و ...

تگ Input

به عنوان پر مصرف ترين تگ مربوط به ورود اطلاعات بايد از تگ <input> نام برد. در اين تگ شناسه ای به نام type به تعيين نوع اطلاعات ورودی اختصاص دارد. مقادير ممکن برای اين شناسه به قرار زيرند:
text , checkbox , radio , password , hidden , submit , reset , button , file , image
در ادامه به شرح بعضی از type های کاربردی خواهيم پرداخت:

وروديهای متن (Text Fields)

اگر ميخواهيد که بازديدکننده اطلاعاتی از قبيل متن، اعداد و ... را وارد کند از شناسه ای با مقدار "text" استفاده ميشود.

کد اچتمل نمايش توسط مرورگر
<form>
First name:
<input type="text" name="firstname">
<br>
Last name:
<input type="text" name="lastname">
</form>
First name:
Last name:
<form dir="rtl" >
نـــــــــــــــام:
<input type="text" name="firstname">
<br>
نام خانوادگی:
<input type="text" name="lastname">
</form>
نـــــــــــــــام:
نام خانوادگی:

توجه داشته باشيد که تگ <form> چيزی را به نمايش نخواهد گذاشت بلکه تگهای درون آن توسط مرورگر نمايش داده خواهند شد. در مثال فارسی بالا به شناسه dir و مقدار rtl آن توجه داشته باشيد.لازم به يادآوری است که اغلب مرورگرها در حالت پيش فرض برای وروديهای متن اندازه 20 کاراکتر را در نظر ميگيرند و اگر ميخواهيد که اندازه پيش فرض وروديهای متن را تغيير دهيد بايد از شناسه ای به نام size استفاده کنيد.

وروديهای Radio Buttons

اگر ميخواهيد که بازديدکننده گزينه ای را از بين چند گزينه محدود انتخاب کند، از مقدار "radio" برای شناسه type استفاده کنيد:

کد اچتمل نمايش توسط مرورگر
<form>
<input type="radio" name="sex" value="male"> Male
<br>
<input type="radio" name="sex" value="female"> Female
</form>
Male
Female
<form dir="rtl">
<input type="radio" name="sex" value="male"> مرد
<br>
<input type="radio" name="sex" value="female"> زن
</form>
مرد
زن

همانطور که مشاهده ميشود فقط امکان يکی از گزينه ها برای کاربر ميسر است.

وروديهای Checkboxes

اگر ميخواهيد که بازديدکننده يک يا چند گزينه را از بين چند گزينه محدود انتخاب کند، از مقدار "checkbox" برای شناسه type استفاده کنيد:

کد اچتمل نمايش توسط مرورگر
<form>
<input type="checkbox" name="bike">
I have a bike
<br>
<input type="checkbox" name="car">
I have a car
</form>
I have a bike
I have a car
<form dir="rtl">
<input type="checkbox" name="bike">
دوچرخه دارم
<br>
<input type="checkbox" name="car">
ماشين دارم
</form>
دوچرخه دارم
ماشين دارم
شناسه Action و دکمه Submit در فرمها ( Form's Action Attribute & Submit Button)

در فرمها برای ارسال اطلاعات کسب شده از دکمه ای به نام ارسال يا Submit Button استفاده ميشود و در اثر کليک کاربر بروی اين دکمه "Submit" ، اطلاعات درون فرم به فايلی ديگر ارسال خواهند شد. برای تعيين مقصد ارسال اطلاعات بايد درون تگ form از شناسه ای به نام action استفاده کنيد. مقدار شناسه action آدرس يا url فايلی است که به دريافت و سپس پردازش اطلاعات دريافتی خواهد پرداخت. معمولا فايلهای بخش action برنامه ها و اسکريپت هائی نوشته شده با ربانهای cgi مانند ASP، Perl ، PHP و ... بوده و وظيفه آنها دريافت اطلاعات فرمها و سپس پردازش آنها ميباشد.

تعيين مقدار "submit" برای شناسه type سبب نمايش دکمه Submit يا ارسال خواهد گرديد.

کد اچتمل نمايش توسط مرورگر
<form name="input" action="form_action.cgi">
Username:
<input type="text" name="user">
<input type="submit" value="Submit">
</form>
Username:
<form name="input" action="form_action.cgi" dir="rtl">
نام کاربر
<input type="text" name="user">
<input type="submit" value="Submit">
</form>
نام کاربر

در مثال بالا در باکس ورودی متن، کلمه ای را وارد کرده و دکمه ارسال را کليک کنيد. مرورگر به محض کليک دکمه ارسال، اطلاعات درون فرم را که در اين مثال متنی ساده است به سمت فايلی که در شناسه action تعيين شده است ارسال کرده و در اين مثال برنامه ای به زبان Perl با نام form_action.cgi در سمت سرور به ذخيره و سپس نمايش متنی خبری خواهد پرداخت.

ورود متن فارسی در عناصری مانند Text field يا Text area:

همانطور که در مثالهای بالا مشاهده کردید در مورد المانهای Text field و Textarea با کمک شناسه dir میتوان سمت و جهت ورود اطلاعات را "از راست به چپ" تعیین کنید. ولی اگر کاربری ویندوز فارسی نداشته باشد، از کامپیوترهای مکینتاش استفاده کند و یا سیستمش را فارسی نکرده باشد قادر به ورود اطلاعات به زبان فارسی نخواهد بود و نویسه های تایپ شده لاتین خواهند بود!، در اینگونه موارد چه باید کرد؟
معمولا برنامه نویسان وب برای فراهم ساختن امکان ورود متن فارسی از یکی از دو روش زیر استفاده میکنند:
  • استفاده از اپلتهای جاوا با این مزیت که سورس و کد اصلی فارسی سازی قابل استفاده توسط دیگران نیست!!
  • استفاده از زبان جاوا اسکریپت و با این عیب که سورس و کد اصلی JavaScript قابل مشاهده و استفاده توسط دیگران است!

    مدرسه وب بر اساس دستورالعملهای "پروژه فارسی وب" از روش دوم استفاده کرده و از کد جاوا اسکریپت فراهم شده توسط این پروژه استفاده ميکند. مثال زير نحوه استفاده از کد فارسی ساز جاوا اسکریپتی مذکور را شرح خواهد داد:

    فارسی ساز جاوا اسکریپتی
    مثالی در مورد نحوه استفاده از فارسی ساز جاوا اسکریپتی در یک فرم متشکل از Textfield ها

    مثالهای بيشتر

    حالتهای مختلف ورودی Input
    در تگ input و با کمک شناسه type و مقادير مختلف برای آن ميتوان انواع مختلف اطلاعات را از وبگرد گرفت.

    Checkboxes
    مثالی در مورد نحوه تعريف فرمی متشکل از Checkbox ها

    Radiobuttons
    مثالی در مورد نحوه تعريف فرمی متشکل از Radiobutton ها

    فهرست کرکره ای ساده
    مثالی در مورد نحوه تعريف فرمی متشکل از drop down box ها

    فهرست کرکره ای ديگر
    مثالی در مورد نحوه تعريف فرمی متشکل از drop down box ها با تعيين پيش گزينه

    Textarea
    مثالی در مورد نحوه تعريف فرمی متشکل از Textarea ، ناحيه ای برای ورود بيش از يک سطر متن (نکته: استفاده از اديتور ما برای اين مثال امکان پذير نيست! اگر گفتيد چرا!؟)

    تعريف فرمی با کمک دکمه يا button
    مثالی در مورد نحوه تعريف فرمی با کمک دکمه يا button

    ترسيم مرز در اطراف فرم
    مثالی در مورد نحوه تعريف فرمی دلخواه و ترسيم مرزی بدور آن به همراه تعيين عنوانی برای فرم با کمک عنصر Fieldset

    ارسال ايميل با کمک فرمها
    مثالی در مورد نحوه ارسال ايميل با کمک فرمها

    ساختن فهرستی از سايتهای مورد علاقه
    مثالی در مورد نحوه استفاده از تگ فرم و منوهای کرکره ای و کمی جاوا اسکريپت برای ساخت فهرستی از سايتها

    • تگهای فرم

    Start Tag | Purpose | کاربرد
<form> | Defines a form for user input | تعريف فرم ورود اطلاعات
<input> | Defines an input field | تعريف ورودی از نوع Input
<textarea> | Defines a text-area (a multi-line text input control) | تعريف ورودی متن چند سطری يا text-area
<label> | Defines a label to a control | تعريف برچسب يا label
<fieldset> | Defines a fieldset | تعريف fieldset
<legend> | Defines a caption for a fieldset | تعريف عنوان برای fieldset ها
<select> | Defines a selectable list (a drop-down box) | تعريف فهرستهای انتخابی يا drop-down box
<optgroup> | Defines an option group | تعريف option group ها
<option> | Defines an option in the drop-down box | تعريف گزينه ای از drop-down box ها
<button> | Defines a push button | تعريف دکمه فشاری، متفاوت با button تگ input

    مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

    درس قبلی، درس بعدی

    ^^ بالای صفحه ^^

    ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


تصاوير در اينترنت و اچتمل - Images / IMG TAG in HTML in Persian / Farsi

﻿
تصاوير ( Images )

در اين درس با تگ img ، شناسه src و alt ، تگهای Map و Area و چگونگی نمايش تصاوير و همچنين تنظيم محل آنها در سندهای اچتمل آشنا خواهيد شد.

درس قبلی، درس بعدی
مثالها:

درج تصوير
نحوه درج تصاوير با کمک تگ img

درج تصويری واقع در فضای آدرسی ديگر
درج تصويری واقع در دايرکتوريی غير از آدر س صفحه اچتمل و يا تصويری واقع در فضای آدرسی ديگر سايتها

مثالهای بيشتر

تگ img و شناسه src يا source

در زبان اچتمل تصاوير را با کمک تگ <img> تعريف ميکنند. تگ <img> از نوع تگهای خالی است، بدين معنا که فقط دارای يک يا چند شناسه و attribute بوده و دارای تگ انتهائی يا <img/> نيست.

مهمترين شناسه برای درج و تعريف يک تصوير src يا source نام دارد و مقدار اين شناسه آدرس يا URL تصوير ميباشد. تصاويری که مرورگر در يک صفحه وب نمايش ميدهد ميتوانند در همان دايرکتوری صفحه اچتمل، در ديگر دايرکتوريهای همان سايت و يا در فضای بيکران وب قرار داشته باشند.

شکل ساده درج يک تصوير:

<img src="url">

مقدار url آدرس اينترنتی تصوير ميباشد و مثلا اگر تصويری که قرار است که در صفحه درج شود در همان دايرکتوری قرار دارد و نامش me.jpg ، کافی است که به جای url فقط نام تصوير يعنی me.jpg را بنويسيد و اگر تصوير در سايتی ديکر قرار دارد url کامل آنرا بنويسيد. مثلا تصوير لوگو سايت google.com دارای url ی برابر http://www.google.com/images/logo.gif است.در اين url نام تصوير logo.gif بوده، در دايرکتوری images قرار داشته و روی وب سايت google.com قرار دارد.

شناسه های width و height در تگ img

کاربرد شناسه های width و height تعيين عرض و ارتفاع نمايش تصوير است. اگر از اين شناسه ها استفاده نکنيد، مرورگر ابتدا تصوير را لود کرده و سپس طول و عرض آنرا يافته و در نهايت نمايش ميدهد. با نوشتن مقاديری غير از مقادير واقعی طول و عرض تصوير ميتوانيد به تغيير شکل و ابعاد آن بپردازيد و آنرا مثلا کوچکتر، بزرگتر و يا کشيده تر نمايش دهيد. مثال زير نحوه درج تصويری را با قيد ابعاد آن شرح ميدهد:

<img src="http://www.google.com/images/logo.gif" width="276" height="110" >

توصيه ميشود که حتما ابعاد تصوير را با کمک شناسه های width و height قيد کنيد، اينکار سبب کمک به مرورگر در تسريع شروع نمايش صفحه خواهد شد.(در واقع با قيد ابعاد تصوير، مرورگر قبل از لود تصوير ميداند که چه مقدار از صفحه نمايش بايد به تصوير بايد اختصاص داده شود و قبل از لوذ شدن تمامی تصاوير مرورگر شروع به نمايش قالب و چارچوب کلی صفحه خواهد کرد.)

شناسه Alt يا "alternate text" يا متن جايگزين

اگر مرورگر به هر دليلی نتواند که يک تصوير را نمايش دهد و يا مرورگر از نوع مرورگرهائی باشد که فقط متن را نمايش ميدهند، متن و text ی که با کمک شناسه alt تعيين شده است نمايش داده خواهد شد. همچنين در اغلب مرورگرها با قرارگرفتن ماوس بروی يک تصوير، متن تعيين شده توسط شناسه alt نمايش داده خواهد شد. با کمک alt اطلاعات اضافی مربوط به تصوير قابل نمايش ميباشد.مثال زير نحوه درج تصويری را با قيد متن جايگزين آن شرح ميدهد:

<img src="images/madresehweb_88_31.jpg" alt="The web school!" >

The Web School!

وبلاگها و اضافه کردن تصاویر:
اگر وبلاگی داشته و میخواهید که تصویری به آن اضافه کنید دو حالت مختلف ممکن است که پیش آید:
  • الف) تصویر روی سایتی دیگر قرار داشته و شما هم میخواهید از آن تصویر که در سایتی دیگر قرار دارد استفاده کنید. در این حالت از آدرس مستقیم تصویر در شناسه src استفاده کنید، مانند :
    <img src="http://www.google.ca/images/hp0.gif" width=258 height=78 >
    در این مثال تصویر روی سایت google.ca قرار داشته و لزومی به ذخیره آن توسط شما نیست.

  • ب) تصویر روی هارد کامییوتر شما است و هنوز بروی وب منتقل نشده است. در این حالت چون اغلب سیستم های وبلاگ امکان ذخیره تصاویر را به شما نمی دهند باید ابتدا تصویرتان را با کمک FTP یا روشهای دیگر به روی سایتی دیگر منتقل کنید. شرکتهای مختلفی فضای مجانی برای ساخت صفحات وب و ذخیره اطلاعات و تصاویر در اختیار شما قرار میدهند و در یکی از سؤالهای این FAQ فهرست این شرکتها را میتوانید ببینید. بنابراین ابتدا فضائی در وب تهیه کرده، سپس تصویرتان را Upload کرده (با کمک FTP یا روشهاس دیگر ) و سپس در شناسه src از تگ img آدرس جدید تصویر را قید کنید.

    چند نکته مهم:

    • اگر در يک صفحه اچتمل از 10 تصوير استفاده شده باشد، مرورگر بايد 11 فايل را لود کند.( خود صفحه به علاوه 10 تصوير)
    • استفاده از تصاوير، سرعت لود شدن صفحات را پايين می آورد.با احتياط از تصاوير استفاده کنيد و به اندازه و حجم تصوير توجه داشته باشيد.
    • لود تصويری با حجم 50 کيلوبايت برای کسی که از مودمی با سرعت 28kbps استفاده ميکند حداقل 15 ثانيه طول خواهد کشيد.
    • برای ديدن مشخصات تصاوير در وب کافی است که روی تصوير Right click کرذه و سپس در بخش properities آدرس،ابعاد و ظرفيت تصوير را ببينيد.
    • برای ذخيره تصاوير در وب کافی است که روی تصوير Right click کرذه و سپس در بخش "Save picture as" آنرا ذخيره کنيد.
    مثالهای بيشتر

    تصاوير زمينه
    مثالی در مورد نحوه تعيين تصاوير زمينه با کمک شناسه background در تگ body

    ترازبندی تصاوير
    اين مثال نحوه ترازبندی تصاوير در کنار متون را نشان ميدهد.

    تصاوير شناور در متن
    آزاد گذاشتن تصوير در سمت چپ يا راست

    نمايش تصاوير در ابعاد مختلف
    مثالی در مورد استفاده از شناسه های width و height و نمايش تصاوير در ابعاد مختلف

    نمايش متن جايگزين برای تصاوير
    مثالی در مورد استفاده از شناسه alt

    استفاده از تصاوير هنگام ايجاد پيوند ها
    مثالی در مورد نحوه استفاده از تصاوير هنگام ايجاد پيوند ها

    ايجاد image map ها
    مثالی در مورد ايجاد image map . در اين مثال هر بخش از نواحی تعريف شده قابل کليک بوده و به پيوندی اختصاصی اشاره ميکند.

    • تگ های تصاوير

    Start Tag | Purpose | کاربرد
<img> | Defines an image | درج تصوير
<map> | Defines an image map | تعريف Image map يا ؟؟؟
<area> | Defines an area inside an image map | تعريف ناحيه ای در داخل Image map

    مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

    درس قبلی، درس بعدی

    ^^ بالای صفحه ^^

    ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


پس زمينه در اينترنت و اچتمل - Background TAG in HTML in Persian / Farsi

﻿
پس زمينه ( Background )

در اين درس با چگونگی تعيين تصاوير و رنگ پس زمينه (Background) آشنا خواهيد شد. رنگ و يا تصوير پس زمينه فاکتور بسيار مهمی در طراحی صفحات اچتمل بوده و استفاده از رنگ و يا تصوير مناسب نقشی تعيين کننده در خوانا بودن صفحات دارد.

درس قبلی، درس بعدی

مثالها:

رنگ متن و زمينه متناسب
انتخاب رنگ مناسب متون و پس زمينه به خوانا بودن متن کمک شايان توجهی خواهد کرد.

رنگ متن و زمينه نامتناسب
مثالی از انتخاب نامناسب رنگ متن و پس زمينه

مثالهای بيشتر

رنگ و تصوير زمينه در صفحات اچتمل:

تگ <body> دارای دو شناسه مهم برای تعيين رنگ و تصوير پس زمينه ميباشد. پس زمينه صفحات اچتمل رنگ و يا يک تصوير ميتواند باشد.

شناسه bgcolor برای رنگ پس زمينه (background color)

شناسه bgcolor رنگ پس زمينه را تعيين ميکند. مقدار رنگ پس زمينه ميتواند نام رنگ (مثل red يا blue ) ، مقدار آن بر اساس استاندارد RGB و يا حتی مقدار هگزادسيمال (Hexadecimal) باشد.

<body bgcolor="#000000">
<body bgcolor="rgb(0,0,0)">
<body bgcolor="black">

در تمامی مثالهای بالا با کمک شناسه bgcolor رنگ زمينه صفحه "سياه" تعيين ميشود.

شناسه Background برای تصوير پس زمينه:

برای تعيين تصويری که به عنوان پس زمينه صفحه نمايش داده ميشود از شناسه background استفاده ميشود.مقدار اين شناسه URL يا آدر س تصوير (image) ميباشد.اگر ابعاد تصوير کوچکتر از ابعاد صفحه مرورگر باشد، تصوير زمينه تکثير خواهد شد تا حدی که تمام صفحه نمايش از تصوير زمينه پوشانده شود.

<body background="bg.gif">
<body background="http://www.khaterat.com/images/bg.gif">

در مثال اول از آدرس دهی نسبی (relative) برای تعيين URL يا آدرس تصوير استفاده شده و در واقع در اين مثال فايل اچتمل و تصوير bg.gif بايد در يک دايرکتوری قرار گيرند. در مقابل مثال دوم از آدرس دهی مطلق (absolute) برای تعيين آدرس تصوير استفاده شده است و همانطور که ميدانيد آدرس تصوير در هر نقطه از فضای وب ميتواند باشد.

نکات مهم: اگر از تصاوير پس زمينه در صفحات اچتمل استفاده ميکنيد به نکات زير توجه کنيد :

  • هرتصويری با فرمت gif و يا jpg قابل استفاده به عنوان تصوير زمينه ميباشد.
  • از تصاوير بزرگتر از ده کيلوبايت ظرفيت به هيچ وجه استفادا نکنيد، در غير اين صورت سرعت load صفحه بشدت پايين خواهد آمد.
  • از تصاوير زمينه هماهنگ با ديگرتصاوير صفحه استفاده کنيد.
  • از تصاوير زمينه هماهنگ با متون صفحه استفاده کنيد.
  • در رزولوشنهای مختلف به ديدن و آزمايش تصاوير پس زمينه بپردازيد.
  • پر مصرف ترين رنگهای زمينه وب سايتها، رنگهای سفيد، سياه و خاکستری ميباشند.
  • اغلب سايتهای وب از تصاوير پس زمينه استفاده نمی کنند! مثلا همين سايت!!!
نکته مهم در سازگاری با نسخه های جديد اچتمل و XHTML

شناسه های bgcolor و background در تگ <body> در نسخه 4 اچتمل و XHTML پشتيبانی نميشوند و در واقع از رده خارج محسوب ميشوند. در عوض کنسرسيوم W3C استفاده از Style Sheet ها را توصيه ميکند و در واقع در نسخه 4 اچتمل و استاندارد جديد XHTML تمامی اطلاعات مربوط به نمايش يا presentation و layout بايد در style sheet ها قرار گيرند.

مثالهای بيشتر

استفاده مناسب از تصوير زمينه 1
در اين مثال بدلیل استفاده از تصوير مناسب برای زمينه، نوشته های صفحه کاملا خوانا هستند.

استفاده مناسب از تصوير زمينه 2
در اين مثال در اثر استفاده از تصوير مناسب برای زمينه، نوشته های صفحه کاملا خوانا هستند.

استفاده نامناسب از تصوير زمينه
در اين مثال نوشته های صفحه خوانا نيستند.

استفاده از تصوير زمينه با آدرس مطلق
در اين مثال آدرس تصوير زمينه بصورت مطلق و کامل آورده شده است.

تعيين رنگ زمينه با Style Sheet ها
در اين مثال چگونگی استفاده از Style Sheet ها برای تعيين رنگ زمينه آورده شده است.

درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


HTML in Persian, Basic Tags, Tables, Frames, Javascript, DHTML - Stock Photos

﻿
به مدرسه وب خوش آمديد!

مدرسه وب اولين پايگاه آنلاين يادگيری وب و اينترنت به زبان فارسی ميباشد. هدف اصلی کلاسهای این مدرسه، آموزش کلیه علوم مربوط به وب و کمک به انتقال تجربه بین بازدیدکنندگان، کاربران فارسی زبان و دانشجویان دانشگاه ها میباشد. تاکيد متون و مقالات اين سايت بر فارسی نويسی بر اساس استاندارد يونيکد بوده و اولين مجموعه دروس آموزش آن شامل آموزش مقدماتی HTML بهمراه مثالهای متعدد، مقالات کوتاه آموزشی و بيشترين سؤالات مربوط به وبلاگ و فارسی نويسی در وب خواهد بود.

لازم به ذکر است که در آينده و به تدريج اين سايت شامل ديگر دروس مربوط به وب مانند Style Sheets ، XHTML ها، جاوا اسکريپت، بخش پرسش و پاسخ، آخرين اخبار اينترنت و مطالب تخصصی برنامه نويسی وب خواهد شد. مشتاقانه منتظر دريافت نظرات، پيشنهادات و مقالات فنی شما به زبان فارسی و در ارتباط با اينترنت هستيم.

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


بیشترین سؤالات پرسیده شده در مورد وبلاگ و تارنگاری فارسی و فارسی نویسی در اینترنت و وب - Farsi Tarnegari / Weblog FAQ in Persian / Farsi

﻿
Farsi Weblog FAQ بیشترین سؤالات پرسیده شده در مورد تارنگاری فارسی و فارسی نویسی در اینترنت
  • تارنگاشت، وبلاگ، بلاگ یا Weblog چیست؟
  • فرقی بین تارنگاشت و وب سایت شخصی هست؟
  • آیا برابری فارسی برای کلمه وبلاگ (Weblog) وجود دارد؟
  • تارنگاری فارسی چیست؟
  • چگونه میتوان یک تارنگاشت فارسی ساخت؟
  • کجا میتوانم فهرستی از تارنگاشت ها را ببینم ؟
  • آیا انجمن یا گروهی برای تارنگاران ایرانی (نگارندگان تارنگاشت) وجود دارد ؟
  • چگونه تارنگاشت فارسیم را به دیگران معرفی کنم؟
  • کجا میتوانم دیگر سایتهای FAQ مربوط به تارنگاری را بخوانم؟
  • چگونه میتوانم تصویر (Image) به تارنگاشتم اضافه کنم؟
  • کجا قالب های (Template) فارسی شده‌ای برای استفاده در استاندارد سایت blogspot.com را میتوانم پیدا کنم؟

  • استاندارد unicode دیگه چیه؟
  • روش کد گذاری UTF-8 چیست؟
  • ادیتورهائی که استاندارد یونیکد و روش UTF-8 را حمایت کنند، کدامند؟
  • چگونه میتوانم متن های نوشته شده با فرمتهای دیگر را به استاندارد یونیکد تبدیل کنم ( و بلعکس )؟
  • این حروف "پ" و "ژ" کجای صفحه کلید(Keyboard) هستند؟
  • چرا بازدیدکنندگان تارنگاشتم با شکل‌های اول و وسط حرف «ی» و نحوه نمایش آن در ویندوز مشکل دارند؟
  • نیم فاصله یا فاصله مجازی (“1/2 space, pseudo space” ) چیست؟
  • چگونه میتوان کل کاراکترها (نویسه ها) یک فونت مثلا Tahoma را دید؟
  • آیا راهی سریع برای یافتن معادل یونیکدی یک کلمه یا جمله فارسی (و بلعکس) وجود دارد؟
  • چگونه به مرورگر اعلام کنم که صفحات HTML من با کد گزاری نوع UTF-8 تهیه شده اند؟
  • سایتهائی خوب برای یادگیری HTML کدامند؟
  • سایتهائی معروفی که فضای مجانی برای میزبانی سایت(Hosting) ارائه میدهند کدامند؟
  • آیا راهنمای فارسی و آنلاینی برای اچتمل (HTML) وجود دارد؟
  • چگونه میتوانم دفتر بازدیدکنندگان(Guestbook) و یا نظرسنجی (Polling) را به سایتم اضافه کنم؟
  • چگونه میتوانم تعداد بازدیدکنندگان و دیگر اطلاعات آماری تارنگاشتم (سایتم) را ببینم؟
  • مـراجــع:

  • تارنگاشت، وبلاگ، بلاگ یا Weblog چیست؟
    تارنگاشت ، وبلگ، بلاگ، newspage یا Filter وب سایتی است که حاوی گزارشهای یک تارنگار یا وبلاگ نویس (بلاگر) در مورد وب سایتهای جالب دیگران است. قالب یا فرمت گزارش نویسی معمولا بدینگونه است که گزارشها از نظر زمانی از بالا به پایین نوشته میشوند و تازه ترین نوشته ها در قسمت بالا قرار خواهند گرفت.
    دو تعریف دیگر برگرفته از تارنگاشت بابا ﻭ دخترش :
    تعریف1- یك تارنگاشت یك وب سایت شخصی یا غیرتجاری است كه از یك فرم گزارش نویس تاریخ دار (كه می‌تواند روزانه یا هرچند وقت یكبار باشد)استفاده می‌كند. تارنگاشت می‌تواند شامل اطلاعات جدید درباره یك موضوع خاص ویا چندین موضوع باشد كه توسط صاحب(ان) سایت نوشته یا از سایت‌های دیگر گردآوری شده ویا باهمكاری خوانندگان بوجود آمده باشد.
    تعریف 2- تارنگاشت اساسا یك روزنگار online است كه توسط یك (یاچند) شخص نگهداری می‌شود كه معمولا همان سردبیر است . مطالب تارنگاشت روی یك موضوع خاص متمركز است و ارجاع (link) دادن به سایر وب سایت‌ها یا مقالات به همراه یك توضیح كوتاه یا بامزه و یا حتی منتقدانه در باره انها از خصوصیات تارنگاری است

  • فرقی بین تارنگاشت و وب سایت شخصی هست؟
    تارنگاشت نوعی از وب سایتهای شخصی است که بصورت پیوسته (روزانه، هفتگی، ...) به روز درآورده شده و حاوی مطالبی دنباله دار در مورد یک موضوع و یا در مورد دیگر سایتها میباشد.

  • آیا معادلی فارسی برای کلمه وبلاگ (Weblog) وجود دارد؟
    بله! تارنگاری یا تارنگاشت
    برای دیدن پیشنهادهای رسیده برای برابر فارسی وبلاگ و نتیجه نهائی رای گیری بعمل آمده "توسط این وبلاگ!" به این صفحه مراجعه کنید.

  • تارنگاشت فارسی چیست؟
    تارنگاشتی که با زبان فارسی و با استفاده از فونتهای فارسی نوشته شده باشد.

  • چگونه میتوان یک تارنگاشت فارسی ساخت؟
    کافی است که وب سایت شخصیتان را راه انداخته و شروع به نوشتن خاطرات، یادداشتها و مطالبتان به صورت گزارش گونه و روزانه به زبان فارسی کنید. اگر مهارت کافی در مورد فارسی نویسی و HTML ندارید و یا فضائی برای نگهداری صفحاتتان روی وب ندارید، سایت blogpost.com فضا و سرویس چند زبانه نویسی (مثلا فارسی ) را به صورت مجانی در اختیارتان قرار داده و در عوض تبلیغی در بالای تارنگاشتتان قرار میدهد. استفاده از راهنمای عالی "چطور یک تارنگاشت فارسی بسازیم؟" تهیه شده توسط آقای حسین درخشان شما را در مورد فارسی نویسی و چکونگی استفاده از سرویسهای سایت مزبور راهنمائی خواهد کرد.

  • کجا میتوانم فهرستی از تارنگاشتها را ببینم ؟
    برای تارنگاشتهای غیر فارسی bloghop.com ، blogdex و ...
    و برای تارنگاشتهای فارسی تارنگاشت سردبیر: خودم (فهرست کامل)، تارنگاشت حامدآقا و تارنگاشت خاطرات

  • آیا انجمن یا گروهی برای تارنگاران ایرانی وجود دارد ؟
    برای تارنگاری فارسی گروه Farsi Blogging در یاهو و تالار "تارنگاری فارسی" در مدرسه وب جزو اولین انجمن های اینترنتی برای تبادل نظر در مورد مسائل و مشکلات تارنگاری فارسی میباشند.

  • چگونه تارنگاشت فارسیم را به دیگران معرفی کنم؟
    کافی است که به یکی از چهار روش زیر عمل کنید:
    • - ایمیلی(رایانامه) برای گروه Farsi Blogging در یاهو فرستاده و نام و URL یا آدرس تارنگاشتتان را به اطلاع اعضای گروه برسانید.
    • - بروی تخته مخصوص! تالار "تارنگاری فارسی" مدرسه وب آدرس تارنگاشتتان را در گروه مناسب وارد کنید.
    • - فرم سایت آقای حسین درخشان را پر کنید تا به فهرست ایشان اضافه شوید.
    • - و به عنوان روش آخر در کوچه و خیابان داد بزنید که "آهای ملت ما تارنگاریم!!"

  • کجا میتوانم دیگر سایتهای FAQ مربوط به تارنگاری را بخوانم؟
    این سایتها دارای سؤال و جوابهای خوبی در مورد تارنگاری هستند:
    • FAQ 1
    • FAQ 2

  • چگونه میتوانم تصویر (Image) به تارنگاشتم اضافه کنم؟
    یک راه مراجعه به مدرسه وب و مطالعه بخش ( Images ) تصاویر میباشد.

  • کجا قالب های (Template) فارسی شده‌ای برای استفاده در استاندارد سایت blogspot.com را میتوانم پیدا کنم؟
    تارنگاشت احسان قالبهای خوبی برای استفاده در استاندارد blogspost طراحی کرده است که در این آدرس قرار دارند.

  • استاندارد unicode دیگه چیه؟
    یونیکد (‌Universal Character Set Transformation Format) استاند‌ارد‌ی‌ بین‌‌المللی ‌(منطبق‌ بر ‌استاند‌ارد ‌ایزو ۱۰۶۴۶) بر‌ا‌ى‌ تبادل‌ ‌اطلا‌عات‌ چندزبانه است. یونیکد ‌امکان‌ کدگذ‌ار‌ى‌ ‌همه‌‌ى‌ نویسه‌‌ها‌ى(character)‌ مورد ‌استفاده‌ در نوشتن‌ زبان‌‌ها‌ى‌ دنیا ر‌ا فر‌ا‌هم‌ مى‌سازد. ‌این‌ ‌استاند‌ارد ‌از کدگذ‌ار‌ى‌ ۱۶بیتى‌‌ا‌ى‌ ‌استفاده‌ کرده و‌ بر‌ا‌ى‌ بیش‌ ‌از ۰۰۰'۶۵ نویسه‌ جا فر‌ا‌هم‌ میکند. ‌اگر چه‌ ۰۰۰'۶۵ نویسه‌ بر‌ا‌ى‌ کدگذ‌ار‌ى‌ ‌اکثر نویسه‌‌هایى‌ که‌ در زبان‌‌ها‌ى‌ مهم‌ دنیا ‌استفاده‌ میشود کافى‌ ‌است‌، استاند‌ارد یونیکد توسط‌ تمامى‌ شرکت‌‌ها‌ى‌ معتبر بین‌‌المللى‌ کامپیوتر‌ى‌، مثل‌ ‌آ‌ى‌بى‌‌ام‌، مایکروسافت‌، و سان‌، و نیز موسسات‌ ملى‌ ‌استاند‌ارد در کشور‌ها‌ى‌ مختلف‌ جهان‌ ‌ مورد تو‌افق‌ قر‌ارگرفته‌ ‌است‌ و سر‌عت‌ رشد بسیار زیاد‌ى‌ نیز در میان‌ کاربر‌ان‌ د‌ارد.
    - برای اطلاعات بیشتر :
    - شرح یونیکد: یونیکد چیست؟
    - شرح بیشتر در مورد یونیکد: پروژه‌‌ى‌ ‌استاند‌ارد خط‌ فارسى‌ در یونیکد
    - شرح باز هم بیشتر در مورد یونیکد: سایت رسمی یونی کد
    - شرح بیشترین در مورد یونیکد: بیشترین سؤالات پرسیده شده در مورد یونیکد

  • روش کد گذاری UTF-8 چیست؟
    همان استاندارد یونیکد است فقط به فرم 8 بیتی و نه 16 بیتی. در واقع UTF-8 شیوه‌‌ا‌ى‌ است بر‌ا‌ى‌ کدگذ‌ار‌ى‌ ۸بیتى‌ در یونى‌کد ‌ که‌ نویسه‌‌ها ر‌ا پس‌ ‌از ‌ا‌عمال‌ یک‌ تابع‌ خاص‌ به‌ کدشان‌، به‌صورت‌ دنباله‌‌هایى‌ که‌ ‌از یک‌ تا چهار بایت‌ د‌ارند نگه‌ مى‌د‌ارد. ‌این‌ شیوه‌ به‌ ‌این‌ خاطر که‌ نویسه‌‌ها‌ى‌ ‌اسکى‌ ر‌ا ‌عیناً حفظ‌ مى‌کند و در نتیجه‌، ‌هم‌ برنامه‌‌ها‌ى‌ قدیمى‌ ر‌احت‌تر با ‌آن‌ کنار مى‌‌آیند و ‌هم‌ طول‌ پرونده‌‌ها‌ى‌ لاتین‌ ر‌ا زیاد نمى‌کند، بسیار محبوب‌ ‌است‌. در و‌اقع‌ بسیار‌ى‌ ‌از سیستم‌‌هایى‌ که‌ ‌اد‌عا‌ى‌ پشتیبانى‌ یونى‌کد ر‌ا مى‌کنند، تنها UTF-8 ر‌ا پشتیبانى‌ مى‌کنند و پرونده‌‌ها‌ى‌ یونى‌کد‌ى‌، ‌ا‌عم‌ ‌از کاربرد‌ها‌ى‌ ‌اینترنتى‌ یا مو‌ارد ‌استفاده‌‌ى‌ محلى‌، ‌عمدتاً در قالب‌ UTF-8 ذخیره‌ شده‌‌اند.

  • ادیتورهائی که استاندارد یونیکد و روش UTF-8 را حمایت کنند، کدامند؟
    برای سیستم عامل ویندوز Notepad ،FrontPage ، MS Word و در واقع Office 2000 و حتی Outlook

    نکته: اگر از "Windows Notepad" برای ورود متون فارسی استفاده می کنید هنگام ذخیره فایل در منوی "File/Save As" نوع Encoing ذخیره سازی را "UTF-8" انتخاب کنید.

  • چگونه میتوانم متن های نوشته شده با فرمتهای دیگر را به یونیکد تبدیل کنم ( و بلعکس )؟
    نرم افزارهای IUC V2.0 و Native code converter مبدلهای ( Convertor ) خوبی برای تبدیل فرمتهای مختلف هستند.

  • این حروف "پ" و "ژ" کجای صفحه کلید(Keyboard) هستند؟
    بسته به ادیتور متن و برنامه ای که برای تایپ استفاده میکنید تعریف صفحه کلید فرق میکند، برای مثال در Windows Notepad کلید "\" معادل "پ" و ترکیب Shift + c معادل "ژ" هستند. صفحه کلید فارسی برای ویندوز NT و 2000 اینجاست.

    Letter | Keystokes | Hex Entity | Decimal Entity
    peh - پ | Alt + 0129 (Farsi) | &#x067e; | &#1662;
    tcheh - چ | Alt + 0141 (Farsi) | &#x0686; | &#1670;
    jeh - ژ | Alt + 0142 (Farsi) | &#x0698; | &#1688;
    gaf - گ | Alt + 0144 (Farsi) | &#x06af; | &#1711;

    مقاله مرجع

  • چرا بازدیدکنندگان تارنگاشتم و یا خودم با شکل‌های اول و وسط حرف «ی» و نحوه نمایش آن در ویندوز مشکل دارند؟
    احتمالا آنها از بعضی از فونتهای ویندوز ( مثلا Tahoma ) که دارای خطای طراحی هستند، استفاده میکنید، برای رفع مشکل یکی از راه حلهای زیر را به آنها توصیه کنید:
    1. ویندوزشان را به روز (update) کنند. Service pack های ویندوز نه تنها آخرین تغییرات را بهمراه دارند بلکه اشکالات فونتها را نیز اصلاح کرده اند. در مورد ویندوز 2000 باید Service Pack 2 را داونلود و نصب کنند.
    2. نصب فونتهای جدید و آخرین اصلاحات فونتها از این آدرس راه دوم میباشد.(در این آدرس تمامی فونتها موجود نیست و مثلا قلم Tahoma را فقط در Service Pack ها میتوان یافت.)
    3. نصب فونتهای جدید و آخرین اصلاحات فونتها از این آدرس راه سوم میباشد.
    4. استفاده از فونتهای طراحی شده در ایران مانند فونت نصف راه حل دیگری میباشد که در اینصورت باید در تارنگاشتتان امکان داونلود فونت مزبور را به بازدیدکنندگانتان بدهید. (ظاهرا حرکات و بعضی از نویسه ها درست کار نمیکنند!!؟)
    5. با توجه به استفاده اغلب تارنگاشتها از فونت Tahoma ، نسخه اصلاح شده 2.80 آنرا میتوانند از این آدرس داونلود کرده و نصب کنند.

    نکته: راه موقت و اشتباه نهائی استفاده از char های بخش عربی فونتها به جای char های مشکل دار بخش فارسی است. ( برای تایپ شکل‌هایِ چسبیده‌ی حرفِ «ی» به جای D از ترکیب "Alt + X" استفاده کنید. در اینصورت بازدیدکنندگان با وجود داشتن فونتهای مسئله دار شکل‌هایِ چسبیده‌یِ حرفِ «ی» را درست خواهند دید. البته در آینده و مثلا موقع جستجوی کلماتی که شامل حرف "ی" میشوند نتایج جستجو درست نخواهد بود!؟)

    برای راهنمائی در مورد نصب قلم ها به فونت نصف مراجعه شود.

  • نیم فاصله یا فاصله مجازی (“1/2 space, pseudo space” ) چیست؟
    - برای تایپ بعضی از کلمات مانند "خاطرهها" باید از نویسه‌ای خاص که فاصله‌ای مجازی بین نویسه‌های دیگر ایجاد میکند استفاده کنید و در اینصورت کلمه "خاطرهها" به صورت صحیح آن یعنی "خاطره‌ها" نمایش داده خواهد شد و ادیتور نوسیه‌ها را به هم نمی‌چسباند. بسته به ادیتور متنی که استفاده میکنید ایجاد و تایپ فاصله مجازی متفاوت بوده و یکی از روشهای کلی در ویندوز استفاده از ترکیب کلید Alt و کد نویسه مربوطه است و برای قراردادن فاصله مجازی باید از ترکیب “Alt + 0157” استفاده کنید. برای مثال "خاطرهها" باید با تایپ فاصله مجازی یعنی بین دو "ه" از به هم چسبیدن نویسه‌ها جلوگیری کنید.
    * برای تایپ اعداد از بخش اعداد صفحه کلید استفاده کرده و مطمئن شوید که چراغ Num Lock روشن است!
    * با کمک فاصله مجازی همچنین قادر به تایپ نویسه‌های مجزای کنار هم خواهید شد، مثلا:
    خ‌ا‌ط‌ر‌ا‌ت برای کلمه "خاطرات" .

  • چگونه میتوان کل کاراکترها (نویسه ها) یک فونت مثلا Tahoma را دید؟
    * در ویندوزNT یا 2000 برنامه Character Map یا Charmap امکان دیدن مجموعه کاراکترها (character sets) داس، ویندور و یونیکد هر فونت دلخواه مثلا Tahoma را فراهم میکند.برای اجرا کافی است که بدین طریق عمل کنید :Start->Run->Charmap

    * در صورتی كه از ویندوز 98یا95 استفاده می‌كنید از این برنامه استفاده كنید.
    * برای linux ، Mac و دیگر OS ها منتظر راهنمائی شما هستیم!
    - برگرفته از تارنگاری بابا ﻭ دخترش

  • آیا راهی سریع برای یافتن معادل یونیکدی یک کلمه یا جمله فارسی (و بلعکس) وجود دارد؟
    یک راه ساده این است که در سایت گاگل متن یا کلمه را تایپ کرده و پس از جستجو مرورگر (یا گاگل؟) معادل یونیکدی را نمایش خواهد داد، مثلا معادل کلمه "خاطرات" خواهد شد:
    &#1582;&#1575;&#1591;&#1585;&#1575;&#1578;

    برای دیدن معادل فارسی رشته ای از کدهای یونیکد، مرورگر یا Browser به صورت اتوماتیک از روی نماد & و عدد کاراکتر میفهمد که کاراکتری خاص (مثلا فارسی) را باید نمایش دهد، مثلا نمایش رشته یونیکدی بالا توسط مرورگر: خاطرات

  • چگونه به مرورگر اعلام کنم که صفحات HTML من با کد گزاری نوع UTF-8 تهیه شده اند؟
    کافی است که در قسمت head صفحه HTML تان Meta tag زیر را اضافه کنید:

    در اینصورت مرورگر یا Browser قبل از نمایش صفحه از روی متاتگ فوق نوع کدگزاری (Encoding) را تشخیص داده و دیگر مثلا نیازی به تعیین دستی (دراکسپلورور 5 : View/Encoing/Unicode / UTF-8 ) نوع Encoing توسط بازدیدکننده سایت نخواهد بود.

  • سایتهائی خوب برای یادگیری HTML کدامند؟

    1) Welcome to HTML School
    2) Getting Started
    3) Authoring HTML Basics
    4) Getting started with HTML
    5) A Beginner's Guide to HTML
    6) HTML Tutorial
    7) HTML Tag Quick Reference Guide
    8) HTML FAQ Knowledge Base
    9) HTML 4.01 Specification

  • سایتهائی معروفی که فضای مجانی برای میزبانی سایت(Hosting) ارائه میدهند کدامند؟
    این لینک Free Domain List 1 و این یکی Free Domain List 2 حاوی فهرست مقایسه‌ای و کاملی از سایتهائی هستند که فضای مجانی برای ساختن و قرار دادن صفحات اچتمل را در اختیارتان قرار میدهند.

  • آیا راهنمای فارسی و آنلاینی برای اچتمل (HTML) وجود دارد؟
    آهان! منتظر همین سؤال بودیم! مدرسه وب و بخش راهنمای اچتمل مقدماتی آن جزو اولین سایتهای آنلاین آموزش وب و اچتمل بزبان فارسی میباشد.

  • چگونه میتوانم دفتر بازدیدکنندگان(Guestbook) و یا نظرسنجی (Polling) را به سایتم اضافه کنم؟
    سایت الکس نت دات کام نمونه خوبی از سایتهایی است که خدمات تقریبا مجانی اینترنتی دارند و از جمله آنها Guestbook , Poll , Quiz , Forum میباشد که میتوانید در صفحات خود از آنها استفاده کنید.
    سایت bravenet.com نمونه خوب دیگر است.

    از دیگر سایتهای بسیار خوبی که امکان نظرسنجی از خوانندگان تارنگاریتان را فراهم کرده، بسیار راحت نصب شده و از قالبهای بسیار خوبی که قابل فارسی سازی است استفاده میکند ، سایت electrichamster.net میباشد که توصیه میشود از امکانات ارائه شده آن حتما استفاده شود.

  • چگونه میتوانم تعداد بازدیدکنندگان و دیگر اطلاعات آماری تارنگاشتم (سایتم) را ببینم؟
    اگر بدنبال ارزیابی و ردیابی مراجعه کنندگان به سایتتان هستید stats4all.com یکی از بهترین خدمات رایگان را در این زمینه ارایه میدهد.پس از باز کردن یک account و اضافه کردن کد HTML مربوطه به سایتتان اطلاعات بسیار جالبی در مورد مراجعه کنندگان گردآوری شده و قابل استفاده توسط شما و یا کسانی که میخواهند که آمار سایت شما را دیده و احیانا به شما پیشنهاد پخش آگهی در سایتتان بدهند ( advertisers ) میباشد
    سایت addfreestats.com و bCentral FastCounter سایتهای خوب دیگر برای آمارگیری بازدیدکنندگان هستند.

  • مـراجــع:

    * راهنمای یونیکد
    * راهنمای دوم یونیکد
    * پروژه‌‌ى‌ ‌استاند‌ارد خط‌ فارسى‌ در یونیکد
    * استفاده از استانداردِ یونی‌کد
    * Farsiblogging Yahoo Group
    * FAQ Unicode
    * Farsi & WIN 2000
    - ایده تهیه این متن برگرفته از تارنگاشت ژینا
    - آخرین اصلاح : 18 می 2002

    • سؤال و یا پیشنهادی برای این صفحه دارید؟

    ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


HTML in Persian, Basic Tags, Tables, Frames, Javascript, DHTML - Stock Photos

﻿
فارسی نويسی

در اين درس با فارسی نويسی، فارسی سازی و استاندارد يونيکد و نحوه استفاده از اديتور آنلاين و فارسی اين سايت آشنا خواهيد شد. همچنين متاتگ http-equiv و شناسه dir نيز معرفی خواهد شد.

درس قبلی، درس بعدی

سؤالات مربوط به فارسی نويسی را ميتوان به سه گروه عمده تقسيم کرد:
- چگونه فارسی بنويسم ؟
- چگونه فارسی بخوانم؟
- چگونه صفحات اچتمل فارسی را نمايش دهم؟

در مورد فارسی نويسی و فارسی خوانی اگر از اديتور آنلاين ما در بخش مثالها استفاده ميکنيد نيازی به فارسی سازی نداريد و با کمک اديتور مزبور بايد به راحتی قادر به تايپ فارسی و لاتين باشيد.اگر ميخواهيد که در هر حال سيستمتان را فارسی کنيد، مطالعه صفحات زير راهنمای بسيار خوبی برای فارسی سازی ميباشند:

* راهنمای فارسی سازی ويندوز
* استفاده از استانداردِ یونيکد
* وبلاگ فارسی FAQ

دو نکته بسيار مهم در مورد فارسی نويسی:

  • روش کدگزاری UTF-8
    اکيدا توصيه ميشود که برای تايپ و تمايش متون فارسی از استاندارد يونيکد و روش کدگزاری UTF-8 اسنفاده شود و اين روشی است که مطالب اين سايت و اديتور آنلاينش از آن استفاده ميکند.نکته مهم در نمايش صحيح متون فارسی تعيين نوع کدگزاری يا encoing صفحات فارسی است که برای اينکار بايد از متاتگ خاصی به نام http-equiv در بخش head صفحات اچتمل به شکل زير استفاده شود:

    • <meta http-equiv="Content-Type" content="text/html; charset=utf-8">

    در اينصورت مرورگر يا Browser قبل از نمايش صفحه از روی متاتگ فوق نوع کدگزاری (Encoding) را تشخيص داده و ديگر مثلا نيازی به تعيين دستی (دراکسپلورور 5 : View/Encoing/Unicode / UTF-8 ) نوع Encoing توسط بازديدکننده سايت نخواهد بود.

  • شناسه يا attribute ی به نام dir
    جهت نمايش متون لاتين به صورت پيش فرض و default از چپ به راست (ltr) ميباشد.در مورد متون و جملات فارسی بايد با کمک روشی جهت نمايش پيش فرض را به "راست به چپ" تغيير دهيد. شناسه يا attribute ی به نام dir يا همان direction اين کار را برای شما انجام ميدهد. اين شناسه دارای دو مقدار ممکن ميباشد :

    • dir="ltr" , Left-to-right text. - چپ به راست
    dir="rtl" , Right-to-left text. - راست به چپ

    مثلا برای نمايش جمله فارسی "سلام بر دنيای وب!" با کمک عناصر p يا div کافی است که به يکی از شکلهای زير عمل شود:

    <p dir="rtl"> سلام بر دنيای وب </p>
    <div dir="rtl"> سلام بر دنيای وب </div>

    در بسياری از عناصر و تگ های اچتمل امکان استفاده از شناسه dir ميسر بوده و به عنوان نمونه ميتوان از عناصر زير نام برد:

    <p> , <div> , <html> , <body> , <table> , <tr> , <td> , <h1 ... h6> , <input> , <pre> , <select> , <span> , ...

    مثالهای زير نحوه ترازبندی متون فارسی را به نمايش ميگذارند و برای مطالعه بيشتر در مورد ترازبندی متون "راست به چپ" به اين صفحه مراجعه کنيد. (عناصر BDO ، Span و شناسه lang هم برای مطالعه مفيد ميباشند.)

    مثالهای فارسی نويسی:
    مثال 1 : سلام بی وفا
    به بخش head و تگ div توجه کنيد. متا تگ http-equiv نوع کدگزاری را تعيين ميکند و در اينجا با کمک تگ div جهت نوشتن مطالب (از راست به چپ يا بلعکس) تعيين ميگردد. dir به معنای direction و جهت بوده و rtl مخفف right to left و ltr معادل left to right ميباشد.

    مثال 2 : متن ها و پاراگراف بندی
    به عناصر div و p توجه کنيد. با کمک شناسه dir جهت نوشتن مطالب (از راست به چپ يآ بلعکس) تعيين ميگردد.

    مثال 3 : متون فارسی و لاتين در کنار هم
    مثالی کاملتر با راهنمای استفاده از عنصر div و شناسه dir آن

    مثال 4 : شناسه dir در عنصر html
    اگر شناسه dir را در عنصر html بکار ببريد جهت نمايش تمامی متون از راست به چپ شده و برای نوشتن از چپ به راست بايد به صورت موردی شناسه "dir="ltr را استفاده کنيد. همچنين در اين حالت ماسماسک! Scrool down مرورگر در سمت چپ صفحه نمايش داده خواهد شد. در صورت استفاده شناسه dir در عنصر body ماسماسک همان سمت راست خواهد ماند.

    مثال 5 : مثال کامل
    نحوه استفاده شناسه dir در عنصرهای مختلف

    لازم به ذکر است که برای فارسی نويسی از کدهای java script موجود در اين آدرس که ابزارهای برنامه نويسی فراهم شده توسط شورای عالی انفورماتيك و دانشجويان دانشگاه صنعتی هستند، استفاده شده است و توصيه ميشود که پروژه farsiweb.info را فراموش نکرده زيرا که استاندارد آينده فارسی نويسی اينترنتی در ايران خواهد شد.

    درس قبلی، درس بعدی

    ^^ بالای صفحه ^^

    ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


HTML in Persian, Basic Tags, Tables, Frames, Javascript, DHTML - Stock Photos

﻿
دریافت قلم فارسی

Tahoma Font Version 2.80, 260 KB

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


قلم ها در اچتمل اینترنت و وب - Font Tag in HTML in Persian / Farsi

﻿
قلم ها ( HTML Fonts )

با وجودیکه هنوز بعضی از اچتمل کاران از تگ <font> برای تعیین نام و نوع قلم، رنگ و اندازه متون استفاده میکنند ولی در استاندارد جدید اچتمل (نسخه 4) و همچنین XHTML از تگ <font> پشتیبانی نمیشود و استفاده از Style Sheet ها به عنوان جایگزین معرفی شده است.

درس قبلی، استایل شیتها

تگ <font>

در نسخه های 3.2 و قبلی تر زبان اچتمل از تگ <font> برای تعیین نام قلم، رنگ و اندازه متون استفاده میشود. در این تگ شناسه face نام قلم ، شناسه size انداره قلم و شناسه color معرف رنگ متن خواهد بود. مثالهای زیر کاربرد تگ <font> خدابیامرز را نشان میدهند:

کد اچتمل نمايش کد روبرو توسط مرورگر
<p>
<font size="2" face="Verdana">
This is a paragraph.
</font>
</p>

This is a paragraph.

<p dir="rtl">
<font size="1" face="Times" color="#FF9900">
متنی با قلم Times و اندازه 1 و رنگ FF9900
</font>
</p>

متنی با قلم Times و اندازه 1 و رنگ FF9900

<p dir="rtl">
<font size="2" face="Tahoma" color="red">
این متنی با قلم Tahoma و اندازه 2 و رنگ قرمز
</font>
</p>

متنی با قلم Tahoma و اندازه 2 و رنگ قرمز

شناسه های تگ <font>
Attribute | Example | کاربرد
size="number" | size="2" | تعیین اندازه قلم
size="+number" | size="+1" | افزایش اندازه قلم
size="-number" | size="-1" | کاهش اندازه قلم
face="face-name" | face="Times" | تعیین نام قلم
color="color-value" | color="#eeff00" | تعیین رنگ قلم
color="color-name" | color="red" | تعیین رنگ قلم

*** بیان مختصر عملکرد تگ <font> در این دروس فقط جهت اطلاع بوده و استفاده از آنها در طراحی صفحات اچتمل توصیه نمیشود.

دیگر از تگ <font> استفاده نکنید!

تگ <font> از رده خارج محسوب میشود و کنسرسیوم جهانی تعیین استانداردهای وب (World Wide Web Consortium, W3C) این تگ را از مجموعه تگهای استاندارد اچتمل کنار گذاشته است و اکیدا توصیه میشود که از Style Sheet ها برای تعریف هر گونه خواص نمایشی و آرایشی (layout & Presentation) المانها در اچتمل استفاده شود.

روش صحیح تعیین نام قلم، اندازه و رنگ متون با کمک Style Sheet ها:

هر چند که مبحث و کلاسهای درس Style Sheet ها در "مدرسه وب" در دست تهیه بوده و امیدواریم که بزودی ارائه شوند ولی تا قبل از آن استفاده از شناسه ای به نام style در بسیاری از المانها کار گشا خواهد بود. مثالهای ساده زیر نحوه تعیین نام قلم، اندازه و رنگ متون را با کمک شناسه style به نمایش خواهند گذاشت:

تعیین نام قلم
مثالی در مورد تعیین نام قلم در یک استیل درجا (inline)

تعیین اندازه قلم
مثالی در مورد تعیین اندازه قلم در یک استیل درجا (inline)

تعیین رنگ قلم
مثالی در مورد تعیین رنگ قلم در یک استیل درجا (inline)

تعیین نام، اندازه و رنگ قلم
مثالی در مورد تعیین نام، اندازه و رنگ قلم در یک استیل درجا (inline)

مثال کاربردی در مورد Style Sheet ها
مثالی در مورد نحوه تعریف استیلهای مختلف نمایش متون در جداول

تگ <span>
تگ <span> سبب تعریف محدوده و گستره ای مشخص میشود. تمامی المان هائی که درون تگهای <span> و <span/> قرار خواهند گرفت خواص آنرا به ارث خواهند برد، خواصی از قبیل استیل (Style) و یا سمت و جهت نمایش متون(dir).
بر خلاف تگ های <p> و <div> مرورگرها هیچ سطر جدیدی به اول یا آخر المان <span> اضافه نمی کنند.

مثال:
کد اچتمل | نمايش کد روبرو توسط مرورگر
<p>Some text <span style="color:#0000AF;">another text</span> again text...</p> | Some text another text again text...

id, class, title, style, dir, lang شناسه های استاندارد المان span

مثالهائی از نحوه استفاده از المان span و Style sheet ها:
روش قدیمی | روش صحیح
<font color="#FF00FF">Hello!</font> | <span style="color:#FF00FF">Hello!</span>
<font color="rgb(255,0,255)">Hello!</font> | <span style="color:rgb(255,0,255)">Hello!</span>
<font style="color:Fuchsia">Hello!</font> | <span style="color:Fuchsia">Hello!</span>
<font color="#FF00FF" size="3">Hello!</font> | <span style="color:#FF00FF;font-size:100%">Hello!</span>

تگ <div>
تگ <div> سبب تعریف محدوده و گستره ای مشخص میشود. تمامی المان هائی که درون تگهای <div> و <div/> قرار خواهند گرفت خواص آنرا به ارث خواهند برد، خواصی از قبیل استیل (Style) و یا سمت و جهت نمایش متون(dir).
بر خلاف تگ <span> مرورگرها یک سطر جدید به اول و آخر المان <div> اضافه می کنند.

مثال:
کد اچتمل | نمايش کد روبرو توسط مرورگر
<p>Some text <div style="color:#0000AF;">another text</div> again text...</p> | Some text another text again text...

id, class, title, style, dir, lang شناسه های استاندارد المان div

تعیین جهت نمایش متون
مثالی در مورد استفاده از تگ div و اعمال "جهت نمایش متون" به بخشی از صفحه اچتمل

Start Tag | Purpose | کاربرد
<div> | Defines a division/section in a document | تعریف بخش و ناحیه ای از صفحه اچتمل
<span> | Defines a section in a document | تعریف بخش و ناحیه ای از صفحه اچتمل

مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

درس قبلی، استایل شیتها

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


مرجع تگ های اچتمل به فارسي در اينترنت - - HTML Reference in Persian / Farsi

HTML Reference
NAME W3C HTML NS MSIE DESCRIPTION

﻿

Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


وب و مرورگرها -HTML, WWW, web, W3C , Browsers, XHTML 1.0 in Farsi / Persian

﻿
HTML & WWW

در اين درس با مفاهيم وب، اينترنت، مرورگرها و استانداردهای وب آشنا خواهيد شد.

درس قبلی، درس بعدی
منظور از وب چيست؟
  • وب شبکه ای است متشکل از تمامی کامپيوترهای دنيا، شبکه ای از شبکه ها.
  • اينترنت، وب، WWW ، web يا World Wide Web همگی يک چيزند.
  • تمامی کامپيوترهای وب ميتوانند با هم ارتباط داشته باشند.
  • کامپيوترهای موجود در وب با کمک استاندارد ارتباطی يا پروتوکل HTTP با هم ارتباط برقرار ميکنند .
نحوه کارکرد وب چگونه است؟
  • اطلاعات وب داخل فايلهائی به نام Web Pages و يا صفحات وب قرار دارند.
  • اين فايلها يا صفحات روی Web Server يا کامپيوترهای سرويس دهنده وب ذخيره شده اند.
  • برای ديدن صفحات وب از نرم افزاری به نام مرورگر و يا Web Browser استفاده ميشود.
  • دو مرورگر Internet Explorer و Netscape Navigator جزو معروفترين مرورگرها حساب ميشوند.
  • مرورگر Internet Explorer متعلق به شرکت مايکروسافت و مرورگر Netscape Navigator متعلق به شرکت نت اسکيپ ميباشد.
مرورگرها چگونه به خواندن صفحات وب ميپردازند؟
  • يک مرورگر با کمک يک Request درخواستی برای خواندن يک صفحه از وب سرور ميکند.
  • اين Request يا درخواست بر اساس استاندارد ارتباطی يا پروتوکل HTTP بوده و شامل آدرس صفحه مورد نظر ميباشد.
  • آدرس يک صفحه وب چيزی شبيه http://www.khaterat.com/faq.html است. بخش //:http نوع پروتوکل و يا استاندارد ارتباطی را تعيين ميکند، www.khaterat.com نام دومين يا Domain است و faq.html نام صفحه ای است که بايد خوانده شود.
مرورگرها چگونه صفحات وب را نمايش ميدهند؟
  • چگونگی نمايش يک صفحه وب بصورت مستتر در آن وجود دارد.
  • مرورگرها از روی دستورالعملهای داخل صفحات وب و با کمک تگ ها به نمايش صفحات ميپردازند.
  • وظيفه اصلی تگ های اچتمل ( HTML tags ) بيان چگونگی نمايش اطلاعات ميباشد.
  • يک تگ اچتمل چيزی شبيه <p> اين تگ پاراگراف است! </p> است.
چه کسانی استاندارد های وب را تعيين ميکند؟
  • تعيين استاندارد های وب ربطی به شرکتهای مايکروسافت و يا نت اسکيپ ندارد.
  • World Wide Web Consortium يا W3C متولی تعيين استانداردهای وب است.
  • HTML, CSS and XML از مهمترين استانداردهای تصويب شده وب ميباشند.
  • آخرين استاندارد HTML استاندارد XHTML 1.0 ميباشد .
درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


مقدمه ای بر اچتمل و اينترنت به فارسي - HTML Intro in Persian / Farsi

﻿
مقدمه ای بر HTML

در اين درس با ويژگيهای فايلهای HTML يا اچتمل و نحوه ايجاد يک فايل ساده و نمايش آن در صفحه مرورگرتان آشنا خواهيد شد.

درس قبلی، درس بعدی
يک فايل HTML چيست؟
  • HTML را "اچ تی ام ال" و يا اچتمل بخوانيد.
  • HTML برگرفته از حروف اول Hyper Text Markup Language
    • ميباشد.
  • يک فايل HTML فايلی از نوع text ميباشد که متشکل از markup tag ها ميباشد.
  • مرورگر يا Browser از روی markup tag ها می فهمد که چگونه بايد صفحه را نمايش بدهد.
  • يک فايل HTML بايد دارای انشعاب htm و يا html باشد.
  • يک فايل HTML فايلی از نوع text ميباشد که با هر اديتور ساده ای قابل ايجاد است.
  • وظيفه اصلی تگ های اچتمل ( markup tags ) بيان چگونگی نمايش اطلاعات ميباشد.
ميخواهيد که يک فايل اچتمل بسازيد؟

اگر از ويندوز مايکروسافت استفاده ميکنيد، Notepad را باز کرده (Mac کارها از SimplaeText استفاده کنند. ) و متن زير را در آن تايپ کنيد:

<html>
<head>
<title>Title of page</title>
</head>
<body>
This is my first html page. <b>This text is bold</b>
</body>
</html>

سپس فايل را با نام مثلا test.html در درايو c:\ ذخيره کنيد.

برای ديدن فايل اچتمل بالا در مرورگر يا Brower تان ( معمولا اينترنت اکسپلورر و يا نتسکيپ نويگيتور ) کافی است که از روی منوی File/Open file فايل بالا را از روی محل ذخيره شده بخوانيد. ( به آدرس فايل در قسمت Address توجه کنيد، مثلا c:\test.html)
يکی از مهمترين وظايف مرورگرها نمايش صفحات اچتمل ميباشد، چه اين صفحات روی کامپيوتر شما ذخيره شده باشند و يا اينکه از اينترنت خوانده شوند. با کليک روی اين لينک فايلی شبيه فايل ذخيره شده توسط شما از روی وب سرور توسط مرورگرتان خوانده شده و سپس نمايش داده خواهد شد!!! ( به آدرس فايل در قسمت Address توجه کنيد، مثلا http://www.khaterat.com/html/dars/test.html )

توضيح مثال بالا

اولين تگ مثال بالا تگ <html> ميباشد. از روی اين تگ، مرورگر نوع متن يعنی اچتمل بودنش را يافته و از روی <html/> انتهای متن اچتمل را ميبابد.

متن بين تگ <head> و تگ <head/> اطلاعات شناسنامه ای يا "Header information" متن اچتمل بوده و نمايش داده نخواهند شد. در اين مثال با کمک تگهای <title> و <title/> تيتر و يا Title صفحه که در اين مثال عبارت "Title of page" ميباشد در بالای مرورگر نمايش داده خواهد شد.

متن بين تگ <body> و انتهای آن يعنی تگ <body/> تنها اطلاعاتی است که توسط مرورگرنمايش داده خواهند شد.

متن بين تگ <b> و انتهای آن يعنی تگ <b/> بصورت Bold و يا توپر نمايش داده خواهند شد.

انشعاب فايل htm يا html ؟

اغلب مرورگرها هر دو نوع انشعاب را به خوبی ميشناسند ولی ترجيحا به هنگام ذخيره فايلهای اچتمل از html استفاده کنيد.( استفاده از انشعابهای سه حرفی مانند htm مربوط به قديم و سيستم عاملهائی چون DOS بودند.)

نکته ای در مورد اديتورهای اچتمل ( HTML Editors )

با وجوديکه با استفاده از اديتورهای اختصاصی اچتمل مانند FrontPage و يا Claris Home Page امکان نوشتن و طراحی صفحات اچتمل بصورت WYSIWYG يا "What You See Is What You Get" وجود دارد اما توصيه ميشود که از اديتورهای معمولی متن برای تهيه صفحات خود استفاده کرده، عملکرد تگها را شناخته و هيچگاه بدون اينکه بدانيد کاربرد يک تگ چيست آنرا بکار نبريد.

بيشترين سوالات پرسيده شده ( FAQ ) :

فايلم را درست کردم ولی هنوز نميتوانم آنرا در صفحه مرورگرم ببينم، مشکل کجاست؟
مطمئن شويد که فايل را با انشعاب درست (htm يا html ) ذخيره کرده ايد. در ضمن مطمئن شويد که همان فايل را Open کرده ايد.( نام و مسير فايل را در قسمت Address مرورگرتان چک کنيد.)

هر بار پس از تغيير و اديت مثالها نسخه اوليه را در صفحه مرورگرم ميبينم و تغييرات داده شده مشاهده نميشود، مشکل کجاست؟
به خاطر بالا بردن سرعت، هميشه مرورگرها از نسخه های موجود در Cache يا حافظه موقت خود برای خواندن صفحات استفاده ميکنند.برای وادار کردن مرورگر به خواندن اصل صفحه کافی است که در مرورگرتان Refresh/Reload کنيد. در اينترنت اکسپلورر کليد F5 يا View/Refresh و در نت اسکيپ Ctrl+R يا View/Reload اينکار را انجام خواهند داد.

آيا ميتوانم از هر دو مرورگر Internet Explorer و Netscape Navigator استفاده کنم؟
بله، فقط اگر از استاندارد يونيکد برای فارسی نويسی استفاده ميکنيد، برای ديدن درست صفحات فارسی بايد از نسخه 5 Internet Explorer و به بالا و در مورد Netscape Navigator از نسخه 6.2 و به بالا استفاده کنيد.

کجا ميتوانم آخرين نسخه از مرورگرهای Internet Explorer و Netscape Navigator را داونلود کنم؟
Internet Explorer اينجاست و Netscape Navigator اينجا.

درس قبلی، درس بعدی

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


HTML in Persian, Basic Tags, Tables, Frames, Javascript, DHTML - Stock Photos

﻿
پيوندهاي مفيد :

- فارسی وب
- farsinuke.com
- سبلان
- آقا مجید رو خط

- Google Webmasters
- Slashdot.org
- Source Forge
- hamedbanaei.com

- chami.com
- Web Monkey
- unicode.org
- persiantalk.com

- Topxml
- freshmeat.net
- webmasterworld.com
- V. Builder

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


مثالهای فارسي اچتمل در اينترنت - Sample HTML files in Persian / Farsi

﻿
مثالهای اچتمل
  1. مثالی ساده از يک صفحه اچتمل
  2. پاراگرافهای ساده با استفاده از عنصر p
  3. نمايش متون فارسی
  4. مثال پاراگرافها و نحوه برخورد مرورگر با فاصله های اضافی
  5. ترازبندی پاراگراف ها با کمک شناسه align
  6. رفتن سر سطر جديد با کمک تگ br
  7. سر تيترها و تکهای h1 تا h6
  8. ترازبندی سر تيترها با استفاده از شناسه align
  9. نمايش خطوط افقی با کمک تگ hr
  10. نحوه استفاده از comment
  11. تعيين رنگ زمينه صفحه با کمک شناسه bgcolor در تگ body
  12. متن های فارسی با کمک شناسه dir
  13. متون فارسی و لاتين در کنار هم
  14. شناسه dir در عنصر html
  15. مثالی کامل در مورد استفاده از شناسه dir در عناصر مختلف
    فرمت دهی (Formating)
  1. شکل دهی متون با کمک تگهای b, strong, big, em, i, small, sub, sup
  2. متون از قبل شکل دهی شده با کمک عنصر pre
  3. عناصر ديگر شکل دهی متن (code, kbd, tt, samp, var)
    پيوندها (Links)
  1. ايجاد پيوندها با کمک متن
  2. ايجاد پيوندها با کمک تصاوير(img)
  3. باز کردن پيوند در پنجره ای جديد با کمک شناسه target
  4. ارجاع به قسمت ديگری از صفحه با کمک پيوندهای نامگذاری شده
  5. رهائی از شر فريم ها با کمک شناسه target
  6. نحوه ايجاد يک پيوند mailto
  7. مثالی کاملتر در مورد mailto
    جداول (Tables)
  1. انواع جداول با کمک المان Table
  2. تعيين مرز جداول با کمک شناسه border
  3. تعيين جهت نمايش متون در جداول با کمک شناسه dir
  4. تعيين عنوان يک جدول با کمک المان caption
  5. توسعه سطری يا ستونی در جداول با کمک شناسه های colspan و rowspan
  6. جدولی با محتويات مختلف در هر خانه
  7. ايجاد فاصله بين خانه های جدول با کمک شناسه cellspacing
  8. ايجاد فاصله خالی بين خانه های جدول و مرز آنها را با کمک شناسه cellpadding
  9. نحوه تعيين رنگ زمينه يا تصوير زمينه در خانه های جداول
  10. نحوه تعيين رنگ زمينه يا تصوير زمينه خانه های جداول
  11. نحوه تعيين ترازبندی در خانه های جداول با کمک شناسه align
  12. روشهای مختلف تعيين مرز جداول با کمک شناسه frame
  13. ترازبندی محتوای خانه های جداول با کمک شناسه "align" و "valign"
    فريمها (Frames)
  1. مجموعه فريمهای عمودی
  2. مجموعه فريمهای افقی
  3. مجموعه فريمهای مرکب
  4. مثالی کاربردی در مورد فريمها
  5. فريمهای شناور و يا درجا (Inline frame)
  6. مثالی کاربردی در مورد فريمهای شناور و درجا (iframe) با کمک 7 صفحه اچتمل مختلف
  7. مثالی در مورد نمايش محتويات درايو لوکال (مثلا c:\) بازديدکنندگان سايت به آنها
  8. فريمها و پيوندهای نامگذاری شده
  9. فريمها و پيوندهای نامگذاری شده کامل
    فهرستها (Lists)
  1. مثالی بسيار ساده در مورد فهرستهای نامرتب
  2. مثالی در مورد فهرستهای مرتب و نحوه نمايش متون فارسی
  3. فهرستهای مرتب و استفاده از شناسه type جهت تعيين نوع نمايش فهرست
  4. فهرستهای نامرتب و استفاده از شناسه type جهت تعيين نوع نمايش فهرست
  5. مثالی در مورد فهرستهای ترکيبی. اعضای فهرست ميتوانند از فهرستهای ديگر تشکيل شوند.
  6. مثالی در مورد فهرستهای تعريفی به همراه استفاده از شناسه dir
    فرمها (Forms)
  1. مثالی ساده در مورد ايجاد text field ها
  2. وروديهای رمز عبور يا Password fields
  3. حالتهای مختلف ورودی Input
  4. مثالی در مورد نحوه تعريف فرمی متشکل از Checkbox ها
  5. مثالی در مورد نحوه تعريف فرمی متشکل از Radiobutton ها
  6. مثالی در مورد نحوه تعريف فرمی متشکل از drop down box ها
  7. مثالی در مورد نحوه تعريف فرمی متشکل از drop down box ها با تعيين پيش گزينه
  8. مثالی در مورد نحوه تعريف فرمی متشکل از Textarea ، ناحيه ای برای ورود بيش از يک سطر متن
  9. مثالی در مورد نحوه تعريف فرمی با کمک دکمه يا button
  10. نحوه تعريف فرمی دلخواه و ترسيم مرزی بدور آن به همراه تعيين عنوانی برای فرم با کمک عنصر Fieldset
  11. مثالی در مورد نحوه ارسال ايميل با کمک فرمها
  12. مثالی کاربردی در مورد نحوه ساختن فهرستی از سايتهای مورد علاقه
    تصاوير (Images)
  1. نحوه درج تصاوير با کمک تگ img
  2. درج تصويری واقع در فضای آدرسی ديگر
  3. نحوه تعيين تصاوير زمينه با کمک شناسه background در تگ body
  4. نحوه ترازبندی تصاوير در کنار متون
  5. تصاوير شناور در متن
  6. استفاده از شناسه های width و height و نمايش تصاوير در ابعاد مختلف
  7. مثالی در مورد استفاده از شناسه alt در تگ img
  8. نحوه استفاده از تصاوير هنگام ايجاد پيوند ها
  9. ايجاد image map ها
    تصاوير و رنگ پس زمينه
  1. انتخاب رنگ پس زمينه با کمک شناسه bgcolor
  2. مثالی از انتخاب نامناسب رنگ متن و پس زمينه
  3. استفاده از تصوير زمينه با استفاده از آدرس مطلق تصوير
  4. استفاده از تصوير زمينه با استفاده از شناسه backround
  5. تعيين رنگ زمينه با Style Sheet ها
    روشهای جایگزین برای تگ <font> با استفاده از Style sheet ها
  1. مثالی در مورد تعیین نام قلم در یک استیل درجا (inline)
  2. مثالی در مورد تعیین اندازه قلم در یک استیل درجا (inline)
  3. مثالی در مورد تعیین رنگ قلم در یک استیل درجا (inline)
  4. مثالی در مورد تعیین نام، اندازه و رنگ قلم در یک استیل درجا (inline)
  5. مثالی کاربردی در مورد نحوه تعریف استیلهای مختلف نمایش متون در جداول

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


مراجع و رفرنسهاي اچتمل به فارسي در اينترنت - HTML Refrences

﻿
مراجع و رفرنسها

فرهنگ لغت واژه های فنی در وب
Anchor | پیوند، لينک، (لنگر كشتی)
Attribute | شناسه، نشان، صفت
Browser, user agent | مرورگر، شبکه نورد، بروزر
Caption | عنوان ، سرلوحه
Character | نويسه، کاراکتر، دخشه
Client | سرويس گيرنده، مشتري ، ارباب رجوع
DHTML | اچتمل ديناميک، FAQ
Division, Div | بخش، قسمت، دسته بندی
Download | گرفتن اطلاعات از وب سرور
Document | سند، متنی اچتمل
Edit | ویرایش
Element | المان، عنصر
Explorer | جستجوگر، مكتشف
Extention | انشعاب فايل
FAQ | بيشترين سؤالات پرسيده شده در مورد يک موضوع
Font | قلم، خانواده حروف
Format | قالب، فرمت
Frame | قاب، چهارچوب
Frameset | مجموعه ای از فريمها
FTP | استانداردی برای مبادله فايل (File Transfer Protocol)
href | آدرس متن مختلط (hyerlink reference)
IP | Internet Protocol
JavaScript | جاوا اسکريپت، زبانی برای اسکريپت نويسی
HTTP | استاندارد تبادل ابر متن ها (Hypertext Transfer Protocol)
Hyper text | ابر متن، متن مختلط
List | فهرست
Link | پيوند، لينک
Online | آنلاين، سرخط
Padding | لايه گذاری، لفافه
Page, Web page | صفحه، متن
Publish | انتشار، بردن اطلاعات روی وب سرور
Protocol | استاندارد ارتباطی، فهرست پروتوکلهای مهم در اينترنت
Robot | نرم افزاری خودکار در وب
Site. Web site | پايگاه، سايت
Script | اسکريپت، دستخط، متن نمايشنامه
Spacing | فاصله گذاري ، فاصله
Span | محدوده، گستره، وجب
Target | هدف و مقصد
Table | جدول، آرايه
Tag | تگ، برچسب
TCP/IP | نوعی استاندارد ارتباطی (Transmission Control Protocol/Internet Protocol)
Unicode | استانداری برای محيط های چند زبانه
Upload | بردن اطلاعات روی وب سرور، معمولا با کمک نرم افزارهای FTP انجام ميپذيرد.
URL | آدرس اينترنتی، خلاصه شده Uniform Resource Locator
User, Surfer | کاربر، وبگرد، بازدیدکننده
Weblog | وب نويسی، تارنگاری
Webmaster | مدیریت سایت
Web Server | سرويس دهنده وب، نرم افزاری که وظيفه اصليش دادن سرويس به درخواستهای دريافت شده از وب ميباشد.
Web, WWW | وب، تار عنکبوت جهانی، خلاصه شده World Wide Web

  • سايتهائي مرجع براي يادگيري اچتمل :

    1) Welcome to HTML School
    2) Getting Started
    3) Authoring HTML Basics
    4) Getting started with HTML
    5) A Beginner's Guide to HTML
    6) HTML Tutorial
    7) HTML Tag Quick Reference Guide
    8) HTML FAQ Knowledge Base
    9) HTML 4.01 Specification

    • ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


آموزش اچتمل اينترنت و وب به فارسي در مدرسه وب - آموزش طراحی سایت

﻿
سرفصل مطالب :

به کلاس اچ تی ام ال مقدماتی خوش آمديد!

يادگيری زبان HTML بسيار ساده است.در اين درسها ياد خواهيد گرفت که چگونه با کمک HTML صفحاتتان را ساخته و وب سايت شخصی فارسی و يا وبلاگتان را راه اندازی کنيد. مبنای اين دروس نسخه 4 استاندارد اچتمل بوده و نکته بسيار مهم اين نسخه جداسازی فرمت بندی و انتقال آن به style sheet ها ميباشد. لازم به توضيح است که که تاکيد دروس و مقالات اين راهنما بر فارسی نويسی مطابق استاندارد يونيکد بوده و اولين مجموعه دروس آموزشی ما شامل آموزش مقدماتی HTML بهمراه مثالهای متعدد فارسی نويسی خواهد بود. ادامه اين بخش به شرح سرفصل مطالب ارائه شده خواهد پرداخت:

درس بعدی

سرفصل مطالب کلاس اچتمل مقدماتی :

  • مقدمه
    در اين درس با ويژگيهای فايلهای اچتمل، اجزا تشکيل دهنده آن يعنی عناصر و تگ ها ( Elements & Tags ) و نحوه ايجاد يک فايل ساده و نمايش آن در صفحه مرورگرتان آشنا خواهيد شد.

  • HTML & WWW
    در اين درس با مفاهيم وب ( تار عنکبوت جهانی يا World Wide Web ) ، اينترنت، مرورگرها و استانداردهای وب آشنا خواهيد شد. همچنين با تفاوتهای مرورگرهای وب ( Web Browsers ) و سرويس دهنده های وب ( Web Servers ) آشنا خواهيد شد.

  • عناصر ( Elements )
    يک متن و يا فايل اچتمل از عناصر يا element ها تشکيل ميشود و برای ايجاد عناصر از تگ ها يا tags استفاده ميشود. در اين فصل با عناصر و تگ ها آشنا خواهيد شد.

  • تگ های اصلی ( Basic Tags )
    تگ ها ( tags ) اجزا تشکيل دهنده عناصر يا elements های اچتمل هستند و يکی از بهترين روش های يادگيری اچتمل ديدن مثالها و تغيير آنها ميباشد. در اين فصل با تگ های پايه و مهم آشنا شده و با کمک اديتور اختصاصی ما و با امکانات فارسی نويسی آن به صورت آنلاين ميتوانيد به مطالعه و يادگيری مثالها بپردازيد.

  • فــارسی نويسی
    در اين درس با فارسی نويسی، فارسی سازی و استاندارد يونيکد و نحوه استفاده از اديتور آنلاين و فارسی اين سايت آشنا خواهيد شد.

  • فرمت دهی ( Formatting )
    وظيفه گروهی از تگ های اچتمل فرمت دهی و تعيين شکل نمايش متون ( مثلا توپر و bold بودن و يا ايتاليک بودن ) ميباشد و در اين درس با اين گروه از تگهای formating آشنا خواهيد شد. همچنين ياد خواهيد گرفت که چگونه source يا اصل کدهای اچتمل يک صفحه يا page را ببينيد.

  • نهادها ( Entities )
    گروهي از نويسه های ( Character ) اچتمل مانند (<) و يا (>) دارای معنی خاصی ( مثلا نويسه < شروع يک تگ را نشان ميدهد. ) در استاندارد اچتمل بوده و برای نمايش آنها در صفحاتتان مستقيما قابل مصرف نميباشند. در اين فصل با اين نويسه ها آشنا شده و با کمک Character Entities چگونگی استفاده از اين گروه از نويسه ها را فرا خواهيد گرفت.

  • پيوندها ( Links )
    در اين درس با پيوندها ( Links ) ، شناسه های مرتبط مخصوصا href و نحوه به کار گيری آنها آشنا خواهيد شد.

  • جداول ( Tables)
    در اين درس با مفاهيم جدول ( Table ) ، رديف يا row ، سلولها يا خانه ها، مرز يا border در جداول و عناصر مرتبط مخصوصا TABLE ، TD , TR آشنا خواهيد شد.

  • فريمها ( Frames )
    در اين درس با مفاهيم فريم ( Frame ) و عناصر مربوطه مخصوصا Frame و Frameset آشنا خواهيد شد.

  • فهرستها ( Lists )
    اين درس شما را با نحوه نمايش فهرستها ( List ) ، انواع فهرستها و تگ های مربوطه آشنا خواهد ساخت.

  • فرمها ( Forms )
    از طريق استفاده از تگ های فرم ( form ) قادر به دريافت اطلاعات از بازديدکنندگان صفحاتتان و يا تبادل اطلاعات بين صفحات مختلف خواهيد شد. با کمک اين گروه از تگ ها قادر به نمايش باکسهای ورود اطلاعات متن (text fields) ، چک باکسها (check-boxes) ، راديو باتونها (radio-buttons) و ... شده و همچنين امکان گذاشتن دکمه های ارسال (submit button) و يا حذف (reset) را خواهيد داشت. اين فصل با شرح تگ های form و input و ... به چگونگی ايجاد ارتباط با بازديدکنندگان و گرفتن اطلاعات از آنها خواهد پرداخت.

  • تصاوير ( Images )
    در اين درس با عنصر img و چگونگی نمايش تصاوير و همچنين تنظيم محل آنها آشنا خواهيد شد.

  • پس زمينه ( Background )
    در اين درس با چگونگی نمايش تصاوير و يا تعيين رنگ پس زمينه آشنا خواهيد شد.

  • مثالهای اچتمل
    با استفاده از دهها مثال موجود در اين سايت و با کمک اديتور HTML ما براحتی قادر به نوشتن کدهای HTML و ديدن نتايچ در مرورگرتان خواهيد بود، آزمايش کنيد!

  • FAQ HTML
    اين صفحه به بيشترين سؤالات پرسيده شده در مورد اچتمل ( Frequently Asked Questions ) و مخصوصا مشکلات مربوط به فارسی نويسی و پاسخهای آنها اختصاص دارد.

  • مراجع
    فهرستی کامل از منابع و مرجعهای مختلف شما را در يافتن پاسخ سؤالهايتان ياری خواهد داد. در اين صفحه فهرستی کلمل از سايتهای مرجع و آموزشی اچتمل را خواهيد ديد. فرهنگ لغت واژه های فنی نيز در اين بخض قرار دارد.
    درس بعدی

    رجوع به : ^^ اول صفحه ^^

    • ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


استایل شیتها در اينترنت و اچتمل - - Style Sheets in HTML in Persian / Farsi

﻿
استایل شیتها ( Style Sheets )

در نسخه جدید(4/0) اچتمل امکان جداسازی کامل فرمت دهی از ساختار صفحات اچتمل فراهم شده است. در این نسخه توصیه میشود که تمامی اطلاعات مربوط به نمایش و ترازبندی به فایلهائی مجزا از صفحه اچتمل منتقل شوند. بخشی از صقحات اچتمل که مربوط به نمایش، ترازبندی و فرمت دهی است، استایل شیت یا "Style Sheet" نامید شده و معمولا به صورت فایلی مجزا درون بخش <head> صفحات اچتمل معرفی میگردند. در این درس به صورت بسیار خلاصه با روشهای مختلف استفاده از استایل شیتها در صفحات اچتمل آشنا خواهید شد.

درس قبلی، مثالهای اچتمل

مثالها

استیلها در اچتمل
در این مثال نحوه تعریف استایل شیتها درون بخش <head> صفحات اچتمل شرح داده شده است. (Internal Style Sheet)

پیوندی بدون خط افقی زیری
در این مثال نحوه ایجاد پیوندی بدون "خط افقی زیری" شرح داده شده است. (Inline Styles)

اتصال به فایلهای استایل شیت خارجی
در این مثال نحوه استفاده از تگ <link> جهت اتصال به فایلهای استایل شیت خارجی شرح داده خواهد شد. (External Style Sheet)

چگونگی استفاده از استایل شیتها:

مرورگرها از روی استیلهای تعریف شده توسط استایل شیتها به فرمت دهی و نمایش اطلاعات درون صفحه اچتمل میپردازند. تعریف و استفاده از استایل ها در صفحات اچتمل به سه روش مختلف ممکن میباشد:

1)استایل شیتهای خارجی (external style sheet) :

در این روش تمامی استیلها و تعاریف نمایشی درون فایلی جداگانه قرار گرفته و بسیار مناسب حالتهائی است که قرار است که استایلی به بیش از یک صفحه اچتمل اعمال شود. مزیت این روش سهولت در تغییر ظاهر صفحات یک وب سایت میباشد و برای یک تغییر کلی در سایت کافی است که فایل استایل شیت کل سایت که معمولا یک فایل واحد است تغییر داده شود. (باید توجه داشت که در این حالت تمامی صفحات سایت باید به یک فایل استایل شیت واحد لینک شده باشند.) استایل شیتهای خارجی توسط تگ <link> که درون بخش head صفحات اچتمل قرار میگیرد، معرفی میشوند.
در مثال زیر با کمک شناسه href از تگ link نام و در حالت کلی url فایل در برگیرنده استایلهای تعریف شده تعیین میگردد:

<head>
<link rel="stylesheet" type="text/css" href="mystyle.css">
</head>

2)استایل شیتهای داخلی (Internal Style Sheet) :

کاربرد این روش در حالتهائی است که صفحه اچتمل نیازمند تعریف استایلی منحصر به فرد و مجزا بوده و استایل طراحی شده فقط بدرد آن صفحه خواهد خورد. در این حالت باید کدهای حاوی تعریف استایل درون تگ های <style> و <style/> قرار گرفته و معمولا نتیجه درون بخش head صفحه اچتمل گذاشته میشود.مثال:

<head>
<style type="text/css">
body {background-color: red}
p {margin-left: 20px}
</style>
</head>

3)استایل شیتهای درجا (Inline Styles) :
کاربرد این روش در مواردی است که باید برای یک المان (یا گروهی) خاص استایلی اعمال شود. در این حالت باید از شناسه ای به نام style که تقریبا در تمامی تگها قابل اعمال است استفاده شود. مثال:

<p style="color: red; margin-left: 20px">
This is a paragraph
</p>

تگ های استایل
Start Tag | Purpose | کاربرد
<style> | Defines a style in a document | تعریف استیلها درون یک سند
<link> | Defines the relationship between two linked documents | تعیین و تعریف فایل استایل شیت خارجی
<font> | Deprecated. Use styles instead | کنار گذاشته شده.از استایل شیتها استفاده شود.
<basefont> | Deprecated. Use styles instead | کنار گذاشته شده.از استایل شیتها استفاده شود.
<center> | Deprecated. Use styles instead | کنار گذاشته شده.از استایل شیتها استفاده شود.

مرجع : HTML 4.01 Specification - فهرست عناصر - فهرست شناسه ها

تغییرات در نسخه جدید اچتمل (4/0) :
هدف اولیه از طراحی زبان اچتمل ایجاد زبانی برای تعریف اطلاعات محض بدون در برداشتن جزئیات مربوط به فرمت و نمایش بود ولی با ایجاد نسخه 3/2 زبان اچتمل و اضافه شدن تگهای فرمت دهی مانند <font> و یا شناسه هائی مانند color و Align محتوا و نمایش در صفحات اچتمل ادغام گردیده و همین امر سبب بروز مشکلات عدیده ای برای طراحان و برنامه نویسان وب گردید. برای رفع این مشکل در نسخه 4/0 اچتمل توصیه بر جداسازی کامل این دو گروه از اطلاعات بوده و در نسخه های آینده اچتمل این جداسازی اجباری خواهد گردید و توصیه مدرسه وب نیز استفاده از استایل شیتها برای هر نوع تعریف فرمت و ترازبندی میباشد. برای مثال در کد اچتمل زیر که بر اساس نسخه 3/2 اچتمل میباشد، ساختار و محتوا (تگی از نوع پاراگراف با محتوای "This is a paragraph") با اطلاعات نمایش یعنی رنگ و ترازبندی (رنک قرمز متن و ترازبندی در وسط صفحه) همزمان و در کنار هم آورده شده اند و این ادغام امکان تغییر و توسعه کد را بسیار محدود خواهد کرد:

<p align="center"><font color="red">This is a paragraph</font></p>

کد معادل مثال فوق با استفاده از استایل شیتها در این مثال شرح داده شده است.(هر چند که این مثال از تمامی امکانات استایل شیتها و ایجاد فایلی کاملا مستقل برای تعریف استایل استفاده نکرده است.)

درس قبلی، مثالهای اچتمل

^^ بالای صفحه ^^

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


HTML in Persian, Basic Tags, Tables, Frames, Javascript, DHTML - Stock Photos

متفرقه
- سري به سايت archive.org بزنيد، سايتي که روزانه کل اينترنت را آرشيو و ذخيره ميکند!!! ميتوانيد تصورش را بکنيد که هر روز چند صد هزار گيگابايت ميشود؟؟؟ لامذهب ها از سال 1996 اين کار را ميکنند، به چه هدفي خدا ميداند!؟ شايد تدارک نامه اعمالمان براي جهنم باشد. نام سايتتان را وارد کنيد، مطمئنم که وبلاگهاي فارسی حداقل ماهی يکبار آرشيو ميشوند.(راستي يه نکته: اگر فايلهاي سايتتان را از دست داديد و پاک شدند، يه راه بازيابي همين سايت archive.org ميتونه باشه!!!) حتماّ ميدونيد که يکی از tag های قسمت head ميتونه از آرشيو شدن سايتتون توسط روبوتها جلوگيري بکنه؟!

- ... أهلا وسهلا !!
کميته اي از کشورها و شرکت هاي عربي به نام arabicdomainname.org شديداّ پيگير استفاده از اسامي و نامهاي اينترنتي عربي(Arabic Domain) هستند و در آينده نزديک امکان ثبت domain هاي عربي هم فراهم خواهد شد.(مثلا براي دومين خاطرات احتمالاّ تايپ خواهيد کرد: " پرو://ووو.خاطرات.کام " (ايران، افغانستان و ديگرکشورهاي فارسي زبان هم بايد بجنبند که دير است!)

- سايت conferenceroom.com يکي از بهترين سايتهاي ارائه کننده سرويس هاي Chat ميباشد که در يک حالت ساده اش امکان اضافه کردن سرويس Chat را بصورت مجاني برايتان فراهم ميکند.(حالت backpack آن Free است.) اگر ميخواهيد که سايتتان chat دار! شود بايد فرم بسيار ساده ای را پر کرده و کد HTML مربوطه تحويلتان خواهد شد.

- اگر در صفحه about us اين سايت دقت کنيد ، عمداّ آدرسهاي ايميل را درست ننوشته اند و از "dot" و "at" به جاي . و @ استفاده کرده اند ، چرا؟ جواب به همان روبوتهاي موذي برميگردد!!. يکي از کارهائي که روبوتها انجام ميدهند يافتن آدرسهاي ايميل از درون صفحات HTML و سپس فروش اين ليستها به شرکتها و اشخاص براي بازاريابي و امثالهم ميباشد و به همين دليل مسئولين سايت جهت جلوگيري از يافته شدن آدرسهاي ايميلشان توسط روبوتها از "dot" و "at" به جاي . و @ استفاده کرده اند. (اگر شما هم هر روز مثل من دهها ايميل بي ربط دريافت ميکنيد، شايد کار همين روبوتها باشد، مثلاّ کافي است جائي guestbook ي را امضا کرده و آدرس ايميلتان را وارد کرده باشيد و ...)

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


HTML in Persian, Basic Tags, Tables, Frames, Javascript, DHTML - Stock Photos

ASCII art
هر نوع کار يا اثر هنري که با استفاده از مجموعه کاراکترهاي ASCII ترسيم شده باشد اسکي آرت(ASCII art) ناميده ميشود و شايد بتوان گفت که دههاهزار اثر هنري با کمک همين کاراکترهاي به ظاهر ساده ترسيم شده اند که در عين ساده گي بسيار بسيار هنرمندانه طراحي شده اند.براي نمونه :

  • يک page خوب FAQ براي سؤال و جوابهاي مربوط به اسکي آرت
  • نمونه کارهاي مختلف اسکي آرت توسط افراد مختلف
  • يک page خوب ديگه رفرنس براي اسکي آرت با کلي راهنمائي
  • اين سايت هم يک برنامه داره براي تبديل هر نوع متن يا تصوير به اسکي آرت

    ... خلاصه اينکه با کمک مجموعه کارکترهاي ASCII ميشه خيلي کارها کرد، مثلا از کاراکترهاي فارسي استفاده کرد. بنابراين اگر در مورد موضوعات مربوط به ايران يا کلمات فارسي چيزي طراحي کرديد، حتما براي اين صفحه بفرستيد چونکه به احتمال زياد يه آرشيو از نمونه کارهاي ايراني اينجا خواهيم داشت، به اميد اون روز!

    • ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


بيل گيتس - Bill Gates, Farsi Tarnegari / Weblog FAQ in Persian / Farsi

بيل گيتس
در مورد ميزان ثروت بيل گيتس سهامدار اصلي شرکت مايکروسافت صدها مقاله جالب در اينترنت ميتوان يافت که شايد اشاره به بعضي از نکات آنها خالي از لطف نباشد:
  • بسته به ارزش روز سهام شرکت مايکروسافت، ثروت بيل کم و زياد ميشود و در حال حاضر حدود 44 ميليارد دلار آمريکا است!(زماني بيش از 100 ميليارد بود.)
  • 7 سال متوالي است که بيل گيتس ثروتمندترين مرد جهان است.
  • متوسط درآمد بيل از شروع کار شرکتش تا کنون حدود ثانيه اي 300 دلار است.
  • اگر به بيل بگويند که ديگر کار نکن و هر روز 8 ساعت اسکناسهاي 1000 دلاري از زمين بردار به ضررش تمام خواهد شد!!( با فرض 4 ثانيه براي برداشتن هر اسکناس)
  • با نرخ رشد فعلي تقريبا 10 سال ديگر بيل تريليونر خواهد شد و هنگام مرگ حدودا 431 تريليون دلار خواهد داشت!!(يک تريليون دلار معادل 800،000،000،000،000 تومان ميشود.)
  • شرکت مايکروسافت حدود 50،000 کارمند دارد و تعداد زيادي از بهترين برنامه نويسانش هندي هستند.
    ... براي نکات خواندني بيشتري در مورد ثروت بيل ميتوانيد اين صفحات (brad و evan) را بخوانيد.

    لازم به ذکر است که هر چند که قسمتي از اين ثروت هنگفت مربوط به خوش فکري و تيز هوشي بيل گيتس و مديران شرکت مايکروسافت ميباشد، اما قسمت عمده آن به انحصار طلبي، قانون شکني و رقيب کشي هاي بي رحمانه شرکت مايکروسافت بر ميگردد و اين موضوع بارها و بارها در دادگاهاي مختلف ثابت شده است.

    ... و اما ما را چه حاصل؟ هيچ! مايکروسافت مدتي است که بزم جديدي را شروع کرده به نام "تکنولوژي NET." و همين باعث علافي و سردرگمي دهها هزار برنامه نويس Java و ديگر زبانهاي کامپيوتري خواهد شد!!!

    *** در طول خواندن اين يادداشت توسط شما، 24 ميليون تومان(30،000 دلار ) به ثروت آن فلان فلان که خيرترين مرد جهان نيز هست افزوده شد!!!

    • ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


ثبت دومين يا دامنه - Domain registeration / Weblog FAQ in Persian / Farsi

Domain Registeration
- سايت godaddy.com ارزانترین، پر طرافدارترین و بهترین سایت برای ثبت دومین با انشعابهای مختلف بوده و توصیه میکنم که اگر برای وبلاگتان یا وب سایت شخصیتان میخواهید دومینی ثبت کنید از انشعابهای جدید .name یا .ws استفاده کرده و از .com یا .biz که معرف سایتهای تجاری است اجتناب کنید. توجه داشته باشید که نامهای فارسی بسیار خوب ثبت نشده ای با انشعابهای .name یا .ws میتوان یافت. در ضمن اگر قبلا دومینی را ثبت کرده اید میتوانید حتی قبل از اتمام مدت ثبت آنرا به سايت مذکور انتقال (Transfer) کرده و مثلا سالی 35 دلار به Register.com نپردازید!

- يکي از سايتهاي خوب براي دين اسامي دومين هاي ثبت شده و احتمالاّ گرفتن ايده براي domain مورد نظرتان سايت domainsurfer.com ميباشد. با کمک اين سايت مثلاّ ليست کل domain هائي که با حروف iran شروع ميشوند را ببينيد، جالب است حدود 1000 دومين ثبت شده که البته اکثرشان غير فعال هستند.(اگر باور نداريد اسامي زير فلش ماوس هستند.)

- تاکنون بيش از 31 ميليون domain ثبت شده اند و خدا ميداند چند تايشان مال ايراني ها است.در ضمن به ياد داشته باشيد که اگر بيشتر از حدود 9 دلار در سال براي ثبت domain تان ميدهيد کلاه سرتان رفته است(البته براي org, net و com ها)

- آيا حدس ميزديد که اسامي چون پشگل، قرتي، بربري، عروس،بدهي ، خاطــــــــــــــرات، چائي ، عنکبوت ، باحال ، پنجه طلا ، دايـــــــــــــــه و اسامي فارسي ديگري که خيلي مؤدبانه نيستند، ثبت شده باشند و سايتهايشان هم فعال باشد!!!(همين خاطرات دات کام لعنتي يک ماه پيش ثبت شد! بنابراين از يافتن اسامي خوب فارسي نااميد نشويد.)

- netfactual.com هم اطلاعات آماري خوبي در مورد domain ثبت شده ارائه ميدهد، يادتان باشد براي بعد. در ضمن اين سايت هم کلي سؤال و جواب خوب(FAQ) در مورد ثبت domain ها دارد، حتماّ نگاهي بيندازيد.

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


HTML in Persian, Basic Tags, Tables, Frames, Javascript, DHTML - Stock Photos

چند لينک مفيد
* در راستاي نبوي زدگي بعضيها (بر وزن بلا و مصيبت زدگي) موارد و لينکهاي ذيل جهت اچتمل کاران عزيز معرفیميگردند:

  • html-color-codes.com حاوي کد هگزاي 216 رنگ safe در اينترنت
  • webmonkey سايتي کامل وخودآموز براي برنامه نويسي در اينترنت
  • bignosebird.com آنچه شما خواسته ايد برنامه نويسي در اينترنت! حاوي کلي برنامه مجاني
  • bootdisk.com اگر ديسک bootable لازم خواهيد داشتيد اين سايت را فراموش نکنيد.
  • html_cheatsheet راهنماي سريع تگهاي HTML

    * اگر بدنبال نرم افزاری برای دسته بندی و نمايش تصاوير گرافيکی هستيد حتما نرم افزار irfanView را داون لود کرده و استفاده کنيد. irfanView تحت ويندوز کار کرده بسيار کم حجم و سريع است و امکانات بسيار جالبی برای کارهای گروهی دارد مثلا ميتوانيد گروهی از تصاوير را به صورت اسلايد نمايش داده و يا دسته اي از تصاوير را با يک فرمان ساده resize کرده و همزمان تغيير نام دهيد و يا حتي فايل HTML براي آنها بسازيد.( برای تصاوير روز همين سايت , در چشم بهم زدنی 400 تصوير را کوچک کرده و پس از اصلاح کيفيت از يک تا 400 مجددا نامگذاري کرد! چيزي که با فتوشاپ حداقل برای من ساعتها طول ميکشيد.)

    • ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


متا تگ ها - HTML Meta tags, Farsi Tarnegari / Weblog FAQ in Persian / Farsi

متا تگ ها
متا تگ ها گروهی از مهمترين tag های صفحات html هستند که در داخل قسمت <head> اين صفحات جای گرفته و بيشتر ، اطلاعات شناسنامه ای صفحه را بيان کرده و گاهی با کمک آنها فرامينی به مرورگر يا browser داده ميشود.تعدادی از پرمصرف ترين اين گروه به شرح زير است:

" keywords" - assign a set of keywords to the document.
روبوتهای موتورهای جستجو يا search engines از روی اين کلمات کليدي سايتتان را index ميکنند.
"description" - specify a summarized description of the document.
شرحی کوتاه و خلاصه از صفحه و محتوايش
"Content-Type" - specify character encoding information.
اين تگ مشخص کننده نحوه رمزگزاری صفحه است مثلاّ charset=utf-8
"refresh" - redirect visitors to another page or reload the current document.
با کمک اين تگ ميتوانيد کاربر يا user را به صفحه ديگري هدايت کنيد ويا صفحه را مجدداْ به روز درآوريد (referesh)
"robots" - instruct Web robots how to index the current document.
اين تگ نحوه برحورد يک روبوت را با صفحه مشخص ميکند.

به عنوان مثال اگر نگاهی به کد اچتمل اين صفحه بيندازيد، کاربرد سه نوع متا تگ مختلف را خواهيد ديد:

- اگر بدنبال جزئيات بيشتری در مورد متا تگها هستيد ، خواندن اين صفحه را به شما توصيه ميکنيم .

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


امنیت در شبکه وب - internet security, Farsi Tarnegari / Weblog FAQ in Persian / Farsi

زيرساختارهاي امنيتي مدرن براي مبادلات در شبكه اينترنت

دكتر شهرام بختياري، استاديار پژوهشكده الكترونيك دانشگاه صنعتي شريف در يك مقاله‌علمي، زيرساختارهاي امنيتي مدرن براي مبادلات در شكبه اينترنت را مورد بررسي قرار داده است.
به گزارش خبرنگار گروه فني مهندسي خبرگزاري دانشجويان ايران (ايسنا) در اين مقاله آمده است: استفاده از رايانه امروزه جزو كارهاي روزمره بسياري از افراد قرار گرفته و در كشورهاي پيشرفته، سيستم‌هاي رايانه‌اي جزو لاينفك زندگي افراد جامعه مي‌باشند. در كشورهاي در حال توسعه از جمله ايران، فرهنگ استفاده از رايانه با سرعت زيادي در حالت شكل‌گيري است و پيش‌بيني مي‌شود كه در آينده‌ي نه‌چندان دور، شاهد همه‌گير شدن استفاده از رايانه در ايران باشيم.
در عصر كنوني استفاده از رايانه به تنهايي قابليت زيادي را براي كاربران فراهم نمي‌كند بلكه عمدتا رايانه‌ها از طريق خطوط تلفني ( dial-up ) و يا شبكه‌هاي محلي (lan) به يكديگر متصل هستند. استقبال جهاني از شبكه اينترنت و وجود ابزار و استانداردهاي مختلف، زمينه‌اي را فراهم آورده تا بتوان كاربران را به راحتي با يكديگر ارتباط داد و منابع و اطلاعات الكترونيكي را درميان آنها از طريق خطوط شبكه‌اي توزيع نمود. حتي مشاهده مي‌شود كه بسياري از اطلاعات با ارزش از قبيل اطلاعات مالي (خريد و فروش) و يا اطلاعات سري نيز از طريق شكبه اينترنت بين كاربران رد و بدل مي‌شوند.
دو مساله مهم كه كاربران شبكه‌هاي كامپيوتري با آنها دست به گريبانند عبارتند از :
‌١- حفظ حريم خصوصي و محرمانگي: كاربران علاقمند هستند كه كارها و ارتباطات آنها غير قابل رديابي توسط ديگران باشد و همچنين پيام‌هايي كه آنها در شبكه مي‌فرستند و يا دريافت مي‌نمايند، قابل فهم توسط مداخله‌گراني كه داده‌هاي رد و بدل شده در مسير شكبه را شنود مي كنند، نباشد.
‌٢- احراز هويت و عدم انكار: كاربران جهت پاره‌اي از مسائل نياز دارند كه از صحت هويت طرف مقابل، اطمينان حاصل نمايند و مطمئن شوند كه كاربري كه با آن تماس گرفته‌اند واقعا همان فردي است كه انتظارش را داشته‌اند. همچنين در بعضي از مسائل، ارسال كننده‌ي يك پيام نبايد بتواند پيامي را كه فرستاده انكار نمايد. اين ابزار همان امضاي معمولي افراد را شبيه سازي مي نمايد.
رمزنگاري به عنوان يك از روش‌هاي قابل اعتماد جهت فراهم آوردن سرويس‌هاي فوق قابل استفاده مي‌باشد. كلمه لاتين cryptography به معني علم نوشتن به رمز مي‌باشد. ولي امروز به صورت كلي‌تري جهت فراهم آوردن ابزارهايي كه مي‌توانند سرويس‌هايي را براي امنيت اطلاعات و داده‌ها ارائه نمايند، استفاده مي‌شود. امروزه رمزنگاري جزو روش‌هاي الزامي در فراهم نمودن امنيت سيستم‌ها و شبكه‌هاي كامپيوتري مي‌باشد و مانند قديم، منحصر به سيستم‌هاي نظامي و بانكي نمي‌شود. در عصر شبكه‌هاي كامپيوتري، هر فرد مي‌تواند از منابع اطلاعاتي خود با استفاده از ابزارهاي امنيتي كه عمدتا توسط سيستم‌هاي رمزنگاري فراهم مي‌شوند، محافظت نمايند.

- سيستمهاي رمزنگاري متقارن و نامتقارن
با وجود اينكه امروزه سيستم‌هاي رمزنگاري براي كاربردهاي مختلفي مورد استفاده قرار مي‌گيرند ولي در ابتدا چنين سيستم‌هايي تنها جهت اختفا و به عنوان ابزاري براي به وجود آوردن محرمانگي پيام، طراحي شده بودند. در يك سناريوي كلي مي توان فضايي را در نظر گرفت كه در آن، كاربر A قصد ارسال پيام P به كاربر B را دارد.
روش كار بدين ترتيب است كه ابتدا كاربر A ا زالگوريتم E جهت رمز نمودن پيام P استفاده مي نمايد. الگوريتم‌هاي رمزنگاري، نياز به يك كليد رمزنگاري (Ke) دارند تا بتوانند از پيامي مانند P، يك خروجي مانند C توليد نمايند كه با پيچيدگي زيادي وابسته به هر دوي P و Ke باشد. كاربر B كه پيام C را دريافت مي‌كند با استفاده از الگوريتم رمزگشايي D و با استفاده از كليد رمزگشايي (Kd) اقدامه به بازنمودن پيام C مي‌نمايد و نتيجه، پيام P خواهد بود.
فرق اساسي ميان سيستم‌هاي رمزنگاري متقارن و نامتقارن اين است كه در سيستم‌هاي رمزنگاري متقارن Kd يا مساوي Ke است و يا به راحتي از آن استنتاج مي شود. در نتيجه كافي است هر دو كاربر A و B، كليد Ke را بدانند تا بتوانند پيام‌هايشان را توسط آن رمز نموده و سپس رمزگشايي نمايند. با توجه به اينكه Ke تنها براي A و B شناخته شده است لذا وقتي كاربر B پيام را باز مي‌كند، مطمئن مي‌شود كه پيام فوق از طرف A است (خاصيت احراز هويت) . با اين وجود A به راحتي مي‌تواند ارسال پيام فوق را انكار نمايد زيرا B نيز مي‌تواند چنان پيامي را به همان شكل، رمز نمايد.
در سيستم‌هاي رمزنگاري نامتقارن، كليدي‌هاي رمزگذاري و رمزگشايي متفاوت هستند. در حقيقت هر كاربر داراي يك زوج كليد مي‌باشد كه يكي كليد عمومي و ديگري كليد خصوصي مي‌باشد. فرض بر اين است كه كليد خصوصي، تنها توسط آن كاربر شناخته شده است ولي كليد عمومي براي همه افرادي كه قصد ارتباط با آن كاربر را دارند معلوم است. حال اگر A قصد ارسال پيامي محرمانه به B را داشته باشد، پيام را توسط كليد عمومي B رمز مي‌كند و‌آن را ارسال مي نمايد. كاربر B پيام رمز شده را توسط كليد خصوصي خود، رمزگشايي مي‌نمايد. با توجه به اينكه تنها B كليد خصوصي را داراست لذا هيچ فرد ديگري نمي‌تواند به محتواي پيام دسترسي پيدا كند. براي ايجاد خاصيت احراز هويت مي‌توان پيام را توسط كليد خصوصي رمز نمود تا هر فردي كه كليد عمومي آن كاربر را داراست بتواند رمز را باز نموده و در نتيجه هويت كاربر فوق احراز شود. البته در عمل به‌جاي اينكه متن، توسط كليد خصوصي رمز شود، توسط يك تابع در هم ساز (hash function)، يك جمع‌آزما با طول ثابت (مثلا ‌١٢٨ بيت) ايجاد مي‌شود و سپس جمع‌آزما رمز مي‌شود.

- مقايسه الگوريتم‌هاي رمزنگاري متقارن و نامتقارن
الگوريتم‌هاي رمزنگاري متقارن و نامتقارن از جنبه‌هاي مختلفي قابل مقايسه هستند. با توجه به اينكه هدف ايجاد امنيت قوي در شكبه اينترنت مي‌باشد لذا امنيت، سادگي و همچنين افزايش توانايي‌هاي سيستم، داراي اهميت بيشتري مي‌باشند.
از لحاظ امنيت مشكل مي توان سيستم‌هاي متقارن و نامتقارن را مقايسه نمود. سيستم‌هاي رمز نامتقارن، عمدتا بر اساس يك مساله سخت رياضي بنيان نهاده شده‌اند و تا وقتي آن مساله رياضي حل نشده، سيستم داراي امنيت لازم مي‌باشد. به عنوان مثال يكي از مسايل رياضي كه سيستم‌هاي رمز بر آن استوار هستند مساله تجزيه اعداد بزرگ مي‌باشد. با توجه به اينكه در سيستم‌هاي رمز نامتقارن، با اعداد بزرگ كار مي‌شود لذا اينگونه سيستم‌ها در مقايسه با سيستم‌هاي رمز متقارن معمولا از سرعت نسبتا پاييني برخوردار هستند.
با وجود سرعت نسبتا كم الگوريتم‌هاي نامتقارن، سادگي كار با آنها و توانايي‌هايي كه فراهم مي‌آورند آنها را براي استفاده از يك سيستم بزرگ و همه‌گير جذب مي‌نمايند. كليدهاي استفاده شده در الگوريتم‌هاي نامتقارن، راحت‌تر از الگوريتم‌هاي متقارن قابل توزيع هستند. اگر فرض كنيم در شبكه n كاربرد وجود دارد و همه كاربران بخواهند توسط الگوريتم متقارن با يكديگر ارتباط امن داشته باشند، نياز به ‌٢/(n (n-1 كليد مي‌باشد كه بين هر دو كاربر به اشتراك گذاشته شده است. در مقابل، اگر از الگوريتم نامتقارن استفاده شده باشد، به n زوج كليد (عمومي و خصوصي) نياز مي‌باشد. در ضمن چون در الگوريتم‌هاي نامتقارن، تنها كليد عمومي هر كاربر بايد در شبكه توزيع شود لذا بر خلاف الگوريتم‌هاي متقارن كه در آنها بايستي كليدها به طور امن (محرمانه) توزيع شوند، در الگوريتم‌هاي نامتقارن مشكل اساسي وجود ندارد.

- سازماندهي يك ساختار كليد عمومي
با مروري بر روند اعمال امنيت شبكه در چند دهه‌ي اخير ديده مي‌شود كه ديوار آتش ( firewall )، جزو اولين روش‌هاي حفاظت در شبكه بوده‌ است. سيستم‌هاي تشخيص نفوذگران ( Intrusion Detection Systems ) و شبكه‌هاي خصوصي - مجازي ( Virtual Private Networks ) نيز پس از آن پا به عرصه وجود گذاشتند. در عصر كنوني ساختار كليد عمومي و يا اصطلاحا (PKI)، Public Key Infrastructure به‌عنوان بهترين روش براي اعمال امنيت در شبكه شناخته شده است.
در اين قسمت قصد بر اين است كه ملزومات طراحي و سازماندهي يك ساختار كلي براي شبكه اينترنت بيان شود كه هر كاربر داراي يك زوج كليد مربوط به يكي از الگوريتم‌هاي نامتقارن باشد. با وجود اينكه امروزه ساختار كليد عمومي بسيار مطرح است ولي هنوز شاهد استفاده از روش‌هاي قديمي در شبكه اينترنت براي بسياري از كارهاي حساس و حتي خريد و فروش مي‌باشيم. البته به‌دليل عدم هماهنگي در روش‌هاي فوق و پيروي نكردن از يك ساختار كلي و استاندارد، نياز به يك سيستم هماهنگ و كارا احساس مي‌شود.
- مشكلاتي كه در شبكه اينترنت وجود دارد
يكي از ساده‌ترين مثال‌هايي كه نشان دهنده‌ي ضعف شبكه اينترنت است؛ پست الكترونيكي مي‌باشد. سناريويي را در نظر بگيريد كه در آن كاربر A قصد ارسال پست الكترونيكي به كابر B را دارد. وقتي نامه از مبدا رها مي‌شود معمولا چندين گره را پشت سر مي‌گذارد و نهايتا به گروه مقصد يعني كاربر B مي‌رسد. در اين ارسال مشكلات فرواني ممكن است اتفاق بيافتند كه مهمترين آنها عبارتند از:
‌١) اگر ايجاد ارتباط فقط از طريق اينترنت ممكن است پس چگونه مي‌توان آدرس كاربر B را به دست آورد به طوري كه مطمئن بود آدرس صحيح است؟
‌٢) چگونه مي‌توان اطمينان حاصل نمود كه پيام ارسالي در بين راه (گره‌هاي عبوري) بازبيني نشده‌اند و پيام محرمانه باقي مانده؟
‌٣) چگونه هويت فرستنده‌ي پيام توسط گيرنده‌ي پيام احراز مي‌گردد؟ به‌عبارت ديگر، كاربر B از كجا بفهمد كه پيام فوق واقعا از طرف كاربر A ارسال گرديده؟
يكي ديگر از مشكلات اساسي كه هم اكنون در شبكه اينترنت وجود دارد؛ انتقال اطلاعات از طريق FTP، HTTP و حتي TELNET مي‌باشد. البته گونه‌اي از سرويس‌ها و ابزارهاي تكميلي ساخته شده‌اند كه تا حدي اينگونه مشكلات را رفع مي‌نمايند ولي هنوز مكررا ديده مي‌شود كه اطلاعات رد و بدل شده در شبكه اينترنت بدون امنيت (محرمانگي و احراز هويت) مي‌باشد و حتي ديده مي‌شود كه مثلا كلمه عبور استفاده شده در پروتكل‌هاي FTP و يا TELNET به صورت ساده در شبكه ارسال مي‌شود و توسط هر فردي قابل كپي برداري مي‌باشد.
مهمترين مشكلي كه شبكه اينترنت با آن دست به گريبان است؛ عدم يك سيستم و ساختار كلي جهت ايجاد ارتباطات امن براي كارهاي حساس از قبيل تجارت الكترونيكي مي‌باشد. در حال حاضر بسياري از شركت‌ها از طريق شبكه اينترنت اقدام به فروش كالاهاي خود نموده‌اند كه عمدتا به كالاهاي ارزان قيمت محدود مي‌شوند، زيرا اولا هنوز اعتماد لازم بين كاربران بوجود نيامده و ثانيا بسياري از پروتكل‌هاي استفاده شده، از امنيت كافي برخوردار نيستند.

- راه‌كارهاي امنيتي
از سالها قبل، كارهاي زيادي براي ايجاد امنيت در شبكه اينترنت انجام شده است. به عنوان مثال PGP، SFTP، SHTTP، Secure Shell و Kerberos نمونه‌هاي عملي هستند كه مورد استفاده قرار گرفته‌اند، ولي هيچ‌يك قابليت‌هاي لازم براي يك سيستم همه‌گير با توانايي‌هاي لازم براي نيازهاي جديد كاربران اينترنت را ندارند.
يكي از معروفترين استانداردهايي كه مي‌تواند منجر به ساختار كلي مورد نظر شود، استاندارد X.509 مي‌باشد. اين استاندارد كه توسط ISO/ITU تهيه شده، جهت ايجاد يك چارچوب براي PKI ارائه شده است و مبتني بر استاندارد X.500 مي‌باشد. استاندارد X.500 براي ايجاد سرويس دايركتوري ( Directory service ) براي شبكه‌هاي بزرگ كامپيوتري ارائه گرديده است.
استاندارد X.509 به‌عنوان يكي از قديمي‌ترين ساختارهاي مبتني بر كليد عمومي در سال ‌١٩٨٨ ميلادي ظاهر شد كه متعاقب آن، نسخه‌هاي ‌٢ و ‌٣ نيز ارايه شدند. اين استاندارد هم اكنون در بعضي از سيستم‌ها و پروتكل‌ها مورد استفاده قرار گرفته و SET و SSL نيز از آن بهره‌ مي‌برند. در اين استاندارد براي هر كاربر، يك گواهي صادر مي‌شود كه از آن طريق مي‌توان بسياري از نيازهاي امنيتي را برطرف نمود. توليد گواهي ( Certification ) و عمل تعيين اعتبار ( Validation ) دو عامل اصلي موردنياز در PKI مي‌باشند. هدف در عمل اول ايجاد ارتباط بين كاربر (يا شركت) و كليد عمومي آن بوده و در عمل دوم نيز هدف، تعيين اعتبار گواهي مي‌باشد.
- خصوصيات PKI
با توجه به مطالب ذكر شده، ‌PKI را مي‌توان به صورت مجموعه‌ي سخت‌افزار، نرم‌افزار، كاربران، سياست‌ها و رويه‌هايي كه براي ايجاد مديريت، ذخيره، توزيع و انهدام گواهي مبتني بر رمزنگاري با كليد عمومي مورد نياز مي‌باشند تعريف نمود.
خصوصياتي كه در يك سيستم PKI مورد نياز مي‌باشند عبارتند از:
‌١) محرمانگي (Confidentiality): شامل محرمانگي محتواي پيام و عدم امكان شناسايي گيرنده و فرستنده پيام توسط نفر سوم.
‌٢) تماميت (integrity): شامل دست‌نخوردگي پيام، اطمينان از رسيدن پيام به مقصد و اطمينان از عدم دريافت بيش از يك نسخه پيام توسط گيرنده.
‌٣) احراز هويت (authentication): شامل اطمينان از اينكه پيام دريافت شده، از كسي ارسال شده باشد كه پيام نشان مي‌دهد و اطمينان از اينكه پيام ارسال شده را كسي دريافت مي‌كند كه فرستنده مدنظر دارد.
‌٤) عدم انكار (non - repudiation): شامل عدم امكان انكار دريافت پيام، توسط گيرنده پيام و عدم امكان انكار ارسال پيام، توسط فرستنده پيام.
‌٥) كنترل (control): شامل وجود قوانين مدون و منابع مورد اطمينان و همچنين امكان دنبال كردن و ثبت خطا در روند سيستم.
‌٦) در دسترس بودن (availability): اطمينان از فعال بودن سيستم در تمام اوقات.
- نحوه توزيع كليد عمومي

روش‌هاي موجود جهت توزيع كليد عمومي يك كاربر عبارتند از:
‌١) ارسال مستقيم توسط كاربر.
‌٢) ذخيره در دفترچه تلفن.
‌٣) ذخيره در يك گره كه با احراز هويت، قابل دريافت باشد.
‌٤) استفاده از گواهي.
با يك بررسي مختصر معين مي‌شود كه روش چهارم از ديگر روش‌ها بهتر است. زيرا ضمن اينكه هويت صاحب كليد در موقع دريافت كليد عمومي قابل احراز مي‌باشد، از ايجاد ترافيك در گره‌هاي خاص (bottle - neck) نيز جلوگيري مي‌شود.
- طرح اصلي يك PKI مطلوب
براي طراحي يك سيستم PKI كامل و امن، نياز است كه ابزارهاي آن با دقت انتخاب شده و مشكلات احتمالي آن دقيقا مورد بررسي قرار گيرند. يكي از ابزارهاي اصلي در چنين سيستمي، توزيع كليد عمومي مي‌باشد كه طبق توضيحات مربوط به قسمت قبل، اين سرويس توسط گواهي قابل حل مي‌باشد.
- گواهي براي كاربران سيستم
حداقل اطلاعاتي كه در يك گواهي مورد نياز مي‌باشند عبارت است از اطلاعات شناسنامه‌اي صاحب گواهي، كليد عمومي صاحب گواهي، اطلاعات شناسه‌اي صادركننده گواهي (CA:Certificate Authority) و امضاي صادر كننده‌ي گواهي. با توجه به اينكه اين طرح يك طرح ملي بوده و قابل گسترش در سطح جهاني مي‌باشد لذا نمي‌توان انتظار داشت كه تنها يك صادركنند‌ي گواهي براي تمام كاربران وجود داشته باشد. روش‌هاي مختلفي براي حل اين مشكل وجود دارد كه روش سلسله مراتب بصورت cross - reference به عنوان مطلوبترين روش در نظر گرفته مي‌شود. در اين روش يك صادركننده‌ي اوليه وجود دارد كه كليه كاربران يك جامعه يا گروه به آن اطمينان دارند. دليل اينكه چنين ساختاري در نظر گرفته شده، امكان آسان و امن احراز هويت گواهي يك كاربر توسط كاربران ديگر مي‌باشد. در روش فوق نياز نيست كه هر كاربر براي تائيد هر كليد عمومي، مستقيما به صادركننده‌ي آن كليد مراجعه نمايد.

...- نحوه‌ي تعيين اعتبار گواهي كاربران
طبق ساختار سلسله مراتبي كه در قسمت قبل بيان شد، هر كاربر مي‌تواند به راحتي هويت كاربر ديگر را احراز و يا رد نمايد. با اين وجود به دليل اينكه امنيت كليدهاي استفاده شده در سيستم‌هاي رمزنگاري، تابع مقدار مصرف آن و همچنين زمان مي‌باشد، لذا لازم است كليدها پس از مدتي عوض شوند. بنابراين يكي ديگر از اقلامي كه بايد در گواهي كاربران منظور شود، تاريخ انقضاي گواهي مي‌باشد كه بر اساس متوسط زمان استفاده از كليد رمز‌نگاري محاسبه مي‌گردد.
اين روش، مشكلاتي از اين قبيل را حل مي‌نمايد ولي اگر به دليلي، كليد خصوصي كاربري از محرمانگي خارج شود و يا كاربر تقاضاي گواهي جديد نمايد آنگاه كليد رمزنگاري قديمي آن كاربر از درجه اعتبار ساقط مي‌شود؛ در صورتي كه هنوز گواهي قديمي كابر ممكن است اعتبار داشته باشد. براي حل اين مشكل از يك ليست شامل شماره گواهي‌هاي از درجه اعتبار ساقط شده (CRL) استفاده مي‌كنيم تا گواهي‌هاي بي‌اعتبار، قابل پيشگيري باشد. بدين ترتيب اگر كار مهمي مانند انجام يك قرار داد مهم در حال انجام باشد لازم است كه كاربران پس از احراز هويت يكديگر (توسط گواهي امضا شده) اقدام به جست‌وجو در ليست فوق نيز بنمايند تا مطمئن شوند كه گواهي‌ها باطل نشده باشند.
- محتويات گواهي

جهت سازگاري با استانداردهاي جهاني، گواهي كاربران را طبق استاندارد X.509 تعريف مي نمائيم. براساس اين استاندارد، يك گواهي داراي اقلام زير مي‌باشد:
1- شماره‌ نسخه استاندارد: عددي صحيح كه نشان دهنده‌ي نسخه‌اي از استاندارد مي‌باشد كه در گواهي استفاده گرديده است. در حال حاضر بالاترين نسخه، 3 مي‌باشد.
2- شماره شناسايي: شماره شناسايي گواهي مي‌باشد و فرض مي‌شود كه يك صادركننده‌ي گواهي هيچ‌گاه دو گواهي با شماره شناسايي يكسان صادر نمي‌نمايد.
3- شماره شناسايي الگوريتم امضا: شناسه‌اي است كه به تعيين الگوريتم صادركننده‌ي گواهي براي امضا كردن مي‌پردازد.
4- نام صادر كننده‌ي گواهي: نام صادر كننده گواهي طبق استاندارد X.500.
5- تاريخ اعتبار: شامل تاريخ شروع و خاتمه اعتبار گواهي.
6- نام صاحب گواهي: نام صاحب گواهي طبق استاندارد X.500.
7- كليد عمومي صاحب گواهي:‌ شامل شناسه‌اي كه الگوريم نامتقارن استفاده شده و همچنين كليد عمومي متناظر با آن الگوريتم براي صاحب گواهي را معين نمايد.
اقلام ليست شده در بالا حداقل اطلاعات لازم در يك گواهي مي‌باشند. در بالا نام صادر كننده‌ي گواهي و نام صاحب گواهي، طبق استاندارد X.500 مي‌باشد كه جهت يكتا بودن نام، شامل اطلاعات سلسله مراتبي كاربر طبق فرمتي مشابه آدرس وب (URL) مي‌باشند. موارد اصلي كه در فرمت X.500 مورد استفاده قرار مي‌گيرند شامل كشور، نام كاربر، مكان، سازمان و واحد سازماني مي‌باشند.
در نسخه‌ي دوم از استاندارد X.509 به دليل اينكه ذخيره نام، طبق استاندارد X.500 ممكن است هميشه يك كاربر را به طور يكتا معين ننمايد (مثلا وقتي كاربري از شركتي اخراج شده و كاربر جديدي با همان نام استخدام شده)، لذا براي هر يك از صادر كننده‌هاي گواهي و صاحب گواهي يك شناسه يكتا در نظر گرفته شده است.
- روش محافظت از كليد خصوصي كاربران
يكي از مهمترين قسمت‌هايي كه بايد به طور جدي مورد توجه قرار گيرد؛ اطمينان از محرمانگي كليد خصوصي كاربران مي‌باشد. اگر به نحوي كليد خصوصي يك كاربر توسط كاربر ديگري مورد شناسايي قرار گيرد، كليه كارهايي كه توسط سيستم رمزنگاري نامتقارن امكان‌پذير است، توسط كاربر فوق قابل انجام خواهد بود. بنابراين محرمانگي، عدم انكار و احراز هويت براي كاربري كه كليدش كشف شده زير سوال خواهد رفت.
اولين مرحله‌اي كه در اين سيستم براي يك كاربر عملي مي‌شود؛ ايجاد گواهي است كه در اين مرحله نياز است كه كاربر يك زوج كليد رمزنگاري داشته باشد. بسته به اينكه سياست‌هاي اعمال شده در سيستم چگونه باشد، يكي از دو روش زير براي توليد كليد استفاده مي‌شوند:
1) توليد كليد توسط كاربر: در اين روش كاربر توسط ابزارهاي مورد اطمينان، يك زوج كليد براي خود توليد نموده و سپس كليد عمومي خود را به همراه مدارك مورد تاييد صاردكننده‌ي گواهي جهت صدور گواهي ارائه مي‌دهد. حسن اين روش اين است كه كاربر از محرمانگي كليد خصوصي خود صد در صد اطمينان دارد. با اين وجود ممكن است كاربران عادي نتوانند براحتي ابزار مورد اطمينان براي توليد زوج كليد را فراهم آورند و همچنين براي انتقال كليد عمومي جهت صدور گواهي نياز است كه حتما هويت كاربر توسط صادركننده گواهي احراز گردد.
2) توليد كليد توسط صادركننده گواهي:‌ در اين روش صادركننده گواهي ابتدا زوج كليد كاربر را توليد مي‌نمايد و سپس با استفاده از كليد عمومي فوق، يك گواهي صادر مي‌گردد. سپس گواهي و كليد خصوصي كاربر به وي داده مي‌شوند. در اين روش كليد خصوصي بايد به صورت محرمانه به كاربر داده شود و بهترين روش حضور فيزيكي كاربر مي‌باشد. حسن اساسي اين روش، امكان قابليت كشف كليد (Key Pecovery) در سيستم مي‌باشد. با وجود اينكه امكان كشف كليد خصوصي كاربران توسط سيستم، موردعلاقه كاربران نمي‌باشد، ولي در بسياري از موارد اين خاصيت ضروري است. به‌عنوان مثال اگر كاربري اطلاعات مورد نياز يك سازمان را رمز كرده باشد و سپس از سازمان اخراج گردد، در صورت امكان كشف كليد خصوصي مي‌توان به اطلاعات فوق دسترسي پيدا كرد. مستقل از اينكه كداميك از دو روش فوق در سيستم استفاده گردند، كليد خصوصي كاربر بايد همواره به صورت محافظت شده باقي بماند.
چهار راه اصلي براي رسيدن به اين هدف عبارتند از:
1) رمز، توسط كلمه عبور: در اين روش كه يكي از مشهورترين و پراستفاده‌ترين روش‌ها مي‌باشد، كليد خصوصي توسط يك كلمه عبور رمز مي‌شود و سپس به صورت فايل برروي ديسك و يا دستگاه‌هاي مشابه ذخيره مي‌شود. 2) ذخيره در كارت‌هاي حافظه‌دار: در اين روش كليد خصوصي در كارت‌هاي با حافظه محافظت شده (معمولا توسط كلمه عبور) ذخيره مي‌شود و در موقع نياز، به حافظه رايانه منتقل شده و پس از استفاده دور ريخته مي‌شود.
3) ذخيره در كارت‌هاي هوشمند: در اين روش از كارت‌هاي هوشمندي كه داراي پردازنده مي‌باشند جهت ذخيره كليد استفاده مي‌شود. با فرض اينكه قسمتي از الگوريتم رمزنگاري، داخل كارت انجام مي‌شود، كليد خصوصي هيچگاه كارت را ترك نمي‌كند.
4) ذخيره در دستگاه‌هاي كاملا غيرقابل نفوذ (Truly attack - resitant devices): در اين روش از دستگاه‌هاي خاصي جهت ذخيره كليد استفاده مي‌شود كه بسيار امن‌تر از كارت‌هاي هوشمند (از نظر نفوذ پذيري توسط دشمن) مي‌باشند.
روش اول به دليل اينكه كلمه عبور، معمولا قابل حدس زدن مي‌باشد و يا ممكن است كاربر آن را فراموش كند براي يك سيستم در سطح بزرگ PKI جالب به نظر نمي‌رسد. با مقايسه روش‌هاي ديگر، روش سوم به دليل اينكه كليد خصوصي به حافظه رايانه منتقل مي‌شود، بسياري از حملات را توسط نفوذگران فراهم مي‌سازد. روش چهارم نيز كاربر را وادار مي‌نمايد تا به توليدكننده‌ي دستگاه اطمينان دهد كه مطلوب نيست؛ زيرا مثلا دستگاه ممكن است پيام‌هاي اضافي را امضا نمايد و يا پيام‌هاي رمزشده را در خود ذخيره نمايد.
يكي از مهمترين خصوصيات كارت‌هاي هوشمند، امكان استفاده از كليد خصوصي در جاهاي مختلف مي‌باشد. در عصر ارتباطات امروزي نمي‌توان انتظار داشت كه كاربر هميشه از يك رايانه براي ارتباط با شبكه اينترنت استفاده نمايد و بنابراين كاربر با حمل كارت هوشمند خود مي‌تواند از هر نقطه‌اي كه به شبكه اينترنت متصل است ( و دستگاه كارت‌خوان را داراست) ارتباط امن ايجاد نمايد.
كارت هوشمندي كه براي PKI مناسب مي‌باشد كارتي است كه در آن قسمتي از الگوريتم رمزنگاري كه نياز به كليد خصوصي كاربر دارد در كارت پياده سازي شده است و در نتيجه هيچ‌گاه نياز نيست كه كليد خصوصي از كارت خارج شود. اينگونه كارت‌ها معمولا توسط يك شماره شناسايي شخصي (PIN) محافظت مي‌شوند تا اگر كارت به دلايلي به دست فرد غيرمجاز برسد، قابل استفاده نباشد. اطلاعاتي كه در كارت ذخيره مي‌شوند، عبارتند از :
1) كليد خصوصي كاربر
2) گواهي كاربر (امضا شده توسط صادركننده گواهي)
3) كليدعمومي صادركننده گواهي اوليه (root)
4) گواهي مربوط به كليه صادركننده‌هاي گواهي كه بين root و كاربر قرار مي‌گيرند
علاوه بر موارد بالا ممكن است يك شماره سريال براي هر كارت هوشمند در نظر گرفته شود و اطلاعات ديگري مروبط به الگوريتم ذخيره شده در كارت وجود داشته باشد.
- مباحث تكميلي
لازم به ذكر است با وجود اينكه سيستم‌هاي PKI بسيار مفيد مي‌باشند ولي آنها نيز داراي محدوديت‌هايي مي‌باشند. به عنوان مثال كاربران بايد به يك صادركننده گواهي (جهت امضاي گواهي) اعتماد كنند. البته چنين اعتمادي دور از ذهن نيست، زيرا در سيستم‌هاي قديمي و حتي سيستم‌هاي غيرشبكه‌اي نيز همواره اعتماد، جزو ملزومات سيستم بوده است. به عنوان مثال در سيستم بانكي، دارنده حساب بايد به سيستم بانكي اعتماد داشته باشد.
يكي از نكات مهم و اساسي در ساختار طراحي شده، اعتماد به امنيت كارت هوشمند مي‌باشد. به عنوان مثال اگر كليد خصوصي كاربر و يا كليد عمومي صادركننده گواهي اوليه root، مورد دسترسي غير مجاز قرار گيرند، امنيت سيستم به خطر مي‌افتد.
در طرح ذكر شده فرض مي‌شود كه الگوريتم‌هاي رمزنگاري با شماره شناسايي، قابل تشخيص هستند و بنابراين كاربران مي‌توانند از الگوريتم‌هاي دلخواه خويش استفاده نمايند. همچنين در گواهي مي‌توان فيلدهاي متغير داشت و بنابراين بسته به نياز مي‌توان گواهي خاصي ايجاد كرد. به عنوان نمونه گواهي رانندگي، گواهي تحصيلي و غيره.
در سيستم فرض مي‌شود كه كاربر، مسوليت هر گونه امضايي كه با كليد خصوصي او انجام گرفته باشد را به عهده مي‌گيرد. حالتي را در نظر بگيريد كه كاربري متني را امضا نموده و سپس تاريخ انقضاي كليد رمزنگاري او به سر آمده، چگونه مي‌توان چنين امضايي را تاييد كرد؟ به عنوان راه اول مي‌توان همواره گواهي كاربر (و اطلاعات مربوط به صادركننده گواهي) را به همراه امضاي وي نگهداري نمود و در نتيجه امضاهاي قديمي نيز قابل پيگيري باشند. به عنوان راه دوم مي‌توان كليد عمومي كليه كاربران (حتي ابطال شده‌ها) را در يك ليست در سيستم نگهداري كرد تا در موقع بروز شكايت، قابل پيگيري باشند.
- نتيجه گيري

در اين مقاله استفاده از الگوريتم رمزنگاري نامتقارن به عنوان يك وسيله كارا براي هماهنگ كردن ساختار امنيتي شبكه در سطح بزرگ مورد بررسي قرار گرفت و يك طرح كلي براي فراهم كردن سرويس‌هاي محرمانگي، احراز هويت و عدم انكار ارائه شد. ساختار ارائه شده به‌راحتي امكان استفاده از سرويس‌هاي فوق را فراهم مي‌آورد.

برگرفته از:
خبرگزاري دانشجويان ايران - تهران
سرويس علمي-آموزشي

﻿

Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


چنـد نکـتهِ مرورگرها - Browers, Farsi Tarnegari / Weblog FAQ in Persian / Farsi

چنـــــد نکـــــــتهِ مرورگرها

- اگر در جائي هستيد که سرعت اينترنت بسيار کند است(مثلاّ ايران) و ميخواهيد فقط متن صفحات را بخوانيد و تصاوير برايتان مهم نيست ، در اينترنت اکسپلورر ميتوانيد load شدن تصاوير را غير فعال کرده و بدين ترتيب سرعت load صفحات را بسيار بسيار افزايش دهيد، کافي است که در منوي Tools/Internet Options در قسمت Advanced حالت show Pictures را غير فعال کنيد.

- اگر ايميلي فارسي دريافت ميکنيد که قادر به خواندن آن نيستيد امکان دارد که مشکل مربوط به نوع encoding يا رمزگذاري ايميل باشد.براي خوانا شدن کافي است که در اينترنت اکسپلورر در منوي View و سپس Endonig نوع endoing را به Unicode/UTF-8 تغيير دهيد.(در مرورگر نت اسکيپ View/Character Set همين کار را انجام ميدهد.)

- در اينترنت اکسپلورر يک راه سريع براي تايپ يک سايت دات کام (com.) تايپ فقط نام سايت و سپس Ctrl+Enter است. (ديگر نيازي به تليپ "http://www" و "com." نيست!)

- در اينترنت اکسپلورر وظيفه Auto Complete ذخيره اطلاعات و کلمات وارد شده در فرمها ميباشد.اگر که ميخواهيد اطلاعات تايپ و ذخيره شده قبلي را پاک کنيد کافي است که در منوي Tools/Internet Options در قسمت Content و سپس Auto Complete عمل Clear Forms را انجام دهيد.

- براي پاک کردن History يا سابقه سايتهائي که ويزيت کرده ايد ، در اينترنت اکسپلورر در منوي Tools/Internet Options بايد Clear History کنيد.

- اگر معتقد به "ياد گيري ماهيگيري" هستيد تا "يادگيري ماهي خوردن" ، اين سايت و مخصوصاّ اين قسمتش بسياري از سؤالهاي شما را در مورد اينترنت اکسپلورر جواب خواهد داد.

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


جستجو در وب, گوگول - Search in Web, Farsi Tarnegari / Weblog FAQ in Persian / Farsi

وبلاگ چيست؟

جستجو در اينترنت

فرض كنيد مي خواهيد در يك زمينه خاص اطلاعاتي كسب كنيد. به چه منابعي رجوع مي كنيد?

بدون شك اولين و مطمئن ترين منبع كتاب مي باشد. اطلاعات موجود در كتابها دقيق و مطمئن هستند چون حداقل چندين بار بوسيله چندين نفر بازبيني شده اند و دقت بسيار زيادي بعمل آمده است تا مطالب نوشته شده در آنها درست و بدون اشكال باشد. اما يك نكته مهم در رابطه با كتاب اينست كه مطالب كتاب كاملاً روزآمد يا اصطلاحاً Up to Date نيست.

پس از كتاب مهمترين منبع براي بدست آوردن اطلاعات، مقالات موجود در مجلات علمي و ژورنالها مي باشد. اطلاعات موجود در ژورنالها تقريباً دقيق است چون اين مقالات قبل از چاپ بدقت بازبيني مي شوند. اين مطالب تقريباً روزآمد هستند و احتمال اشتباه در اين مطالب بسيار اندك است و اگر هم احياناً اشتباهي رخ دهد، در شماره هاي بعدي تصحيح مي گردد.

نكته: يكي از روشهاي بدست آوردن اطلاعات، استفاده از منابع و مراجع مقالات و كتابهاست كه معمولاً در انتهاي كتاب يا مقالات ذكر مي شود.

يكي ديگر از منابع اطلاعاتي بانكهاي اطلاعاتي مي باشند. بدليل فراواني مقالات، پژوهشگران امروزه با كمك نرم افزارهاي رايانه اي به جستجو در بانكهاي اطلاعاتي مختلف مي پردازند. اين بانكهاي اطلاعاتي را مؤسسات بين المللي اطلاع رساني تهيه كرده و به فروش مي رسانند. امروزه اغلب بانكهاي اطلاعاتي روي CD به بازار عرضه مي شوند. از مزيتهاي CD اينست كه دستيابي به اطلاعات در آنها بسيار ساده، سريع و با جستجوي چند كلمة كليدي (Kyword) مي باشد.

از سال 1992 يك منبع بسيار مهم ديگر به منابع اطلاعاتي اضافه شد و آن شبكه جهاني وب (World Wide Web) مي باشد. مجموعة اطلاعات در دسترس براي افرادي كه با اينترنت كار مي كنند روز به روز افزايش مي يابد. البته اينترنت داراي سرويسهاي ديگري نيز مي باشد كه پرداختن به آن در اين مجال اندك ميسر نيست و ان شاءالله در شماره هاي بعدي به آن خواهيم پرداخت.

حال اگر بخواهيم در زمينة يك مطلب خاص در اينترنت يا بهتر است بگوئيم وب به جستجو بپردازيم ، از كجا بايد شروع كرد؟

راه حل اول اينست كه اگر آدرس يك سايت را مي دانيد با تايپ آدرس آن سايت در كادر آدرس مرورگر خود به آن سايت وصل شده و اطلاعات موردنظر رادريافت مي كنيد. بعنوان مثال فرض كنيد مي خواهيد اطلاعاتي در مورد بورسيه دانشگاه M IT كسب كنيد. مي دانيد كه آدرس اين دانشگاه http://www.mit.edu مي باشد پس با تايپ آدرس اين صفحه مي توانيد به سايت اين دانشگاه رفته و اطلاعات موردنظر را بدست آوريد.

ولي اگر موضوع موردنظر شما جديد باشد يا كسي در اين مورد اطلاعاتي نداشته باشد چه بايد كرد. خوشبختانه افراد باهوشي اين كار را براي شما ساده كرده و جستجو در انبوهي از اطلاعات موجود در اينترنت را براي شما ممكن ساخته اند.

روشهاي جستجو در اينترنت

براي جستجو در وب دو راه وجود دارد: 1- دايركتوري يا فهرست 2- موتورهاي جستجو.

در روش دايركتوري اطلاعات بر حسب موضوع و زير موضوع طبقه بندي شده اند ( مانند كتاب اول). شما با محدود كردن جستجوي خود بصورت سلسله مراتبي به اطلاعات دلخواه خود دست پيدا مي كنيد بدين ترتيب كه از يك موضوع كلي شروع كرده و سپس آنرا خاص تر مي كنيد تا به موضوعي كه مي خواهيد برسيد.

بعنوان مثال فرض كنيد شما مي خواهيد در مورد مبدلهاي حرارتي اطلاعاتي پيدا كنيد. مي دانيد كه مبدلهاي حرارتي مربوط به مهندسي مكانيك و مهندسي شيمي مي شود. پس ابتدا موضوع مهندسي را انتخاب كرده و در آن زير شاخه مهندسي مكانيك يا مهندسي شيمي را انتخاب مي كنيد و در آن زير شاخه به اطلاعات مورد نظر دست پيدا مي كنيد.

از آنجايي كه مرتب نمودن اين فهرستها و شاخه هاي آن توسط انسان انجام گرفته است، در طول جستجوي خود، با مطالب بي ربط كمتري مواجه مي شويد. البته يكي از ضعفهاي مهم فهرستها اينست كه اطلاعات آنها به روز و كاملاً جديد نمي باشند.

موتور جستجو سايت وبي است كه براي جستجو روي اينترنت طراحي شده است، تا به كاربران در جستجوي اطلاعات موردنظر در ميان انبوه اطلاعات موجود در شبكه كمك كند.

موتورهاي جستجو، از نظر توانايي در جمع آوري اطلاعات و مرتب سازي اتوماتيك آنها با فهرستها تفاوت دارند. نتيجة جستجوي شما بر روي يك موضوع با استفاده از فهرستها در ارتباط با موضوع موردنظر شماست ولي در موتورهاي جستجو جوابهاي بي ربط زيادي وجود دارد. با اين وجود نتيجة جستجو در فهرستها بسيار محدودتر از نتيجة جستجو در موتورهاي جستجو است.

در موتور جستجو شما يك كليد واژه را وارد كرده و برنامه جستجو در بانك اطلاعاتي خود به جستجو پرداخته و سايتهاي مرتبط با موضوع شما را نمايش خواهد داد.

البته امروزه بيشتر موتورهاي جستجو داراي اطلاعات طبقه بندي شده مانند دايركتوريها مي باشند و همچنين اكثر دايركتوريها قابليت جستجو مانند موتورهاي جستجو را دارند.

ادهم برهان زهي
دانشجوي كارشناسي مهندسي شيمي- دانشگاه شيراز

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


جستجو در وب, گوگول - Search in Web, Farsi Tarnegari / Weblog FAQ in Persian / Farsi

موتورهاي جستجو
در ادامه بحث شيرين! روبوتها به نظر ميرسد که اشاره اي هم به موتورهاي جستجو يا search engines بد نباشد:
  • google.com, yahoo.com, Altavista.com, InfoSeek.com چند نمونه از جستجوگرهاي معروف هستند.
  • موتورهاي جستجو از روباتها (robots, spiders or crawlers ) براي جستجو ميان صفحات وب استفاده ميکنند.
  • بيشتر موتورهاي جستجو بانک اطاعاتي خود را بر اساس کلمات کليدي يا keywords تنظيم کرده اند.
  • Yahoo يک موتور جستجو نيست بلکه بر اساس موضوع و کاتالوگ به دسته بندي اطلاعات ميپردازد.
  • Google.com يکي از موفق ترين موتورهاي جستجو در ماههاي اخير ميباشد؛ حتي ميتوانيد در آن به جستجوي تصاوير هم بپردازيد!!
  • آيا ميدانستيد که ميتوانيد کلمات و عبارات فارسي را سرچ کنيد!؟ نتايج جستجوي کلمه "خاطرات" در google جالب نيست؟!
  • يک راه تعيين کلمات کليدي براي صفحات وب استفاده از meta tag ها است، کافي است که داخل قسمت <HEAD> از meta tag ي به نام keywords استفاده کنيد:
    < meta name="keywords" content=word1, word2 >
    ... و روبوتها بطور اتوماتيک کلمات کليدي نمونه word1 و word2 را از روي متا تگ keywords خواهند يافت.(سورس اين صفحه را ديده و نگاهي به keywords هاي داخل تگ head بيندازيد. View/Source در اکسپلورر )
  • سايت مجـــله دنيــاي کامپيوتر هم اطلاعات جالبي در مورد موتورهاي جستجو دارد.
  • اگر ميخواهيد بيشتر در مورد موتورهاي جستجوگر بدانيد، سري به اين سايت بزنيد. اين يکي هم بد نيست.

    • ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


ايميل هاي ناخواسته -Spam, Farsi Tarnegari / Weblog FAQ in Persian / Farsi

Spam
Link Extractor يکي از سريعترين برنامه هاي load صفحات اينترنت و سپس جمع آوري لينکها و آدرسهاي ايميل درون آن ميباشد که از يک سايت دلخواه شروع به کار کرده و به صورت بازگشتي(recursive) تا هر چند مرحله اي که تعيين کرده ايد به خواندن و سپس جستجوي آدرسهاي ايميل ادامه خواهد داد. Link Extractor در واقع يک روبوت يابنده آدرسهاي ايميل ميباشد که بصورت Shareware بوده و در اين آدرس ميتوانيد آنرا download کرده و استفاده کنيد. لازم به ذکر است که بيشترين کاربرد اين برنامه براي امور بازاريابي و تبليغات ميباشد.

unsolicited email or Spam or junk e-mail :
بايد توجه داشت که ارسال ايميل به تعداد زياد و به منظور بازاريابي بدون اينکه طرف شخصا خود مشترک دريافت ايميل شده باشد جرم محسوب ميشود و يکي از ملزومات ارسال ايميل به قصد بازاريابي دادن اجازه به مشترک جهت خذف آدرس ايميلش از ليست ميباشد.(من حدودا سه سال است که هر هفته ايميلي تحت عنوان "Your university diploma" دريافت ميکنم و تنها راه حل خلاصي از دستشان ظاهرا تغيير آدرس ايميل ميباشد! خلاصه اينکه مواظب آدرس ايميلتان باشيد مثلا آدرس ايميلتان را در هر guestbook ي ننويسيد مگر اينکه مطمئن شويد که روبوتها به آن صفحات دسترسي ندارند و يا اينکه آدرس ايميلتان به هر کس و ناکسي فروخته نخواهد شد.)

اگر در مورد سايتي که بازديد کرده ايد مردد هستيد و نمي دانيد که مثلا با اطلاعات شخصي کسب شده شما از قبيل IP آدرستان، نام و يا آدرس ايميلتان چگونه برخورد خواهد شد، بايد به قسمت Privacy Policy يا Terms of service آن سايت مراجعه کرده و مسئول سايت در آنجا شرح داده است که با اطلاعات کسب شده از شما چه برخوردي خواهد شد و نهايتا در صورت عدم وجود چنين صفحه اي بايد انتظار هر چيزي را داشته باشيد! (من هم بايد هر چه زودتر يک بخش Privacy Policy به اين صفحات اضافه کنم ! )

... و نهايتا چند لينک مرتبط با موضوع امروز:

  • Spam FAQ
  • چند طنز خيلي خواندني در مورد Spam
  • The Coalition Against Unsolicited Commercial Email

    • ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


شرکتهای میزبان سایت -Web Hostings, Farsi Tarnegari / Weblog FAQ in Persian / Farsi

شرکتهای میزبان سایت

شرکتهای میزبان سایت (Hosting company)

ورود به دنیای وب و راه‌اندازی یک سایت حرفه‌ای معمولا شامل سه مرحله است:
الف) ثبت دومین (Domain Registeration) که تقریبا 10 دلار در سال هزینه دارد.
ب ) نوشتن و تهیه کدهای اچتمل و در واقع طراحی و پیاده سازی سایت و تهیه محتوا که زمان‌بر و پر هزینه‌ میباشد.
ج ) انتخاب میزبان سایت و قرار دادن محتوای سایت روی یک کامپیوتر وب سرور.

انتخاب میزبان سایت یا host یکی از مهمترین تصمیم‌گیریها در شروع راه‌اندازی یک سایت بوده و مخصوصا در سایتهای حرفه‌ای میزبان سایت (Hosting company) نقش مهمی را ایفا میکند. اگر تصمیم به راه‌اندازی وب سایتی دارید، برای میزبانی سایت سه انتخاب متفاوت پیش رویتان قرار دارد:

  • 1) استفاده از فضای مجانی که بعضی از شرکتها در اختیارتان قرار میدهند .در این حالت معمولا میزبان با گذاشتن تبلیغات در ابتدای صفحه و یا به صورت پنجره‌های pop-up هزینه سرویسهایش را جبران کرده و هم آنها به نوائی میرسند و هم شما بدون هیچ هزینه‌ای خود و سایتتان را به دنیا معرفی کرده‌اید.از معایب این روش نمایش تبلیغات بی ربط با سایت، عدم تضمین در ارائه سرویس مجانی در آینده، محدودیت سرویسهای ارائه شده مجانی، خوردی اعصاب بازدیدکنندگان از تبلیغات تکراری و معمولا بی‌ربط با محتوای سایت میباشد. برای استفاده از خدمان میزبانهائی که خدمات مجانی ارائه میدهند به این فهرستها سری بزنید:
    free-domain-hosting 1 و free-domain-hosting 2
    توصیه شخصی من این است که برای سایتهای شخصی و یا سایتهای کوچک ابتدا برای مدتی محدود از سرویسهای مجانی استفاده کرده و پس از تکمیل محتوا و شناخته شدن سایتتان به سراغ سرویسها و میزبانهای حرفه‌ای بروید. (مخصوصا اگر بودجه لازم برای اجاره فضای اختصاصی برای سایتتان را ندارید.)

  • 2) میزبانی سایت در خانه و یا شرکت. در این حالت کافی است که خط ارتباطی سریعی به همراه یک IP استاتیک در اختیار داشته و روی کامپیوتری که باید همیشه روشن باشد نرام افزارهای مناسب از قبیل وب سرور و سرور بانک اطلاعاتی و ... را نصب کرده و در این حالت تمامی امکانات کامپیوتر از قبیل مثلا فضای 10 گیگابایتی هارد دیسک، تمامی رام، تمامی قدرت سی ‌پی یو و ... در اختیارتان خواهد بود. از مزایای این روش امکان میزبانی صدها سایت روی سرورتان، قابلیت انعطاف آن و در اختیار داشتن تمامی امکانات سرور میباشد و از معایب باید بگویم که به خط ارتباطی سریع ( مثلا حداقل ADSL) نیاز داشته، سرور همیشه باید روشن باشد و نیاز به UPS خواهید داشت. تنها هزینه پرداختی این روش هزینه خط ارتباطی بوده که بسته به نوع آن متفاوت بوده و معمولا بین 30 تا 500 دلار در ماه میباشد. در این روش باید تمامی جزئیات مرتبط با شبکه و اینترنت را دانسته و استفاده از آن به شرکتهای اینترنتی و به دوستانی که کار اصلیشان وب و شبکه است توصیه میشود. برای دیدن و مقایسه انواع مختلف روشها و خطوط ارتباطی در ارتباطات وب به این صفحه مراجعه کنید. زمان لازم برای داونلود پنج مگابایت اطلاعات در سرعتهای مختلف نیز در این صفحه بخوبی مقایسه شده است. اگر شما و میزبان از خط OC-12 استفاده کنید در کمتر از یک دهم ثانیه 5 مگابایت اطلاعات داونلود خواهد شد!!!

  • 3) استفاده از فضائی که شرکتهای تخصصی میزبان سایت یا Hosting company در اختیارتان قرار میدهند .در این حالت معمولا میزبان به صورت ماهانه و یا سالانه شما را شارژ کرده و هزینه آن بسته به سرویسهای ارائه شده متغییر بوده و معمولا بین 5 تا 50 دلار در ماه متغییر میباشد. در این حالت خبری از تبلیغات اجباری نبوده و سرویسهای بیشتری از قبیل میل‌باکس، امکان برنامه نویسی، امکان کار با بانکهای اطلاعاتی، خدمات و حمایت فنی و ... در اختیارتان خواهد بود.
    قبل از انتخاب میزبان سایتتان از موارد زیر مطمئن شوید:
    - آیا میزبانی به فرم www.mydomain.com خواهد بود؟
    - میزبان سایت از چه نوع خطوط ارتباطی برای اتصال به اینترنت استفاده میکند؟ فهرست مقایسه‌ای
    - آیا سرویسهای ارائه شده بر اساس سیستم‌عامل ویندوز است یا یونیکس؟
    - آیا تضمین پس دادن پول را در 30 روز اول دارند؟ (30 Day Money Back Guarantee)
    - اگر قرارداد یکساله بستید و وسط سال پشیمان شدید بقیه پولتان را پس خواهند داد؟
    - هزینه های استفاده بیش از حد مجاز از امکانات چقدر است؟ مثلا استفاده بیشتر از حد تععین شده Band width
    - آیا به صورت 24 ساعته خدمات پشتیبانی دارند؟
    - آیا پشتیبانی به صورت ایمیل است یا تلفنی هم امکان دارد؟
    - اگر پشتیبانی به صورت ایمیل است، پاسخ‌ها چقدر طول میکشند؟
    - مشخصات فنی کامپیوترهای وب سرورشان چیست ؟ سرعت cpu و میزات RAM?
    - آیا به صورت روزانه از فایلها backup میگیرند؟
    - روی هر کامپیوتر وب سرور چند سایت را نگهداری میکنند؟ (معمولا باید زیر 250 سایت باشد.)
    - آیا IP استاتیک به شما خواهند داد یا به صورت مشترک با دیگران از یک IP واحد استفاده خواهید کرد؟
    - چه اسکریپت‌ها و نرم‌افزارهائی مجانی قابل دسترس خواهد بود؟ مثلا Shopping Cart خواهید داشت؟
    - آیا اسکریپتی برای ارسال اتوماتیک سایتتان به صورت مجانی به موتورهای جستجوگر (Search engines) را دارند؟
    - چند سال است که به میزبانی سایتهای اینترنتی مشغولند؟
    - آیا سابقه فعالیت خوبی دارند؟ در این سایت چک شود.

    در این ارتباط چند سایت مفید به قرار زیر معرفی میشود:
    - سایتی معروف حاوی اطلاعات دیگر میزبانهای وب
    - سایتی دیگر برای یافتن میزبانهای وب
    - جستجوی بسیار عالی و کامل برای یافتن میزبان مناسب
    - سایتی ایرانی برای میزبانی وب
    - سایتی ایرانی برای میزبانی وب
    - سایتی ایرانی برای میزبانی وب
    - سایتی بسیار خوب برای میزبانی وب
    - سایتی بسیار خوب برای میزبانی وب

    لطفا اگر سایت میزبان ایرانی دیگری میشناسید خبر دارم کنید تا به فهرست اضافه شود. نظری دارید؟

    • ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


HTML in Persian, Basic Tags, Tables, Frames, Javascript, DHTML - Stock Photos

روبوتهاي وب چيستند؟
Web robots , Web Wanderers, Web Crawlers, or Spiders
در وادي برنامه نويسي وب , روبوت نرم افزاري است که بطور اتوماتيک به خواندن و کاوش درون ديگر صفحات وب ميپردازد.يک روبوت کارش را از يک page يا صفحه نمونه شروع کرده و بطور بازگشتي يا recursive به خواندن محتواي تمامي link هاي داخل صفحات ميپردازد.بيشترين کاربرد روبوتها در موارد زير ميباشد:
  • Indexing
  • Link Validation
  • "What's New " monitoring
  • HTML validation
  • Mirroring
    اگر ميخواهيد بيشتر در مورد روبوتها بدانيد بد نيست که سري به يکي از صفحات FAQ در مورد روبوتها بزنيد و مطمين باشيد که اگر داراي web page ي هستيد , به احتمال زياد روبوتهاي عزيز موتورهاي جستجوي معروف مثل goggle و يا yahoo بارها صفحاتتان را سرچ کرده و کلمات و Link هاي مهم آنرا در بانک اطلاعاتيشان ثبت کرده اند.توجه داشته باشيد که بتدريچ و با گذشت زمان هر چه که بيشتر فارسي نويسي در اينترنت گسترش مي يابد ضرورت جستجوي کلمات فارسي بيشتر خواهد شد و در آينده اي نه چندان دور خلايق قادر به جستجو در ميان مثلا وب لاگهاي فارسي خواهند شد و آخرين نکته اينکه اگر نمي خواهيد که روبوتها سايتتان را زيرورو!!! کنند راه حل را اينجا خواهيد يافت.

    ... و اما روبوتها در وادي زندگي واقعي:
    اين موجودات بسيار سخت گير هستند , کم حرف , بدون احساس و خيلي جدي هستند , در ميان رنگها فقط سياه و سفيد را ميشناسند , همه قضايا را ديجيتالي( 0 يا 1) بررسي ميکنند احساس! ميکنند خيلي منطقي اند و اغلب تنها و منزويند.... طفلکها بيشتر رشته هاي فني, رياضي و يا کامپيوتر خوانده اند!!! البته ناگفته نماند که مثل روبوتهاي وب کارشان را درست انجام ميدهند ,غالبا آدمهاي خوبي هستند و احتمال ابتلايشان به وبلاگ نويسي زياد است.
    .... اميدوارم که من يک روبوت نباشم!!!

    - اگر در صفحه about us اين سايت دقت کنيد ، عمداّ آدرسهاي ايميل را درست ننوشته اند و از "dot" و "at" به جاي . و @ استفاده کرده اند ، چرا؟ جواب به همان روبوتهاي موذي برميگردد!!. يکي از کارهائي که روبوتها انجام ميدهند يافتن آدرسهاي ايميل از درون صفحات HTML و سپس فروش اين ليستها به شرکتها و اشخاص براي بازاريابي و امثالهم ميباشد و به همين دليل مسئولين سايت جهت جلوگيري از يافته شدن آدرسهاي ايميلشان توسط روبوتها از "dot" و "at" به جاي . و @ استفاده کرده اند. (اگر شما هم هر روز مثل من دهها ايميل بي ربط دريافت ميکنيد، شايد کار همين روبوتها باشد، مثلاّ کافي است جائي guestbook ي را امضا کرده و آدرس ايميلتان را وارد کرده باشيد و ...)

    • ﻿
    Google |
 | Web Khaterat.com
    فهرست مقالات کوتاه آموزشی :

    - جستجو در وب
    - شرکتهای میزبان سایت
    - امنیت در شبکه وب
    - مقالات شما!!!

    - روبوتهای وب چيستند؟
    - چند لينک مفيد
    - تارنگار چیست؟
    - اين را بلاگ گنيد !

    - Spam
    - بيل گيتس
    - ASCII art
    - متفرقه

    - چنـد نکـتهِ مرورگرها
    - متا تگ ها
    - ثبت domain
    - موتورهای جستجو

    لینک به مدرسه وب HTML code for your page

    اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

    خــانه خاطرات
    |
    Farsi Font
    |
    تالارها
    |
    وبلاگ FAQ
    |
    تماس با ما
    |
    ثبت سايت
    |
    مدرسه
    Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

    2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

            ﻿
    اچ تی ام ال مقدماتی
    سرفصل مطالب
    مقدمه
    وب و اچ تی ام ال
    ( Elements ) عناصر
    تگ های اصلی
    فــارسی نويسی
    ( Formatting ) فرمت دهی
    Character Entities
    ( Links ) پيوندها
    ( Tables ) جداول
    ( Frames ) فريمها
    ( Lists ) فهرستها
    ( Forms ) فرمها
    ( Images ) تصاوير
    ( Background ) پس زمينه
    ( Fonts ) قلم ها
    ستایل شیت ها

    ضـمیمه اچ تی ام ال
    مثالهای اچتمل
    مرجع تگ های اچتمل
    جدول رنگهای اچتمل
    برگه تقلب اچتمل
    فرهنگ لغت فارسی

    Iran yellow Pages


تارنگاري چیست؟ - Farsi Tarnegari / Weblog FAQ in Persian / Farsi

وبلاگ چيست؟

من وب لاگ مي نويسم / پس هستم !

ترجمه و تلخيص گزارش بي بي سي در باره پديده وب لاگ نويسي و سخنان برگزيدگان مسابقه بهترين هاي وب لاگ

بلاگرها در شكار گاه (اينترنت) مي گردند و به گرد آوري مي پردازند . براي ما مطالب را طي فعاليت خود در صفحات اينتر نت و… نمونه برداري كرده و گاه آنها را نقادي مي كنند . ما در كنار درياي اينترنت ايم و آنها بر آن مي بارانند . بلاگرها مردان آماده (رزم) انقلاب ديجيتالي هستند . كلمه « بلاگ » مختصر شده « وبلاگ » است . چند سال پيش يكي از كساني كه بسيار در وب مي گشت شروع به ارايه گزارش روزانه كرد . وي موجزي از اطلاعات نادر و جالب را كه در طي سير در صفحات وب به آنها برخورد كرده بود را ارائه مي كرد . پيشرفت در ابزار طراحي «وب» ، براي تازه آشنايان با اينترنت ساختن صفحات شخصي در وب را بسيار آسان كرد . تا آنجا كه بتوانند آن را بسادگي هر موقع كه خواستند روز آمد كنند – حتي هر 5 دقيقه يكبار- بطوريكه آن دوست – در كنفرانس- انجام مي داد . بدين سان « بلاگها» داراي پويايي بيشتري نسبت به ساير استاندارد هاي وب سازي هستند . خيلي دائمي تر از پست كردن به صفحات بحث در اينترنت . آنها شخصي تر و خصوصي تر از روزنامه نگاري سنتي و عمومي تر از دفتر چه خاطرات هستند .

آيا تا كنون وبلاگ خوانده ايد؟ شايد شما يكي از افرادي باشيد كه وبلاگ داريد . يا ممكن است شما هنوز ندانيد كه آن چيست .
وبلاگ سايتي اينترتني است كه توسط مردم معمولي مثل من و شما راه اندازي مي شود . آنها ، داستان ، شعر ، قطعه هاي ادبي ، عكس و يا مطالبي شبيه ساير وب سايت ها را به وبلاگ خودشان پست مي كنند.
- سريع آپ ديت مي شود .
آما نه شبيه روش home page. آنها دائماً عوض مي شوند . خيلي از وب لاگ ها يا «بلاگ ها» حد اقل هر روز روز آمد مي شوند و در بعضي موارد بارها در يك روز . بعضي از صاحبان وبلاگ مخصوصاً آنها كه براي مدتي بدين كار پرداخته اند-در صورتي كه از وبلاگ خود شهرتي به دست نياورند ، انگشت نما مي شوند. آنها ممكن است به همان اندازه در ميان همكاران خود به چهره اي قديمي باشند اما در اينترنت مشهورند .
غير از روزآمد كردن روزانه سايت ها ، نكته مهم ديگر ان است كه هر كس مي تواند يكي از آن را داشته باشد . ساختن يك وبلاگ نياز به تجربه زيادي از اينترنت ندارد و به هيچ وجه نيازي به پول نيست .
شروع ساختن وبلاگ در blogget.com ، سايتي كه پيشرفت وبلاگ ها از آنجا شروع شد – كمي بيش از دو دقيقه وقت مي گيرد – من آن را تست كرده ام – سادگي مراحل ساختن وب ، موجب افزايش سريع سازندگان وبلاگ شده است . سايت بسيار مورد توجه واقع شده است چرا كه اين ايده اكنون در جريان قرار دارد . بي بي سي نيوز آن لاين يك وبلاگ دارد كه خبرنگاران سياسي در مواقع اضطراري و سر بزنگاه اخبار را در آن به طور منظم آپ ديت مي كنند . گاردين يك وب لاگ جالب دارد كه اخبار بين المللي را در آن هم آهنگ مي كند .

وبلاگ شهرت و اعتبار خود را از حكايات و اطلاعاتي كه در خود دارد بدست مي آورد . درست مثل يك كتابخانه شخصي كه انسان مي تواند هر چيز جالبي را در آن ذخيره كند تا در روز هاي بعد به آن مراجعه كند . صاحبان وبلاگ همواره قدرت خلاقه و تجربه را در خود افزايش مي دهند .صاحب وبلاگ البته دوست دارد كه وبلاگ هاي ديگر را هم بخواند . آنها غالبا خطوط پيوسته اي ا ز يك وبلاگ به وبلاگ بعدي درست مي كنند . آنها فرا گرفته اند تا دوستاني بيابند . آنها گاه حتي با هم نرد عشق مي بازند ، عصباني مي شوند ، بله گاهي هم از هم مي رنجند . وقتي كه هفته گذشته صاحب بهترين وبلاگ جايزه را برد شور و تهيجي در ميان وب لاگ نويسان به وجود آمد .

Tom Coates ، مرد پشت كيسه پلاستيكي ، ارگ ، جايزه بهترين وب لاگر اروپايي را برد .اجازه بدهيد جهان بداند در دفترخاطرات شما چيست ؟ او مي گويد: «من اكنون بسيار خوشحالم كه از خيلي وقت پيش تا حالا وب لاگ دارم و به همين دليل در جامعه بخوبي شناخته شده ام .» «خوب يا بد ، به نظر مي رسد كه مشتركان بسياري براي وب لاگ پيدا شده است . مردم داخل سايتي كه واقعاً براي آنها بهره اي نداشته باشد نمي آيند و به آن راي نمي دهند . بنا براين من بايد كار درستي انجام دهم » مقرر كردن جايزه ، « راهي با مزه براي ديدن سايت ها توسط افرادي است كه در صورت ديگر هرگزدر باره آنها چيزي نمي دانستند . اين همچنين تبليغي براي نوعي رسانه ي موثر است . مستقيم ، شخصي ، آنلاين و منتشر شده »

خانم Meg Pikard ديگر وب لاگ نويس انگليسي كه او هم برنده شده است ، سعي كرد تا جاذبه هاي وب لاگ نويسي را شرح دهد . « من الآن در باره وب خيلي بيشتر از چند سال پيش مي دانم كه تازه شروع به ساخت وب لاگ كردم . داشتن وب لاگي كه هر روز بايد آن را آپ ديت كرد راهي جالب براي شنا ختن سايتها ي جديد ، تكنولوژي ، خاطرات و نظرات است .من نمي خواهم يك شخصيت وبي داشته باشم ، سايت من تنها جاي پرسه زدن من است مثل زماني كه من با رفقايم به كلوپ ميروم اما در فرم ديجيتالي آن . من سايتم را براي خوشا مد و كنجكاوي خودم حفظ مي كنم .آنجا فضاي فكر كردن است .»و Dan Hon يكي از چهره هاي قديمي وب لاگ در انگلستان از زماني ياد مي كند كه تنها 20 نفر وب لاگر در آنجا وجود داشت ( الآن بيش از 400 است) . او مي گويد :« اين روش ديگري براي ارتباطات است . من مي توانم از ايميل استفاده كنم اما برخي اوقات پست كردن مطالب در وب لاگم آسانتر است .»

ترجمه با اندكي تلخيص : امير حسين اصغري

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


تارنگاري چیست؟ - Farsi Tarnegari / Weblog FAQ in Persian / Farsi

وبلاگ چيست؟

مطلب زير ترجمه مقاله آقاي هنري جنكيس – رييس گروه مطالعات تطبيقي رسانه ها درMIT است كه در باره پديده وبلاگ نگاشته شده است . مقاله وي از منظر يك استاد ارتباطات در باره اين پديده قابل توجه است . وي اولا وب لاگ را يك رسانه مي داند و پس آن را در آينده انقلاب ديجيتالي با اهميت ذكر مي كند . اين مقاله در نشريه Technology Reviweشماره ماه مارس 2002 درج شده است .

اين را بلاگ كنيد!
نويسنده : هنري جنيكس
ترجمه با اندكي تلخيص : امير حسين اصغري
چند ماه پيش من در كنفرانس تكنولوژي در كامدن پاپ بودم ، دوستي كه در نزديكي من نشسته بود پيوسته مشغول تايپ كردن سخنراني ها در كامپيوتر دستي خود بود . وي لينك هاي مربوطه خود را مي يافت و با فشار بر دكمه اي آن مطالب را براي روز آمد كردن سايتش مي فرستاد. سريعا پس از پست مطالب در سايتش او پاسخ هايي از خوانندگانش در سراسر كشور دريافت مي كرد . او يك بلاگر بود .

بلاگرها در شكار گاه (اينترنت) مي گردند و به گرد آوري مي پردازند . براي ما مطالب را طي فعاليت خود در صفحات اينتر نت و… نمونه برداري كرده و گاه آنها را نقادي مي كنند . ما در كنار درياي اينترنت ايم و آنها بر آن مي بارانند . بلاگرها مردان آماده (رزم) انقلاب ديجيتالي هستند . كلمه « بلاگ » مختصر شده « وبلاگ » است . چند سال پيش يكي از كساني كه بسيار در وب مي گشت شروع به ارايه گزارش روزانه كرد . وي موجزي از اطلاعات نادر و جالب را كه در طي سير در صفحات وب به آنها برخورد كرده بود را ارائه مي كرد . پيشرفت در ابزار طراحي «وب» ، براي تازه آشنايان با اينترنت ساختن صفحات شخصي در وب را بسيار آسان كرد . تا آنجا كه بتوانند آن را بسادگي هر موقع كه خواستند روز آمد كنند – حتي هر 5 دقيقه يكبار- بطوريكه آن دوست – در كنفرانس- انجام مي داد . بدين سان « بلاگها» داراي پويايي بيشتري نسبت به ساير استاندارد هاي وب سازي هستند . خيلي دائمي تر از پست كردن به صفحات بحث در اينترنت . آنها شخصي تر و خصوصي تر از روزنامه نگاري سنتي و عمومي تر از دفتر چه خاطرات هستند .

blogger.com يكي از چند سايتي است كه در قلب اين پديده واقع شده است . اكنون بيش از 375000 استفاده كننده از خدمات آن ، ثبت نام كرده اند و اين در حالي است كه روزانه بيش از 1300 عضو جديد بدان افزوده مي شود . صاحبان وبلاگ ها شامل افراد خيلي متفاوتي اند : از جماعت كليسايي كه وبلاگ را به عنوان پديده اي تاثير گذار براي سرپرستي روحي مخاطبان خودشان تا فعالاني كه در پي دادن آگاهي هاي سياسي هستند . همينطور از ورزش دوستاني كه مي خواهند با وبلاگ با ديگر مشتاقان داراي كنش و روابط متقابل باشند . اغلب اوقات بلاگرها تجربيا ت روزانه را تعريف مي كنند . پرچم داستانهاي جالب از انتشارات در صفحات وب تا تبادل نصايح درباره مشكلات خودماني در آنجا در اهتزاز است . سايت آنها داراي نامهاي رنگارنگي است . بعضي شان شبيه متن هاي واقعي ماجراجويي دوستان آكاردئون در قرن 21 يا مهملات اروپايي هستند به حدي گاه به شما اجازه مي دهد در باره برخي از آنها تصور كنيد كه آنها داراي عقده هاي روحي جواني با زمان و فرصت زياد براي نوشتن هستند .

هنوز يك چيز خيلي مهم در جريان است . در زماني كه خيلي از نقطه . كام ها بسته مي شوند وبلاگ در حال اهتزاز و بر خاستن است . ما در آرامش بين موجهاي تجاري كردن در رسانه هاي ديجيتالي هستيم و بلاگرها تصرف كنندگان لحظه هايند كه بالقوه تنوع فرهنگي را افزايش داده و مانع انسداد مشاركت فرهنگي مي شوند .

براي دموكراسي در محيط رسانه هاي جاري چه رخ خواهد داد ؟ جايي كه قدرت در دست چند ناشر و شبكه قرار گرفته باشد . محقق رسانه ها « Robert Mc Chesney» اخطار مي دهد كه حدود رسايي صدا در بحث هاي سياسي ، تحت محدوديت و فشار در خواهد آمد . دانشكده حقوق دانشگاه شيكاگو نگران است كه متلاشي كردن وب ممكن است موجب از بين رفتن ارزشهاي مشترك فرهنگي اي شود كه دموكراسي طالب آن است . به عنوان مصرف كنندگان ، ما اين كشاكش متقابل را تجربه مي كنيم . تلويزيون را روشن مي كنيم و اين احساس به ما دست مي دهد كه برنامه هاي كانال هاي مختلف شبيه يكديگرند . به داخل « وب » مي رويم و شلوغي نمي گذارد كه ما چيز هاي خوب را تميز دهيم . بلاگر به هر دوي اينها پاسخ مي دهد ، مناظر گوناگون را بسط مي دهد و اگر آنها باهوش باشند با ساختن دسته بندي هاي تخصصي از هرج و مرج داده ها جلو گيري مي كنند.

با ريسك خود ستايي به من اجازه دهيد اجازه دهيد تصور كنيم كه اگر بلاگر به عنوان تفسير آنلاين « رنسانس ديجيتالي» شنا خته و نگه داشته شود چه رخ خواهد داد ؟ بعضي ها ممكن است لينك هايي پست كنند و مرا الاغ پر مدعا بخوانند . ديگران ، اگر من خوشبخت باشم ، ممكن است احساس كنند كه من داراي بصيرت جالبي مي باشم . استدال من براي ريشه هاي سبزGRASS-ROOTS رسانه ها ممكن است از سوي دو گروه محافظه كار و مترقي خواه به يكسان جذب شود . اما در چارچوبهاي متفاوت ، بسته به ايدئولوژي در دستور كار صاحبان وبلاگها. در نهايت آينده مطبو عات ما ممكن است به نوعي ترك منازعه ناآرام ميان رسانه هاي تجاري واين ريشه هاي سبز GRASS-ROOTS وابسته باشد . جهاني را تصور كنيد كه در ان دو نوع قدرت رسانه اي موجود باشد يكي از ميان رسانه هاي متمركز بر آيد جايي كه هر پيام با انتشار در شبكه تلويزيون قدرت حاصل مي كند وديگري با وساطت ريشه هاي سبز مي آيد. بلاگر اين موضوع را بر خواهد گرداند به نوعي همگاني خواهد كرد كه هر كس توان در يافت و شنيدن اخبار را داشته باشد .

اين ممكن است سخت به نظر برسد كه تصور كنيم كه جامعه بلاگ به عنوان يك نيروهاي اطلاع رساني تقريبا به قدرتمندي يك رسانه داراي شخصيت حقوقي مستقل فضاي رسانه ها را تغيير خواهد داد . ما در تاريخ با كتاب هايي در باره سامويل مورس ، مخترع تلگراف آشنا مي شويم اما نه درباره هزاران نفري كه با تلگراف كار مي كنند و پيام ها را مي فرستند و…
در نهايت شكل تكامل يافته بسياري از رسانه ها از ميان كنش متقابل ميان قدرت توزيع شده ريشه هاي سبز – نشريات مشاركتي- و نشرياتي كه شخصيت حقوقي انها متمركز است /نشريات دولتي/ متشكل مي شود .
به عنوان اينكه « انقلاب ديجيتالي» به يك دوره تحولي نزديك مي شود با وساطت وب لاگ ممكن است تا دوباره« ادراك عمومي »public perceptionبه يك رسانه تعريف شود و تاثير خود را گسترش دهد .
پس اين را بلاگ گنيد !

ترجمه با اندكي تلخيص : امير حسين اصغري

﻿
Google |
 | Web Khaterat.com
فهرست مقالات کوتاه آموزشی :

- جستجو در وب
- شرکتهای میزبان سایت
- امنیت در شبکه وب
- مقالات شما!!!

- روبوتهای وب چيستند؟
- چند لينک مفيد
- تارنگار چیست؟
- اين را بلاگ گنيد !

- Spam
- بيل گيتس
- ASCII art
- متفرقه

- چنـد نکـتهِ مرورگرها
- متا تگ ها
- ثبت domain
- موتورهای جستجو

لینک به مدرسه وب HTML code for your page

اگر از این سایت راضی هستيد و ميخواهيد ديگران را هم به مدرسه! بفرستيد لطفا از کد اچتمل زیر استفاده کنيد:

خــانه خاطرات
|
Farsi Font
|
تالارها
|
وبلاگ FAQ
|
تماس با ما
|
ثبت سايت
|
مدرسه
Mahvareh - Vancouver Stock Photos - Canada Stock Photos - Kurdistan Site

2001-2003 © کليه حقوق محفوظ است .نقل تمام یا قسمتی از مطالب مدرسه وب مطلقا ممنوع است.

﻿
اچ تی ام ال مقدماتی
سرفصل مطالب
مقدمه
وب و اچ تی ام ال
( Elements ) عناصر
تگ های اصلی
فــارسی نويسی
( Formatting ) فرمت دهی
Character Entities
( Links ) پيوندها
( Tables ) جداول
( Frames ) فريمها
( Lists ) فهرستها
( Forms ) فرمها
( Images ) تصاوير
( Background ) پس زمينه
( Fonts ) قلم ها
ستایل شیت ها

ضـمیمه اچ تی ام ال
مثالهای اچتمل
مرجع تگ های اچتمل
جدول رنگهای اچتمل
برگه تقلب اچتمل
فرهنگ لغت فارسی

Iran yellow Pages


﻿

فريم 1


﻿

فريم 2


﻿

فريم 3


﻿

به سايت من خوش آمديد!

با Right Click روی فريمهای مختلف و سپس View Source ميتوانيد source يا کد اجتمل هر فريم را ببينيد.

توجه داشته باشيد که در اين مثال با کمک شناسه name هر فريم نامگذاری شده است و اگر source فريم سمت راست را مطالعه کنيد خواهيد ديد که چگونه با کمک شناسه target در پيوندها مقصد و فريم نهائي پيوندها تعيين شده است.(بدون نامگذاری فريمها اين آدرس دهی ميسر نبود.)


﻿

دفتر خاطرات زندگی من:

بخش پايانی

فصل 1

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 2

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 3

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 4

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 5

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 6

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 7

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 8

>

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 9

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 10

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 11

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 12

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 13

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 14

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

بخش پايانی

 آري آري مرگ با عزت هم زيباست!!

رجوع به اول صفحه

با Right Click روی فريمهای مختلف و سپس View Source ميتوانيد source يا کد اجتمل هر فريم را ببينيد.

در اين صفحه از پيوندهای نامگذاری شده استفاده شده است. (بخش پايانی، فصل 1 و ... )
توجه داشته باشيد که در اين مثال با کمک شناسه name هر فريم نامگذاری شده است و اگر source فريم سمت راست (منوی فصلها) را مطالعه کنيد خواهيد ديد که چگونه با کمک شناسه target در پيوندها، مقصد و فريم نهائي پيوندها تعيين شده است.(بدون نامگذاری فريمها و داشتن پيوند های نامگذاری شده اين آدرس دهی ميسر نبود.)


﻿

خـــــانـــــه

ياهو
گاگل
سنندج


﻿

خـــــانـــــه

فصل 1
فصل 5
فصل 10
فصل 14


﻿

اولين سايت شخصی من !!!


﻿


﻿

به سايت من خوش آمديد!

با Right Click روی فريم و سپس View Source ميتوانيد source يا کد اجتمل هر صفحه را ببينيد.

توجه داشته باشيد که در اين مثال با کمک شناسه name فريم درجا (iframe) نامگذاری شده است و اگر source را مطالعه کنيد خواهيد ديد که چگونه با کمک شناسه target در پيوندها مقصد و فريم نهائي پيوندها فریمی با نام "body" تعيين شده است.

اين مثال از 7 صفحه مختلف استفاده ميکند، صفحه mesal691.html به عنوان صفحه اصلی و معرفی کننده فريم درجا و شش صفحه home.html , page1.html , page2.html , page3.html , page4.html , page5.html که همگی در يک دايرکتوری قرار دارند.


﻿ آخرين صفحه وب دنيا

تــبــريــک!!!

شما به آخرين لينک و صفحه وب در دنيا رسيده ايد، اميدواريم که از اينترنت لذت برده باشيد!

... ديگر چيزی جديد برای ديدن در وب وجود ندارد، کامپيوترتان را خاموش کرده و بدنبال کار و زندگيتان برويد!!!


My first HTML page

﻿ My first HTML page Hello World!


﻿

This is a paragraph.

This is a paragraph.

This is a paragraph.

Paragraph elements are defined by the p tag.


﻿
سلام بی وفا

سلام با وفا


This paragraph contains a lot of lines in the source code, but the browser ignores it.

This paragraph contains a lot of spaces in the source code, but the browser ignores it.

The number of lines in a paragraph depends on the size of your browser window. If you resize the browser window, the number of lines in this paragraph will change.


﻿ My Heading test

This is a heading

This is a heading

This is a heading

This is a heading

This is a heading
This is a heading


﻿ My Paragraph test

This is a paragraph

This is another paragraph


﻿ My <br> test

This
is a para
graph with line breaks


﻿ My Comment test

This is a sample sentence using paragraph tag


﻿ Line Break test

To break
lines
in a
paragraph,
use the br tag.

This a line in my editor and 6 space Another new line But Browser ignores all extra spaces and ...


﻿ heading test

This is heading 1

This is heading 2

This is heading 3

This is heading 4

This is heading 5
This is heading 6

Use heading tags only for headings. Don't use them just to make something bold. Use other tags for that.


﻿ heading test, Center

This is heading 1

The heading above is aligned to the center of this page.


﻿ Horizontal rule test

The hr tag defines a horizontal rule:

This is a paragraph


﻿ Set Background Color test

This is a paragraph


﻿

Text in

Text in here is

Text in here is pushed

Text in here is pushed to the center

The default attribute for paragraph's alignment is left alignmebt.


﻿

نوشته راست به چپ

اين نوشته از راست به چپ چيده ميشود.

اين نوشته از راست به چپ چيده ميشود.

This is an English Paragraph.

This is an English Paragraph.


﻿

اين نوشته با کمک شناسه dir و مقدار rtl برای آن از راست به چپ چيده ميشود. فونت پيش فرض يا default برابر Time new roman است.

اينبار سعی کنيد که کد اچتمل را تغيير داده و پس از کليک روی دکمه "نمايش نتايج" نتايج را در سمت چپ ببينيد! اگر ميخواهيد که متون لاتين از چپ به راست چيده شوند، از شناسه dir=ltr به شکل زير عمل کنيد.

This a English Paragraph, ltr=Left to Right & rtl=Right to Left

اگر گفتيد چرا اين متن فارسی به صورت اشتباه از چپ به راست چيده شده است؟!!!


﻿

به شناسه dir و تگ html توجه کنيد.در اثر استفاده از اين شناسه در تگ html تمامی متن از راست به چپ چيده ميشود و در مرورگر اکسپلورر بخش scrool down در سمت چپ صفحه نمايش داده ميشود.

... مادر ليزا گفت: - آه ! چه سخنان حکيمانه و تهورآميزی! آنچه تو ميگويی در قلب من اثر دارد و با اينهمه، آن نيکبختی که درباره آن صحبت ميکنی کجاست؟ چه کسی ميتواند ادعا کند که نيکبخت است! چون تو آنقدر نسبت به ما ابراز لطف کرده ای که اجازه داده ای امروز بار ديگر بديدن شما بياييم. گوش کن آنچه را که بار گذشته با تو بميان ننهادم، آنچه را که جرات ادای آنرا در خويشتن نيافتم، آنچه را که مدت مديدی مرا رنج ميدهد به تو اعتراف کنم! آه! من رنج ميبرم! مرا عفو کن.. آنگاه دستهای خود را بشکل صليب رويهم نهاد و بفکر فرو رفت. زوسيما پرسيد: - از چيزی رنج می بری ؟ - از بی ايمانی. - از ايمان نداشتن به خدا - آه ! خير! خير! جرات نميکنم چنين فکری را به ذهن راه دهم ولی اين زندگی آينده که اينهمه درباره آن بحث ميکنند معمای بزرگی است! هيچکس نمی تواند به اين سوال پاسخ دهد... . - البته کشنده است ولی هيچ چيز را نميتوان اثبات کرد. با اينهمه می توان ايمان آورد. - چطور؟ به چه شکل ؟ - بر اثر عشق شديد و مثبت. سعی کن حتی المقدور همنوع خودت را دوست بداری وبتدريج که در اين عشق پيشرفت کردی بوجود خدا و جاودانی روح خودت ايمان خواهی آورد. هر گاه در ابراز عشق بديگران به مرحله ای برسی که خود را بکلی فراموش کنی آنگاه با نهايت اعتماد ايمان خواهی آورد. کمترين شکی به روح تو راه نخواهد يافت. تجربه اين حقيقت را اثبات کرده است. - عشق شديد و مثبت؟ اينهم خود مساله ای است! آنهم چه مساله دشواری ! من آنقدر انسانيت را دوست دارم که غالب اوقات فکر ميکنم از همه چيز خود حتی از ليزا چشم بپوشم و تارک دنيا شوم. ديدگان خود را مي بندم و بفکر فرو ميروم و خواب مي بينم و در اين لحظات در خود نيروی خارق العاده ای احساس ميکنم. هيچ زخمی، هيچ جراحتی مرا نمی ترساند. همه را با دست خود خواهم شست و خواهم بست. پرستار اين تيره بختان خواهم شد و حتی حاضرم زخمهای آنان را ببوسم. - جای شکرش باقی است.. باز هم خوب است که ذهن تو متوجه اين مسايل است و بموضوع های ديگری نمی انديشی. هر گاه بر حسب تصادف فرصتی پيش آيد تو ميتوانی کار نيکی انجام دهی. مادر ليزا با حرارت و حتی يک نوع آشفتگی گفت: - درست است ولی آيا ميتوانم بيش از اين چنين عمری را تحمل کنم؟ موضوع اساسی اين است. اين است مساله ای که مرا شکنجه می دهد. چشمهای خود را می بندم و از خودم می پرسم: " آيا ميتوانی مدت مديدی اين زندگی را ادامه دهی؟ اگر بيماری که زخمهايش را ميشويي بيدرنگ از تو سپاسگزاری نکند و برعکس فداکاری تو را ناديده انگارد و با هوسهايش ناراحتت کند، به تو پرخاش نمايد، از تو توقعات بيجا داشته باشد و (بطوريکه زياد برای اشخاص رنجيده پيش ميايد) عليه تو به مافوقت شکايت نمايد آنگاه چه خواهی کرد؟ آيا عشقت همچنان ادامه خواهد يافت؟" فکر کن من به چه نتايج دهشت انگيزی رسيده ام، اگر چيزی وجود داشته باشد که بيدرنگ آتش عشق"شديد و مثبت" مرا به انسانيت سرد کند ناسپاسی است. بعبارت ديگر من برای مزدی کار ميکنم و متوقعم که بيدرنگ حق خودم يعنی تمجيد و عشق در ازای عشقم دريافت دارم و در غير اينصورت قادر به دوست داشتن نخواهم بود. او جداَ نسبت بخود احساس تنفر شديدی می کرد. پس از اتمام سخنانش مانند حريفی چشم به پير دوخت و در انتظار اظهارات او ماند. زوسيما گفت: - اتفاقا چندی پيش پزشگی عين همين سخنان تو را ايراد ميکرد. وی مردی تقريبا سالمند و فوق العاده عاقل بود و با همان صراحتی که تو سخن ميگويی او هم صحبت ميکرد. گو اينکه سخنانش خالی از ظرافت نبود. ميگفت: " من انسانيت را بطور کلی دوست دارم ولی از خودم درشگفتم زيرا هر چه بيشتر بشريت را بطور کلی دوست ميدارم نسبت باشخاص بطور انفرادی کمتر مهر و محبت در دل احساس ميکنم. در خواب و عالم رويا غالبا برای خدمت به انسانيت آماده ميشوم و گاهی خود را برای فدا شدن در راه خدمت بنوع مهيا ميکنم با اينهمه حاضر نيستم دو روز با کسی در اطاقی زندگی کنم. اين حقيقت را بتجربه دريافته ام. بمحض اين که کسی را نزد خود مييابم احساس ميکنم که حس عزت نفس مرا جريحه دار ميسازد و آزاديم را به مخاطره ميافکند. بعيد نيست که پس از بيست و چهار ساعت نسبت به بهترين مرد جهان در دل احساس کين و عداوت نمايم و از يکی برای آنکه خيلی کند غذا ميخورد و از ديگری برای آنکه زکام است و مرتب بينی ميگيرد متنفر گردم. بمحض اينکه کسی دست به من بزند نسبت بهمه مردم احساس دشمنی ميکنم. اما اين نکته هم در عين حال کاملا صحيح است که هر قدر بيشتر نسبت به افراد احساس تنفر ميکنم آتش عشقم نسبت به انسانيت شعله ورتر ميگردد. " اما چه بايد کرد؟ در اين صورت تکليفم چيست؟ آيا نبايد مايوس شد؟ - خير! همين اندازه که احساس ناراحتی ميکنی خود مايه اميدواری است. تا جايی که ميسر است خوبی کن. اين نيکی بحساب تو منظور ميشود. تا کنون هم خيلی برای آن باين صراحت با من سخن گفتی که از راستگويی تو تمجيد کنم. بدون شبهه هرگز در راه عشق مثبت بجايی نخواهی رسيد. همه اينها تنها در رويا و خوابهای تو وجود خواهد داشت .و خود زندگی نيز همچون خوابی بسر خواهد رسيد و در اين صورت بدون شبهه ديگر بفکر حيات آينده نخواهی بود و سرانجام به يک صورتی آرامش خواهی يافت. - تو کاملا مرا مغلوب کردی. تنها حالا يعنی در همين لحظه که تو صحبت کردی دريافتم که در حقيقت منظورم جلب ستايش تو بود و تنها برای آن گفتم قادر به تحمل ناسپاسی نيستم که تو راستگويی مرا تقدير کنی. تو فکر مرا بيان کردی و منظور مرا دريافتی و هدفم را برای خودم شرح دادی. - راست می گويی؟ حالا پس از اين اعتراف خيال می کنم که تو راست ميگويی و قلب پاک داری. هرگاه بسعادت هم نايل نگردی دست کم بياد آور که راه راست را اختيار کرده ای و بهتر است هرگز از اين راه خارج نشوی. مخصوصا از هر دروغی بگريز و هرگز بخودت دروغ نگو. مراقب دروغگويی خودباش و در هر ساعت و هر لحظه به اين موضوع توجه کن. همچنين از ابراز نفرت نسبت به ديگران و خودت جداّ احتراز نما. بمحض اينکه يک آلودگی در خويشتن مشاهده کنی تنها علم بدان موجب تطهير تو ميگردد. از ترس هم بپرهيز گو اينکه ترس هم خود زاييده دروغگويی است. در تعقيب عشق هرگز از نقص و ناتوانی خودت نهراس و همچنين از اقدامات ناپسند خود نيز وحشت نداشته باش. بسيار متاسفم که نمی توانم مطلب سرورانگيزی را با تو در ميان نهم زيرا عشق حقيقی بمراتب دشوارتر و جانکاه تر از عشق رويايی است. عشق رويايی تشنه اقدامات شتاب آميز و فوری است که بتوانند آنرا ارضا نموده و توجه عمومی را جلب کنند و در اين موقع است که غالبا زندگی خود را در راه اين عشق فدا می کنند بشرط آنکه اين فداکاری ديری نپايد و اقدام هر چه زودتر صورت گيرد و همه آنرا مشاهده کنند و زبان به تحسين گشايند و حال آنکه عشق مثبت يعنی کار و تسلط بر نفس کاری بس دشوار است. وبهمين جهت برای بسياری از اشخاص اين عشق خود علمی دارد. اما بتو ميگويم از همان لحظه ای که با نهايت وحشت و نگرانی مشاهده کردی که با وجود تمام مساعی خود به مقصد نزديک نشده ای بلکه برعکس از هدف دورتر رفته ای در همين لحظه ناگهان به مراد می رسی و با نهايت صراحت احساس ميکنی که قدرت اعجاز انگيز باری تعالی که پيوسته بتو مهر ميورزيد و بطور اسرارانگيزی هدايتت ميکرد بر تو سايه افکنده است. ...

برادران کارامازوف - فيودور داستايوسکی، ترجمه: مشفق همدانی – انتشارات جاويدان ، چاپ 1368 ، صفحات 63 تا 66 نوشته شده در ساعت 8:43 PM توسط محمد رضا افشاری ، وبلاگ "مثل هميشه "


﻿

سر تيتر راست به چپ

راست به چپ با کمک عنصر div

راست به چپ با کمک عنصر پاراگراف

abcdef | ABC | Forced Left to Right
اين متن بايد از راست به چپ چيده شود. | abcdefgh | اين متن بايد از راست به چپ چيده شود.
a | ab | abc


﻿
اين جمله توپر يا Bold نمايش داده ميشود.
اين جمله strong نمايش داده ميشود.
اين جمله big نمايش داده ميشود.
اين جمله تاکيد شده يا emphasize نمايش داده ميشود.
اين جمله ايتاليک نمايش داده ميشود.
اين جمله کوچک نمايش داده ميشود.
اين جمله دارای بخشی subscript است.
اين جمله دارای بخشی superscript است.

بايد توجه داشت که مرورگرهای مختلف با اندکی تفاوت به شکل دهی متون ميپردازند.


﻿
اين متن از نوع
"فرمت دهی از قبل"         ميباشد و
همانطور که مبينيد فاصله ها و

حتی سطرهای جديد همانطور که تايپ شده اند
نمايش         داده ميشوند.
اين عنصر بسيار مناسب برای نمايش اشعار ميباشد.

تليفون کرده‌اي جانم فدايت
الهي مو به قربون صدايت
چو از صحرا بيايم، نازنينم
فرستم‌ پاسخي از دل برايت

- بابا طاهر عريان!?

کاربرد ديگر عنصر pre نمايش کدهای برنامه نويسی ميباشد، مانند:

for i = 1 to 10
    for j = 1 to 10
     print i+j
    next j
next i


﻿

برای نمايش متون به ظاهر حذف شده از عنصر del و برای نمايش متون "زير خط دار!" از عنصر ins بايد استفاده شود.

Computer code
Keyboard input
Teletype text
Sample text
Computer variable

Note: These tags are often used to display computer/programming code.

Most browsers will overstrike deleted text and underline inserted text.

Some older browsers will display deleted or inserted text as plain text.


﻿

This is link to Sanandaj.com Site!!!

اين متن لينکی است به صفحه ای ديگر در همين سایت!

لطفا توجه داشته باشيد که در مثال اول پيوند به سايتی ديگر در وب برقرار شد و مثال دوم پيوندی بود به صفحه ای ديگر از همين سايتی که اين صفحه در آن قرار گرفته است.


﻿

نحوه استفاده از يک تصوير به عنوان يک پيوند:

در اين مثال از يک تصوير بجای متن استفاده شده است و آدرس منبع يا source تصوير در شناسه src عنصر img قرار دارد. تصوير ميتواند روی سايت خودتان يا در هر کجای وب قرار داشته باشد.


﻿

This is link to Sanandaj.com Site!!!

با استفاده از شناسه target و مقدار "_blank" برای آن مرورگر پيوند بالا را در پنجره جديدی باز خواهد کرد. سعی کنيد که شناسه target و مقدارش را حذف کرده و نتيجه را دوباره آزمايش کنيد.


﻿

آموزش استفاده از شناسه name در پيوندها

بخش پايانی

فصل 1

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 2

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 3

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 4

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 5

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 6

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 7

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 8

>

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 9

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 10

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 11

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 12

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 13

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

فصل 14

آري آري زندگي زيباست، زندگي آتشگهي ديرنده پابرجاست،

بخش پايانی

 شاهنامه آخرش خوشه!!!!!!!!!!!!!!!

رجوع به اول صفحه


﻿

رهائی از شر فريمها

اينجا را کليک کنيد!

استفاده از مقدار "top_" برای شناسه target سبب باز شدن پيوند در صفحه اصلی مرورگر شده و در واقع از فريمها خلاص ميشويد! توجه داشته باشيد که مقدار "self_" برای شناسه target مقدار پيش فرض بوده و اگر در يک پيوند شناسه target قيد نشود به صورت پيش فرض مقدار self برای آن در نظر گرفته خواهد شد.


﻿

نمونه ای از پيوند mailto: برايم ایميل بفرستيد!

توجه داشته باشيد که به جای space های لازم در بخش subject از معادل ASCII آن يعنی %20 استفاده شده است.


﻿

نمونه ای از پيوند mailto: دعوت نامه به پارتـــــی

در پيوند از نوع mailto تمامی پارامترها قابل مقدار دهی هستند. آدرس ايميل مقصد و Carbon Copy or cc, Blinded Carbon Copy or bcc, Subject & Body


﻿ >


﻿

تعريف فريمی شناور و داخل صفحه با کمک تگ iframe :
مقدار شناسه src آدرس يا url صفحه ای است که درون فريم نمايش داده خواهد شد.
شناسه های درون تگ را تغيير داده و به مشاهده نتايج بپردازيد. اگر NORESIZE را حذف کنيد بايد چه اتفاقی بيفتد؟
توجه داشته باشيد که نه تنها اکسپلورر بلکه نسخه جديد (6) نتسکيپ ار iframe پشتيبانی ميکنند.


﻿

اگر شما از بهترين انسان روي زمين هم يک مطلب شش خطي به من بدهيد، من در آن چيزي پيدا خواهم کرد که بهانه اي براي اعدامش قرار دهم....(کاردينال ريشيلو- سياستمدار فرانسوی)


﻿

رسيدن به شهرت آسان است. اما به دست آوردن اعتبار، نه!!! رسيدن به شهرت آسان است. اما به دست آوردن اعتبار، نه!!! رسيدن به شهرت آسان است. اما به دست آوردن اعتبار، نه!!! رسيدن به شهرت آسان است. اما به دست آوردن اعتبار، نه!!! رسيدن به شهرت آسان است. اما به دست آوردن اعتبار، نه!!! رسيدن به شهرت آسان است. اما به دست آوردن اعتبار، نه!!! رسيدن به شهرت آسان است. اما به دست آوردن اعتبار، نه!!! رسيدن به شهرت آسان است. اما به دست آوردن اعتبار، نه!!! رسيدن به شهرت آسان است. اما به دست آوردن اعتبار، نه!!!


﻿

انتقام اگر چه در ابتدا شيرين است، اما با سپري شدن زمان تلخ تر و تلخ تر مي شود. (جان ميلتون- شاعر انگليسي)

انتقام اگر چه در ابتدا شيرين است، اما با سپري شدن زمان تلخ تر و تلخ تر مي شود. (جان ميلتون- شاعر انگليسي)

انتقام اگر چه در ابتدا شيرين است، اما با سپري شدن زمان تلخ تر و تلخ تر مي شود. (جان ميلتون- شاعر انگليسي)

با Right Click روی زمينه و سپس "Save Background as" فايل تصوير زمينه را ذخيره و با حجم آن دقت کنيد، 16kb . هر چند که اين حجم کمی بالا است ولی بدليل استفاده مرورگر از Cache ، فقط برای بار اول تصوير از وب لود شده و در دفعات بعد مرورگر تصوير را از روی هاردديسک خواهد خواند.


﻿

تصاوير زمينه:

هيچ چيز برای ساخت آينده به اندازه داشتن روياي آن موثر نخواهد بود. (ن.ق : ويکتور هوگو)

هيچ چيز برای ساخت آينده به اندازه داشتن روياي آن موثر نخواهد بود. (ن.ق : ويکتور هوگو)

هرتصويری با فرمت gif و يا jpg قابل استفاده به عنوان تصوير زمينه ميباشد.


﻿

تصاوير زمينه:

هيچ چيز براي ساخت آينده به اندازه داشتن روياي اون موثر نخواهد بود. (ن.ق : ويکتور هوگو)


﻿

تصاوير زمينه:

اگر مي خواهي پس از مرگ فراموش نشوي ، يا چيزي بنويس كه قابل خواندن باشد،يا كاري كن كه قابل نوشتن باشد.( فرانكلين )


﻿
تعيين رنگ زمينه با کمک Style Sheet ها:

در Style Sheet تعريف شده اين مثال در بخش head پارامتر color رنگ متون و پارامتر background-color تعيين کننده رنگ زمينه ميباشد. لازم به ذکر است که مبحث Style Sheet ها بخش جداگانه ای ميطلبد و اميدواريم که در مدرسه وب ارائه شود.

بی تو مهتاب

بی تو مهتاب شبی باز از آن كوچه گذشتم
همه تن چشم شدم خيره به دنبال تو گشتم
شوق ديدار تو لبريز شد از جام وجودم
شدم آن عاشق ديوانه كه بودم

در نهانخانه جانم، گل ياد تو درخشيد
باغ صد خاطره خنديد
عطر صد خاطره پيچيد

يادم امد كه شبی با هم از آن كوچه گذشتيم
پر گشوديم و در آن خلوت دلخواسته گشتيم
ساعتی چند برآن جوي نشستيم

تو همه راز جهان ريخته در چشم سياهت
من همه محو تماشای نگاهت

آسمان صاف و شب آرام
بخت خندان و زمان رام

خوشه ماه فرو ريخته در آب
شاخه ها دست برآورده به مهتاب

شب و صحرا و گل و سنگ
همه دل داده به آواز شباهنگ

يادم آمد تو به من گفتي
از اين عشق حذر كن
لحظه اي چند بر اين آب نظر كن

آب آئينه عشق گذران است
تو كه امروز نگاهت به نگاهي گذران است
باش فردا كه دلت با دگران است

تافراموش كنی چندي از اين شهر سفر كن

با تو گفتم ، حذر از عشق ندانم
سفر از پيش تو هرگز نتوانم، نتوانم

روز اول كه دل من به تمناي تو پرزد
چون كبوتر لب بام تو نشستم
تو به من سنگ زدي من نرميدم، نگسستم
باز گفتم كه تو صيادی و من آهوی دشتم
تا به دام تو درافتم همه جا گشتم و گشتم
حذر از عشق ندانم ، نتوانم

اشكي از شاخه فرو ريخت
مرغ شب ناله تلخي زد و بگريخت

اشك در چشم تو لرزيد
ماه بر عشق تو خنديد

يادم آيد كه دگر از تو جوابی نشنيدم
پاي در دامن اندوه كشيدم
نگسسنم، نرميدم
رفت در ظلمت شب آن شب و شبهاي دگرهم
نگرفتي دگر از عاشق آزرده خبر هم
نكنی ديگر از آن كوچه گذر هم
بي تو اما به چه حالي من از آن كوچه گذشتم ...

برگرفته از وبلاگ "وفا جون"

شعر از: فريدون مشيری


﻿

An Unordered List:

  • Red
  • Blue
  • Green


﻿

فهرست مرتب:

  1. قهوه
  2. شير
  3. چای

شناسه dir و مقدار rtl سبب نمايش از راست به چپ تمامی اعضای فهرست خواهد شد.


﻿

حالتهای مختلف فهرستهای مرتب:

کاربرد شناسه type تعيين شکل نمايش فهرست ميباشد.

Numbered list:

  1. Apples
  2. Bananas
  3. Lemons
  4. Oranges

Letters list:

  1. Apples
  2. Bananas
  3. Lemons
  4. Oranges

Lowercase letters list:

  1. Apples
  2. Bananas
  3. Lemons
  4. Oranges

Roman numbers list:

  1. Apples
  2. Bananas
  3. Lemons
  4. Oranges

Lowercase Roman numbers list:

  1. Apples
  2. Bananas
  3. Lemons
  4. Oranges


﻿

حالتهای مختلف فهرستهای نامرتب:

کاربرد شناسه type تعيين شکل نمايش فهرست ميباشد.

Disc bullets list:

  • Apples
  • Bananas
  • Lemons
  • Oranges

Circle bullets list:

  • Apples
  • Bananas
  • Lemons
  • Oranges

Square bullets list:

  • Apples
  • Bananas
  • Lemons
  • Oranges


﻿

مثال فهرست ترکيبی فارسی:

  1. قهوه
    • قهوه ترک
    • قهوه کرد
  2. شير
    • پاکتی
    • آب
    • ژيان
  3. چای
  4. Goole.com

A nested List:

  • Coffee
  • Tea
    • Black tea
    • Green tea
  • Milk


﻿

فهرست تعريفی:

مقدمه
خلاصه ای از مقدمه
فصل 2
خلاصه ای از فصل 1
فصل 2
خلاصه ای از فصل 2

شناسه dir و مقدار rtl سبب نمايش از راست به چپ تمامی اعضای فهرست خواهد شد.


﻿
First name:
Last name:


﻿
Username:
Password:

بايد توجه داشت که هنگام ورود اطلاعات درون وروديهای از نوع password ، مرورگر اطلاعات واقعي را ذخيره کرده و در روی صفحه نمايش نويسه * را نمايش خواهد داد.


﻿
Computer Experience:
Less than 1 year.
1-5 years.
More than 5 years.
تجربه کار با کامپيوتر:
کمتر از يک سال
بين يک تا پنج سال
بيشتر از پنج سال

نکات مهم:

  1. به شناسه dir و مقدار rtl آن در مثال فارسی توجه کنيد.
  2. در بخش action فرمها فايل اجرائی cgi غير فعال ميباشد.
  3. فايل يا اسکريپت بخش action برنامه ای به يکی از زبانهای اسکريپت مانند asp ، perl و ... خواهد بود که توسط برنامه نويس وب نوشته خواهد شد و به پردازش اطلاعات دريافتی از فرم پرداخته و نتايج مناسبی را به کاربر نمايش خواهد داد.


﻿
Computer Experience:

تجربه کار با کامپيوتر:

نکات مهم:

  1. به شناسه dir و مقدار rtl آن در مثال فارسی توجه کنيد.
  2. در بخش action فرمها فايل اجرائی cgi غير فعال ميباشد.
  3. فايل يا اسکريپت بخش action برنامه ای به يکی از زبانهای اسکريپت مانند asp ، perl و ... خواهد بود که توسط برنامه نويس وب نوشته خواهد شد و به پردازش اطلاعات دريافتی از فرم پرداخته و نتايج مناسبی را به کاربر نمايش خواهد داد.


﻿
Computer Experience:

تجربه کار با کامپيوتر:

نکات مهم:

  1. به عبارت SELECTED در کد اچتمل توجه کنيد. اضافه کردن اين عبارت به يک رديف سبب انتخاب آن رديف از فهرست در بدو نمايش فهرست خواهد شد.
  2. به شناسه dir و مقدار rtl آن در مثال فارسی توجه کنيد.
  3. در بخش action فرمها فايل اجرائی cgi غير فعال ميباشد.
  4. فايل يا اسکريپت بخش action برنامه ای به يکی از زبانهای اسکريپت مانند asp ، perl و ... خواهد بود که توسط برنامه نويس وب نوشته خواهد شد و به پردازش اطلاعات دريافتی از فرم پرداخته و نتايج مناسبی را به کاربر نمايش خواهد داد.


﻿
Health information:
Height Weight
مشخصات بدن شما:
قد وزن

نکات مهم:

  1. به شناسه dir و مقدار rtl آن در مثال فارسی توجه کنيد.
  2. در بخش action فرمها فايل اجرائی cgi غير فعال ميباشد.
  3. فايل يا اسکريپت بخش action برنامه ای به يکی از زبانهای اسکريپت مانند asp ، perl و ... خواهد بود که توسط برنامه نويس وب نوشته خواهد شد و به پردازش اطلاعات دريافتی از فرم پرداخته و نتايج مناسبی را به کاربر نمايش خواهد داد.


﻿

تصويری که در دايرکتوری يکسان با صفحه اچتمل قرار داشته واز نوع jpg ميباشد:

تصويری که در دايرکتوری يکسان با صفحه اچتمل قرار داشته و از نوع gif ميباشد:

تصويری که از نوع gif animation ميباشد:

در صفحات اچتمل از تصاوير با فرمت jpg و gif ميتوانيد استفاده کنيد.
تصاوير با فرمت gif ميتوانند ساده و يا gif animation باشند ولی در نامگذاری هر دو دارای انشعاب يا extension ی با نام gif هستند.


﻿

تصويری که در سايتی ديگر قرار دارد:

روی تصوير Right click کرذه و سپس در بخش properities آدرس،ابعاد و ظرفيت تصوير را ببينيد.


﻿

تصاوير زمينه:

هر تصويری با فرمت gif و يا jpg قابل استفاده به عنوان تصوير زمينه ميباشد. اگر ابعاد تصوير کوچکتر از ابعاد صفحه مرورگر باشد، تصوير زمينه تکثير خواهد شد.


﻿

تصويری [image] درون متن (bottom)

تصويری [image] درون متن (middle)

تصويری [image] درون متن (top)

نکته: ترازبندی از نوع bottom حالت پيش فرض يا default است.

تصويری [image] درون متن (حالت پيش فرض)

تصوير قبل از متن

تصوير بعد از متن


﻿

پاراگرافی شامل تصوير. در اين مثال با کمک شناسه align و مقدار left برای آن ، تصوير در سمت چپ صفحه نمايش داده ميشود.

پاراگرافی شامل تصوير. در اين مثال با کمک شناسه align و مقدار right برای آن ، تصوير در سمت راست صفحه نمايش داده ميشود.


﻿
من امروز بس دلم تنگ است و هر سازي كه مي بينم بد آهنگ است، بيا ره توشه بر داريم، قدم در راه بگذاريم، ببينيم آسمان هر كجا آيا همين رنگ است؟

اگر مرورگر به هر دليلی نتواند که يک تصوير را نمايش دهد و يا مرورگر از نوع مرورگرهائی باشد که فقط متن را نمايش ميدهند، متن و text ی که با کمک شناسه alt تعيين شده است نمايش داده خواهد شد. همچنين در اغلب مرورگرها با قرارگرفتن ماوس بروی يک تصوير، متن تعيين شده توسط شناسه alt نمايش داده خواهد شد. با کمک alt اطلاعات اضافی مربوط به تصوير قابل نمايش ميباشد.

ماوس را روی تصویر بالا نگه دارید و متن را بخوانید!


﻿

استفاده از تصوير به جای متن هنگام ايجاد پيوندها

به سنندج خوش آمديد!!!

همان پيوند بالا بدون استفاده از تصوير


﻿

مثالهائی از انواع روشهای تعريف Image map :
ناحيه دايره ای شکل
ناحيه چند ضلعی شکل
ناحيه مربع مستطيل شکل
ناحيه غير فعال


﻿

شوخی با فريم های شناور!
اگر مقدار شناسه src را درايو لوکال (مثلا c:\ ) انتخاب کنيد المان iframe دايرکتوری فايلهای آن درايو را نشان خواهد داده و به عنوان شوخی ميتوانيد به بازديدکننده سايت بگوئيد که از محتويات درايو لوکال او خبر داريد!( البته هر بازديدکننده دايرکتوری درايو لوکال خود را خواهد ديد و نه درايو ديگران را!)
ظاهرا این امکان در نسخه های جدید مرورگرها حذف شده است!!!


﻿

جدولها در اچتمل با تگ table شروع ميشوند. هر تک table با تگ tr شروع و با کمک تگ td اطلاعات سلولها و خانه های آن مشخص ميگردند.

جدولی با يک سطر و يک ستون

100

جدولی با يک رديف و 3 ستون:

100 200 300

جدولی با دو سطر و سه ستون:

100 | 200 | 300
400 | 500 | 600

جدولی با محتوای فارسی و لاتين:

One | يک
Two | دووووووووو
Three | ســـــــــــــــــــــــه

در مثال آخر به شناسه dir و مقادير rtl و ltr برای تعيين جهت نمايش متون فارسی و لاتين توجه کنيد.


﻿

جدولی دو در دو با مرز واحد:

يک | دو
سه | چهار

جدولی دو در دو با مرز 5:

يک | دو
سه | چهار

جدولی دو در دو با مرز 15 :

يک | دو
سه | چهار

جدولی دو در دو بدون مرز (حالت پيش فرض):

يک | دو
سه | چهار


﻿

جدولی دو در دو با مرز واحد:

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

جدولی دو در دو بدون مرز (حالت پيش فرض):

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار


﻿

جدولی دو در دو با مرز واحد:

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

جدولی دو در دو بدون شناسه dir :

One | Two, Two
Three, Three, Three | Four, Four, Four, Four


﻿

جدولی با عنوان (آزمايش اول) و مرز ضخيم:

آزمايش اول
يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

به محل تگ caption و مقدار شناسه border در تگ table توجه کنيد. با کمک تگ caption ميتوان عنوان جدول را تعيين کرد.


﻿

در اين مثال با کمک شناسه colspan دو ستون به يک ستون تبديل شده است:

Name | Telephone
Bill Gates | 555 77 854 | 555 77 855

در اين مثال با کمک شناسه rowspan دو رديف به يک رديف تبديل شده است:

First Name: | Bill Gates
Telephone: | 555 77 854
 | 555 77 855


﻿

محتوی يک سلول (cell) ميتواند متن، تصوير، فهرستها، جداول ديگر، پاراگرافها و یا حتی یک زندانی باشد:

اين که يه پاراگرافه

اينم يه پاراگرافه ديگه!

 اين خونه هم که يه جدول ديگه توشه:
11 | Sanandaj.com
3333 | 4444444444444
اين خونه يه فهرست داره توش
  • apples
  • bananas
  • pineapples
 يك رؤيا تنها يك رؤياست. يك هدف رويائيست كه طرح و فرجه مشخص دارد.
اگه اشکتون دراومده مقصر منم ، ميدونم.
تو اين خونه هم متن هست هم تصوير
Remember that a minute of anger denies you sixty seconds of happiness.

به شناسه dir و و مقادير rtl و ltr توجه داشته باشيد.


﻿

اين مثال نحوه ايجاد فاصله بين خانه های جدول را با کمک شناسه cellspacing نشان ميدهد:

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار


﻿

اين مثال نحوه ايجاد فاصله خالی بين خانه های جدول و مرز آنها را با کمک شناسه cellpadding نشان ميدهد:

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار


﻿

اين مثال نحوه تعيين رنگ زمينه يا تصوير زمينه در خانه های جداول را با کمک شناسه های bgcolor و background نشان ميدهد.:

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار


﻿

اين مثال نحوه تعيين ترازبندی در خانه های جداول را با کمک شناسه align نشان ميدهد.:

Number | عدد | رقم
One | يک | 11.1
Two, Two | دو، دو | 233332.2
Three, Three, Three | سه، سه، سه | 33333333333.3


﻿

اين مثال روشهای مختلف تعيين مرز جداول را با کمک شناسه frame نشان ميدهد:

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار

يک | دو، دو
سه، سه، سه | چهار، چهار، چهار، چهار


﻿ Horizontal and Vertical Alignment
HORIZONTAL ALIGNMENT | Left | Center | Right
Horizontal alignment properties align text or images to the left, center, or right of the cell. |  |  |
VERTICAL ALIGNMENT | Top | Middle | Bottom
Vertical alignment properties align the contents of the cell to the top, middle, or bottom of the cell. |  |  |


﻿
نـــــــام

آدرس ايميل

  • در این مثال کد جاوا اسکریپت فارسی ساز درون المان head قرار گرفته است و با لود شدن صفحه کد مزبور هم لود خواهد شد.
  • درون تگهای Input باید از Event Handler های onkeypress و onkeydown استفاده شود.
  • سورس کد جاوااسکریپت را میتوانید با تایپ "http://www.khaterat.com/scripts/farsi.js" در Address bar مرورگر ببینيد.
  • به شناسه dir و مقدار rtl و ltr برای ورود متن فارسی یا لاتین توجه داشته باشيد.
  • چگونه اجازه تایپ توام لاتین و فارسی را در textarea به کاربر خواهيد داد؟! نگاهی به سورس صفحه "تماس با ما" سايت خاطرات.کام بیندازید.!!!


﻿
This form sends an e-mail to someone@somedomain.com!!!
Name:

Mail:

Comment:

استفاده از اين روش مناسب کسانی است که آشنايي چندانی با زبانهای cgi نداشته و بدنبال روشی آسان برای کسب اطلاعات از بازديدکنندگان سايتشان با کمک فرمها هستند. در اين مثال پس از تکميل فرم و کليک روی دکمه Send ، مرورگر در صورت وجود برنامه ای برای ارسال ايميل بروی کامپيوتر استفاده کننده، تمامی اطلاعات کسب شده از بازديدکننده را به صورت ايميلی به آدرس ايميل داخل شناسه action خواهد فرستاد.

نکات مهم:

  1. به پسوند mailto در ابتدای شناسه action توجه کنيد.
  2. در بخش ايميل از آدرس ايميل خودتان استفاده کرده و نتيجه را بررسی کنيد.
  3. تنها مسئله اين روش برای بازديدکننده سايت اين است که آدرس ايميلش برای صاحب سايت آشکار خواهد شد!


﻿
استفاده از تگ فرم و منوهای کرکره ای و کمی جاوا اسکريپت برای ساختن فهرستی از سايتهای مورد علاقه توجه داشته باشيد که فهرست اين مثال با اضافه کردن رديفهای جديد (با کمک المان option ) قابل تکميل ميباشد.


﻿

A heading

A Paragraph!

متنی با قلم Tahoma

متنی با قلم Times

استفاده از شناسه style روشی درجا (Inline) جهت تعريف style المانهای صفحات اچتمل ميباشد. در اين مثالها بصورت درجا استيل نمايش متون (نام قلم) درون پاراگرافها تعيين ميشوند . font-family خاصيتی است مربوط به نام (نوع) قلم متون يک استيل.


﻿

A heading

A Paragraph!

متنی با اندازه 150%

متنی با اندازه 100%

استفاده از شناسه style روشی درجا (Inline) جهت تعريف style المانهای صفحات اچتمل ميباشد. در اين مثالها بصورت درجا استيل نمايش متون (اندازه قلم) درون پاراگرافها تعيين ميشوند . font-size خاصيتی است مربوط به اندازه قلم متون يک استيل.


﻿

A heading

A Paragraph!

متنی با رنگ red

متنی با رنگ 336600

استفاده از شناسه style روشی درجا (Inline) جهت تعريف style المانهای صفحات اچتمل ميباشد. در اين مثالها بصورت درجا استيل نمايش متون (رنگ قلم) درون پاراگرافها تعيين ميشوند . color خاصيتی است مربوط به رنگ متون يک استيل.


﻿

A heading

A Paragraph!

متنی با قلم Tahoma ، اندازه 80% و رنگ red

متنی با قلم Times ، اندازه 140% و رنگ 336600

استفاده از شناسه style روشی درجا (Inline) جهت تعريف style المانهای صفحات اچتمل ميباشد. در اين مثالها بصورت درجا استيل نمايش متون (رنگ، نام و اندازه قلم) درون پاراگرافها تعيين ميشوند. به نويسه ";" مابين خاصيتهای مختلف توجه کنيد.


Today's quote


﻿

نمونه ای از يک پاراگراف

  1. نمونه ای از فهرستها
  2. نمونه ای از فهرستها
خانه اول | خانه دوم
خانه سوم | خانه چهارم

توجه کنيد که چگونه تمامی المانهائی که درون تگهای <div> و <div/> قرار گرفته اند خاصيت "راست به چپ" بودن نمایش متن را به ارث ميبرند.


﻿

This is header 1

This is header 2

سر تیتری از درجه سه

تعریف استایل لازم برای رنگ نمایش سرتیترها درون تگهای <style> و <style/> در بخش <head> صفحه اچتمل.


﻿ اینجا را نشان کنید
اینجا را نشان کنید

تعریف استایل درجا برای یک پیوند:
در این مثال خاصیت "text-decoration" پیوند اول خنثی شده (none) و مرورگر بر خلاف روش معمول برای پیوندها ، هیچ خطی زیر پیوند مزبور نمایش نخواهد داد.


﻿

This is header 1

This is header 2

سر تیتری از درجه سه

تعریف استایل لازم برای رنگ نمایش سرتیترها با کمک استایل خارجی (Ecternal)
تگ <link> در بخش <head> صفحه اچتمل به معرفی فایل ستایل شیت خواهد پرداخت.


﻿

This is a paragraph

تعریف استایل لازم برای تعیین رنگ و ترازبندی پاراگرافها با کمک استایل شیتها. توجه داشته باشید که چگونه اطلاعات نمایشی و ترازبندی به عنوان قسمتی جداگانه درون تگ style معرفی شده اند.


﻿ آموزش اچتمل اينترنت و وب به فارسي در مدرسه وب - Khaterat - Learn HTML in Persian Farsi School

پس از تغيير کد HTML زير، با کليک روی دکمه " نمايش نتايج " ، نتيجه نهائی را در پنجره سمت چپ مشاهده کنيد.


﻿ آموزش اچتمل اينترنت و وب به فارسي در مدرسه وب - Khaterat - Learn HTML in Persian Farsi School

پس از تغيير کد HTML زير، با کليک روی دکمه " نمايش نتايج " ، نتيجه نهائی را در پنجره سمت چپ مشاهده کنيد.

فارسی English :زبان


﻿

صفحه اول:


﻿

صفحه دوم:


﻿

صفحه سوم:


﻿

صفحه چهاوم:


﻿
تماس با ما: webmaster@khaterat.com

در منزل حافظ

رفته‌ام بيرون از کاشانه خود، غم مخور
تا مگر بينم رخ جانانه خود، غم مخور
بشنوي پاسخ ز حافظ گر که بگذاري پيام
آن زمان کو بازگردد خانه خود، غم مخور

درمنزل سعدي

از آواي دل‌انگيز تو مستم
نباشم خانه و شرمنده هستم
به پيغام توخواهم‌ گفت ‌پاسخ
فلک ‌گرفرصتي ‌دادي به دستم

در منزل خيام

اين چرخ فلک عمر مرا داد ‌به باد
ممنون توام ‌که ‌کرده‌اي ‌از ما ‌ياد
رفتم سر کوچه منزل کوزه فروش
آيم چو به خانه، پاسخت خواهم داد

در منزل بابا طاهر عريان

تليفون کرده‌اي جانم فدايت
الهي مو به قربون صدايت
چو از صحرا بيايم، نازنينم
فرستم‌ پاسخي از دل برايت


Title of page

﻿ Title of page This is my first html page. This text is bold


﻿
Tell us about your computer experience:

برايمان بنويسيد که چقدر تجربه کار با کامپيوتر داريد؟

نکات مهم:

  1. به شناسه dir و مقدار rtl آن در مثال فارسی توجه کنيد.
  2. در بخش action فرمها فايل اجرائی cgi غير فعال ميباشد.
  3. فايل يا اسکريپت بخش action برنامه ای به يکی از زبانهای اسکريپت مانند asp ، perl و ... خواهد بود که توسط برنامه نويس وب نوشته خواهد شد و به پردازش اطلاعات دريافتی از فرم پرداخته و نتايج مناسبی را به کاربر نمايش خواهد داد.