JavaScript.ir - -

سایت ایران جاوااسکریپت

هدف ما از تاسيس اين سايت، آموزش گام به گام زبان برنامه نويسي JavaScript است، به خاطر نبود يک سايت آموزشي در اين زمينه به زبان فارسي، ما بر آن شديم تا آغازگر اين راه باشيم واميد داريم که با همکاري و همياري تمامي فارسي زبانان اين سايت هر روز بهتر و پربارتر از قبل گشته و ما بتوانيم شاهد فراگيري زبان JavaScript توسط تمامي کاربران فارسي زبان اينترنت باشيم.
اگر با اين سايت همراه باشيد ما همه چيز در مورد JavaScript را براي شما در غالب بيش از 400 مبحث توضيح خواهيم داد و شما روزي خواهيد توانست به راحتي دستورات JavaScript مورد نياز خود را بنويسيد و از اجراي آن لذت ببريد. خواهيد آموخت که چگونه نسبت به عمل کاربر عکس العمل نشان دهيد، خواهيد ديد که ما Cookie خواهيم ساخت تا کاربر را شناسايي کنيم، منوهاي Pull-down خواهيم ساخت، يک عکس را بدنبال موس بر روي صفحه حرکت خواهيم داد، فرمها را هوشمند خواهيم کرد و...
اولين قدم آشنايي با Javascript است. از همين حالا شروع کنيد.
مقالات جدید [ ليست تمامي مقالات ] [ دریافت لیست مقالات [image] ] [ تعداد مقالات : 72 ]
Submit کردن فرم
Submit کردن فرم بدون دخالت کاربر.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: شنبه 15 مرداد 1384

تاريخ شمسي
درج تاريخ شمسي
توسط: احمد | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 28 شهريور 1383

دستور Thead
Thead دستوري است که به موجب آن مي توان براي Table عنوان هايي را مشخص نمود.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 24 ارديبهشت 1383

بازي O_X
بزرگترين مزيت استفاده از JavaScript قابليت اجراي آن در سيستم کاربر مي باشد. اين خصوصيت باعث شده تا بتوانيم حتي براي کاربران Game طراحی کنیم و آنها را به بازی با سیستم خود در محیط IE تشويق نماييم !
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: سه شنبه 2 دي 1382

تبديل متن به گرافيک
با استفاده از اين اسکريپت میتوانيد جمله خود را بصورت گرافيکی به نمايش در آوريد.
توسط: مرتضی پاينده | مبحث: کنترل Eventها | تاريخ: شنبه 17 آبان 1382

مقالاتي که بيشتر مورد مطالعه قرار گرفتند [ طبقه بندي مقالات برحسب تعداد بيننده ]
نمايش گرافيکی ساعت
ميتوانيد ساعت سيستم کاربر را بر روی سايت بصورت گرافيکی بنمايش در بياورید.
توسط: مرتضی پاينده | تاريخ: جمعه 8 آذر 1381 | تعداد بازديد کننده: 26408

حرکت عکس بدنبال موس (2)
بدليل استقبال کاربران از شماره قبلي اين اسکريپت (حرکت عکس بدنبال موس) تصميم گرفتم Version جديدتر اين اسکريت را با قابليت توقف حرکت موس, ارائه دهيم.
توسط: مديريت سايت | تاريخ: چهارشنبه 30 بهمن 1381 | تعداد بازديد کننده: 26094

حرکت عکس بدنبال موس
حرکت عکس بدنبال موس
توسط: مديريت سايت | تاريخ: دوشنبه 24 تير 1381 | تعداد بازديد کننده: 24294

اصول طراحي صفحات وب
اصول طراحي صفحات وب
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 23081

افکت روي متن
با استفاده از اين اسکريپت ميتوانيد متن را به حرکت درآوريد.
توسط: مهدي ميرزايي | تاريخ: يکشنبه 21 ارديبهشت 1382 | تعداد بازديد کننده: 22346

بخش تبادل نظر [ آرشيو ] [ مطرح کردن سئوال جديد ] [ تعداد مطالب ارسالي: 877 ]
درست کردن صفحات پست در وب
توسط: فريد | تعداد پاسخهاي داده شده: 0 | تاريخ: دوشنبه 1 شهريور 1384

کمک
توسط: اکبر | تعداد پاسخهاي داده شده: 0 | تاريخ: پنجشنبه 28 مرداد 1384

نمايش تصوير هاي مختلف در ساعات مختلف
توسط: رميليا | تعداد پاسخهاي داده شده: 0 | تاريخ: چهارشنبه 16 تير 1384

خبرنامه فارسي براي سايت
توسط: احسان ر.م | تعداد پاسخهاي داده شده: 2 | تاريخ: پنجشنبه 13 خرداد 1384

غيرفعال سازي Save as and print in file function
توسط: علي جعفري | تعداد پاسخهاي داده شده: 3 | تاريخ: يکشنبه 9 خرداد 1384

معرفي سايتهاي مفيد [ آرشيو ]
Road Conditions and Weather
http://pepperdine.edu

ou'll have to be in Southern California to make use of this page, but wait until you see the stuff here. The up-to-the minute freeway speeds map tells you how fast you'll have to go to get on (or off) a highway like Interstate 405. Blue dots warn of accidents or "suspected incidents." Surfers can also get tide conditions for the LA region, or check the Southern California Swell Model, which charts how high waves have been getting. This is high-tech surfing, courtesy of Pepperdine University. Their nickname? The Wave, of course.

Stacey’s Professional Bookstore Homepage
http://staceys.com

The strength of this large and well-established California bookstore is its huge storehouse of technical and professional books, and we can tell from their online presence that they aren’t kidding around. Search the database or simply use their nifty “auto browse” method, and get an idea of the catalog. If something sound good, chance are you’ll be able to read a good chunk of it online. The samples here are truly impressive (long and varied), and other juicy bits include sections on publishers and specific authors (including recommendations updated frequently). Although it is clearly still growing, this site already commands a high position among ALL online bookstores.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٥ بازديدکننده در حال حاضر
٥١٦ صفحه امروز
تبليغات

Design by http://amirtabrizi.com


سایت ایران جاوااسکریپت

هدف ما از تاسيس اين سايت، آموزش گام به گام زبان برنامه نويسي JavaScript است، به خاطر نبود يک سايت آموزشي در اين زمينه به زبان فارسي، ما بر آن شديم تا آغازگر اين راه باشيم واميد داريم که با همکاري و همياري تمامي فارسي زبانان اين سايت هر روز بهتر و پربارتر از قبل گشته و ما بتوانيم شاهد فراگيري زبان JavaScript توسط تمامي کاربران فارسي زبان اينترنت باشيم.
اگر با اين سايت همراه باشيد ما همه چيز در مورد JavaScript را براي شما در غالب بيش از 400 مبحث توضيح خواهيم داد و شما روزي خواهيد توانست به راحتي دستورات JavaScript مورد نياز خود را بنويسيد و از اجراي آن لذت ببريد. خواهيد آموخت که چگونه نسبت به عمل کاربر عکس العمل نشان دهيد، خواهيد ديد که ما Cookie خواهيم ساخت تا کاربر را شناسايي کنيم، منوهاي Pull-down خواهيم ساخت، يک عکس را بدنبال موس بر روي صفحه حرکت خواهيم داد، فرمها را هوشمند خواهيم کرد و...
اولين قدم آشنايي با Javascript است. از همين حالا شروع کنيد.
مقالات جدید [ ليست تمامي مقالات ] [ دریافت لیست مقالات [image] ] [ تعداد مقالات : 72 ]
Submit کردن فرم
Submit کردن فرم بدون دخالت کاربر.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: شنبه 15 مرداد 1384

تاريخ شمسي
درج تاريخ شمسي
توسط: احمد | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 28 شهريور 1383

دستور Thead
Thead دستوري است که به موجب آن مي توان براي Table عنوان هايي را مشخص نمود.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 24 ارديبهشت 1383

بازي O_X
بزرگترين مزيت استفاده از JavaScript قابليت اجراي آن در سيستم کاربر مي باشد. اين خصوصيت باعث شده تا بتوانيم حتي براي کاربران Game طراحی کنیم و آنها را به بازی با سیستم خود در محیط IE تشويق نماييم !
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: سه شنبه 2 دي 1382

تبديل متن به گرافيک
با استفاده از اين اسکريپت میتوانيد جمله خود را بصورت گرافيکی به نمايش در آوريد.
توسط: مرتضی پاينده | مبحث: کنترل Eventها | تاريخ: شنبه 17 آبان 1382

مقالاتي که بيشتر مورد مطالعه قرار گرفتند [ طبقه بندي مقالات برحسب تعداد بيننده ]
نمايش گرافيکی ساعت
ميتوانيد ساعت سيستم کاربر را بر روی سايت بصورت گرافيکی بنمايش در بياورید.
توسط: مرتضی پاينده | تاريخ: جمعه 8 آذر 1381 | تعداد بازديد کننده: 26405

حرکت عکس بدنبال موس (2)
بدليل استقبال کاربران از شماره قبلي اين اسکريپت (حرکت عکس بدنبال موس) تصميم گرفتم Version جديدتر اين اسکريت را با قابليت توقف حرکت موس, ارائه دهيم.
توسط: مديريت سايت | تاريخ: چهارشنبه 30 بهمن 1381 | تعداد بازديد کننده: 26091

حرکت عکس بدنبال موس
حرکت عکس بدنبال موس
توسط: مديريت سايت | تاريخ: دوشنبه 24 تير 1381 | تعداد بازديد کننده: 24291

اصول طراحي صفحات وب
اصول طراحي صفحات وب
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 23079

افکت روي متن
با استفاده از اين اسکريپت ميتوانيد متن را به حرکت درآوريد.
توسط: مهدي ميرزايي | تاريخ: يکشنبه 21 ارديبهشت 1382 | تعداد بازديد کننده: 22343

بخش تبادل نظر [ آرشيو ] [ مطرح کردن سئوال جديد ] [ تعداد مطالب ارسالي: 877 ]
درست کردن صفحات پست در وب
توسط: فريد | تعداد پاسخهاي داده شده: 0 | تاريخ: دوشنبه 1 شهريور 1384

کمک
توسط: اکبر | تعداد پاسخهاي داده شده: 0 | تاريخ: پنجشنبه 28 مرداد 1384

نمايش تصوير هاي مختلف در ساعات مختلف
توسط: رميليا | تعداد پاسخهاي داده شده: 0 | تاريخ: چهارشنبه 16 تير 1384

خبرنامه فارسي براي سايت
توسط: احسان ر.م | تعداد پاسخهاي داده شده: 2 | تاريخ: پنجشنبه 13 خرداد 1384

غيرفعال سازي Save as and print in file function
توسط: علي جعفري | تعداد پاسخهاي داده شده: 3 | تاريخ: يکشنبه 9 خرداد 1384

معرفي سايتهاي مفيد [ آرشيو ]
Road Conditions and Weather
http://pepperdine.edu

ou'll have to be in Southern California to make use of this page, but wait until you see the stuff here. The up-to-the minute freeway speeds map tells you how fast you'll have to go to get on (or off) a highway like Interstate 405. Blue dots warn of accidents or "suspected incidents." Surfers can also get tide conditions for the LA region, or check the Southern California Swell Model, which charts how high waves have been getting. This is high-tech surfing, courtesy of Pepperdine University. Their nickname? The Wave, of course.

Stacey’s Professional Bookstore Homepage
http://staceys.com

The strength of this large and well-established California bookstore is its huge storehouse of technical and professional books, and we can tell from their online presence that they aren’t kidding around. Search the database or simply use their nifty “auto browse” method, and get an idea of the catalog. If something sound good, chance are you’ll be able to read a good chunk of it online. The samples here are truly impressive (long and varied), and other juicy bits include sections on publishers and specific authors (including recommendations updated frequently). Although it is clearly still growing, this site already commands a high position among ALL online bookstores.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٥ بازديدکننده در حال حاضر
٢٦٨ صفحه امروز
تبليغات

Design by http://amirtabrizi.com


JavaScript چيست؟

در اولين روزهاي تاسيس مجمع جهاني وب (World Wide Web) دستورات HTML بسيار ساده و آسان بود، بطوريکه فراگيري فرامين مورد نياز بيشتر از چند روز طول نميکشيد ولي هنگامي که Web، شروع به پيشرفت نمود، طراحان خواستار کنترل بيشتري شده و در نتيجه مجموعه دستورات مورد نياز تهيه گرديد.
سپس از آنجاييکه صفحات وب، بهتر است به صورت ديناميک و متحرک باشند، طراحان نيز خواستار ارتباط بين بينندگان سايت و صاحبان آن شدند، در نتيجه استفاده از دستورات HTML به تنهايي نياز آنها را برطرف نکرد و سپس شرکت Netscape براي ايجاد و کنترل ارتباط بين صاحبان سايت و بينندگان آن در صفحات Web از JavaScript کمک گرفت.
مفهوم JavaScript

JavaScript دقيقا يک زبان برنامه نويسي ميباشد که به وسيله آن ميتوان بين کاربر و سايت ارتباط برقرار نمود. توجه داشته باشيد که استفاده از JavaScript در صفحات Web نيازي به نوشتن اسکريپتها نداشته و ميتوانيد اسکريپتهاي موجود در شبکه اينترنت را کپي و در مکان مورد نظر با ايجاد تغييرات مورد نياز استفاده کنيد، اما در صورتيکه يک برنامه نويس باشيد با استفاده از اين سايت خواهيد توانست اسکريپتهاي مورد نظرتان را بنويسيد.
قابليت JavaScript

به وسيله جاوا اسکريپت ميتوان قابليتهاي بيشماري از قبيل ايجاد ارتباط بين کاربر و سايت به صفحه Web اضافه نمود. مثلا سايتهايي را مشاهده نموديد که با قرار گرفتن نشانگر موس بر روي دکمه مورد نظر بصورتي متفاوت (برجسته، تغيير محتويات درون دکمه) نمايش داده ميشود، اين عمل توسط JavaScript انجام شده و به اين تکنيک rollover گفته ميشود.
به وسيله rollover ميتوان حالتي ايجاد نمود تا اطلاعات وارد شده توسط کاربر درون فرمها بطور صحيح باشند و در نتيجه در زمان و هزينه مربوط بتوان صرفه جويي نمود. ميتوان محاسبات لازم و مورد نياز عددي را بدين وسيله در دستگاه کاربر و بدون نياز به هيچ گونه فرايندي در serverها انجام داد تفاوت بين برنامهاي server-side و client-side بدين گونه است که در برنامه server-side برنامه توسط CGI در خود serverها اجرا ميشود مانند: برنامه ASP ولي در برنامه هاي client-side برنامه در دستگاه کاربر اجرا خواهد شد.
از ديگر فرمت ها و قابليتهاي JavaScript ميتوان، صفحات HTML را بر اساس عمل کارير نمايش داد. فرض کنيد که يک سايت آژانس مسافرتي را باز کرده و مقصد خود را هاوايي انتخاب کنيد، بوسيله اسکريپت ميتوان آخرين اطلاعات مسافرتي مورد نياز براي هاوايي را در صفحه اي جديد مشاهده نماييد.
به وسيله اين برنامه ميتوان بر browser کنترل انجام داد و پنجره هاي جديدي را باز نمود، جعبه هاي پيغام را به کاربر اعلام نمود و بر روي قسمت status bar پنجره browser پيغام مخصوصي را نمايش داد.
همچنين بخاطر وجود قابليتهاي ويژه اي که در اين نوع برنامه نويسي وجود دارد ميتوان ساعت، تقويم و هر برنامه زماني ديگري نيز تهيه کرد.
JavaScript يک برنامه Java نيست.

برخلاف شباهت اسمي موجود برنامه Java و JavaScript، هيچگونه شباهتي بين اين دو برنامه وجود ندارد Java يک زبان برنامه نويسي بسيار کامل پيشرفته اي است که توسط شرکت sun microsystem تهيه شده و با استفاده از آن که نسل بعدي برنامه هاي c و ++c ميباشد، ميتوان تمامي برنامه مورد نياز را نوشته و در ضمن قطعات الکترونيکي استفاده کننده را نيز کنترل نمود. از خاصيتهاي ديگر Java اجراي برنامه نوشته شده توسط آن در تمامي مکانها با هرگونه سيستم عامل از قبيل Windows، Unix، Mac os ميباشد.
اساس Java در برنامه هاي client-side براي ايجاد appletها ميباشد، اين برنامه هاي کوچک توسط شبکه اينترنت دريافت شده و درون خود browserها اجرا ميشوند بطوريکه بعلت وجود قابليت همه گير Java، اين برنامه در تمامي browserهايي که قابليت اجراي Java را دارند، کار ميکنند.
ميتوانيد بااستفاده از تگ <APPLET> در سند HTML فرامين Java را بکار بگيريد و سپس هنگامي که browser تگ <APPLET> را مشاهده کرد، applet مورد نظر از server وارد دستگاه شده و در جاي تعبيه شده درون سند HTML اجرا ميشود.
اندکي در مورد تاريخچه JavaScript

در صورتيکه JavaScript با نام Java تناسبي ندارد، پس چرا در نام خود شباهت دارند؟ پاسخ به اين سئوال را در استفاده از معروفيت نام موجود در بازار خواهيد يافت. بعد از اضافه نمودن قابليتهاي اسکريپت نويسي Netscape که اساسا زبان برنامه نويسي Livescript ناميده شده در همين موقع زبان gava معروفيت خاصي پيدا کرد و شرکت Netscape بعنوان اولين شرکت از آن در browserهاي خود استفاده کرد و نام آنرا به JavaScript تغيير اين زبان برنامه نويسي گسترش چشمگيري بدنبال داشت.
زبان ترکيبي:

زبان JavaScript يک زبان برنامه نويسي "شي گرا" ميباشد. در اين قسمت مفهوم شي گرايي يک برنامه را با توجه به مفاهيم object مشخصات و اعمال، آنها را توضيح ميدهيم.
Object

در دنياي حقيقي اشياء مانند کامپيوتر، دوچرخه و ... ميباشند، در زبان JavaScript اشياء درون browserها بوده و عبارتند از پنجره ها و فرم ها.
Properties

اشياء (object) خود داراي مشخصه هايي ميباشد مثلا گربه داراي پوست ميباشد، کامپيوتر، کيبورد داشته و دوچرخه داراي چرخ است! در دنياي JavaScript پنجره داراي تيتر و فرمها داراي check box ميباشند.
تغيير مشخصه يک شي ميتواند آن را تغيير ميدهد، بطوريکه ميتوان همان مشخصه را در اشياي کاملا متفاوتي بکار برد.
فرض کنيد که داراي مشخصه اي بنام empty هستيد، پس بنابرآنچه گفته شد اين مشخصه (خالي بودن) را ميتوانيد هم براي شکم گربه و هم براي کاسه گربه بکار ببريد!
Methods

کاري که اشياء ميتوانند انجام دهند، Methods ناميده ميشود، که مثلا خرخر گربه، خرابي کامپيوتر، و چرخش دوچرخه را ميتوان عنوان نمود. اشياء زبان JavaScript نيز داراي methodsهايي ميباشد مثلا عمل کليک براي دکمه ه، بازکردن پنجره و انتخاب متن مورد نظر را بدنبال دارد. همانطور که توجه ميکنيد پرانتزها نمايانگر وجود method ميباشند.
کنترل وقايع (handling events)

events عملياتي بوده که کاربر در هنگام مشاهده صحنه طراحي شده انجام ميدهد.
پذيرش (Submitting) يک فرم و تغيير مکان نشانگر ماوس برروي يک تصوير، دو نمونه از حالات و وقايع اتفاق افتاده ميباشند.
توسط دستورات بنام event handlers، اين برنامه وقايع مورد نظر را کنترل ميکند. متداولترين کنترل کننده هاي وقايع در جدول فوق آورده شده اند و در آينده بيشتر در مورد آنها صحبت خواهيم کرد.
Event
onAbort | کاربر با اشياء کاري ندارد.
onBlur | کابر شي را تغيير ميدهد.
OnError | اسکريپت با اشتباه مواجه ميشود.
oncHange | کاربر برروي شي کليک ميکند.
onFocuse | کاربر يک شي را فعال ميکند.
onLoad | بارگزاري شي اتمام ميشود.
onMouseover | نشانگر ماوس بر روي شي ميرود.
onMouseout | نشانگر ماوس از روي شي کنار ميرود.
onSubmit | کاربر يک فرم را پذيرش ميکند.
onUnload | کاربر به پنجره کاري ندارد.
onSelect | کاربر محتويات شي را انتخاب ميکند.
نکات مورد توجه

  • زبان JavaScript به حروف بزرگ و کوچک حساس ميباشد.

  • نام متغيرها با اعداد شروع نميشود. و در آنها فضاي خالي يا نقطه گذاري وجود ندارد. همچنين نبايد اسمي مشابه با کلمات از قبل رزرو شده و مخصوص JavaScript استفاده کرد.
عملگردها

عملگرده، علاماتي بوده که براي کار با متغييرها استفاده ميشوند. مطمئنا با عملگرهاي ساده رياضي مثل جمع، تفريق آشنا هستيد. براي اطلاع بيشتر به ديگر عملگرها به جدول فوق توجه کنيد.

X+Y (عددي) | دو عدد X و Y را با يکديگر جمع ميکند.
X+Y (حرفي) | عبارت داخلي Y و X را در کنار هم قرار ميدهد.
X-Y | Y را از X کم ميکند.
X*Y | Y و X را هم ضرب ميکند.
X/Y | X را بر Y تقسيم ميکند.
X%Y | خارج قسمت X بر Y را نشان ميدهد.
X++ ، ++X | به X يک عدد اضافه ميکند. (X=X+1)
X-- ، --X | از X يک عدد کم ميکند. (X=X-1)
X- | علامت X را عوض ميکند.
نکات مورد توجه

هر چند دو عملگر X++ ، ++X به مقدار X يک واحد اضافه ميکنند، اما در اصل دو عملگر متفاوت از يکديگر ميباشند. به عنوان مثال اگر X=5 باشد و ++Y=X باشد در نتيجه Y=5 و X=6 ميشود ولي در عبارت Y=++X مجهولهاي X و Y هر دو داراي مقدار 6 خواهد بود.
معادله ها
X=Y | مقدار X برابر Y قرار داده ميشود.
X+=Y | مانند معادله X=X+Y است.
X-=Y | مانند معادله X=X-Y است.
X*=Y | مانند معادله X=X*Y است.
X/=Y | مانند معادله X=X/Y است.
X%=Y | مانند معادله X=X%Y است.
نامعادله ها
X==Y | در صورتيکه X،Y مساوي باشند مفهوم، true را بر ميگرداند.
X!=Y | در صورتيکه X،Y نامساوي باشند مفهوم، true را بر ميگرداند.
X>Y | در صورتيکه X از Y بزرگتر باشد مفهوم، true را بر ميگرداند.
X>=Y | در صورتيکه X از Y بزرگتر يا برابر باشد مفهوم، true را بر ميگرداند.
X<Y | در صورتيکه Y از X بزرگتر باشد مفهوم، true را بر ميگرداند.
X<=Y | در صورتيکه Y از X بزرگتر يا برابر باشد مفهوم، true را بر ميگرداند.
X&&Y | در صورتيکه هم X و هم Y صحيح باشد مفهوم، true را بر ميگرداند.
X\\Y | در صورتيکه يا X يا Y صحيح باشند مفهوم، true را بر ميگرداند.
X! | در صورتيکه مقدار X غير صحيح باشد مفهوم، true را بر ميگرداند.
نکات مورد توجه

در صورتيکه متغييرهاي (حرفي) رشته اي را با يکديگر مقايسه کنيد، توجه داشته باشيد که "a" از "A" بزرگتر و "be" از "abracadabra" کوچکتر ميباشد.
ابزارهاي مورد نياز

از آنجا که JavaScript يک متن ساده ميباشد، در نتيجه ميتوان از هر ويرايشگر متن کمک گرفت، همچنين ميتوان از يک پردازشکر متن مثل word که فايل را نهايت بصورت text only ذخيره شود، استفاده کرد ولي کلا بهتر است از برنامه اي که حالت plain text که بصورت فرمت استاندارد آن است استفاده نماييد. در سيستم ويندوز اغلب کاربران از برنامه notepad استفاده ميکنند.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤١ صفحه امروز
تبليغات

© 2001-2004 JavaScript.ir


تعرفه تبلیغ در سایت ایران جاوا اسکریپت

برخلاف برنامهاي ديگر مانند: ASP و JAVA و... که نياز به محيط و برنامه خاصي جهت اجرا دارند، کد های JavaScript به هيچ محيط و برنامه اي وابسته نيستند در نتيجه اين کد ها قابليت اجرا توسط تمامي کاربران اينترنت را دارا ميباشد اين خود عاملي مهمي خواهد بود جهت فيلتر نکردن و مورد مخاطب قرار ندادن قسمتي خاصي از کاربران.
مخاطبان سايت ما تمامي کاربران فارسي زبان هستند که مشتاق ياد گيريند.
جهت دریافت تعرفه با نشانی ads@javascript.ir مکاتبه نمایید.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤٢ صفحه امروز
تبليغات


Submit کردن فرم
Submit کردن فرم بدون دخالت کاربر.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: شنبه 15 مرداد 1384

تاريخ شمسي
درج تاريخ شمسي
توسط: احمد | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 28 شهريور 1383

دستور Thead
Thead دستوري است که به موجب آن مي توان براي Table عنوان هايي را مشخص نمود.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 24 ارديبهشت 1383

بازي O_X
بزرگترين مزيت استفاده از JavaScript قابليت اجراي آن در سيستم کاربر مي باشد. اين خصوصيت باعث شده تا بتوانيم حتي براي کاربران Game طراحی کنیم و آنها را به بازی با سیستم خود در محیط IE تشويق نماييم !
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: سه شنبه 2 دي 1382

تبديل متن به گرافيک
با استفاده از اين اسکريپت میتوانيد جمله خود را بصورت گرافيکی به نمايش در آوريد.
توسط: مرتضی پاينده | مبحث: کنترل Eventها | تاريخ: شنبه 17 آبان 1382

حرکت متن درون Box
می توانيد متن دلخواه خود را در Box مورد نظر به حرکت درآوريد.
توسط: يوشا ماندنی پور | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 30 شهريور 1382

تعريف home page
با استفاده از اين اسکريپت می توان نشانی سايت موردنظر را به عنوان home page به browser کاربر معرفی نمود.
توسط: سپهر لاجوردی | مبحث: ايجاد صفحات ديناميک | تاريخ: دوشنبه 13 مرداد 1382

تغيير رنگ Boxها
با استفاده از اين اسکريپت ميتوانيد رنگ Boxها را بعد از کليک کردن تغيير دهيد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 6 تير 1382

ترانس رنگ
ميتوانيد بر روي سايت خود ترنسفر رنگ ايجاد نماييد.
توسط: مهدي ميرزايي | مبحث: کنترل Eventها | تاريخ: دوشنبه 5 خرداد 1382

افکت روي متن
با استفاده از اين اسکريپت ميتوانيد متن را به حرکت درآوريد.
توسط: مهدي ميرزايي | مبحث: کنترل Eventها | تاريخ: يکشنبه 21 ارديبهشت 1382

قبلی

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤٣ صفحه امروز
تبليغات


Submit کردن فرم
Submit کردن فرم بدون دخالت کاربر.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: شنبه 15 مرداد 1384

تاريخ شمسي
درج تاريخ شمسي
توسط: احمد | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 28 شهريور 1383

دستور Thead
Thead دستوري است که به موجب آن مي توان براي Table عنوان هايي را مشخص نمود.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 24 ارديبهشت 1383

بازي O_X
بزرگترين مزيت استفاده از JavaScript قابليت اجراي آن در سيستم کاربر مي باشد. اين خصوصيت باعث شده تا بتوانيم حتي براي کاربران Game طراحی کنیم و آنها را به بازی با سیستم خود در محیط IE تشويق نماييم !
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: سه شنبه 2 دي 1382

تبديل متن به گرافيک
با استفاده از اين اسکريپت میتوانيد جمله خود را بصورت گرافيکی به نمايش در آوريد.
توسط: مرتضی پاينده | مبحث: کنترل Eventها | تاريخ: شنبه 17 آبان 1382

حرکت متن درون Box
می توانيد متن دلخواه خود را در Box مورد نظر به حرکت درآوريد.
توسط: يوشا ماندنی پور | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 30 شهريور 1382

تعريف home page
با استفاده از اين اسکريپت می توان نشانی سايت موردنظر را به عنوان home page به browser کاربر معرفی نمود.
توسط: سپهر لاجوردی | مبحث: ايجاد صفحات ديناميک | تاريخ: دوشنبه 13 مرداد 1382

تغيير رنگ Boxها
با استفاده از اين اسکريپت ميتوانيد رنگ Boxها را بعد از کليک کردن تغيير دهيد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 6 تير 1382

ترانس رنگ
ميتوانيد بر روي سايت خود ترنسفر رنگ ايجاد نماييد.
توسط: مهدي ميرزايي | مبحث: کنترل Eventها | تاريخ: دوشنبه 5 خرداد 1382

افکت روي متن
با استفاده از اين اسکريپت ميتوانيد متن را به حرکت درآوريد.
توسط: مهدي ميرزايي | مبحث: کنترل Eventها | تاريخ: يکشنبه 21 ارديبهشت 1382

قبلی

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٥ بازديدکننده در حال حاضر
٥٣٦ صفحه امروز
تبليغات


انتخاب radio button
ميتوانيد رنگ radio button هاي انتخابي را بعد از select تغيير دهيد.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: جمعه 12 ارديبهشت 1382

نمايش فايل گرافيکی
با استفاده از اين مجموعه دستوارت ميتوانيد فايل گرافيکي موجود در سيستم خود را در پنجره Browser همراه با اطلاعات کامل به نمايش درآوريد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: چهارشنبه 6 فروردين 1382

نمايش عمودی متن
با استفاده از اين اسکريپت ميتوان متنی را بصورت عمودی به نمايش درآورد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 16 اسفند 1381

حرکت عکس بدنبال موس (2)
بدليل استقبال کاربران از شماره قبلي اين اسکريپت (حرکت عکس بدنبال موس) تصميم گرفتم Version جديدتر اين اسکريت را با قابليت توقف حرکت موس, ارائه دهيم.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: چهارشنبه 30 بهمن 1381

قرار دادن متن در قسمت Title
ميتوانيد متن را در قسمت Title صفحات خود بصورت فعال به نمایش در آوريد.
توسط: ناصر نايب | مبحث: ايجاد صفحات ديناميک | تاريخ: شنبه 12 بهمن 1381

اجرای صدا در زمانی مشخص
با استفاده از اين اسکريپت ميتوانيد آهنگ دلخواه خود را در ساعتی مشخص به اجرا درآوريد.
توسط: مرتضی پاينده | مبحث: کنترل Eventها | تاريخ: چهارشنبه 13 آذر 1381

نمايش گرافيکی ساعت
ميتوانيد ساعت سيستم کاربر را بر روی سايت بصورت گرافيکی بنمايش در بياورید.
توسط: مرتضی پاينده | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 8 آذر 1381

نمایش منو با یک کلیک
با استفاده از اين اسکريپت ميتوانيد منوي مورد نظر خود را با يک کليک به نمايش درآوريد.
توسط: ناصر نايب | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 3 آذر 1381

چرخش سايه متن
در IE يکسري داده غير استاندارد بنام Filler وجود دارد که به javascript قابليت تغيير و اصلاح objectها را ميدهد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: شنبه 13 مهر 1381

تاکيد يک مطلب
ميتوانيد مطلب مورد نظر خود را در قسمت پايين Browser کاربر به دفعات به نمايش درآوريد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: دوشنبه 28 مرداد 1381

بعدی

قبلی

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٥٢ صفحه امروز
تبليغات


تغيير bgcolor
با استفاده از اين اسکريپت ميتوانيد رنگ پس زمينه را تغيير دهيد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 18 مرداد 1381

ارجاع به صفحه مورد نظر بعد از زماني مشخص
در اين اسکريپت ميتوانيد صفحه را بعد از مدت زمان خاصي Refresh نماييد و صفحه جديدي را بجاي صفحه کنوني بارگزاري نماييد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 13 مرداد 1381

نوشتن متن در قسمت
اين اسکريپت موجب خواهد شد که حروف يک کلمه ابتدا تک تک به نمايش درآيد سپس تکميل گردد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: جمعه 18 مرداد 1381

قرار دادن ساعت بر روی سايت
با استفاده از اين اسکريپت ميتوان ساعت را بر روی سايت بطور دايناميک به نمايش درآورد
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: دوشنبه 31 تير 1381

حرکت عکس بدنبال موس
حرکت عکس بدنبال موس
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: دوشنبه 24 تير 1381

نمايش Cookieها
نمايش Cookieها
توسط: مديريت سايت | مبحث: Cookies | تاريخ: يکشنبه 23 تير 1381

خواندن Cookie
بعد از تنظيم Cookie بايستي از آن در موارد مفيد و گوناگون استفاده نمود.
توسط: مديريت سايت | مبحث: Cookies | تاريخ: يکشنبه 23 تير 1381

ايجاد Cookie
ايجاد Cookie
توسط: مديريت سايت | مبحث: Cookies | تاريخ: يکشنبه 23 تير 1381

معتبر سازي نام فايل
RegExpها داراي توانايي و قابليتهاي بيشماري ميباشند, بطوريکه يکي از قابليتهاي پر کاربرد آنها,معتبر سازي وروديهاي فيلدها در فرم صفحه وب ميباشد.
توسط: مديريت سايت | مبحث: فرم ها و معادلات قاعده اي | تاريخ: يکشنبه 23 تير 1381

onFocus Event
در صورتيکه بخواهيد در يک فيلد که اطلاعات مخصوص به نمايش در مي آيد, کاربر تغييراتي در آن اعمال نکند
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: يکشنبه 23 تير 1381

بعدی

قبلی

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤١ بازديدکننده در حال حاضر
٧٦٠ صفحه امروز
تبليغات


اسکريپتهاي CGI
توضيحی مختصر در مورد اسکريپتهاي CGI
توسط: مديريت سايت | مبحث: اصول طراحي | تاريخ: يکشنبه 23 تير 1381

onDbclick Event
بدين طريق کاربر ميتواند با انجام عمل Double Click عمل خاصي را مشاهده خواهد کرد.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: يکشنبه 23 تير 1381

OnMousedown Event
يکي از سوالهايي که بطور فراوان, توسط اکثر کاربران پرسيده ميشود, نحوه و چگونگي پنهان کردن اصل محتوي اسکريپت بکار گرفته شده در صفحه است.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: يکشنبه 23 تير 1381

onResize Event
از آنجايي که درنسخه 4 برنامه Netscape, هنگام تغيير اندازه پنجره يک bug معروف وجود داشته بنابراين بايستي بعد از تغيير اندازه صفحه, محتويات درون پنجره را مجددا Load نمود.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: يکشنبه 23 تير 1381

onUnLoad Event
در هنگام ترک يک صفحه وب, کنترل کننده onUnLoad فعال ميشود.
توسط: مديريت سايت | مبحث: کنترل Eventها | تاريخ: يکشنبه 23 تير 1381

نوشتن متن درون سند on the fly
قابليت نوشتن اطلاعات بر روي يک صفحه وب در پي پاسخ به عمل کاربر, يکي از راههاي مفيد در ديناميک کردن صفحه بوده و در ضمن از اين طريق کلا ميتوان کاربردهاي گوناگون پيدا نمود.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 23 تير 1381

ارائه يک پيغام براي زماني از روز
ارائه يک پيغام براي زماني از روز
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 23 تير 1381

بازي با روزها
ممکن است بخواهيد در مواقع و زوهاي خاص سال مثلا آخر هفته, پيغامي خاص به کاربر ارائه دهيد.
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 23 تير 1381

قرار دادن تاريخ فعلي بر روي صفحه وب
قرار دادن تاريخ فعلي بر روي صفحه وب
توسط: مديريت سايت | مبحث: ايجاد صفحات ديناميک | تاريخ: يکشنبه 23 تير 1381

کارکترهاي خاص معادلات قاعده اي
کارکترهاي خاص معادلات قاعده اي
توسط: مديريت سايت | مبحث: فرم ها و معادلات قاعده اي | تاريخ: يکشنبه 23 تير 1381

بعدی

قبلی

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٥ بازديدکننده در حال حاضر
٦١٨ صفحه امروز
تبليغات


Road Conditions and Weather
http://pepperdine.edu

ou'll have to be in Southern California to make use of this page, but wait until you see the stuff here. The up-to-the minute freeway speeds map tells you how fast you'll have to go to get on (or off) a highway like Interstate 405. Blue dots warn of accidents or "suspected incidents." Surfers can also get tide conditions for the LA region, or check the Southern California Swell Model, which charts how high waves have been getting. This is high-tech surfing, courtesy of Pepperdine University. Their nickname? The Wave, of course.

Stacey’s Professional Bookstore Homepage
http://staceys.com

The strength of this large and well-established California bookstore is its huge storehouse of technical and professional books, and we can tell from their online presence that they aren’t kidding around. Search the database or simply use their nifty “auto browse” method, and get an idea of the catalog. If something sound good, chance are you’ll be able to read a good chunk of it online. The samples here are truly impressive (long and varied), and other juicy bits include sections on publishers and specific authors (including recommendations updated frequently). Although it is clearly still growing, this site already commands a high position among ALL online bookstores.

Global Shopping Network
http://gsn.com

This shopping site is steeped in marine and outdoor gear for both amateurs and professionals. Visitors tend to cast out compliments like great graphics and awesome selection. No wonder: you can go to Marine Net for frog hooks or even fishing line - or look through the Fishnet photo gallery. where an old woman holds a salmon as big as she is. Those with fat wallets can look intro a champagnes champagne boat to Juneau. Alaska, or use the search engine (computer, not outboard) to buy a real schooner.

Chess Space
http://www.chess-space.com

Gather round, chess fans-here's site for all facets of the chess nut in you. There are, of course, links to significant chess sites, like the Internet Chess Library and related resource. But there's a more eclectic mix of links here, some of which may have an only tangential connection to the game, like home pages of other chess enthusiasts, and audio clips (really) of HAL saying "Would you like to play a game of chess?"

Public Policy Issues
http://www.dana.org

The Dana Foundation wants to understand what's going on inside your head. That's why it tracks the progress of brain research in reports and bulletins year-round. This New York based charity, but its Acrobat files are the real strength here. Readers receive updates on Congressional funding for research and issue briefs on schizophrenia and other disorders. A good site for brain specialists and researchers.

Ultimate Weapons Systems
http://www.uws.com

they bill these "tactical weapon" sales as suite to law enforcement, but the page seems aimed less at police than at those who'd like to take law into their own hands. Still, they have quite an amazing selection. The online catalog is rife with rifles and stocks and scopes, plus accessories such as flash suppressers (always essential to self-defense). Video tapes for order include "Rock 'n' Roll #3 Sexy Girls and Sexy Guns," the "John Shaw Combat Shotgun Seminar." We feel safer already!

The Better Business Bureau Web Server
http://www.bbb.org

The BBB is the place for information on everything from "work-at-home" schemes to complaint report on businesses in your area. And the BBB's Internet presence is growing. Plans are in the works for individual bureaus to offer "reliability reports" on area businesses beginning in Boston at the end of 1995 and expanding after that. For now, you can find moneysaving tips (like the fact that participating in foreign lotteries is not only costly but illegal) and advice on refinancing a mortgage loan. It's also a great place to find the nearest bureau. In any event, it's nice to have somebody looking out for you.

Poly-Links
http://www.plastics.com

The word "polymer" means "having many parts. "This page, then, is a chemistry polymer, So to speak. Maybe it's a little strange for chemists to shamelessly promote themselves, but Ploy-Links backs it up. Visitors to this vast resource of information and links about polymers are politely requested to tell other folks how great this site is. It does have plenty of unique resources-the resume creator and polymer want ads are two examples. Something for anybody interested in polymers.

Woman's International Center
http://www.wic.org

WIC is a non-profit foundation that honors and encourages woman who make positive contributions to humanity. This page outlines their mission and projects, including the annul Living Legacy Awards. Among the project detailed here: scholarship assistance to older woman reentering the work force; medical studies scholarships; and "Operation Green trees," an ongoing donation of tree seedling to organizations and schools. Biographies, a "global town hall," and a terrific history of woman in America make this one of the better resource for woman on the Net.

NASA Information Services via World Wide Web
http://www.nasa.gov

If think space, you probably think NASA, and this is the gateway to the largest respository of space-related information on the Internet. For all of its problems and bureaucaric malaise, the accomplishments of this agency defy belief. NASA landed men on the moon who drove around in a buggy! Vehicle launched from the Kennedy Space Center have explored the surface of Mars. The Hubble Space Telescope has photographed the outer limits of outer galaxy with unprecedented clarity and detail-even though HST has to wear glasses. Revolutionary advance in aeronautics, computer science and technology development can be directly attributed to NASA's programs. The Mission to Planet Earth alone has led to radical advances in environmental science, meteorology, geology, cartography, navigational systems and a host of applied and theoretical discipline. NASA's Web presence is quite possibly the single largest entity on the Internet, and this gateway takes you to an incredible array of information, images and database. Launch yourself into a galaxy of resource that encompass the whole of modern science and technology.

RSA Date Security, Inc
http://www.rsa.com

If you're afraid some 15-year old kid will break will break into your zillion-dollar corporate computer and steal trade secrets (or worse, read your private e-mail), a visit here may help you sleep better at night. Learn all about data security, firewalls, cryptography, and the like. You probably won't understand a word you read, but the complexity may help you feel safer. One of the most comprehensive (if not comprehensible) security sites we've seen.

Cycling
http://www.cyclery.com

"An Internet Bicycling Resource".is the subtitle of this site. Talk about understatement! It's a most excellent uber-index, serving up publication like Cycling Science, company pages, local bike shops from Kansas to Norway, you name it. Given a leisure reading section, maintenance tips, pointers to the likes of "Bicycle touring across Labrador," and on, the Activities Resource section alone would make a fine page. We can't say enough about what the rather anonymous Webmasters have assembled here, except check it out!

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤٤ صفحه امروز
تبليغات


نمايش گرافيکی ساعت
ميتوانيد ساعت سيستم کاربر را بر روی سايت بصورت گرافيکی بنمايش در بياورید.
توسط: مرتضی پاينده | تاريخ: جمعه 8 آذر 1381 | تعداد بازديد کننده: 26409

حرکت عکس بدنبال موس (2)
بدليل استقبال کاربران از شماره قبلي اين اسکريپت (حرکت عکس بدنبال موس) تصميم گرفتم Version جديدتر اين اسکريت را با قابليت توقف حرکت موس, ارائه دهيم.
توسط: مديريت سايت | تاريخ: چهارشنبه 30 بهمن 1381 | تعداد بازديد کننده: 26095

حرکت عکس بدنبال موس
حرکت عکس بدنبال موس
توسط: مديريت سايت | تاريخ: دوشنبه 24 تير 1381 | تعداد بازديد کننده: 24295

اصول طراحي صفحات وب
اصول طراحي صفحات وب
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 23082

افکت روي متن
با استفاده از اين اسکريپت ميتوانيد متن را به حرکت درآوريد.
توسط: مهدي ميرزايي | تاريخ: يکشنبه 21 ارديبهشت 1382 | تعداد بازديد کننده: 22346

تبديل متن به گرافيک
با استفاده از اين اسکريپت میتوانيد جمله خود را بصورت گرافيکی به نمايش در آوريد.
توسط: مرتضی پاينده | تاريخ: شنبه 17 آبان 1382 | تعداد بازديد کننده: 18693

حرکت متن درون Box
می توانيد متن دلخواه خود را در Box مورد نظر به حرکت درآوريد.
توسط: يوشا ماندنی پور | تاريخ: يکشنبه 30 شهريور 1382 | تعداد بازديد کننده: 18090

بازي O_X
بزرگترين مزيت استفاده از JavaScript قابليت اجراي آن در سيستم کاربر مي باشد. اين خصوصيت باعث شده تا بتوانيم حتي براي کاربران Game طراحی کنیم و آنها را به بازی با سیستم خود در محیط IE تشويق نماييم !
توسط: مديريت سايت | تاريخ: سه شنبه 2 دي 1382 | تعداد بازديد کننده: 16347

ترانس رنگ
ميتوانيد بر روي سايت خود ترنسفر رنگ ايجاد نماييد.
توسط: مهدي ميرزايي | تاريخ: دوشنبه 5 خرداد 1382 | تعداد بازديد کننده: 15134

تعريف home page
با استفاده از اين اسکريپت می توان نشانی سايت موردنظر را به عنوان home page به browser کاربر معرفی نمود.
توسط: سپهر لاجوردی | تاريخ: دوشنبه 13 مرداد 1382 | تعداد بازديد کننده: 15104

تغيير رنگ Boxها
با استفاده از اين اسکريپت ميتوانيد رنگ Boxها را بعد از کليک کردن تغيير دهيد.
توسط: مديريت سايت | تاريخ: جمعه 6 تير 1382 | تعداد بازديد کننده: 13971

تاريخ شمسي
درج تاريخ شمسي
توسط: احمد | تاريخ: يکشنبه 28 شهريور 1383 | تعداد بازديد کننده: 13938

قرار دادن ساعت بر روی سايت
با استفاده از اين اسکريپت ميتوان ساعت را بر روی سايت بطور دايناميک به نمايش درآورد
توسط: مديريت سايت | تاريخ: دوشنبه 31 تير 1381 | تعداد بازديد کننده: 13024

انتخاب radio button
ميتوانيد رنگ radio button هاي انتخابي را بعد از select تغيير دهيد.
توسط: مديريت سايت | تاريخ: جمعه 12 ارديبهشت 1382 | تعداد بازديد کننده: 12720

نمايش يک تصوير به صورت اتفاقي
در صورت وجود منبع بزرگي از تصاوير در صفحه, ميتوان از يک تصوير بفرم اتفاقي استفاده کرد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 12519

نمایش منو با یک کلیک
با استفاده از اين اسکريپت ميتوانيد منوي مورد نظر خود را با يک کليک به نمايش درآوريد.
توسط: ناصر نايب | تاريخ: يکشنبه 3 آذر 1381 | تعداد بازديد کننده: 12510

نمايش فايل گرافيکی
با استفاده از اين مجموعه دستوارت ميتوانيد فايل گرافيکي موجود در سيستم خود را در پنجره Browser همراه با اطلاعات کامل به نمايش درآوريد.
توسط: مديريت سايت | تاريخ: چهارشنبه 6 فروردين 1382 | تعداد بازديد کننده: 12298

چرخش سايه متن
در IE يکسري داده غير استاندارد بنام Filler وجود دارد که به javascript قابليت تغيير و اصلاح objectها را ميدهد.
توسط: مديريت سايت | تاريخ: شنبه 13 مهر 1381 | تعداد بازديد کننده: 11571

قرار دادن متن در قسمت Title
ميتوانيد متن را در قسمت Title صفحات خود بصورت فعال به نمایش در آوريد.
توسط: ناصر نايب | تاريخ: شنبه 12 بهمن 1381 | تعداد بازديد کننده: 11554

نمايش عمودی متن
با استفاده از اين اسکريپت ميتوان متنی را بصورت عمودی به نمايش درآورد.
توسط: مديريت سايت | تاريخ: جمعه 16 اسفند 1381 | تعداد بازديد کننده: 11419

اجرای صدا در زمانی مشخص
با استفاده از اين اسکريپت ميتوانيد آهنگ دلخواه خود را در ساعتی مشخص به اجرا درآوريد.
توسط: مرتضی پاينده | تاريخ: چهارشنبه 13 آذر 1381 | تعداد بازديد کننده: 11375

پيغام متحرک در status bar
توسط اين اسکريپت جمله اي درون قسمت status bar پنجره هاي browser به حرکت در مي آيد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 10948

پيامها در status bar
يکي ديگر از کارهايي که ميتوان انجام داد, ارائه توضيحات لازم براي هر پيوند, در هنگام قرار گرفتن نشانگر موس بر روي آنها در قسمت status bar ميباشد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 10350

نمايش Cookieها
نمايش Cookieها
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 10180

نوشتن متن در قسمت
اين اسکريپت موجب خواهد شد که حروف يک کلمه ابتدا تک تک به نمايش درآيد سپس تکميل گردد.
توسط: مديريت سايت | تاريخ: جمعه 18 مرداد 1381 | تعداد بازديد کننده: 10173

قرار دادن page درون قالب
با دستور ميتوانيد يک Page ديگري را در صفحه فعلي نمايش دهيد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 9899

تاکيد يک مطلب
ميتوانيد مطلب مورد نظر خود را در قسمت پايين Browser کاربر به دفعات به نمايش درآوريد.
توسط: مديريت سايت | تاريخ: دوشنبه 28 مرداد 1381 | تعداد بازديد کننده: 9791

قرار دادن تاريخ فعلي بر روي صفحه وب
قرار دادن تاريخ فعلي بر روي صفحه وب
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 9740

ارجاع به صفحه مورد نظر بعد از زماني مشخص
در اين اسکريپت ميتوانيد صفحه را بعد از مدت زمان خاصي Refresh نماييد و صفحه جديدي را بجاي صفحه کنوني بارگزاري نماييد.
توسط: مديريت سايت | تاريخ: يکشنبه 13 مرداد 1381 | تعداد بازديد کننده: 9498

دستور Thead
Thead دستوري است که به موجب آن مي توان براي Table عنوان هايي را مشخص نمود.
توسط: مديريت سايت | تاريخ: جمعه 24 ارديبهشت 1383 | تعداد بازديد کننده: 9446

نحوه ايجاد Control panel
يکي از راههاي ايجاد امکانات بيشمار در زمينه طراحي صفحه هاي با قابليت ايجاد ارتباط استفاده از زير پنجره ها ميباشد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 9212

ايجاد Cookie
ايجاد Cookie
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 9090

تغيير bgcolor
با استفاده از اين اسکريپت ميتوانيد رنگ پس زمينه را تغيير دهيد.
توسط: مديريت سايت | تاريخ: جمعه 18 مرداد 1381 | تعداد بازديد کننده: 9047

اسکريپتهاي CGI
توضيحی مختصر در مورد اسکريپتهاي CGI
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8960

غير فعال کردن دکمه سمت راست موس
غير فعال کردن دکمه سمت راست موس
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8948

محل قرار گرفتن اسکريپتها
اسکريپتها را ميتوان در دوجا درون صفحه قرار داد: يا داخل تگهاي و و يا داخل تگهاي و
توسط: مديريت سايت | تاريخ: دوشنبه 24 تير 1381 | تعداد بازديد کننده: 8708

تغيير سايز browser
شما با اين دستور ميتوانيد بزرگي و کوچکي browser کاربر را مشخص نماييد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8678

قرار دادن چندين rollover در صفحه
تابحال دستورات مورد نياز براي قرار دادن تنها يک rollover در صفحه آموختيد, براي قرار دادن چند rollover بايستي تنها اندکي دستور به آنچه قبلا ذکر شده بيافزاييد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8572

اخطار به کاربر
اخطار به کاربر
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8545

نوشتن متن درون سند on the fly
قابليت نوشتن اطلاعات بر روي يک صفحه وب در پي پاسخ به عمل کاربر, يکي از راههاي مفيد در ديناميک کردن صفحه بوده و در ضمن از اين طريق کلا ميتوان کاربردهاي گوناگون پيدا نمود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8469

معتبر سازي ادرس Email با استفاده از معادلات قاعده اي
با استفاده از معادلات با قاعده, ميتوان آدرسهاي Email را معتبر ساخت.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8268

خواندن Cookie
بعد از تنظيم Cookie بايستي از آن در موارد مفيد و گوناگون استفاده نمود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8241

منوهاي Select-Go
در صورتيکه در سايتهاي شبکه اينترنت به جستجو پرداخته باشيد, به احتمال قوي با منوهايي که داراي چندين انتخاب باشند ...
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8162

بازي با روزها
ممکن است بخواهيد در مواقع و زوهاي خاص سال مثلا آخر هفته, پيغامي خاص به کاربر ارائه دهيد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8099

ايجاد rolloverهاي کاراتر
به منظور ايجاد يک تصوير متحرک در هنگام قراردادن ماوس برروي تصوير, بايستي در نمايش تصوير دوم تاخيري ايجاد نشود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8024

کنترل Browser
شما ميتوانيد پنجرهاي موجود را به سادگي کنترل نماييد و يا مشخصات خاصي را براي آن تعريف نماييد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7967

OnMousedown Event
يکي از سوالهايي که بطور فراوان, توسط اکثر کاربران پرسيده ميشود, نحوه و چگونگي پنهان کردن اصل محتوي اسکريپت بکار گرفته شده در صفحه است.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7958

ارائه يک پيغام براي زماني از روز
ارائه يک پيغام براي زماني از روز
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7908

ايجاد rolloverها
مفهوم rollover بسيار ساده ميباشد, بدين معنا که ابتدا دو تصويروجود داشته, تصوير اول در هنگام دريافت صفحه وب توسط کاربر در browser نمايش داده ميشود...
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7870

تاييد انتخاب شدن اجزاي يک منو
تاييد انتخاب شدن اجزاي يک منو
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7866

اعلان پيغام به کاربر
در بعضي موارد بجاي دريافت اعلام بله/خير (yes/no) از طرف کاربر نياز به جواب بيشتري ميباشيم.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7789

معتبر سازي نام فايل
RegExpها داراي توانايي و قابليتهاي بيشماري ميباشند, بطوريکه يکي از قابليتهاي پر کاربرد آنها,معتبر سازي وروديهاي فيلدها در فرم صفحه وب ميباشد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7682

تشابه فيلدهاي Password
تشابه فيلدهاي Password
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7593

فراخواني تابع
فراخواني تابع
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7557

تاييد انتخاب کاربر
تاييد انتخاب کاربر
توسط: مديريت سايت | تاريخ: دوشنبه 24 تير 1381 | تعداد بازديد کننده: 7252

وجود Java
قبل از قراردادن appletهاي جاوا براي افزايش کارايي و زيبايي صفحه وب, بايستي ابتدا وجود قابليت غير فعال کردن جاوا در browser آزمايش گردد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7232

تشخيص زبانbrowser كاربر
تشخيص زبانbrowser كاربر
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7143

تنظيم يک فيلد بر اساس فيلد ديگر
شايد تابحال به فرمهايي برخورد کرده ايد که با تعيين يک فيلد, فيلد ديگر بصورت اتوماتيک انتخاب ميشود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7096

onDbclick Event
بدين طريق کاربر ميتواند با انجام عمل Double Click عمل خاصي را مشاهده خواهد کرد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6972

onFocus Event
در صورتيکه بخواهيد در يک فيلد که اطلاعات مخصوص به نمايش در مي آيد, کاربر تغييراتي در آن اعمال نکند
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6870

شناسايي Browser
با اين مجموعه دستورات ميتوانيد Browser کاربر را شناسايي نماييد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6856

onUnLoad Event
در هنگام ترک يک صفحه وب, کنترل کننده onUnLoad فعال ميشود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6783

بکارگيري Radio button ها
بکارگيري Radio button ها
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6771

قرار دادن توضيحات در اسکريپتها
قرار دادن توضيحات در اسکريپتها را ميتوان از نکات مهم در هنگام نوشتن اسکريپتها دانست
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6770

کار با پنجرهاي Browser
کار با پنجرهاي Browser
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6653

پنهان کردن اسکريپتها از browserهاي قديمي
مخفی کردن تکها از Browserهای قديمی
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6618

دستور عمل redirecting با استفاده از پيوند
دستور عمل redirecting با استفاده از پيوند
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6559

دستور العمل redirecting
نه تنها ميتوان وجود برنامه JavaScript را درسيتم کاربر چک کرد, بلکه ميتوان علاوه بر آن نسخه JavaScript را نيز معين نمود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6390

توابع
تابع مجموعه اي از جملات JavaScript بوده که يک وظيفه مشخصي را انجام ميدهند. بطوريکه هر تابع داراي اسم بوده و توسط قسمتهاي ديگر اسکريپت فراخواني ميشود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6267

کارکترهاي خاص معادلات قاعده اي
کارکترهاي خاص معادلات قاعده اي
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6071

onResize Event
از آنجايي که درنسخه 4 برنامه Netscape, هنگام تغيير اندازه پنجره يک bug معروف وجود داشته بنابراين بايستي بعد از تغيير اندازه صفحه, محتويات درون پنجره را مجددا Load نمود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6058

Submit کردن فرم
Submit کردن فرم بدون دخالت کاربر.
توسط: مديريت سايت | تاريخ: شنبه 15 مرداد 1384 | تعداد بازديد کننده: 1736

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤٥ صفحه امروز
تبليغات


محل قرار گرفتن اسکريپتها
توصيه به ديگران

توسط: مديريت سايت

نسخه مناسب چاپ

تاريخ نشر: دوشنبه 24 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 8709 بار خوانده شده است

اسکريپتها را ميتوان در دوجا درون صفحه قرار داد: يا داخل تگهاي <head> و <head/> و يا داخل تگهاي <body> و <body/> .

براي نوشتن اولين اسکريپت

  1. عبارت
    <"script language="JavaScript" type="text/JavaScript>
    را تايپ کنيد. بدين طريق تگ ابتدايي دستور <script> وجود اين برنامه را به browser معين ميکند.
    ويژگي "script language="JavaScript نوع زبان اسکريپت نويسي را تعيين کرده و بوسيله ويژگي type="text/javascript"s اسکريپت را بعنوان plain text تحت JavaScript معرفي ميکند.

  2. سپس عبارت ("document.write("test1 را تايپ کنيد, بدين طريق يک پنجره جديد باز شده و در آن عبارت test1 تايپ ميشود.

  3. تگ پاياني <script/> را تايپ کنيد.

بعد از اين browser بقيه سند HTML را اجرا ميکند زيرا متوجه پايان اسکريپت شده است.
**نکات مورد توجه

  • ميتوان در يک صفحه به هر تعداد از تگ اسکريپت <script> استفاده نمود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦٥ صفحه امروز
تبليغات


پنهان کردن اسکريپتها از browserهاي قديمي

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 6618 بار خوانده شده است

browserهاي قديمي از جمله amrica online 1, internet explorer 3, netscape قبل از ويرايش چهارم, JavaScript را متوجه نميشوند, از آنجا که اساس browser بر اين مبنا است که در صورتي که متوجه تگي نشود, از آن بگذرد, اما همه آنها اينگونه عمل نميکنند. يک راه براي پنهان کردن آنها وجود دارد که بوسيله آن تمامي محتويات موجود در تگ مورد نظر به عنوان تگ HTML در نظر گرفته ميشود و در نتيجه اجرا نخواهند شد.

به منظور پنهان کردن اسکريپتها از browserهاي قديمي:

ابتدا عبارت <--hide script from old browser --!> را تايپ کنيد. بدين وسيله دستور HTML نوشته ميگردد.

 1.

سپس عبارت document.write("test")d را تايپ کنيد.

 2.

سپس عبارت <--end hiding script from old browser// را تايپ کنيد. اين خط با علامت مخصوص (//) شروع و باعلامت مخصوص HTML , <--- پايان ميپذيزد.

 3.

**نکات مورد توجه

  • اين تکنيک نيز مانند دستور قبل در تمام اين سايت فرض شده و فقط در اين مثال به آن توجه شده ولي وجود آن ضروري است.

  • در صورتي که بخواهيد عبارتي را براي کاربراني که از browserهاي قديمي استفاده ميکنند بنويسيد, آنرا در تگ <noscript> قرار دهيد, اين پيغام هم در browserهاي قديمي و در browserهاي جديدي که JavaScript در آنها فعال نيست, نشان داده ميشود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٣٩ صفحه امروز
تبليغات


قرار دادن توضيحات در اسکريپتها

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 6771 بار خوانده شده است

قرار دادن توضيحات در اسکريپتها را ميتوان از نکات مهم در هنگام نوشتن اسکريپتها دانست, زيرا که بدين طريق ميتوان علل نوشتن چنين اسکريپتها را متوجه شد. همچنين يکي ديگر از دلايل نوشتن توضيحات اسکريپت, کمک به استفاده مجدد آن توسط ديگر افراد ميباشد.
براي نوشتن توضيح در اسکريپتها
ابتدا متن مورد نظر را تايپ کنيد. | 1.
توجه داشته باشيد با علامت --!> , JavaScript ديگر به تمامي محتويات داخل آن توجهي از لحاظ دستوري نميکند. |
سپس براي پايان توضيحات علامت <-- را تائپ کنيد. | 2.
سپس دستورات اصلي که در اينجا document.write("test")s است را تائپ کنيد. | 3.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦٤ صفحه امروز
تبليغات


اخطار به کاربر

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 8546 بار خوانده شده است

يکي از مزاياي برنامه JavaScript قابليت ارائه پيش زمينه ذهني به کاربران صفحه طراحي شده ميباشد, بدين معنا که پنجره اي براي اعلام نياز به برنامه JavaScript در صفحه وب مورد درخواست کاربر نمايش در مي آورد. در طراحي نوين, اين روش منسوخ شده است.

براي اخطار به کاربر

عبارت arert("welcome to IranJavaScript webSite")s را تائپ کنيد, همانطور که مشاهده ميکنيد مجموعه اسکريپتهاي مورد نياز براي اخطار دادن به کاربر بايد در بين تگ و قرار گيرد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦٦ صفحه امروز
تبليغات


تاييد انتخاب کاربر

نسخه مناسب چاپ

تاريخ نشر: دوشنبه 24 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 7253 بار خوانده شده است

تاييد انتخاب کاربر

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦٧ صفحه امروز
تبليغات


اعلان پيغام به کاربر

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 7790 بار خوانده شده است

در بعضي موارد بجاي دريافت اعلام بله/خير (yes/no) از طرف کاربر نياز به جواب بيشتري ميباشيم. در اين حالت همانطور که اسکريپت فوق مشاهده ميکنيد, امکان پرسش سئوالي (البته باجواب از قبل تعيين شده) از کاربر فراهم شده تا جوابي بصورت يک جمله از پيش تعيين شده دريافت کنيد.

براي اعلان پيغام به کاربر

ans=prompet("Are you sure you want to do that ?)

در پرانتز اين دستور همانطور که مشاهده ميکنيد, سئوال مطرح شده براي کاربر و جواب از پيش تعيين شده, که در هر صورت يا جواب کاربر برگردانده شده و يا هيچ. حالت دوم در يکي از سه حالت زير پيش مي آيد:
يا برروي "cancel" کليد کند و يا جواب پيش فرض وجود نداشته و کاربر برروي "ok" کليک نمايد و يا کاربر جواب از پيش تعيين شده را پاک کرده و سپس بر روي "ok" کليک نمايد.

**تذکر

  • در بعضي از browserها ميتوان پارامتر قسمت دوم را بدون ايجاد خلل حذف کرد. اما در بغيه, پيغام پيش فرض بنام "undefined" ظاهر ميشود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦٨ صفحه امروز
تبليغات


دستور العمل redirecting

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 6391 بار خوانده شده است

نه تنها ميتوان وجود برنامه JavaScript را درسيتم کاربر چک کرد, بلکه ميتوان علاوه بر آن نسخه JavaScript را نيز معين نمود. همانطور که در اسکريپت زير مشاهده ميکنيد نحوه عمل redirect کردن و يا فرستادن کاربر به صفحه اي ديگر بر اساس نسخه JavaScript موجود در browser ذکر شده است.

به منظور انتقال کاربر به صفحه جديد

<script language="javascript 1.3" type="text/javascript">

 1.

توسط ويژگي Language در تگ script ميتوان حداقل نسخه اي که browser بتواند زبان اسکريپت نوشته شده را اجرا کند, مشخص نمود. در اين حالت browser نيازمند برنامه JavaScript 1.3 و به بعد ميباشد, بطوريکه اگر browser قابليت اجراي اسکريپت را نداشته باشد, پيغام خطا را مشاهده خواهد کرد.

Window.location="www.microsoft.com"s

2.

در اين خط مشخصه مکاني پنجره فعلي مجددا تنظيم ميشود. بعبارت ديگر browser صفحه فعلي را به صفحه اي خاص تغيير ميدهد.

</script>

3.

تگ پاياني اسکريپت

** نکات مورد توجه

  • نيازي به اضافه کردن ويژگي هاي type يا language به تگ پاياني <script/> نميباشد.

  • توجه داشته باشيد که ميتوان در يک صفحه, از چند نسخه (version) يک زبان اسکريپت استفاده کرد, مثلا در يک جا JavaScript 1.2 و در جاي ديگر JavaScript 1.5 را بکار برد.

  • نميتوان اسکريپت را محدود به نسخه خاصي نمود, از هر نسخه اي که تعيين شود نسخه هاي بعدي آن نيز به اجرا در مي آيد.

  • ذکر اين نکته نيز الزامي است که با مشخص کردن نسخه مخصوصي از اسکريپت, تعدادي از کاربران و بينندگان صفحه در شبکه اينترنت, قادر به دسترسي آن نبوده و در نتيجه عموميت شبکه و استفاده از آن محدود ميشود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦٩ صفحه امروز
تبليغات


دستور عمل redirecting با استفاده از پيوند

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 6560 بار خوانده شده است

هنگاميکه کاربر اسکريپت موجود در بحث قبل را اجرا کرد, مستقيما از يک صفحه به صفحه ديگر بطور اتوماتيک فرستاده ميشود, بدين وسيله کاربر ميتواند قبل از رفتن به دومين صفحه, بطور مختصر صفحه اول را مشاهده کند و چون اينگونه بنظر ميرسد که در هر صورت مشاهده کامل صفحه ضروري ميباشد, در نتيجه بهتر است عمل انتقال کاربر (redirecting) توسط يک پيوند در صفحه اول انجام شود.
براي انتقال کاربر با استفاده از پيوند
<a href="http://microsoft.com" onclick="windows.locating="aghta.com" ; return false">test</a>s | 1.
بدين صورت, برنامه JavaScript را در تگ پيوند درون سند HTML قرار داده و در صورتيکه کاربر برنامه مزبور را نداشته باشد, پيغامي مبتني بر نياز وجود JavaScript مشاهده خواهد کرد. |
ولي در صورتي که کاربر برنامه قابل اجرا براي JavaScript را داشته و بر روي پيوند کليک کند, کنترل کننده onClick صفحه جديد اجرا ميکند. اما در قسمت return false فرايند مربوطه به درخواست, کاربر متوقف ميسازد و ديگر آدرس مربوطه اجرا نخواهد شد. | 2.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٣ بازديدکننده در حال حاضر
٦٧٥ صفحه امروز
تبليغات


شناسايي Browser

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 6857 بار خوانده شده است

اغلب موارد اجراي مناسبترين حالت يک صفحه بهتر است که نوع browser کاربر مشخص شود.
براي شناسايي نوع browser کاربر
if(navigator.appName== "Microsoft Internet Explorer"){ | 1.
بدين وسيله در صورتيکه مشخصه appName در browser برنامه Microsoft Internet Explorer باشد, اسکريپت به قسمت then ميرود. |
document.write("You're ruuning Internet Explorer") | 2.
در صورتيکه شرط درست باشد دستور write اجرا شده و عبارت داخل گيومه نشان داده ميشود. |
else {s if(navigator.appName== "Netscape") { | 3.
ميتوان از دستور if/else ديگري استفاده نمود, در اين مرحله در صورتيکه appName مربوطه به Netscape باشد, برنامه به قسمت then در مرحله بعد ميرود. |
document.write("You're running Netscape") | 4.
در صورتي که کاربر از IE استفاده کند متن بالا براي نمايش داده خواهد شد. |
document.write("You're not running Netscape or IE") | 5.
در صورتيکه کاربر نه از IE و نه از Netscape استفاده کند, پيغام فوق نمايش داده خواهد شد. |

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٥ بازديدکننده در حال حاضر
٦٧٨ صفحه امروز
تبليغات


وجود Java

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 7234 بار خوانده شده است

قبل از قراردادن appletهاي جاوا براي افزايش کارايي و زيبايي صفحه وب, بايستي ابتدا وجود قابليت غير فعال کردن جاوا در browser آزمايش گردد. تسط اسکريپت فوق ميتوان فعال و يا غيرفعال بودن و بطور کلي, وجود آنرا در سيستم کاربر جستجو کرد.

براي بررسي در فعال بودن جاوا

document.write("Java is")

1.

ابتدا جمله پيغام دهنده را در يک گيومه قرار دهيد.

if (!navigator.javaEnabled()) {

2.

توسط دستور فوق العاده بودن جاوا مورد بررسي قرار ميگيرد. مفهوم علامت تعجب (!), کلمه نه ميباشد, پس دستور فوق در واقع غير فعال بودن جاوا را سئوال ميکند.

document.write("not")

3.

در صورتيکه نتيجه مرحله قبل, درست باشد, در نتيجه برنامه جاوا غيرفعال بوده و سپس کلمه "not" چاپ ميشود.

document.write("enabled")

4.

در هر صورت کلمه فعال (enabled) در پايان, در پنجره کاربر ظاهر ميشود.

**تذکر

  • با توجه به وجود اسکريپت هاي مختلف JavaScript بهتر است براي ترکيب آنها اين اسکريپتها را در مکاني خاص ذخيره کنيد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤٧ صفحه امروز
تبليغات


توابع

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: شروع JavaScript

اين مقاله تاکنون 6269 بار خوانده شده است

تابع مجموعه اي از جملات JavaScript بوده که يک وظيفه مشخصي را انجام ميدهند. بطوريکه هر تابع داراي اسم بوده و توسط قسمتهاي ديگر اسکريپت فراخواني ميشود.
از خصوصيات توابع, ميتوان از استفاده متناوب و بيشمار آن در کل اسکريپت نام برد. مثلا توسط تابعي, اطلاعاتي تائپ شده توسط کاربر درون يک فرم با برنامه JavaScript ذخيره ميشود. ذکر اين نکته نيز لازم است که ميتوان از يک کد به دفعات براي استفاده يکسري اطلاعات استفاده کرد. اما بهتر است که کد مربوطه را بعنوان يک تابع نوشته و سپس تابع را در مکانهاي مختلف اسکريپت استفاده نمود. تابع, شامل لغت function به همراه نام تابع ميباشد و سپس بعد از نام تابع, پرانتزها و يک براکت قرار ميگيرد. بعد از آن دستور العمل مورد نظر نوشته شده و براکت بسته ميشود. در زير نمونه اي از تابع نوشته شده است:

Function saysomething(){
alert("for score and seven years ago")
}

توجه داشته باشيد که خط دستور (alert) براي شناسايي و راحتي تشخيص کد, اندکي از خط به داخل رفته است.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤٨ صفحه امروز
تبليغات


فراخواني تابع

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 7559 بار خوانده شده است

براي فراخواني تابع بهتر است که از کنترل کنندهاي حالت همان طور که قبلا توضيح داديم, استفاده نمود.
مثلا براي فراخواني تابع saysomething در هنگام کليک برروي دکمه (button) بايستي از کد زير استفاده کنيد:

<input type="button" value="lincoln" onclick="saysomething()"

تبادل اطلاعات

در اغلب موارد بايستي به تابع يک سري اطلاعات داد و يا از آن يک سري اطلاعات دريافت نمود.
به اين عمل تبادل اطلاعات گويند.

function saysomething(message) {
alert(message)
}

همچنين کد فراخواني به صورت زير ميباشد:

<input type="button" value="lincoln" onclick="'four score and saysomething seven years ago..'">

در تابع فوق متغيير message پارامتر تابع ناميده ميشود, بطوريکه در هنگام فراخواني تابع داده Four score and seven years years ago به پارامتر message ارتباط داده ميشود. پارامترهاي تابع ميتواند شامل رشته حرفي, عددي و حتي يک (JavaScript object) ديگر باشند.
يکي از محسنات اين نوع تابع, استفاده از آن در يک سري از دکمه ها ميباشد که با يک تابع, پيغام هاي مختلفي به کاربر داده ميشود.

<input type="button" value="lincoln" onclick="saysomething('four score and saysomething seven years ago..')">

<input type="button" value="kennedy" onclick="sysomething (Ask not what your country can do for you..">

<input type="button" value="nixon" onclick="saysomething('I am not a crook!)'">

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤٩ صفحه امروز
تبليغات


پيغام متحرک در status bar

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 10950 بار خوانده شده است

توسط اين اسکريپت جمله اي درون قسمت status bar پنجره هاي browser به حرکت در مي آيد.

براي ايجاد پيغام متحرک در status bar

myMsg="welcome to IranJavaScript.com website..

.1

بدين طريق متغير myMsg به متن داخل علامت گيومه مرتبط شده است.

i=0

.2

متغير i در برنامه بعنوان شمارنده استفاده ميشود. در طول اين برنامه مقدار i ايتدا زياد و سپس به صفر بر ميگردد.

function scrollMsg() {

.3

توسط اين دستور, تابعي با نام scrollMsg ايجاد ميشود.

window.status=myMsg.SUBstring
(i,myMsg.length) + myMsg.
SUBstring(0/i-1)

.4

توسط اين خط ويژگي قسمت status bar در پنجره تنظيم ميشود, بعبارت ديگر مشخصات همان خطي که در پايين پنحره قرار ميگيرد, تعيين ميگردد. همچنين توسط SUBstring(x,y)s متغيير myMsg به دو قسمت تقسيم ميشود, بگونه اي که پيغام کاراکتر از مکان کاراکتر x شروع و به مکان ما قبل y خاتمه مي يابد.

if (i<myMsg.>length)
i++

.5

در صوتيکه مقدار i کمتر از طول متغيير myMsg باشد, به i مقدار يک اضافه ميگردد.

else {
i=0

.6

در غير اين صورت, هنگاميکه مقدار i برابر و يا بيشتر myMsg , باشد, مقدار i=0 ميگردد.

setTimeout("scrollMsg()",50)

.7

توسط دستور setTimeout()s ميتوان توقفي در فرآيند ايجاد کرد. بطوريکه بايستي در داخل پرانتزها, نام تابعي که بايستي متوقف شود را نوشته و سپس بعد از کاما مدت زمان توقف را برحسب ميلي ثانيه مشخص نمود. در اين مثال, تابع scrollMsg()s به مقدار 50 ميلي ثانيه در فرايند, متوقف ميشود.

**نکات مورد توجه

  • براي افزايش و سرعت نمايش پيغام متحرک, عدد 50 را در مرحله 7 کاهش دهيد و بالعکس.

  • توجه داشته باشيد که هر ثانيه شامل 1000 ميلي ثانيه ميباشد.

  • امروزه استفاده از پيامهاي متحرک در قسمت status اندکي کليشه اي شده است.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٥٠ صفحه امروز
تبليغات


پيامها در status bar

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: شروع JavaScript

اين مقاله تاکنون 10352 بار خوانده شده است

يکي ديگر از کارهايي که ميتوان انجام داد, ارائه توضيحات لازم براي هر پيوند, در هنگام قرار گرفتن نشانگر موس بر روي آنها در قسمت status bar ميباشد.

<A href="aghta.com"
                    onMouseover="window.status='Personal web site' ; return
                    true" onMouseout="window.status=''; return true">test</a>

همانطور که مشاهده ميکنيد دستورات JavaScript در تگ آدرس دهي HTML قرار گرفته اند, بطوريکه توسط کنترل کننده onMouserover هنگام قرار گرفتن ماوس برروي پيوند مربوطه, عمل خاصي را انجام داده, در اين مثال عبارت 'Persinal web site' را در پيوند test به شي window.status,(object)s ربط داده است. در قمستي return true پيغام نمايش داده ميشود. سپس کنترل کننده onMouseout عبارت فوق را در قسمت status پاک ميکند.

<a href="aghta.com"
                    onMouseover="window.status='personal web site !';return
                    true" onMouseout="window.status='';return true">test</a>
**نکته

  • توجه داشته باشيد که بعضي از نسخه هاي IE قادر به استفاده از اين کنترل کننده نيستند.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٥١ صفحه امروز
تبليغات


ايجاد rolloverهاي کاراتر

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: بازي با تصاوير

اين مقاله تاکنون 8024 بار خوانده شده است

به منظور ايجاد يک تصوير متحرک در هنگام قراردادن ماوس برروي تصوير, بايستي در نمايش تصوير دوم تاخيري ايجاد نشود. بدين منظور با استفاده از JavaScript تمامي تصاوير را از قبل به سيستم کاربر انتقال داده تا در زمان لزوم, تصاوير توسط متغيير بوسيله اسکريپت نشان داده شوند.
براي تهيه rollover بهتر

if
                    (document.images) {
arrowRed = new Image
arrowBlue = new Image
arrowRed.src = "images/test1.gif"
arrowBlue.src = "images/test2.gif"
}

 1.
توسط اين کدها, قابليت درک اشياء توسط browser امتحان گشته, در صوريتکه جواب مثبت شد, دو تصوير مجزاي arrowRed و arrowBlue ايجاد ميگردند. سپس از ويژگي src در تعيين مکان تصوير استفاده ميشود.

else {
arrowRed = ""
arrowBlue = ""
document.arrow = ""
}

2.
براي browserهاي قديمي, به منظور جلوگيري از نمايش پيغامهاي اشتباه, بهتر است از حالت else با متغيرها و document.arrow که خالي هستند, يک رشته حرفي خالي درست کنيد.

<A href="aghta.com" onMuseover =
"document.arrow.src = arrowRed.src"
onMouseout = "document.arrow.src = arrowBlue.src">

3.
دستورات آدرس دهي فوق, براي ايجاد پيوند با توجه به مشخصات, rollover موجود در صفحه نوشته ميشود, يعني دو کنترل کننده onMouseover و onMouseout را درون تگ آدرس قرار داده تا دو حالت ممکن را تعريف کنند.
**نکات مورد توجه
  • يادآوري ميشود که در هنگام ايجاد تصوير gif از تصاوير شفاف استفاده نکنيد زيرا در هنگام تعويض تصوير دوم, تصوير قبل در زير آن نمايش داده ميشود.
  • توجه داشته باشيد که ابعاد هر دو تصوير بايستي يکسان باشند. هرچند در IE تصاوير غير اندازه بطور مناسب نمايش داده ميشوند, اما در netscape متيجه مطلوبي نخواهد داشت.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٣٣ صفحه امروز
تبليغات


ايجاد rolloverها

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: بازي با تصاوير

اين مقاله تاکنون 7870 بار خوانده شده است

مفهوم rollover بسيار ساده ميباشد, بدين معنا که ابتدا دو تصويروجود داشته, تصوير اول در هنگام دريافت صفحه وب توسط کاربر در browser نمايش داده ميشود, سپس بعد از آنکه کاربر, ماوس را برروي اولين تصوير ببرد browser تصوير دوم را با تصوير اول در عوض چند لحظه عوض ميکند.
براي ايجاد rollover

<A href="aghta.com"

1.
همانطور که ميدانيد, پيوند براي مشخص کردن مسير بعدي تصوير ميباشد.

onMouseover="document.arrow.src='images/test1.gif'"

2.
هنگام قرار گرفتن ماوس برروي تصوير دوم از داخل دايرکتوري برروي سند پنجره نمايان ميشود.

onMouseout="document.arrow.src='images/test2.gif'"

3.
سپس با کنار رفتن موس از روي تصوير, تصوير به حالت اوليه برميگردد.
**تذکر
  • ساختن rollover ها بدين طريق, در هنگام قرار گرفتن ماوس برروي تصوير, به علت وجود تصوير دوم بر روي server آن تصوير با اندکي تاخير نمايان ميشود. براي برطرف کردن اين موضوع به مبحث بعد که در مورد ollover ها کاملتر بحث ميشود, رجوع نماييد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٣٤ صفحه امروز
تبليغات


قرار دادن چندين rollover در صفحه

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: بازي با تصاوير

اين مقاله تاکنون 8572 بار خوانده شده است

تابحال دستورات مورد نياز براي قرار دادن تنها يک rollover در صفحه آموختيد, براي قرار دادن چند rollover بايستي تنها اندکي دستور به آنچه قبلا ذکر شده بيافزاييد.
براي قرار دادن چند rollover در صفحه

button1Red = new Image
button1Blue = new Image
button2Red = new Image
button2Blue = new Image

1.
بطور کلي براي هر rollover بايستي دو تصوير تهيه نمود.

button1Red.src = "images/test1.gif"
button1Blue.src = "images/test2.gif"
button2Red.src = "images/test1.gif"
button2Blue.src = "images/test3.gif"

2.
در اين مرحله مسير تصاوير ويژگي src تخصيص داده ميشود.

button1Red = ""
button1Blue = ""
button2Red = ""
button2Blue = ""

3.
اين مرحله نيز براي browserهاي قديمي در نظر گرفته ميشود تا در هنگام بارگذاري صفحه, پيغام اشتباه در روي سيستم کاربر نمايان نشود.

document.button1 = ""
document.button2 = ""

4.
هر کدام از متغييرهاي document نيز براي يک rollover نوشته ميشوند.
**تذکر
  • توجه داشته باشيد که هر تصوير و هر تگ IMG بايستي داراي يک نام باشند, در غير اينصورت JavaScript قادر به تشخيص مکانهاي تصاوير نميشود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٣٥ صفحه امروز
تبليغات


نمايش يک تصوير به صورت اتفاقي

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: بازي با تصاوير

اين مقاله تاکنون 12519 بار خوانده شده است

در صورت وجود منبع بزرگي از تصاوير در صفحه, ميتوان از يک تصوير بفرم اتفاقي استفاده کرد.
براي نمايش يک تصوير بصورت اتفاقي

myPix=newArray
("images/test1.gif","images/test2.gif",
"images/test3.gif")

1.
بدين وسيله يک ارائه 3 عضوء با نام myPix ايجاد ميشود.

imgCt=myPix.Length

2.
تعداد ارقام موجود در آرايه myPix برابر با مقدار متغيير imgCt ميگردد.

function choosepic(){

3.
تابع choosepic()s تعريف ميگردد.

if(document.images) {
randomNum = Math.floor
((Math.random()*imgCt))

4.
در صورتي که سند بتواند تصاوير را به نمايش درآورد, متغيري بنام randomNum ايجاد شده که در نتيجه ارزشي عبارت رياضي را دريافت ميکند. و اما عبارت Math.random()s يک عدد اتفاقي بين صفر و بک ايجاد نموده و سپس با متغيير imgCt ضرب ميکند. در ضمن بدليل گردکردن نتيجه عددي, عدد بايستي بين صفر و دو باشد.

document.myPicture.src= myPix[randomNum]

5.
بدين صورت مبدا تصوير myPicture در متغيير myPix بوده که در اين حالت ارزش مقداري آن وابسته به مقدار random Num ميباشد.

onload = "choosePic()"

6.
با استفاده از دستور onLoad تابع choosePic آغاز ميشود.

<img src="images/test1.gif" name="myPicture">

7.
در اين قسمت نام تصوير myPicture نامگذاري شده و سپس از آن در تغيير تصوير توسط اسکريپت استفاده ميشود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٣٦ صفحه امروز
تبليغات


تشخيص زبانbrowser كاربر

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 7143 بار خوانده شده است

تشخيص زبان كاربري كه وارد سايت شما مي ‌شود، مي تواند خيلي جالب باشد و كارايي سايت شما را بالاتر ببرد. Navigator 4.0 و نگارش هاي بعدي آن داراي خصوصيت navigator.language هستند، كه يك كد دو حرفي بر حسب زبان مرورگر وب شما است و از استاندارد ISO639 استفاده مي كند. براي مثال اگر زبان مرورگر خود را روي فارسي قرار داده باشيد كدي كه توسط اين خصوصيت برگردانده مي شود fa خواهد بود. ليست كامل اين كدها در آدرس زير موجود است:
http://palimpsest.stanford.edu/lex/iso639.html

مرورگرهاي IE 4.0 و نگارش هاي بعدي آن نيز داراي سه خاصيت هستند:
browserLanguage , systemLanguage , userLanguage
browserLanguage زبان انتخاب شده در مرورگر
systemLanguage زبان انتخاب شده در سيستم عامل
userLanguage زباني كه كاربر فعلي در Control Panel و در قسمت RegionalSettings انتخاب كرده است.

كد برگردانده شده توسط اين خصوصيات كمي با كدهاي داده شده در Navigator فرق مي كند، البته براي زبان فارسي همان كد fa داده مي شود. ليست كامل اين كدها در آدرس زير موجود است:
http://msdn.microsoft.com/library/default.asp?url=/workshop/author/dhtml/reference/language_codes.asp

به اين ترتيب شما مي توانيد به كاربران سايت خود، صفحات را به زبان خودشان نمايش دهيد. البته براي اين كار شما بايد اطلاعات بيشتري درباره javascript داشته باشيد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٣٧ صفحه امروز
تبليغات


قرار دادن page درون قالب

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کار با Framesها

اين مقاله تاکنون 9899 بار خوانده شده است

با دستور ميتوانيد يک Page ديگري را در صفحه فعلي نمايش دهيد.
براي قرار دادن يک صفجه درون قالب
if(top.location==self.location) { | 1.
محل قرار گرفتن صفحه فعلي(self) را در بالاترين سطح بررسي ميکند. درصورتيکه پاسخ منفي باشد, بدين معني خواهد بود که سطح فعلي در يک مجموعه قالب ميباشد. |
self.location.replace("http://iranjavascipt.com") | 2.
در صورتيکه محل صفحه فعلي در قسمت top باشد, صفحه فعلي را با آدرس مجموعه قالب تعويض ميکند. بدين طريق در يک مجموعه قالب نشان داده ميشود. |

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٣٨ صفحه امروز
تبليغات


کار با پنجرهاي Browser

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 6653 بار خوانده شده است

همانطور که مستحضر هستيد, پنجره يک فصل اشتراک مهم در شبکه وب ميباشد, بطوريکه توسط JavaScript ميتوان اعمال متفاوتي در چگونگي عملکرد اين پنجره ها انجام داد.
در اين قسمت ما با استفاده از يک gif قسمتها مختلف browser را به شما معرفي ميکنيم تا در مقالات بعد در صورت استفاده از اصطلاح شما دچار مشگل نگرديد.
معرفي قسمتهاي browser
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤٠ صفحه امروز
تبليغات


کنترل Browser

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 7969 بار خوانده شده است

شما ميتوانيد پنجرهاي موجود را به سادگي کنترل نماييد و يا مشخصات خاصي را براي آن تعريف نماييد.
نحوه اجرا
براي ايجاد صفحه جديد کافيست در قسمت

href="javaScript:openTourWindow('iranjavascript.com',500,300);"

تغييرات مورد نظر خود را اعمال نماييد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤١ بازديدکننده در حال حاضر
٧٥٤ صفحه امروز
تبليغات


نحوه ايجاد Control panel

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 9213 بار خوانده شده است

يکي از راههاي ايجاد امکانات بيشمار در زمينه طراحي صفحه هاي با قابليت ايجاد ارتباط استفاده از زير پنجره ها ميباشد.
براي ايجاد يک Control panel

newWindow = window.open("test2.asp","newWin","Width=200,height=350")

1.

با اين دستور پنجره جديدي باز خواهد شد که درون آن صفحه test2.asp نمايش داده خواهد شد.

function updateParent(newURL) {

2.
در اين مرحله صفحه test2.asp اجرا ميشود در اين خط, يک تابع جديد با نام updateParent و به همراه متغيير newURL تعريف شده است.

opener.document.location = newURL

3.
در اين خط, موقعيت سند opener بوسيله متغيير newURL معلوم ميشود.

<a href="javascript:updateParent('http://iranjavascript.com')">

4.
با کليک کردن بر روي پيوند IranJavaScript.com تابع updateParent صدا زده شده و متغيير newURL نام صفحه به test2.asp را به خود اختصاص ميدهد.
**نکته
  • در دستور زماني درست کار خواهد کرد که در تمام صفحاتي که نمايش داده ميشوند اسکريپت فوق وجود داشته باشد

function updateParent(newURL) {
opener.document.location = newURL

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٦٨١ صفحه امروز
تبليغات


تغيير سايز browser

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 8679 بار خوانده شده است

شما با اين دستور ميتوانيد بزرگي و کوچکي browser کاربر را مشخص نماييد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٦٨٢ صفحه امروز
تبليغات


منوهاي Select-Go

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 8163 بار خوانده شده است

در صورتيکه در سايتهاي شبکه اينترنت به جستجو پرداخته باشيد, به احتمال قوي با منوهايي که داراي چندين انتخاب باشند و بتوان اقلام آنها را انتخاب نموده و سپس با استفاده از کليد Go به مبحث مورد نظر متصل شود, برخورد کرده ايد.
براي ايجاد منوهاي Select -Go

Function jumpPage(newLoc) {

1.
ابتدا تابعي با نام jumpPage و به همراه متغيير newLoc ايجاد کنيد.

newPage=newLoc.options[newLoc.Select Index].Value

2.
نحوه کار اين دستور فوق از قسمت داخل به بيرون ميباشد.

if(newPage !="") {
Window.Location=newPage
}

3.
در صورتيکه متغيير newPage خالي نباشد, و يا به عبارتي اگر متغيير مذکور داراي مقداري باشد, پنجره به آدرس مشخص شده توسط انتخاب موجود در منو ميرود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٦٨٣ صفحه امروز
تبليغات


تشابه فيلدهاي Password

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 7594 بار خوانده شده است

هنگامي که کاربر بايستي رمز را براي استفاده مجدد تايپ کند به منظور کاهش احتمال خطا, دو فيلد password در فرم قرار ميدهند, که در صورت غير يکسان بودن محتوياتشان پيغام اخطاري به کاربر داده شود.
به منظور تعيين صحت Password هاي وارد شده

function validForm(passForm){
if (passForm.passwd1.valu == "") {
alert("you must enter a password")
passForm.passwd1.focus()
return false
}

1.
پس از تعيين تايع, مقدار فيلد Passwd1 مورد بررسي قرار گرفته و در صورت خالي بودن محتوايش, يک پيغام اخطار به مضنون, " کلمه عبور را تائپ کنيد" نمايان ميگردد. سپس نشانگر ماوس را به ابتداي فيلد Passwd1 برده و به تابع, ارزش false ميدهد.

if(passForm.passwd1.value !=passForm.passwd2.value) {
alert("entered passwords did not match")

passForm.passwd1.focus()
passForm.passwd1.select()

return false
}
return true
}

2.
در صورتکيه مقدار Passwd1 برابر Passwd2 نباشد, پيغام اخطار (alert) داده ميشود, سپس محتوي فيلد اول را انتخاب کرده بطوريکه ميتوان محتويات آن را تغيير داد. در غير اين صورت پيغام صحيح (true) را ارائه ميدهد.

onSubmit="return validForm(this)"

3.
در هنگام Submit فرم, چه با کليد Submit و چه با هر حرکت ديگري که مدنظر است, کنتزل کننده onSubmit به اجرا در مي آيد. در صورتيکه نتيجه بدست آمده از مراحل قبل صحيح (true) باشد, اطلاعات تائپ شده به Server فرستاده ميشود و در غير اين صورت کنترل کننده مزبور وجود اشتباه (false) را متوحه گشته و از فرستاده شدن اطلاعات به Server جلوگيري ميکند. در واقع يکي از فرمتهاي javascript درک اشتباه در قسمت Client side ميباشد, بنابراين هيچگاه Server در ارتباط با چنين عملي قرار نخواهد گرفت.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٦٨٤ صفحه امروز
تبليغات


تاييد انتخاب شدن اجزاي يک منو

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 7867 بار خوانده شده است

درمثال فوق کاربر بايد از فرم مربوطه يکي را حتما انتخاب نمايد.
براي تاييد انتخاب

function SubmitIt(carForm) {

1.
بدين صورت يک تابع با نام SubmitIt که در اجزاء فرم مورد استفاده قرار ميگيرد ايجاد ميشود.

colorChoice = carForm.color.selectedIndex

2.
متغيير colorChoice يکي از رنگهاي موجود را بر اساس انتخاب کاربر, به خود ميگيرد.

if(carForm.color.options[colorChoice].value == "") {
alert("You must pick a color")
return false

3.
در اين قسمت مقدار متغير colorChoice مورد بررسي قرار گرفته و در صورتيکه مقداري نداشته باشد, پيغام اخطاري به مضنون "يک رنگ انتخاب کنيد." به کاربر داده شده و نتيجه false ارسال ميشود, سپس مراحل از ابتدا آغاز ميگردد.

return true

4.
در غير اين صورت, صحت انتخاب تاييد شده و نتيجه true اعلام ميگردد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٩ بازديدکننده در حال حاضر
٦٨٨ صفحه امروز
تبليغات


بکارگيري Radio button ها

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 6772 بار خوانده شده است

براي انتخاب يک مورد ازموارد قرار داده شده تحت يک تيتر و موضوع مورد نظر از radio button ها استفاده ميشود.
در اين مطلب کاربر حتما يکي از radio buttonهاي موجود را انتخاب نمايد.
براي حصول اطمينان از انتخاب يک radio button

Function SubmitIt(carForm) {
door Option = -1

1.
با تعريف تابع SubmitIt و تخصيص يک عدد نامفهوم (1-) به متغيير door Option حلقه مورد نظر شروع ميشود.

for (i=0; i<carForm.DoorCt.length;i++) {

2.
اکنون حلقه آغاز ميشود, ابتدا متغيير i ارزشي معادل صفر داشته, درضمن چون مقداري کمتر از عدد radiobutton در فرم دارد, يک واحد به ارزش i مي افزايد. (1++)

if(carForm.DoorCt[1].checked) {
doorOption = i
}

3.
سپس در صورتيکه radio button انتخاب شده باشد, مقدار i به doorOption تخصيص مي يابد.

if(doorOption ==-1) {
alert("You must choose 2 or 4 door")
return false
}

4.
و در صورتيکه کاربر هيچ کدام از آنها را انتخاب نکند, پيغام اخطاري داده شده و نتيجتا ارزش false ارسال ميگردد.

return true

5.
در غير اين صورت (door Option=-1) و سپس يک کدام انتخاب شده و نتيجه صحيح ارائه ميگردد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٩ بازديدکننده در حال حاضر
٦٨٩ صفحه امروز
تبليغات


غير فعال کردن دکمه سمت راست موس

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 8949 بار خوانده شده است

اين مجموعه دستورات باعث خواهد شد تا دکمه سمت راست موس از فعاليت بيوفتد و پيغام درخواستي شما را براي User به نمايش درآورد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٢٥ صفحه امروز
تبليغات


تنظيم يک فيلد بر اساس فيلد ديگر

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 7097 بار خوانده شده است

شايد تابحال به فرمهايي برخورد کرده ايد که با تعيين يک فيلد, فيلد ديگر بصورت اتوماتيک انتخاب ميشود.
به منظور تنظيم اتوماتيک مقدار يک فيلد

function doorSet(sunroofField) {

1.
طبق معمول ابتدا يک تابع تعريف ميشود.

if (sunroofField.checked) {
for (i=0; i<document.myForm.DoorCt.length; i++) {

2.
در اين مرحله, در صورت انتخاب فيلد Sunroof يک حلقه براي تمامي فيلدهاي DoorCt ايجاد ميشود.

if (document.myForm.DoorCt[i].value == "twoDoor") {

3.
کاربر به دنبال يک ماشين دو درب خواهد بود.

document.myForm.DoorCt[i].checked = true

4.
هنگام انتخاب يک ماشين دو درب, به آن ارزش true داده ميشود.

<input type="CHECKBOX" name="sunroof" value="YES" onClick="doorSet(this)">

5.
درون قسمت Body, بايستي فيلد مربوط به Sunroof تعيين شود تا با کليک بر روي آن, توسط کنترل کننده onClick, تابعdoorSet(this)s اجرا گردد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
١٧ بازديدکننده در حال حاضر
٦٩٨ صفحه امروز
تبليغات


معتبر سازي ادرس Email با استفاده از معادلات قاعده اي

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: فرم ها و معادلات قاعده اي

اين مقاله تاکنون 8269 بار خوانده شده است

با استفاده از معادلات با قاعده, ميتوان آدرسهاي Email را معتبر ساخت.
به منظور معتبر سازي آدرس email با استفاده ازمعادلات قاعده اي

re=/^\w+([\.-]?\w+)*@\w+([\.-]?\w+)*(\.\w{2,3})+$/

1.
re يک متغيير ميباشد که مقدار سمت راست به آن اختصاص مي يابد. يک RegExp هميشه با يک علامت / شروع و پايان مي يابد و هر آنچه که درون اين دو علامت باشند, را معادله قاعده اي مي نامند. علامت ^ براي آزمايش از ابتداي رشته حرفي بوده زيرا ممکن است کاربر, کلمات و يا علامات نامفهومي را نوشته باشد.
علامت + بدين معني ميباشد که يک يا چند جزء قبلي در حال بررسي ميباشند. در اين حالت که يک آدرس email همانطور که قبلا نيز ذکر شد, بايستي با يک يا چند ترکيب از کارکترهاي a تا z, س A تا Z , س 0 تا 9 و خط تيره شروع شود.
علامت [] براي استفاده از يک يا چند کارکتر مورد نظر, استفاده ميشود. در اين مثال, کارکترهاي -.\ داخل براکت ( [] ) ميباشد. بدين صورت کاربر ميتواند " نقطه " ( . ) يا خط فاصله ( - ) را استفاده نمايد. اما بدليل انکه " نقطه " داراي مفهوم خاصي درمعادلات قاعده اي ميباشد, قبل از آن از علامت "\" استفاده شده است بدين صورت مفهوم " نقطه" به تنهايي مدنظر است. در ضمن علامت "-" نيز خودداري مفهوم اصليش ميباشد.
علامت ? بدين مضنون استفاده ميشود که ميتوان يک يا هيچکدام از کارکترهاي قبلي را مورد استفاده قرار داد.
بعد از علامت ( يا پرانتز بسته, انتهاي گروه باز شده را مشخص ميکند.
سپس علامت * بدين مفهوم است که ميتوان از موارد ذکر شده در گروه قبل ( داخل پرانتز) هم استفاده کرد و يا آنها را اصلا بکار نبرد, پس با توجه به مطالب گذشته, از آنجايي که کلمه "dort" يک پيشوند email معتبر هست, عبارت "testing-testing" نيز ميتواند يک پيشوند email معتبر به حساب آيد.
علامت @ مابين آدرس email و نام domain مربوطه قرار ميگيرد.
استفاده مجدد از +W\, بدليل آنست که نام domain بايستي با يکي از کارکترهاي a تا z ,س A تا Z,س 0 تا 9 ويا خط فاصله شروع گردد.
مجددا عبارت ( + w \ ? [ - . \ ] ) استفاده شده که وجود "." يا "-" را در قسمت پسوند email مجاز ميشمارد.
سپس گروه داخل پرانتز {2,3}w\.\ قرار گرفته شده که از وجود يک نقطه به همراه چند کارکتر خبر مي دهد. {2,3} نيز مقدار 2 يا 3 کارتر قبلي مي باشد.
سپس منظور از علامت +, وجود تعداد دفعات جزء تعداد دفعات جزء قبلي را ميان ميکند. مثلا پسوند نهايي ميتوان بصورت "Com" , ".edu" , "Ox.ac.uk" باشد.
نهايتا با قرار دادن علامت $ رشته حرفي پايان يافته و از قرار دادن موارد نامناسب ديگر توسط کاربر جلوگيري کند.

if(re.test(myForm.emailAddr.value)) {

2.
با استفاده از دستور test()s اعتبار myForm.emailAddr.value بررسي ميشود که در صورت قرار گرفتن نمونه اي نادرست, پيغام اشتباه همراه با اخطار نمايان شده و در غير آن که يک متغيير معتبر است (آدرس email درست نوشته شده باشد) پيغامي نميگردد.
**تذکر
  • جهت آشنايي با کارکترهاي خاص معادلات قاعده اي روي متن فوق کليک نماييد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٣٩ بازديدکننده در حال حاضر
٧٢١ صفحه امروز
تبليغات


اصول طراحي صفحات وب

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: اصول طراحي

اين مقاله تاکنون 23083 بار خوانده شده است

در اين مبحث, بعلت درخواست مکرر دوستان در مورد چگونه آغاز کردن ساخت يک وب سايت, جدا از مباحث نرم افزاري شما نياز به يکسري آگاهي در مورد خصوصيات خاص صفحه هات اينترنتي داريد که در زير به اختصار در مورد آن توضيح ميدهيم.

طراحي صنعتي

چگونه يك مشتري جنس مورد نظر خود را شناسايي و رديابي ميكند، و احتمالا پيشنهادات خوبي را براي فروش بر روي صفحه وب ارائه ميدهد؟ اين مبارزه طلبي طراحي صفحات تجاري وب ميباشد
بيشترين توليد كنندگان صنعتي با جديت به سمت مشتريانشان جهت گيري كرده و صفحات طراحي شده براي كمپانيهاي صنعتي، ميبايست تعصبات مشتري گرايانه قوي داشته باشند.
گرايش به مشتري در روشي كه صفحات صنعتي، مشتري را چه از لحاظ تصويري و چه از لحاظ تعاملي درگير ميكنند، ديده ميشود. صفحات صنعتي غالبا معموليتر از صفحات ديگر به نظر ميدهند.
صفحات صنعتي در كل داراي سه عنصر ميباشند
خصوصيات محصول: هر مشتري ميبايست بتواند يك محصول خاص را از ميان مجموعه اي از محصولات مشخص كند. اين كار ميتواند به صورت تصويري، با استفاده از يك ليست انتخابي يا با استفاده از يك برنامه جستجو انجام شود.

مشخصات محصول: بيشتر محصولات صنعتي همراه با اطلاعاتي عرضه ميشوند كه صفحه مشخصات ناميده ميشود يك صفحه مشخصات تركيبي از متن، تصوير و توصيفاتي در مورد كارايي محصول در يك ورق كاغذ ميباشد. خصوصيات كارايي يا تصوير توصيف كننده ساختار كالا، اغلب عامل فروش يك محصول ميباشند.
البته با توجه به قابليتهاي وب، ايجاد صفحه مشخصات كالا در وب به روش سنتي، محدود كننده به نظر ميرسد. مشخصات كارايي كالا ميتواند به صورت سه بعدي و همراه با حركت ايجاد شود، همچنين خود محصول در حال انجام عمل، قابل نمايش باشد.

ارتباط با مشتري: ‏‏‏كارتهاي جالبي را كه در آنها از شما سئوال ميشود «آيا مايليد كه نمايندگي سرويسهاي مشتري در مورد كالايي خاص با شما تماس بگيرد؟» را بخاطر بياوريد. با استفاده از وب سئوالات تقريبا پس از پرسيده شدن جواب داده خواهند شد.

طراحي صفحات خرده فروشي

صفحات خرده فروشي كاملا با صفحات صنعتي متفاوت است چرا كه در مورد محصولات خرده فروشي، انتقال اطلاعات تكنيكي چندان مورد توجه نميباشد. بهر حال چيزي كه در اين نوع صفحات داراي اهميت بسيار است، تطابق تصاوير با اصل ميباشد.

در اين نوع طراحي بايد مسائل زير را در نظر گرفت:
خصوصيات تصويري و سازماني فروشندگي خرده فروشيهاي موفق چيست؟
اجزا ساختاري خرده فروشي چيست؟
از چه خصوصيات وب ميتوان به گونه اي موثر در طراحي صفحات خرده فروشي سود جست؟

صفحات تجاري

صفحاتي كه براي مخاطبين تجاري طراحي ميشوند با صفحات خرده فروشي و صنعتي تفاوت دارند. به خاطر داشته باشيد كه هر شركت داراي زندگي و يك شخصيت وجودي در زمينه محصولات ويژه يا عمليات فروش خاصي ميباشد. يك شركت تلاش زيادي را صرف به تصوير كشيدن يك نماي حساب شده از خود ميكند. اين تلاش ممكن است شامل اسم،ارم شركت،رسم الخطي كه در مكاتبات شركت استفاده ميشود. رنگهاي مورد استفاده و اينكه دقيقا چه اسامي براي معرفي محصولاتشان ميكنند، باشد.
يك صفحه تجاري ميبايست منعكس كننده فرهنگ ان شركت باشد. اين بدان معني است كه صفحات وب يك بانك، اساسا با صفحات وب يك توليد كننده اسباب بازي متفاوت است.

قطعات اصلي پازل صفحه وب تجاري شامل اجزا زير ميباشد
نام شركت رسما چگونه استفاده ميشود؟ ايا به طور كامل نوشته ميشود يا مخفف؟ ايا نام، يك نام تجاري ثبت شده است؟
ايا نام شركت تحت قانون حق تكثير ميباشد؟
ايا نام شركت همان آرم شركت است. يا يك طرح گرافيكي جداگانه ميباشد؟ اندازه، مكان و جهت رسمي ان چگونه است؟
ايا يك ارم تجاري يا يك نشان سازماني است؟
ايا اسامي محصولات، اسامي تجاري طراحي شده به شكل خاص ميباشند؟
ايا اين نوع اسامي با قلم،وزن و تاكيد متفاوتي نمايش داده ميشوند؟
آيا رسم الخط رسمي، براي بدنه اصلي مكاتبات وجود دارد؟
ايا متن ترازبندي شده است يا داراي برامدگي و فرورفتگي است؟
آيا اصلا رنگهاي رسمي براي شركت وجود دارد؟
ايا يك سلسله مراتب براي مكاتبات در شركت وجود دارد؟
شما چگونه ميتوانيد سئوالات و تقاضاهايتان را به قسمتهاي مختلف ابلاغ كنيد؟

موسسات آموزشي

موسسات آموزشي داراي اولين و بيشترين نشريات وب ميباشند و همگي با مشگل ساختاري يكساني مواجهند. كالجها و دانشگاهها، بيش از حد معمول ساخت يافته اند يا به عبارتي قسمت بندي شده به بخشهاي مختلف ميباشند، بنابراين صفحات وب ميبايست حس مجازي تصويري از ارتباطات ساختاري داخل يك موسسه ارائه دهند بگونه اي كه حس قدم زدن در آن موسسه در بيننده القا شود.

جنبه يكسان صفحات آموزشي، ترتيب عمليات داخل موسسات ميباشد. اين مسئله در تضاد كامل با صفحات توليد كنندگان و فروشندگان جز ميباشد. ترمهاي مدارس هميشه مدت ثابتي دارند. تاريخ شروع و خاتمه از قبل دقيقا مشخص شده اند تقاضانامه و عمليات ورود به موسسه همگي استاندارد شده ميباشند. گذراندن كل دوره تحصيلي اجباري است و معمولا ميبايست تحت مجموعه اي از مراحل مشخص گذرانده شوند. كارنامها مقدار پيشرفت محصل را مشخص ميكنند. دانش اموزان براساس پيشرفتشان طبقه بندي ميشوند، در حقيقت بر اساس وضعيت قبولي هر مقطع طبقه بندي ميشوند، اين صفحات به دليل كمبود آزادي عمل طراح، جز مشگل ترين صفحات از لحاظ طراحي ميباشد

صفحات مربوط به سرگرمي

در مقابل صفحات تجاري، صفحات مربوط به سرگرميها قرار دارند. درست است كه در اينجا هم ممكن است برخي محدوديتهاي تجاري اعمال شوند(سوني، ديسني و غيره )ولي اين صفحات در معموليترين و مورد قبولترين شكلشان داراي كمترين محدوديتهاي طراحي بوده و آزادي عمل زيادي براي طراح وجود دارد. مشتريان سرگرميها اغلب جز بي ثباترين و مشگلترين مشتريان براي شناسايي و رديابي ميباشند. موضوعي كه در سال گذشته مورد توجه ترين موضوعات بوده ممكن است ديگر موردتوجه نباشد.

صفحات وب سرگرمي داراي خصوصيات زير ميباشد؛
كمترين ساختارو عمل-عكس العمل بيشتر
اعتماد بيشتر به تصوير نسبت به اطلاعات نوشتاري
استفاده بيشتر از منابعي كه مشتريان بالقوه اين نوع صفحات وب مجبور به يادگيري آن هستند.
انجام محاسبات سطح بالا به منظور بهبود سرعت پردازنده، عمق نمايش و پهناي باند شبكه.
حداقل در حال حاضر، كمبود مهمي كه در مورد صفحات سرگرمي وجود دارد تفاوت كلي بين شمايل صفحات وب با شكل واقعي سرگرمي واقعي مورد توجهشان مثل فيلم، كتاب، بازي، ضبط صوت، كنسرت و نمايش زنده و چيزهاي ديگر را با صفحات وب مقايسه كنند، به سادگي به عدم واقعگرايي صفحات وب نسبت به رسانه اصلي پي ميبرند. براي موفقيت صفحات سرگرمي وب
يا بايد واقعگرايانه صفحات وب با وسايل موجود در زندگي منطق شود و يا صفحات سرگرمي وبي طراحي شود كه هيچ مرجعي در
دنياي واقعي براي مقايسه نداشته باشند
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤٦ صفحه امروز
تبليغات


کارکترهاي خاص معادلات قاعده اي

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: فرم ها و معادلات قاعده اي

اين مقاله تاکنون 6072 بار خوانده شده است

در اين قسمت با کارکترهاي خاص مورد استفاده در اسکريپتهاي قاعده اي آشنا خواهيد شد.
به کارکتر بعد از خود, مفهومي حرفي و يا مفهومي خاص ميدهد, مثلا در W\ مقصد, ارزشي خاص W بوده ولي در $\ ارزش خاص علامت $ که در زير ذکر شده را صرفنظر نموده است. | \
شروع رشته (String) | ^
پايان رشته | $
صفر يا چند مرتبه | *
يک يا چند مرتبه | +
صفر يا يک مرتبه | ?
هر کارکتر بجز خط جديد | .
محدوديت لغتي | \b
عدم محدوديت لغتي | \B
ارقام بين 0 تا 9 | \d
محدوديت استفاده از ارقام | \D
فرم | \F
خط جديد | \A
بازگشت | \r
هر يک از کارکترهاي White space | \s
هيچ يک از کارکترهاي White space | \S
Tab | \t
Tab عمودي | \v
هر حرف, يا Underline | \w
هر کارکتر غير از حرف, عدد يا Underline | \W
کارکترهاي ASCII که با اعداد هگزادسيمال nn مشخص ميشوند | \xnn
کارکترهاي ASCII گخ با اعداد اکتال nn مشخص ميشوند | \onn
کارکتر کنترل X | \cX
مجموعه کارکترهاي که با هر يک از کارکترهاي داخل براکت مطابقت داشته باشد | [abcde]
مجموعه کارکترهاي که با هر يک از کارکترهاي داخل براکت مطابقت نداشته باشد | [^abcde]
مجموعه کارکترهاي که با هر يک از کارکترهاي داخل براکت مطابقت دارد | [a-e]
کارکترهاي حرفيb\ | [\b]
دقيقا n اتفاق از کارکتر قبلي | {n}
حداقل اتفاق از کارکتر قبلي | {n , }
بين n و m اتفاق از کارکتر قبلي | {n , m}
گروه سازي براي استفاده در آينده | ()
يا x يا y | X|Y
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٢٣ صفحه امروز
تبليغات


قرار دادن تاريخ فعلي بر روي صفحه وب

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9741 بار خوانده شده است

توسط JavaScript ميتوان با استفاده از زمان و تاريخ کامپيوتر کاربر کارهاي بسيار انجام داد. در اين مبحث تاريخ عددي بوسيله اسکريپت به تاريخ حرفي تبديل ميشود. اسکريپت فوق که شامل در اسکريپت در قسمت Head و Body صفحه ميباشد, نحوه دريافت تاريخ فعلي, تبديل آن از عدد به تاريخ استاندارد و سپس نوشتن نتيجه مذکور در مکان مشخص شده را توضيح ميدهد.
براي قرار دادن تاريخ فعلي بر روي صفحه وب
dayName = new Array ("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday") | 1.
ابتدا يک آرايه با اجزاي روزهاي هفته ايجاد ميشود. به ياد داشته باشيد که مابين روزهاي هفته حتما قرار بگيرد و سپس آرايه درون متغييري بنام dayName قرار ميگيرد. |
monName = new Array ("January","February","March","April","May","June","July","Auguest","September","October","November", "December") | 2.
در اين مرحله مانند مرحله قبل, آرايه اي براي نام روزهاي ماههاي سال ايجاد ميشود. |
now = new Date | 3.
آخرين کاري که در اولين اسکريپت بايستي انجام دهيد, ايجاد يک متغيير تاريخ با دستور newDate ميباشد. بدين صورت javascript يک Object تاريخ جديد ايجاد کرده و تاريخ فعلي را درون آن قرار ميدهد. |
document.write("<h3>Today is " + dayName[now.getDay()] + ", " + monName[now.getMonth()] + " " + now.getDate() + ".</h3>") | 4.
در اين اسکريپت قسمت Body که شامل يک خط ميباشد نتيجه مستقيما روي صفحه نوشته ميشود. دستور document.write عبارت مورد نظر را درون يک پرانتز قرار داده و آن را در پنجره صفحه مورد نظر مي نويسد. همانطور که از Html بخاطر داريد تگ <h3> براي استفاده در تيترنويسي با سايز 3 ميباشد. به دنبال آن رشته حرفي "Today is" و علامت + قرار گرفته که منظور از اين علامت, اضافه کردن محتويات بعدي به قسمت قبل ميباشد. عبارت dayName[now.getDay()]s از سمت راست به چپ خوانده ميشود. دستور getDay()s روز هفته را دريافت کرده و با اضافه کردن now, عدد روز امروز را به خود اختصاص داده که نتيجه عددي آن با توجه به اجزاي آرايه dayName در مرحله اول, روز مربوطه را مشخص ميکند. سپس بعد از قرار دادن علامت + عبارت monName[now.getMonth()]s نوشته شده که همانند قسمت قبل, نام ماه را بر اساس آرايه monName مشخص ميکند. بعد از قرار دادن يک فاصله درون گيومه, now.getDay()s نوشته شده که تاريخ ماه را نشان ميدهد. در نهايت يک نقطه قرار داده و تگ <h3> بسته ميشود. |

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٢٦ صفحه امروز
تبليغات


بازي با روزها

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 8100 بار خوانده شده است

ممکن است بخواهيد در مواقع و زوهاي خاص سال مثلا آخر هفته, پيغامي خاص به کاربر ارائه دهيد.
براي فهميدن آخر هفته

now = new Date

1.
تاريخ فعلي به متغيير now اختصاص مي يابد.

if (now.getDay() > 0 && now.getDay() <6) {

2.
توجه داشته باشيد که کد يکشنبه, عدد صفر ميباشد. منظور از عملگر &&, and منطقي بوده که بايستي در نتيجه هر دو قسمت درست باشند.

document.write("Sorry, it's a weekday.")

3.
اگر نتيجه مرحله قبل بزرگتر از صفر و کوچکتر از 6 بود, پيغام مورد نظر به نمايش در خواهد آمد.

else {
document.write("Hooray, it's weekend!")

4.
در صورتيکه حالت شرطي مرحله قبل, نادرست باشد, اين مرحله اجرا ميشود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٢٧ صفحه امروز
تبليغات


ارائه يک پيغام براي زماني از روز

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 7909 بار خوانده شده است

با توجه به تکنيک ارائه شده در مقاله قبل, ميتوان يک پيغام نيز در زمان خاصي از روز نمايش داد.
براي ارائه يک پيغام در زماني از روز
now = new Date if (now.getHours() < 5) { | 1.
تاريخ (Date) جديد به متغيير now اختصاص داده ميشود. سپس با استفاده از getHours()s ساعت را از متغيير now دريافت کرده و اگر عدد کمتر از 5(منظور 5 صيح ميباشد.) باشد به مرحله بعد ميرود. |
document.write("What are you doing up so later?") | 2.
در اين مرحله, عبارت يا پيغام خاصي تعريف شده که در صورت گذراندن مرحله 1 اين پيام در پنجره کاربر نشان داده ميشود. بغيه اسکريپت در مورد پيغامهاي ديگر در ساعات مختلف روز ميباشد. |

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٢٨ صفحه امروز
تبليغات


نوشتن متن درون سند on the fly

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 8470 بار خوانده شده است

قابليت نوشتن اطلاعات بر روي يک صفحه وب در پي پاسخ به عمل کاربر, يکي از راههاي مفيد در ديناميک کردن صفحه بوده و در ضمن از اين طريق کلا ميتوان کاربردهاي گوناگون پيدا نمود.
براي نوشتن متون بصورت on the fly

dayInfo = new Array
dayInfo[2] = "Dad's Birthday"
dayInfo[5] = "Rehearsal Dinner"
dayInfo[6] = "Wedding Day"

1.
خطوط موجود در اسکريپت فوق را درقسمت head بنويسد.

function showInfo(thisDay) {
document.calendar.dateInfo.value = dayInfo[thisDay]
}

2.
توسط تابع ShowInfo, متن مورد نظر گرفته شده و از آن اطلاعات مربوطه به رخداد از آرايه dayInfo نيز تهيه شده و آن را در text area بنام dateInfo قرار ميدهد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٢٩ صفحه امروز
تبليغات


onUnLoad Event

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

اين مقاله تاکنون 6784 بار خوانده شده است

در هنگام ترک يک صفحه وب, کنترل کننده onUnLoad فعال ميشود. به علت عدم محبوبيت اين نوع پنجره ها, بهتر است که کنترل کننده فوق الذکر در کمترين حالت استفاده شود. اسکريپت فوق نحوه ايجاد پيغام خداحافظي درهنگام ترک سايت با استفاده از کنترل کننده onUnLoad را نشان ميدهد.
براي ايجاد onUnLoad

onUnload="alert('thanks for visiting, and come back soon!')"

با قرار دادن کنترل کننده فوق درتگ body, هنگام ترک سايت پيغام مذکور به نمايش در خواهد آمد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤٠ صفحه امروز
تبليغات


onResize Event

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

اين مقاله تاکنون 6059 بار خوانده شده است

از آنجايي که درنسخه 4 برنامه Netscape, هنگام تغيير اندازه پنجره يک bug معروف وجود داشته بنابراين بايستي بعد از تغيير اندازه صفحه, محتويات درون پنجره را مجددا Load نمود.
براي اجراي onResize Event
if(document.layers) { | 1.
همانطور که ذکر شد اين اسکريپت فقط براي Netscape 4 نياز ميباشد. به ياد داشته باشيد که document.layers نيز يکي از Object هايي بوده که تنها در اين browser وجود دارد. |
origWidth = window.innerWidth origHeight = window.innerHeight | 2.
در صورتيکه کاربر در Netscape 4 باشد, ايتدا ابعاد پنجره اصلي (Orginal) را براي استفاده آينده نگهداري ميکند. |
function resizeFix() { | 3.
در اين قسمت عمل resize تحت کنترل قرار ميگيرد. |
if(document.layers) { | 4.
مجددا براي کسب اطمينان, وجود Netscape 4 بررسي ميشود. |
if(window.innerWidth != origWidth || window.innerHeight != origHeight) { | 5.
در صورتيکه يا اندازه طول و يا عرض پنجره تغيير کرده باشد آماده انجام عمل بارگذاري مجدد محتويات صفحه در مرحله بعد خواهد شد و در غير اين صورت عملي صورت نميگيرد. |
window.location.reload() | 6.
در صورتيکه ابعاد صفحه پنجره تغيير کرده باشد, محتويات درون صفحه مجددا بارگذاري ميشوند. |
onResize="resizeFix()" | 7.
در اين قسمت پس از تغيير در ابعاد پنجره, تابع resizeFix فراخوانده ميشود. |

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤١ صفحه امروز
تبليغات


OnMousedown Event

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

اين مقاله تاکنون 7959 بار خوانده شده است

يکي از سوالهايي که بطور فراوان, توسط اکثر کاربران پرسيده ميشود, نحوه و چگونگي پنهان کردن اصل محتوي اسکريپت بکار گرفته شده در صفحه است. اما پاسخ آنها بطور خيلي ساده, "غير ممکن" ميباشد. يعني کاربر با اندکي تجربه و تشخيص ميتواند مفهوم کدهاي اسکريپت را دريابد.
ولي در صورتيکه بخواهيد از جستجوگران که سطح معلومات متوسطي دارند, اسکريپت را اندکي غير قابل دسترسي نماييد, آنگاه اسکريپت فوق, چگونگي کد لازم را به شما توضيح ميدهد. بدين صورت کاربر نميتواند با انجام کليک راست بر روي صفحه از منوي Shortcut براي مشاهده Source برنامه استفاده کند.
براي غير فعال کردن دکمه سمت راست موس

if(document.layers) {
document.captureEvents(Event.MOUSEDOWN)
}

1.
در صورتيکه کاربر داراي Netscape 4 باشد, آنگاه به browser, استفاده از Capture Events را براي کنترل Mousedown اعلام ميکند.

document.onmousedown = captureMousedown

2.
براي تمامي browserها از تابع captureMousedown براي حالت onmousedown استفاده ميشود. توجه کنيد در اين مرحله, کنترل کننده event, (CaptureMousedown) داراي پرانتز نميباشد. در صورتيکه وجود پرانتز از اساس کنترل کننده event بوده ولي در جاوااسکريپت ميتوان از آن صرفنظر نمود.

function captureMousedown(evt) {

3.
تابع مورد نياز براي کنترل Mousedown در اين مرحله شروع ميشود. پارامتر evt نيز توسط Netscape, بطور اتوماتيک در هنگام اجراي event, که شامل اطلاعات در مورد event مربوطه است را ارسال ميکند.

if(evt) {
mouseClick = evt.which

4.
در صورت استفاده از Netscape, متغير evt وجود داشته, در اين صورت انتخاب کليد ماوس توسط کاربر مشخص ميشود.

else {
mouseClick = window.event.button
}

5.
ولي در صورتيکه که کاربر از IE استفاده کند, نتيجه عملها در متغيير mouseClick ذخيره ميشود.

if(mouseClick == 1 || mouseClick == 2 || mouseClick == 3) {
alert("Mouse Disabled")
return false
}

6.
در صورتيکه کليک ماوس مربوط به يکي از دکمه 1,2,3 آن باشد يک پيغام اخطار نمايان ميگردد که نشاندهنده عدم قابليت تابع نويسي ميباشد. در نتيجه false را برگردانده و بدين وسيله, پنجره منو از ناپديد شدن در امان مي ماند.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤٢ صفحه امروز
تبليغات


onDbclick Event

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

اين مقاله تاکنون 6973 بار خوانده شده است

بدين طريق کاربر ميتواند با انجام عمل Double Click عمل خاصي را مشاهده خواهد کرد.
براي عمل onDbclick Event

onDblclick="newWindow(1)"

بدين صورت با دوبار کليک بر روي تصوير کوچک, تصوير بزرگ آن در پنجره جديد نمايش داده ميشود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤٣ صفحه امروز
تبليغات


اسکريپتهاي CGI

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: اصول طراحي

اين مقاله تاکنون 8961 بار خوانده شده است

بخاطر قدرت زياد و انعطاف پذيري, اسکريپت CGI طرفداران زيادي دارند. کاربر با ارسال يک فرم يا کليک کردن روي يک ابر پيوند درخواستي را براي اجراي يک CGI به سويServer ارسال ميکند. اين CGI بر رويServer اجرا شده و اطلاعات ارسالي را بررسي ميکند و براساس آن صفحه ديگري ايجاد مينمايد. اين صفحه ميتواند تجديدنظري از صفحه اول, يا يک صفحه کاملا جديد باشد.

CGI مخفف Common Gateway Interface ميباشد. استانداري است که روش ارتباط برقرار کردنServer وب به ساير برنامه ها را مشخص ميکند. اين برنامه ها ميتوانند صفحات وب جديدي ايجاد کرده و براي مرورگر ارسال نمايند. برنامهاي CGI معمولا براي پردازش و تجزيه و تحليل اطلاعات يک پرسشنامه که از سوي کاربر ارسال شده بکار ميروند.

CGI تواناييهاي زيادي به طراح صفحه وب ميبخشد. مثلا به کمک آن ميتوان بين صفحات و بانکهاي اطلاعاتي ارتباط برقرار کرد. همچنين ميتوان صفحات وب را به گونه اي طراحي کرد که براي هر نوع کاربر خاص ظاهر و محتواي متفاوتي داشته باشد.

اسکريپتهاي CGI عليرغم قدرتشان کند ميباشند. براي اجراي يک اسکريپت CGI مراحل زيادي بايد انجام شود. اطلاعات بايد دو بار بين مرورگر وServer منتقل شوند. بعلاوه, سرويگر بايد مدتي را صرف پردازش اطلاعات دريافتي از مرورگر نمايد. در واقع, اجراي يکCGI مانند درخواست يک صفحه جديد است. با اين تفاوت که زماني نيز بايد صرف اجراي آن CGI بر روي سريسگر شود.

اگر تنها يک کاربر بهServer متصل باشد, ميتوانيم زمان پردازش اسکريپت را نديده بگيريم, اما اگرServer مجبور به پاسخ به درخواستهاي متعدد و پردازشهاي مکرر باشد, اين زمان خود را بيشتر نشان ميدهد.

مسئله ديگر در هنگام کار با اسکريپتهاي CGI, مدت زماني است که براي ايجاد هر اسکريپت لازم است. ابتدا بايد برنامه کوچکي به يکي از زبانهاي رايج اسکريپت نويسي مثل PERL يا ASP نوشته شود, سپس با داده هاي مختلفي آزموده شده و براي اجرا بهServer ارسال گردد.

منبع: اينترنت

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦٠ صفحه امروز
تبليغات


onFocus Event

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

اين مقاله تاکنون 6871 بار خوانده شده است

در صورتيکه بخواهيد در يک فيلد که اطلاعات مخصوص به نمايش در مي آيد, کاربر تغييراتي در آن اعمال نکند, ميتوان از ويژگي Readonly استفاده نمود ولي به ياد داشته باشيد که اکثر browserها ويژگي مذکور را پشتيباني نميکنند.اسکريپت فوق اين مشگل را برطرف خواهد کرد.
براي ثابت نگه داشتن اطلاعات يک فيلد
onFocus="this.blur()" | 1.
دستور فوق را در کنار input> کپي نماييد. |

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤٤ صفحه امروز
تبليغات


معتبر سازي نام فايل

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: فرم ها و معادلات قاعده اي

اين مقاله تاکنون 7683 بار خوانده شده است

RegExpها داراي توانايي و قابليتهاي بيشماري ميباشند, بطوريکه يکي از قابليتهاي پر کاربرد آنها,معتبر سازي وروديهاي فيلدها در فرم صفحه وب ميباشد. اسکريپت فوق از کاربر انتظار دارد که آدرس تصوير را به شکل درستي تائپ کند (حتي پسوند فايل تصوير را حتما يا jpg ويا gif انتخاب نمايد).
براي معتبر نمودن يک آدرس:
re = /^(File\http):\/\/\s + \/\s+\.(gif\jpg) $/i | 1.
همانطور که در مباحث قبل اشاره گرديد, براي بررسي نمودن کل عبارت داخل فيلد از RegExp استفاده شده بطوريکه که با علامت ^/ شروع و با علامت / خاتمه يافته است. ورودي فيلد ميتواند با File يا با http شروع گردد, علامت بعدي بايستي "//:" باشد از آنجا که علامت / به منظور خاصي در معادله قاعده اي استفاده ميشود براي خنثي نمودن مفهوم آن علامت \ در قبل از علامت / به کار برده شده است. (\/\/) سپس +S/ را براي نوشتن هر کاراکتر غير white space به همراه علامت /\ که به منظور جدا کردن domain از نام فايل ميباشد, نوشته شده است. در مرحله بعد, +S\, مجددا براي نوشتن نام فايل ديگر, مورد استفاده قرار گرفته و بعلت نياز به نقطه و پسوند فايل gif يا jpg از عبارت (gif\jpg).\ استفاده شده است. در پايان از تصحيح کننده, i به منظور تايپ حروف بزرگ و کوچک و يا غير حساس بودن نسبت به آنها استفاده شده است. |

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٢٤ صفحه امروز
تبليغات


ايجاد Cookie

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: Cookies

اين مقاله تاکنون 9091 بار خوانده شده است

Cookie يکسري رشته حرفي با فرمت مشخص ميباشد. يعني:

CookieName = CookieValue; expires = expirationDateGMT ; path = URLpath ; Domain = siteDomain

توضيح خطوط فوق از اين قرار است که اولين قسمت رشته حرفي به Cookie اسم و مقدار مربوطه را تخصيص داده که بايستي هميشه در ايجاد Cookie در نظر داشت. سپس تاريخ انقضاي Cookie توسط expiration Date تعيين ميشود که در فرمان تعيين شده فوق, browser بطور اتوماتيک, Cookie را پاک ميکند. سپس اجازه وجود يک URL داده شده و در نهايت آدرس domain در Cookie تنظيم ميگردد.
توجه داشته باشيد که ميتوان از چند Cookie درون يک صفحه استفاده نمود بدين منظور بعد از مشخصات هر قسمت, از علامت " ; " استفاده ميگردد.
براي ايجاد Cookie

expireDate = new Date

1.
ابتدا تاريخ فعلي گرفته شده و در متغيير expireDate نهاده ميشود.

expireDate.setMonth(expireDate.getMonth()+6)

2.
بدين صورت مقدار تاريخ اعتبار Cookie مورد نظر, 6 ماه تعيين ميگردد.

userName = ""

3.
سپس متغيير userName با مقدار خالي تعريف ميگردد.

userName = document.cookie.split("=")[1]

4.
ابتدا خالي نبودن محتوي Cookie بررسي ميشود. سپس توسط متد ("=")split, هر record مربوط به Cookie به فيلدهاي مختلف تقسيم ميشود بطوريکه مثلاCookieField[0]s نام وCookieField[1]s مقدار Cookie ميباشد.

function setCookie() {
userName = document.myForm.nameField.value

5.
در اين مرحله يک تابع جديد با نامsetCookie()s ايجاد شده, سپس در خط بعد مقدار UserName توسط اطلاعات وارد شده کاربر درون فيلد فرم, مجددا نوشته ميشود.

document.cookie = "username=" + username + ";expires=" + expireDate.toGMTString()

6.
همانطور که در مطالب قبل ذکر شد, Cookie ها شامل رشته هاي حرفي ساده ميباشد, در نتيجه توسط document.cookie, نام کاربر و تاريخ انقضاء نوشته شده زيرا توسط متد toGMTString, تاريخ expireDate به رشته حرفي تبديل شده, که نتيجتا ميتوان آن را درون Cookie قرار داد.

onLoad="document.myForm.nameField.value=userName"

7.
دستور onLoad در تگ body, نام کاربر را در صورت وجود در فايل Cookie درون فيلد name مينويسد.

<input readonly type="text" name="nameField" onBlur="setCookie()" size="40">

8.
نهايتا هنگام رهايي کاربر از فيلد متن, توسط کنترل کننده onBlur, تابع setCookie فرا خوانده ميشود.
**نکته
  • در اين اسکريپت فرض ميشود User name در Cookie وجود داشته است. در مباحث بعدي, نحوه کنترل چندين Cookie نيز توضيح داده ميشود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦٢ صفحه امروز
تبليغات


خواندن Cookie

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: Cookies

اين مقاله تاکنون 8242 بار خوانده شده است

بعد از تنظيم Cookie بايستي از آن در موارد مفيد و گوناگون استفاده نمود.
براي خواندن Cookie

if(document.cookie !="") {

1.
درصورت خالي نبودن محتويات Cookie به مرحله بعد ميرود.

document.write("Hello, "+ document.cookie.split("=")[1])

2.
در صورتي که Cookie خالي نباشد, رشته حرفي "Hello" به همراه مقدار موجود در Cookie در صورت نمايش, ظاهر ميگردد.
**نکته
  • در صورتي که دقت کرده باشيد, به اين نکته پي خواهيد برد که Cookie خاصي انتخاب نشده است! زيرا هر Cookie تنها توسط Server, مخصوص که براي اولين بار درون آن نوشته شده, خوانده ميشود. يعني فقط ميتوانيد به Cookie هاي مربوط به خود دسترسي پيدا نماييد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦١ صفحه امروز
تبليغات


نمايش Cookieها

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: Cookies

اين مقاله تاکنون 10181 بار خوانده شده است

در مبحث قبل, مقدار يک Cookie از Server خوانده شد. در اين قسمت, نحوه خواندن تمام Cookieها از Server و نمايش نام و مقاديرشان را فرا ميگيرد. بطوريکه اگر هيچ Cookie نباشد, پيغام "هيچ Cookie وجود ندارد" اعلام ميشود و در صورتيکه وجود داشته باشد. براي هر Cookie يک خط شامل اطلاعات آن نمايش داده ميشود.
به منظور نمايش Cookieها

if(document.cookie == "") {
document.write("There are no cookies here")

1.
در صورتيکه محتوي Cookieها خالي باشد, پيغام "There are no cookies here" نشان داده ميشود.

else {
thisCookie = document.cookie.split("; ")

2.
ولي در صورتيکه محتواي آن خالي نباشد, مقدار تمامي Cookieهاي موجود توسط document.cookie.split("; ")s گرفته شده و در متغييري بنام thisCookie قرار داده ميشود. به ياد داشته باشيد که توسط دستورsplit("; ")s آرايه اي از تمام Cookieها بوجود آمده تا درنهايت بتوان به مقدار هر Cookie ارجاعي داده شود.

for (i=0; i<thisCookie.length; i++) {

3.
در حلقه فوق, که شمارنده آن از صفر شروع ميشود, در صورتيکه i کمتر از تعداد Cookieها در آرايه thisCookie باشد به مقدار i, يک واحد مي افزايد.

document.write("Cookie name is"+thisCookie[i].split("=")[0])
document.write(",and the value is"+thisCookie[i].split("=")[1]+"<br>")

4.
و درصورت وجود Cookie در پنجره browser ابتدا عبارت "Cookie name is" و بعد نام Cookie و به دنبال آن, عبارت and the value is به همراه مقدار Cookie نوشته ميگردد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٦٣ صفحه امروز
تبليغات


حرکت عکس بدنبال موس

نسخه مناسب چاپ

تاريخ نشر: دوشنبه 24 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

دريافت نمونه برنامه بصورت zip (13k)

اين مقاله تاکنون 24296 بار خوانده شده است

برطبق درخواست مکرر دوستان مبني بر مجموعه دستوراتي که موجب حرکت يک عکس بدنبال موس گردد, اسکريپت فوق جهت استفاده ارائه ميگردد.
براي دريافت کامل برنامه با امکانات آن بر روي متن فوق کليک نماييد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤٧ صفحه امروز
تبليغات


قرار دادن ساعت بر روی سايت

نسخه مناسب چاپ

تاريخ نشر: دوشنبه 31 تير 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 13025 بار خوانده شده است

با استفاده از اين اسکريپت ميتوان ساعت را بر روی سايت بطور دايناميک به نمايش درآورد
اين مجموعه دستورات را ميتوان بعنوان يکی از بهترين اسکريپتهای موجود معرفی کرد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣١ صفحه امروز
تبليغات


نوشتن متن در قسمت

نسخه مناسب چاپ

تاريخ نشر: جمعه 18 مرداد 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 10174 بار خوانده شده است

اين اسکريپت موجب خواهد شد که حروف يک کلمه ابتدا تک تک به نمايش درآيد سپس تکميل گردد. اين اسکريپت جزوء اولين اسکريپتهاي در اين زمينه ميباشد به مرور اسکريپتهايي با همين کاربرد ولي به گونه اي ديگر ارائه خواهد شد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣٠ صفحه امروز
تبليغات


ارجاع به صفحه مورد نظر بعد از زماني مشخص

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 13 مرداد 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9499 بار خوانده شده است

در اين اسکريپت ميتوانيد صفحه را بعد از مدت زمان خاصي Refresh نماييد و صفحه جديدي را بجاي صفحه کنوني بارگزاري نماييد. اسکريپت فوق بعد از 5 ثانيه شما را به صفحه ok.asp ارجاع خواهد داد, شما ميتوانيد اين زمان را تغيير داده و صفحه مورد نظر را نيز بجاي ok.asp صفحه مورد نظر خود را قرار دهيد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣٢ صفحه امروز
تبليغات


تغيير bgcolor

نسخه مناسب چاپ

تاريخ نشر: جمعه 18 مرداد 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9048 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد رنگ پس زمينه را بدلخواه خود تغيير دهيد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣٣ صفحه امروز
تبليغات


تاکيد يک مطلب

نسخه مناسب چاپ

تاريخ نشر: دوشنبه 28 مرداد 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9792 بار خوانده شده است

ميتوانيد مطلب مورد نظر خود را در قسمت پايين Browser کاربر به دفعات به نمايش درآوريد.
اين کار پيشنهاد نميشود و فقط جهت آگاهی اعلام گرديده است.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣٤ صفحه امروز
تبليغات


چرخش سايه متن

نسخه مناسب چاپ

تاريخ نشر: شنبه 13 مهر 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 11572 بار خوانده شده است

در IE يکسري داده غير استاندارد بنام Filler وجود دارد که به javascript قابليت تغيير و اصلاح objectها را ميدهد. اسکريپت مورد بحث نحوه استفاده از فيلتر drop shadow براي تغيير ظاهر متن (بنام dropShadow) را نشان ميدهد.

بمنظور چرخش سايه متن

1.

function doShadow(newDiretction){

ابتدا تابعي با نام doShadow و متغيير newDirection ايجاد ميشود. متغيير, مربوط به جهت فعلي سايه ميباشد.
2.

if (document.all && newDiretction < 360) {

درصورتيکه کاربر از IE استفاده کند و همچينين مقدار متغيير newDirection کمتر از 360 درجه باشد به مرحله يعد ميرود.
3.

newDiretction += 10
document.all.dropText.style.filter="shadow(direction=" + newDiretction + ")"

به متغيير newDirection,س10 درجه به منظور تعيين مکان بعدي سايه, اضافه ميشود. سپس فيلتر با خصوصيات جديد سايه تنظيم ميگردد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣٥ صفحه امروز
تبليغات


نمایش منو با یک کلیک

توسط: ناصر نايب

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 3 آذر 1381

دريافت نمونه برنامه بصورت js (5k) Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 12511 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد منوي مورد نظر خود را با يک کليک به نمايش درآوريد.
به راحتي ميتوانيد مطلب خود را جايگزين منوهاي ارائه در مثال قرار دهيد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣٦ صفحه امروز
تبليغات


نمايش گرافيکی ساعت

توسط: مرتضی پاينده

نسخه مناسب چاپ

تاريخ نشر: جمعه 8 آذر 1381

دريافت نمونه برنامه بصورت js (2k) Help

مبحث: ايجاد صفحات ديناميک

دريافت نمونه برنامه بصورت zip (25k)

اين مقاله تاکنون 26410 بار خوانده شده است

ميتوانيد ساعت سيستم کاربر را بر روی سايت بصورت گرافيکی بنمايش در بياورید.
با درِيافت فايل مورد نظر و دادن تغييرات در Gifهای ارسالی ميتوانيد اعداد مورد نظر خود را بنمايش درآوريد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤٨ صفحه امروز
تبليغات


اجرای صدا در زمانی مشخص

توسط: مرتضی پاينده

نسخه مناسب چاپ

تاريخ نشر: چهارشنبه 13 آذر 1381

دريافت نمونه برنامه بصورت js (3k) Help

مبحث: کنترل Eventها

اين مقاله تاکنون 11376 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد آهنگ دلخواه خود را در ساعتی مشخص به اجرا درآوريد, کافيست فايل مورد نظر را در برنامه تعريف نماييد و ساعت مربوطه را تنظِم کنيد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤٦ صفحه امروز
تبليغات


قرار دادن متن در قسمت Title

توسط: ناصر نايب

نسخه مناسب چاپ

تاريخ نشر: شنبه 12 بهمن 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 11555 بار خوانده شده است

ميتوانيد متن را در قسمت Title صفحات خود بصورت فعال به نمایش در آوريد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣٧ صفحه امروز
تبليغات


حرکت عکس بدنبال موس (2)
توصيه به ديگران

توسط: مديريت سايت

نسخه مناسب چاپ

تاريخ نشر: چهارشنبه 30 بهمن 1381

دريافت نمونه برنامه بصورت js (5k) Help

مبحث: کنترل Eventها

اين مقاله تاکنون 26096 بار خوانده شده است

بدليل استقبال کاربران از شماره قبلي اين اسکريپت (حرکت عکس بدنبال موس) تصميم گرفتم Version جديدتر اين اسکريت را با قابليت توقف حرکت موس, ارائه دهيم.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥٠ صفحه امروز
تبليغات


نمايش عمودی متن

نسخه مناسب چاپ

تاريخ نشر: جمعه 16 اسفند 1381

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 11420 بار خوانده شده است

با استفاده از اين اسکريپت ميتوان متنی را بصورت عمودی به نمايش درآورد.
متن مورد نظر فارق از اينکه در صفحه چه جيزی وجود دارد بر روی صفحه قرار ميگيرد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣٨ صفحه امروز
تبليغات


نمايش فايل گرافيکی

نسخه مناسب چاپ

تاريخ نشر: چهارشنبه 6 فروردين 1382

دريافت نمونه برنامه بصورت js (4k) Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 12299 بار خوانده شده است

با استفاده از اين مجموعه دستوارت ميتوانيد فايل گرافيکي موجود در سيستم خود را در پنجره Browser همراه با اطلاعات کامل به نمايش درآوريد.
ميتوانيد حتي width و height فايل مورد نظر را نيز مشاهده نماييد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٣٩ صفحه امروز
تبليغات


انتخاب radio button

نسخه مناسب چاپ

تاريخ نشر: جمعه 12 ارديبهشت 1382

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

اين مقاله تاکنون 12721 بار خوانده شده است

ميتوانيد رنگ radio button هاي انتخابي را بعد از select تغيير دهيد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤٠ بازديدکننده در حال حاضر
٧٤٥ صفحه امروز
تبليغات


افکت روي متن

توسط: مهدي ميرزايي

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 21 ارديبهشت 1382

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

اين مقاله تاکنون 22347 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد متن را به حرکت درآوريد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٤٩ صفحه امروز
تبليغات


ترانس رنگ

توسط: مهدي ميرزايي

نسخه مناسب چاپ

تاريخ نشر: دوشنبه 5 خرداد 1382

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

اين مقاله تاکنون 15135 بار خوانده شده است

ميتوانيد بر روي سايت خود ترنسفر رنگ ايجاد نماييد.
اين script قابليت تغيير رنگ را براحتي فراهم آورده است و جابجايي رنگ آن بدون range شدن رنگ صورت ميگيرد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥١ صفحه امروز
تبليغات


تغيير رنگ Boxها

نسخه مناسب چاپ

تاريخ نشر: جمعه 6 تير 1382

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 13972 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد رنگ Boxها را بعد از کليک کردن تغيير دهيد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥٢ صفحه امروز
تبليغات


تعريف home page

توسط: سپهر لاجوردی

نسخه مناسب چاپ

تاريخ نشر: دوشنبه 13 مرداد 1382

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 15105 بار خوانده شده است

با استفاده از اين اسکريپت می توان نشانی سايت موردنظر را به عنوان home page به browser کاربر معرفی نمود.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥٣ صفحه امروز
تبليغات


حرکت متن درون Box

توسط: يوشا ماندنی پور

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 30 شهريور 1382

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 18091 بار خوانده شده است

می توانيد متن دلخواه خود را در Box مورد نظر به حرکت درآوريد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥٤ صفحه امروز
تبليغات


تبديل متن به گرافيک

توسط: مرتضی پاينده

نسخه مناسب چاپ

تاريخ نشر: شنبه 17 آبان 1382

دريافت نمونه برنامه بصورت js (2k) Help

مبحث: کنترل Eventها

دريافت نمونه برنامه بصورت zip (15k)

اين مقاله تاکنون 18694 بار خوانده شده است

با استفاده از اين اسکريپت میتوانيد جمله خود را بصورت گرافيکی به نمايش در آوريد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥٥ صفحه امروز
تبليغات


بازي O_X

نسخه مناسب چاپ

تاريخ نشر: سه شنبه 2 دي 1382

دريافت نمونه برنامه بصورت js (8k) Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 16348 بار خوانده شده است

بزرگترين مزيت استفاده از JavaScript قابليت اجراي آن در سيستم کاربر مي باشد. اين خصوصيت باعث شده تا بتوانيم حتي براي کاربران Game طراحی کنیم و آنها را به بازی با سیستم خود در محیط IE تشويق نماييم !

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥٦ صفحه امروز
تبليغات


دستور Thead

نسخه مناسب چاپ

تاريخ نشر: جمعه 24 ارديبهشت 1383

دريافت نمونه برنامه بصورت js Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9447 بار خوانده شده است

Theadدستوري است که باعث ايجاد عنوان در هنگام Table بندي صفحات مي شود.
براي ساختن ستون در table به غير از <tr> دستور ديگر نيز وجود دارد کد <thead> در تمامي قسمتهاي يک table ميتواند ستون مانند <tr> ايجاد نمايد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥٧ صفحه امروز
تبليغات


تاريخ شمسي

توسط: احمد

نسخه مناسب چاپ

تاريخ نشر: يکشنبه 28 شهريور 1383

دريافت نمونه برنامه بصورت js (2k) Help

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 13939 بار خوانده شده است

با استفاده از اين کد ميتوانيد تاريخ شمسي را در وب سايت خود درج نماييد نکته قابل توجه اين است که تاريخ شمسي بر طبق تاريخ سيستم کاربر تعيين مي گردد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥٨ صفحه امروز
تبليغات


Submit کردن فرم

نسخه مناسب چاپ

تاريخ نشر: شنبه 15 مرداد 1384

دريافت نمونه برنامه بصورت js Help

مبحث: کنترل Eventها

اين مقاله تاکنون 1737 بار خوانده شده است

با استفاده از دستورات فوق میتوانید فرمی را بدون دخالت کاربر به صفحه دیگر ارسال نمایید، نکته قابل توجه این است که کاربر از ارسال فوق موردنظر اطلاع نخواهد داشت.
در قسمت var speed مدت زمانی را که ارسال فرم می بایست به طول بی انجامد را مشخص میکند.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٢ بازديدکننده در حال حاضر
٦٥٩ صفحه امروز
تبليغات


ارتباط باما

Info@javascript.ir | مدیریت سایت:
Newsletter@javascript.ir | خبرنامه:
Faq@javascript.ir | پرسش و پاسخ:
Ads@javascript.ir | تبلیغات:

Name:

Email:
To:
Subject:
Message:

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٢٨٩ صفحه امروز
تبليغات


پرسش و پاسخ

سئوالاتي که به دفعات پرسيده شده اند در اين صفحه پاسخ داده خواهد شد.
جهت ارسال سئوالات خود به قسمت ارتباط باما مراجعه نماييد، و يا با FAQ@javascript.ir مکاتبه نماييد.

براي اجراي جاوا اسکريپت به چه چيزي نياز است؟

براي اجراي جاوا اسکريت شما به هيچ برنامه اي نياز نداريد.چون browserهاي کنوني تماما قابليت اجراي جاوااسکريپت را دارا ميباشند و يکي از دلايل همه گير شدن جاوا اسکريپت نيز همين امر ميباشد.

آيا جاوا اسکريپت در تمام browserها اجرا ميشوند؟

دستورات جاوا اسکريپت در تمامي browserها درست اجرا نميشوند براي اجراي آنها بايد در متن آن تغييراتي را اعمال نمود, اما دستوراتي که ما در اين سايت از آنها استفاده ميکنيم قابليت اجرا در تمامي browserها را دارا ميباشند. دستوراتي هم وجود دارن که فقط بر روي browserهاي خاص اجرا ميشوند که ما از استفاده آن خودداري ميکنيم.

آيا شما به سايت IranASP.net وابسته هستيد؟

خير ما هيچ گونه وابستگي به سايت IranASP.net نداريم.

در خواندن خبرنامه دچار مشگل هستيم و حروف را به صورت فارسي مشاهده نميکنيم.

در Outlook Express و يا Browser خود گزينهاي زير را به ترتيب انتخاب نماييد.

view --> Encoding --> unicode(UTF-8)
OR
view --> Encoding --> more ---> unicode(UTF-8)

بهترين Editor جهت تائپ حروف فارسي چه Editor ميباشد؟

در حال حاظر مسئله اصلي بهترين Editor نيست. بلکه الان مسئله Unicode بودن Editor است بصورتي که همه کاربران اينترنت بتوانند از سايت ما استفاده نمايند.
براي اين مهم Windows 2000 به بالا Unicode را پشتیبانی کرده و بشما اين امکان را ميدهد که صفحات و متنهاي نوشتاري خود را با اين سيستم ذخيره نماييد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٢٩٤ صفحه امروز
تبليغات


سئوال مطرح شده [ ارسال پاسخ ] [ پرسيدن سئوال جديد ]

نام: | علي جعفري
Email : | jafariali@noavar.com
تاريخ : | يکشنبه 9 خرداد 1384
متن پيغام : |
 | خيلي متاسفم با اين همه کاربران مدعي و اسکريپت نويس و آشنا به VBScript هنوز به اين سئوال من نتوانستند پاسخ دهند که چگونه مي توان يک صفحه را Secure نموده و از ذخيره آن چه به صورت پرينت و چه به صورت Save as جلوگيري نمود!منتظر پاسخ هستم زيرا خود تا بحال نتوانستم Script آنرا بيابم.

پاسخهاي ارائه شده

نام: | مهدي پاکدل فرد
Email : | m1pfard@yahoo.com
تاريخ : | سه شنبه 25 خرداد 1384
متن پيغام : |
 | دوست عزيز حرف مديريت محترم سايت رو قبول کن. هيچ راهي براي جلوگيري از آن در HTML معمولي وجود ندارد و تنها مي توان اسکريپتها را با استفاده از بزخي برنامه ها مثل Windows Script Encoder به صورت کد درآورد که آن را هم به سادگي ميتوان DeCode نمود. ولي با اين حال اگر توانستي راه حل مناسبي بيابي حتما لطفي کن و ما رو هم در جريان بذار. موفق باشي
نام: | علي جعفري
Email : | jafariali@noavar.com
تاريخ : | چهارشنبه 12 خرداد 1384
متن پيغام : |
 | با تشکر از پاسخ Admin ولي مطمئنم که Scrpit آن وجود دارد و اگر آنرا يافتم حتماً ارئه خواهم داد زيرا يکبار آنرا پيدا کرده ام ولي متاسفانه Link آنرا گم کرده ام.بهرحال اين نياز را مي توان در صفحات PDF بوسيله Adobe Acrobat pro 7 اجرا کرد که گزينه هاي Print and save as غيرفعال مي شوند و لي ما در صفحات html نياز داريم که اين دو غير فعال شده و حتي از Download آن در Temprory نيز جلوگيري نمود.
نام: | مديريت سايت
Email : | info@javascript.ir
تاريخ : | دوشنبه 10 خرداد 1384
متن پيغام : |
 | دوست عزيز هيچ تضميني براي اين مورد وجود ندارد بهترين راه اين است که شما دکمه سمت راست موس را غير فعال نماييد. کد موردنظر در سايت موجود مي باشد.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٢٩٥ صفحه امروز
تبليغات


سئوال مطرح شده [ ارسال پاسخ ] [ پرسيدن سئوال جديد ]

نام: | احسان ر.م
Email : | elsan_rahimi@yahoo.com
تاريخ : | پنجشنبه 13 خرداد 1384
متن پيغام : |
 | آيا سايتي فارسي يا حتي غير فارسي را براي دادن خبرنامه رايگان به سايت من سراغ دارديد؟و آيا با کدهاي جاوا مي توان يک خبرنامه سخت؟

پاسخهاي ارائه شده

نام: | میثاق
Email : | misagh_moayyed@hotmail.com
تاريخ : | يکشنبه 17 مرداد 1384
متن پيغام : |
 | بسیاری از سایتهای خبری کد خبرنامه خودشون رو ارائه میکنن که شما در سایت خودتون قرار بدید. مثل ایران پیک و ایران نت و غیره...
نام: | مهدي پاکدل فرد
Email : | m1pfard@yahoo.com
تاريخ : | دوشنبه 24 خرداد 1384
متن پيغام : |
 | سلام اين سايت چندين سرويس مجاني asp داره. مي توني به راحتي از اونا استفاده کني: http://www.webwizguide.info/

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٢٩٦ صفحه امروز
تبليغات


سئوال مطرح شده [ ارسال پاسخ ] [ پرسيدن سئوال جديد ]

نام: | رميليا
Email : | remiliagomerdina@yahoo.co.uk
تاريخ : | چهارشنبه 16 تير 1384
متن پيغام : |
 | لطفا اگر كسي مي تواند كد نمايش تصاوير مختلف در ساعات مختلف را ارايه دهد من را كمك كند

پاسخهاي ارائه شده

براي اين سئوال هنوز پاسخي ارسال نگرديده است.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٢٩٧ صفحه امروز
تبليغات


سئوال مطرح شده [ ارسال پاسخ ] [ پرسيدن سئوال جديد ]

نام: | اکبر
Email : | samanfb@yahoo.com
تاريخ : | پنجشنبه 28 مرداد 1384
متن پيغام : |
 | من يه فايل جاوا اسکريپت فارسي يا انگليسي مي خوام منظورم همان راهنماي اينها

پاسخهاي ارائه شده

براي اين سئوال هنوز پاسخي ارسال نگرديده است.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٢٩٨ صفحه امروز
تبليغات


سئوال مطرح شده [ ارسال پاسخ ] [ پرسيدن سئوال جديد ]

نام: | فريد
Email : | f_scorpion_f@yahoo.com
تاريخ : | دوشنبه 1 شهريور 1384
متن پيغام : |
 | با سلام--اول از همه تشکر مي کنم بابت سايت پر محتواتون که خيلي به من کمک کرده--سوالي که داشتم اين بود که به چه صورت مي تونم برا وبلاگم صفحات پست(صفحات متعدد ) درست کنم-با تشکر-منتظرم

پاسخهاي ارائه شده

براي اين سئوال هنوز پاسخي ارسال نگرديده است.

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٢٩٩ صفحه امروز
تبليغات


دریافت لیست مقالات توسط فایل js

برای استفاده از لیست مقالات سایت ایران جاوااسکریپت در سايت يا وبلاگ شخصيتان کافی است کد دريافتی را در صفحات سايت خود درج نماييد. فایل مورد نظر بصورت text بوده و همیشه شامل لیست جدیدترین مقالات سایت می باشید.

لیست تمامی مقالات [ پیش نمایش ]

Copy

لیست 5 مقاله آخر [ پیش نمایش ]

Copy

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣٠١ صفحه امروز
تبليغات


پیوند

پیوند سایت شما با ایران جاوا اسکریپت برای ما بسیار بااهمیت است، لطفا یکی از نمادهای فوق را در سایت خود قرار دهید و ما را از آن مطلع سازید.
Copy

Copy

Copy

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣٠٢ صفحه امروز
تبليغات


خبرنامه سايت javascript.ir شامل قسمتهاي فوق ميباشد.

  • مطالب اين ماه

  • پربيننترين مقالات

  • آمار سايت شامل تعداد بازديدکنندگان برطبق منطقه جغرافيايي, ليست سايتهايي که بيشترين بازديد کننده را براي سايت javascript.ir بهمراه داشته اند و ...

  • و مطالب خواندني ديگر در زمينه اينترنت

عضويت در اين خبرنامه براي عموم آزاد ميباشد.

Email:

Un-Subscribe

Subscribe

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٤٣٦ صفحه امروز
تبليغات


پرسيدن سئوال جديد

شما ميتوانيد سئوالات خود را در اين قسمت مطرح نماييد.

بعد از نوشتن پيغام, شما به صفحه اول سايت اجراء ميشويد, سئوال مطرح شده توسط شما پس از تاييد توسط مديريت, در سايت قرار خواهد گرفت.
درصورتي که اطلاعات درخواستي را بدرستي پرننماييد مطلب ارسالي شما از سايت حذف خواهد شد.

سئوال مورد نظر شما

پاسخ شما پس از تاييد توسط مديريت سيستم در سايت قرار خواهد گرفت.

جهت تغيير زبان از کليد F8 استفاده نماييد.

نام :

Email :

موضوع کلي سئوال خود را با چند کلمه اعلام داريد :
(حداکثر 50 کارکتر)

متن پيغام :
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣٠٥ صفحه امروز
تبليغات


ارسال پاسخ [ پرسيدن سئوال جديد ]

نام: | علي جعفري
Email : | jafariali@noavar.com
تاريخ : | يکشنبه 9 خرداد 1384
متن پيغام : |
 | خيلي متاسفم با اين همه کاربران مدعي و اسکريپت نويس و آشنا به VBScript هنوز به اين سئوال من نتوانستند پاسخ دهند که چگونه مي توان يک صفحه را Secure نموده و از ذخيره آن چه به صورت پرينت و چه به صورت Save as جلوگيري نمود!منتظر پاسخ هستم زيرا خود تا بحال نتوانستم Script آنرا بيابم.

ارسال پاسخ

پاسخ شما پس از تاييد توسط مديريت سيستم در سايت قرار خواهد گرفت.

جهت تغيير زبان از کليد F8 استفاده نماييد.

نام :

Email :

متن پيغام :
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٤٣٠ صفحه امروز
تبليغات


ارسال پاسخ [ پرسيدن سئوال جديد ]

نام: | احسان ر.م
Email : | elsan_rahimi@yahoo.com
تاريخ : | پنجشنبه 13 خرداد 1384
متن پيغام : |
 | آيا سايتي فارسي يا حتي غير فارسي را براي دادن خبرنامه رايگان به سايت من سراغ دارديد؟و آيا با کدهاي جاوا مي توان يک خبرنامه سخت؟

ارسال پاسخ

پاسخ شما پس از تاييد توسط مديريت سيستم در سايت قرار خواهد گرفت.

جهت تغيير زبان از کليد F8 استفاده نماييد.

نام :

Email :

متن پيغام :
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٤٣٢ صفحه امروز
تبليغات


ارسال پاسخ [ پرسيدن سئوال جديد ]

نام: | رميليا
Email : | remiliagomerdina@yahoo.co.uk
تاريخ : | چهارشنبه 16 تير 1384
متن پيغام : |
 | لطفا اگر كسي مي تواند كد نمايش تصاوير مختلف در ساعات مختلف را ارايه دهد من را كمك كند

ارسال پاسخ

پاسخ شما پس از تاييد توسط مديريت سيستم در سايت قرار خواهد گرفت.

جهت تغيير زبان از کليد F8 استفاده نماييد.

نام :

Email :

متن پيغام :
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٤٣٣ صفحه امروز
تبليغات


ارسال پاسخ [ پرسيدن سئوال جديد ]

نام: | اکبر
Email : | samanfb@yahoo.com
تاريخ : | پنجشنبه 28 مرداد 1384
متن پيغام : |
 | من يه فايل جاوا اسکريپت فارسي يا انگليسي مي خوام منظورم همان راهنماي اينها

ارسال پاسخ

پاسخ شما پس از تاييد توسط مديريت سيستم در سايت قرار خواهد گرفت.

جهت تغيير زبان از کليد F8 استفاده نماييد.

نام :

Email :

متن پيغام :
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٤٣٤ صفحه امروز
تبليغات


ارسال پاسخ [ پرسيدن سئوال جديد ]

نام: | فريد
Email : | f_scorpion_f@yahoo.com
تاريخ : | دوشنبه 1 شهريور 1384
متن پيغام : |
 | با سلام--اول از همه تشکر مي کنم بابت سايت پر محتواتون که خيلي به من کمک کرده--سوالي که داشتم اين بود که به چه صورت مي تونم برا وبلاگم صفحات پست(صفحات متعدد ) درست کنم-با تشکر-منتظرم

ارسال پاسخ

پاسخ شما پس از تاييد توسط مديريت سيستم در سايت قرار خواهد گرفت.

جهت تغيير زبان از کليد F8 استفاده نماييد.

نام :

Email :

متن پيغام :
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٤٣٥ صفحه امروز
تبليغات


ارسال مقالات

دوستاني که اگاهي در مورد زبانهاي برنامه نويسي دارند ميتوانند مقالات خود را در اين زمينها براي ما ارسال دارند تا با نام خودشان در سايت قرار گيرد.

  • مسئولین سایت میتوانند مقالات موردنظر را ویرایش نمایند.

  • ارسال مقالات به منزله قرار گرفتن آن در سايت نمي باشد.

  • بعد از ارسال مقالات و قرار گرفتن آن برروي سايت مسئوليت مطالب موجود در مقاله به عهده مسئولين سايت ميباشد.

مقالات خود را به نشانی info@javascript.ir ارسال نمایید.
شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣١٨ صفحه امروز
تبليغات


اصول طراحي

در اين مجموعه مطالب, سعي شده است در مورد مسايلي صحبت شود که در کل ميتوان به پياده سازي يک Website مورد توجه قرار گيرد.

ليست مباحث:
اسکريپتهاي CGI
توضيحی مختصر در مورد اسکريپتهاي CGI
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8958

اصول طراحي صفحات وب
اصول طراحي صفحات وب
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 23080

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣١٩ صفحه امروز
تبليغات


شروع JavaScript

در اين مبحث مکان قرار گرفتن JavaScript در Html, طريقه استفاده از پيغامها براي ارتباط با کاربر, طريقه چک کردن Browser و طريقه نوشتن JavaScript را فرا ميگيريد. در اين فصل همچنين مفاهيم بيشتري در مورد زبان JavaScript از قبيل Loop و توابع مشاهده ميکنيد. به ياد داشته باشيد که در اين مباحث به چگونگي حالت اينگونه موارد, بيش از حد کنکاش نکنيد تا بتوانيد مفاهيم اصلي اين فصل را متوجه گرديد.

ليست مباحث:
پيامها در status bar
يکي ديگر از کارهايي که ميتوان انجام داد, ارائه توضيحات لازم براي هر پيوند, در هنگام قرار گرفتن نشانگر موس بر روي آنها در قسمت status bar ميباشد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 10346

پيغام متحرک در status bar
توسط اين اسکريپت جمله اي درون قسمت status bar پنجره هاي browser به حرکت در مي آيد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 10944

فراخواني تابع
فراخواني تابع
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7553

توابع
تابع مجموعه اي از جملات JavaScript بوده که يک وظيفه مشخصي را انجام ميدهند. بطوريکه هر تابع داراي اسم بوده و توسط قسمتهاي ديگر اسکريپت فراخواني ميشود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6264

وجود Java
قبل از قراردادن appletهاي جاوا براي افزايش کارايي و زيبايي صفحه وب, بايستي ابتدا وجود قابليت غير فعال کردن جاوا در browser آزمايش گردد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7228

شناسايي Browser
با اين مجموعه دستورات ميتوانيد Browser کاربر را شناسايي نماييد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6853

دستور عمل redirecting با استفاده از پيوند
دستور عمل redirecting با استفاده از پيوند
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6556

دستور العمل redirecting
نه تنها ميتوان وجود برنامه JavaScript را درسيتم کاربر چک کرد, بلکه ميتوان علاوه بر آن نسخه JavaScript را نيز معين نمود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6387

اعلان پيغام به کاربر
در بعضي موارد بجاي دريافت اعلام بله/خير (yes/no) از طرف کاربر نياز به جواب بيشتري ميباشيم.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7786

تاييد انتخاب کاربر
تاييد انتخاب کاربر
توسط: مديريت سايت | تاريخ: دوشنبه 24 تير 1381 | تعداد بازديد کننده: 7249

اخطار به کاربر
اخطار به کاربر
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8542

قرار دادن توضيحات در اسکريپتها
قرار دادن توضيحات در اسکريپتها را ميتوان از نکات مهم در هنگام نوشتن اسکريپتها دانست
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6765

پنهان کردن اسکريپتها از browserهاي قديمي
مخفی کردن تکها از Browserهای قديمی
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6613

محل قرار گرفتن اسکريپتها
اسکريپتها را ميتوان در دوجا درون صفحه قرار داد: يا داخل تگهاي و و يا داخل تگهاي و
توسط: مديريت سايت | تاريخ: دوشنبه 24 تير 1381 | تعداد بازديد کننده: 8705

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣٠٩ صفحه امروز
تبليغات


بازي با تصاوير

يکي از بهترين کاربردهاي JavaScript اعمال تغييرات هيجان انگيز و جالب به صفحات وب با استفاده از تصاوير متحرک ميباشد. مثلا تغيير تصوير در هنگام قرار دادن ماوس بر روي آن, متداولترين عمل بشمار مي ايد. به اين دستورات rollover گفته ميشود.
همچنين ميتوان از اين اسکريپت, تصاويري که خودبخود تغيير مي يابد را ايجاد نمود و حتي تبليغات متحرکي را جايگزين فايلهاي تصويري متحرک کرد.

ليست مباحث:
نمايش يک تصوير به صورت اتفاقي
در صورت وجود منبع بزرگي از تصاوير در صفحه, ميتوان از يک تصوير بفرم اتفاقي استفاده کرد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 12514

قرار دادن چندين rollover در صفحه
تابحال دستورات مورد نياز براي قرار دادن تنها يک rollover در صفحه آموختيد, براي قرار دادن چند rollover بايستي تنها اندکي دستور به آنچه قبلا ذکر شده بيافزاييد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8567

ايجاد rolloverها
مفهوم rollover بسيار ساده ميباشد, بدين معنا که ابتدا دو تصويروجود داشته, تصوير اول در هنگام دريافت صفحه وب توسط کاربر در browser نمايش داده ميشود...
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7865

ايجاد rolloverهاي کاراتر
به منظور ايجاد يک تصوير متحرک در هنگام قراردادن ماوس برروي تصوير, بايستي در نمايش تصوير دوم تاخيري ايجاد نشود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8019

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣١٠ صفحه امروز
تبليغات


کار با Framesها

قالبها يکي از پر قدرتترين طرحهاي موجود در Html ميباشد. در اين مباحث, نحوه ترکيب آنها با JavaScript به طور کامل شرح داده ميشود.

ليست مباحث:
قرار دادن page درون قالب
با دستور ميتوانيد يک Page ديگري را در صفحه فعلي نمايش دهيد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 9894

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣١١ صفحه امروز
تبليغات


کار با پنجره هاي Browser

همانطور که مستحضر هستيد, پنجره browser يک فصل اشتراک مهم در شبکه وب مي باشد, بطوريکه توسط برنامه JavaScript ميتوان اعمال متفاوتي در چگونگي عملکرد اين پنجره ها انجام داد.
در اين مجموعه مباحث, نحوه اعمال نفوذ JavaScript در باز و بسته کردن پنجره ها, حرکت کردن در محتواي صفحه, بهنگام سازي پنجره ها و همچنين ايجاد پنجره براي استفاده در پنل هاي کنترل کننده را خواهيد آموخت. در ضمن چگونگي عملکرد کنترل کنندها در هنگام بارگذاري يک پنجره و نحوه نوشتن اطلاعات درون پنجره ها نيز مورد بررسي قرار مي گيرد.

ليست مباحث:
تغيير سايز browser
شما با اين دستور ميتوانيد بزرگي و کوچکي browser کاربر را مشخص نماييد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8675

نحوه ايجاد Control panel
يکي از راههاي ايجاد امکانات بيشمار در زمينه طراحي صفحه هاي با قابليت ايجاد ارتباط استفاده از زير پنجره ها ميباشد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 9209

کنترل Browser
شما ميتوانيد پنجرهاي موجود را به سادگي کنترل نماييد و يا مشخصات خاصي را براي آن تعريف نماييد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7963

کار با پنجرهاي Browser
کار با پنجرهاي Browser
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6649

تشخيص زبانbrowser كاربر
تشخيص زبانbrowser كاربر
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7138

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣١٢ صفحه امروز
تبليغات


معتبر سازي فرمها

يکي از روشهاي مهم در معتبر سازي و فرمت رشته هاي حرفي در فرمها استفاده از معادلات با قاعده ميباشد. بدين صورت که با استفاده از يک يا دو خط از معادله هاي مذکور, ميتوان از نوشتن چندين خط دستور و فرمان صرفنظر نمود. يک معادله قاعده اي که به صورت RegExp خلاصه ميشود, با استفاده از سمبلها و علامات خاص, يک يا چند رشته حرفي را توضيح ميدهد. مانند يک معادله رياضي, در معادله قاعده اي با استفاده از عملکردهاي خاص بجاي اعداد, مابين يکسري حروف رابطه برقرار ميشود. در اين فصل تعدادي از متداولترين معادله ها را مورد بررسي قرار ميدهيم که با فراگيري آنها ميتوان, مقدار زيادي مسئله خاص ديگر را براحتي حل نمود.

ليست مباحث:
تنظيم يک فيلد بر اساس فيلد ديگر
شايد تابحال به فرمهايي برخورد کرده ايد که با تعيين يک فيلد, فيلد ديگر بصورت اتوماتيک انتخاب ميشود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7094

بکارگيري Radio button ها
بکارگيري Radio button ها
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6767

تاييد انتخاب شدن اجزاي يک منو
تاييد انتخاب شدن اجزاي يک منو
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7864

تشابه فيلدهاي Password
تشابه فيلدهاي Password
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7591

منوهاي Select-Go
در صورتيکه در سايتهاي شبکه اينترنت به جستجو پرداخته باشيد, به احتمال قوي با منوهايي که داراي چندين انتخاب باشند ...
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8160

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٦ بازديدکننده در حال حاضر
٤٣٧ صفحه امروز
تبليغات


فرم ها و معادلات قاعده اي

يکي از روشهاي مهم در معتبر سازي و فرمت رشته هاي حرفي در فرمها استفاده از معادلات با قاعده ميباشد. بدين صورت که با استفاده از يک يا دو خط از معادله هاي مذکور, ميتوان از نوشتن چندين خط دستور و فرمان صرفنظر نمود. يک معادله قاعده اي که به صورت RegExp خلاصه ميشود, با استفاده از سمبلها و علامات خاص, يک يا چند رشته حرفي را توضيح ميدهد. مانند يک معادله رياضي, در معادله قاعده اي با استفاده از عملکردهاي خاص بجاي اعداد, مابين يکسري حروف رابطه برقرار ميشود. در اين فصل تعدادي از متداولترين معادله ها را مورد بررسي قرار ميدهيم که با فراگيري آنها ميتوان, مقدار زيادي مسئله خاص ديگر را براحتي حل نمود.

ليست مباحث:
معتبر سازي نام فايل
RegExpها داراي توانايي و قابليتهاي بيشماري ميباشند, بطوريکه يکي از قابليتهاي پر کاربرد آنها,معتبر سازي وروديهاي فيلدها در فرم صفحه وب ميباشد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7679

کارکترهاي خاص معادلات قاعده اي
کارکترهاي خاص معادلات قاعده اي
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6069

معتبر سازي ادرس Email با استفاده از معادلات قاعده اي
با استفاده از معادلات با قاعده, ميتوان آدرسهاي Email را معتبر ساخت.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8265

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣١٣ صفحه امروز
تبليغات


ايجاد صفحات ديناميک

براي طراحي صفحات جذاب, عوامل و کارکترهاي بيشماري را بايد, در نظر گرفت, مثلا فرمت قرار دادن متون, طراحي خوب, توجه به جزئيات از قبيل سرعت بارگزاري صفحه.
يکي از روشهاي افزايش سرعت بارگزاري صفحه, استفاده از JavaScript بوده که در نتيجه, تک تک اجزاي صفحه دورن browser کاربر اجرا شوند. بدين معنا که ديگر قسمتهاي مختلف صفحه درون Server اجرا نخواهند شد و در نتيجه اسکريپت با کمک قدرت کامپيوتر کاربر صفحه را اجرا ميکند. به اين نوع صفحات, صفحات ديناميک اطلاق ميشود. با انتقال انجام فرآيند بارگذاري از روش Server-side به Clinet-side , در نتيجه عملکرد بهتري عايد ميشود.
در اين مباحث, نحوه قرار دادن تاريخ و زمان بر روي صفحات وب, تعريف يک "خوش امدگويي" بر حسب موقعيت زماني در روز, و همچنين نحوه فرستادن کاربران به صفحات ديگر با توجه به domain کاربر را خواهيد آموخت.

ليست مباحث:
تاريخ شمسي
درج تاريخ شمسي
توسط: احمد | تاريخ: يکشنبه 28 شهريور 1383 | تعداد بازديد کننده: 13936

دستور Thead
Thead دستوري است که به موجب آن مي توان براي Table عنوان هايي را مشخص نمود.
توسط: مديريت سايت | تاريخ: جمعه 24 ارديبهشت 1383 | تعداد بازديد کننده: 9444

بازي O_X
بزرگترين مزيت استفاده از JavaScript قابليت اجراي آن در سيستم کاربر مي باشد. اين خصوصيت باعث شده تا بتوانيم حتي براي کاربران Game طراحی کنیم و آنها را به بازی با سیستم خود در محیط IE تشويق نماييم !
توسط: مديريت سايت | تاريخ: سه شنبه 2 دي 1382 | تعداد بازديد کننده: 16345

حرکت متن درون Box
می توانيد متن دلخواه خود را در Box مورد نظر به حرکت درآوريد.
توسط: يوشا ماندنی پور | تاريخ: يکشنبه 30 شهريور 1382 | تعداد بازديد کننده: 18088

تعريف home page
با استفاده از اين اسکريپت می توان نشانی سايت موردنظر را به عنوان home page به browser کاربر معرفی نمود.
توسط: سپهر لاجوردی | تاريخ: دوشنبه 13 مرداد 1382 | تعداد بازديد کننده: 15102

تغيير رنگ Boxها
با استفاده از اين اسکريپت ميتوانيد رنگ Boxها را بعد از کليک کردن تغيير دهيد.
توسط: مديريت سايت | تاريخ: جمعه 6 تير 1382 | تعداد بازديد کننده: 13968

نمايش فايل گرافيکی
با استفاده از اين مجموعه دستوارت ميتوانيد فايل گرافيکي موجود در سيستم خود را در پنجره Browser همراه با اطلاعات کامل به نمايش درآوريد.
توسط: مديريت سايت | تاريخ: چهارشنبه 6 فروردين 1382 | تعداد بازديد کننده: 12295

نمايش عمودی متن
با استفاده از اين اسکريپت ميتوان متنی را بصورت عمودی به نمايش درآورد.
توسط: مديريت سايت | تاريخ: جمعه 16 اسفند 1381 | تعداد بازديد کننده: 11414

قرار دادن متن در قسمت Title
ميتوانيد متن را در قسمت Title صفحات خود بصورت فعال به نمایش در آوريد.
توسط: ناصر نايب | تاريخ: شنبه 12 بهمن 1381 | تعداد بازديد کننده: 11551

نمايش گرافيکی ساعت
ميتوانيد ساعت سيستم کاربر را بر روی سايت بصورت گرافيکی بنمايش در بياورید.
توسط: مرتضی پاينده | تاريخ: جمعه 8 آذر 1381 | تعداد بازديد کننده: 26406

نمایش منو با یک کلیک
با استفاده از اين اسکريپت ميتوانيد منوي مورد نظر خود را با يک کليک به نمايش درآوريد.
توسط: ناصر نايب | تاريخ: يکشنبه 3 آذر 1381 | تعداد بازديد کننده: 12507

چرخش سايه متن
در IE يکسري داده غير استاندارد بنام Filler وجود دارد که به javascript قابليت تغيير و اصلاح objectها را ميدهد.
توسط: مديريت سايت | تاريخ: شنبه 13 مهر 1381 | تعداد بازديد کننده: 11568

تاکيد يک مطلب
ميتوانيد مطلب مورد نظر خود را در قسمت پايين Browser کاربر به دفعات به نمايش درآوريد.
توسط: مديريت سايت | تاريخ: دوشنبه 28 مرداد 1381 | تعداد بازديد کننده: 9788

تغيير bgcolor
با استفاده از اين اسکريپت ميتوانيد رنگ پس زمينه را تغيير دهيد.
توسط: مديريت سايت | تاريخ: جمعه 18 مرداد 1381 | تعداد بازديد کننده: 9044

ارجاع به صفحه مورد نظر بعد از زماني مشخص
در اين اسکريپت ميتوانيد صفحه را بعد از مدت زمان خاصي Refresh نماييد و صفحه جديدي را بجاي صفحه کنوني بارگزاري نماييد.
توسط: مديريت سايت | تاريخ: يکشنبه 13 مرداد 1381 | تعداد بازديد کننده: 9495

نوشتن متن در قسمت
اين اسکريپت موجب خواهد شد که حروف يک کلمه ابتدا تک تک به نمايش درآيد سپس تکميل گردد.
توسط: مديريت سايت | تاريخ: جمعه 18 مرداد 1381 | تعداد بازديد کننده: 10170

قرار دادن ساعت بر روی سايت
با استفاده از اين اسکريپت ميتوان ساعت را بر روی سايت بطور دايناميک به نمايش درآورد
توسط: مديريت سايت | تاريخ: دوشنبه 31 تير 1381 | تعداد بازديد کننده: 13021

نوشتن متن درون سند on the fly
قابليت نوشتن اطلاعات بر روي يک صفحه وب در پي پاسخ به عمل کاربر, يکي از راههاي مفيد در ديناميک کردن صفحه بوده و در ضمن از اين طريق کلا ميتوان کاربردهاي گوناگون پيدا نمود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8465

ارائه يک پيغام براي زماني از روز
ارائه يک پيغام براي زماني از روز
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7905

بازي با روزها
ممکن است بخواهيد در مواقع و زوهاي خاص سال مثلا آخر هفته, پيغامي خاص به کاربر ارائه دهيد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8096

قرار دادن تاريخ فعلي بر روي صفحه وب
قرار دادن تاريخ فعلي بر روي صفحه وب
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 9737

غير فعال کردن دکمه سمت راست موس
غير فعال کردن دکمه سمت راست موس
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8945

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣١٤ صفحه امروز
تبليغات


کنترل Eventها

eventها يا وقايع در اصل, اعمالي هستند که در هنگام مراجعه به صفحه وب توسط کاربر انجام ميشوند. بطوريکه در زمان شناسايي وجود يک event, مثل mouse click يا key press, توسط javascript, کنترل کننده آن اجرا ميشود. در اکثر مطالب قبل, نحوه عملکرد اين کنترل کننده ها را مشاهده نموده ايد. اما تاکيد ميشود که فهميدن تکنيک کنترل کردن وقايع, بسيار مهم ميباشد که نتيجتا توضيحات مربوطه در اين مجموعه مطالب آورده شده اند.

ليست مباحث:
Submit کردن فرم
Submit کردن فرم بدون دخالت کاربر.
توسط: مديريت سايت | تاريخ: شنبه 15 مرداد 1384 | تعداد بازديد کننده: 1734

تبديل متن به گرافيک
با استفاده از اين اسکريپت میتوانيد جمله خود را بصورت گرافيکی به نمايش در آوريد.
توسط: مرتضی پاينده | تاريخ: شنبه 17 آبان 1382 | تعداد بازديد کننده: 18691

ترانس رنگ
ميتوانيد بر روي سايت خود ترنسفر رنگ ايجاد نماييد.
توسط: مهدي ميرزايي | تاريخ: دوشنبه 5 خرداد 1382 | تعداد بازديد کننده: 15132

افکت روي متن
با استفاده از اين اسکريپت ميتوانيد متن را به حرکت درآوريد.
توسط: مهدي ميرزايي | تاريخ: يکشنبه 21 ارديبهشت 1382 | تعداد بازديد کننده: 22344

انتخاب radio button
ميتوانيد رنگ radio button هاي انتخابي را بعد از select تغيير دهيد.
توسط: مديريت سايت | تاريخ: جمعه 12 ارديبهشت 1382 | تعداد بازديد کننده: 12716

حرکت عکس بدنبال موس (2)
بدليل استقبال کاربران از شماره قبلي اين اسکريپت (حرکت عکس بدنبال موس) تصميم گرفتم Version جديدتر اين اسکريت را با قابليت توقف حرکت موس, ارائه دهيم.
توسط: مديريت سايت | تاريخ: چهارشنبه 30 بهمن 1381 | تعداد بازديد کننده: 26092

اجرای صدا در زمانی مشخص
با استفاده از اين اسکريپت ميتوانيد آهنگ دلخواه خود را در ساعتی مشخص به اجرا درآوريد.
توسط: مرتضی پاينده | تاريخ: چهارشنبه 13 آذر 1381 | تعداد بازديد کننده: 11372

حرکت عکس بدنبال موس
حرکت عکس بدنبال موس
توسط: مديريت سايت | تاريخ: دوشنبه 24 تير 1381 | تعداد بازديد کننده: 24292

onFocus Event
در صورتيکه بخواهيد در يک فيلد که اطلاعات مخصوص به نمايش در مي آيد, کاربر تغييراتي در آن اعمال نکند
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6867

onDbclick Event
بدين طريق کاربر ميتواند با انجام عمل Double Click عمل خاصي را مشاهده خواهد کرد.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6969

OnMousedown Event
يکي از سوالهايي که بطور فراوان, توسط اکثر کاربران پرسيده ميشود, نحوه و چگونگي پنهان کردن اصل محتوي اسکريپت بکار گرفته شده در صفحه است.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 7955

onResize Event
از آنجايي که درنسخه 4 برنامه Netscape, هنگام تغيير اندازه پنجره يک bug معروف وجود داشته بنابراين بايستي بعد از تغيير اندازه صفحه, محتويات درون پنجره را مجددا Load نمود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6055

onUnLoad Event
در هنگام ترک يک صفحه وب, کنترل کننده onUnLoad فعال ميشود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 6780

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣١٥ صفحه امروز
تبليغات


Cookies

در مباحث وب, Cookie شامل يکسري اطلاعات بوده که Server, مربوطه براي اولين بار با browser کاربر ارتباط برقرار کرده و سپس براي هربار اتصال مجدد, اطلاعات آن استفاده ميکند. اين اطلاعات به اصطلاح Cookie هم در Server و هم در browser به صورت فايل Plain text ذخيره ميشوند.
بعنوان مسئول سايت IranJavaScript بر اين عقيده هستم که ميتوان کارهاي مفيدي را با Cookie ها انجام داد. مثلا در صورتيکه سايت نيازمند, ثبت نام اشخاص باشد, ميتوان از Cookie ها در نگهداري name user و Password بر روي درايوهايشان استفاده نمود تا از وارد کردن مجدد آنها در هربار اتصال خودداري شود. همچنين بدين صورت ميتوان, تعداد دفعات استفاده از سايتها را در Cookie ها ذخيره نمود.
اما مشخصات خاص Cookieها:
1. از آنها نميتوان براي بررسي محتويات هارد کاربر استفاده نمود.
2. توسط Cookieها ويروسها, انتقال نمي يابند. بطور خلاصه, يک Cookie تنها يک فايل ساده متني بر روي هارد ديسک کاربر بوده که برنامه نويس JavaScript بعضي از اطلاعات را در آن نگهداري ميسازد.
در Cookie همچنين آدرس مربوط به Server نيز نگهداري ميشود. بطور کلي ميتوان اساس پيدايش آن را "Identification" ناميد. بخاطر داشته باشيد که بدين صورت تنها کامپيوتر متصل شده, تعيين هويت ميگردد, يعني مشخصات کاربرها و يا سايتهاي مورد استفاده, مشخص نخواهد شد.

ليست مباحث:
نمايش Cookieها
نمايش Cookieها
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 10177

خواندن Cookie
بعد از تنظيم Cookie بايستي از آن در موارد مفيد و گوناگون استفاده نمود.
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 8238

ايجاد Cookie
ايجاد Cookie
توسط: مديريت سايت | تاريخ: يکشنبه 23 تير 1381 | تعداد بازديد کننده: 9087

شنبه 17 مهر 1384
منوي اصلي
صفحه اول
ارسال مقالات
درباره جاوااسکريپت
معرفي اين سايت
دریافت لیست مقالات
پرسش و پاسخ
خبرنامه
پيوند به سايت
تبليغات
ارتباط با ما
ليست 10 مقاله آخر

Submit کردن فرم

تاريخ شمسي

دستور Thead

بازي O_X

تبديل متن به گرافيک

حرکت متن درون Box

تعريف home page

تغيير رنگ Boxها

ترانس رنگ

افکت روي متن

[ ليست تمامي مقالات ]

مباحث مربوطه
Cookies
کنترل Eventها
ايجاد صفحات ديناميک
فرم ها و معادلات قاعده اي
معتبر سازي فرمها
کار با پنجره هاي Browser
کار با Framesها
بازي با تصاوير
شروع JavaScript
اصول طراحي
عضويت در خبرنامه

Email:

Un-Subscribe

Subscribe

آمار سايت
٤ بازديدکننده در حال حاضر
٣٠٨ صفحه امروز
تبليغات


فایلهای js.
فایلهای js فایلهایی هستند که شامل کدهای JavaScript می باشد، فایلهای js بیشتر به دو منظورمورد استفاده قرار میگیرند:
اول: هنگامی که بخواهید کدهای جاوا اسکریپت را در تعدادی زیادی از صفحات خود مورد استفاده قرار دهید، می توانید کد JavaScript را در فایل js ذخیره نموده و آن را به صورت یک فایل با کد
<script language="JavaScript" src="http://domains.com/js/header.js"></script>
به صفحه خود اضافه نمایید.
دوم: برای انتقال کدهای جاوااسکریپت از سروری به سرور دیگر نیز مورد استفاده قرار میگیرد.
درضمن فایلهای js فایلهای اجرایی نیستند و از جنس فایلهای txt می باشند.


OK !


javascript - -

محل قرار گرفتن اسکريپتها

دستور چاپ

تاريخ نشر: دوشنبه 24 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 8707 بار خوانده شده است

اسکريپتها را ميتوان در دوجا درون صفحه قرار داد: يا داخل تگهاي <head> و <head/> و يا داخل تگهاي <body> و <body/> .

براي نوشتن اولين اسکريپت

  1. عبارت
    <"script language="JavaScript" type="text/JavaScript>
    را تايپ کنيد. بدين طريق تگ ابتدايي دستور <script> وجود اين برنامه را به browser معين ميکند.
    ويژگي "script language="JavaScript نوع زبان اسکريپت نويسي را تعيين کرده و بوسيله ويژگي type="text/javascript"s اسکريپت را بعنوان plain text تحت JavaScript معرفي ميکند.

  2. سپس عبارت ("document.write("test1 را تايپ کنيد, بدين طريق يک پنجره جديد باز شده و در آن عبارت test1 تايپ ميشود.

  3. تگ پاياني <script/> را تايپ کنيد.

بعد از اين browser بقيه سند HTML را اجرا ميکند زيرا متوجه پايان اسکريپت شده است.
**نکات مورد توجه

  • ميتوان در يک صفحه به هر تعداد از تگ اسکريپت <script> استفاده نمود.

<html>
<head>
</head>

<body>
<h1>
<script language="javascript" type="text/javascript">

document.write("IranJavaScript")

</script>
</h1>

</body>
</html>


javascript - -

پنهان کردن اسکريپتها از browserهاي قديمي

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 6615 بار خوانده شده است

browserهاي قديمي از جمله amrica online 1, internet explorer 3, netscape قبل از ويرايش چهارم, JavaScript را متوجه نميشوند, از آنجا که اساس browser بر اين مبنا است که در صورتي که متوجه تگي نشود, از آن بگذرد, اما همه آنها اينگونه عمل نميکنند. يک راه براي پنهان کردن آنها وجود دارد که بوسيله آن تمامي محتويات موجود در تگ مورد نظر به عنوان تگ HTML در نظر گرفته ميشود و در نتيجه اجرا نخواهند شد.

به منظور پنهان کردن اسکريپتها از browserهاي قديمي:

ابتدا عبارت <--hide script from old browser --!> را تايپ کنيد. بدين وسيله دستور HTML نوشته ميگردد.

 1.

سپس عبارت document.write("test")d را تايپ کنيد.

 2.

سپس عبارت <--end hiding script from old browser// را تايپ کنيد. اين خط با علامت مخصوص (//) شروع و باعلامت مخصوص HTML , <--- پايان ميپذيزد.

 3.

**نکات مورد توجه

  • اين تکنيک نيز مانند دستور قبل در تمام اين سايت فرض شده و فقط در اين مثال به آن توجه شده ولي وجود آن ضروري است.

  • در صورتي که بخواهيد عبارتي را براي کاربراني که از browserهاي قديمي استفاده ميکنند بنويسيد, آنرا در تگ <noscript> قرار دهيد, اين پيغام هم در browserهاي قديمي و در browserهاي جديدي که JavaScript در آنها فعال نيست, نشان داده ميشود.

<html>
<head>
</head>

<body>

<h1>

<!-- hide script from old browsers -->

<script language="javascript" type="text/javascript">

document.write("IranJavaScript")

//end hiding script from old browsers -->
</script>
</h1>

</body>
</html>


javascript - -

قرار دادن توضيحات در اسکريپتها

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 6770 بار خوانده شده است

قرار دادن توضيحات در اسکريپتها را ميتوان از نکات مهم در هنگام نوشتن اسکريپتها دانست, زيرا که بدين طريق ميتوان علل نوشتن چنين اسکريپتها را متوجه شد. همچنين يکي ديگر از دلايل نوشتن توضيحات اسکريپت, کمک به استفاده مجدد آن توسط ديگر افراد ميباشد.
براي نوشتن توضيح در اسکريپتها
ابتدا متن مورد نظر را تايپ کنيد. | 1.
توجه داشته باشيد با علامت --!> , JavaScript ديگر به تمامي محتويات داخل آن توجهي از لحاظ دستوري نميکند. |
سپس براي پايان توضيحات علامت <-- را تائپ کنيد. | 2.
سپس دستورات اصلي که در اينجا document.write("test")s است را تائپ کنيد. | 3.

<html>
<head>
</head>

<body>
<h1>

<!-- hide script from old browsers -->
<!--this is on example of a long JavaScript comment-->

<script language="javascript" type="text/javascript">

document.write("IranJavaScript")

//end hiding script from old browsers -->
</script>
</h1>

</body>
</html>


javascript - -

اخطار به کاربر

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 8544 بار خوانده شده است

يکي از مزاياي برنامه JavaScript قابليت ارائه پيش زمينه ذهني به کاربران صفحه طراحي شده ميباشد, بدين معنا که پنجره اي براي اعلام نياز به برنامه JavaScript در صفحه وب مورد درخواست کاربر نمايش در مي آورد. در طراحي نوين, اين روش منسوخ شده است.

براي اخطار به کاربر

عبارت arert("welcome to IranJavaScript webSite")s را تائپ کنيد, همانطور که مشاهده ميکنيد مجموعه اسکريپتهاي مورد نياز براي اخطار دادن به کاربر بايد در بين تگ و قرار گيرد.

<html>
<head>
<script language="javascript" type="text/javascript">

alert("Welcome to IranJavaScript webSite")

</script>

</head>

<body>
<h1>

<!-- hide script from old browsers -->
<!--this is on example of a long JavaScript comment-->

<script language="javascript" type="text/javascript">

document.write("IranJavaScript")

//end hiding script from old browsers -->
</script>
</h1>

</body>
</html>


javascript - -

تاييد انتخاب کاربر

دستور چاپ

تاريخ نشر: دوشنبه 24 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 7251 بار خوانده شده است

تاييد انتخاب کاربر

<html>
<head>
<script language="javascript" type="text/javascript">

if (confirm("Are you sure you want to do that?")) {
alert("you said yes")
}
else {
alert("you said no")
}
</script>

</head>

<body>
<h1>

<!-- hide script from old browsers -->
<!--this is on example of a long JavaScript comment-->

<script language="javascript" type="text/javascript">

document.write("IranJavaScript")

//end hiding script from old browsers -->
</script>
</h1>

</body>
</html>


javascript - -

اعلان پيغام به کاربر

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 7788 بار خوانده شده است

در بعضي موارد بجاي دريافت اعلام بله/خير (yes/no) از طرف کاربر نياز به جواب بيشتري ميباشيم. در اين حالت همانطور که اسکريپت فوق مشاهده ميکنيد, امکان پرسش سئوالي (البته باجواب از قبل تعيين شده) از کاربر فراهم شده تا جوابي بصورت يک جمله از پيش تعيين شده دريافت کنيد.

براي اعلان پيغام به کاربر

ans=prompet("Are you sure you want to do that ?)

در پرانتز اين دستور همانطور که مشاهده ميکنيد, سئوال مطرح شده براي کاربر و جواب از پيش تعيين شده, که در هر صورت يا جواب کاربر برگردانده شده و يا هيچ. حالت دوم در يکي از سه حالت زير پيش مي آيد:
يا برروي "cancel" کليد کند و يا جواب پيش فرض وجود نداشته و کاربر برروي "ok" کليک نمايد و يا کاربر جواب از پيش تعيين شده را پاک کرده و سپس بر روي "ok" کليک نمايد.

**تذکر

  • در بعضي از browserها ميتوان پارامتر قسمت دوم را بدون ايجاد خلل حذف کرد. اما در بغيه, پيغام پيش فرض بنام "undefined" ظاهر ميشود.

<html>
<head>

<script language="javascript" type="text/javascript">
ans=prompt("Are you sure you want to do that?","")
if (ans) {
alert("You said "+ans)
}
else {
alert("You refused to answer")
}

</script>

</head>

<body>
<h1>

<!-- hide script from old browsers -->
<!--this is on example of a long JavaScript comment-->

<script language="javascript" type="text/javascript">

document.write("IranJavaScript")

//end hiding script from old browsers -->
</script>
</h1>

</body>
</html>


javascript - -

دستور العمل redirecting

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 6389 بار خوانده شده است

نه تنها ميتوان وجود برنامه JavaScript را درسيتم کاربر چک کرد, بلکه ميتوان علاوه بر آن نسخه JavaScript را نيز معين نمود. همانطور که در اسکريپت زير مشاهده ميکنيد نحوه عمل redirect کردن و يا فرستادن کاربر به صفحه اي ديگر بر اساس نسخه JavaScript موجود در browser ذکر شده است.

به منظور انتقال کاربر به صفحه جديد

<script language="javascript 1.3" type="text/javascript">

 1.

توسط ويژگي Language در تگ script ميتوان حداقل نسخه اي که browser بتواند زبان اسکريپت نوشته شده را اجرا کند, مشخص نمود. در اين حالت browser نيازمند برنامه JavaScript 1.3 و به بعد ميباشد, بطوريکه اگر browser قابليت اجراي اسکريپت را نداشته باشد, پيغام خطا را مشاهده خواهد کرد.

Window.location="www.microsoft.com"s

2.

در اين خط مشخصه مکاني پنجره فعلي مجددا تنظيم ميشود. بعبارت ديگر browser صفحه فعلي را به صفحه اي خاص تغيير ميدهد.

</script>

3.

تگ پاياني اسکريپت

** نکات مورد توجه

  • نيازي به اضافه کردن ويژگي هاي type يا language به تگ پاياني <script/> نميباشد.

  • توجه داشته باشيد که ميتوان در يک صفحه, از چند نسخه (version) يک زبان اسکريپت استفاده کرد, مثلا در يک جا JavaScript 1.2 و در جاي ديگر JavaScript 1.5 را بکار برد.

  • نميتوان اسکريپت را محدود به نسخه خاصي نمود, از هر نسخه اي که تعيين شود نسخه هاي بعدي آن نيز به اجرا در مي آيد.

  • ذکر اين نکته نيز الزامي است که با مشخص کردن نسخه مخصوصي از اسکريپت, تعدادي از کاربران و بينندگان صفحه در شبکه اينترنت, قادر به دسترسي آن نبوده و در نتيجه عموميت شبکه و استفاده از آن محدود ميشود.

<html>
<head>

<script language="javascript 1.3" type="text/javascript">

window.location="http://www.aghta.com"

</script>

</head>

<body>
<h1>

<!-- hide script from old browsers -->
<!--this is on example of a long JavaScript comment-->

<script language="javascript" type="text/javascript">

document.write("IranJavaScript.com")

//end hiding script from old browsers -->
</script>
</h1>

</body>
</html>


javascript - -

دستور عمل redirecting با استفاده از پيوند

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 6558 بار خوانده شده است

هنگاميکه کاربر اسکريپت موجود در بحث قبل را اجرا کرد, مستقيما از يک صفحه به صفحه ديگر بطور اتوماتيک فرستاده ميشود, بدين وسيله کاربر ميتواند قبل از رفتن به دومين صفحه, بطور مختصر صفحه اول را مشاهده کند و چون اينگونه بنظر ميرسد که در هر صورت مشاهده کامل صفحه ضروري ميباشد, در نتيجه بهتر است عمل انتقال کاربر (redirecting) توسط يک پيوند در صفحه اول انجام شود.
براي انتقال کاربر با استفاده از پيوند
<a href="http://microsoft.com" onclick="windows.locating="aghta.com" ; return false">test</a>s | 1.
بدين صورت, برنامه JavaScript را در تگ پيوند درون سند HTML قرار داده و در صورتيکه کاربر برنامه مزبور را نداشته باشد, پيغامي مبتني بر نياز وجود JavaScript مشاهده خواهد کرد. |
ولي در صورتي که کاربر برنامه قابل اجرا براي JavaScript را داشته و بر روي پيوند کليک کند, کنترل کننده onClick صفحه جديد اجرا ميکند. اما در قسمت return false فرايند مربوطه به درخواست, کاربر متوقف ميسازد و ديگر آدرس مربوطه اجرا نخواهد شد. | 2.

<html>
<head>
</head>

<body>
<h1>

<a href="http://microsoft.com" onclick="windows.location="http://aghta.com" ; return false"> test </a>

</h1>

</body>
</html>


javascript - -

شناسايي Browser

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 6855 بار خوانده شده است

اغلب موارد اجراي مناسبترين حالت يک صفحه بهتر است که نوع browser کاربر مشخص شود.
براي شناسايي نوع browser کاربر
if(navigator.appName== "Microsoft Internet Explorer"){ | 1.
بدين وسيله در صورتيکه مشخصه appName در browser برنامه Microsoft Internet Explorer باشد, اسکريپت به قسمت then ميرود. |
document.write("You're ruuning Internet Explorer") | 2.
در صورتيکه شرط درست باشد دستور write اجرا شده و عبارت داخل گيومه نشان داده ميشود. |
else {s if(navigator.appName== "Netscape") { | 3.
ميتوان از دستور if/else ديگري استفاده نمود, در اين مرحله در صورتيکه appName مربوطه به Netscape باشد, برنامه به قسمت then در مرحله بعد ميرود. |
document.write("You're running Netscape") | 4.
در صورتي که کاربر از IE استفاده کند متن بالا براي نمايش داده خواهد شد. |
document.write("You're not running Netscape or IE") | 5.
در صورتيکه کاربر نه از IE و نه از Netscape استفاده کند, پيغام فوق نمايش داده خواهد شد. |

<html>
<head>

</head>

<body>
<h1>
<script language="javascript" type="text/javascript">

if (navigator.appName== "Microsoft Internet Explorer") {
document.write("You're ruuning Internet Explorer")

}
else {
if (navigator.appName== "Netscape") {
document.write("You're ruuning Netscape")

}
else {
document.write("You're not ruuning IE or Netscape")

}
}

</script>

</h1>

</body>
</html>


javascript - -

وجود Java

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 7230 بار خوانده شده است

قبل از قراردادن appletهاي جاوا براي افزايش کارايي و زيبايي صفحه وب, بايستي ابتدا وجود قابليت غير فعال کردن جاوا در browser آزمايش گردد. تسط اسکريپت فوق ميتوان فعال و يا غيرفعال بودن و بطور کلي, وجود آنرا در سيستم کاربر جستجو کرد.

براي بررسي در فعال بودن جاوا

document.write("Java is")

1.

ابتدا جمله پيغام دهنده را در يک گيومه قرار دهيد.

if (!navigator.javaEnabled()) {

2.

توسط دستور فوق العاده بودن جاوا مورد بررسي قرار ميگيرد. مفهوم علامت تعجب (!), کلمه نه ميباشد, پس دستور فوق در واقع غير فعال بودن جاوا را سئوال ميکند.

document.write("not")

3.

در صورتيکه نتيجه مرحله قبل, درست باشد, در نتيجه برنامه جاوا غيرفعال بوده و سپس کلمه "not" چاپ ميشود.

document.write("enabled")

4.

در هر صورت کلمه فعال (enabled) در پايان, در پنجره کاربر ظاهر ميشود.

**تذکر

  • با توجه به وجود اسکريپت هاي مختلف JavaScript بهتر است براي ترکيب آنها اين اسکريپتها را در مکاني خاص ذخيره کنيد.

<html>
<head>

</head>

<body>
<h1>
<script language="javascript" type="text/javascript">
document.write("Java is ")
if (!navigator.javaEnabled()) {
document.write("not")
}

document.write("enabled")
</script>

</h1>

</body>
</html>


javascript - -

توابع

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: شروع JavaScript

اين مقاله تاکنون 6266 بار خوانده شده است

تابع مجموعه اي از جملات JavaScript بوده که يک وظيفه مشخصي را انجام ميدهند. بطوريکه هر تابع داراي اسم بوده و توسط قسمتهاي ديگر اسکريپت فراخواني ميشود.
از خصوصيات توابع, ميتوان از استفاده متناوب و بيشمار آن در کل اسکريپت نام برد. مثلا توسط تابعي, اطلاعاتي تائپ شده توسط کاربر درون يک فرم با برنامه JavaScript ذخيره ميشود. ذکر اين نکته نيز لازم است که ميتوان از يک کد به دفعات براي استفاده يکسري اطلاعات استفاده کرد. اما بهتر است که کد مربوطه را بعنوان يک تابع نوشته و سپس تابع را در مکانهاي مختلف اسکريپت استفاده نمود. تابع, شامل لغت function به همراه نام تابع ميباشد و سپس بعد از نام تابع, پرانتزها و يک براکت قرار ميگيرد. بعد از آن دستور العمل مورد نظر نوشته شده و براکت بسته ميشود. در زير نمونه اي از تابع نوشته شده است:

Function saysomething(){
alert("for score and seven years ago")
}

توجه داشته باشيد که خط دستور (alert) براي شناسايي و راحتي تشخيص کد, اندکي از خط به داخل رفته است.


javascript - -

فراخواني تابع

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 7555 بار خوانده شده است

براي فراخواني تابع بهتر است که از کنترل کنندهاي حالت همان طور که قبلا توضيح داديم, استفاده نمود.
مثلا براي فراخواني تابع saysomething در هنگام کليک برروي دکمه (button) بايستي از کد زير استفاده کنيد:

<input type="button" value="lincoln" onclick="saysomething()"

تبادل اطلاعات

در اغلب موارد بايستي به تابع يک سري اطلاعات داد و يا از آن يک سري اطلاعات دريافت نمود.
به اين عمل تبادل اطلاعات گويند.

function saysomething(message) {
alert(message)
}

همچنين کد فراخواني به صورت زير ميباشد:

<input type="button" value="lincoln" onclick="'four score and saysomething seven years ago..'">

در تابع فوق متغيير message پارامتر تابع ناميده ميشود, بطوريکه در هنگام فراخواني تابع داده Four score and seven years years ago به پارامتر message ارتباط داده ميشود. پارامترهاي تابع ميتواند شامل رشته حرفي, عددي و حتي يک (JavaScript object) ديگر باشند.
يکي از محسنات اين نوع تابع, استفاده از آن در يک سري از دکمه ها ميباشد که با يک تابع, پيغام هاي مختلفي به کاربر داده ميشود.

<input type="button" value="lincoln" onclick="saysomething('four score and saysomething seven years ago..')">

<input type="button" value="kennedy" onclick="sysomething (Ask not what your country can do for you..">

<input type="button" value="nixon" onclick="saysomething('I am not a crook!)'">

<html>
<head>

<script language="javascript" type="text/javascript">
function saysomething(message) {
alert(message)
}
</script>

</head>

<body>
<h1>
<form>
<input type="button" value="Lincoln" onClick="saysomething('four score and seven years ago..')" >
<input type="button" value="Kennedy" onClick="saysomething('Ask not what your country con do for you...')" >
<input type="button" value="Nixon" onClick="saysomething('I am not a crook!')" >
</form>
</h1>

</body>
</html>


javascript - -

پيغام متحرک در status bar

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 10946 بار خوانده شده است

توسط اين اسکريپت جمله اي درون قسمت status bar پنجره هاي browser به حرکت در مي آيد.

براي ايجاد پيغام متحرک در status bar

myMsg="welcome to IranJavaScript.com website..

.1

بدين طريق متغير myMsg به متن داخل علامت گيومه مرتبط شده است.

i=0

.2

متغير i در برنامه بعنوان شمارنده استفاده ميشود. در طول اين برنامه مقدار i ايتدا زياد و سپس به صفر بر ميگردد.

function scrollMsg() {

.3

توسط اين دستور, تابعي با نام scrollMsg ايجاد ميشود.

window.status=myMsg.SUBstring
(i,myMsg.length) + myMsg.
SUBstring(0/i-1)

.4

توسط اين خط ويژگي قسمت status bar در پنجره تنظيم ميشود, بعبارت ديگر مشخصات همان خطي که در پايين پنحره قرار ميگيرد, تعيين ميگردد. همچنين توسط SUBstring(x,y)s متغيير myMsg به دو قسمت تقسيم ميشود, بگونه اي که پيغام کاراکتر از مکان کاراکتر x شروع و به مکان ما قبل y خاتمه مي يابد.

if (i<myMsg.>length)
i++

.5

در صوتيکه مقدار i کمتر از طول متغيير myMsg باشد, به i مقدار يک اضافه ميگردد.

else {
i=0

.6

در غير اين صورت, هنگاميکه مقدار i برابر و يا بيشتر myMsg , باشد, مقدار i=0 ميگردد.

setTimeout("scrollMsg()",50)

.7

توسط دستور setTimeout()s ميتوان توقفي در فرآيند ايجاد کرد. بطوريکه بايستي در داخل پرانتزها, نام تابعي که بايستي متوقف شود را نوشته و سپس بعد از کاما مدت زمان توقف را برحسب ميلي ثانيه مشخص نمود. در اين مثال, تابع scrollMsg()s به مقدار 50 ميلي ثانيه در فرايند, متوقف ميشود.

**نکات مورد توجه

  • براي افزايش و سرعت نمايش پيغام متحرک, عدد 50 را در مرحله 7 کاهش دهيد و بالعکس.

  • توجه داشته باشيد که هر ثانيه شامل 1000 ميلي ثانيه ميباشد.

  • امروزه استفاده از پيامهاي متحرک در قسمت status اندکي کليشه اي شده است.

<html>
<head>

<script language="javascript" type="text/javascript">
myMsg = "Welcome to IranJavaScript.com website..."
i=0
function scrollMsg() {
window.status = myMsg.substring(i,myMsg.length) + myMsg.substring(0/i-1)
if (i<myMsg.length) {
i++
}
else {
i = 0
}
setTimeout("scrollMsg()",150)
}

</script>

</head>

<body onload="scrollMsg()">
<h1>
IranJavaScript.com
</h1>

</body>
</html>


javascript - -

پيامها در status bar

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: شروع JavaScript

اين مقاله تاکنون 10348 بار خوانده شده است

يکي ديگر از کارهايي که ميتوان انجام داد, ارائه توضيحات لازم براي هر پيوند, در هنگام قرار گرفتن نشانگر موس بر روي آنها در قسمت status bar ميباشد.

<A href="aghta.com"
                    onMouseover="window.status='Personal web site' ; return
                    true" onMouseout="window.status=''; return true">test</a>

همانطور که مشاهده ميکنيد دستورات JavaScript در تگ آدرس دهي HTML قرار گرفته اند, بطوريکه توسط کنترل کننده onMouserover هنگام قرار گرفتن ماوس برروي پيوند مربوطه, عمل خاصي را انجام داده, در اين مثال عبارت 'Persinal web site' را در پيوند test به شي window.status,(object)s ربط داده است. در قمستي return true پيغام نمايش داده ميشود. سپس کنترل کننده onMouseout عبارت فوق را در قسمت status پاک ميکند.

<a href="aghta.com"
                    onMouseover="window.status='personal web site !';return
                    true" onMouseout="window.status='';return true">test</a>
**نکته

  • توجه داشته باشيد که بعضي از نسخه هاي IE قادر به استفاده از اين کنترل کننده نيستند.

<html>
<head>
</head>

<body>
<h1>
<a href="http://Iranjavascript.com" onMouseover="window.status='personal web site !';return true" onMouseout="window.status='';return true">IranJavaScript.com</a>
</h1>

</body>
</html>


javascript - -

ايجاد rolloverهاي کاراتر

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: بازي با تصاوير

اين مقاله تاکنون 8021 بار خوانده شده است

به منظور ايجاد يک تصوير متحرک در هنگام قراردادن ماوس برروي تصوير, بايستي در نمايش تصوير دوم تاخيري ايجاد نشود. بدين منظور با استفاده از JavaScript تمامي تصاوير را از قبل به سيستم کاربر انتقال داده تا در زمان لزوم, تصاوير توسط متغيير بوسيله اسکريپت نشان داده شوند.
براي تهيه rollover بهتر

if
                    (document.images) {
arrowRed = new Image
arrowBlue = new Image
arrowRed.src = "images/test1.gif"
arrowBlue.src = "images/test2.gif"
}

 1.
توسط اين کدها, قابليت درک اشياء توسط browser امتحان گشته, در صوريتکه جواب مثبت شد, دو تصوير مجزاي arrowRed و arrowBlue ايجاد ميگردند. سپس از ويژگي src در تعيين مکان تصوير استفاده ميشود.

else {
arrowRed = ""
arrowBlue = ""
document.arrow = ""
}

2.
براي browserهاي قديمي, به منظور جلوگيري از نمايش پيغامهاي اشتباه, بهتر است از حالت else با متغيرها و document.arrow که خالي هستند, يک رشته حرفي خالي درست کنيد.

<A href="aghta.com" onMuseover =
"document.arrow.src = arrowRed.src"
onMouseout = "document.arrow.src = arrowBlue.src">

3.
دستورات آدرس دهي فوق, براي ايجاد پيوند با توجه به مشخصات, rollover موجود در صفحه نوشته ميشود, يعني دو کنترل کننده onMouseover و onMouseout را درون تگ آدرس قرار داده تا دو حالت ممکن را تعريف کنند.
**نکات مورد توجه
  • يادآوري ميشود که در هنگام ايجاد تصوير gif از تصاوير شفاف استفاده نکنيد زيرا در هنگام تعويض تصوير دوم, تصوير قبل در زير آن نمايش داده ميشود.
  • توجه داشته باشيد که ابعاد هر دو تصوير بايستي يکسان باشند. هرچند در IE تصاوير غير اندازه بطور مناسب نمايش داده ميشوند, اما در netscape متيجه مطلوبي نخواهد داشت.

<html>
<head>

<script language="javascript" type="text/javascript">
if(document.images) {
arrowRed = new Image
arrowBlue = new Image

arrowRed.src = "images/test1.gif"
arrowBlue.src = "images/test2.gif"

}
else {

arrowRed = ""
arrowBlue = ""
document.arrow = ""
}

</script>
</head>

<body>
<h1>

<a href="http://aghta.com" onMouseover="document.arrow.src=arrowRed.src" onMouseout="document.arrow.src=arrowBlue.src"><img border="0" src="images/test2.gif" name="arrow"></a>
</h1>

</body>
</html>


javascript - -

ايجاد rolloverها

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: بازي با تصاوير

اين مقاله تاکنون 7867 بار خوانده شده است

مفهوم rollover بسيار ساده ميباشد, بدين معنا که ابتدا دو تصويروجود داشته, تصوير اول در هنگام دريافت صفحه وب توسط کاربر در browser نمايش داده ميشود, سپس بعد از آنکه کاربر, ماوس را برروي اولين تصوير ببرد browser تصوير دوم را با تصوير اول در عوض چند لحظه عوض ميکند.
براي ايجاد rollover

<A href="aghta.com"

1.
همانطور که ميدانيد, پيوند براي مشخص کردن مسير بعدي تصوير ميباشد.

onMouseover="document.arrow.src='images/test1.gif'"

2.
هنگام قرار گرفتن ماوس برروي تصوير دوم از داخل دايرکتوري برروي سند پنجره نمايان ميشود.

onMouseout="document.arrow.src='images/test2.gif'"

3.
سپس با کنار رفتن موس از روي تصوير, تصوير به حالت اوليه برميگردد.
**تذکر
  • ساختن rollover ها بدين طريق, در هنگام قرار گرفتن ماوس برروي تصوير, به علت وجود تصوير دوم بر روي server آن تصوير با اندکي تاخير نمايان ميشود. براي برطرف کردن اين موضوع به مبحث بعد که در مورد ollover ها کاملتر بحث ميشود, رجوع نماييد.

<html>
<head>
</head>

<body>
<h1>

<a href="http://aghta.com" onMouseover="document.arrow.src='images/test1.gif'" onMouseout="document.arrow.src='images/test2.gif'"><img border=1 src="images/test1.gif" name="arrow"></a>
</h1>

</body>
</html>


javascript - -

قرار دادن چندين rollover در صفحه

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: بازي با تصاوير

اين مقاله تاکنون 8569 بار خوانده شده است

تابحال دستورات مورد نياز براي قرار دادن تنها يک rollover در صفحه آموختيد, براي قرار دادن چند rollover بايستي تنها اندکي دستور به آنچه قبلا ذکر شده بيافزاييد.
براي قرار دادن چند rollover در صفحه

button1Red = new Image
button1Blue = new Image
button2Red = new Image
button2Blue = new Image

1.
بطور کلي براي هر rollover بايستي دو تصوير تهيه نمود.

button1Red.src = "images/test1.gif"
button1Blue.src = "images/test2.gif"
button2Red.src = "images/test1.gif"
button2Blue.src = "images/test3.gif"

2.
در اين مرحله مسير تصاوير ويژگي src تخصيص داده ميشود.

button1Red = ""
button1Blue = ""
button2Red = ""
button2Blue = ""

3.
اين مرحله نيز براي browserهاي قديمي در نظر گرفته ميشود تا در هنگام بارگذاري صفحه, پيغام اشتباه در روي سيستم کاربر نمايان نشود.

document.button1 = ""
document.button2 = ""

4.
هر کدام از متغييرهاي document نيز براي يک rollover نوشته ميشوند.
**تذکر
  • توجه داشته باشيد که هر تصوير و هر تگ IMG بايستي داراي يک نام باشند, در غير اينصورت JavaScript قادر به تشخيص مکانهاي تصاوير نميشود.

<html>
<head>

<script language="javascript" type="text/javascript">

if(document.images) {
button1Red = new Image
button1Blue = new Image

button2Red = new Image
button2Blue = new Image

button1Red.src = "images/test1.gif"
button1Blue.src = "images/test2.gif"

button2Red.src = "images/test1.gif"
button2Blue.src = "images/test3.gif"

}
else {

button1Red = ""
button1Blue = ""

button2Red = ""
button2Blue = ""

document.button1 = ""
document.button2 = ""
}

</script>
</head>

<body>
<h1>

<a href="aghta.com" onMouseover="document.button1.src=button1Red.src" onMouseout="document.button1.src=button1Blue.src"><img border="0" src="images/test2.gif" name="button1"></a>
<br>
<a href="aghta.com" onMouseover="document.button2.src=button2Red.src" onMouseout="document.button2.src=button2Blue.src"><img border="0" src="images/test3.gif" name="button2"></a>

</h1>

</body>
</html>


javascript - -

نمايش يک تصوير به صورت اتفاقي

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: بازي با تصاوير

اين مقاله تاکنون 12516 بار خوانده شده است

در صورت وجود منبع بزرگي از تصاوير در صفحه, ميتوان از يک تصوير بفرم اتفاقي استفاده کرد.
براي نمايش يک تصوير بصورت اتفاقي

myPix=newArray
("images/test1.gif","images/test2.gif",
"images/test3.gif")

1.
بدين وسيله يک ارائه 3 عضوء با نام myPix ايجاد ميشود.

imgCt=myPix.Length

2.
تعداد ارقام موجود در آرايه myPix برابر با مقدار متغيير imgCt ميگردد.

function choosepic(){

3.
تابع choosepic()s تعريف ميگردد.

if(document.images) {
randomNum = Math.floor
((Math.random()*imgCt))

4.
در صورتي که سند بتواند تصاوير را به نمايش درآورد, متغيري بنام randomNum ايجاد شده که در نتيجه ارزشي عبارت رياضي را دريافت ميکند. و اما عبارت Math.random()s يک عدد اتفاقي بين صفر و بک ايجاد نموده و سپس با متغيير imgCt ضرب ميکند. در ضمن بدليل گردکردن نتيجه عددي, عدد بايستي بين صفر و دو باشد.

document.myPicture.src= myPix[randomNum]

5.
بدين صورت مبدا تصوير myPicture در متغيير myPix بوده که در اين حالت ارزش مقداري آن وابسته به مقدار random Num ميباشد.

onload = "choosePic()"

6.
با استفاده از دستور onLoad تابع choosePic آغاز ميشود.

<img src="images/test1.gif" name="myPicture">

7.
در اين قسمت نام تصوير myPicture نامگذاري شده و سپس از آن در تغيير تصوير توسط اسکريپت استفاده ميشود.

<html>
<head>
<script language="javascript" type="text/javascript">

myPix = new Array("images/test1.gif","images/test2.gif","images/test3.gif")
imgCt = myPix.length

function choosePic() {
if(document.images){
randomNum = Math.floor((Math.random()*imgCt))
document.myPicture.src = myPix[randomNum]
}
}
</script>
</head>

<body onload="choosePic()">
<h1>
<img src="images/test1.gif" name="myPicture">
</h1>

</body>
</html>


javascript - -

تشخيص زبانbrowser كاربر

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 7140 بار خوانده شده است

تشخيص زبان كاربري كه وارد سايت شما مي ‌شود، مي تواند خيلي جالب باشد و كارايي سايت شما را بالاتر ببرد. Navigator 4.0 و نگارش هاي بعدي آن داراي خصوصيت navigator.language هستند، كه يك كد دو حرفي بر حسب زبان مرورگر وب شما است و از استاندارد ISO639 استفاده مي كند. براي مثال اگر زبان مرورگر خود را روي فارسي قرار داده باشيد كدي كه توسط اين خصوصيت برگردانده مي شود fa خواهد بود. ليست كامل اين كدها در آدرس زير موجود است:
http://palimpsest.stanford.edu/lex/iso639.html

مرورگرهاي IE 4.0 و نگارش هاي بعدي آن نيز داراي سه خاصيت هستند:
browserLanguage , systemLanguage , userLanguage
browserLanguage زبان انتخاب شده در مرورگر
systemLanguage زبان انتخاب شده در سيستم عامل
userLanguage زباني كه كاربر فعلي در Control Panel و در قسمت RegionalSettings انتخاب كرده است.

كد برگردانده شده توسط اين خصوصيات كمي با كدهاي داده شده در Navigator فرق مي كند، البته براي زبان فارسي همان كد fa داده مي شود. ليست كامل اين كدها در آدرس زير موجود است:
http://msdn.microsoft.com/library/default.asp?url=/workshop/author/dhtml/reference/language_codes.asp

به اين ترتيب شما مي توانيد به كاربران سايت خود، صفحات را به زبان خودشان نمايش دهيد. البته براي اين كار شما بايد اطلاعات بيشتري درباره javascript داشته باشيد.

<html>
<head>
<title>UserLanguage</title>
</head>
<body>
<h1>
<script type="text/javascript">
document.write("User language is: " + navigator.userLanguage);
</script>
</h1>
</body>
</html>


javascript - -

قرار دادن page درون قالب

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کار با Framesها

اين مقاله تاکنون 9896 بار خوانده شده است

با دستور ميتوانيد يک Page ديگري را در صفحه فعلي نمايش دهيد.
براي قرار دادن يک صفجه درون قالب
if(top.location==self.location) { | 1.
محل قرار گرفتن صفحه فعلي(self) را در بالاترين سطح بررسي ميکند. درصورتيکه پاسخ منفي باشد, بدين معني خواهد بود که سطح فعلي در يک مجموعه قالب ميباشد. |
self.location.replace("http://iranjavascipt.com") | 2.
در صورتيکه محل صفحه فعلي در قسمت top باشد, صفحه فعلي را با آدرس مجموعه قالب تعويض ميکند. بدين طريق در يک مجموعه قالب نشان داده ميشود. |

<html>
<head>
<script language="javascript" type="text/javascript">
if(top.location==self.location){
self.location.replace("http://iranjavascript.com")
}
</script>
</head>

<body onload="choosePic()">
<h1>
<img src="images/test1.gif" name="myPicture">
</h1>

</body>
</html>


javascript - -

کار با پنجرهاي Browser

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 6651 بار خوانده شده است

همانطور که مستحضر هستيد, پنجره يک فصل اشتراک مهم در شبکه وب ميباشد, بطوريکه توسط JavaScript ميتوان اعمال متفاوتي در چگونگي عملکرد اين پنجره ها انجام داد.
در اين قسمت ما با استفاده از يک gif قسمتها مختلف browser را به شما معرفي ميکنيم تا در مقالات بعد در صورت استفاده از اصطلاح شما دچار مشگل نگرديد.
معرفي قسمتهاي browser


javascript - -

کنترل Browser

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 7965 بار خوانده شده است

شما ميتوانيد پنجرهاي موجود را به سادگي کنترل نماييد و يا مشخصات خاصي را براي آن تعريف نماييد.
نحوه اجرا
براي ايجاد صفحه جديد کافيست در قسمت

href="javaScript:openTourWindow('iranjavascript.com',500,300);"

تغييرات مورد نظر خود را اعمال نماييد.

<html>
<head>
<script language="JavaScript"><!--
//Tour Window
function openTourWindow(url, width, height) {
var Win = window.open (url,"OpenTourWindow",'width=' + width + ',height=' + height + ',resizable=yes,scrollbars=yes,menubar=no,resizable=no,scrollbars=no,statusbar=no,left=200,top=150');
}
// -->
</script>
</head>

<body>
<h4>
<a target="_self" href="javaScript:openTourWindow('http://iranjavascript.com',500,300);">
IranJavaScript.com</a></h4>

</body>
</html>


javascript - -

نحوه ايجاد Control panel

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 9211 بار خوانده شده است

يکي از راههاي ايجاد امکانات بيشمار در زمينه طراحي صفحه هاي با قابليت ايجاد ارتباط استفاده از زير پنجره ها ميباشد.
براي ايجاد يک Control panel

newWindow = window.open("test2.asp","newWin","Width=200,height=350")

1.

با اين دستور پنجره جديدي باز خواهد شد که درون آن صفحه test2.asp نمايش داده خواهد شد.

function updateParent(newURL) {

2.
در اين مرحله صفحه test2.asp اجرا ميشود در اين خط, يک تابع جديد با نام updateParent و به همراه متغيير newURL تعريف شده است.

opener.document.location = newURL

3.
در اين خط, موقعيت سند opener بوسيله متغيير newURL معلوم ميشود.

<a href="javascript:updateParent('http://iranjavascript.com')">

4.
با کليک کردن بر روي پيوند IranJavaScript.com تابع updateParent صدا زده شده و متغيير newURL نام صفحه به test2.asp را به خود اختصاص ميدهد.
**نکته
  • در دستور زماني درست کار خواهد کرد که در تمام صفحاتي که نمايش داده ميشوند اسکريپت فوق وجود داشته باشد

function updateParent(newURL) {
opener.document.location = newURL

<html>
<head>

<script language="javascript" type="text/javascript">
newWindow = window.open("test2.asp","newWin","Width=200,height=350")
</script>

</head>

<body>
<h1>
IranJavaScript.com
</h1>

</body>
</html>


javascript - -

تغيير سايز browser

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کار با پنجره هاي Browser

اين مقاله تاکنون 8677 بار خوانده شده است

شما با اين دستور ميتوانيد بزرگي و کوچکي browser کاربر را مشخص نماييد.

<html>
<head>
<script>
function changeScreenSize(w,h)
{
window.resizeTo( w,h )
}
</script>
</head>

<body onload="changeScreenSize(400,400)">

<p><a href="#" onclick="return changeScreenSize(800,600)">change screen to 800,
600</a></p>
<p><a href="#" onclick="return changeScreenSize(640,480)">change screen to 640,
480</a></p>

</body>

</html>


javascript - -

منوهاي Select-Go

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 8161 بار خوانده شده است

در صورتيکه در سايتهاي شبکه اينترنت به جستجو پرداخته باشيد, به احتمال قوي با منوهايي که داراي چندين انتخاب باشند و بتوان اقلام آنها را انتخاب نموده و سپس با استفاده از کليد Go به مبحث مورد نظر متصل شود, برخورد کرده ايد.
براي ايجاد منوهاي Select -Go

Function jumpPage(newLoc) {

1.
ابتدا تابعي با نام jumpPage و به همراه متغيير newLoc ايجاد کنيد.

newPage=newLoc.options[newLoc.Select Index].Value

2.
نحوه کار اين دستور فوق از قسمت داخل به بيرون ميباشد.

if(newPage !="") {
Window.Location=newPage
}

3.
در صورتيکه متغيير newPage خالي نباشد, و يا به عبارتي اگر متغيير مذکور داراي مقداري باشد, پنجره به آدرس مشخص شده توسط انتخاب موجود در منو ميرود.

<html>
<head>

<script language="javascript" type="text/javascript">
function jumpPage(newLoc) {
newPage = newLoc.options[newLoc.selectedIndex].value

if(newPage != "") {
window.location = newPage
}
}
</script>

</head>
<body>

<form action="#">
<select name="newLocation" onChange="jumpPage(this.form.newLocation)">
<option value="http://gooya.com">Gooya
<option value="http://aghta.com">AGHTA
<option value="http://npiran.com">NPIran
<option value="http://iranasp.com">IranASP
</select>

</body>
</html>


javascript - -

تشابه فيلدهاي Password

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 7592 بار خوانده شده است

هنگامي که کاربر بايستي رمز را براي استفاده مجدد تايپ کند به منظور کاهش احتمال خطا, دو فيلد password در فرم قرار ميدهند, که در صورت غير يکسان بودن محتوياتشان پيغام اخطاري به کاربر داده شود.
به منظور تعيين صحت Password هاي وارد شده

function validForm(passForm){
if (passForm.passwd1.valu == "") {
alert("you must enter a password")
passForm.passwd1.focus()
return false
}

1.
پس از تعيين تايع, مقدار فيلد Passwd1 مورد بررسي قرار گرفته و در صورت خالي بودن محتوايش, يک پيغام اخطار به مضنون, " کلمه عبور را تائپ کنيد" نمايان ميگردد. سپس نشانگر ماوس را به ابتداي فيلد Passwd1 برده و به تابع, ارزش false ميدهد.

if(passForm.passwd1.value !=passForm.passwd2.value) {
alert("entered passwords did not match")

passForm.passwd1.focus()
passForm.passwd1.select()

return false
}
return true
}

2.
در صورتکيه مقدار Passwd1 برابر Passwd2 نباشد, پيغام اخطار (alert) داده ميشود, سپس محتوي فيلد اول را انتخاب کرده بطوريکه ميتوان محتويات آن را تغيير داد. در غير اين صورت پيغام صحيح (true) را ارائه ميدهد.

onSubmit="return validForm(this)"

3.
در هنگام Submit فرم, چه با کليد Submit و چه با هر حرکت ديگري که مدنظر است, کنتزل کننده onSubmit به اجرا در مي آيد. در صورتيکه نتيجه بدست آمده از مراحل قبل صحيح (true) باشد, اطلاعات تائپ شده به Server فرستاده ميشود و در غير اين صورت کنترل کننده مزبور وجود اشتباه (false) را متوحه گشته و از فرستاده شدن اطلاعات به Server جلوگيري ميکند. در واقع يکي از فرمتهاي javascript درک اشتباه در قسمت Client side ميباشد, بنابراين هيچگاه Server در ارتباط با چنين عملي قرار نخواهد گرفت.

<html>
<head>

<script language="javascript" type="text/javascript">
function validForm(passForm){
if (passForm.passwd1.valu == "") {
alert("you must enter a password")
passForm.passwd1.focus()
return false
}

if(passForm.passwd1.value !=passForm.passwd2.value) {
alert("entered passwords did not match")

passForm.passwd1.focus()
passForm.passwd1.select()

return false
}
return true
}

</script>

</head>

<body><h3>
<form onSubmit="return validForm(this)" action="ok.asp">
Your name:<input type="text" size="30"><br>
Choose a password:<input type="password" name="passwd1" size="20"><br>
verify password:<input type="password" name="passwd2" size="20"><br>
<input type="Submit" value="Submit">
</form>
</h3>

</body>
</html>


javascript - -

تاييد انتخاب شدن اجزاي يک منو

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 7865 بار خوانده شده است

درمثال فوق کاربر بايد از فرم مربوطه يکي را حتما انتخاب نمايد.
براي تاييد انتخاب

function SubmitIt(carForm) {

1.
بدين صورت يک تابع با نام SubmitIt که در اجزاء فرم مورد استفاده قرار ميگيرد ايجاد ميشود.

colorChoice = carForm.color.selectedIndex

2.
متغيير colorChoice يکي از رنگهاي موجود را بر اساس انتخاب کاربر, به خود ميگيرد.

if(carForm.color.options[colorChoice].value == "") {
alert("You must pick a color")
return false

3.
در اين قسمت مقدار متغير colorChoice مورد بررسي قرار گرفته و در صورتيکه مقداري نداشته باشد, پيغام اخطاري به مضنون "يک رنگ انتخاب کنيد." به کاربر داده شده و نتيجه false ارسال ميشود, سپس مراحل از ابتدا آغاز ميگردد.

return true

4.
در غير اين صورت, صحت انتخاب تاييد شده و نتيجه true اعلام ميگردد.

<html>
<head>

<script language="javascript" type="text/javascript">
function SubmitIt(carForm) {
colorChoice = carForm.color.selectedIndex
if(carForm.color.options[colorChoice].value == "") {
alert("You must pick a color")
return false
}
return true
}
</script>

</head>
<body>

<form onSubmit="return SubmitIt(this)" name="myForm" action="ok.asp">
<select name="color">
<option value="" selected>Choose a color
<option value="RED">Red
<option value="GREEN">Green
<option value="BLUE">Blue
</select><input type="Submit" value="Submit">
</form>

</body>
</html>


javascript - -

بکارگيري Radio button ها

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 6771 بار خوانده شده است

براي انتخاب يک مورد ازموارد قرار داده شده تحت يک تيتر و موضوع مورد نظر از radio button ها استفاده ميشود.
در اين مطلب کاربر حتما يکي از radio buttonهاي موجود را انتخاب نمايد.
براي حصول اطمينان از انتخاب يک radio button

Function SubmitIt(carForm) {
door Option = -1

1.
با تعريف تابع SubmitIt و تخصيص يک عدد نامفهوم (1-) به متغيير door Option حلقه مورد نظر شروع ميشود.

for (i=0; i<carForm.DoorCt.length;i++) {

2.
اکنون حلقه آغاز ميشود, ابتدا متغيير i ارزشي معادل صفر داشته, درضمن چون مقداري کمتر از عدد radiobutton در فرم دارد, يک واحد به ارزش i مي افزايد. (1++)

if(carForm.DoorCt[1].checked) {
doorOption = i
}

3.
سپس در صورتيکه radio button انتخاب شده باشد, مقدار i به doorOption تخصيص مي يابد.

if(doorOption ==-1) {
alert("You must choose 2 or 4 door")
return false
}

4.
و در صورتيکه کاربر هيچ کدام از آنها را انتخاب نکند, پيغام اخطاري داده شده و نتيجتا ارزش false ارسال ميگردد.

return true

5.
در غير اين صورت (door Option=-1) و سپس يک کدام انتخاب شده و نتيجه صحيح ارائه ميگردد.

<html>
<head>
<script language="javascript" type="text/javascript">
function SubmitIt(carForm) {
doorOption = -1
for (i=0; i<carForm.DoorCt.length;i++) {
if(carForm.DoorCt[1].checked) {
doorOption = i
}
}
if(doorOption ==-1) {
alert("You must choose 2 or 4 door")
return false
}
return true
}
</script>
</head>
<body>
<h2>
Car Picker<p>
<form onSubmit="return SubmitIt(this)" action="ok.asp" name="myForm">
Doors:<br>
<input type="radio" value="twoDoor" name="DoorCt">two
<input type="radio" value="fourDoor" name="DoorCt">Four
<br>
<input type="Submit" value="Submit">
</form></h2>
</body>
</html>


javascript - -

غير فعال کردن دکمه سمت راست موس

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 8947 بار خوانده شده است

اين مجموعه دستورات باعث خواهد شد تا دکمه سمت راست موس از فعاليت بيوفتد و پيغام درخواستي شما را براي User به نمايش درآورد.

<html>
<head>
</head>
<script language="JavaScript">
<!--
var message="HTTP://IranJavaScript.com";
function click(e) {
if (document.all) {
if (event.button==2||event.button==3) {
alert(message);
return false;
}
}
if (document.layers) {
if (e.which == 3) {
alert(message);
return false;
}
}
}
if (document.layers) {
document.captureEvents(Event.MOUSEDOWN);
}
document.onmousedown=click;

//-->
</script>

<body>
<h2>
IranJavaScript.com
</h2>
</body>
</html>


javascript - -

تنظيم يک فيلد بر اساس فيلد ديگر

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: معتبر سازي فرمها

اين مقاله تاکنون 7095 بار خوانده شده است

شايد تابحال به فرمهايي برخورد کرده ايد که با تعيين يک فيلد, فيلد ديگر بصورت اتوماتيک انتخاب ميشود.
به منظور تنظيم اتوماتيک مقدار يک فيلد

function doorSet(sunroofField) {

1.
طبق معمول ابتدا يک تابع تعريف ميشود.

if (sunroofField.checked) {
for (i=0; i<document.myForm.DoorCt.length; i++) {

2.
در اين مرحله, در صورت انتخاب فيلد Sunroof يک حلقه براي تمامي فيلدهاي DoorCt ايجاد ميشود.

if (document.myForm.DoorCt[i].value == "twoDoor") {

3.
کاربر به دنبال يک ماشين دو درب خواهد بود.

document.myForm.DoorCt[i].checked = true

4.
هنگام انتخاب يک ماشين دو درب, به آن ارزش true داده ميشود.

<input type="CHECKBOX" name="sunroof" value="YES" onClick="doorSet(this)">

5.
درون قسمت Body, بايستي فيلد مربوط به Sunroof تعيين شود تا با کليک بر روي آن, توسط کنترل کننده onClick, تابعdoorSet(this)s اجرا گردد.

<html>
<head>
<script language="javascript" type="text/javascript">
function SubmitIt(carForm) {
doorOption = -1

if (carForm.DoorCt[doorOption].value == "fourDoor" && carForm.sunroof.checked) {
alert("The sunroof is only available on the two door model")
return false
}
return true
}

function doorSet(sunroofField) {
if (sunroofField.checked) {
for (i=0; i<document.myForm.DoorCt.length; i++) {
if (document.myForm.DoorCt[i].value == "twoDoor") {
document.myForm.DoorCt[i].checked = true
}
}
}
}
</script>
</head>
<body>
<h2>
Car Picker<p>
<form onSubmit="return SubmitIt(this)" action="ok.asp" name="myForm">
Doors:
<br>
<input type="CHECKBOX" name="sunroof" value="YES" onClick="doorSet(this)">Sunroof(two door only)
<br><br>
<input type="radio" value="twoDoor" name="DoorCt">two
<input type="radio" value="fourDoor" name="DoorCt">Four
<br>

<input type="Submit" value="Submit">
</form></h2>
</body>
</html>


javascript - -

معتبر سازي ادرس Email با استفاده از معادلات قاعده اي

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: فرم ها و معادلات قاعده اي

اين مقاله تاکنون 8267 بار خوانده شده است

با استفاده از معادلات با قاعده, ميتوان آدرسهاي Email را معتبر ساخت.
به منظور معتبر سازي آدرس email با استفاده ازمعادلات قاعده اي

re=/^\w+([\.-]?\w+)*@\w+([\.-]?\w+)*(\.\w{2,3})+$/

1.
re يک متغيير ميباشد که مقدار سمت راست به آن اختصاص مي يابد. يک RegExp هميشه با يک علامت / شروع و پايان مي يابد و هر آنچه که درون اين دو علامت باشند, را معادله قاعده اي مي نامند. علامت ^ براي آزمايش از ابتداي رشته حرفي بوده زيرا ممکن است کاربر, کلمات و يا علامات نامفهومي را نوشته باشد.
علامت + بدين معني ميباشد که يک يا چند جزء قبلي در حال بررسي ميباشند. در اين حالت که يک آدرس email همانطور که قبلا نيز ذکر شد, بايستي با يک يا چند ترکيب از کارکترهاي a تا z, س A تا Z , س 0 تا 9 و خط تيره شروع شود.
علامت [] براي استفاده از يک يا چند کارکتر مورد نظر, استفاده ميشود. در اين مثال, کارکترهاي -.\ داخل براکت ( [] ) ميباشد. بدين صورت کاربر ميتواند " نقطه " ( . ) يا خط فاصله ( - ) را استفاده نمايد. اما بدليل انکه " نقطه " داراي مفهوم خاصي درمعادلات قاعده اي ميباشد, قبل از آن از علامت "\" استفاده شده است بدين صورت مفهوم " نقطه" به تنهايي مدنظر است. در ضمن علامت "-" نيز خودداري مفهوم اصليش ميباشد.
علامت ? بدين مضنون استفاده ميشود که ميتوان يک يا هيچکدام از کارکترهاي قبلي را مورد استفاده قرار داد.
بعد از علامت ( يا پرانتز بسته, انتهاي گروه باز شده را مشخص ميکند.
سپس علامت * بدين مفهوم است که ميتوان از موارد ذکر شده در گروه قبل ( داخل پرانتز) هم استفاده کرد و يا آنها را اصلا بکار نبرد, پس با توجه به مطالب گذشته, از آنجايي که کلمه "dort" يک پيشوند email معتبر هست, عبارت "testing-testing" نيز ميتواند يک پيشوند email معتبر به حساب آيد.
علامت @ مابين آدرس email و نام domain مربوطه قرار ميگيرد.
استفاده مجدد از +W\, بدليل آنست که نام domain بايستي با يکي از کارکترهاي a تا z ,س A تا Z,س 0 تا 9 ويا خط فاصله شروع گردد.
مجددا عبارت ( + w \ ? [ - . \ ] ) استفاده شده که وجود "." يا "-" را در قسمت پسوند email مجاز ميشمارد.
سپس گروه داخل پرانتز {2,3}w\.\ قرار گرفته شده که از وجود يک نقطه به همراه چند کارکتر خبر مي دهد. {2,3} نيز مقدار 2 يا 3 کارتر قبلي مي باشد.
سپس منظور از علامت +, وجود تعداد دفعات جزء تعداد دفعات جزء قبلي را ميان ميکند. مثلا پسوند نهايي ميتوان بصورت "Com" , ".edu" , "Ox.ac.uk" باشد.
نهايتا با قرار دادن علامت $ رشته حرفي پايان يافته و از قرار دادن موارد نامناسب ديگر توسط کاربر جلوگيري کند.

if(re.test(myForm.emailAddr.value)) {

2.
با استفاده از دستور test()s اعتبار myForm.emailAddr.value بررسي ميشود که در صورت قرار گرفتن نمونه اي نادرست, پيغام اشتباه همراه با اخطار نمايان شده و در غير آن که يک متغيير معتبر است (آدرس email درست نوشته شده باشد) پيغامي نميگردد.
**تذکر
  • جهت آشنايي با کارکترهاي خاص معادلات قاعده اي روي متن فوق کليک نماييد.

<html>
<head>

<SCRIPT language="Javascript" type="text/javascript">
re=/^\w+([\.-]?\w+)*@\w+([\.-]?\w+)*(\.\w{2,3})+$/

function SubmitIt(myForm) {
if(re.test(myForm.emailAddr.value)) {
return true
}

alert("Invalid email address")
myForm.emailAddr.focus()
myForm.emailAddr.select()
return false
}

</SCRIPT>

</head>
<body>
<h2>
<form onSubmit="return SubmitIt(this)" action="ok.asp">
Email:<br>
<input name="emailAddr" type="text" size="30">
<br>
<input type="Submit" value="Submit">
</form></h2>
</body>
</html>


javascript - -

اصول طراحي صفحات وب

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: اصول طراحي

اين مقاله تاکنون 23081 بار خوانده شده است

در اين مبحث, بعلت درخواست مکرر دوستان در مورد چگونه آغاز کردن ساخت يک وب سايت, جدا از مباحث نرم افزاري شما نياز به يکسري آگاهي در مورد خصوصيات خاص صفحه هات اينترنتي داريد که در زير به اختصار در مورد آن توضيح ميدهيم.

طراحي صنعتي

چگونه يك مشتري جنس مورد نظر خود را شناسايي و رديابي ميكند، و احتمالا پيشنهادات خوبي را براي فروش بر روي صفحه وب ارائه ميدهد؟ اين مبارزه طلبي طراحي صفحات تجاري وب ميباشد
بيشترين توليد كنندگان صنعتي با جديت به سمت مشتريانشان جهت گيري كرده و صفحات طراحي شده براي كمپانيهاي صنعتي، ميبايست تعصبات مشتري گرايانه قوي داشته باشند.
گرايش به مشتري در روشي كه صفحات صنعتي، مشتري را چه از لحاظ تصويري و چه از لحاظ تعاملي درگير ميكنند، ديده ميشود. صفحات صنعتي غالبا معموليتر از صفحات ديگر به نظر ميدهند.
صفحات صنعتي در كل داراي سه عنصر ميباشند
خصوصيات محصول: هر مشتري ميبايست بتواند يك محصول خاص را از ميان مجموعه اي از محصولات مشخص كند. اين كار ميتواند به صورت تصويري، با استفاده از يك ليست انتخابي يا با استفاده از يك برنامه جستجو انجام شود.

مشخصات محصول: بيشتر محصولات صنعتي همراه با اطلاعاتي عرضه ميشوند كه صفحه مشخصات ناميده ميشود يك صفحه مشخصات تركيبي از متن، تصوير و توصيفاتي در مورد كارايي محصول در يك ورق كاغذ ميباشد. خصوصيات كارايي يا تصوير توصيف كننده ساختار كالا، اغلب عامل فروش يك محصول ميباشند.
البته با توجه به قابليتهاي وب، ايجاد صفحه مشخصات كالا در وب به روش سنتي، محدود كننده به نظر ميرسد. مشخصات كارايي كالا ميتواند به صورت سه بعدي و همراه با حركت ايجاد شود، همچنين خود محصول در حال انجام عمل، قابل نمايش باشد.

ارتباط با مشتري: ‏‏‏كارتهاي جالبي را كه در آنها از شما سئوال ميشود «آيا مايليد كه نمايندگي سرويسهاي مشتري در مورد كالايي خاص با شما تماس بگيرد؟» را بخاطر بياوريد. با استفاده از وب سئوالات تقريبا پس از پرسيده شدن جواب داده خواهند شد.

طراحي صفحات خرده فروشي

صفحات خرده فروشي كاملا با صفحات صنعتي متفاوت است چرا كه در مورد محصولات خرده فروشي، انتقال اطلاعات تكنيكي چندان مورد توجه نميباشد. بهر حال چيزي كه در اين نوع صفحات داراي اهميت بسيار است، تطابق تصاوير با اصل ميباشد.

در اين نوع طراحي بايد مسائل زير را در نظر گرفت:
خصوصيات تصويري و سازماني فروشندگي خرده فروشيهاي موفق چيست؟
اجزا ساختاري خرده فروشي چيست؟
از چه خصوصيات وب ميتوان به گونه اي موثر در طراحي صفحات خرده فروشي سود جست؟

صفحات تجاري

صفحاتي كه براي مخاطبين تجاري طراحي ميشوند با صفحات خرده فروشي و صنعتي تفاوت دارند. به خاطر داشته باشيد كه هر شركت داراي زندگي و يك شخصيت وجودي در زمينه محصولات ويژه يا عمليات فروش خاصي ميباشد. يك شركت تلاش زيادي را صرف به تصوير كشيدن يك نماي حساب شده از خود ميكند. اين تلاش ممكن است شامل اسم،ارم شركت،رسم الخطي كه در مكاتبات شركت استفاده ميشود. رنگهاي مورد استفاده و اينكه دقيقا چه اسامي براي معرفي محصولاتشان ميكنند، باشد.
يك صفحه تجاري ميبايست منعكس كننده فرهنگ ان شركت باشد. اين بدان معني است كه صفحات وب يك بانك، اساسا با صفحات وب يك توليد كننده اسباب بازي متفاوت است.

قطعات اصلي پازل صفحه وب تجاري شامل اجزا زير ميباشد
نام شركت رسما چگونه استفاده ميشود؟ ايا به طور كامل نوشته ميشود يا مخفف؟ ايا نام، يك نام تجاري ثبت شده است؟
ايا نام شركت تحت قانون حق تكثير ميباشد؟
ايا نام شركت همان آرم شركت است. يا يك طرح گرافيكي جداگانه ميباشد؟ اندازه، مكان و جهت رسمي ان چگونه است؟
ايا يك ارم تجاري يا يك نشان سازماني است؟
ايا اسامي محصولات، اسامي تجاري طراحي شده به شكل خاص ميباشند؟
ايا اين نوع اسامي با قلم،وزن و تاكيد متفاوتي نمايش داده ميشوند؟
آيا رسم الخط رسمي، براي بدنه اصلي مكاتبات وجود دارد؟
ايا متن ترازبندي شده است يا داراي برامدگي و فرورفتگي است؟
آيا اصلا رنگهاي رسمي براي شركت وجود دارد؟
ايا يك سلسله مراتب براي مكاتبات در شركت وجود دارد؟
شما چگونه ميتوانيد سئوالات و تقاضاهايتان را به قسمتهاي مختلف ابلاغ كنيد؟

موسسات آموزشي

موسسات آموزشي داراي اولين و بيشترين نشريات وب ميباشند و همگي با مشگل ساختاري يكساني مواجهند. كالجها و دانشگاهها، بيش از حد معمول ساخت يافته اند يا به عبارتي قسمت بندي شده به بخشهاي مختلف ميباشند، بنابراين صفحات وب ميبايست حس مجازي تصويري از ارتباطات ساختاري داخل يك موسسه ارائه دهند بگونه اي كه حس قدم زدن در آن موسسه در بيننده القا شود.

جنبه يكسان صفحات آموزشي، ترتيب عمليات داخل موسسات ميباشد. اين مسئله در تضاد كامل با صفحات توليد كنندگان و فروشندگان جز ميباشد. ترمهاي مدارس هميشه مدت ثابتي دارند. تاريخ شروع و خاتمه از قبل دقيقا مشخص شده اند تقاضانامه و عمليات ورود به موسسه همگي استاندارد شده ميباشند. گذراندن كل دوره تحصيلي اجباري است و معمولا ميبايست تحت مجموعه اي از مراحل مشخص گذرانده شوند. كارنامها مقدار پيشرفت محصل را مشخص ميكنند. دانش اموزان براساس پيشرفتشان طبقه بندي ميشوند، در حقيقت بر اساس وضعيت قبولي هر مقطع طبقه بندي ميشوند، اين صفحات به دليل كمبود آزادي عمل طراح، جز مشگل ترين صفحات از لحاظ طراحي ميباشد

صفحات مربوط به سرگرمي

در مقابل صفحات تجاري، صفحات مربوط به سرگرميها قرار دارند. درست است كه در اينجا هم ممكن است برخي محدوديتهاي تجاري اعمال شوند(سوني، ديسني و غيره )ولي اين صفحات در معموليترين و مورد قبولترين شكلشان داراي كمترين محدوديتهاي طراحي بوده و آزادي عمل زيادي براي طراح وجود دارد. مشتريان سرگرميها اغلب جز بي ثباترين و مشگلترين مشتريان براي شناسايي و رديابي ميباشند. موضوعي كه در سال گذشته مورد توجه ترين موضوعات بوده ممكن است ديگر موردتوجه نباشد.

صفحات وب سرگرمي داراي خصوصيات زير ميباشد؛
كمترين ساختارو عمل-عكس العمل بيشتر
اعتماد بيشتر به تصوير نسبت به اطلاعات نوشتاري
استفاده بيشتر از منابعي كه مشتريان بالقوه اين نوع صفحات وب مجبور به يادگيري آن هستند.
انجام محاسبات سطح بالا به منظور بهبود سرعت پردازنده، عمق نمايش و پهناي باند شبكه.
حداقل در حال حاضر، كمبود مهمي كه در مورد صفحات سرگرمي وجود دارد تفاوت كلي بين شمايل صفحات وب با شكل واقعي سرگرمي واقعي مورد توجهشان مثل فيلم، كتاب، بازي، ضبط صوت، كنسرت و نمايش زنده و چيزهاي ديگر را با صفحات وب مقايسه كنند، به سادگي به عدم واقعگرايي صفحات وب نسبت به رسانه اصلي پي ميبرند. براي موفقيت صفحات سرگرمي وب
يا بايد واقعگرايانه صفحات وب با وسايل موجود در زندگي منطق شود و يا صفحات سرگرمي وبي طراحي شود كه هيچ مرجعي در
دنياي واقعي براي مقايسه نداشته باشند


javascript - -

کارکترهاي خاص معادلات قاعده اي

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: فرم ها و معادلات قاعده اي

اين مقاله تاکنون 6071 بار خوانده شده است

در اين قسمت با کارکترهاي خاص مورد استفاده در اسکريپتهاي قاعده اي آشنا خواهيد شد.
به کارکتر بعد از خود, مفهومي حرفي و يا مفهومي خاص ميدهد, مثلا در W\ مقصد, ارزشي خاص W بوده ولي در $\ ارزش خاص علامت $ که در زير ذکر شده را صرفنظر نموده است. | \
شروع رشته (String) | ^
پايان رشته | $
صفر يا چند مرتبه | *
يک يا چند مرتبه | +
صفر يا يک مرتبه | ?
هر کارکتر بجز خط جديد | .
محدوديت لغتي | \b
عدم محدوديت لغتي | \B
ارقام بين 0 تا 9 | \d
محدوديت استفاده از ارقام | \D
فرم | \F
خط جديد | \A
بازگشت | \r
هر يک از کارکترهاي White space | \s
هيچ يک از کارکترهاي White space | \S
Tab | \t
Tab عمودي | \v
هر حرف, يا Underline | \w
هر کارکتر غير از حرف, عدد يا Underline | \W
کارکترهاي ASCII که با اعداد هگزادسيمال nn مشخص ميشوند | \xnn
کارکترهاي ASCII گخ با اعداد اکتال nn مشخص ميشوند | \onn
کارکتر کنترل X | \cX
مجموعه کارکترهاي که با هر يک از کارکترهاي داخل براکت مطابقت داشته باشد | [abcde]
مجموعه کارکترهاي که با هر يک از کارکترهاي داخل براکت مطابقت نداشته باشد | [^abcde]
مجموعه کارکترهاي که با هر يک از کارکترهاي داخل براکت مطابقت دارد | [a-e]
کارکترهاي حرفيb\ | [\b]
دقيقا n اتفاق از کارکتر قبلي | {n}
حداقل اتفاق از کارکتر قبلي | {n , }
بين n و m اتفاق از کارکتر قبلي | {n , m}
گروه سازي براي استفاده در آينده | ()
يا x يا y | X|Y


javascript - -

قرار دادن تاريخ فعلي بر روي صفحه وب

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9739 بار خوانده شده است

توسط JavaScript ميتوان با استفاده از زمان و تاريخ کامپيوتر کاربر کارهاي بسيار انجام داد. در اين مبحث تاريخ عددي بوسيله اسکريپت به تاريخ حرفي تبديل ميشود. اسکريپت فوق که شامل در اسکريپت در قسمت Head و Body صفحه ميباشد, نحوه دريافت تاريخ فعلي, تبديل آن از عدد به تاريخ استاندارد و سپس نوشتن نتيجه مذکور در مکان مشخص شده را توضيح ميدهد.
براي قرار دادن تاريخ فعلي بر روي صفحه وب
dayName = new Array ("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday") | 1.
ابتدا يک آرايه با اجزاي روزهاي هفته ايجاد ميشود. به ياد داشته باشيد که مابين روزهاي هفته حتما قرار بگيرد و سپس آرايه درون متغييري بنام dayName قرار ميگيرد. |
monName = new Array ("January","February","March","April","May","June","July","Auguest","September","October","November", "December") | 2.
در اين مرحله مانند مرحله قبل, آرايه اي براي نام روزهاي ماههاي سال ايجاد ميشود. |
now = new Date | 3.
آخرين کاري که در اولين اسکريپت بايستي انجام دهيد, ايجاد يک متغيير تاريخ با دستور newDate ميباشد. بدين صورت javascript يک Object تاريخ جديد ايجاد کرده و تاريخ فعلي را درون آن قرار ميدهد. |
document.write("<h3>Today is " + dayName[now.getDay()] + ", " + monName[now.getMonth()] + " " + now.getDate() + ".</h3>") | 4.
در اين اسکريپت قسمت Body که شامل يک خط ميباشد نتيجه مستقيما روي صفحه نوشته ميشود. دستور document.write عبارت مورد نظر را درون يک پرانتز قرار داده و آن را در پنجره صفحه مورد نظر مي نويسد. همانطور که از Html بخاطر داريد تگ <h3> براي استفاده در تيترنويسي با سايز 3 ميباشد. به دنبال آن رشته حرفي "Today is" و علامت + قرار گرفته که منظور از اين علامت, اضافه کردن محتويات بعدي به قسمت قبل ميباشد. عبارت dayName[now.getDay()]s از سمت راست به چپ خوانده ميشود. دستور getDay()s روز هفته را دريافت کرده و با اضافه کردن now, عدد روز امروز را به خود اختصاص داده که نتيجه عددي آن با توجه به اجزاي آرايه dayName در مرحله اول, روز مربوطه را مشخص ميکند. سپس بعد از قرار دادن علامت + عبارت monName[now.getMonth()]s نوشته شده که همانند قسمت قبل, نام ماه را بر اساس آرايه monName مشخص ميکند. بعد از قرار دادن يک فاصله درون گيومه, now.getDay()s نوشته شده که تاريخ ماه را نشان ميدهد. در نهايت يک نقطه قرار داده و تگ <h3> بسته ميشود. |

<html>
<head>
<script language="javascript" type="text/javascript">
dayName = new Array ("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday")
monName = new Array ("January","February","March","April","May","June","July","Auguest","September","October","November","December")

now = new Date
</script>
</head>
<body>
<script language="javascript" type="text/javascript">
document.write("<h3>Today is " + dayName[now.getDay()] + ", " + monName[now.getMonth()] + " " + now.getDate() + ".</h3>")
</script>
</body>
</html>


javascript - -

بازي با روزها

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 8098 بار خوانده شده است

ممکن است بخواهيد در مواقع و زوهاي خاص سال مثلا آخر هفته, پيغامي خاص به کاربر ارائه دهيد.
براي فهميدن آخر هفته

now = new Date

1.
تاريخ فعلي به متغيير now اختصاص مي يابد.

if (now.getDay() > 0 && now.getDay() <6) {

2.
توجه داشته باشيد که کد يکشنبه, عدد صفر ميباشد. منظور از عملگر &&, and منطقي بوده که بايستي در نتيجه هر دو قسمت درست باشند.

document.write("Sorry, it's a weekday.")

3.
اگر نتيجه مرحله قبل بزرگتر از صفر و کوچکتر از 6 بود, پيغام مورد نظر به نمايش در خواهد آمد.

else {
document.write("Hooray, it's weekend!")

4.
در صورتيکه حالت شرطي مرحله قبل, نادرست باشد, اين مرحله اجرا ميشود.

<html>
<head>
</head>
<body>
<h2>
<script language="javascript" type="text/javascript">
now = new Date
if (now.getDay() > 0 && now.getDay() <6) {
document.write("Sorry, it's a weekday.")
}
else {
document.write("Hooray, it's weekend!")
}
</script>
</h2>
</body>
</html>


javascript - -

ارائه يک پيغام براي زماني از روز

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 7907 بار خوانده شده است

با توجه به تکنيک ارائه شده در مقاله قبل, ميتوان يک پيغام نيز در زمان خاصي از روز نمايش داد.
براي ارائه يک پيغام در زماني از روز
now = new Date if (now.getHours() < 5) { | 1.
تاريخ (Date) جديد به متغيير now اختصاص داده ميشود. سپس با استفاده از getHours()s ساعت را از متغيير now دريافت کرده و اگر عدد کمتر از 5(منظور 5 صيح ميباشد.) باشد به مرحله بعد ميرود. |
document.write("What are you doing up so later?") | 2.
در اين مرحله, عبارت يا پيغام خاصي تعريف شده که در صورت گذراندن مرحله 1 اين پيام در پنجره کاربر نشان داده ميشود. بغيه اسکريپت در مورد پيغامهاي ديگر در ساعات مختلف روز ميباشد. |

<html>
<head>
</head>
<body>
<h2>
<script language="javascript" type="text/javascript">
now = new Date
if (now.getHours() < 5) {
document.write("What are you doing up so later?")
}
else if (now.getHours() < 9) {
document.write("Good Morning!")
}
else if (now.getHours() < 17) {
document.write("No surfing during working hours!")
}
else {
document.write("Good Evening!")
}
</script>
</h2>
</body>
</html>


javascript - -

نوشتن متن درون سند on the fly

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 8468 بار خوانده شده است

قابليت نوشتن اطلاعات بر روي يک صفحه وب در پي پاسخ به عمل کاربر, يکي از راههاي مفيد در ديناميک کردن صفحه بوده و در ضمن از اين طريق کلا ميتوان کاربردهاي گوناگون پيدا نمود.
براي نوشتن متون بصورت on the fly

dayInfo = new Array
dayInfo[2] = "Dad's Birthday"
dayInfo[5] = "Rehearsal Dinner"
dayInfo[6] = "Wedding Day"

1.
خطوط موجود در اسکريپت فوق را درقسمت head بنويسد.

function showInfo(thisDay) {
document.calendar.dateInfo.value = dayInfo[thisDay]
}

2.
توسط تابع ShowInfo, متن مورد نظر گرفته شده و از آن اطلاعات مربوطه به رخداد از آرايه dayInfo نيز تهيه شده و آن را در text area بنام dateInfo قرار ميدهد.

<html>
<head>

<script language="javascript" type="text/javascript">
dayInfo = new Array
dayInfo[2] = "Dad's Birthday"
dayInfo[5] = "Rehearsal Dinner"
dayInfo[6] = "Wedding Day"
function showInfo(thisDay) {
document.calendar.dateInfo.value = dayInfo[thisDay]
}
</script>

</head>
<body>
<a href="javascript:showInfo(2)">1</a>
<br>
<a href="javascript:showInfo(5)">5</a>
<br>
<a href="javascript:showInfo(6)">6</a>
<p>
<form name="calendar">
<input name="dateInfo" size="20">
</form>
</body>
</html>


javascript - -

onUnLoad Event

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

اين مقاله تاکنون 6782 بار خوانده شده است

در هنگام ترک يک صفحه وب, کنترل کننده onUnLoad فعال ميشود. به علت عدم محبوبيت اين نوع پنجره ها, بهتر است که کنترل کننده فوق الذکر در کمترين حالت استفاده شود. اسکريپت فوق نحوه ايجاد پيغام خداحافظي درهنگام ترک سايت با استفاده از کنترل کننده onUnLoad را نشان ميدهد.
براي ايجاد onUnLoad

onUnload="alert('thanks for visiting, and come back soon!')"

با قرار دادن کنترل کننده فوق درتگ body, هنگام ترک سايت پيغام مذکور به نمايش در خواهد آمد.

<html>
<head>
</head>

<body onUnload="alert('thanks for visiting, and come back soon!')">

<h2>IranJavaScript</h2>

</body>
</html>


javascript - -

onResize Event

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

اين مقاله تاکنون 6057 بار خوانده شده است

از آنجايي که درنسخه 4 برنامه Netscape, هنگام تغيير اندازه پنجره يک bug معروف وجود داشته بنابراين بايستي بعد از تغيير اندازه صفحه, محتويات درون پنجره را مجددا Load نمود.
براي اجراي onResize Event
if(document.layers) { | 1.
همانطور که ذکر شد اين اسکريپت فقط براي Netscape 4 نياز ميباشد. به ياد داشته باشيد که document.layers نيز يکي از Object هايي بوده که تنها در اين browser وجود دارد. |
origWidth = window.innerWidth origHeight = window.innerHeight | 2.
در صورتيکه کاربر در Netscape 4 باشد, ايتدا ابعاد پنجره اصلي (Orginal) را براي استفاده آينده نگهداري ميکند. |
function resizeFix() { | 3.
در اين قسمت عمل resize تحت کنترل قرار ميگيرد. |
if(document.layers) { | 4.
مجددا براي کسب اطمينان, وجود Netscape 4 بررسي ميشود. |
if(window.innerWidth != origWidth || window.innerHeight != origHeight) { | 5.
در صورتيکه يا اندازه طول و يا عرض پنجره تغيير کرده باشد آماده انجام عمل بارگذاري مجدد محتويات صفحه در مرحله بعد خواهد شد و در غير اين صورت عملي صورت نميگيرد. |
window.location.reload() | 6.
در صورتيکه ابعاد صفحه پنجره تغيير کرده باشد, محتويات درون صفحه مجددا بارگذاري ميشوند. |
onResize="resizeFix()" | 7.
در اين قسمت پس از تغيير در ابعاد پنجره, تابع resizeFix فراخوانده ميشود. |

<html>
<head>

<script language="javascript" type="text/javascript">
if(document.layers) {
origWidth = window.innerWidth
origHeight = window.innerHeight
}

function resizeFix() {
if(document.layers) {
if(window.innerWidth != origWidth || window.innerHeight != origHeight) {
window.location.reload()
}
}
}

</script>
</head>
<body onResize="resizeFix()">

<h2>IranJavaScript.com</h2>

</body>
</html>


javascript - -

OnMousedown Event

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

اين مقاله تاکنون 7957 بار خوانده شده است

يکي از سوالهايي که بطور فراوان, توسط اکثر کاربران پرسيده ميشود, نحوه و چگونگي پنهان کردن اصل محتوي اسکريپت بکار گرفته شده در صفحه است. اما پاسخ آنها بطور خيلي ساده, "غير ممکن" ميباشد. يعني کاربر با اندکي تجربه و تشخيص ميتواند مفهوم کدهاي اسکريپت را دريابد.
ولي در صورتيکه بخواهيد از جستجوگران که سطح معلومات متوسطي دارند, اسکريپت را اندکي غير قابل دسترسي نماييد, آنگاه اسکريپت فوق, چگونگي کد لازم را به شما توضيح ميدهد. بدين صورت کاربر نميتواند با انجام کليک راست بر روي صفحه از منوي Shortcut براي مشاهده Source برنامه استفاده کند.
براي غير فعال کردن دکمه سمت راست موس

if(document.layers) {
document.captureEvents(Event.MOUSEDOWN)
}

1.
در صورتيکه کاربر داراي Netscape 4 باشد, آنگاه به browser, استفاده از Capture Events را براي کنترل Mousedown اعلام ميکند.

document.onmousedown = captureMousedown

2.
براي تمامي browserها از تابع captureMousedown براي حالت onmousedown استفاده ميشود. توجه کنيد در اين مرحله, کنترل کننده event, (CaptureMousedown) داراي پرانتز نميباشد. در صورتيکه وجود پرانتز از اساس کنترل کننده event بوده ولي در جاوااسکريپت ميتوان از آن صرفنظر نمود.

function captureMousedown(evt) {

3.
تابع مورد نياز براي کنترل Mousedown در اين مرحله شروع ميشود. پارامتر evt نيز توسط Netscape, بطور اتوماتيک در هنگام اجراي event, که شامل اطلاعات در مورد event مربوطه است را ارسال ميکند.

if(evt) {
mouseClick = evt.which

4.
در صورت استفاده از Netscape, متغير evt وجود داشته, در اين صورت انتخاب کليد ماوس توسط کاربر مشخص ميشود.

else {
mouseClick = window.event.button
}

5.
ولي در صورتيکه که کاربر از IE استفاده کند, نتيجه عملها در متغيير mouseClick ذخيره ميشود.

if(mouseClick == 1 || mouseClick == 2 || mouseClick == 3) {
alert("Mouse Disabled")
return false
}

6.
در صورتيکه کليک ماوس مربوط به يکي از دکمه 1,2,3 آن باشد يک پيغام اخطار نمايان ميگردد که نشاندهنده عدم قابليت تابع نويسي ميباشد. در نتيجه false را برگردانده و بدين وسيله, پنجره منو از ناپديد شدن در امان مي ماند.

<html>
<head>
<script language="javascript" type="text/javascript">
if(document.layers) {
document.captureEvents(Event.MOUSEDOWN)
}
document.onmousedown = captureMousedown

function captureMousedown(evt) {
if(evt) {
mouseClick = evt.which
}
else {
mouseClick = window.event.button
}

if(mouseClick == 1 || mouseClick == 2 || mouseClick == 3) {
alert("Mouse Disabled")
return false
}
}
</script>
</head>
<body>
<h2>IranJavaScript.com</h2>
</body>
</html>


javascript - -

onDbclick Event

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

اين مقاله تاکنون 6971 بار خوانده شده است

بدين طريق کاربر ميتواند با انجام عمل Double Click عمل خاصي را مشاهده خواهد کرد.
براي عمل onDbclick Event

onDblclick="newWindow(1)"

بدين صورت با دوبار کليک بر روي تصوير کوچک, تصوير بزرگ آن در پنجره جديد نمايش داده ميشود.

<html>
<head>
<script language="javascript" type="text/javascript">
function newWindow(imgNumber) {
imgName = "images/test" + imgNumber + ".gif"
imgWindow = window.open(imgName,"imgWin","width=320,height=240,scrollbars=no")
}
</script>
</head>
<body>
<h2>Double-click on an image to see the full-size version</h2>
<img src="images/test1.gif" border="2" onDblclick="newWindow(1)">
<img src="images/test2.gif" border="2" onDblclick="newWindow(2)">
<img src="images/test3.gif" border="2" onDblclick="newWindow(3)">

</body>
</html>


javascript - -

اسکريپتهاي CGI

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

مبحث: اصول طراحي

اين مقاله تاکنون 8960 بار خوانده شده است

بخاطر قدرت زياد و انعطاف پذيري, اسکريپت CGI طرفداران زيادي دارند. کاربر با ارسال يک فرم يا کليک کردن روي يک ابر پيوند درخواستي را براي اجراي يک CGI به سويServer ارسال ميکند. اين CGI بر رويServer اجرا شده و اطلاعات ارسالي را بررسي ميکند و براساس آن صفحه ديگري ايجاد مينمايد. اين صفحه ميتواند تجديدنظري از صفحه اول, يا يک صفحه کاملا جديد باشد.

CGI مخفف Common Gateway Interface ميباشد. استانداري است که روش ارتباط برقرار کردنServer وب به ساير برنامه ها را مشخص ميکند. اين برنامه ها ميتوانند صفحات وب جديدي ايجاد کرده و براي مرورگر ارسال نمايند. برنامهاي CGI معمولا براي پردازش و تجزيه و تحليل اطلاعات يک پرسشنامه که از سوي کاربر ارسال شده بکار ميروند.

CGI تواناييهاي زيادي به طراح صفحه وب ميبخشد. مثلا به کمک آن ميتوان بين صفحات و بانکهاي اطلاعاتي ارتباط برقرار کرد. همچنين ميتوان صفحات وب را به گونه اي طراحي کرد که براي هر نوع کاربر خاص ظاهر و محتواي متفاوتي داشته باشد.

اسکريپتهاي CGI عليرغم قدرتشان کند ميباشند. براي اجراي يک اسکريپت CGI مراحل زيادي بايد انجام شود. اطلاعات بايد دو بار بين مرورگر وServer منتقل شوند. بعلاوه, سرويگر بايد مدتي را صرف پردازش اطلاعات دريافتي از مرورگر نمايد. در واقع, اجراي يکCGI مانند درخواست يک صفحه جديد است. با اين تفاوت که زماني نيز بايد صرف اجراي آن CGI بر روي سريسگر شود.

اگر تنها يک کاربر بهServer متصل باشد, ميتوانيم زمان پردازش اسکريپت را نديده بگيريم, اما اگرServer مجبور به پاسخ به درخواستهاي متعدد و پردازشهاي مکرر باشد, اين زمان خود را بيشتر نشان ميدهد.

مسئله ديگر در هنگام کار با اسکريپتهاي CGI, مدت زماني است که براي ايجاد هر اسکريپت لازم است. ابتدا بايد برنامه کوچکي به يکي از زبانهاي رايج اسکريپت نويسي مثل PERL يا ASP نوشته شود, سپس با داده هاي مختلفي آزموده شده و براي اجرا بهServer ارسال گردد.

منبع: اينترنت


javascript - -

onFocus Event

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

اين مقاله تاکنون 6869 بار خوانده شده است

در صورتيکه بخواهيد در يک فيلد که اطلاعات مخصوص به نمايش در مي آيد, کاربر تغييراتي در آن اعمال نکند, ميتوان از ويژگي Readonly استفاده نمود ولي به ياد داشته باشيد که اکثر browserها ويژگي مذکور را پشتيباني نميکنند.اسکريپت فوق اين مشگل را برطرف خواهد کرد.
براي ثابت نگه داشتن اطلاعات يک فيلد
onFocus="this.blur()" | 1.
دستور فوق را در کنار input> کپي نماييد. |

<html>
<head>
</head>
<body>
<form>
Email address:
<input type="text" onFocus="this.blur()" value="info@iranjavascript.com" size="20">
<br>
</form>
</body>
</html>


javascript - -

معتبر سازي نام فايل

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: فرم ها و معادلات قاعده اي

اين مقاله تاکنون 7681 بار خوانده شده است

RegExpها داراي توانايي و قابليتهاي بيشماري ميباشند, بطوريکه يکي از قابليتهاي پر کاربرد آنها,معتبر سازي وروديهاي فيلدها در فرم صفحه وب ميباشد. اسکريپت فوق از کاربر انتظار دارد که آدرس تصوير را به شکل درستي تائپ کند (حتي پسوند فايل تصوير را حتما يا jpg ويا gif انتخاب نمايد).
براي معتبر نمودن يک آدرس:
re = /^(File\http):\/\/\s + \/\s+\.(gif\jpg) $/i | 1.
همانطور که در مباحث قبل اشاره گرديد, براي بررسي نمودن کل عبارت داخل فيلد از RegExp استفاده شده بطوريکه که با علامت ^/ شروع و با علامت / خاتمه يافته است. ورودي فيلد ميتواند با File يا با http شروع گردد, علامت بعدي بايستي "//:" باشد از آنجا که علامت / به منظور خاصي در معادله قاعده اي استفاده ميشود براي خنثي نمودن مفهوم آن علامت \ در قبل از علامت / به کار برده شده است. (\/\/) سپس +S/ را براي نوشتن هر کاراکتر غير white space به همراه علامت /\ که به منظور جدا کردن domain از نام فايل ميباشد, نوشته شده است. در مرحله بعد, +S\, مجددا براي نوشتن نام فايل ديگر, مورد استفاده قرار گرفته و بعلت نياز به نقطه و پسوند فايل gif يا jpg از عبارت (gif\jpg).\ استفاده شده است. در پايان از تصحيح کننده, i به منظور تايپ حروف بزرگ و کوچک و يا غير حساس بودن نسبت به آنها استفاده شده است. |

<html>
<head>
<script language="javascript" type="text/javascript">

re = /^(File\http):\/\/\s + \/\s+\.(gif\jpg) $/i

function SubmitIt(myForm) {
if(re.test(myForm.imgURL.value)) {
document.chgImg.src = myForm.imgURL.value
}
else {
alert ("Invalid URL")
myForm.imgURL.focus()
myForm.imgURL.select()
}
return false
}

</script>
</head>
<body>
<h2>
<form onSubmit="return SubmitIt(this)" action="ok.asp" name="myForm" >
<input type="file" name="imgURL" size="30">
<br>
<input type="Submit" value="Submit">
</form>
</h2>
</body>
</html>


javascript - -

ايجاد Cookie

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: Cookies

اين مقاله تاکنون 9089 بار خوانده شده است

Cookie يکسري رشته حرفي با فرمت مشخص ميباشد. يعني:

CookieName = CookieValue; expires = expirationDateGMT ; path = URLpath ; Domain = siteDomain

توضيح خطوط فوق از اين قرار است که اولين قسمت رشته حرفي به Cookie اسم و مقدار مربوطه را تخصيص داده که بايستي هميشه در ايجاد Cookie در نظر داشت. سپس تاريخ انقضاي Cookie توسط expiration Date تعيين ميشود که در فرمان تعيين شده فوق, browser بطور اتوماتيک, Cookie را پاک ميکند. سپس اجازه وجود يک URL داده شده و در نهايت آدرس domain در Cookie تنظيم ميگردد.
توجه داشته باشيد که ميتوان از چند Cookie درون يک صفحه استفاده نمود بدين منظور بعد از مشخصات هر قسمت, از علامت " ; " استفاده ميگردد.
براي ايجاد Cookie

expireDate = new Date

1.
ابتدا تاريخ فعلي گرفته شده و در متغيير expireDate نهاده ميشود.

expireDate.setMonth(expireDate.getMonth()+6)

2.
بدين صورت مقدار تاريخ اعتبار Cookie مورد نظر, 6 ماه تعيين ميگردد.

userName = ""

3.
سپس متغيير userName با مقدار خالي تعريف ميگردد.

userName = document.cookie.split("=")[1]

4.
ابتدا خالي نبودن محتوي Cookie بررسي ميشود. سپس توسط متد ("=")split, هر record مربوط به Cookie به فيلدهاي مختلف تقسيم ميشود بطوريکه مثلاCookieField[0]s نام وCookieField[1]s مقدار Cookie ميباشد.

function setCookie() {
userName = document.myForm.nameField.value

5.
در اين مرحله يک تابع جديد با نامsetCookie()s ايجاد شده, سپس در خط بعد مقدار UserName توسط اطلاعات وارد شده کاربر درون فيلد فرم, مجددا نوشته ميشود.

document.cookie = "username=" + username + ";expires=" + expireDate.toGMTString()

6.
همانطور که در مطالب قبل ذکر شد, Cookie ها شامل رشته هاي حرفي ساده ميباشد, در نتيجه توسط document.cookie, نام کاربر و تاريخ انقضاء نوشته شده زيرا توسط متد toGMTString, تاريخ expireDate به رشته حرفي تبديل شده, که نتيجتا ميتوان آن را درون Cookie قرار داد.

onLoad="document.myForm.nameField.value=userName"

7.
دستور onLoad در تگ body, نام کاربر را در صورت وجود در فايل Cookie درون فيلد name مينويسد.

<input readonly type="text" name="nameField" onBlur="setCookie()" size="40">

8.
نهايتا هنگام رهايي کاربر از فيلد متن, توسط کنترل کننده onBlur, تابع setCookie فرا خوانده ميشود.
**نکته
  • در اين اسکريپت فرض ميشود User name در Cookie وجود داشته است. در مباحث بعدي, نحوه کنترل چندين Cookie نيز توضيح داده ميشود.

<html>
<head>
<script language="javascript" type="text/javascript">
expireDate = new Date
expireDate.setMonth(expireDate.getMonth()+6)

userName = ""
if (document.cookie !="") {
userName = document.cookie.split("=")[1]
}

function setCookie() {
userName = document.myForm.nameField.value
document.cookie = "username=" + username + ";expires=" + expireDate.toGMTString()
}
</script>
</head>
<body onLoad="document.myForm.nameField.value=userName">
</p>
<h2>
Cookies:
</h2>
<form name="myForm">
<input readonly type="text" name="nameField" onBlur="setCookie()" size="40">

</form>
</body>
</html>


javascript - -

خواندن Cookie

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: Cookies

اين مقاله تاکنون 8240 بار خوانده شده است

بعد از تنظيم Cookie بايستي از آن در موارد مفيد و گوناگون استفاده نمود.
براي خواندن Cookie

if(document.cookie !="") {

1.
درصورت خالي نبودن محتويات Cookie به مرحله بعد ميرود.

document.write("Hello, "+ document.cookie.split("=")[1])

2.
در صورتي که Cookie خالي نباشد, رشته حرفي "Hello" به همراه مقدار موجود در Cookie در صورت نمايش, ظاهر ميگردد.
**نکته
  • در صورتي که دقت کرده باشيد, به اين نکته پي خواهيد برد که Cookie خاصي انتخاب نشده است! زيرا هر Cookie تنها توسط Server, مخصوص که براي اولين بار درون آن نوشته شده, خوانده ميشود. يعني فقط ميتوانيد به Cookie هاي مربوط به خود دسترسي پيدا نماييد.

<html>
<head>
</head>
<body>
<h2>
<script language="javascript" type="text/javascript">
if(document.cookie !="") {
document.write("Hello, "+ document.cookie.split("=")[1])
}
</script>
</h2>
</body>
</html>


javascript - -

نمايش Cookieها

دستور چاپ

تاريخ نشر: يکشنبه 23 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: Cookies

اين مقاله تاکنون 10179 بار خوانده شده است

در مبحث قبل, مقدار يک Cookie از Server خوانده شد. در اين قسمت, نحوه خواندن تمام Cookieها از Server و نمايش نام و مقاديرشان را فرا ميگيرد. بطوريکه اگر هيچ Cookie نباشد, پيغام "هيچ Cookie وجود ندارد" اعلام ميشود و در صورتيکه وجود داشته باشد. براي هر Cookie يک خط شامل اطلاعات آن نمايش داده ميشود.
به منظور نمايش Cookieها

if(document.cookie == "") {
document.write("There are no cookies here")

1.
در صورتيکه محتوي Cookieها خالي باشد, پيغام "There are no cookies here" نشان داده ميشود.

else {
thisCookie = document.cookie.split("; ")

2.
ولي در صورتيکه محتواي آن خالي نباشد, مقدار تمامي Cookieهاي موجود توسط document.cookie.split("; ")s گرفته شده و در متغييري بنام thisCookie قرار داده ميشود. به ياد داشته باشيد که توسط دستورsplit("; ")s آرايه اي از تمام Cookieها بوجود آمده تا درنهايت بتوان به مقدار هر Cookie ارجاعي داده شود.

for (i=0; i<thisCookie.length; i++) {

3.
در حلقه فوق, که شمارنده آن از صفر شروع ميشود, در صورتيکه i کمتر از تعداد Cookieها در آرايه thisCookie باشد به مقدار i, يک واحد مي افزايد.

document.write("Cookie name is"+thisCookie[i].split("=")[0])
document.write(",and the value is"+thisCookie[i].split("=")[1]+"<br>")

4.
و درصورت وجود Cookie در پنجره browser ابتدا عبارت "Cookie name is" و بعد نام Cookie و به دنبال آن, عبارت and the value is به همراه مقدار Cookie نوشته ميگردد.

<html>
<head>
</head>
<body>
<script language="javascript" type="text/javascript">
if(document.cookie == "") {
document.write("There are no cookies here")
}
else {
thisCookie = document.cookie.split("; ")
for (i=0; i<thisCookie.length; i++) {
document.write("Cookie name is"+thisCookie[i].split("=")[0])
document.write(",and the value is"+thisCookie[i].split("=")[1]+"<br>")
}
}
</script>

</body>
</html>


javascript - -

حرکت عکس بدنبال موس

دستور چاپ

تاريخ نشر: دوشنبه 24 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

دريافت نمونه برنامه بصورت zip (13k)

اين مقاله تاکنون 24293 بار خوانده شده است

برطبق درخواست مکرر دوستان مبني بر مجموعه دستوراتي که موجب حرکت يک عکس بدنبال موس گردد, اسکريپت فوق جهت استفاده ارائه ميگردد.
براي دريافت کامل برنامه با امکانات آن بر روي متن فوق کليک نماييد.

<HTML>
<HEAD>
<TITLE>Butterfree</TITLE>
<SCRIPT src="js/NNsprites.js"></SCRIPT>
</HEAD>
<DIV id=disclaimer style="WIDTH: 300px; POSITION: absolute; HEIGHT: 50px"> </DIV>
<DIV id=directional0 style="POSITION: absolute">
<IMG height=15 src="images/direction.gif" width=15>
</DIV>
<DIV id=sprite0 style="POSITION: absolute">
<IMG height=67 src="images/Butterfree.gif" width=75 name=sprite1>
</DIV>

<SCRIPT>
addSprite("Butterfree", 60, 60, 5, 3)
startAnimation()
</SCRIPT>

</HTML>


javascript - -

قرار دادن ساعت بر روی سايت

دستور چاپ

تاريخ نشر: دوشنبه 31 تير 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 13023 بار خوانده شده است

با استفاده از اين اسکريپت ميتوان ساعت را بر روی سايت بطور دايناميک به نمايش درآورد
اين مجموعه دستورات را ميتوان بعنوان يکی از بهترين اسکريپتهای موجود معرفی کرد.

<html>
<script language="JavaScript">

var clockID = 0;

function UpdateClock() {
if(clockID) {
clearTimeout(clockID);
clockID = 0;
}

var tDate = new Date();

document.theClock.theTime.value = ""
+ tDate.getHours() + ":"
+ tDate.getMinutes() + ":"
+ tDate.getSeconds();

clockID = setTimeout("UpdateClock()", 1000);
}
function StartClock() {
clockID = setTimeout("UpdateClock()", 500);
}

function KillClock() {
if(clockID) {
clearTimeout(clockID);
clockID = 0;
}
}

//-->

</script>
<body onload="StartClock()" onunload="KillClock()">
<center><form name="theClock">
<input type=text name="theTime" size=8>
</form></center>
</body>
</html>


javascript - -

نوشتن متن در قسمت

دستور چاپ

تاريخ نشر: جمعه 18 مرداد 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 10172 بار خوانده شده است

اين اسکريپت موجب خواهد شد که حروف يک کلمه ابتدا تک تک به نمايش درآيد سپس تکميل گردد. اين اسکريپت جزوء اولين اسکريپتهاي در اين زمينه ميباشد به مرور اسکريپتهايي با همين کاربرد ولي به گونه اي ديگر ارائه خواهد شد.

<html>
<body>
<script language="JavaScript">
<!--
// please keep these lines on when you copy the source
// made by: Amir - http://www.iranjavascript.com

var current = 0
var x = 0
var speed = 100
var speed2 = 4000

function initArray(n) {
this.length = n;
for (var i =1; i <= n; i++) {
this[i] = ' '
}
}

action = new initArray(4)
action[0]="This is Message 1"
action[1]="Now it is Message 2"
action[2]="No, do not say I have to do 3 messages"
action[3]="Yea, this message, 4, is the last message (and it's long)"

function action2() {
var m = action[current]

window.status = m.charAt(x++)

if (x == m.length + 1) {
x = 0
current++
window.status = m

if (current > action.length - 1) {
current = 0
}

setTimeout("action2()", speed2)
}

else {
setTimeout("action2()", speed)
}
}

action2()
//-->
</script>
<h2>IranJavaScript.com</h2>
</body>
</html>


javascript - -

ارجاع به صفحه مورد نظر بعد از زماني مشخص

دستور چاپ

تاريخ نشر: يکشنبه 13 مرداد 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9497 بار خوانده شده است

در اين اسکريپت ميتوانيد صفحه را بعد از مدت زمان خاصي Refresh نماييد و صفحه جديدي را بجاي صفحه کنوني بارگزاري نماييد. اسکريپت فوق بعد از 5 ثانيه شما را به صفحه ok.asp ارجاع خواهد داد, شما ميتوانيد اين زمان را تغيير داده و صفحه مورد نظر را نيز بجاي ok.asp صفحه مورد نظر خود را قرار دهيد.

<html>
<head>
</head>
<body>

<script language="Javascript">
<!--
// please keep these lines on when you copy the source
// made by: Amir - http://www.IranJavaScript.com

var URL = "ok.asp"
var speed = 5000

function reload() {
location = URL
}

setTimeout("reload()", speed);
//-->
</script>

Please wait 5 seconds,<br>
<br>
then you will be taken to another page.
</body>
</html>


javascript - -

تغيير bgcolor

دستور چاپ

تاريخ نشر: جمعه 18 مرداد 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9046 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد رنگ پس زمينه را بدلخواه خود تغيير دهيد.

<html>
<body>
<script language="Javascript">
<!--
// please keep these lines on when you copy the source
// made by: Amir - http://www.IranJavaScript.com

function backbs(clr) {
document.bgColor = clr
}

//-->
</script>
<form>
<input type="button" value="Aqua" onclick="backbs('aqua')">
<input type="button" value="Yellow" onclick="backbs('yellow')">
<input type="button" value="Khaki" onclick="backbs('khaki')">
<input type="button" value="White" onclick="backbs('white')">
<input type="button" value="Gray" onclick="backbs('gray')">
</form>
</script>
</body>
</html>


javascript - -

تاکيد يک مطلب

دستور چاپ

تاريخ نشر: دوشنبه 28 مرداد 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9790 بار خوانده شده است

ميتوانيد مطلب مورد نظر خود را در قسمت پايين Browser کاربر به دفعات به نمايش درآوريد.
اين کار پيشنهاد نميشود و فقط جهت آگاهی اعلام گرديده است.

<html>
<script language="JavaScript">
<!--
// please keep these lines on when you copy the source
// made by: Amir - http://www.iranjavascript.com

var x = 0
var speed = 200
var text = "Welcome to IranJavaScript.com."

function Blinky() {
window.status = text
setTimeout("Blinky2()", speed)
}

function Blinky2() {
window.status = " "
setTimeout("Blinky()", speed)
}

Blinky()
//-->
</script>
<body>
<h2>IranJavaScript.com</h2>
</body>
</html>


javascript - -

چرخش سايه متن

دستور چاپ

تاريخ نشر: شنبه 13 مهر 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 11570 بار خوانده شده است

در IE يکسري داده غير استاندارد بنام Filler وجود دارد که به javascript قابليت تغيير و اصلاح objectها را ميدهد. اسکريپت مورد بحث نحوه استفاده از فيلتر drop shadow براي تغيير ظاهر متن (بنام dropShadow) را نشان ميدهد.

بمنظور چرخش سايه متن

1.

function doShadow(newDiretction){

ابتدا تابعي با نام doShadow و متغيير newDirection ايجاد ميشود. متغيير, مربوط به جهت فعلي سايه ميباشد.
2.

if (document.all && newDiretction < 360) {

درصورتيکه کاربر از IE استفاده کند و همچينين مقدار متغيير newDirection کمتر از 360 درجه باشد به مرحله يعد ميرود.
3.

newDiretction += 10
document.all.dropText.style.filter="shadow(direction=" + newDiretction + ")"

به متغيير newDirection,س10 درجه به منظور تعيين مکان بعدي سايه, اضافه ميشود. سپس فيلتر با خصوصيات جديد سايه تنظيم ميگردد.

<html>

<head>
<title>New Page 1</title>
<script type = "TEXT/JAVASCRIPT" LANGUAGE = "JAVASCRIPT">
function doShadow(newDiretction){
if (document.all && newDiretction < 360) {
newDiretction += 10
document.all.dropText.style.filter="shadow(direction=" + newDiretction + ")"
setTimeout("doShadow(" + newDiretction + ")" , 100)
}
}
</script>

<STYLE TYPE="TEXT/CSS">
#dropText {width: 500px; height: 100px; font-size: 36px; filter: shadow(direction=90)}
</STYLE>
</head>
<body>
<DIV ID="dropText">
IranJavaScript.com
</DIV>

</body>

</html>


javascript - -

نمایش منو با یک کلیک

توسط: ناصر نايب

دستور چاپ

تاريخ نشر: يکشنبه 3 آذر 1381

دريافت نمونه برنامه بصورت js (5k)

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 12509 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد منوي مورد نظر خود را با يک کليک به نمايش درآوريد.
به راحتي ميتوانيد مطلب خود را جايگزين منوهاي ارائه در مثال قرار دهيد.

<html>
<head>
<title>First menu</title>
<style>
.curhand{cursor:hand}
</style>
<script language="javascript">

function displayit(paragraph,title,imgmenu){
if (document.all[paragraph].style.display=='none')
{document.all[paragraph].style.display="block";
document.all[imgmenu].src="arrow_u2.jpg"}
else {document.all[paragraph].style.display="none";
document.all[imgmenu].src="arrow_d2.jpg"}
}

function setoverstyles(paragraph,imgmenu,title){
if (document.all[paragraph].style.display=='none')
{document.all[imgmenu].src="arrow_d2.jpg";
document.all[title].style.textDecorationUnderline='true'}
else {document.all[imgmenu].src="arrow_u2.jpg";
document.all[title].style.textDecorationUnderline='true'}
}

function setoutstyles(paragraph,imgmenu,title){
if (document.all[paragraph].style.display=='none')
{document.all[title].style.textDecoration='none';
document.all[imgmenu].src="arrow_d1.jpg"}
else {document.all[imgmenu].src="arrow_u1.jpg";
document.all[title].style.textDecoration='none'}
}

sw=0;
function displayall(){
if (sw==0) {swall.innerText="Hide all";document.all['x'].style.display='block';sw=1;
for (i=1;i<=5;i++)
{ xmenu='menu'+i ; ximg='imgmenu'+i ;
if (document.all[xmenu].style.display=='none')
{document.all[xmenu].style.display="block";document.all[ximg].src="arrow_u1.jpg"}}}

else {swall.innerText="Show all";document.all['x'].style.display='none';sw=0;
for (i=1;i<=5;i++)
{xmenu='menu'+i;ximg='imgmenu'+i;
if (document.all[xmenu].style.display=='block')
{document.all[xmenu].style.display="none";document.all[ximg].src="arrow_d1.jpg"}}}
}

function displayinline(text){
if (document.all[text].style.display=="none"){document.all[text].style.display="inline"}
else {document.all[text].style.display="none"}
}

</script>
</head>

<body>

<table border="0" cellpadding="0" cellspacing="0" style="border-collapse: collapse" bordercolor="#111111" width="100%" id="AutoNumber1">
<tr>
<td width="598" height="28">

<p align="left">
<span id="swall" onmouseover="this.style.textDecorationUnderline='true'" onmouseout="this.style.textDecoration='none'" class="curhand" onclick="displayall()">
Show all</span></td>
<td width="93" height="28">
<p align="right">
</td>
</tr>
</table><br>
<p id='x' style="display:none"></p>
<div onmouseover="setoverstyles('menu1','imgmenu1','title1')" onmouseout="setoutstyles('menu1','imgmenu1','title1')" class="curhand" onclick="displayit('menu1','title1','imgmenu1')" id="title1" style="position:static; width:83; height:19">
<img id="imgmenu1" border="0" src="arrow_d1.jpg" width="12" height="12">First
menu</div>
<blockquote>
<span id="menu1" style="display:none; width: 140">Item 1<br>
Item 2<br>
Item 3<br>
Itrm 4<br>
Item 5<br>
Item 6<br>
Item 7</span>
</blockquote>
<p></p>
<div onmouseover="setoverstyles('menu2','imgmenu2','title2')" onmouseout="setoutstyles('menu2','imgmenu2','title2')" class="curhand" onclick="displayit('menu2','title2','imgmenu2')" id="title2" style="position:static; width:100; height:4">
<img id="imgmenu2" border="0" src="arrow_d1.jpg" width="12" height="12">Second
menu</div>
<p></p>
<blockquote>
<span id="menu2" style="display:none; width: 140">Item 1<br>
Item 2<br>
Item 3<br>
Item 4<br>
Item 5<br>
Item 6<br>
Item 7</span>
</blockquote>
<p></p>
<div onmouseover="setoverstyles('menu3','imgmenu3','title3')" onmouseout="setoutstyles('menu3','imgmenu3','title3')" class="curhand" onclick="displayit('menu3','title3','imgmenu3')" id="title3" style="position:static; width:84; height:19">
<img id="imgmenu3" border="0" src="arrow_d1.jpg" width="12" height="12">Third
menu</div>
<p></p>
<blockquote>
<span id="menu3" style="display:none; width: 140">Item 1<br>
Item 2<br>
Item 3<br>
Item 4<br>
Item 5<br>
Item 5<br>
Item 6</span>
</blockquote>
<p></p>
<div onmouseover="setoverstyles('menu4','imgmenu4','title4')" onmouseout="setoutstyles('menu4','imgmenu4','title4')" class="curhand" onclick="displayit('menu4','title4','imgmenu4');" id="title4" style="position:static; width:93; height:19">
<img id="imgmenu4" border="0" src="arrow_d1.jpg" width="12" height="12">Fourth
menu</div>
<p></p>
<blockquote>
<span id="menu4" style="display:none; width: 140">
Item 1<br>
Item 2<br>
Item 3<br>
Item 4<br>
Item 5<br>
Item 6</span>
</blockquote>
<p></p>
<div onmouseover="setoverstyles('menu5','imgmenu5','title5')" onmouseout="setoutstyles('menu5','imgmenu5','title5')" class="curhand" onclick="displayit('menu5','title5','imgmenu5')" id="title5" style="position:static; width:80; height:19">
<img id="imgmenu5" border="0" src="arrow_d1.jpg" width="12" height="12">Fifth
menu</div>
<p></p>
<blockquote>
<span id="menu5" style="display:none; width: 140">
Item 1<br>
Item 1<br>
Item 2<br>
Item 3<br>
Item 4<br>
Item 5</span>
</blockquote>
</body>
</html>


javascript - -

نمايش گرافيکی ساعت

توسط: مرتضی پاينده

دستور چاپ

تاريخ نشر: جمعه 8 آذر 1381

دريافت نمونه برنامه بصورت js (2k)

مبحث: ايجاد صفحات ديناميک

دريافت نمونه برنامه بصورت zip (25k)

اين مقاله تاکنون 26407 بار خوانده شده است

ميتوانيد ساعت سيستم کاربر را بر روی سايت بصورت گرافيکی بنمايش در بياورید.
با درِيافت فايل مورد نظر و دادن تغييرات در Gifهای ارسالی ميتوانيد اعداد مورد نظر خود را بنمايش درآوريد.

<html>
<head>
<script language="javascript">
pic0=new Image
pic1=new Image
pic2=new Image
pic3=new Image
pic4=new Image
pic5=new Image
pic6=new Image
pic7=new Image
pic8=new Image
pic9=new Image
pic0.src="images-script/0.jpg"
pic1.src="images-script/1.jpg"
pic2.src="images-script/2.jpg"
pic3.src="images-script/3.jpg"
pic4.src="images-script/4.jpg"
pic5.src="images-script/5.jpg"
pic6.src="images-script/6.jpg"
pic7.src="images-script/7.jpg"
pic8.src="images-script/8.jpg"
pic9.src="images-script/9.jpg"
ima=new Array()
ima[0]=pic0.src
ima[1]=pic1.src
ima[2]=pic2.src
ima[3]=pic3.src
ima[4]=pic4.src
ima[5]=pic5.src
ima[6]=pic6.src
ima[7]=pic7.src
ima[8]=pic8.src
ima[9]=pic9.src
function ho(){
ut=new Date()
h=ut.getHours()
m=ut.getMinutes()
s=ut.getSeconds()
if (h<10){
document.img2.src=ima[h]
document.img1.src=ima[0]
}
else{
a=h+""
b=a.substring(0,1)
c=a.substring(2,1)
/*do not need to write*/
b=b-0
c=c-0
/*not need*/
document.img1.src=ima[b]
document.img2.src=ima[c]
}
if (m<10){
document.img4.src=ima[m]
document.img3.src=ima[0]
}
else{
e=m+""
f=e.substring(0,1)
g=e.substring(2,1)
/*do not need to write two lines later*/
f=f-0
g=g-0
/*to this*/
document.img3.src=ima[f]
document.img4.src=ima[g]
}
if(s<10){
document.img6.src=ima[s]
document.img5.src=ima[0]
}
else{
p=s+""
q=p.substring(0,1)
t=p.substring(2,1)
/*not need*/
q=q-0
t=t-0
/*not need*/
document.img5.src=ima[q]
document.img6.src=ima[t]
}
setTimeout("ho()",1000)
}
</script>
</head>
<body bgcolor="#ffffff" onload="ho()">
<center><img src="images-script/0.jpg" name="img1" width="25" height="41"><img src="images-script/0.jpg" name="img2" width="25" height="41"><img src="images-script/d.jpg" width="8" height="41"><img src="images-script/0.jpg" name="img3" width="25" height="41"><img src="images-script/0.jpg" name="img4" width="25" height="41"><img src="images-script/d.jpg" width="8" height="41"><img src="images-script/0.jpg" name="img5" width="25" height="41"><img src="images-script/0.jpg" name="img6" width="25" height="41"></center>
</body>
</html>


javascript - -

اجرای صدا در زمانی مشخص

توسط: مرتضی پاينده

دستور چاپ

تاريخ نشر: چهارشنبه 13 آذر 1381

دريافت نمونه برنامه بصورت js (3k)

مبحث: کنترل Eventها

اين مقاله تاکنون 11374 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد آهنگ دلخواه خود را در ساعتی مشخص به اجرا درآوريد, کافيست فايل مورد نظر را در برنامه تعريف نماييد و ساعت مربوطه را تنظِم کنيد.

<HTML>
<HEAD>
<script language="javascript">
function da(form){
ut=new Date()
h=ut.getHours()
m=ut.getMinutes()
if (h<10) h="0"+h
if (m<10) m="0"+m
time=h+":"+m
document.frm.txt.value=time
setTimeout("da(this.form)",1000)
}
function alermon(){
hr=document.frm.se1.selectedIndex
mn=document.frm.se2.selectedIndex
tim=document.frm.se1.options[hr].value+":"+document.frm.se2.options[mn].value
if (h>12) time="0"+(h-12)+":"+m
if (h=00) time="12"+":"+m
if (time==tim){
document.all.sound.src=document.frm.alermsound.value
}
else setTimeout("alermon()",1000)
}
function alermoff(){
document.all.sound.src=""
tim=0
}
</script>
<bgSound src="" id="sound">
</HEAD>
<BODY onload="da(this.form)">
<font color="red" size="6">Alerm Clock</font>
<form name="frm">
your system clock is:<input type="text" name="txt" size="12"><p>
<font size="4" color="#0000FF">step1:</font>when you want the clock is ringing?
select hour:<select name="se1" size=1>
<option selected value="01">01 or 13
<option value="02">02 or 14
<option value="03">03 or 15
<option value="04">04 or 16
<option value="05">05 or 17
<option value="06">06 or 18
<option value="07">07 or 19
<option value="08">08 or 20
<option value="09">09 or 21
<option value="10">10 or 22
<option value="11">11 or 23
<option value="12">12 or 24
</select>
select minute:<select name="se2" size=1>
<option selected value="00">00<option value="01">01<option value="02">02<option value="03">03<option value="04">04
<option value="05">05<option value="06">06<option value="07">07<option value="08">08<option value="09">09
<option value="10">10<option value="11">11<option value="12">12<option value="13">13<option value="14">14
<option value="15">15<option value="16">16<option value="17">17<option value="18">18<option value="19">19
<option value="20">20<option value="21">21<option value="22">22<option value="23">23<option value="24">24
<option value="25">25<option value="26">26<option value="27">27<option value="28">28<option value="29">29
<option value="30">30<option value="31">31<option value="32">32<option value="33">33<option value="34">34
<option value="35">35<option value="36">36<option value="37">37<option value="38">38<option value="39">39
<option value="40">40<option value="41">41<option value="42">42<option value="43">43<option value="44">44
<option value="45">45<option value="46">46<option value="47">47<option value="48">48<option value="49">49
<option value="50">50<option value="51">51<option value="52">52<option value="53">53<option value="54">54
<option value="55">55<option value="56">56<option value="57">57<option value="58">58<option value="59">59
</select><p>
<font size="4" color="#0000FF">step2:</font>browse your sound file:
<input type="file" size=36 name="alermsound"><p>
<font color="#0000FF" size="4">step3:</font><input type="button" value="on" onclick="alermon()"> <input type="button" value="off" onclick="alermoff()"><br>
if you minimize this window you can't hear any sound.

</form>
</BODY>
</HTML>


javascript - -

قرار دادن متن در قسمت Title

توسط: ناصر نايب

دستور چاپ

تاريخ نشر: شنبه 12 بهمن 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 11553 بار خوانده شده است

ميتوانيد متن را در قسمت Title صفحات خود بصورت فعال به نمایش در آوريد.

<html>
<head>
<script language="javascript">
function changettl1(){
if(boxtxt.value==''){document.title='Enter a text in text box , ...by Naser'}
else{document.title=boxtxt.value};
setTimeout("changettl2()",500)
}

function changettl2(){
document.title="\r\r\r"
setTimeout("changettl1()",300)
}
</script>
</head>

<body onload="changettl1()">
<nobr>enter a text for title here :
<input type="text" id="boxtxt" size="20"></nobr>
</body>
</html>


javascript - -

حرکت عکس بدنبال موس (2)

توصيه به ديگران

توسط: مديريت سايت

دستور چاپ

تاريخ نشر: چهارشنبه 30 بهمن 1381

دريافت نمونه برنامه بصورت js (5k)

مبحث: کنترل Eventها

اين مقاله تاکنون 26093 بار خوانده شده است

بدليل استقبال کاربران از شماره قبلي اين اسکريپت (حرکت عکس بدنبال موس) تصميم گرفتم Version جديدتر اين اسکريت را با قابليت توقف حرکت موس, ارائه دهيم.

<html>
<head>

</head>
<body>

<script>
var ns = (document.layers)?1:0;
var Anim=new Array(); /* holds interval events */
var imgwidth=40; // Image width
var imgheight=40; // Image height
var button = Array(); // to pre-cache images
button[0]=new Image();
button[0].src="images-script/pic1.gif";
button[1]=new Image();
button[1].src="images-script/pic3.gif";

var text="<table width=10 bgcolor=#ffffff><td><a href='javascript:showhideAnimation()'><center><img name='Button' src='"+button[0].src+"' width='"+imgwidth+"' height='"+imgheight+"' border='0'></center></a></font></td></table>" // A bit of HTML code to display the button

//Initialize some variables to make the button always to appear on the frame's bottom-right corner
if (ns) {
document.write("<LAYER NAME='FlyOnOff' LEFT=0 TOP=0>"+text+"</LAYER>");
horz=".left";
vert=".top";
docStyle="document.";
styleDoc="";
innerW="window..innerWidth";
innerH="window.innerHeight";
offsetX="window.pageXOffset";
offsetY="window.pageYOffset";
}else {
document.write("<div id='FlyOnOff' style='position:absolute; visibility:show; left:235px; top:-50px; z-index:2'>"+text+"</div>");
horz=".pixelLeft";
vert=".pixelTop";
docStyle="";
styleDoc=".style";
innerW="document.body.clientWidth";
innerH="document.body.clientHeight";
offsetX="document.body.scrollLeft";
offsetY="document.body.scrollTop";
}

// Moves the button in the right position
function checkLocation() {
objectXY="FlyOnOff";
var availableX=eval(innerW);
var availableY=eval(innerH);
var currentX=eval(offsetX);
var currentY=eval(offsetY);
x=availableX-(imgwidth+30)+currentX;
y=availableY-(imgheight+20)+currentY;
eval(docStyle + objectXY + styleDoc + horz + "=" + x);
eval(docStyle + objectXY + styleDoc + vert + "=" + y);
}

Anim[0]=setInterval('checkLocation()', 10);

(document.layers)?window.captureEvents(Event.MOUSEMOVE):0;
(document.layers)?window.onMouseMove=getMousePosition:document.onmousemove=getMousePosition;

var Dot_Ro=60; //Dot's distance from the mouse pointer
var Dot_Theta=0; //Dot's initial angle
var Dot_Speed; //Dot's absolute Angular speed
var Dot_Direction=1; //Dot's direction (1=clockwise)
var Dot_x=0; //Dot's original position
var Dot_y=0;

var alpha; //Angle from the fly to the mouse
var mult; //Ausiliary variable to define the angle

var picX = 20; //Fly's coords.
var picY = 100;
var mouseX = 0; //Mouse coords.
var mouseY = 0;
var step = 10; //Pixels
var speed = 100;//u-seconds

// Dir specifies the right picture;
// img pre-caches images.
var dir = Array();
dir[-4]="images-script/pic1.gif";
dir[-1]="images-script/pic2.gif";
dir[-2]="images-script/pic3.gif";
dir[-3]="images-script/pic4.gif";
dir[3]="images-script/pic1.gif";
dir[4]="images-script/pic2.gif";
dir[1]="images-script/pic3.gif";
dir[2]="images-script/pic4.gif";
dir[0]="";

var img = Array();
for (var i=-4; i<5; i++){
img[i]=new Image();
img[i].src=dir[i];
}

// Some HTML code to show the fly.
if (ns) {
document.write("<LAYER NAME='FlyDiv' LEFT=0 TOP=0><img src="+dir[1]+" name='pic'></LAYER>");
}else {
document.write("<div id='FlyDiv' style='position:absolute'>");
document.write("<img name='pic' src=" + dir[1] + "></div>");
}

// Shows the proper image for the fly.
function display(direction) { //direction must be from -4 to 4, but not 0.
if (ns) {
document.pic.src = dir[direction];
}else{
pic.src = dir[direction];
}
}

function getMousePosition(e) {
mouseY=(ns)?e.pageY:window.event.y + document.body.scrollTop;
mouseX=(ns)?e.pageX:window.event.x + document.body.scrollLeft;
}

//Calculate new position
function calcNewPos() {

var dist=Math.sqrt(Math.pow(mouseY-picY,2) + Math.pow(mouseX-picX,2));
Dot_Speed=Math.PI/15;
Dot_Theta+=Dot_Direction*Dot_Speed;
Dot_x=mouseX+Dot_Ro*Math.cos(Dot_Theta);
Dot_y=mouseY+Dot_Ro*Math.sin(Dot_Theta);
var arg = (Dot_y-picY) / (Dot_x-picX);
mult = (Dot_x - picX < 0)? mult = -1:1;
alpha = Math.atan(arg);
var dx = mult * step * Math.cos(alpha);
var dy = mult * step * Math.sin(alpha);
picX += dx;
picY += dy;
}

//Shows or hides the fly when the "button" is pressed
function showhideAnimation() {
if (ns) {
document.layers['FlyDiv'].visibility=document.layers['FlyDiv'].visibility=="hide"?"show":"hide";
document.Button.src = document.layers['FlyDiv'].visibility=="hide"?button[1].src:button[0].src;
}else {
FlyDiv.style.visibility=="hidden"?FlyDiv.style.visibility = "visible":FlyDiv.style.visibility = "hidden";
Button.src = FlyDiv.style.visibility=="hidden"?button[1].src:button[0].src;
}
}

// Moves the fly around the screen
function moveFly() {
// moves the fly in a new position...
calcNewPos();
if (ns) {
document.layers['FlyDiv'].left = picX;
document.layers['FlyDiv'].top = picY;
}else{
FlyDiv.style.left = picX - pic.width / 2;
FlyDiv.style.top = picY - pic.height / 2;
}

// ... and changes the image.
alpha=-180*alpha/Math.PI;
alpha+=22.5;
var OK=0;
for(var i=0; (i<4)&& !OK; i++){
if (alpha<-Math.PI+45*i){
display(mult*(i+1));
OK=1;
}
}
}

// Changes Dot's turning direction
function ChangeDotDirection() {
Dot_Direction=-Dot_Direction;
Dot_Theta+=Math.PI;
}

//Go!
Anim[1]=setInterval('moveFly()', speed);
Anim[2]=setInterval('ChangeDotDirection()', speed*50);

function killIt()
{
for(var i=0;i<Anim.length;i++)
{
if(Anim[i])
{
clearInterval(Anim[i]);
Anim[i]=null;
}
}
}
</script>

</body>
</html>


javascript - -

نمايش عمودی متن

دستور چاپ

تاريخ نشر: جمعه 16 اسفند 1381

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 11418 بار خوانده شده است

با استفاده از اين اسکريپت ميتوان متنی را بصورت عمودی به نمايش درآورد.
متن مورد نظر فارق از اينکه در صفحه چه جيزی وجود دارد بر روی صفحه قرار ميگيرد.

<html>
<head>

<style>
.myStyle { writing-mode: tb-rl;
filter: flipH() flipV();
}
</style>

</head>
<body>

<span class="myStyle">
<font size="6" color="#000000">IranJavascript</font>
</span>

</body>
</html>


javascript - -

نمايش فايل گرافيکی

دستور چاپ

تاريخ نشر: چهارشنبه 6 فروردين 1382

دريافت نمونه برنامه بصورت js (4k)

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 12297 بار خوانده شده است

با استفاده از اين مجموعه دستوارت ميتوانيد فايل گرافيکي موجود در سيستم خود را در پنجره Browser همراه با اطلاعات کامل به نمايش درآوريد.
ميتوانيد حتي width و height فايل مورد نظر را نيز مشاهده نماييد.

<html>
<head>
<script>
IE4 = (document.all) ? 1 : 0;
NS4 = (document.layers) ? 1 : 0;
VER4 = (IE4 || NS4) ? 1 : 0;
function f_external_drop(e)
{
var ls_file_url, ls_filename, ls_html;

if (NS4)
{
netscape.security.PrivilegeManager.enablePrivilege('UniversalBrowserRead');
netscape.security.PrivilegeManager.enablePrivilege('UniversalFileRead');

ls_file_url = e.data[0];
ls_filename = ls_file_url.substring(8).replace(/\|/g, ':').replace(/\//g,java.lang.System.getProperty('file.separator'));
document.forms[0].elements["inputfile"].value = ls_filename;
if (e.data.length == 1 ) { f_view(); }
else { f_multiview(e); }
}

// else
// {
// alert("IE, Popeye");
// }

return false;
}

window.ondragdrop = f_external_drop;

function f_rewrite(as_name, as_text)
{
if (NS4)
{
// NS4 - GET <DIV> (ie layers[]) NAME and rewrite document
ls_eval = "document.layers['" + as_name +"'].document.open()";
eval(ls_eval);
ls_eval = "document.layers['" + as_name +"'].document.write(as_text)";
eval(ls_eval);
ls_eval = "document.layers['" + as_name +"'].document.close()";
eval(ls_eval);
}
else
{
ls_eval = "document.all['" + as_name +"'].innerHTML='" + as_text + "'";
eval(ls_eval);
}
}

function f_ieview()
{
if (IE4) { f_view(); }
}

function f_nsview()
{
if (NS4) { f_view(); }
}

function f_view()
{
var ls_file, ls_html, ls_msg;
var li;

ls_file = document.forms[0].inputfile.value;

li = ls_file.indexOf("\\");
while (li > 0)
{
ls_file = ls_file.substr(0, li) + "\/" + ls_file.substr(li + 1, ls_file.length - 1);
li = ls_file.indexOf("\\");
}

// ADD type file:///
li = ls_file.indexOf(":");
if (li > 0) { ls_file = "file:\/\/\/" + ls_file.substr(0, li) + "|" + ls_file.substr(li + 1, ls_file.length - 1);}

ls_file = ls_file.toLowerCase();
if ( ls_file.indexOf(".jpg") != -1 || ls_file.indexOf(".jpeg") != -1 || ls_file.indexOf(".gif") != -1 )
{
// GET img dimensions
ls_msg = "";
limg = new Image();
limg.src = ls_file;
ls_msg = limg.src ;
ls_msg += " : W=" + limg.width + " : H=" + limg.height ;
window.status = ls_msg;

ls_html = "<CENTER><TABLE BORDER=1 CELLSPACING=2 CELLPADDING=5 WIDTH=400><TR><TD><CENTER>";
ls_html += ls_msg + "</CENTER></TD></TR>";
ls_html += "<TR><TD><CENTER><IMG NAME=show SRC=" + limg.src + " SIZE=50%></CENTER></TD></TR>";
ls_html += "</TABLE></CENTER>";
f_rewrite("displaysection", ls_html);
}
else
{
// ls_eval = "document.layers['displaysection'].src=" + ls_file;
//window.status = ls_eval;
//alert(ls_eval);
// eval(ls_eval);
}
}

function f_multiview(e)
{
var ls_file, ls_html, ls_name, ls_contacts, ls_newrow;
var li;

ls_html = "";
ls_contacts = "";
for (li=0; li < e.data.length; li++)
{
ls_file = e.data[li]
ls_file = ls_file.toLowerCase();

if ( ls_file.indexOf(".jpg") != -1 || ls_file.indexOf(".jpeg") != -1 || ls_file.indexOf(".gif") != -1 )
{
ls_name = ls_file.substring(ls_file.lastIndexOf("/") + 1, ls_file.length);
ls_newrow = "";
if (li!=0 && li%4==0) { ls_newrow="</TR><TR>"; }
ls_contacts += ls_newrow
ls_contacts += "<TD VALIGN=bottom><CENTER>";
ls_contacts += "<TABLE BORDER=1 BORDERCOLOR=blue CELLSPACING=0 BGCOLOR=white>";
ls_contacts += "<TR><TD><CENTER>";
ls_contacts += " <IMG NAME=show SRC=" + ls_file + " WIDTH=64>";
ls_contacts += "</CENTER></TD></TR>";
ls_contacts += "<TR><TD><CENTER>" + ls_name + "</CENTER></TD></TR>";
ls_contacts += "</TABLE></CENTER>";
ls_contacts += "</TD>";
}
}
lj = e.data.length%4
if (lj%4 > 0 && e.data.length > 4)
{
lj = 4 - lj;
for (li=0; li < lj; li++) { ls_contacts += "<TD> </TD>"; }
}

ls_html = "<CENTER><TABLE BORDER=4 BORDER-STYLE=ridge CELLSPACING=2 CELLPADDING=5 WIDTH=400 BGCOLOR=#C0C0C0>";
ls_html += "<TR>" + ls_contacts + "</TR>";
ls_html += "</TABLE></CENTER>";

f_rewrite("displaysection", ls_html);
}

</SCRIPT>

</head>
<body>

<CENTER>

<DIV id=displaysection> </DIV>

<FONT SIZE=+1>

<FORM ENCTYPE=multipart/form data>
<TABLE BORDER=1>
<TR>
<TD CLASS=TDMED><INPUT TYPE=button VALUE=View onClick='f_view();' TABINDEX=10></TD>
<TD><INPUT TYPE=file NAME=inputfile SIZE=80 onFocus='f_ieview();' onChange='f_nsview();' TABINDEX=20></TD>
</TR><TR>
<TD COLSPAN=2 CLASS=TDMED><CENTER>In Netscape Navigator you can <B>Drag and Drop</B> single or multiple images onto this page.</CENTER></TD>
</TR>
</TABLE>
</FORM>
</CENTER>
</body>
</html>


javascript - -

انتخاب radio button

دستور چاپ

تاريخ نشر: جمعه 12 ارديبهشت 1382

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

اين مقاله تاکنون 12719 بار خوانده شده است

ميتوانيد رنگ radio button هاي انتخابي را بعد از select تغيير دهيد.

<html>
<head>

<style>
.s0 { color: red; background-color: gold; }
.s1 { color: gold; background-color: red; }
.t0 { color: blue; background-color: purple; }
.t1 { color: purple; background-color: blue; }
.s { color: orange; background-color: silver; }
.t { color: orange; background-color: silver; }
</style>

</head>
<body>

<form name=f1>
<span id=i0 class=s0>R0 <input id=j0 class=t0 type=radio name=r1 value="0" onclick="doIt(this.form,0)"></span><BR>
<span id=i1 class=s1>R1 <input id=j1 class=t1 type=radio name=r1 value="1" onclick="doIt(this.form,1)"></span><BR>
</form>
<script>
function doIt(_f,_i)
{
if(!document.getElementById)return; /* this example only for DOM browsers */
document.getElementById("i"+_i).className="s";
document.getElementById("j"+_i).className="t";
_i=(_i+1)%2; /* if 1 make 0 : if 0 make 1 */
document.getElementById("i"+_i).className="s"+_i;
document.getElementById("j"+_i).className="t"+_i;
}
</script>

</body>
</html>


javascript - -

افکت روي متن

توسط: مهدي ميرزايي

دستور چاپ

تاريخ نشر: يکشنبه 21 ارديبهشت 1382

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

اين مقاله تاکنون 22345 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد متن را به حرکت درآوريد.

<HTML>
<HEAD>
<STYLE>
DIV.aFilter {FILTER:PROGID:DXIMAGETRANSFORM.MICROSOFT.WAVE(
strength=7,
freq=3,
lightstrength=100,
add=0,
phase=0);
width: 150px; color: #0000FF;font-size:30px;font-weight:bold;
text-align :Center;
}
</STYLE>
<SCRIPT language="javascript">
function doWave()
{
document.getElementById("myDiv").filters[0].phase += 10;
status = document.getElementById("myDiv").filters[0].phase ;

}
</SCRIPT>
</HEAD>
<BODY OnLoad="window.setInterval('doWave();',100);" >
<DIV CLASS="aFilter" id="myDiv">Iran Java Script</DIV>
</BODY>
</HTML>


javascript - -

ترانس رنگ

توسط: مهدي ميرزايي

دستور چاپ

تاريخ نشر: دوشنبه 5 خرداد 1382

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

اين مقاله تاکنون 15133 بار خوانده شده است

ميتوانيد بر روي سايت خود ترنسفر رنگ ايجاد نماييد.
اين script قابليت تغيير رنگ را براحتي فراهم آورده است و جابجايي رنگ آن بدون range شدن رنگ صورت ميگيرد.

<DIV ID="oTransContainer" STYLE="text-align:Center;font-size:30px;font-family:arial;position:absolute; top: 0px; left: 0px; width: 300px;
height:300px; filter:progid:DXImageTransform.Microsoft.Wipe(
GradientSize=1.0, wipeStyle=0, motion='forward') ">
<!-- This is the first content that is displayed. -->
<DIV ID="oDIV1" STYLE="color:pink;position:absolute; top:50px; left:10px; width:240px; height:140px;
background:blue"> Iran Java Script </DIV>
<!-- This content displays after the first content. -->
<DIV ID="oDIV2" STYLE="color:#e1e1e1;visibility:hidden; position:absolute; top:50px; left:10px;
width:240px; height:140px; background: green"> <BR><BR> Wipe Transition</DIV>
</DIV>
<BUTTON onclick="fnToggle()">Toggle Transition</BUTTON>
<SCRIPT>
var bTranState = 0;
function fnToggle() {
oTransContainer.filters[0].Apply();
if (bTranState=='0') {
bTranState = 1;
oDIV2.style.visibility="visible";
oDIV1.style.visibility="hidden";}
else {
bTranState = 0;
oDIV2.style.visibility="hidden";
oDIV1.style.visibility="visible";}
oTransContainer.filters[0].Play(duration=2);}
</SCRIPT>


javascript - -

تغيير رنگ Boxها

دستور چاپ

تاريخ نشر: جمعه 6 تير 1382

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 13970 بار خوانده شده است

با استفاده از اين اسکريپت ميتوانيد رنگ Boxها را بعد از کليک کردن تغيير دهيد.

<html>
<head>

<style>
.t0 { color: brown; background-color: pink; }
.t1 { color: darkblue; background-color: gold; }
</style>

</head>
<body>

<form name=f1>
<textarea class=t1 id=textone>stuff in the box
</textarea>
<BR><input type=button value="Change" onclick="doIt()">
</form>
<script>
var _I=1;
function doIt()
{
_I=(_I+1)%2;
/* example is for DOM browsers only */
if(document.getElementById)
document.getElementById("textone").className="t"+_I;
}
</script>

</body>
</html>


javascript - -

تعريف home page

توسط: سپهر لاجوردی

دستور چاپ

تاريخ نشر: دوشنبه 13 مرداد 1382

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 15103 بار خوانده شده است

با استفاده از اين اسکريپت می توان نشانی سايت موردنظر را به عنوان home page به browser کاربر معرفی نمود.

<html>
<head>
<title>Set as HOMEPAGE Script</title>
</head>
<body>

<a style="cursor:hand;font-weight:bold;color:#004080;font-family:Verdana" HREF onClick="this.style.behavior='url(#default#homepage)';this.setHomePage('http://www.iranjavascript.com');">Click here to make Iranjavascript.com your default homepage!</a>

</body>
</html>


javascript - -

حرکت متن درون Box

توسط: يوشا ماندنی پور

دستور چاپ

تاريخ نشر: يکشنبه 30 شهريور 1382

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 18089 بار خوانده شده است

می توانيد متن دلخواه خود را در Box مورد نظر به حرکت درآوريد.

<SCRIPT LANGUAGE="JavaScript">

<!-- hide from old browsers

var msg = "IranJavaScript "

function scrollMsg(){

document.scrollerForm.welcomeMsg.value = msg

msg = msg.substring(1, msg.length) + msg.substring(0, 1)

setTimeout("scrollMsg()", 150)

}

//-->

</SCRIPT>

<BODY ONLOAD="scrollMsg()">

<FORM NAME="scrollerForm">

<INPUT TYPE="text" NAME="welcomeMsg" VALUE="" size=30>

</FORM>


javascript - -

تبديل متن به گرافيک

توسط: مرتضی پاينده

دستور چاپ

تاريخ نشر: شنبه 17 آبان 1382

دريافت نمونه برنامه بصورت js (2k)

مبحث: کنترل Eventها

دريافت نمونه برنامه بصورت zip (15k)

اين مقاله تاکنون 18692 بار خوانده شده است

با استفاده از اين اسکريپت میتوانيد جمله خود را بصورت گرافيکی به نمايش در آوريد.

<HTML>
<HEAD>
<script language="javascript">
alpha=new Array("images-script/a.gif","images-script/b.gif","images-script/c.gif","images-script/d.gif","images-script/e.gif","images-script/f.gif","images-script/g.gif","images-script/h.gif","images-script/i.gif","images-script/j.gif","images-script/k.gif","images-script/l.gif","images-script/m.gif","images-script/n.gif","images-script/o.gif","images-script/p.gif","images-script/q.gif","images-script/r.gif","images-script/s.gif","images-script/t.gif","images-script/u.gif","images-script/v.gif","images-script/w.gif","images-script/x.gif","images-script/y.gif","images-script/z.gif","images-script/space.gif","images-script/dot.gif")
nu=0
pics=new Array()
var pq=''
function sep(ww){
pq=ww
if(screen) lp=screen.width-650
wine=window.open('','win','width=600,height=200,scroolbars=yes,left='+lp+'top=0')
sent=document.frm.txt.value
for(iu=1;iu<=sent.length;iu++){
qu=sent.substring(nu,iu)
ss=qu+""
if (ss=="a") nn=0
if (ss=="b") nn=1
if (ss=="c") nn=2
if (ss=="d") nn=3
if (ss=="e") nn=4
if (ss=="f") nn=5
if (ss=="g") nn=6
if (ss=="h") nn=7
if (ss=="i") nn=8
if (ss=="j") nn=9
if (ss=="k") nn=10
if (ss=="l") nn=11
if (ss=="m") nn=12
if (ss=="n") nn=13
if (ss=="o") nn=14
if (ss=="p") nn=15
if (ss=="q") nn=16
if (ss=="r") nn=17
if (ss=="s") nn=18
if (ss=="t") nn=19
if (ss=="u") nn=20
if (ss=="v") nn=21
if (ss=="w") nn=22
if (ss=="x") nn=23
if (ss=="y") nn=24
if (ss=="z") nn=25
if (ss==" ") nn=26
if (ss==".") nn=27
pics[nu]=new Image
pics[nu].src=alpha[nn]
pq+="<img src="+pics[nu].src+">"
nu++
}
nu=0
iu=1
wine.document.write(pq)
wine.document.close()
}
</script>
</HEAD>
<BODY>
<p>please use the <font color="#0000FF">english alphabet</font> and <font color="#0000FF">space</font>
and '<font size="7" color="#0000FF">.</font>' characters<br>
your text will display in <font color="red" size="4">new window</font>.
</p>
<form name="frm">
<input type="text" name="txt" size=20>
<input type="button" value="go to picture" onclick="sep('')">
</form>
</BODY>
</HTML>


javascript - -

بازي O_X

دستور چاپ

تاريخ نشر: سه شنبه 2 دي 1382

دريافت نمونه برنامه بصورت js (8k)

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 16346 بار خوانده شده است

بزرگترين مزيت استفاده از JavaScript قابليت اجراي آن در سيستم کاربر مي باشد. اين خصوصيت باعث شده تا بتوانيم حتي براي کاربران Game طراحی کنیم و آنها را به بازی با سیستم خود در محیط IE تشويق نماييم !

<html>
<head>

<body>

<script>
var _url = document.location.toString().split("?");
var _parm = _url[1]?_url[1]:"";
var _P0n = "";
var _P0v = 0;
var _P1n = "";
var _P1v = 0;
if (_parm != "") {
_P0n=_parm.split("&")[0].split("=")[0].toLowerCase();
_P0v=parseInt(_parm.split("&")[0].split("=")[1]);
if(_parm.split("&")[1]) {
_P1n = _parm.split("&")[1].split("=")[0].toLowerCase();
_P1v = parseInt(_parm.split("&")[1].split("=")[1]);
} else {
_P1n ="";
}
} else {
_P0n="";
_P1n="";
}

var MATRIX_SIZE = 3;
var AMOUNT_TO_WIN = 4;
var PARAM_SIZE = "size".toLowerCase();
var PARAM_WIN = "win".toLowerCase();
if (_P0n==PARAM_SIZE) {MATRIX_SIZE=_P0v;}
if (_P1n==PARAM_SIZE) {MATRIX_SIZE=_P1v;}
if (_P0n==PARAM_WIN) {AMOUNT_TO_WIN=_P0v;}
if (_P1n==PARAM_WIN) {AMOUNT_TO_WIN=_P1v;}

//////////////////////////////

if(MATRIX_SIZE<3)MATRIX_SIZE=3;
if(MATRIX_SIZE>10)MATRIX_SIZE=10;
if(AMOUNT_TO_WIN>MATRIX_SIZE)AMOUNT_TO_WIN=MATRIX_SIZE;
if(AMOUNT_TO_WIN<3)AMOUNT_TO_WIN=3;

document.write("<BR>"+AMOUNT_TO_WIN+" in a row wins!<BR>");
var tbo = '';
tbo += '<form name=table1>';
tbo += '<table>';
for (var i=0;i<MATRIX_SIZE;i++) {
tbo += '<TR>';
for(var j=0;j<MATRIX_SIZE;j++) {
var _c = parseInt(i)*parseInt(MATRIX_SIZE)+parseInt(j);
tbo += '<td><input name=s'+_c+' type=text size=1 value=" " onfocus="clicked(table1.s'+_c+');blur()"></td>';
}
tbo += '</tr>';
}
tbo += '</table>';
tbo += '<table><tr><td>Restart Game with: <input type=button value="Player is X" onclick=setPlayers("X","O")></td>';
tbo += '<td><input type=button value="Computer is X" onclick=setPlayers("O","X")></td></tr>';
tbo += '<tr><td>Player is: <input name=pis type=text size=1 value="X" onfocus=blur()></td>';
tbo += '<td>Computer is: <input name=cis type=text size=1 value="O" onfocus=blur()></td></tr>';
tbo += '</table>';
tbo += '<table><tr><td>Won: <input type=text value="0" name=gameswon size=2></td>';
tbo += '<td>Ties: <input type=text value="0" name=gamestied size=2></td>';
tbo += '<td>Lost: <input type=text value="0" name=gameslost size=2></td></tr></table>';
tbo += 'Set Matrix Size: ';
var XX="";
for(var i=3;i<11;i++) {
if(i==MATRIX_SIZE) {
tbo += ' '+i+'x'+j+' ';
} else {
tbo += '<input type=button value="'+i+'x'+i+'"';
XX =_url[0]+"?"+PARAM_SIZE+'='+i+"&"+PARAM_WIN+'='+AMOUNT_TO_WIN;
tbo += ' onclick="document.location=\''+XX+'\'"> ';
}
}
tbo += '<BR>Amount In a Row Wins: ';
for(var i=3;i<11;i++) {
if(i==AMOUNT_TO_WIN) {
tbo += ' '+i+' ';
} else {
tbo += '<input type=button value='+i+' ';
XX = _url[0]+"?"+PARAM_SIZE+'='+MATRIX_SIZE+'&'+PARAM_WIN+'='+i;
tbo += ' onclick="document.location=\''+XX+'\'"> ';
}
}
tbo += '</form>';
document.write(tbo);
/////////////////////////////////////////////

var PLAYER="X";
var COMPUTER="O";
var BLANK=" ";
var ROWS = new Array();
var COLS = new Array();
var DIAG = new Array();

DIAG[0]=new Array();
DIAG[1]=new Array();
for(var _i=0;_i<MATRIX_SIZE;_i++) {
DIAG[0][_i]=_i*MATRIX_SIZE+_i;
DIAG[1][_i]=(MATRIX_SIZE-1)*(_i+1);
}
for (var i=1;i<=(MATRIX_SIZE-AMOUNT_TO_WIN);i++) {
var n=2+((i-1)*4);
DIAG[n+0]=new Array();
DIAG[n+1]=new Array();
DIAG[n+2]=new Array();
DIAG[n+3]=new Array();
for (var j=1;j<=(MATRIX_SIZE-i);j++) {
DIAG[n+0][j-1]=(MATRIX_SIZE+1)*(j-1)+i;
DIAG[n+1][j-1]=(MATRIX_SIZE+1)*(j-1)+(i*MATRIX_SIZE);
DIAG[n+2][j-1]=(MATRIX_SIZE-1)*(j)-i;
DIAG[n+3][j-1]=DIAG[n+2][j-1]+(MATRIX_SIZE+1)*(i);
}
}

for(var i=0;i<MATRIX_SIZE;i++) {
ROWS[i]=new Array();
COLS[i]=new Array();
for (var j=0;j<MATRIX_SIZE;j++) {
ROWS[i][j]=i*MATRIX_SIZE+j;
COLS[i][j]=i+j*MATRIX_SIZE;
}
}

//////////////////////////////

function setPlayers(_p,_c) {
PLAYER=document.table1.pis.value=_p;
COMPUTER=document.table1.cis.value=_c;
resetBoard();
if(COMPUTER=="X") {
computerMove();
}
}

var GAMEOVER = false;

function clicked(_s) {
if(_s.value!=BLANK || GAMEOVER) return;
_s.value=PLAYER;
postMoveLogic();
computerMove();
}

function postMoveLogic() {
var _status = gameOver();
if (_status == BLANK) { document.table1.gamestied.value++;GAMEOVER=true; }
if (_status == PLAYER) { document.table1.gameswon.value++;GAMEOVER=true; }
if (_status == COMPUTER) { document.table1.gameslost.value++;GAMEOVER=true; }
}

function resetBoard() {
for (var i=0;i<MATRIX_SIZE;i++) {
for (var j=0;j<MATRIX_SIZE;j++) {
var _a = parseInt(i)*parseInt(MATRIX_SIZE)+parseInt(j);
eval("document.table1.s"+_a+".value=BLANK");
}
}
GAMEOVER=false;
}

function gameOver() {
var _ret = -1;
var spotsTaken=true;
for (var i=0;i<MATRIX_SIZE;i++) {
for (var j=0;j<MATRIX_SIZE;j++) {
var _a = parseInt(i)*parseInt(MATRIX_SIZE)+parseInt(j);
var _b = eval("document.table1.s"+_a+".value");
eval("var _s"+_a+"='"+_b+"'");
if(eval("_s"+_a)==BLANK) {
spotsTaken=false;
}
}
}

if(spotsTaken) return (BLANK);
for(var i=0;i<MATRIX_SIZE;i++) {
if (AmountInARow(ROWS[i])) return (whoHasWon);
if (AmountInARow(COLS[i])) return (whoHasWon);
}
for(var i=0;i<DIAG.length;i++) {
if(AmountInARow(DIAG[i])) return (whoHasWon);
}
return (_ret);
}

function allTheseMatch(_v) {
var _ret = true;
for(var i=1;i<_v.length;i++) {
var _a=eval("document.table1.s"+_v[i-1]+".value");
var _b=eval("document.table1.s"+_v[i]+".value");
if (_a != _b) _ret = false;
}
return (_ret);
}

var OneAwaySpot=-1;

function oneFromWin(_who,_a) {
for(var i=0;i<(_a.length-AMOUNT_TO_WIN+1);i++) {
var _newA = new Array();
for (var j=0;j<AMOUNT_TO_WIN;j++) {
_newA[j]=_a[i+j];
}
if(oneAway(_who,_newA)) {return true;}
}
}

var whoHasWon=-1;
function AmountInARow(_a) {
whoHasWon=-1;
for(var i=0;i<(_a.length-AMOUNT_TO_WIN+1);i++) {
var _newA = new Array();
for (j=0;j<AMOUNT_TO_WIN;j++) {
var _TEMP = parseInt(i)+parseInt(j);
_newA[j]=eval("document.table1.s"+_a[_TEMP]+".value");
}
if (_newA[0]!=BLANK && arrayIsEqual(_newA)) {
whoHasWon = _newA[0];
return true;
}
}
return false;
}

function oneAway(_who,_a) {
OneAwaySpot=-1;
var _ret = false;
var _aTemp = new Array();
for (var i=0;i<_a.length;i++) {
var _y = eval("document.table1.s"+_a[i]+".value");
if (_y !=BLANK) {
_aTemp[_aTemp.length?_aTemp.length:0]=_a[i];
} else {
OneAwaySpot = _a[i];
}
}
if (_aTemp.length && _aTemp.length == _a.length-1) {
_ret = true;
var _latchValue = eval("document.table1.s"+_aTemp[0]+".value");
for (var i=1;i<_aTemp.length;i++) {
var _y = eval("document.table1.s"+_aTemp[i]+".value");
if(_latchValue != _y || _y != _who) {
_ret = false;
}
}
}
return (_ret);
}

function determineComputerMove() {
var firstMove=true;
for(var i=0;i<MATRIX_SIZE;i++) {
for (var j=0;j<MATRIX_SIZE;j++) {
var _a=parseInt(i)*parseInt(MATRIX_SIZE)+parseInt(j);
var _b=eval("document.table1.s"+_a+".value");
eval("var _s"+_a+"='"+_b+"'");
if(eval("_s"+_a) !=BLANK)
firstMove = false;
}
}
if (firstMove && (MATRIX_SIZE%2==1)) return (MATRIX_SIZE*MATRIX_SIZE-1)/2;
for(var i=0;i<MATRIX_SIZE;i++) {
if(oneFromWin(COMPUTER,ROWS[i])) return (OneAwaySpot);
if(oneFromWin(COMPUTER,COLS[i])) return (OneAwaySpot);
}
for(var i=0;i<DIAG.length;i++) {
if(oneFromWin(COMPUTER,DIAG[i])) return (OneAwaySpot);
}
for(var i=0;i<MATRIX_SIZE;i++) {
if(oneFromWin(PLAYER,ROWS[i])) return (OneAwaySpot);
if(oneFromWin(PLAYER,COLS[i])) return (OneAwaySpot);
}
for(var i=0;i<DIAG.length;i++) {
if(oneFromWin(PLAYER,DIAG[i])) return (OneAwaySpot);
}
var _spot = Math.round(Math.random()*(MATRIX_SIZE*MATRIX_SIZE-1));
while(eval("_s"+_spot) !=BLANK) {
_spot=(++_spot)%(MATRIX_SIZE*MATRIX_SIZE);
}
return (_spot);
}

function computerMove() {
if(GAMEOVER) return;
var _spot = determineComputerMove();
eval("document.table1.s"+_spot+".value=COMPUTER");
postMoveLogic();
}

function arrayIsEqual(_a) {
var _first=_a[0];
for(var i=1;i<_a.length;i++) {
if(_first != _a[i]) { return false; }
}
return true;
}

function isEqual() {
var _ret = true;
for(var i=1;i<arguments.length;i++) {
if(arguments[i-1]!=arguments[i]) _ret = false;
}
return (_ret);
}

</script>

</body>
</html>


javascript - -

دستور Thead

دستور چاپ

تاريخ نشر: جمعه 24 ارديبهشت 1383

دريافت نمونه برنامه بصورت js

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 9445 بار خوانده شده است

Theadدستوري است که باعث ايجاد عنوان در هنگام Table بندي صفحات مي شود.
براي ساختن ستون در table به غير از <tr> دستور ديگر نيز وجود دارد کد <thead> در تمامي قسمتهاي يک table ميتواند ستون مانند <tr> ايجاد نمايد.

<table border="1">
<thead>
<tr>
<th>id</th>
<th>last_name</th>
<th>first_name</th>
<th>sales</th>
</tr>
</thead>
<tr>
<td>6</td>
<td>Andersen </td>
<td>David </td>
<td>6420</td>
</tr>
<tr>
<td>3</td>
<td>Buchanan </td>
<td>Steven </td>
<td>3245</td>
</tr>
</table>


javascript - -

تاريخ شمسي

توسط: احمد

دستور چاپ

تاريخ نشر: يکشنبه 28 شهريور 1383

دريافت نمونه برنامه بصورت js (2k)

مبحث: ايجاد صفحات ديناميک

اين مقاله تاکنون 13937 بار خوانده شده است

با استفاده از اين کد ميتوانيد تاريخ شمسي را در وب سايت خود درج نماييد نکته قابل توجه اين است که تاريخ شمسي بر طبق تاريخ سيستم کاربر تعيين مي گردد.

<script language="javascript" type="text/javascript">
dayName = new Array ("ÙŠÚ© Ø´Ù†Ø¨Ù‡ "," Ø¯ÙˆØ´Ù†Ø¨Ù‡"," Ø³Ù‡ Ø´Ù†Ø¨Ù‡ "," Ú†Ù‡Ø§Ø± Ø´Ù†Ø¨Ù‡ "," Ù¾Ù†Ø¬Ø´Ù†Ø¨Ù‡ "," Ø¬Ù…Ø¹Ù‡ "," Ø´Ù†Ø¨Ù‡" )
monName = new Array ( "Ø¯ÙŠ","Ø¨Ù‡Ù…Ù†","Ø§Ø³ÙÙ†Ø¯","ÙØ±ÙˆØ±Ø¯ÙŠÙ†","Ø§Ø±Ø¯ÙŠØ¨Ù‡Ø´Øª","Ø®Ø±Ø¯Ø§Ø¯","ØªÙŠØ±","Ù…Ø±Ø¯Ø§Ø¯","Ø´Ù‡Ø±ÙŠÙˆØ±","Ù…Ù‡Ø±","Ø¢Ø¨Ø§Ù†","Ø¢Ø°Ø±")
now = new Date
</script>
<script language="javascript">
rr=dayName[now.getDay()]
if (now.getMonth() <= 1 ) { ii=now.getFullYear()-622 } else { if ( now.getDate() <= 21 && now.getMonth() == 2) { ii=now.getFullYear()-622 } else { ii=now.getFullYear()-621 }}
</script>
<script language="javascript" type="text/javascript">
if ( now.getMonth() == 6 || now.getMonth() == 7 || now.getMonth() == 8 || now.getMonth() == 9) { if ( now.getDate() <=22 ) { mm=monName[now.getMonth()] } else {mm=monName[now.getMonth()+1]}}
if ( now.getMonth() == 4 || now.getMonth() == 5 || now.getMonth() == 10 ) { if ( now.getDate() <=21 ) { mm=monName[now.getMonth()] } else {mm=monName[now.getMonth()+1] }}
if ( now.getMonth() == 0 || now.getMonth() == 2 || now.getMonth() == 3 ) { if ( now.getDate() <=20 ) { mm=monName[now.getMonth()] } else { mm=monName[now.getMonth()+1] }}
if ( now.getMonth() == 1) { if ( now.getDate() <=19 ) { mm=monName[now.getMonth()] } else { mm=monName[now.getMonth()+1] }}
if ( now.getMonth() == 11) { if ( now.getDate() <=21 ) { mm=monName[now.getMonth()] } else { mm=monName[now.getMonth()-11] }}
if ( now.getMonth() == 2 || now.getMonth() == 3 || now.getMonth() == 0 ){if ( now.getDate() <=20 ) {mr=now.getDate()+10 } else { mr=now.getDate()+10-30 }}
if ( now.getMonth() == 4 || now.getMonth() == 5 ){ if ( now.getDate() <=21 ) { mr=now.getDate()+10 } else { mr=now.getDate()+10-31 }}
if ( now.getMonth() == 6 || now.getMonth() == 7 || now.getMonth() == 8 ){ if ( now.getDate() <=21 ) { mr=now.getDate()+9 } else { mr=now.getDate()+9-31 }}
if ( now.getMonth() == 10 || now.getMonth() == 11){ if ( now.getDate() <=21 ) { mr=now.getDate()+9 } else { mr=now.getDate()+9-30 }}
if ( now.getMonth() == 9){ if ( now.getDate() <=22 ) { mr=now.getDate()+8 } else { mr=now.getDate()+8-30} }
if ( now.getMonth() == 1 ){ if ( now.getDate() <=20 ) { mr=now.getDate()+11 } else { mr=now.getDate()+11-30 }}
document.write("<font face='Tahoma' size='2' color='#FF0000'>" + rr + ", " +mr+" "+ mm + " " + ii + "</font>")
</script></font>


javascript - -

Submit کردن فرم

دستور چاپ

تاريخ نشر: شنبه 15 مرداد 1384

دريافت نمونه برنامه بصورت js

مبحث: کنترل Eventها

اين مقاله تاکنون 1735 بار خوانده شده است

با استفاده از دستورات فوق میتوانید فرمی را بدون دخالت کاربر به صفحه دیگر ارسال نمایید، نکته قابل توجه این است که کاربر از ارسال فوق موردنظر اطلاع نخواهد داشت.
در قسمت var speed مدت زمانی را که ارسال فرم می بایست به طول بی انجامد را مشخص میکند.

<html>

<head>

<script language="Javascript">
function reload()
{
document.frmRefresh.submit();
}

var speed = 1

function StartRedirectTimer()
{
setTimeout("reload()", speed);
}

//-->
</script>
</head>

<body onload="StartRedirectTimer()">
<b>
Loading...
</b>
<div style="display:none">
<Form id="frmRefresh" name="frmRefresh" action="../Inc/Login.asp" Method="Post">
<INPUT TYPE="HIDDEN" name="Username" Value="Test">
<INPUT TYPE="HIDDEN" name="Password" Value="Test">
<Input Type=Submit>
</Form>
</div>

</body>
</html>