The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Please try the following:

  • If you typed the page address in the Address bar, make sure that it is spelled correctly.
  • Open the home page, and then look for links to the information you want.
  • Click the Back button to try another link.

HTTP 404 - File not found
Internet Information Services

Technical Information (for support personnel)

  • More information:
    Microsoft Support


مقالات طراحی وب
نظر شما لينک مطلب
1383/01/12
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي
Site Meter

لينک

محصولات ماکرومديا
© www.MacromediaX.com - All Rights Reserved


اسکریپت چیست ؟

اسکریپت

زبان های اسکریپتی برای ارائه تحولات و ایجاد پویایی در صفحات وب ایجاد شدند . این زبان ها از روی زبان های برنامه نویسی ساخته شدند و بهمین دلیل دارای تشابه بسیاری با هم هستند . این زبان ها در اصل نمونه کوچک شده زبان های مادر خود هستند . تعدادی از فرمان ها و امکانات زبان های بزرگ در این زبان ها حذف شده اند . مثلا امکان نوشتن فایل یا پاک کردن فایل ها برروی سیستم کاربر مانند زبان های برنامه نویسی وجود ندارد . البته این زبان ها برای استفاده در زمینه کاری شبکه طراحی شده اند و حذف این دستورات علل خاصی ( از جمله بالا رفتن امنیت و ... ) داشته است .

VB Script

این زبان نمونه کوچک شده زبان VB است و کسانی که با ویژوال بیسیک کار کرده اند در یاد گیری این زبان بیشتر راه را پیموده اند و کافیست تفاوت های آن را با ویژوال بیسیک یاد گیرند . این زبان برای افزودن افکت به صفحات وب نیز کاربرد دارد . ولی کاربرد برتر آن در نوشتن برنامه های سمت سرور است که بر اساس تکنولوژی ASP صورت میگیرد . این زبان به عنوان زبان پیش فرض برای نوشتن صفحات ASP است . یاد گیری این زبان برای کسانی که تا کنون برنامه نویسی نکرده اند بسیار آسان است و شروع بسیار خوبی برای ورود به دنیای برنامه نویسی است .

JAVA Script

این زبان ساختاری شبیه زبان C دارد و بیشتر برای ایجاد افکت بر روی کامپیوتر کاربر استفاده میشود (Client-side) .احتمالا تا کنون سایت هایی را دیده اید که در آن کلمه خاصی دنبال موس میدود . یا هنگام وارد شدن به آن سایت مرورگر شما در صفحه ویندوزتان میلرزد . این قبیل کد ها که فقط روی سیستم کاربر اجرا میشوند و نیازی به پردازش توسط سرور ندارند را کد های سمت کاربر (کلاینت ساید) میگویند . البته این زبان نیز قابلیت های استفاده به صورت server-side را داراست . اما چون استفاده از زبان VBS آسانتر است معمولا از VBS برای نوشتن برنامه های سرور-ساید استفاده میشود . یکی از تفاوت های این دو زبان در طرز نوشتن حروف است . در VBS تفاوتی ندارد که دستورات را با حروف کوچک یا بزرگ بنویسید ، اما در JavaScript اگر دستوری که با حروف کوچک است با حروف بزرگ بنویسید با Error در صفحات خود مواجه میشوید.برای دیدن قدرت زبان JavaScript میتوانید از سایت AnfyTeam دیدن کنید . این سایت همچنین امکان دانلود برنامه ای برای ساخت افکت های جاوا اسکریپت خود را در اختیارتان میگذارد .
نظر شما لينک مطلب
1383/01/14
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي
Site Meter


قالب دستوري اكشن اسكريپت

نقطه :

در اكشن اسكريپت نقطه براي نشان دادن خواص يا متدهاي وابسته به يك شيي يا سمبل مووي كليپ استفاده ميشود . همچنين براي تعيين target path در يك مووي كليپ يا متغير ، فانكشن يا آبجكت ها استفاده ميشود . عبارت نقطه دار با نام شيئ يا كليپ موردنظر آغاز شده ، نقطه ميگذاريم و در آخر با يك المان كه توسط شما تعيين ميشود پايان مي يابد .

بطور مثال خاصيت x كه براي مووي ها ميباشد مكان افقي مووي را روي صحنه مشخص ميكند . مثلا عبارت ball.x نشان دهنده مشخصه x از كليپ ball ميباشد .

مثال ديگر : submit يك متغير در كليپ Form است كه در كليپ shop قرار دارد . عبارت shop.form.submit=True مقدار متغير submit از form را True ميكند .

مثال ديگر : عبارت ball.play(); را داريم . play يك متد از كليپ ball است كه باعت اجراي اين كليپ ميشود .

نقطه همچنين با شيي مجازي _root و _parent كار ميكند . شيي مستعار _root به Timeline اصلي بر ميگردد. شما از اين شيي ميتوانيد براي خلق Target path هاي مطلق استفاده كنيد . بطور مثال عبارت زير باعث فراخواني فانكشن Buildgameboard در مووي كليپ functions در Timeline اصلي ميشود .

_root.functions.buildgameboard();

از شيي مجازي _parent براي مراجعه يه يك كليپ كه كليپ كنوني در آن قرار دارد استفاده ميشود . همچنين ميتوانيد براي ساخت target path وابسته استفاده اش كنيد .

آكولاد:

عبارات اكشن اسكريپت توسط آكولاد ها گروه ميشوند .به مثال زير توجه كنيد .

on(release) {

myDate = new Date();

currentMonth = myDate.getMonth();

{

سمي كالن :

عبارات زبان اكشن اسكريپت با سمي كالن پايان ميابد . مثال:

column = passedDate.getDay();

row = 0;

اگر شما سمي كالن پاياني را فراموش كنيد هيچ مشكلي براي اسكريپت شمل پيش نمي آيد اما بهتر است براي شيوايي اسكريپت خود آنرا هميشه بگذاريد .

پرانتز ها :

وقتي شما يك فانكشن تعريف ميكنيد ، بايد پارامتر هاي فرستاده شده در فانكشن را در پرانتز قرار دهيد . مثال :

function myFunction (name, age, reader){

...

}

همچنين براي آسانتر شدن عبارات رياضي در اسكريپت نيز از پرانتز ها بصورت ذيل استفاده ميشود .

(در زبان هاي برنامه نويسي اعمال رياضي بترتيب خاصي در پراسيجر تفسير ميشوند . وقتي يك عبارت رياضي داخل پرانتز باشد محاسبه آن قبل از بقيه عبارت صورت ميگيرد . به مثال زير دقت كنيد :

Total =2+3*5 ;

Total =(2+3)*5 ;

در عبارت اولي ابتدا عمل ضرب و سپس جمع صورت ميگيرد و پاسخ عدد 17 است

در عبارت دوم بعلت وجود پرانتز ابتدا پرانتز محاسه و سپس ضرب صورت ميگيرد و جواب 25 است .

از پرانتز همچنين براي مقدار دهي عبارات استفاده ميشود . قالب كلي آن مانند مثال زير است :

(new Color(this)).setRGB(0xffffff);

اگر بخواهيد از پرانتز استفاده نكنيد بايد از 2 عبارت استفاده كنيد :

myColor = new Color(this);

myColor.setRGB(0xffffff);

حساسيت به حروف كوچك و بزرگ :

فقط كلمات كليدي اكشن اسكريپت به حروف حساسند و در بقيه موارد ميتوانيد از هر دو حالت استفاده كنيد .

شما نميتوانيد از اسم هاي رزرو شده اكشن اسكريپت بجاي نام اشياي خود استفاده كنيد .

اگر كلمات كليدي اسكريپت را از لحاظ كوچكي و بزرگي اشتباه بنويسيد اسكريپت حاصل دچار مشكل خواهد شد . keyword ها در حالت پيش فرض در پنجره اكشن به رنگ آبي هستند

كامنت نويسي :

كامنت ها كد نيستند بلكه جملاتي اند كه طراح در ميان كد ها براي توضيح درباره كد مينويسد تا در رجوع بعدي خود كاري كه انجام داده را بياد آورد . در اكشن اسكريپت از دو بك اسلش پشت سر هم ، براي نوشتن كامنت استفاده ميشود . خطي كه با // شروع شود جزو كد ها به حساب نمي آيد و در كامپايل فايل فلش ناديده گرفته ميشود . در نوشتن كامنت محدوديت لغتي وجود ندارد .

كلمات كليدي :

اكشن اسكريپت تعدادي از لغات خاص را براي استفاده هاي خاص زبان اسكريپت براي خود رزرو كرده كه شما نميتوانيد اين لغات را بعنوان اسم متغير ، فانكشن يا اسامي ليبل استفاده كنيد .

اين كلمات عبارتند از :

break | else | instanceof | typeof
case | for | new | var
continue | function | return | void
default | if | switch | while
delete | in | this | with

ثابت ها :

ثابت ها چيز هايي مانند متغير ها هستند با اين تفاوت كه مقدارشان هرگز تغيير نميكند . بطور مثال ثابت هاي BACKSPACE, ENTER, QUOTE, RETURN از ثابت هاي شيي key هستند كه به كليد هاي كيبورد مربوطند . مثلا براي اينكه بفهميد كاربر كدام كليد را فشار داده از كد زير استفاده ميكنيم .

if(Key.getCode() == Key.ENTER) {

alert = "Are you ready to play?";

controlMC.gotoAndStop(5);

}
نظر شما لينک مطلب
1383/01/16
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آشنایی با سمبل ها در فلش

تفاوت سمبل های Graphic و Movie در فلش :

سمبل های گرافیک معمولا برای ساخت سمبل های ثابت استفاده میشوند و سمبل های movie برای ساخت سمبل های متحرک . ولی اگر به پنجره ویرایش یک سمبل گرافیک بروید میبینید که دارای Timeline است .ولی کاربرد آن در سمبل گرافیک کمی با سمبل Movie فرق دارد. اگر شما یک سمبل Movie متحرک درست کنید میتوانید از آن در یک فریمی که فیلم stop میشود استفاده کنید و این کلیپ در آن فریم حرکت خود را خواهد داشت ، با اینکه فیلم فلش شما ایستاده است. اما اگر در یک سمبل گرافیک ، یک قطعه متحرک بوجود آورید سمبل شما تا وقتی متحرک است که فیلم فلش شما در حال اجراست و به محض ایستادن فیلم در هر فریمی ، آن سمبل نیز از حرکت می ایستد و بصورت ثابت دیده میشود.

استفاده از یک سمبل در سمبل دیگر :

در هنگام import کردن یک عکس در فیلم فلش چند نکته مهم هست .

1- عکس را در کوچکترین سایز ممکن وارد فلش کنید . چون اگر عکس بزرگی را وارد کنید و در فلش با ابزار های transform آن را کوچک کنید علاوه بر افزایش حجم فایل شما ، آن عکس نیز با شفافیت کامل دیده نمی شود.

2- شما میتوانید از عکس هایی که وارد فلش کردید ، سمبل بسازید و سمبل آن را در فیلم فلش نمایش دهید . اینکار باعث میشود ابزار های بیشتری برای کار روی عکس داشته باشید . مثلا از روی عکستان سمبل گرافیک بسازید و آن را وارد صفحه فلش کنید . حالا یک Motion Tween بسازید از این سمبل گرافیک . در فریم کلیدی آخر آن کلیک کنید و سپس روی سمبل گرافیک کلیک کنید . حالا در پنجره properties از منوی بازشوی color گزینه alpha را برگزینید و مقدارش را صفر کنید . خوب ، فیلم فلشتان را اجرا کنید ، میبینید که سمبل شما آرام آرام در صفحه محو میشود .

3- توجه داشته باشید که فلش هنگام ساختن سمبلی از روی سمبل دیگر ، عکس یا شکل های سمبل اولی را در سمبل ساخته شده کپی نمی کند . بلکه سمبل اولی را در سمبل ساخته شده نشان میدهد . بنا بر این پاک کردن سمبل اولی باعث خراب شدن سمبل هایی میشود که سمبل اولی در آنها بکار رفته است.

تغییر خواص سمبل ها با اسکریپت

ما سه نوع سمبل داریم –graphic , movie , botton - از بین این سمبل ها میتوان خواص دو سمبل دکمه و مووی(متحرک ) را براحتی کنترل کرد . برای کنترل هر شیی ابتدا باید نامی به آن بدهیم تا در کد نویسی با آن نام شیئ را خطاب کنیم . روی سمبل مورد نظرتان کلیک کنید و در پنجره properties در سمت چپ یک کادر متنی کوچک میبینید که داخل آن با حروف کمرنگ نوشته شده : instance name روی آن کلیک کنید و نامی برای شیی خود بگذارید . حالا یک دکمه روی فرم بگذارید و کد زیر را برای آن بنویسید ( کد زیر را در حالت expert وارد کنید)

On (release) {

Setproprty(“object”,_alpha,33);

}

درکد فوق object نام شیی مورد نظر و alpha نام خاصیت مورد نظر و 33 مقدار داده شده به خاصیت آلفا میباشد . خاصیت آلفا همانطور که میدانید میزان پدیدار بودن شیئ را تعیین میکند و کم کردن آن باعث محو شدن شیی میشود .

خواص دیگری که میتوانید مقدارشان را تعیین کنید عبارتند از :

_rotate میزان چرخش شیی

_height ارتفاع سمبل

_width طول سمبل

_x,_y نیز محل قرار گیری سمبل در صفحه هستند .

_visible نیز قابل دید بودن یا نبودن شیئ را معلوم میکند که باید مقدار آنرا بجای عدد ، True یا False بگذارید .
نظر شما لينک مطلب
1383/01/17
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


Action Script - FScommand

چگونه در فلش فایل exe بسازیم ؟

همانطور که اکثرا میدانید برای ساخت فایل های اجرایی با فلش بعد از ساخت فایل swf به منوی فایل رفته و سپس روی گزینه publish setting کلیک میکنیم . در پنجره ای که باز میشود گزینه windows projector را تیک میزنیم . حالا برای ساخت فایل exe دکمه publish را میزنیم . فایل exe ما آماده است . اما این فایل یک فیلم فلش است که همیشه در پنجره flash player اجرا میشود . با این فرق که اجراگر فلش همراه فایل ، ضمیمه شده است و در دستگاه هایی که این player را ندارند اجرا میشود . در ضمن برای اینکه کاربر فلش شما را ببندد باید flash player آن را ببندد . حال برای اینکه یک دکمه خروج در برنامه بگذاریم چه میکنیم ؟

اکشن اسکریپت fscommand

یک دکمه روی فیلم خود بگذارید . حال آنرا انتخاب کنید و با زدن دکمه F9 پنجره Actions را باز کنید . کتاب Actions و سپس کتاب Browser/network را باز کنید و روی fscommand را دوبل کلیک کنید . حالا از منوی بازشوی سمت راست ، گزینهquit را انتخاب کنید . حال زدن این دکمه توسط کاربر در برنامه باعث بسته شدن فیلم فلش میشود ! .

اکشن اسکریپت برای full screen شدن

یک دکمه روی فیلم خود بگذارید . باز هم fscommand را دوبل کلیک کنید و اینبار از منوی سمت راست آن fullscreen را برگزینید. میبینید که در جعبه متنی بالای آن نام fullscreen و در قسمت پارامتر true نوشته شده است .این هم کد کامل آن که فلش برای شما ساخته است .

on (release) {

fscommand("fullscreen", "true");

}

اگر خواستید فیلم با زدن دکمه از حالت فوق خارج شود خودتان پارامتر true را به false تغییر دهید .

تغییر سایز فلش با سایز صفحه شما

اگر بخواهید فیلم فلش شما هنگامی که کاربر سایز FLASH PLAYER را عوض میکند ثابت بماند باید در منوی بازشوی fscommand گزینه allowscale را مساوی false قرار دهید . این هم کد کامل آن :

on (release) {

fscommand("allowscale", "false");

}
نظر شما لينک مطلب
1383/01/23
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


سرور افزار Flash Communication Server MX

Macromedia Flash Communication Server MX 1.5

این برنامه برای ساخت و گسترش برنامه های بر پایه وب مانند چت وب کم ، برنامه های مولتی مدیای بر پایه وب و پروژه های چند کاربره استفاده میشود.

نوآوری های ورژن 1.5:

Video on Demand

قدرت بالا در ارائه مدیا های گوناگون بصورت جریان دار در وب – سرعت بالا و بافرگیری مناسب بهمراه محیط قابل گسترش فلش

WebCam Chat

کپچر آسان از وب کم و جریان دار کردن صدا و تصویر بصورت چند راهه شما را برای افزودن چت وب کم و پیام های ویدئویی به سایتتان تشویق می کند .

Real-Time Collaboration

جریان سازی صدا و تصویر با کنترل گر چند کاربره و نیز توانایی افزودن متن و دیتا بهترین پلتفرم را برای برنامه های چند کاربره فراهم میکند.

در ضمن : سايت یاهو برای سرویس های ویدئو آنلاین(جریان دار) از فلش ام ایکس و فلش کام سرور ام ایکس استفاده کرده است.
نظر شما لينک مطلب
1383/01/25
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


سرور افزار Macromedia Breeze

ماکرومدیا بریز ، یک نرم افزار سمت سرور است که برای ساخت آرشیو های مولتی مدیا بر روی سایت ها مورد استفاده قرار میگیرد . پلتفرم ارائه اطلاعات بریز شما را قادر میسازد تا نمایش اطلاعات را در سایت خود جذاب تر کنید . با این سیستم مدیریت اطلاعات شما میتوانید دوره های آموزشی آنلاین در سایت خود برگزار کنید و اطلاعات بانک خود را بصورت یک آرشیو قابل جستجو در آورید .برای آگاهی شما از سطح سواد کسانی که دوره های سایت شما را میگذرانند میتوانید براحتی امتحان و کوئیز بصورت آنلاین برگزار کنید .

قالب ارائه اطلاعات Breeze :

  • تالیف محتویات : پس از تالیف و ویرایش کار خود در برنامه پاور پوینت مایکروسافت ، براحتی میتوانید quiz های مختلف را به آن اضافه کرده و محتویات و اطلاعات دسته بندی شده تان را پوبلیش کنید . فایل ها و ترک های صوتی ای که اضافه کرده اید بطور اتوماتیک برای پخش بر روی وب بهینه میشوند .
  • مدیریت محتویات : فایل های مدیای خود - که شامل فلش ، پاورپوینت ، ویدئو ها و ... میشوند – را در کتابخانه محتویات Breeze ذخیره میکنید و میتوانید هر جا و هر زمانی به آنها دسترسی داشته باشید ، مدیریتشان کنید و دانلود نمایید . همچنین ابزار های جداگانه ای برای دسترسی به اطلاعات محرمانه برای شما فراهم شده است .
  • مدیریت پخش : شما میتوانید از Flash Player برای پخش فایل های خود بر روی سیستم کلاینت استفاده کنید تا کاربران مجبور به دانلود برنامه جدیدی جهت دسترسی به اطلاعات سایت شما نباشند.
  • مدیریت کاربران : براحتی میتوانید group یا user های بسیاری تعریف کنید و برای هر کاربر یا گروه های کاربری ، میزان دسترسی خاصی را تعریف کنید .

نمونه کار بريز که در فلش اجرا ميشود .
نظر شما لينک مطلب
1383/01/26
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


سرور افزار Macromedia Flex
معرفی ماکرومدیا فلکس :

سرور افزار ماکرومدیا فلکس یک قالب برنامه نویسی استاندارد و راحت را همراه با دسته ای از اشیاء قدرتمند برای خلق صفحات وب ایجاد کرده است .فلکس همچونXML تحت فلش است .بله ،ماکرومدیا نیز محیطی جذاب با قدرتی دو چندان را در برابر چشمان مایکروسافت برپا کرد.فلکس MXML توليد ميکند .

Flex ; A Flash Generator

کارهایی که قبلا با نرم افزارهای مرسوم صورت میگرفت اکنون با فلکس بصورت حرفه ای تر قابل انجام است .

· تعریف کردن آبجکت کلاس(object class) مناسب برای برنامه ها

· انتخاب ارتباط مناسب بین اشیاء تعریف شده ( وراثت ، اجتماع ، ...) .

· تعریف زیربنای مناسب برای برنامه ها برای ارتباط با سرویسهای راه دور

· ایجاد یک قالب کاری مناسب برای برنامه ها

ساخت یک برنامه فلکس دقیقا مانند ساخت یک برنامه جاوا یا دات نت یا هر سیستم شیی گرای دیگر است. همانگونه شما کلاس ها را میسازید و کامپایل میکنید . نمودار فلکس سه نوع کلاس را با کلاس های رابط کاربر که توسط MXML و ماژول های اکشن اسکریپت تکمیل شده ، ارائه میکند .کلاس های کنترل کننده فلکس ، سرویس دهنده های وب و اتصال دهنده هایی هستند که جرئی از قابلیت های مدیریت اطلاعات فلکس به حساب می آیند .

با فلکس طراحان میتوانند اطلاعات را بصورت فانکشن هایی ذخیره و بصورت تگ ها بازیابی کنند. این عمل باعث سادگی در بازیابی اطلاعات و نیز گسترش تیم طراحی میشود . همه طراحان گروه ، نیازی به دانستن نحوه خلق کامپوننت ها ندارند بلکه بسادگی میتوانند از آن بعنوان یک تگ استفاده کنند.

ماژول رویداد :

برای افزایش قابلیت بازیابی و استفاده ، فلکس طراحان را قادر میسازد تا از کامپوننت های ارتباطی و ماژول رویداد بصورت متصل بهم استفاده کنند که این حالت برای برنامه نویسان جاوا و دات نت بسیار آشناست . ماژول رویداد به کامپوننت ها اجازه میدهد تا بصورت یک دریافت کننده رویداد در آیند تا بتوانند رویدادهای رخ داده رادریابند .

مدیریت اطلاعات :

شما به سه روش میتوانید به اطلاعات داینامیک دست یابید :

1- با استفاده از وب سرویسز

2- فراخوانی آبجکت اتصال جاوا

3- XML های روی http

فلکس راهی ساده را به شما ارائه میکند . شما کافیست سرویس دهنده وب خود را در فایلWSDL به فلکس معرفی کنید و سپس با خیال راحت قهوه خود را بنوشید ، چون باقی کار ها را فلکس انجام میدهد .DATA Binding در فلکس به شما این امکان را میدهد که میزان پراپرتی یک کامپوننت را به پراپرتی یک کامپوننت دیگر وابسته سازید و از آن بعنوان یک گیرنده اطلاعات استفاده کنید . این در حالیست که برای نشان دادن اطلاعات در کامپوننت های User Interface نیز کدنویسی شما بسیار مختصر شده است .

کامپوننت های اکشن اسکریپت :

اکشن اسکریپت 2 یک زبان شیی گرای طبقه بندی شده است و بسیار شبیه کلاس جاوا یا سی شارپ است . شما میتوانید برای اعمال کنترل روی ساخت کلاس های فلکس از این زبان استفاده کنید .

Cascading Style Sheets :

فایل main.css فونت ها و رنگ ها را در برنامه تنظیم میکند . همچنین در فلکس میتوانید از CSS های استاندارد استفاده کنید تا بدون دستکاری در این فایل از قالب های css استفاده کنید .

مدیریت برنامه :

فلکس شامل یک سری از مدیریت کننده هاست که شما را قادر میسازد بسادگی MXML و اکشن اسکریپت ها را اجرا و کنترل کنید . بطور مثال فلکس شامل یک مدیریت تاریخچه (History) است که شما را قادر میسازد هنگام رویدادهای Back و Forward در برنامهء مرورگر ، کنترل را در دست داشته باشید وهمچنین یک برنامه مدیریت Drag-n-Drop که ابزار خوبی برای بالا بردن توانایی های برنامه شماست . با برنامه مدیریت Tooltip شما میتوانید با تنظیم یک خاصیت کوچک ، هرکدام از کامپوننت های بصری را مجهز به ToolTip کنید .
نظر شما لينک مطلب
1383/01/30
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


Microsoft InfoPath 2003 چیست ؟

این برنامه ابزار جدید مایکروسافت برای طراحی فرم های اداری است که امکان ساخت فرم ها و نیز ارتیاط آنها را با بانک های اطلاعاتی تضمین میکند .

پس از پر کردن فیلد های یک فرم شما میتوانید اطلاعات ثبت شده در فرم را برای دسته بندی و نگه داری به یک برنامه مانند exel بفرستید تا در آن ثبت شود و قابل چارت بندی و ارائه مجدد باشد . همچنین در این برنامه شما میتوانید اطلاعات چندین فرم را در یک فرم بازیابی کنید .

اتصال با XML :

استفاده از XML و سرویس های وب بصورت گسترده ای مورد استفاده است . اما در حالیکه سرور ها ، بانک های اطلاعاتی و خیلی ابزار های دیگر ، XML را پشتیبانی میکنند ، هنوز برنامه هایی هستند که با این تکنولوژی همخوانی ندارند . مثلا لیست هزینه های ماهانه خود را که در word یا Excel نوشته اید نمیتوان براحتی به XML منتقل کرد و علت در قفل بودن ساختار این برنامه هاست ، پس انتقال باید بصورت دستی و توسط یک نفر انجام شود ... اما هم اکنون این قابلیت فراهم شده که شما این اسناد آفیس را توسط ابزار های آفیس بصورت XML های قابل استفاده در وب در آورید .

برنامه InfoPath 2003 شکاف ارتباطی میان بانک های اطلاعاتی و XML و مدل ها و سرویس های وب را برداشته است و شما را برای فرستادن اطلاعات خود بر روی وب همراهی میکند .

ویرایشگر اسکریپت مایکروسافت (MSE) حالت سند بندی فوق العاده ای را برای گسترش دهندگان فراهم کرده است و شامل مرجع کاملی به سرویس های XML و زبان های VBscript و Jscript میباشد.
نظر شما لينک مطلب
1383/02/01
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


Join کردن بيش از ۲ جدول براي Database هاي Access

کتاب ColdFusion MX Bible براي Join کردن بيش از دو جدول يک بانک اطلاعاتي راه حل زير را پيشنهاد مي کند:

SELECT
  c.CompanyID,
  c.CompanyName,
  e.LastName,
  e.FirstName,
  e.Salary,
  d.FullName,
  d.RelationShip
FROM
  Company c INNER JOIN Employee e
  ON c.CompanyID = e.CompanyID
  INNER JOIN Dependant d
  ON e.SSN = d.SSN
که در بيشتر برنامه هاي Database Server درست عمل مي کند.
اما در بانکهاي اطلاعاتي Microsoft Access پيغام خطايي با توضيح زير مي دهد :
Operator expected
من پس از يک کم جستجو در کتاب ها و پرسش از ديگران ، يک دوست آمريکايي من راه حل زير را پيشنهاد داد. در اکسس در برخي قسمت ها وجو د پارانتز الزامي است با اينکه در انواع ديگر بانک هاي اطلاعاتي نيازي به آن پارانتز ها نيست. يعني کد مورد نظر را بايد به صورت زير باز نويسي کنيم :
SELECT
  c.CompanyID,
  c.CompanyName,
  e.LastName,
  e.FirstName,
  e.Salary,
  d.FullName,
  d.RelationShip
FROM
  (Company c INNER JOIN Employee e
  ON c.CompanyID = e.CompanyID)
  INNER JOIN Dependant d
  ON e.SSN = d.SSN

و يک نمونه ي ديگر در اتصال ۴ جدول :
SELECT
  cfarticle.id,
  cfarticle.title,
  cfarticle.description,
  cfarticle.dateadded,
  editorial.authorname as author,
  categories.name,
  levels.levelname
FROM
  ((cfarticle INNER JOIN categories ON cfarticle.category=categories.id)
   INNER JOIN editorial ON cfarticle.author=editorial.id)
    INNER JOIN levels ON cfarticle.skllevel=levels.id
نظر شما لينک مطلب
1383/02/05
هادی مشیدی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


مدارک بین المللی مایکروسافت
  • مدرك MCSA: مدرك MCSA Microsoft Certified System Administor به افرادی داده می‌شود كه در زمينه مديريت شبكه و محيط‌های سيستمی مبتنی بر سيستم عامل‌های ويندوز، مهارت كافی داشته باشند.

    درحال حاضر، اين مدارك روی ويندوز 2000 داده می‌شود و برای كسب آن بايد از توانايی مديريت اين سيستم عامل و مديريت شبكه با استفاده از آن برخوردار بود. كسی نامزد دريافت اين مدارك می‌شود و برای كسب آن در آزمون شركت می‌كند. بايد 6 تا 12 ماه تجربه پياده كردن و مديريت يك سيستم عامل روی رايانه شخصی، پياده كردن و مديريت يك سيستم عامل روی شبكه و مديريت شبكه‌هايی با بيش از 200كاربر را داشته باشد.
  • مدرك MCSE: افرادی كه به تحليل نيازهای يك طرح تجاری، طراحی و پياده كردن يك زيرساخت مبتنی بر محصولات و سيستم عامل‌های مايكروسافت می‌پردازد و بر اين اساس ، راه حل‌هايی را به كارفرمايان ارائه می‌دهند. مدرك Microsoft Certified Systems Engineer را به عنوان تاييد توانايی‌هايشان اخذ می‌كنند. در واقع، اين مدرك برای مهندسان سيستم، مهندسان پشتيبانی فنی، تحليلگران سيستم، تحليلگران شبكه و مشاوران فنی مناسب است. اين مدرك، از پرطرفدارترين و معروف‌ترين مدارك فنی به حساب می‌آيد.كسی كه برای كسب اين مدرك اقدام می‌كند، بايد دست كم تجربه‌ای يك ساله در پياده كردن و مديريت يك سيستم عامل تحت شبكه با 2000 كاربر و در 5 نقطه فيزيكی داشته باشد. علاوه بر آن، نامزد MCSE بايد دست كم يك سال تجربه در زمينه پياده كردن و مديريت سيستم عامل روی رايانه شخصی و طراحی زيرساخت شبكه داشته باشند.
  • مدرك MCDBA : مخفف عبارت Microsoft Certified Database Administrator به مديران پايگاه داده‌های DATABASE SQL اختصاص دارد. كه به طراحی، پياده سازی و مديريت اين كارگزار (Server) مشغولند. در حال حاضر، اين مدرك روی SQL Server 2000 ارائه می‌شود.
  • مدرك MCT: دارندگان مدرك ( MCT (Microsoft Certified Trained استادانی هستند كه از سوی مايكروسافت، برای تدريس و آموزش دوره‌های مايكروسافت تاييده شده‌اند. برای دريافت اين مدرك بايد يكی از ديگر مدارك MCP را داشت.
  • مدرك MCAD : كه مخفف عبارت Microsoft Certified Application Developer می‌باشد. مدركی است برای كسانی كه از فناوری‌های مايكروسافت برای توسعه و نگهداری برنامه‌های كاربردی، برنامه‌های تحت وب و سرويس‌های داده اي استفاده می‌كنند. افرادی كه به XML يا.NET تسلط دارند و از آنها برای ارائه برنامه‌های مختلف استفاده می‌كنند. در اين گروه قرار می‌گيرند. كسانی كه برای دريافت اين مدرك، نامزد می‌شوند بايد يك يا 2سال تجربه در اين زمينه داشته باشند. برنامه نويسان، تحليلگران برنامه و توليدكنندگان نرم‌افزار می‌توانند برای كسب اين مدرك اقدام كنند.
  • مدرك MCSD: دارندگان مدرك Microsoft Certified Solution Develper افرادی هستند كه با فناوری‌ها، سيستم‌های عامل و معماری ويندوز، راهكارهای مناسبی را برای صاحبان صنايع و تجارت طراحی كرده و توسعه می‌دهند. دست كم يك تجربه 2ساله كاری برای خواستاران اين مدرك لازم است. مهندسان نرم‌افزار. تحليلگران و توليدكنندگان برنامه‌های كاربردی و مشاوران فنی كسانی هستند كه داشتن اين مدرك را به آنها توصيه می‌كنيم.
  • مدرك MOS : Microsoft Office Specialist به كسانی داده می‌شود كه در كار با مجموعه نرم‌افزارهای Office يعنی Word,Excel, outlook,powerpoint, Access و MS project مهارت كافی داشته باشند. از آنجا كه مجموعه Office در بيش از 100كشور و با 18 زبان در اختيار كاربران قرار می‌گيرند. می‌توان آن را فراگيرترين مدرك مايكروسافت دانست. بد نيست بدانيد كه ماهانه 32هزار نفر در سراسر دنيا اين مدرك را دريافت می‌كنند.
  • مدرك Microsoft Office Specialist Master Instructor : اين مدرك به كسانی داده می‌شود كه برای تدريس بخش‌های مختلف Office مهارت كافی داشته باشند. خواستاران اين مدرك بايد دست كم از 2 سال تجربه تدريس اين نرم‌افزارها بهره مند باشند.
نظر شما لينک مطلب
1383/02/10
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آشنايي با زبان اسکريپتي جاوا اسکریپت

اگر کمی با دنيای وب آشنايی داشته باشيد حتما در مورد جاوا اسکريپت شنيده ايد و هرگاه در مورد حرکات عجيب و غريب بعضی از سايت ها از دوستان پرسيده ايد آنها را به جاوا اسکريپت نسبت داده اند. حرکاتی مانند حرکت یک عکس یا متن بدنبال موس ، لرزیدن صفحه هنگام ورود به یک وبلاگ ، منوهای پایین افتادنی در سایت ها و ...

اما جاوا اسکريپت چيست؟

جاوا اسکريپت زبانی است که در صفحات html کاربرد دارد و قابليتهای بسياری از قبيل : افزايش کيفيت طراحی صفحات , کنترل صفحات ، کنترل browser بازديد کننده ، ساخت و استفاده cookie ها و بسياری چيزهای ديگر.

اطلاعات پيش نياز چيست؟

فقط HTML /XHTML ، البته کمی هم ديد برنامه نويسی لازم است .اما ما تمامی مبانی آنرا به شما آموزش ميدهيم و شما احتياجی به دانستن زبان برنامه نويسی جداگانه نداريد ولی کمی ديد برنامه نويسی لازم است.

JavaScript يک زبان برنامه نويسي اسکریپتی است که کدهای آن بسيار شبيه به زبان C است . زبان جاوا اسکریپت به حروف بزرگ و کوچک حساس ميباشد. ). زبان JavaScript يک زبان برنامه نويسي "شي گرا" ميباشد. از آنجا که JavaScript يک متن ساده ميباشد، در نتيجه ميتوان از هر ويرايشگر متن کمک گرفت، در سيستم ويندوز اغلب کاربران از برنامه notepad استفاده ميکنند

تفاوت جاوا و جاوا اسکریپت :

برخلاف شباهت اسمي موجود برنامه Java و JavaScript، هيچگونه شباهتي بين اين دو برنامه وجود ندارد. Java يک زبان برنامه نويسي بسيار کامل و پيشرفته اي است که توسط شرکت sun microsystem تهيه شده و جاوا اسکریپت توسط شرکت netscape.( اساس Java در برنامه هاي client-side براي ايجاد appletها ميباشد، اين برنامه هاي کوچک توسط شبکه اينترنت دريافت شده و درون خود browserها اجرا ميشوند بطوريکه بعلت وجود قابليت همه گير Java، اين برنامه در تمامي browserهايي که قابليت اجراي Java را دارند، کار ميکنند

مزايای جاوا اسکريپت :

· جاوا اسکريپت بر خلاف vbscript در همه browser ها قابل استفاده و خوانده شدن است.

· جاوا اسکريپت قابليت برنامه نويسی را به صفحات HTML شما ميدهد.

· جاوا اسکريپت صفحات HTML شما را پويا ميکند.

· جاوا اسکريپت به رويدادها پاسخ ميدهد ( مثل کليک موس،load شدن صفحه و ...)

· جاوا اسکريپت قابليت ارزيابی و تغيير روی اطلاعات را دارد.

· جاوا اسکريپت قابليتهای زيادی در کنترل browser بيننده دارد.

· جاوا اسکريپت ميتواند cookie بسازد و استفاده کند

و اما شروع ساده ای از جاوا اسکريپت :

چگونه کد جاوا اسکريپت بنويسيم:

برای وارد کردن اسکريپت در خطوط کد HTML از تگ <script> استفاده ميکنيم و سپس در قسمت Type نوع اسکريپت را مشخص ميکنيم :

<script type="text/JavaScript">

و سپس کد مورد نظر را وارد ميکنيم :

Document.write("It's Java Script")

و در انتها بايد تگ اسکريپت را ببنديم :

</script>

نکته ای در مورد سميکالون(;) :

هنگامی که شما کدهای جاوا يا C را مينويسيد در انتهای هر خط کد از سميکالون استفاده ميکنيد، اما اين امر در جاوا اسکريپت کاملا اختياری است ، البته برای زمانی که شما چند کد را در يک خط قرار ميدهيد استفاده از سميکالون اجباری است.

اميدوارم درس امروز مفيد بوده باشد در درس بعدی درباره نحوه استفاده از جاوا اسکريپت توضيح خواهيم داد و در انتهای هر درس يکی از کدهای جالب جاوا اسکريپت را برای شما در سايت قرار خواهيم داد.

منابع جاوا اسکريپت: جاوا اسکريپت دات آي آر javascript.internet.com javascriptkit
نظر شما لينک مطلب
1383/02/13
مازيار بهره دار

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


The search key was not found in any record

Microsoft JET Database Engine error '80040e21'

The search key was not found in any record.

/myfile.asp, line 113

یه روز یه برنامه ASP که از بانک اطلاعاتی ACCESS استفاده میکرد نوشته بودم که وقتی فرمان update يا delete را بر روی بانک اعمال ميکردم پيام فوق برام می آمد و به من میگفت که چنین رکوردی در بانک وجود ندارد.این در حالی بود که وقتی Query میگرفتم همه چیز درست بود . فکر کردم مشکل از سرور است .دیتابیس رو از سایت دانلود کردم تا رکورد موردنظر را در اکسس بصورت دستی پاک کنم ، اما با کمال تعجب دیدم که در حالی که رکورد موردنظر جلوی چشمان منه ، میگه چنین رکوردی موجود نیست . هر چی کتاب در این زمینه داشتم زیر و رو کردم ، اما چیزی پیدا نکردم . یه دفعه یاد یه کتابخانه خیلی بزرگ افتادم که میدونستم حتما حداقل یه مقاله در این مورد توش هست ! بله ، اینترنت !

مشابه این برنامه را قبلا نوشته بودم و درست کار میکرد .اما این برنامه با قبلی کمی فرق داشت . این برنامه در بانک اطلاعاتی اش دارای یک فیلد MEMO بود . بانک اکسس من صدمه دیده بود و برای درست کردن آن راه زیر را پیدا کردم :

  • برای تعمیر دیتابیس : اگر بانک روی سرور است آنرا دانلود کنید و در اکسس آن را باز کنید . به منوی Tools بروید و 'Database Utilities را باز کنید و Compact and Repair Database را انتخاب کنید . با اینکار اکسس دیتابیس را تعمیر میکند . حال آنرا ذخیره کنید و دوباره میتوانید رکورد ها را حذف یا آپدیت کنید.

این کار را کردم ودرست شد و من دیتابیس را آپلود کردم . اما بار دیگر این اتفاق افتاد .خوب ، باید یه راه درستی باشه که از بروز این مشکل پیشگیری کنه، نمیشه که هر روز من فایل رو دانلود کنم. ( همیشه پیشگیری بهتر از درمان است ) و بالاخره راه حل را یافتم .

  • برای پیشگیری از بروز مشکل : فیلد MEMO نباید Index آن برابر YES باشد . چون فیلد های memo نمی توانند اندیس داشته باشند این مشکل روی میدهد .
  • یک مشکل و یک راه دیگر : این مشکل در موقعی که نام یک فیلد دارای فاصله باشد نیز روی میدهد . هنگام استفاده از درایور ODBC با یک کرسر سمت سرور ، اجازه آپدیت داده نمیشود و بجای آن ADO یک فرمان SQL برای آن میسازد ، ولی از گذاشتن علامت [ ] در اطراف نام فیلد غفلت میکند و این امر باعث ایجاد Error میشود . برای پیشگیری از این مشکل در نام فیلد از فاصله استفاده نکنید و یا بجای ADO از فرامین SQL استفاده کنید .

با تشکر از : ASP Free Forums
نظر شما لينک مطلب
1383/02/15
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


ColdFusion مقدماتی، قسمت اول

مقدمه

Coldfusion ، توليد شده توسط شرکت Allaire (در سال 2001 Allaire به Macromedia پيوست)، شامل يک سرور و مجموعه ابزارهايی برای استفاده از پايگاه داده ها در صفحات وب می باشد. با استفاده از ColdFusion، شخصی می تواند نامی را در يک صفحه وب وارد کند، و سرور اطلاعات مربوط به آن نام را از پايگاه داده درخواست کند و اطلاعات استخراج شده را به صورت صفحات HTML نشان دهد.

برنامه های ColdFusion در فايل هايی با پسوند .cfm ذخيره می شوند. برنامه های ColdFusion، دارای تگ هايی می باشند که ارتباط با پايگاه داده و کار با داده ها را آسان می سازد. اين تگ ها با CF شروع می شوند. مانند : CFQuery، CFMail و ...

شروع کار

برای اجرای سرور coldfusion :

1- اگر در ويندوز 98 هستيد، Start->Macromedia ColdFusion MX -> ColdFusion MX Start

2- اگر از ويندوز 2000 يا XP استفاده می کنيد،

Control Panel -> Administrative Tools -> Services

سپس ، از پانل سمت راست، ColdFusion MX Application Server را پيدا کنيد و راست کليک کرده و start را انتخاب کنيد.

اولين برنامه ColdFusion شما

برای نوشتن يک برنامه ColdFusion به يک ويرايشگر نياز داريد. اين ويرايشگر می تواند هر ويرايشگر مورد علاقه شما مانند : HTML-Kit، HomeSite، Notepad و ... باشد. فقط بايد فايل خود را با پسوند .cfm و بصورت متنی ذخيره کنيد. من برای نوشتن مثال های اين مقاله از Notepad ويندوز استفاده کرده ام.

1- Notepad را باز کنيد.

2- کد زير را تايپ کنيد :

<HTML>

<HEAD>

<Title>

Salam

</Title>

</HEAD>

<Body>

<CFSet MyVar="Hello World" />

<CFOutput>#MyVar#</CFOutput>

</Body>

</HTML>

3- يک دايرکتوری جديد به نام mysite در زيرشاخه wwwroot کلدفيوژن ايجاد کنيد.

4- فايل خود را در دايرکتوری جديد با نام MyPage.cfm ذخيره کنيد.

دقت کنيد که “Save As Type” را برابر All Files (*.*) قرار دهيد تا با پسوند txt ذخيره نگردد.

1- يک پنجره Internet Explorer باز کنيد و به آدرس زير برويد :

http://localhost:8500/mysite/MyPage.cfm

http://localhost:8500/ به مسير زيرشاخه wwwroot مسيری که ColdFusion در آن نصب شده است اشاره می کند در اينجا C:\CfusionMX\wwwroot. و بقيه آدرس مسير فايل مورد نظر نسبت به wwwroot می باشد.

توضيح برنامه بالا :

<HTML>

<HEAD>

<Title>

Salam

</Title>

</HEAD>

<Body>

< "CFSet MyVar="Hello World>

<CFOutput>#MyVar#</CFOutput>

</Body>

</HTML>

قسمت های سبز کد بالا کد HTML معمولی می باشند.

و اما قسمت های سياه کد بالا :

<CFSet MyVar=”Hello World” />

يک متغير به نام MyVar ايجاد می شود و مقدار آن برابر "Hello World" قرار می گيرد. کلا برای ايجاد و مقدار دهی به متغير ها دو راه وجود دارد. راه اول استفاده از CFSet می باشد که پس از نوشتن CFSet نام متغير و سپس علامت مساوی و سپس مقدار جديد متغير را می نويسيم. راه دوم، استفاده استفاده از CFParam به شکل زير می باشد :

<CFParam name=”MyVar” default=”DefaultValue”>

اگر متغيری به نام MyVar وجود نداشته باشد، با اجرای خط بالا، متغيری با نام MyVar و مقدار DefaultValue ايجاد می گردد و اگر از قبل متغيری با نام MyVar وجود داشته باشد هيچ اتفاقی نمی افتد. يعنی متغير MyVar مقدار پيشين خود را حفظ می کند.

و اما خط زير :

<CFOutput>#MyVar#</CFOutput>

عبارات بين <CFOutput></CFOutput> مورد بررسی قرار می گيرد و هر عبارتی که بين ## قرار داشته باشد، مقدار معادل آن جايگزين می گردد. مثلا در مثال بالا، بجای #MyVar# ، Hello World جايگزين می شود.

پس از اجرای کد بالا، کد HTML زير به عنوان نتيجه کد ColdFusion ايجاد می گردد و به مرور گر کاربر فرستاده می شود :

<HTML>

<HEAD>

<Title>

Salam

</Title>

</HEAD>

<Body>

Hello World

</Body>

</HTML>

متغير ها در ColdFusion

قوانين نام گذاری متغير ها :

1- نام متغيرها تشکيل شده است از يک حرف بعلاوه چندين کاراکتر حرفی، عددی يا underscore.

2- نام متغيرها بايد يک کلمه باشند و دارای space نباشند.

3- از حروف خاص مانند ! يا ? در نام گذاری متغيرها نمی توانيد استفاده کنيد.

4- نام متغيرها حساس به کوچکی و بزرگی حروف نمی باشند.

برای نشان دادن مقدار يک متغير از <CFOutput> به شکل زير استفاده می کنيم:

<CFOutput>

# This is the Value for a variable : #MyVar

</CFOutput>

MyVar نام متغير می باشد. بقيه عبارت به همان صورت به خروجی فرستاده خواهند شد.

پایان قسمت اول

هرگونه پیشنهاد و سوال خود را به irancoldfusion@yahoo.com ايميل بزنيد. در قسمت بعد نحوه کار کردن با پايگاه داده را ياد خواهم داد.
نظر شما لينک مطلب
1383/02/22
هادي مشيدي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


متاتگ چیست ؟

متاتگ ها راهی برای شناساندن وب سایت شما به جهان خارج است . عنوان تگ هایی که برای صفحات سایت خود تعریف میکنید موتور های جستجوگر را در شناختن مطالب داخل سایت شما یاری میکند .

دو نوع اصلی متاتگ وجود دارد :

این متاتگ باعث میشود که اطلاعات اضافی ای همراه صفحه وب درخواستی شما در http header به مرورگر ارسال شود . مثلا میتوانید تاریخ انقضای اطلاعات را تعیین کنید یا میتوانید صفحه وب را با یک متا تگ خاص پس از چند ثانیه به صفحه دیگری بفرستید بدون دخالت کاربر ! | HTTP-EQUIV
این نوع از متاتگ برای تعیین اطلاعات داخل صفحه وب استفاده میشود که باعث میشود صفحه وب شما با راحتی بیشتری برای موتورهای جستجوگر شناخته شود ... مثلا زبان این صفحه ، نام طراح ، کلمات کلیدی این صفحه و ... | NAME

متاتگ ها کجای صفحه وب نوشته میشوند ؟

متاتگ ها را باید داخل تگ head نوشت . در صفحه هایی که از چند فریم درست شده باید در تمام صفحات متاتگ را نوشت.

به مثال های زیر دقت کنید : content در متاتگ کارش معرفی مقداری هست که متاتگ با یکی از دو صفت name و HTTP-EQUIV در خود دارد .

مثال : NAME="keywords" CONTENT=" persian macromediax dreamweaver">

تگ بالا را یه نگاه کنید . از نوع name است . مقدار name مساوی با keywords است . یعنی این متاتگ کارش شناساندن کلمات کلیدی سایت به موتور های جستجوگر است ... اگر میخواهید موتور های جستجو مانند گوگل سایت شما را بهتر بشناسند این تگ را به قالب سایت یا وبلاگ خود بیفزایید و در جلوی content کلمات کلیدی سایت خود را بنویسید .

مثال : NAME="description" CONTENT=" persian web design center">

تگ بالا کارش افزودن توضیحات سایت شما به موتور های جستجوگر است . اگر این تگ را به وب سایت یا وبلاگ خود اضافه کنید از ماه آینده اگر کسی بصورت تصادفی در گوگل به سایت شما بر بخورد توضیحات داخل این متا تگ را بجای توضیحات میبیند . یعنی گوگل دقیقا از این متاتگ برای ذخیره اطلاعات درباره سایت شما استفاده میکند . پس بکاربردن این متا تگ ها خیلی مهمه !

مثال :<META HTTP-EQUIV="Expires" CONTENT="Tue, 04 Dec 1993 21:29:02 GMT">

تگ بالا تاریخ انقضای این صفحه وب را تعیین میکند . یعنی اگر کسی این صفحه وب را یکبار دیده باشد وقتی این زمان فرا برسد و او دوباره آدرس این سایت را در مرورگرش بزند این صفحه از داخل cache لود نمیشود بلکه از سرور دانلود میشود .

منابع : htmlhelp.com و html-reference.com
نظر شما لينک مطلب
1383/02/24
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


اکشن اسکریپت ، یک زبان شیئ گرا

به چه چيز هايي ميتوان Action Script داد ؟

دكمه ها ، فريم ها و مووي كليپ ها ميتوانند اكشن اسكريپت بگيرند .

  • براي ربط دادن يك كد اسكريپت به فريم بايد ابتدا روي فريم موردنظر كليك كنيد و سپس وارد پنل اكشنز شويد و كد هاي خود را وارد كنيد . (توجه كنيد كه فقط فريم هايي كه فريم كليدي باشند اكشن ميپذيرند و اگر روي يه فريم معمولي كليك كنيد كه فريم كليدي نباشد اكشني كه در آن فريم وارد كنيد به اولين فريم كليدي قبل از آن فريم تعلق ميگيرد) .
  • براي كد دادن به يك دكمه ، ابتدا روي دكمه كليك كنيد و سپس وارد پنل اكشنز شده و كد موردنظرتان را به آن اضافه كنيد .
  • براي كد دادن به مووي كليپ ها شما در اصل به يك كپي از مووي كليپ كتابخانه كه روي صفحه فلشتان است اسكريپت ميدهيد و بقيه كپي هايي كه از سمبل روي آن كليپ كتابخانه در صفحه مي آوريد از آن اسكريپت بهره نمي گيرند.(در صورتي كه هنگام ويرايش مووي كليپ اصلي ، كدي را به يكي از فريم ها يا دكمه هاي موجود در مووي كليپ بدهيد آن اسكريپت براي سمبل است و تمام كپي هايي كه از روي آن ميسازيد آن كد را دارا هستند). وقتي شما يك اكشن به يك مووي كليپ ميدهيد بايد اكشن را در يك Event Handler قرار دهيد تا در صورت رخ دادن آن Event اكشني كه داده ايد اجرا شود .(Event به معناي رويداد است كه در تمامي زبان هاي برنامه نويسي نيز به همين نام مرسوم است . رويداد يعني رخ دادن يك اتفاق بر روي شيئ مورد نظر . مثلا رد شدن موس از روي مووي كليپ يك رويداد است و يا كليك روي آن يا خاتمه يافتن صدايي كه به يك فريم اختصاص داده ايد.).

اسكريپت نويسي شيئ گرا :

در اسكريپت نويسي شي گرا ، اطلاعات در گروه هاي خاصي دسته بندي ميشوند كه به آنها Class ميگويند . شما ميتوانيد چندين كپي از يك كلاس را در اسكريپت خود بسازيد كه به هر يك از آنها يك شي (Object) ميگوييم . شما ميتوانيد كلاس هاي مربوطه را خودتان بسازيد و يا از كلاس هاي آماده فلش در پوشه Objects در پنل اكشنز استفاده كنيد.

وقتي شما يك كلاس ميسازيد ، بايد تمامي دارايي ها ( property ) و متد Method هاي مربوط به هر شي اي را كه ساخته ايد تعريف كنيد. مثلا يك آدم داراي چه دارايي هايي است ؟ چشم ، دست ، مو ، و مانند آن . و داراي چه متد هايي ؟ متد راه رفتن ، خنديدن ، حرف زدن و غيره . در مثال فوق كاراكتر آدم يك كلاس است و هر كپي از روي آن يك شي خواهد بود . اشياء در اكشن اسكريپت ميتوانند اطلاعات يا گرافيك ها را حمل كنند. بطور مثال يك مووي كليپ در فيلم فلش ما در اصل يك شي از كلاس مووي كليپي است كه در كتابخانه آن فيلم فلش قرار دارد و شامل تمام دارايي ها و متد هاي شي اصلي است.

براي تعريف كردن يك كلاس شما بايد يك فانكشن constructorتعريف كنيد بطور مثال اگر شما اطلاعاتي درباره يك دوچرخه سوار در فيلم فلش خود داريد شما ميتوانيد يك فانكشن از نوع constructor بنام Biker بسازيد و براي آن دو پراپرتي زمان و فاصله تعريف كنيد و يك متد Getspeed كه اين متد سرعت دوچرخه سوار را در هر لحظه كه فراخواني شود ميدهد .

function Biker(t, d) {

this.time = t;

this.distance = d;

this.getSpeed = function() {return this.time / this.distance;};

}

در مثال بالا يك فانكشن ساختيم كه دو متغير براي دريافت اطلاعات بنام هاي t , d دارد .وقتي شما اين فانكشن را براي ساخت يك كپي از شي آن فراخواني ميكنيد بايد پارامتر هاي تعريف شده را نيز بهمراه نام فانكشن وارد كنيد . به مثال زير توجه كنيد:

emma = new Biker(30, 5);
hamish = new Biker(40, 5);

در كد هاي بالا دو شيئ biker با نام هاي emma و hamish ساختيم . همانطور كه ميبينيد بعد از نوشتن نام فانكشن داخل پرانتز پارامتر هاي تعريف شده را هم نوشته ايم.

وراثت در اسكريپت نويسي شيئ گرا :

در اسكريپت نويسي شيئ گرا Class ها ميتوانند متد ها و پراپرتي ها را به روش وراثت inheritance از همديگر دريافت كنند . شما ميتوانيد وراثت را براي گسترش يا دوباره سازي متد ها و پراپرتي هاي يك كلاس بكار گيريد . كلاسي كه ار كلاس ديگر ارث ميبرد Subclass ناميده ميشود .(sub به معناي زير مجموعه است) و كلاسي كه متد ها و پراپرتي هايش را به كلاس ديگر پاس ميدهد superClass ناميده ميشود . يك كلاس ميتواند هم Subclass و هم SuperClass باشد .

نظر شما لينک مطلب
1383/02/28
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


کار با پایگاه داده ها در کلدفیوژن

برای کار با پایگاه داده در کلدفیوژن، ابتدا باید برای آن پایگاه داده یک Datasource تعریف کنید. مثلا، برای ایجاد یک Datasource برای یک پایگاه داده Microsoft Access به روش زیر عمل می کنیم :

اگر در ویندوز 98 هستید، به Control Panel -> Data Sources (ODBC) بروید.

اگر در ویندوز 2000 یا ویندوز XP هستید، به Control Panel -> Administrative Tools -> Data Sources(ODBC) بروید.

به System DSN بروید.

Add ... را کلیک کنید.

در پنجره باز شده، “Microsoft Access Driver" را انتخاب کنید و روی Finish کلیک کنید.

در پنجره باز شده برای Datasource خود یک نام انتخاب کنید.

روی Select ... کلیک کنید و فایل Access مورد نظر را انتخاب کنید.

به Start -> Programs -> Macromedia Coldfusion MX -> Administrator بروید.

کلمه عبور را وارد کنید.

از قسمت سمت چپ صفحه Data Sources را انتخاب کنید.

در Data Source Name نام Datasource خود را بنویسید.

از Driver ، گزینه ی JDBC-ODBC Bridge را انتخاب کنید و روی Add کلیک کنید.

در صفحه ای که ظاهر می شود، از لیست ODBC DSN، نام Datasource ی را که درControl Panel ایجاد کرده بودید را انتخاب کنید.

روی Submit کلیک مکنید.

برای نمایش داده های یک پایگاه داده در یک برنامه کلدفیوژن، از تق <CFQuery> به روش زیر استفاده می کنیم :

<CFQuery Datasource=”mydatasource” name=”query_name”>

Select field_1,field_2,field_3 from table_name

</CFQuery>

<CFOutput query=”query_name”>

Field 1 : #field_1# <BR>

Field 2 : #field_2# <BR>

Field 3 : #field_3# <BR>

</CFOutput>

Select field_1,field_2,field_3 from table_name یک عبارت SQL می باشد که سه فیلد field_1، field_2، و field_3 تمام رکوردهای جدول table_name از پایگاه داده ای که datasource “mydatasource” را به آن نسبت داده ایم را انتخاب می کند و سپس نتیجه را در متغیر query_name قرار می دهد.

<CFQuery ...> یک حلقه چرخشی روی تمام رکوردهای متغیر query_name انجام می دهد و در هر مرحله مقادیر فیلد های هر رکورد به صورت متغیر در دسترس هستند و می توان عملیات مختلفی روی آن ها انجام داد. مثلا در کد بالا در هر مرحله مقادیر داخل ## با مقادیر واقعی فیلد های هر رکورد جایگزین می گردند و نمایش داده می شوند.

برای افزودن یک رکورد به یک پایگاه داده، مراحل زیر را باید انجام دهیم :

ابتدا یک فرم HTML ساده برای دریافت اطلاعات و ارسال آن ها به صفحه action ایجاد می کنیم :

<HTML>

<HEAD>

<TITLE>A Title</TITLE>

</HEAD>

<BODY>

<Form action=”add.cfm” method=”post”>

Name : <input type=”text” name=”name”>

<BR>

Last name: <input type=”text” name=”lastname”>

<BR>

<input type=”submit”>

</Form>

</BODY>

</HTML>

برای یادگیری مطالب بیشتر در این باره به کتاب ها و مراجع HTML مراجعه فرمائید.

سپس صفحه action را برای افزودن رکورد جدید به پایگاه داده ایجاد می کنیم (add.cfm) :

<CFQuery name=”add_query” datasource=”mydatasource”>

Insert Into my_table(

Field_1,

Field_2)

Values(

‘#form.name#’,

‘#form.lastname#’)

</CFQuery>

این کد یک رکورد به جدول my_table پایگاه داده ای که mydatasource به آن اشاره می کند، با مقادیر فیلد های form.name و form.lastname اضافه می کند. Form.name یک متغیر است که به مقدار Submit شده ی فیلد name در فرم HTML اشاره می کند و مقدار آن با مقدار اصلی عوض می گردد.

برای محدود کردن نمایش رکوردها ی یک پایگاه داده از عبارت SQL ی مانند مثال زیر استفاده می کنیم :

Select field1,field2,field3 from my_table where field1>0 AND field2=2

این عبارت نتایج را به نتایجی که مقدار field1 آن ها بزرگتر از صفر و مقدار field2 آن ها برابر 2 می باشد، محدود می کند. برای اطلاعات بیشتر در این زمینه به کتاب ها و مراجع SQL مراجعه کنید.

کنترل جریان برنامه :

در این قسمت چند شیوه کنترل جریان برنامه را توضیح می دهم و بقیه را برای قسمت های بعدی می گذارم.

برای اجرا کردن کد یک فایل cfm دیگر در جایی از برنامه ی مان، از cfinclude به صورت زیر استفاده می کنیم :

<cfinclude template=”myfile.cfm”>

این دستور در هر کجا از برنامه قرار بگیرد، با کد های موجود در فایل myfile.cfm جایگزین می گردد.

برای هدایت کردن مرور گر به یک صفحه ی دیگر یا یک آدرس اینترنتی دیگر، از cflocation به صورت زیر استفاده می کنیم :

<cflocation url=”http://google.com/”>

<cflocation url=”mypage.cfm”>

این دستور ها باعث توقف اجرای برنامه جاری می شوند و مرورگر کاربر را به صفحه ی مشخص شده ( مثلا http://google.com در مثال اول و mypage.cfm در مثال دوم) می فرستد.

برای انجام دادن کار ها بر اساس شرط یا شروط، از ساختار cfif/cfelseif/cfelse به صورت زیر استفاده می کنیم :

<cfif condition1 >

Do something here if condition1 is true

<cfelseif condition2 >

Do another thing here if condition2 is true

<cfelse>

Do some other thing here if neither condition1 nor condition2 is true

</cfif>

در این جا اگر شرط condtion1 درست باشد، کد قسمت اول اجرا می گردد (و بقیه قسمت ها اجرا نمی گردند.) وگرنه اگر شرط condition2 درست باشد، کد قسمت دوم اجرا می گردد. و گرنه، کد قسمت آخر (سوم) اجرا می گردد.

شروط در کلدفیوژن عباراتی مثل Var1 EQ Var2 به معنی اینکه آیا مقدار Var1 با مقدار Var2 برابر می باشد یا نه و یا Var1 Is Not Var2 به معنی اینکه آیا مقادیر Var1 و Var2 نا برابر می باشند یا نه، هستند.

برای توقف اجرای برنامه از cfabort استفاده می کنیم :

<CFAbort>
نظر شما لينک مطلب
1383/03/08
هادی مشیدی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


هفت اشکال بزرگ در طراحی قالب وبلاگ‌

موارد زیر اشکالاتی است که در اغلب وبلاگ‌های فارسی دیده می‌شوند. رفع این اشکالات صرفا به عنوان پیشنهاد از سوی نگارنده مطرح می‌شود، اگر دوست دارید مخاطبان در هنگام بازدید از وبلاگ شما اذیت نشوند و بعد از رفتن پشت سرشان را گاهی نگاه کنند! می‌توانید به آنها توجه کنید.

۱- استفاده از موسیقی

۲- بکار بردن پیغامهای VBScript و Java Script

۳- استفاده از جملات متحرک (Marquee)

۴- استفاده زیاد از تصویر ( باعث کاهش سرعت لود وبلاگ میشود)

۵- تنظیم نبودن تعداد پستهای وبلاگ ( بیش از 10 تا )

۶- در دسترس نبودن آرشیو

۷- نبودن آدرس ایمیل نویسنده وبلاگ

ادامه مطلب
نظر شما لينک مطلب
1383/03/08
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال

رشته چيست ؟

رشته مجموعه اي از كاراكتر هاست كه در كنار هم قرار گرفته اند و ميتواند شامل حروف و اعداد و كاراكتر هاي نقطه گذاري باشند . براي نوشتن رشته ها بايد آنها را در ميان كوتيشن قرار داد. مثلا : “Mediax”

شما ميتوانيد از عملگر + جهت متصل كردن دو رشته به هم استفاده كنيد . اكشن اسكريپت فاصله ها را در ابتدا يا انتهاي رشته ها جزو رشته به حساب مي آورد . يعني هر فاصله دقيقا مانند يك كاراكتر از رشته است . گر چه در اكشن اسكريپت متغير ها ، نام اشياء و ليبل فريم ها حساس به بزرگي يا كوچي حروف نيستند ، اما در مورد رشته ها اين خاصيت برقرار است .در مثال زير جملات نوشته شده خروجي هاي گوناگوني را نشان ميدهند . چون دو لغت “macro”و “MACRO” دو رشته واقعي هستند :

invoice.display = "macro";

invoice.display = "MACRO";

براي نشان دادن كوتيشن در يك رشته ، بايد قبل از آن يك كاراكتر بك اسلش بگذاريد . به اينكار ميگويند فرار (Escaping) كاراكتر . كاراكترهاي ديگري هم هستند كه در اكشن اسكريپت نشان داده نميشوند مگر اينكه از روش هاي فرار كاراكتر خاص آنها استفاده كنيد . جدول زير تمامي كاراكتر هاي استفاده براي فرار يك كاراكتر را نشان ميدهد :

Escape sequence | Character
\b | Backspace character (ASCII 8)
\f | Form-feed character (ASCII 12)
\n | Line-feed character (ASCII 10)
\r | Carriage return character (ASCII 13)
\t | Tab character (ASCII 9)
\" | Double quotation mark
\' | Single quotation mark
\\ | Backslash
\000 - \377 | A byte specified in octal
\x00 - \xFF | A byte specified in hexadecimal
\u0000 - \uFFFF | A 16-bit Unicode character specified in hexadecimal

اعداد :

نوع داده اي عدد از نوع داده اي بسيار دقيق شناور ميباشد . شما ميتوانيد از عملگر هاي حسابي زير جهت عمليات رياضي استفاده كنيد :

+ جمع

- تفريق

* ضرب

/ تقسيم

% به پيمانه

++ افزايش

ـ ـ كاهش

  • توجه : ++ جهت افزودن يك واحد به يك متغير عددي كاربرد دارد . بيشترين استفاده از آن نوشتن i++ بجاي i=i+1 ميباشد . اين عملگر هم قبل و هم بعد از نام متغير عددي استفاده ميشود . در مثال زير متغير age ابتدا يك واحد اضافه شده و سپس با عدد 30 چك ميشود .

if (++age >= 30)

اما در مثال زير age بعد از انجام عمل مقايسه اضافه ميشود .

if (age++ >= 30)

همچنين ميتوانيد از متد هاي آماده آبجكت رياضي اكشن اسكريپت براي دستكاري اعداد استفاده كنيد . در مثال زير ازمتد sqrt جهت جذر گرفتن از عدد داده شده استفاده كرده ايم :

Math.sqrt(100);

نوع داده بولين :

يك مقدار بولين مقداريست كه دو حالت بيشتر نداره ، يا true يا false . اكشن اسكريپت اين دو مقدار را به دو مقدار 1 و 0 نيز تبديل ميكند . مقادير بولين معمولا با عملگر هاي منطقي در جملات اكشن اسكريپت استفاده ميشوند كه باعث انجام مقايسه اي براي اجراي كد بعدي ميشود . بطور مثال در كد زير فيلم در صورتي اجرا ميشود كه متغير Password مقدارش true باشد

onClipEvent(enterFrame) {

if (userName == true && password == true){

play();

}

}

نوع داده تهيNULL) ) :

اين نوع داده فقط يك مقدار دارد و آنهم NULL است به معناي پوچ ، يعني هيچ داده اي وجود ندارد. اين نوع داده براي تفاوت قائل شدن بين وضعيت هاي گوناگون كاربرد دارد . چند مثال :

  • براي اينكه نشون بده هنوز يك متغير مقدار دهي نشده يا اينكه در اين لحظه هيچ مقداري نداره .
  • براي هنگامي كه ميخواهيد در يك فانكشن مقدارش را چك كنيد تا در صورت وجود ارسال شود .
  • و ...

نوع داده اي تعريف نشده ( Undefined) :

اين نوع داده نيز فقط يك مقدار دارد كه Undefined است و براي متغير ها استفاده ميشود كه هنوز مقداري نگرفته اند .

نظر شما لينک مطلب
1383/03/12
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش کلد فیوژن : متغیر های Client و Session

از من درخواست شده بود که در باره ی متغیرهای Session بنویسم. از آن جایی که بین متغیر های Session و Client و تشابه هایی وجود دارد، آن ها را در یک مقاله توضیح می دهم.

1- متغیرهای Client

متغیرهای Client به جای اینکه در سیستم کاربر ذخیره گردد، در سرور Coldfusion ذخیره می گردند. متغیرهای Client با مرورگر کاربر یک جفت تشکیل می دهند و برای هر مرورگر یک Client.MyVar وجود دارد. برای این که سرور کلدفیوژن بتواند تشخیص بدهد که کدام متغیر Client مربوط به کدام مرورگر می باشد، از یک جفت متغیر CFID و CFTOKEN استفاده می کند. بعدا در باره ی این دو متغیر بحث خواهیم کرد.

برای تنظیم حداکثر مدت زمان باقی ماندن متغیرهای Client، از Administrator کلدفیوژن استفاده می شود. مقدار پیش فرض 90 روز می باشد. شما می توانید این مقدار تا یک روز پایین بیاورید. اگر از متغیرهای مربوط به CFID و CFTOKEN خاصی ، در این مدت زمان استفاده نگردد، متغیرهای مربوط به آن از روی سرور پاک می گردد.

برای استفاده از متغیرهای Client، ابتدا باید با استفاده از cfapplication، مقدار clientManagement را true کنید. به این صورت :

<cfapplication clientManagement=”true” … >

سپس، برای ایجاد متغیرهای Client از CFSet و یا CFParam به صورت زیر استفاده کنید :

<CFSet Client.MyVar=1>

<CFParam name=”Client.MyVar” default=”1”>

یکی از کاربردهای جالب متغیرهای Client، متغیر Client.LastVisit می باشد که خود به خود ایجاد می گردد و مقدار آن خود به خود به روز می گردد و دارای مقدار تاریخ آخرین روزی است که وب سایت جاری توسط یک مرورگر در خواست شده است. برای استفاده از این متغیر، به مثال زیر توجه کنید :

<CFOUTPUT>

Welcome back to the Web

SuperShop, your last visit

was on #DateFormat(Client.LastVisit)#.

</CFOUTPUT>

برای حذف کردن یک متغیر Client، از تابع DeleteClientVariable() به صورت زیر استفاده کنید :

<cfset result=DeleteClientVariable(“MyVar”)>

2- متغیر های Session

متغیرهای Session در RAM سیستمی که سرور کلدفیوژن در آن اجرا می شود ذخیره می گردند و مانند متغیرهای Client برای هر مرورگر مجزایی متغیرهای Session مجزا ایجاد می شوند و این متغیرها نیز، توسط متغیرهای CFToken و CFID از هم باز شناخته می شوند.

تفاوت های بین متغیرهای Client و متغیرهای Session عبارت است از :

· متغیرهای session قادر به ذخیره سازی انواع داده ی پیچیده مانند Structure ها و آرایه ها می باشند، ولی متغیر های Client تنها قادر به ذخیره سازی داده های ساده مانند رشته های متنی و اعداد می باشند.

· متغیرهای session نیاز به استفاده از CFLock می باشند ولی متغیر های Client نیازی به استفاده از CFLock ندارند. (بعدا در این مقاله استفاده از CFLock را شرح خواهم داد.)

· مدت عمر متغیرهای کمتر از مدت عمر متغیرهای Client می باشد.

· اگر سرور Coldfusion را از نو راه اندازی کنیم، متغیرهای Session از بین خواهند رفت ولی متغیر های Client هم چنان باقی خواهند ماند.

· متغیرهای Session از لحاظ فضای اشغالی هیچ محدودیتی ندارند در حالی که متغیرهای Client به 32 کیلوبایت محدود هستند.

برای استفاده از متغیرهای Session، ابتدا باید SessionManagement را به صورت زیر “true” کنیم :

<cfapplication sessionManagement=”true” … >

اگر می خواهید مقدار پیش فرض مدت عمر متغیرهای Session را تغیر دهید، مقدار SessionTimeout را به روش زیر تغییر دهید :

<cfapplication sessionmanagement=”true” sessiontimeout=”#CreateTimeSpan(0,0,20,0)#” …>

مثلا مثال بالا حداکثر مدت طول عمر متغیر های از نوع Session را برابر 20 دقیقه قرار می دهد. ( در تابع CreateTimeSpan، پارامتر اول تعداد روزها، پارامتر دوم، ساعات، پارامتر سوم، دقیقه ها و پارامتر آخر ثانیه ها می باشند.)

برای حذف یک متغیر Session از تابع StructDelete به روش زیر استفاده کنید :

<cfset Result=StructDelete(Session,”MyVar”)>

برای حذف تمام متغیرهای Session، از cfapplication به روش زیر استفاده کنید :

<cfapplication sessiontimeout=”#CreateTimeSpan(0,0,0,0)#” …>

متغیرهای Session در حافظه ی سرور کلدفیوژن ذخیره می گردند و کاربرهای مختلف ممکن است خواهان دسترسی به آن ها در یک زمان خاصی باشند. برای اینکه در مدیریت حافظه اختلال به وجود نیاید، باید هنگام خواندن مقدار و یا مقدار دهی این متغیرها استفاده از حافظه را به یک کاربر خاص محدود کرد و پس از آن که این کاربر خاص کار بر روی مقادیر متغیرها را تمام کرد، نوبت به کاربر دیگر می رسد.

برای این کار، از cflock استفاده می کنیم. برای مقدار دهی به متغیرهای session، از cflock به صورت زیر استفاده می کنیم :

<CFLock name=”Session_MyVar”

type=”Exclusive”

timeout=”10”

throwOnTimeOut=”Yes”>

<CFSet Session.MyVar=”1”>

</CFLock>

برای خواندن مقدار یک متغیر session از cflock به صورت زیر استفاده می کنیم :

<CFLock name=”Session_MyVar”

type=”READONLY”

timeout=”10”

throwOnTimeOut=”Yes”>

<CFSet Variables.MyVar=Session.MyVar>

</CFLock>

امیدوارم این مقاله توانسته باشد به اکثر سوال هایتان جواب لازم را داده باشد. هرگونه پیشنهاد، سوال و یا اشکال در این مقاله را به irancoldfusion@yahoo.com ایمیل بزنید. متشکرم.
نظر شما لينک مطلب
1383/03/14
هادي مشيدي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


تفاوت هاي اكشن اسكريپت و جاوا اسكريپت

اكشن اسكريپت بسيار شبيه به هسته زبان برنامه نويسي جاوا اسكريپت است . نيازي به دانستن جاوا اسكريپت براي ياد گيري اكشن اسكريپت نيست ، اما با دانستن آن ، اكشن اسكريپت براي شما كمي آشنا خواهد بود .

انجمن شركت هاي كامپيوتري اروپا ECMA در سند رسمي شماره 262 خود جاوا اسكريپت و طرز استفاده استاندارد هاي آن را ثبت نموده است و اكشن اسكريپت نيز بر پايه آن سند پايه ريزي شده است .

چندي از تفاوت هاي اكشن اسكريپت و جاوا اسكريپت :

  • اكشن اسكريپت از آبجكت هاي سمت سرور مانند Browser, window ,anchor پشتيباني نمي كند .
  • اكشن اسكريپت بطور كامل از آبجكت هاي داخلي جاوا اسكريپت پشتيباني نميكند .
  • اكشن اسكريپت از بعضي ساختارهاي دستوري پشتيباني ميكند كه در جاوا اسكريپت ممنوع است ( بطور مثال ifFrameloaded و اسلش ها) و جاوا اسكريپت نيز بعضي از سينتكس هاي خاص خود را دارد .مانند try , catch , throw , statement lables
  • اكشن اسكريپت از فانكشن ساز هاي جاوا اسكريپت پشتيباني نميكند .
  • در جاوا اسكريپت مقدار بازگشتي داده هاي undefined همان undefined است . اما در اكشن اسكريپت مقدارش “” ميشود(یعنی تهی) .
  • در اكشن اسكريپت مقدار تعيين نشده در متغير هاي عددي NaN است . اما در مقدار تعيين نشده ها در عبارات وو متغير هاي عددي صفر است .
  • در جاوا اسكريپت وقتي يك رشته نوع بولين دارد و طول رشته غير از صفر باشد ،نتيجه آن true است و اگر طول رشته صفر باشد مقدارش false ميشود . در اكشن اسكريپت رشته به عدد تبديل ميشود . اگر عدد غير صفر بود مقدار true ميدهد وگر نه مقدار false خواهد شد .
نظر شما لينک مطلب
1383/03/18
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


نرم افزار Macromedia Director

Director MX 2004

Macromedia Director جزو قدیمی ترین نرم افزارهای ساخت برنامه های چند رسانه ای هست که تا حد زیادی به برنامه Flash شباهت داره . Director دارای نسخه 5/8 بود که نسخه MX اون به بازار اومد و مدت خیلی کوتاهی هست که نسخه MX2004 اون به بازار اومده و این در صورتی هست که برنامه Flash دارای نسخه 5 بود که نسخه MX اون به بازار اومد و بعد از اون و خیلی زود تر از Director نسخه MX2004 اون به بازار ارائه شد و همچنین در کنار اون, نسخه MX 2004 Profesional هم ارائه شد که دارای امکانات فوق العاده قوی هست و اینها نشون میده که شرکت ماکرومدیا هم نسبت به برنامه Director توجه بیشتری به نرم افزار Flash داره با توجه به اینکه Director برنامه ای قدیمی تر از Flash هست ! شاید دلیلش هم استقبال بیشتر مردم از این برنامه هست و همچنین بیشتر شدن محبوبیت وب و برنامه های مربوط به وب . چون اگر به ساختار این دو برنامه توجه کنید , میبینید که خیلی شباهت دارند ولی Flash بیشتر برای ساخت نرم افزارهای تحت وب تخصصی شده و Director هم برای برنامه های چند رسانه ای که روی CD ارائه میشه . البته با دایرکتور هم میشه برنامه های تحت وب ایجاد کرد و برعکس .
در دایرکتور برای ایجاد قسمتهای Inter Active ( فعال) از زبانی به نام Lingo استفاده میشه ولی در Flash از زبان برنامه نویسی Flash Script استفاده میشه . یکی از خصوصیات قابل توجه در دایرکتور این هست که ما میتونیم فایلهایی مثل تصویر, صدا و چیزهایی از این قبیل رو که برای ایجاد برنامه لازم هست رو به صورت یک فایل خارجی (External) استفاده کنیم و بدون وارد کردن اونها در داخل پروژه, برنامه رو بسازیم . دایرکتور دارای امکانات خیلی جالب و آماده ای برای ایجاد افکتهای تصویری و سه بعدی داره که معمولا اونها رو با زبان Lingo ایجاد میکنه . ما میتونیم توسط دایرکتور یک برنامه چت تحت وب , خیلی راحت تر از اون چیزی که فکرش رو بکنید بسازیم که برای این کار احتیاج به نصب Macromedia Shockwave MultiuserServer بر روی سروری که میزبان وب ما هست داریم که به این صورت قابلیت استفاده هزاران نفر هم زمان از این چت ایجاد میشه .
همونطوری که برای دیدن صفحات Flash تحت وب احتیاج به Plugin مخصوص Flash Player هست برای دیدن صفحات و برنامه های دایرکتور تحت وب هم احتیاج به Plugin مخصوص به نام Shockwave Player هست که باید برای مرورگر وب نصب کنیم .
یکی از خصوصیات جدید برنامه دایرکتور در نسخه MX2004 اون توانایی استفاده از Syntax های زبان Java Script هست .
در حال حاضر بیشتر از دایرکتور برای ساخت انیمیشنها و برنامه های تحت وب, بازیها, CD های آموزشی , CD های مرجع,CD های تبلیغاتی و حتی CD هایی که این اواخر به صورت کارت ویزیت و در ابعاد کوچک هست استفاده میشه .
با مراجعه به این سایت میتونید کارهای بیشتری از دایرکتور رو ببینید .
من به دوستانی که با برنامه Flash کار میکنند توصیه میکنم که برای ساخت CD های مالتی مدیا حتما از برنامه دایرکتور استفاده کنند چون این برنامه دارای امکانات خاصی برای ایجاد نرم افزارهای Desktop مخصوصا در حجمهای بالا داره که نرم افزار Flash در این زمینه ها ضعیف تر هست . اگر دقت کنیم سایتهای ایرانی که در باره Flash صحبت میکنن یا آموزش میدن خیلی زیاد هست و لی در باره دایرکتور اینطور نیست و هنوز زمینه کاری برای این نرم افزار زیاد هست چون متخصصین کمتری برای دایرکتور وجود داره !
برای آگاهی از آخرین اخبار و تکنولوژیهای Director بد نیست سری به این سایت هم بزنید .

منبع مقاله
نظر شما لينک مطلب
1383/03/18
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


اكشن اسكريپت : كنترل در زمان اجرا

وقتي شما يك اكشن اسكريپت مينويسد ،از پنل Actions براي ضميمه كردن كد ها به فريم يا دكمه يا مووي كليپ ها استفاده ميكنيد . اسكريپت هايي كه به فريم ها ضميمه ميكنيد زماني اجرا ميشوند كه هد اجرايي فلش وارد آن فريم شود . اما فريم اول فيلم فلش بگونه اي متفاوت از ساير فريم ها عمل ميكند . چون اولين فريم فيلم فلش كم كم لود ميشود و اشياء در آن همينطور كه دانلود ميشوند نمايش داده ميشوند و اين موضوع بر روي اجراي اسكريپت ها اثر ميگذارد . اما فريم هاي بعد از فريم اول تا وقتي تمام اشياء داخل آن فريم لود نشوند نمايش داده نميشوند .

اسكريپت هايي كه به مووي كليپ يا دكمه ها نسبت داده شده اند زماني اجرا ميشوند كه رويداد (event) خواسته شده اتفاق افتد . يك رويداد يك اتفاقي است كه توسط كاربر يا گاهي توسط فيلم فلش شما اتفاق مي افتد ، مانند كليك كردن موس ، فشردن يك دكمه از كيبورد ، و يا لود شدن يك مووي كليپ ( اين آخري توسط فيلم اتفاق افتاده) . شما ميتوانيد بر اساس رويداد هايي كه رخ ميدهد كد هاي متفاوتي بنويسيد تا در هنگام رخ دادن هر رويداد يك كد خاص اجرا گردد .

اكشن هايي كه به دكمه ها يا مووي كليپ ها نسبت ميدهيد در اكشن هاي خاصي بنام Handler حبث ميشوند .on و onClipEvent دوHandler هستند . شما ميتوانيد يك يا بيش از يك Event را در يك Handler قرار دهيد و همچنين ميتوانيد بيش از يك Handler براي هر شيئ قرار دهيد . هندلر onClipEvent براي مووي كليپ و هندلر on براي دكمه هاست . همچنين شما ميتوانيد از on براي خلق مووي كليپ دكمه اي استفاده كنيد كه رويداد هاي دكمه را دريافت ميكند .

رويداد هاي مووي كليپ و دكمه ها ميتوانند توسط متد هاي خود شيئ نيز بكار گرفته شوند . شما بايد يك فانكشن تعريف كنيد و آن را به متد Event Hadler ارجاع دهيد . اين فانكشن وقتي كه رويداد اتفاق بيافتد اجرا ميشود .

جدول زير متد ها و Event Handler هاي دكمه ها را نشان ميدهد :

Event handler actions | Event handler methods
on (press) | onPress
on (release) | onRelease
on (releaseOutside) | onReleaseOutside
on (rollOver) | onRollOver
on (rollOut) | onRollOut
on (dragOver) | onDragOver
on (dragOut) | onDragOuot
on (keyPress"...") | onKeyDown, onKeyUp

جدول زير متد ها و Event Handler هاي مووي كليپ ها را نشان ميدهد :

Event handler actions | Event handler methods
onClipEvent (load) | onLoad
onClipEvent (unload) | onUnload
onClipEvent (enterFrame) | onEnterFrame
onClipEvent (mouseDown) | onMouseDown
onClipEvent (mouseUp) | onMouseUp
onClipEvent (mouseMove) | onMouseMove
onClipEvent (keyDown) | onKeyDown
onClipEvent (keyUp) | onKeyUp
onClipEvent (data) | onData

با اكشن اسكريپت همچنين ميتوانيد رويداد هاي TEXTbox و ديگر اشياء اكشن اسكريپت را كنترل كنيد .
نظر شما لينک مطلب
1383/03/22
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


ارکات ; فراکتالی از انسان ها

ارکات چیست ؟

سايت Orkut يک سايت Social Networking از دوستان تاييد شده است . اين به اين معني است که همه نمي توانند مستقيما در اين سايت عضو شوند و فقط اعضايي که در سايت وجود دارند مي توانند دوستان جديدي به داخل سايت دعوت کنند . این سایت یک شهر مجازی از دوستانی بوجود می آورد که میتوانند با هم رابطه داشته باشند ، حالا این رابطه کاری ، درسی ، عشقی یا هر نوع دیگر است . شما بعد از عضويت در ارکات مي توانيد در انجمن هاي مختلف آن عضو شوید و با ديگران رابطه داشته باشيد ، انجمن هايي با میلیون ها موضوع گوناگون !

تولد ارکات :

ارکات یکی دیگر از پروژه های مهندسین گوگل بنام Orkut Buyukkokten است . او دانشجوي دکتراي علوم کامپيوتر در دانشگاه استانفورد است .بد نیست که سایت شخصی ارکات را که پروژه های دیگرش را توضیح داده ببینید .او که در شرکت گوگل در بخش طراحي رابط کاربر فعاليت مي کند اين سايت را در همان زمان يک روز در هفته که در شرکت Google وجود دارد نوشته است ( اين شرکت به کارمندان خود اجازه مي دهد که در هفته يک روز را صرف پروژه هاي دلخواه خود بکنند . براي نمونه پروژه Google News در همين مدت يک هفته رد روز توسط يک برنامه نويس ديگر اين شرکت به نام کريشنا بهارات نوشته شده است )

امکانات ارکات :

  • امکان پيدا کردن دوستان جديد که مي تواند به يکي از حالات دعوت از افرادي که عضو نيستند ، اضافه کردن دوستان دوستانتان و يا جستجو و پيدا کردن دوستاني از بين اعضاي فعلي سايت انجام گيرد .
  • امکان نوشتن پيام به دوستان و بقيه افراد عضو در سايت که به چند حالت پيام خصوصي و يا پيام عمومي ، مثل نظر در مورد فرد مورد نظر و يا نوشتن در دفتر يادداشت دوستان امکان پذير است .
  • درست کردن گروه جديد و يا عضو شدن در گروههاي مختلف موجود که تعداد آنها کم کم نجومي مي شود .
  • امکان راي دادن به يک نفر بر اساس معيارهايي مثل قابل اعتماد بودن و سکسي بودن و همچنين اعلام طرفداري از يک نفر .
  • امکان ايجاد آلبوم عکس و دفترچه خاطرات
  • استفاده از ارکات برای تبلیغات خودتان و کار خودتان در سایت
  • و بطور کلی تجربه زندگی در دنیای مجازی

نظر شخصی من در مورد فراکتال ارکات :

طرح ریزی ارکات و نیز نوع ارتباطات در ارکات بسیار زیبا پایه ریزی شده است و زیبایی علم ریاضی در آن پیداست .ارکات بر اساس یکی از زیبا ترین فرمول های ریاضی که فراکتال نام دارد در حال گسترش است . طبق این فرمول گسترش از یک جا آغاز شده و بصورت زیر مجموعه ای گسترش میابد. یه مثال میزنم : بجای هر انسان شما یک نقطه در نظر بگیرید . اولین نقطه 43 نقطه را عضو میکند ( همون دعوت دوستان به ارکات ) و هر یک از این 43 تا خودشان 43 عضو میگیرند و میشوند 1850 تا . حال هر کدام از این 1850 تا خودشان 43 عضو میگیرند و میشوند 79500 تا . هر کدام از این 79500 تا خودشان 43 عضو میگیرند و میشوند حدود 3.5 میلیون . اگر این 3.5 میلیون هر کدام 43 عضو بگیرند میشوند در حدود 147 میلیون و اگر این 147000000 نفر هر کدام 43 عضو بگیرند بیش از 6.3 میلیارد نفر در این فراکتال عضو میشوند !!!

چیه ؟ تعجب کردین ؟ اگر هر کس فقط 43 نفر را وارد کند و نه بیشتر ، وقتی سری ششم 43 نفرشان را تکمیل کنند بیش از کل جمعیت جهان در عرض مدت کوتاهی وارد این شبکه می شوند . پس فکر نکنید که پر شدن ارکات زمان زیادی بطول میانجامد . بخصوص با این سیستم عضویت که گذاشته همه دوست دارند توسط یک نفر عضو شوند تا سر از کار این سایت در آورند .

مخالفان ارکات :

روزنامه بازتاب در گزارشي بسيار کوبنده به نقد سرويس ارکات پرداخت و از آن با نام فرزند پنتاگون ياد کرد .بخشی از گزارش بازتاب :

· " اين سايت در صدد است تا زنجيره‌اي از ارتباطات نخبگان كشورهاي مختلف را به همراه برخي اطلاعات دقيق آنها دريافت و نگهداري كند.

· در زمان عضويت افراد در اين سايت، بخش security (امنيتي) آن پيغام مي‌دهد كه هيچ ضمانتي نمي‌دهيم كه اطلاعات شما مورد استفاده قرار نگيرد و مي‌افزايد: شما موافقت مي‌كنيد كه Orkut مشخصات شما را كه به آنها دسترسي دارد، در صورت لزوم بر اساس قانون و يا براي يك كار خوب ديگر، مورد بهره‌برداري قرار دهد.

· بر اساس آمار ارايه شده از سوي اين سايت، آمريكا با 3/34 درصد، برزيل (95/24%)، ژاپن (05/4%)، هند (89/3%)، استوني (65/3%) و ايران (33/3%) 6 كشور اول مشتري اين سايت به شمار مي‌روند و حدود 48% مشتريان آن را افراد 18 تا 25 سال تشكيل مي‌دهند. مسلما گردانندان اين سايت، از اطلاعات ارسال شده توسط اعضا در عرصه فرار مغزها و موارد اطلاعاتي و امنيتي در راستاي منافع ملي خودشان استفاده مي‌كنند ."

بنظر من فرار مغز ها حرف کاملا بیهوده ای است . چون وقتی دانش آموخته های ما از کشور میروند که جا برای رشد آنان نیست . محمد پیامبر هم گفته که اگه نتونستی یه جایی رشد کنی و با رشد تو منافات داشت هجرت کن . البته من یک ایرانی هستم و عاشق وطنم . اما وقتی میتونی موقعیت بهتری داشته باشی چرا از دستش بدی ؟ آیا اگر از دانشگاه یوتا یا استنفرد یا یه دانشگاه آمریکایی خوب برات دعوتنامه بیاد و بگن که تمام مخارج شما راهم میپردازند و شرایط رشد شما تا دکترا فراهم است ، اونوقت بخاطر وطنت نمیری ؟ ترجیح میدی با کار روزانه و درس خواندن شبانه و هزار بدبختی فقط و فقط بخاطر عشق وطن بمونی ؟ !!! با خودت رو راست باش ....

نظر شما لينک مطلب
1383/04/03
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش ColdFusion ، ساختار Switch/Case

ساختار Switch/Case يک عبارت را در برابر چندين شرط، ارزيابي مي کند و سپس کد مربوطه را اجرا مي کند.

مثلا، تکه کد زير را در نظر بگيريد :

<cfif myVar EQ 1>

One

<cfelseif myVar EQ 2>

Two

<cfelseif myVar EQ 3>

Three

</cfif>

تکه کد بالا مقدار myVar را سه بار ارزيابي مي کند و هر بار تست مي کند که آيا مقدار آن برابر مقدار خاصي هست يا نه. کد بالا را مي توان به صورت بهتر مي توان نوشت :

<cfswitch expression=”#myVar#”>

<cfcase value=1>

One

</cfcase>

<cfcase value=2>

Two

</cfcase>

<cfcase value=3>

Three

</cfcase>

</cfswitch>

هر دو کد يک کار واحد انجام مي دهند اما ساختار cfswitch بهينه تر مي باشد، زيرا مقدار متغير myVar به جاي سه بار، يک بار ارزيابي مي کند. کلدفيوژن عبارات cfswitch را بسيار بهينه تر از عبارات cfif اجرا مي کند ، زيرا براي اجراي cfif، هر دفعه هر مقدار هر عبارت شرطي را ارزيابي مي کند (true يا false) تا آنجا مقدار يک عبارت true شود، ولي cfswitch ابتدا مقدار عبارت را ارزيابي مي کند (يک بار) و سپس قسمت مطابق با آن را اجرا مي کند.

مقادير ذکر شده در cfcase بايد از نوع ثابت باشند و نمي توانند متغير و يا عبارت باشند. به عنوان مثال، تکه کد زير مجاز نيست :

<cfswitch expression=”#MyVar#”>

…

<cfcase value=”#1+1#”>

Two

</cfcase>

…

</cfswitch>

در کد زير cfdefaultcase برابر cfelse در ساختار cfif مي باشد.

<cfswitch expression=”#myVar#”>

<cfcase value=1>

One

</cfcase>

<cfcase value=2>

Two

</cfcase>

<cfcase value=3>

Three

</cfcase>

<cfdefaultcase>

Some Other Number

</cfdefaultcase>

</cfswitch>

کد بالا به اين معناست که اگر هيچ يک از مقادير cfcase برابر مقدار عبارت نبودند، بلوک کد مربوط به cfdefaultcase را اجرا کند.

اگر چه ساختار هاي cfswitch مزاياي زيادي دارند، اما در اغلي اوقات نمي توان از آن به جاي cfif استفاده کرد. مثلا به کد زير توجه کنيد :

<cfif MyVar GREATER THAN myOtherVar>

<cfoutput>#MyVar#</cfoutput>

<cfesleif myVar EQUAL myOtherVar>

<cfoutput>#MyVar+MyOtherVar#</cfoutput>

<cfelse>

<cfoutput>#MyOtherVar#</cfoutput>

</cfif>

اين کد را نمي توان به وسيله ساختار cfswitch نوشت. زيرا عبارات شرطي کد بالا چيزي بيشتر از يک مقايسه ي برابري ساده مي باشند.
نظر شما لينک مطلب
1383/04/06
هادی مشیدی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


معرفی Macromedia Fireworks

Fireworks MX 2004—Just Updated

Fireworks چیست ؟

Fireworks نرم افزاری است که تقریبا از روی نرم افزار فتوشاپ نوشته شده است . و میتوانم اینطور بگویم که به نظر می رسد که شرکت Macromedia در تولید این نرم افزار از روی دست شرکت Adobe نگاه کرده است.

شرکت Macromedia در زمانهای قدیم حدود 6 یا 7 سال قبل ، یک نرم افزار از نوع نرم افزارهای گرافیک Pixel داشت به نام XREZ . که این نرم افزار Pixel از فتوشاپ یک تو دهنی محکم خورد و نتوانست جلوی این نرم افزار گرانقیمت و غول پیکر دوام بیاورد . و شرکت Macromedia پروژه Xrez را کنار گذاشت و این نرم افزار تعطیل شد .

حالا برگردیم به سراغ Fireworks

Fireworks نرم افزار گرافیک Pixel شرکت Macromedia است که به هدف web طراحی شده است . به همین دلیل برای خودش منعی قائل نشده که خیلی از کارهاش شبیه فتوشاپ نباشد . و البته این خود یک مژده برای فتوشاپ کارهایی است که قصد دارند کارهای وبی انجام دهند. و البته این یک نوع سیاست کاری است که نرم افزار Fireworks طرفدار پیدا کند .

هم اکنون تنها رقیب Fireworks نرم افزار Image Ready از شرکت ADOBE میباشد البته یک سری کارها است که Fireworks انجام میدهد و Image Ready نمیتواند انجام دهد و یک سری کارهای دیگری است که Image Ready انجام میدهد و Fireworks نمیتواند انجام دهد و هیچ کدام از آن دو Gif Animation را خوب نمی سازند . باید این توضیح را بدهم که نرم افزار Fireworks با Dreamweaver از شرکت Macromedia و Image Ready با Golive که ساخته همین شرکت Adobe است به خوبی مکالمه میکنند .

ما هم چون هدف ما شرکت Macromedia است و Dreamweaver نرم افزار طراحی وب این شرکت است ، به همین دلیل ما نیز نرم افزار گرافیک وب خود را Fireworks انتخاب مینماییم .

حالا در مورد قابلیتهایی که نرم افزار Fireworks دارد . برای شما به طور مختصر مینویسم :

- Fireworks یک نرم افزار گرافیک وب است که هم Pixel کار میکند و هم Vector و ترسیمات هر دو حالت گرافیک را میتوان در یک محیط و در کنار هم انجام داد و این در سرعت کار بسیار مهم است که خود Vector کار کردن این نرم افزار خودش مزیتی بزرگ است . چون تصاویر Vector مشکل حجم ندارند و به راحتی قابل بزرگ و کوچک شدن است .

- Fireworks توانایی ساخت Gif Animation را هم دارد .

- این نرم افزار دارای قابلیت Image Map برای قابلیت دادن به قسمتی از عکس که قرار است Link شود که قابلیت این را دارد که هم مستطیل و هم یک شکل نا منظم باشد مانند یک نقشه .

- Fireworks قادر است تصاویر را Slice کند یعنی تصاویر را به چند قطعه کوچکتر خورد کند که در ادامه و در بخشهای دیگر در مورد آن صحبت خواهم کرد .

- Fireworks توانایی ساختن منوهای Popup را نیز دارد که این کار را به وسیله زبان برنامه نویسی معروف وب یعنی JavaScript انجام میدهد .

- حتی با این نرم افزار میتوان طراحی Layout سایت وب را نیز انجام داد .

- و یکی از مهمترین امکاماتی که Fireworks در اختیار ما قرار میدهد این است که این نرم افزار میتواند XML هم بسازد . یعنی یک Template برای Fireworks طراحی کنید و تصاویر آن در صفحات مختلف عوض شود و عکسها از یک فایل XML خوانده شود که این راه حل در Fireworks MX مطرح شد و در Fireworks MX 2004 به آن وسعت داد .

نظر شما لينک مطلب
1383/04/09
رامین خوشحال

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
pageRank چیست ؟

Pagerank به معنای رتبه صفحه است و در اصل امتیازی است که گوگل برای هر صفحه وب قائل میشود . برای دیدن رتبه صفحات یک سایت میتوانید تولبار گوگل را دانلود و روی IE خود نصب کنید تا به محض ورود به هر صفحه ای امتیاز آن صفحه را روی نوار ابزار گوگل مشاهده کنید .

تئوری عملکرد PageRank :

امتیاز بندی صفحات به این صورت است که یک لینک از یک صفحه وب به یک صفحه دیگر که در یک سایت دیگر است به معنای یک امتیاز مثبت برای صفحه مقصد حساب میشود . چون وب مسترها لینک سایت هایی را در سایت خود قرار میدهند که فکر میکنند برای بازدید کنندگان سایتشان جالب و با ارزش باشد . گوگل از تعداد این لینک های ورودی به صفحات سایت های دیگر ، برای قضاوت درباره امتیاز دهی به آنها و نیز مرتب کردن آنها در هنگام جستجو در گوگل استفاده کرد . برای مشاهده لینک های ورودی به سایت خود میتوانید جمله link:http://www.yourURL.com را در گوگل وارد کنید تا لیست سایت هایی که به شما لینک داده اند را مشاهده کنید . البته هنوز گوگل تمامی لینک های ورودی به سایت را نشان نمی دهد .

PageRank چگونه محاسبه میشود :

راحت ترین سخن درباره محاسبه اش اینه که PageRank با استفاده از اشتراک گرفتن تمامی لینک های ورودی به سایت شما محاسبه میشود . البته این موضوع اکیدا صحیح نیست ، چون گوگل لینک های داخلی را هم در محاسبه شریک میکند . همچنین رتبه PageRank صفحه ای که به شما لینک داده هم ، در بالا بردن رتبه سایت شما موثر است . بعلاوه تعداد لینک های خارجی که در صفحه مبدا وجود دارد نیز در رتبه سایت مقصد تاثیر دارد . بطور عمومی 85% از رتبه سایت مبدا همراه با لینک به سایت مقصد ارسال میشود . پس یک صفحه وب با پیج رنک 5 و فقط با یک لینک خارجی در صفحه اش( که همان لینک سایت شماست) باید 85% از اعتبار رتبه 5 را برای صفحه ای که به آن لینکیده ارسال کند .

ولی در واقع هیچ صفحه ای فقط یک لینک ندارد – به یاد آورید که لینک های داخلی هم اغلب اوقات در محاسبه بحساب می آیند – پس میزان پیج رنک ارسالی عبارت است از 85% از پیج رنک همان صفحه تقسیم بر تعداد لینک های خارجی .

سوالی که اینجا مطرح میشه اینه که تفاوت رتبه های پیج رنک چقدر است و مثلا رتبه 4 با 5 چقدر تفاوت داره ؟ چیزی که معلومه اینه که اعداد گوگل در پیج رنک فقط یک عدد ثابت نیستند و نشان دهنده یه بازه عددی هستند . بنابر این تمام پیج رنک های 5 با هم مساوی نیستند .طبق جدول زیر رتبه 6 ممکن است فقط یک درجه از 5 بیشتر باشو و ممکن است فقط کمی از 7 کمتر باشد:

Page Rank Calculation
PR | Start | End | Median | Median | Links | Links | Links | Links
 | Range | Range | Value | PR Passed | for PR5 | for PR6 | for PR7 | for PR8
1 | 6 | 30 | 18 | 0.30 | 16,803 | 92,414 | 508,277 | 2,795,522
2 | 30 | 164 | 97 | 1.65 | 3,055 | 16,803 | 92,414 | 508,277
3 | 166 | 900 | 533 | 9.06 | 555 | 3,055 | 16,803 | 92,414
4 | 915 | 4,948 | 2,931 | 49.83 | 101 | 555 | 3,055 | 16,803
5 | 5,033 | 27,213 | 16,123 | 274 | 18.362 | 101 | 555 | 3,055
6 | 27,681 | 149,670 | 88,675 | 1,507 | 3.339 | 18.362 | 100.992 | 555.456
7 | 152,244 | 823,186 | 487,715 | 8,291 | 0.607 | 3.339 | 18.362 | 100.992
8 | 837,339 | 4,527,522 | 2,682,431 | 45,601 | 0.110 | 0.607 | 3.339 | 18.362
9 | 4,605,367 | 24,901,372 | 14,753,369 | 250,807 | 0.0201 | 0.110 | 0.607 | 3.339
10 | 25,329,516 | 136,957,543 | 81,143,530 | 1,379,440 | 0.0036 | 0.020 | 0.110 | 0.607
Assumption: 85% of median value passed
Assumption: 50 links per page average
نظر شما لينک مطلب
1383/04/10
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


اكشن اسكريپت - متغير ها در فلش

اكشن اسكريپت - متغير ها در فلش :

متغير چيست ؟

يك متغير يك نگه دارنده اطلاعات است كه بخشي از حافظه را بنام خود ميكند تا شما بتوانيد داخلش مقدار هاي متفاوتي را بنويسيد و پاك كنيد . متغير خودش ثابت ميماند اما مقدار داخلش تغيير ميكند .براي نگه داشتن مقادير انجام شدن يك كار خاص يا گرفتن اطلاعات از كاربر ، اول اطلاعات به حافظه رم كامپيوتر منتقل ميشود كه اينجا متغير ها هستند كه نقش نگه داري اطلاعات را انجام ميدهند .

يك ايده خوب در بكار گيري متغير ها اينه كه همون اول كه متغير را تعريف ميكنيم يه مقدار اوليه بهش بديم . به اينكار ميگويند initialize كردن . اينكار را معمولا در فريم اول انجام ميدن .

متغير ها ميتوانند انواع مختلفي از اطلاعات را در خود نگه دارند مانند اعداد ، رشته ها ، مقادير بولين ، آبجكت ها يا مووي كليپ ها .

نام گذاري متغير ها :

نام يك متغير از قوانين زير پيروي ميكند :

  • بايد اسم آن نشان دهنده نوع آن باشد .
  • نام متغير نميتواند از بين keyword هاي اكشن اسكريپت باشد . همچنين نميتواند از كلمات تعيين كننده مانند true , false , null و undefiend باشد.
  • نام متغير بايد در محيط خودش يكتا باشد .

مقدار دهي متغير :

در فلش نيازي نيست كه نوع متغير را در ابتداي كار تعيين كنيد . فلش هنگامي كه شما به آن مقدار ميدهيد نوع متغيرش را تعيين ميكند.

X = 3 ;

در عبارت فوق ، فلش داده سمت راست مساوي را تعيين هويت ميكند و ميفهمد كه نوع آن عدد است . يك مقدار دهي ديگر ميتواند نوع x را عوض كند . مثلا x = “hello”; مقدار x را به نوع رشته اي تغيير ميدهد . متغيري كه هنوز هيچ داده اي به آن نداده ايم نوع undefiend دارد .

وقتي يك عبارت اكشن اسكريپت يك متغير را با نوع داده اي خاصي طلب ميكند ، اكشن اسكريپت بصورت اتوماتيك نوع آن را تغيير ميدهد تا نوع داده اي مطلوب حاصل شود . بطور مثال وقتي شما مقداري را به دستور trace ميدهيد مقدارش به نوع داده رشته اي تغيير ميكند و سپس آن را نمايش ميدهد . در عبارت هايي كه عملگر هاي رياضي و مانند آن قرار دارند اكشن اسكريپت متغير ها را به نوع داده اي مورد نياز تبديل ميكند . مثلا در عبارت زير 7 يك عدد است كه براي جمع با رشته تبذيل به رشته ميشود .

"Next in line, number " + 7

پس از تبديل جواب جمع رشته بصورت زير در ميايد :

"Next in line, number 7"
 وقتی شما اسکریپت هایتان را اشکال زدایی میکنید نگاهی به نوع متغیرها بیندازید.
کد زیر نوع متغیر را اعلام میکند
trace(typeof(نام متغير));

قلمرو يك متغير :

قلمرو يك متغير به محدوده اي ميگويند كه آن متغير در آن شناسايي ميشود و ميتوان به آن دسترسي داشت . سه نوع قلمرو براي متغير ها در اكشن اسكريپت موجود است .

  • متغير هاي local (محلي) : اين متغيرهادر بلوك كد خودشان قابل دسترسي هستند (كه بلوك كد آنها با آكولاد محصور ميشود) .
  • متغير هاي Timeline : كه در هر تايم لايني كه از Target path استفاده كنيد قابل دسترسي هستند .
  • متغير هاي عمومي (global) : كه در هر تايم لايني قابل دسترسي است . حتي اگر از target path استفاده نكرده باشيد .

براي اعلام كردن يك متغير(declare) ميتوانيد از عبارت var استفاده كنيد . بطور مثال متغير هاي j و i معمولا براي استفالده در حلقه ها استفاده ميشوند (البته هر اسمي ميشه گذاشت ، فكر نكني اسمش چيز خاصي داره ها .. اما خوب برنامه نويسا به يه سري اسامي عادت كردن ديگه) .

در كد زير i به عنوان يك متغير محليبگار رفته كه فقط در فانكشن makedays وجود دارد .

function makeDays() {
               var i;
               for( i = 0; i < monthArray[month]; i++ ) {
                               _root.Days.attachMovie( "DayDisplay", i, i + 2000 );
                               _root.Days[i].num = i + 1;
                               _root.Days[i]._x = column * _root.Days[i]._width;
                               _root.Days[i]._y = row * _root.Days[i]._height;
                               column = column + 1;
                               if (column == 7 ) {
                                              column = 0;
                                              row = row + 1;
                               }
               }
}

اعلام كردن يا مقدار دهي متغير (declaration):

  • براي ديكلر كردن متغير هاي تايم لاين ، از اكشن set variable استفاده ميشود و يا از عملگر مساوي . هر دو متد يك كار را انجام ميدهند .
  • براي ديكلر كردن متغير هاي محلي از عبارت var در داخل فانكشن ها استفاده ميشود . يك متغير محلي در بلوك فانكشن محصور است و با رسيدن كد به خط پاياني فانكشن ، متغير محلي (اصطلاحا) ميميرد . متغير محلي اي كه در داخل بلوك نباشد با رسيدن به پايان اسكريپتش مي ميرد .
  • براي دكلر كردن متغير هاي عمومي (global ) از عبارت _global قبل از اسم متغير استفاده ميشود. كدي كه مشاهده ميكنيد يك متغير عمومي بنام myname ميسازد :

_global.myName = "SHARAFI";

استفاده از يك متغير :

به مثال زير توجه كنيد :

getURL(myWebSite);
myWebSite = "http://www.macromediax.net";

اين كد دچار مشكل است و باعث ايجاد خطا در اسكريپت ميشود . چون در اين كد ابتدا از يك متغير استفاده كرده ايم و بعد آن را مقدار داده ايم . پس مقدار دهي بايد قبل از استفاده صورت گيرد .

يك مثال ديگر : در مثال زير x مقدار 15 گرفته و سپس مقدارش در Y كپي شده . در خط سوم مقدار x مساوي با 30 شده است . اما مقدار Y همان 15 ميماند . چون Y مقدارش را از X كپي گرفته و ديگر كاري به كار هم ندارند .

var x = 15;
var y = x;
var x = 30;
نظر شما لينک مطلب
1383/04/14
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


اهميت رنگ در طراحي وب

ما در هنگام صحبت با ديگران علاوه بر حرف زدن كارهاي ديگري نيز مانند خنديدن ، اشاره كردن ، نگاه كردن ، عصباني شدن و غيره انجام ميدهيم . تمام اين كار ها در ارتباط برقرار كردن ما با مخاطب تاثير دارد و گاهي بسياري از حرف ها را با چيزي غير از زبان بيان ميكنيم . يك صفحه وب نيز بايد بتواند علاوه بر انتقال مطالب ، احساس طراح وب آن صفحه را نيز بيان كند . اين كار را رنگ ها در طراحي وب انجام ميدهند . حس خشم ، محبت ، شادي و حتي اعتماد از طريق رنگ ها به بيننده منتقل ميشود .

رنگ ها و معاني آنها :

رنگ سبز و سفيد با هم تركيب مناسبي بوجود مي آورند . اما در ژاپن يك گل ميخك صد پر سفيد نشان مرگ است و در چين كلاه سبز به معناي خيانت يك زن به شوهرش معني ميدهد . كلاه سبز با ميخك سفيد نشان زيبايي براي لوگوي يك شركت نميتواند باشد . گرچه سبز رنگ آرامش بخش است ( بهمين دليل در بيمارستان ها استفاده ميشود ) و در ضمن رنگ سبز راحت تر از بقيه رنگ ها در چشم انسان آناليز ميشود . تركيب هاي گوناگون رنگ سبز معاني گوناگوني ميدهد . تركيب سبز و زرد كمترين طرفدار را بين بينندگان دارد .

قرمز براي افزايش فشار خون و سرعت ضربان قلب استفاده ميشود . افرادي كه در محيط قرمز كار ميكنند معمولا سريعتر كار ميكنند ، اما اشتباهاتشان در كار بيش از ديگران است . اين رنگ اميال دروني مثل اشتها ، بي قراري و تنش عصبي را افزايش ميدهد . ايجاد يك سايت با دو رنگ آبي كمرنگ و قرمز كمرنگ ايده بسيار ضعيفي است .رنگ قرمز ملايم طولاني ترين طول موج را داراست و آبي ملايم كوتاه ترين را . هنگام نگاه كردن انسان به اين دو رنگ ، لنز چشم براي تنظيم زوم تغيير اندازه ميدهد . اما چون فركانس هاي رنگي اين دو رنگ با هم خيلي تفاوت دارد باعث خستگي چشم و ايجاد سردرد براي بيننده ميشود .

سايت هايي كه از از سايه هاي گوناگون آبي يا رنگ آبي و سفيد استفاده ميكنند بيشتر از بقيه ، مردم پسند بنظر مي آيند . چرا ؟ آبي آرامش ، استواري ، اميد داشتن و دانايي و بخشندگي را عرضه ميدارد . مردم ذاتا به سايت هاي آبي رنگ سريعتر اعتماد ميكنند . متن هاي آبي رنگ بيشتر در ذهن مردم به ياد ميماند . تركيب آبي و سفيد و بنفش نجابت و اصالت را در ذهن انسان ميسازد .

خدا را شكر كه سايت هاي زرد رنگ زياد نيستند . با وجود اينكه رنگ زرد نشان از جمع شدگي و تمركز است ، اما بسيار سخت و مشكل در چشم آناليز ميشود . رنگ اطاق را زرد كنيد: نتيجه اين ميشود كه بچه ها گريه بيشتري ميكنند و بزرگتر ها سريعتر عصباني ميشوند. رنگ زرد يك رنگ حسي و چشم فريب است و استفاده آن در ميزان كم بسيار جذاب و خوش ديد خواهد بود .

بذار كمي درباره نارنجي حرف بزنيم ،نارنجي باعث ميشه كه اجناس گرون قيمت در نظر افراد مناسب و خوب جلوه كند . نارنجي روشن تر سخت تر در چشم ديده ميشود . و به عنوان متن ها و بك گراند صفحه پيشنهاد نميشود . مقدار كمي نارنجي كمرنگ ميتونه كمك كنه كه يه سايت شاد و دلچسب بسازيد .

عمل و عكس العمل :

رنگ روي حس ما و ادراك ما و عكس العمل ما تاثير ميگذارد . يك بيننده با آگاهي از سايتتان وارد سايت شما شده است ، حال شما بايد او را همچنان سر شوق نگه داريد .شما 8 الي 10 ثانيه وقت داريد تا او را از لحاظ بصري جذب كنيد . با استفاده از رنگ شما ميتوانيد حس خوش آمد گويي و راحتي و اعتماد را به بيننده منتقل كنيد . اگر شما گرافيك هاي يك سايت را تغيير دهيد در اصل زبان گفتگوي تصويري آن را عوض كرده ايد و بدين سان است كه عكس العمل متفاوتي از بازديدكننده سايت سر ميزند.

قرار دادن يك محصول كه با آب سر و كار دارد (مثل لباس شنا و ... ) در زمينه بنفش و نارنجي قدرت فروش آن را كاهش ميدهد . رنگ هاي بنفش و نارنجي بطور سريع با آب و طبيعت ارتباط ندارند و يك ادراك غلط به بيننده منتقل ميكنند . قرار دادن همان محصول در رنگ آبي يا سبز باعث افزايش جذابيت آن محصول ميشود .

MMX سايت هايي كه اصطلاحا سايت هاي رنگين كماني هستند و از همه جور رنگ در هم استفاده كرده اند كمترين زمان بازديد توسط بيننده ها را دارند و بيننده خيلي سريع ازين سايت ها خارج ميشود . زيرا چشم براي ديدن رنگ هاي گوناگون زوم هاي گوناگوني ميكند و زود خسته ميشود . (سايت هايي كه رنگ سفيد در آنها غالب است و مقدار خيلي كمي از ديگر رنگ ها در آن در بخش هاي گوناگون ديده ميشود جزو اين دسته نميشوند ) . هر چه تعدد رنگ ها كم شود مدت زمان ماندن بازديد كننده در صفحه زياد ميشود . يك نكته در استفاده از رنگ هاي گوناگون اينه كه حداكثر از 5 رنگ استفاده كنيد و آنها را همگي از رنگ هاي گرم يا سرد استفاده كنيد و زمينه را سفيد بگذاريد . اين كار چشم ها را خسته نميكند و سايت هاي كودكان كه ميخواهند با استفاده از رنگ هاي گوناگون محيط شادي را ايجاد كنند اگر ازاين روش استفاده كنند فروش بهتري دارند .

رنگ هاي گرم و سرد :

رنگ هاي گرم تشكيل شده اند از : زرد ، نارنجي ، قهوه اي ، زرد-سبز و نارنجي- قرمز . يعني رنگ هايي كه با پاييز در تعامل هستند . بطور كلي رنگ هاي گرم گرايش به هيجان و تكاپو دارند . بسياري از مردم مقدار كم از اين رنگ ها را مي پسندند . بنفش و سبز رنگ هاي واسط هستند كه نه گرم و نه سردند و وابسته به ميزان رنگ قرمز يا زردي هستند كه در رابطه با رنگ آبي در آنها بكار رفته است . اگر رنگ آبي آن كم تر باشد بيشتر شبيه رنگ هاي گرم بنظر ميرسد .

رنگ هاي سرد عبارتند از : آبي ، سبز ، صورتي ها ، بنفش ها ، آبي-سبز ها ، سرخابي ها و آبي-قرمز ها . رنگ هايي كه بيشتر با بهار و تابستان در تعامل هستند . رنگ هاي سرد آرامش بخش هستند و محبوبيت بيشتري نزد مردم دارند . طراحي يك سايت با رنگ هاي گرم و سرد باعث گيج شدن بيننده ميشود و باعث ميشود سايت شلوغ و بي نظم و غير قابل اعتماد جلوه كند . طراحان سايت معمولا متوجه نميشوند كه تركيب رنگ هايشان گرم و سرد است . استفاده از چرخه رنگ ها مفيد است . دايره رنگ رنگ هاي اصلي ( آبي و قرمز و زرد) و رنگ هاي ثانويه ( نارنجي و سبز و بنفش) را نشان ميدهد . تركيب دو رنگ اصلي يك رنگ ثانويه ميسازد . تمامي رنگ ها از تركيب سياه و سفيد با رنگ هاي اصلي بوجود آمده اند .

اميدواريم با تركيب درست رنگ ها ، وب سايت هايي جذاب تر طراحي كنيد .
نظر شما لينک مطلب
1383/04/17
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها

آرايه ها نيز مانند ليست ها، براي ذخيره سازي مقادير متعدد، تحت يک نام مي باشند. اما، برخلاف ليست ها، اين ذخيره سازي در قسمت ها جدا از هم انجام مي گيرد و مانند ليست ها تمام مقادير در يک رشته اي از مقادير جدا شده به وسيله ي حرف جدا کننده ذخيره نمي گردند.

ليست ها داده هاي ساده مي باشند، چون فقط يک رشته مي باشند، در حالي که آرايه ها داده هاي پيچيده مي باشند، چون متشکل از چندين قسمت قابل آدرس دهي مي باشند و داراي چنيدن مقدار مختلف مي باشند.

ايجاد يک آرايه

برخلاف ليست، که يک رشته ساده مي باشد، آرايه ها نوع داده ي پيچيده اي مي باشند که توسط تابع ArrayNew() ايجاد مي گردند. مانند مثال زير :

<cfset myArray = ArrayNew(1) >

تکه کد بالا، يک آرايه ي يک بعدي ايجاد مي کند و آن را به ArrayNew تخصيص مي دهد. يک آرايه مي تواند تا 3 بعد داشته باشد.

ارجاع به عضوي از يک آرايه

براي دسترسي به عضوي از آرايه، مانند مثال زير عمل مي کنيم :

<cfoutput>#MyArray[2]#</cfoutput>

مثال بالا مقدار عنصر دوم آرايه را چاپ مي کند. بر خلاف اکثر زبان هاي برنامه نويسي، انديس آرايه در کلدفيوژن از يک شروع مي شود.

افزودن عنصري به آرايه

براي افزودن عنصري به آرايه از ArrayAppend() به شکل زير استفاده مي کنيم :

<cfset myArray = ArrayNew(1)>

<cfset ArrayAppend(myArray,”apple”)>

به تفاوت ArrayAppend و ListAppend توجه کنيد :

<cfset myList = ListAppend(myList, “apple”)>

<cfset ArrayAppend(myArray,”apple”)>

ListAppend مقدار ليست اصلي را تغيير نمي دهد، بلکه يک ليست جديد با يک مقدار جديد افزوده شده به انتهاي آن ايجاد مي کند. اما ArrayAppend تغييرات را روي آرايه ي اصلي اعمال مي کند، و مقدار بازگشتي آن در صورت موفقيت تابع true مي باشد و در غير اين صورت false مي باشد. بنابراين شما حتي نياز نداريد که مقدار بازگشتي را ذخيره کنيد.

همچنين براي افزودن عنصري به ابتداي يک آرايه از تابع ArrayPrepend مانند مثال زير استفاده مي کنيم :

<cfset ArrayPrepend(myArray,”lemon”)>

شما همچنين مي توانيد عنصري را ميان عناصر موجود اضافه کنيد . مثلا فرض کنيد آرايه ي ما داراي عناصر زير باشد :

1 : peach

2 : apple

شما مي توانيد عنصري را ميان عناصر اول و دوم اضافه کنيد . بدين منظور از تابع ArrayInsertAt به صورت زير استفاده مي کنيم :

<cfset ArrayInsertAt(myArray,2,”lemon”)>

پس از اجراي کد بالا آرايه ي ما داراي عناصر زير خواهد بود :

1 : peach

2 : lemon

3 : apple

شما همچنين مي توانيد يک عنصر براي آرايه بوسيله عمل تخصيص ايجاد کنيد. مثلا، براي آرايه ي بالا، کد زير را اجرا مي کنيم :

<cfset myArray[4]=”blueberry”>

حال، آرايه ي ما داراي چهار عنصر زير مي باشد :

1 : peach

2 : lemon

3 : apple

4 : blueberry

شما همچنين مي توانيد از مقدار دهي به برخي از عناصر صرف نظر کنيد :

<cfset myArray[6]=”pomegranate”>

پس از اجراي کد بالا آرايه ما به صورت زير مي باشد :

1 : peach

2 : lemon

3 : apple

4 : blueberry

5 : هيچ عنصري با انديس پنج وجود ندارد

6 : pomegranate

به آرايه ي بالا توجه کنيد، هيچ عنصري با انديس 5 وجود ندارد و اين به اين معني نيست که آرايه ي پنجم داراي مقدار خالي مي باشد، فقط، هيچ عنصري با انديس 5 وجود ندارد.

حذف عنصري از يک آرايه

براي حذف عنصري از آرايه مي توانيد از تابع ArrayDeleteAt به صورت زير استفاده کنيد :

<cfset ArrayDeleteAt(myArray,2)>

تابع بالا عنصر دوم از آرايه را حذف مي کند.

براي پاک کردن کل آرايه ، يعني حذف تمام عناصر از تابع ArrayClear مانند زير استفاده مي کنيم :

<cfset ArrayClear(myArray)>

بدست آوردن اطلاعاتي در رابطه با آرايه :

براي تست کردن اينکه آيا هيچ عنصري در آرايه موجود مي باشد يا نه ، از تابع ArrayIsEmpty به صورت زير استفاده مي کنيم :

<cfif ArrayIsEmpty(myArray)>

This Array is empty.

<cfelse>

This Array has some elements.

</cfif>

براي بدست آوردن تعداد عناصر يک آرايه از تابع ArrayLen بصورت زير استفاده مي کنيم :

<cfset numElements = ArrayLen(myArray) >

ArrayLen عناصر تعريف نشده را نيز حساب مي کند.

پيدا کردن عنصري در آرايه :

براي پيدا کردن عناصر در يک ليست دو تابع ListFind و ListFindnocase وجود داشتند، ولي هيچ تابعي براي جستجو بر روي آرايه ها وجود ندارد. بنابراين، براي جستجو در يک آرايه، بايد از cfloop مانند مثال زير استفاده کرد :

<cfloop from=”1” to=”#ArrayLen(myArray)#” index=”I”>

<cfif myArray[I] EQ “apple”>

<cfbreak>

</cfif>

</cfloop>

پس از اجراي کد بالا، I داراي انديس عنصر داراي مقدار apple مي باشد.

برخي توابع رياضي براي آرايه ها :

تابع ArrayMin براي پيدا کردن کمترين مقدار موجود در آرايه به کار مي رود.

تابع ArrayMax براي پيدا کردن بيشترين مقدار موجود در آرايه به کار مي رود.

تابع ArraySum براي پيدا کردن مجموع مقادير موجود در آرايه به کار مي رود.

تابع ArrayAvg براي پيدا کردن ميانگين مقادير موجود در آرايه به کار مي رود.

به عنوان مثال، به تکه کد زير توجه کنيد :

<cfset NumericArray=ArrayNew(1)>

<cfset NumericArray[1]=10>

<cfset NumericArray[2]=12>

<cfset NumericArray[3]=11>

<cfset NumericArray[4]=20>

<cfset NumericArray[5]=10>

<cfset Minimum=ArrayMin(NumericArray)>

<cfset Maximum=ArrayMax(NumericArray)>

<cfset Sum=ArraySum(NumericArray)>

<cfset Avg=ArraySum(NumericArray)>

تعويض جاي عناصر يک آرايه :

فرض کنيد عناصر آرايه ي ما به صورت زير باشند :

1 : peach

2 : lemon

3 : apple

4 : blueberry

براي تعويض جاي عنصر اول و عنصر سوم ، از تابع ArraySwap به صورت زير استفاده مي کنيم :

<cfset ArraySwap(myArray,1,3)>

حال عناصر آرايه ي ما به صورت زير مي باشند :

1 : apple

2 : lemon

3 : peach

4 : blueberry

مرتب سازي عناصر يک آرايه :

همانند ليست ها، شما مي توانيد عناصر يک آرايه را به راحتي مرتب کنيد :

<cfset ArraySort(myArray,”text”,”asc”>

پس از اينکه کد بالا اجرا شد، آرايه داراي عناصر به ترتيب زير مي باشد :

1 : apple

2 : blueberry

3 : lemon

4 : peach

اگر عنصر تعريف نشده اي در آرايه موجود باشد، و شما بخواهيد آرايه را مرتب کنيد، کلدفيوژن يک خطا ايجاد مي کند.

همانند براي ListSort()، دومين پارامتر تابع ArraySort، نوع مرتب سازي که مي خواهيد انجام دهيد را مشخص مي کند :

· Numeric : آرايه را به صورت عددي مرتب سازي مي کند. اگر عنصري از آرايه نتواند به يک عدد تبديل شود، يک خطا رخ مي دهد.

· Text : آرايه را به صورت الفبايي مرتب سازي مي کند، و حساس به بزرگي و کوچکي حروف مي باشد.

· Textnocase : آرايه را به صورت الفبايي مرتب سازي مي کند، و حساس به بزرگي و کوچکي حروف نمي باشد.

سومين پارامتر تابع ArraySort() مي تواند “asc” و يا “desc" باشد. بستگي دارد به اينکه شما مي خواهيد آرايه را به صورت از کوچک به بزرگ مرتب کنيد و يا از بزرگ به کوچک مرتب کنيد.

تغيير اندازه ي يک آرايه :

هر وقت که شما يک عنصر را به آرايه اضافه مي کنيد، مقداري حافظه از سرور کلدفيوژن براي آن عنصر تخصيص مي دهيد. اگر مقدار حافظه ي کافي در محل جاري آرايه موجود نباشد، کلدفيوژن مجبور است که تمام آرايه را يک جا به محل حافظه ي ديگري انتقال دهد. اگر تعداد زيادي عنصر در آرايه موجود باشد، اين عمليات از CPU و حافظه بيهوده استفاده مي کند.

به خاطر بهنيه سازي، اگر تعداد عناصر يک آرايه را از اول مي دانيد، مي توانيد قبل از شروع به افزودن عناصر به آرايه بوسيله ي تابع ArrayResize حافظه مورد نياز را از قبل اختصاص دهيد. مانند مثال زير :

<cfset ArrayResize(myArray, 500)>

براي بدست آوردن حداکثر بهينه سازي، از تابع ArrayResize بلافاصله بعد از استفاده از ArrayNew استفاده کنيد.

تبديل بين آرايه ها و ليست ها

براي تبديل يک آرايه ي موجود به يک ليست جديد، از تابع ArrayToList به صورت زير استفاده مي کنيم :

<cfset NewList = ArrayToList(myArray)>

براي تبديل يک ليست موجود به يک آرايه ي جديد، از تابع ListToArray به صورت زير استفاده مي کنيم :

<cfset NewArray = ListToArray(myList)>
نظر شما لينک مطلب
1383/04/20
هادی مشیدی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید

بسياري از وب سايت ها هستند كه نميتوانند ترافيك كافي را براي سايت خود بدست آورند ، يكي از اين علت ها يك نكته ساده است : ” وب سايت براي موتور هاي جستجوگر بهينه نشده “ . در اين مقاله اعمالي كه براي بهينه سازي وب سايت در برخورد با موتور هاي جستجو بايد صورت گيرد شرح داده ميشود :

1. صفحات را مطابق ميل جستجوگر ها طراحي كنيد :

براي يك موتور جستجو گرافيك سايت شما يا فلش ها و كد هاي جاوا اسكريپت جذابي كه ساخته ايد اهميتي ندارد . بلكه چيزي كه يك موتور جستجو نياز دارد روان بودن كد نوشته شده در صفحات است . منظور من نوشتن كامنت در بين تگ ها يا رعايت كردن فاصله ها نيست بلكه استفاده از تگ هايي است كه جستجوگر ها از آنها استفاده ميكنند . تگ هاي مهم در يك صفحه وب عبارتند از : تگ title و description و Keywordsو Alt . ( اين روزها بعضي از موتور هاي جستجو فقط از تگ Keywords براي ارائه نتايج استفاده ميكنند ).

چند نكته :

· اگر از جدول ها براي ساخت صفحات سايتتان بهره گرفته ايد ، سعي كنيد از كد هاي ساده استفاده كنيد نه از تگ هاي تو در توي پيچيده .

· استفاده از فريم ها باعث سر گيجه موتور هاي جستجو ميشود كه به ضرر شماست . در ضمن استفاده از فريم ها ديگر در طراحي سايت ها متداول نيست .

· اگر از كد هاي جاوا اسكريپت استفاده كرده ايد براي فراخواني فايل هاي جاوا اسكريپت خارجي از كد هاي كوتاه استفاده كنيد .

· استفاده از تگ Alt در تگ تصاوير موتور هاي جستجو را در يافتن موضوع تصاوير كمك ميكند . حتما از اين تگ براي عكس ها استفاده كنيد .

· متن اصلي را قبل از عكس ها در صفحاتتان قرار دهيد و يا حداقل عكس ها را در ميان متن قرار دهيد .

2. كلمات كليدي Keywords :

استفاده از اين تگ بسيار اهميت داره و نوع كلمات استفاده شده در اون هم مهمه . سايت wordtracker كلمات كليدي خوبي را براي هر نوع سايتي پيشنهاد ميدهد كه ميتوانيد از آن بهره بگيريد . تعداد كلماتي كه ميتوان در اين تگ استفاده كرد محدوديت خاصي ندارد ، اما براي حصول نتيجه بهتر از 10 الي 15 كلمه برتر استفاده كنيد .

3. محتواي سايت :

بسياري از موتور هاي جستجو از متن اصلي صفحات براي يافتن كلمات كليدي استفاده شده در تگ keywords استفاده ميكنند . پس استفاده درست از كلمات كليدي و مطابقت آن كلمات با متن شما بسيار اهميت دارد. كلمات اصلي متن را در تگ heading و يا bold بگذاريد و يا آن را لينك كنيد تا جستجوگر ها به آن لغات اهيت ويژه اي دهند .

4. عنوان سايت :

تگ title يكي از مهم ترين بخش ها از ديد جستجوگر هاست . عنوان صفحات نيز بايد مانند كلمات كليدي درست و مطابق متن انتخاب شود . چون گاهي موتور هاي جستجوگر به عناوين صفحات بيش از كلمات كليدي اهميت ميدهند . تعداد كلماتي كه در عنوان صفحات استفاده ميكنيد نيز براي اينكه از حد استاندارد جستجوگر ها خارج نباشد بايد حداكثر 9 كلمه باشد .

5. تگ توضيحات :

موتور هاي جستجو هنگام نشان دادن نتايج جستجوي خود ، اطلاعات تگ متاي توضيحات هر صفحه را براي نمايش توضيحات آن سايت نمايش ميدهند .بنابراين نوشتن توضيحات جذاب و درست بيننده را به سوي سايت شما جذب ميكند . استاندارد تعداد كلمات اين تگ 20 الي 25 كلمه ميباشد .

6. گرافيك :

استفاده از عكس اگر چه زيبايي خاصي به سايت شما ميدهد اما حتي با تگ ALT نيز يك عكس به اندازه چند كلمه قدرت ندارد . چون موتور هاي جستجو فقط كلمات را ميشناسند و عكس ها را هم با تگ Alt آنها شناسايي ميكنند . بنا براين استفاده از عكس به جاي لينك و يا بجاي متن از خوانايي سايت شما براي چشم هاي يك موتور جستجوگر مي كاهد .

7. نقشه سايت :

نقشه سايت كمك بسياري به جستكوگر ها ميكند تا تمام صفحات سايت شما را شناسايي كنند . ابزار هاي زيادي بر روي وب هست كه نقشه سايت شما را در چند كليك ميسازد .

8. لينك هاي هدايتگر :

لينك هايي كه به ديگر صفحات سايت ميدهيد بايد ساده باشد . استفاده از منوهاي pop up‌ و فلش و مانند آن از خوانايي لينك هاي شما مي كاهد .اگر مجبور به استفاده از لينك هاي پيچيده در طراحي سايت هستيد ميتوانيد از لينك هاي ساده در انتهاي صفحات استفاده كنيد تا موتور هاي جستجوگر نيز بتوانند لينك هاي شما را شناسايي كنند .

رعايت اصول فوق باعث ميشود تا سايت شما در نتيجه جستجوي جستجوگر هاي معروف رتبه بالاتري را بدست آورد .
نظر شما لينک مطلب
1383/04/26
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


معرفي پايگاه داده SQL Server 2000
SQL Server 2000 يك Engine پايگاه داده ارائه شده توسط شركت مايكروسافت است و ادامه ويرايش SQL Server 7.0 است. بدون اقراق ميتوان گفت اين محصول پر كاربرد ترين Package پايگاه داده محسوب ميشود. البته مايكروسافت ادعا كرده است كه بيش از 60 % بازار Database جهان را به خود اختصاص داده و اين روز به روز در حال افزايش است. شركت IBM در اواخر دهه 70 زبان SEQUEL كه براي Query ها (پرس و جو ها ) استفاده ميشد را ابداع كرد. با تغيير زمان اين زبان نيز تغييراتي كرد و تا آنجا كه فقط براي Query ها استفاده نميشد و از آن ميتوانستيم براي Administrating (مديريت) و Sequrity (امنيت) در Database نيز استفاده كنيم و بعد از مدتها اين زبان به SQL تغيير نام داد. امروزه ورژنهاي متعددي از اين نرم افزار استفاده ميشود كه نرم افزار Microsoft SQL Server 2000 از Transact SQL كه به آن TSQL هم ميگويند استفاده ميكند. SQL Server 2000 هم اكنون داراي 2 نسخه است : يكي SQL Server 2000 Personal Edition كه بر روي Client نصب ميشود (Windows 98 – Windows ME – Windows 2000 Proffessional – Windows XP Home Edition – Windows XP Proffessional Edition) البته اگر بر روي Windows 98 و Windows ME نصب كنيم ، بسياري از قابليتهاي اين Package از بين ميرود. بهترين حالت نصب اين نسخه بر روي سيستم عاملهاي Windows 2000 Proffessional و Windows XP Proffessional است. يك نسخه ديگر اين نرم افزار : SQL Server 2000 Enterprise Edition است كه مختص Server ها است يعني فقط بر روي تمامي نگارش هاي Window 2K Server و Windows Server 2003 نصب ميشود.
نظر شما لينک مطلب
1383/05/07
رامین خوشحال

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها

يك عبارت (معمولا عبارت رياضي)جمله ايست كه فلش ميتواند مقدارش را محاسبه كند و يك مقدار برگرداند .شما ميتوانيد با تركيب فانكشن ها ، عملگر ها و استفاده از و مقدار هاي داده شده يك عبارت بسازيد . وقتي در پنل اكشن در حالت نرمال يك عبارت بنويسيد بايد گزينه Expression را در كنار جعبه متني اي كه عبارت را در داخل آن مينويسيد تيك بزنيد تا فلش آن را بعنوان يك عبارت در نظر بگيرد و هنگام استفاده از آن ، آن را محاسبه كند ، نه اينكه آن را مستقيم استفاده كنيد . در صورت تيك نزدن گزينه Expression فلش آن را بعنوان يك رشته در نظر ميگيرد .

انواع عملگر ها در فلش :

1- عملگر هاي عددي

2- عملگر هاي مقايسه اي

3- عملگر هاي رشته اي

4- عملگر هاي منطقي

5- عملگر هاي Bitwise براي اعداد شناور

6- عملگر هاي تساوي

7- عملگر هاي انتقالي

8- عملگر هاي دسترسي آرايه و نقطه

1 - عملگر هاي عددي :

كارشان جمع و تفريق و ضرب و تقسيم است ، بيشترين كاربرد عملگر افزايشگر ، استفاده i++ بجاي i = i+1 است . عملگر افزايشگر هم قبل و هم بعد از متغير ها ميتواند بيايد . با يك مثال فرق آنها را متوجه ميشويد :

if (++age >= 30)

در مثال فوق ابتدا Age افزايش يافته و سپس مقايسه صورت ميگيرد .

if (age++ >= 30)

در مثال دوم ابتدا مقايسه صورت ميگيرد و سپس Age افزايش ميابد .

عملگر | كار عملگر
+ | جمع
* | ضرب
/ | تقسيم
% | Mod (باقيمانده تقسيم)
- | تفريق
++ | افزايش
-- | كاهش

2 - عملگر هاي مقايسه اي :

اين عملگر ها مقادير عبارات را بررسي کرده و يک مقدار بولين بر ميگردانند . و اکثرا در اکشن هاي if دار و در حلقه ها استفاده ميشوند .

عملگر | كار عملگر
< | کوچک تر از
> | بزرگتر از
<= | کوچکتر مساوي
>= | بزرگتر مساوي

3 - عملگر هاي رشته اي :

عملگر + يك حالت خاص را روي رشته ها انجام ميدهد و آن متصل كردن رشته ها به يكديگر ميباشد . مثالي براي جمع دو رشته :

"Congratulations, " + "Donna!"
نتيجه بصورت زير در مي آيد :
"Congratulations, Donna!"

3 - عملگر ها ي منطقي:

اين عملگر ها مقادير بولين را با هم مقايسه ميكنند و يك مقدار بولين بعنوان جواب پس ميدهند .

بطور مثال اگر هر دو مقدار داده شده به عملگر and مقدار true باشد جواب نهايي and مقدار true خواهد بود ،عملگر OR زماني مقدارش true ميشود كه حداقل يكي از مقادير داده شده به آن true باشد . عملگر not يك مقدار را ميگيرد و اگر آن مقدار درست نباشد (يعني false باشد ) آنگاه مقدار not برابر با true ميشود . به مثال زير توجه كنيد :

if (i > 10 && _framesloaded > 50){
         play();
}

جدول زير نمونه هاي عملگر منطقي را نشان ميدهد .

Operator | Operation performed
&& | Logical AND
|| | Logical OR
! | Logical NOT
نظر شما لينک مطلب
1383/05/20
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


برای نصب ویژوال استودیو دات نت چه کنیم ؟

اگر میخواهید هم ویژوال استودیو 6 را داشته باشید و هم دات نت باید بگویم هیچ مشکلی وجود ندارد . این دو محیط براحتی در کنار هم نصب میشوند . پس نگران برنامه های نوشته شده در محیط قبلی نباشید.

  1. بعد از نصب ویندوز XP به کنترل پنل بروید و از بخش Add/remove وارد کامپوننت های ویندوز شوید و IIS را نیز تیک بزنید . Win XP CDROM را از شما میخواهد تا نصب شود .
  • بعد از نصب اگر با ASP کار میکنید فرانت پیچ را نیز نصب و server extensions را پیکر بندی کنید و سپس برای داشتن محیط قبلی مانند VB6 و VC++ ، ویژوال استودیو 6 را نصب کنید .برای امتحان نصب IIS باید Internet Explorer را باز کنید و به آدرسhttp://localhost/ بروید . اگر این آدرس باز شد نشان از درست نصب شدن IIS دارد .
  2. حالا نوبت به نصب Visual Studio.net میرسد. بهتر است نسخه 2003 آن را تهیه و نصب کنید . در مرحله اول از شما میخواهد تا کامپوننت هایش را که در یکی از CD هاست نصب کنید و بعد خود برنامه را نصب میکند . بعد از آن نیز میتوانید SQL server 2000 را نصب کنید.
  3. حالا به منوی start و programs و بعد وارد شاخه Microsoft Visual Studio .NET شوید و Microsoft Visual Studio .NET را اجرا کنید . همانطور که میبینید تمام زبان های برنامه نویسی در کنار هم در این محیط نوشته میشوند و محیط های vb.net از VC++.net و بقیه جدا نیستند . زبان خود را انتخاب کنید. برای نوشتن اپلیکیشن های تحت ویندوز گزینه windows application را برنید . وارد محیط برنامه نویسی مورد نظر میشوید و یک فرم جلوی روی شماست . جعبه کنترل ها در سمت چپ و بصورت کشویی باز میشود. چند کنترل روی فرم قرار دهید و اگر در VB.net هستید F5 را برای اجرای برنامه بزنید .فرم شما مانند VS6 اجرا میشود .
  4. به محیط جدید خوش آمدید . این محیط آنقدر ابزارهای مفید جدید دارد که دیگر حاضر نخواهید شد به محیط VS6 برگردید . مثلا یادتان هست که برای مرتب کردن tabindex در VB6 چه مشکلاتی بود ؟ در دات نت یک ابزار مخصوص این کار طراحی شده که کارتان را خیلی راحت میکنید. چند ابزار روی فرم بچینید و سپس به منوی view بروید و TabOrder را بزنید . حالا بترتیب روی کنترل ها کلیک کنید تا Tabindexآنها بر اساس کلیک شما مرتب شود. از این راحت تر ؟
نظر شما لينک مطلب
1383/05/24
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


دریم ویور : رویاباف طراحان وب

نام این نرم افزار به معنای رویاباف میباشد ، البته از نظر من ماکرومدیا در این مورد اصلا اقراق نکرده است . چون کار این نرم افزار آنچنان ظریف و استثنایی است که جز در رویای شما قابل تصور نیست . در این مقاله در مورد قابلیتهای نرم افزار Dreamweaver صحبت خواهد شد .

Dreamweaver MX 2004—Just Updated

کار دریم ویور چیست ؟

نرم افزار Dreamweaver از شرکت Macromedia در نگاه اول نرم افزار ساده ای جهت ساخت صفحات HTML (Hyper Text Markup Language) است . که به ما کمک میکند تا مجبور نشویم کدهای زبان HTML را حفظ کنیم و با چند حرکت و کلیک دستورات به زبان HTML انجام میشوند و در واقع باید بگوییم این نرم افزار Dreamweaver است که Tag های زبان HTML را کاملا حفظ کرده و برای ما انجام میدهد .

شاید اولین سوالی که برای شما پیش بیاید این است که چه اشخاصی به سوی نرم افزار Dreamweaver میروند و چرا از نرم افزار های رقیب Dreamweaver یعنی GoLive از شرکت Adobe و FrontPage از شرکت Microsoft استفاده نکنیم . جواب این است که نرم افزار Dreamweaver از شرکت Macromedia و همچنین نرم افزار GoLive از شرکت Adobe برای طراحان وبی است که کارهای گرافیکی میتوانند بکنند یا بهتر بگویم طراح گرافیکی هستند اما نرم افزار FrontPage از شرکت Microsoft برای کسانی بیشتر به درد میخورد که کار آنها اتوماسیون اداری است یعنی با مجموعه برنامه Office از شرکت Microsoft کار میکنند بهتر است . و ما چون زمینه کارمان گرافیک است از بین نرم افزارهای Macromedia Dreamweaver MX 2004 و Adobe GoLive CS نرم افزار Dreamweaver را انتخاب کردیم ، زیرا نرم افزار Dreamweaver با نرم افزار Fireworkes از همین شرکت Macromedia است به خوبی مکالمه میکند و نرم افزار GoLive با نرم افزار Adobe ImageReady به خوبی مکالمه میکند و ما نیز چون Target کارمان شرکت Macromedia است نرم افزار Dreamweaver MX 2004 را انتخاب کردیم .

Dreamweaver MX 2004 به جز ساخت صفحات HTML از نوع Static و Dynamic میتواند به ساخت صفحات با PHP و ASP و ASP.NET و JSP و ColdFusion نیز به ما کمک کند ، همچنین این برنامه فلش را بخوبی پشتیبانی میکند و همین امر در طراحی سرعت ما را افزایش و خطاهای ایجاد شده در فرانت پیج را در هنگام کار با فلش ها کاهش میدهد . این برنامه ساخت behavior ها را نيز بخوبي پشتيباني ميکنيد . امکانات ديگر آن در هنگام کار با برنامه چندان زياد است که گاهي از اينهمه ابزار به هيجان مي آييد . پس از اين پس براي بافتن روياهاي خود در وب يک روياباف داريد !
نظر شما لينک مطلب
1383/05/27
رامین خوشحال

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


اکشن اسکریپت : اولويت عملگر هاي فلش

وقتي در يك عبارت رياضي اكشن اسكريپت چند عملگر گوناگون را در كنار هم بكار ميبريد فلش براي بعضي عملگر ها نسبت به بقيه حق تقدم قائل ميشود . بطور مثال ضرب هميشه قبل از جمع انجام ميشود .گرچه پرانتز ها هميشه بر همه چيز تقدم دارند .

مثال زير را مشاهده كنيد :

Total = 2 + 4 * 3 ;

مقدار توتال در مثال فوق 14 است (اول ضرب و بعد جمع)

Total = (2 + 4) * 3 ;

در مثال دوم جواب 18 است . (اول پرانتز محاسبه شده و بعد ضرب)

جدول زير ليست عملگر هاي اكشن اسكريپت و موقعيت آنها و اولويت آنها را از بالا به پايين ليست كرده است .

عملگر | توضيحات | پشت هم آمدن
بالاترين اولويت
+ | Unary plus | راست به چپ
- | Unary minus | راست به چپ
~ | Bitwise one's complement | راست به چپ
! | Logical NOT | راست به چپ
not | Logical NOT (Flash 4 style) | راست به چپ
++ | Post-increment | چپ به راست
-- | Post-decrement | چپ به راست
( ) | Function call | چپ به راست
[ ] | Array element | چپ به راست
. | Structure member | چپ به راست
++ | Pre-increment | راست به چپ
-- | Pre-decrement | راست به چپ
new | Allocate object | راست به چپ
delete | Deallocate object | راست به چپ
typeof | Type of object | راست به چپ
void | Returns undefined value | راست به چپ
* | Multiply | چپ به راست
/ | Divide | چپ به راست
% | Modulo | چپ به راست
+ | Add | چپ به راست
add | String concatenation (formerly &) | چپ به راست
- | Subtract | چپ به راست
<< | Bitwise left shift | چپ به راست
>> | Bitwise right shift | چپ به راست
>>> | Bitwise right shift (unsigned) | چپ به راست
< | Less than | چپ به راست
<= | Less than or equal to | چپ به راست
> | Greater than | چپ به راست
>= | Greater than or equal to | چپ به راست
lt | Less than (string version) | چپ به راست
le | Less than or equal to (string version) | چپ به راست
gt | Greater than (string version) | چپ به راست
ge | Greater than or equal to (string version) | چپ به راست
== | Equal | چپ به راست
!= | Not equal | چپ به راست
eq | Equal (string version) | چپ به راست
ne | Not equal (string version) | چپ به راست
& | Bitwise AND | چپ به راست
^ | Bitwise XOR | چپ به راست
| | Bitwise OR | چپ به راست
&& | Logical AND | چپ به راست
and | Logical AND (Flash 4) | چپ به راست
|| | Logical OR | چپ به راست
or | Logical OR (Flash 4) | چپ به راست
?: | Conditional | راست به چپ
= | Assignment | راست به چپ
*=, /=, %=, +=, -=, &=, |=, ^=, <<=, >>=, >>>= | Compound assignment | راست به چپ
, | Multiple evaluation | چپ به راست
پايين ترين اولويت
نظر شما لينک مطلب
1383/06/06
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


Flash برای چه بوجود آمد ؟

نرم افزار Flash از شرکت Macromedia نرم افزاری است که شرکت ماکرومدیا به عنوان یک Solution یک راه حل در مرحله اول ایجاد کرد برای انتقال تصاویر Vector بر روی وب .

تصاویر Vector به چه معنی است ؟؟؟

دو نوع تصویر وجود دارد ، یکی تصاویر Pixel که در اصطلاح به آنها Raster هم گفته میشود و یکی دیگر تصاویر برداری یا Vector .

اوایل که اینترنت به وجود آمده بود سرعتهای Connection اینترنتی در حد سرعتهایی که هم اکنون ما در ایران از آن استفاده میکنیم هم نبود ، چه برسد به آن سرعتی که هم اکنون آمریکایی ها از آن استفاده میکنند . در آن زمان سرعتهای مودمهایی که معمول بود 9600 بیت در ثانیه بود بهد از آن به 14400 بیت در ثانیه تبدیل شد . 9600 یعنی در یک ثانیه 0.9 کیلوبایت میتوانست اطلاعات را Transfer کند . یعنی اگر قرار بود که تصویری ایجاد شود که این تصویر تبلیغات یک محصول قرار بود باشد و این تصویر 50 KB حجمش بود زمانی که لازم بود Data Transfer انجام بشه و تصویر ظاهر بشود در آن مودمها 55 ثانیه بود . در نتیجه انتقال اطلاعات در اینترنت بسیار بسیار کند اتفاق می افتاد . به همین دلیل بود که در HTML های ورژن 1 و 2 مرسوم نبود که از تصویر در سایت وب استفاده کنند و راحت تر بگویم اصلا Tag های مربوط به Image در آن زمان در زبان HTML وجود نداشت .

به تدریج که سرعتها افزایش پیدا کردند و سرعتها به 14400 و 28800 بیت در ثانیه رسیدند ، کم کم تصاویر Pixel در وب مطرح شدند و لی خوب یک چیزایی وجود داشت که هیچ الزامی پشتش نبود که این تصاویر بخواهد Pixel باشد مثلا آرم شرکت یا مثلا یک Title که قرار بود در بالای سایت قرار بگیرد و با یک فونت خاصی هم نمایش داده شود . اینها را اگر به یک شکلی میتوانستیم Vector انتقالشان دهیم خیلی خیلی سبکتر میشدند و در واقع یک صفحه وب هر چه حجمش کمتر باشد در اصطلاح به آن میگویند صفحه وب از لحاظ حجم بهینه است یا بهتره .

در یک نرم افزار گرافیک Vector اگر بخواهیم یک خط ترسیم کنیم ، نرم افزار گرافیک Vector برای ترسیم مختصات نقطه شروع و مختصات نقطه پایان را در خودش ذخیره میکند. یعنی 2 جفت عدد را یا بهتر بگم 4 تا دونه عدد را . ولی در نرم افزار گرافیک Pixel زمانی که بخواهیم یک خط بکشیم باید اطلاعات مربوط به تک تک این Pixel هایی که در روی خط قرار دارند بعلاوه تمام Pixel های دور آن را در خود ذخیره کند و هیچ فرمول ریاضی در این داستان نمیتواند دخالت کند و فقط میتوانیم در فرمتهای مختلف گرافیکی آنها را فشرده سازی کرد .

ولی در هر صورت حجم فایلهای Pixel اصلا قابل قیاس با فایلهای Vector نبود . دو شرکت آمدند و سعی کردند که این کار را انجام دهند ، یعنی آمدند یک قالب و یک روشی را پیدا کنند که فایلها را بتوانند به صورت Vector انتقال دهند. زیرا مرورگرها فقط فایلهای Pixel را میتوانند نمایش دهند .

یکی شرکت Adobe بود که آمد و یک چیزی اختراع کرد به نام SVG (Scalble Vector Graphic) و دیگری شرکت Macromedia بود که آمد و SWF (Shockwave Flash) را اختراع کرد .

پس هدف در مرحله اول انتقال تصاویر Vector بود به هدف سبک تر شدن حجم صفحات .

اما مرورگرهای وب به تدریج توانایی پخش این جریان را نداشتند در نتیجه یک چیزی به وجود آمد به نام Plugin که بر روی مرورگر دستگاه شخص نصب میشود که باعث میشود که آن گرافیک به نمایش در آید. مثلا Flash Player که از اینترنت دانلود میکنیم و یا از روی CD نصب میکنیم، همین نقش را به عهده دارد .

Flash به تدریج که تکامل پیدا کرد خیلی از داستانهای دیگری بود که به آن اضافه شد یعنی مثلا بحث انیمیشن در این برنامه مطرح شد – بحث موزیک در این برنامه مطرح شد – بحث برنامه نویسی در این برنامه مطرح شد .

تا قبل از این جریان که Flash انیمیشن را در خودش قرار بدهد میبایستی برای ساخت انیمیشن های اینترنتی از Gif Animation استفاده میشد که مشکلی که بود این بود که این قضیه باید فریم فریم ساخته میشد و مساله بعدی این بود که Gif Animation ها به صورت PIXEL بودند و Flash تصاویر Vector را به انیمیشن تبدیل میکند و این را هم باید بگویم که ساخت انیمیشن در Flash بسیار راحت تر از ساخت Gif Animation است .

امکان استفاده از موزیک در Flash یک امکان فوق العاده بود که یک استاندارد برای پخش موزیک در وب قرار دارد که این استاندارد MP3 بود .

ادامه داستان تا بعد ...
نظر شما لينک مطلب
1383/06/12
رامين خوشحال

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
  • براى وارد كردن يك پرس و جو در گوگل، فقط كافيست تا كلمات تشريحى خود را ورودى گوگل وارد كرده و بعد كليد 'enter' را بزنيد (يا برروى دكمه Search -- جستجو كليك كنيد) .گوگل از پيچيده ترين تكنيكهاى هماهنگی متون براى پيدا كردن صفحاتى كه مربوط به جستوى شما هستند استفاده ميكند. براى نمونه، وقتى گوگل صفحه اى را تجزيه و تحليل ميكند، گوگل به به صفحاتى كه به آن صفحه نيز لينك هستند نگاه ميكند تا ببيند كه شايد آن صفحات هم درخور با جستوى شما باشند. گوگل همچنين صفحاتى كه را كه موضوعى ارتباطى با موضوع جستجوى شما دارند را براى شما ترجيح ميدهد.
  • اگر میخواهید کلمات تایپ شده در جستجو باشند آنها را با فاصله بصورت ساده در کنار هم بنویسید . مانند : macromedia nokia agreement
  • اگر میخواهید یکی از کلمات شما حداقل در نتایج باشد بین آنها OR بگذارید . مانند : macromedia OR Nokia OR "YAHOO news"
  • اگر بخواهید یک کلمه حتما باشد و همراه با یکی از دو کلمه دیگر بیاید از حالت پرانتز میتوانید استفاده کنید . مانند :Persian (yahoo OR blog) . این جستجو دو عبارت را جستجو میکند : Persian Yahoo و Persian Blog
  • اگر بخواهید کلمه خاص شما در title صفحه موجود باشد باید از کلمه کلیدی intitle استفاده کنید . مثلا : intitle: "macromediax web services"
  • اگر بخواهید کلمه ای که وارد کرده اید بخشی از آدرس url صفحه ای باشد از inurl استفاده کنید . مثلا : inurl: "Persian" این جستجو تمام کلماتی که در آدرس سایت آنها کلمه پرشین موجود باشد را پیدا میکند .
  • اگر میخواهید گوگل فقط بدنه متون را جستجو کند از کلمه intext استفاده کنید . مثلا : intext: "access 2000 problems"
  • اگر میخواهید که گوگل فقط در یک سایت خاص دنبال مطلب وارد شده شما بگردد بعد از نوشتن موضوع جستجو از کلمه site به شکل زیر استفاده کنید : site:macromediax.com این کد در ادامه جستجوی شما باعث میشود تا گوگل بدنبال مقاله مورد نظر شما در سایت macromediax بگردد .
  • اگر شما یک سایت یا وبلاگ دارید و میخواهید بدانید چه کسانی لینک سایت شما را در سایتشان قرار داده اند از کلمه link با آدرس خودتان بشکل زیر استفاده کنید .link:www.macromediax.com
  • اگر میخواهید دنبال فایلهایی خاصی که با موضوع شما مرتبط هستند بگردید از کلمه filetype بصورت زیر استفاده کنید . programming vb filetype:pdf این کد جستجو فایل های pdf که درباره برنامه نویسی vb باشند را بشما نشان میدهد .
  • یک نکته در جستجو : گوگل حداکثر 10 کلمه را برای جستجو می پذیرد و اگر بیشتر باشد از بقیه کلمات صرفنظر میکند .
  • گوگل کلمات ربطی ساده مانند a , an , and , the ,of را نادیده میگیرد . برای اینکه این کلمات را هم جزو متن کلمات در خواستی شما در نظر بگیرد باید قبل ازین کلمات یک علامت بعلاوه + قرار دهید .
  • اگر بخواهید چیزی در جستجوی شما اصلا نباشد از علامت منفی در کنار آن کلمه خاص استفاده کنید . این حالت برای کد ها هم تاثیر دارد. مثلا میخواهید کلمه programming را جستجو کنید . اما نمیخواهید کلمه web در نتایج جستجوی شما باشد : پس مینویسید : programming –web
  • اگر بخواهیم تعداد نتایج دریک جستجو را مثلا به صد نتیجه در یک صفحه افزایش دهید از num=100 در متن جستجوی خود استفاده میکنیم .
  • براى فراهم سازى نتايج دقيق، گوگل از بند آوردن يا "wildcard" براى حمايت از جستجوهاى خود استفاده نميكند. براى مثال اگر شما "googl" را جستجو كنيد نتايج ارايه شونده شامل "googler" يا "googlin" نميشوند.
  • جستجوهاى گوگل حساس به حالت نوشتن (case sensitive)آنها نيست. تمامى كلمات بعد از ورود به حروف كوچك تبديل ميشوند. براى مثال اگر وارد كنيد "GOOGLE" يا "GoOgLe" به عنوان "google" شناخته ميشود.
نظر شما لينک مطلب
1383/06/16
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


ويژوال استوديو 2005 در راه است

در فوریه سال 2002 ارتقا دهندگان و مهندسین سیستم های کامپیوتری با Visual Studio .NET و .NET Framework آشنا شدند. این محصول برجسته محیط های توسعه هماهنگ و مدلهای برنامه نویسی را جهت ایجاد یک حوزه حل مشکلات نرم افزاری عرضه می دارد.

با آغاز به کار Visual Studio .NET 2003 مشتریان از یک منبع ثابت و تحقق یافته جهت ایجاد برنامه های کاربردی با کارایی حداکثر و قابلیت اطمینان بالا بهره مند شده اند.

همچنان با افزایش نیازهای بازار، شرکت مایکروسافت با استفاده از ابزارهای بدیع ارتقا سیستم های نرم افزاری، موفقیت مشتریان خود را که همواره با این نیاز در حال تغییر مواجه هستند، متعهد می شود.به منظور کمک به طرحهای توسعه نرم افزاری و آتی سازمانها، شرکت مایکروسافت در حال تهیه نقشه راهی برای پیشنهادات مربوط به ابزارهای ارتقا سیستم میباشد. این نسخه به ویژه بر روی محصولات ارائه شده (در بازار) که در ادامه آمده است متمرکز شده است.

ابزارهای Visual Studio برای سیستم های آفیس2003 شرکت مایکروسافت

در حال حاضر این تکنولوژی در نسخه beta، توسعه ای برپایه .NET Framework را جهت بهبود راه حل های عملی ارائه می دهد که برنامه های Word2003 و Excel2003 را هدف قرار داده است.

Visual Studio 2004 با اسم رمز (Whidbey)

این نسخه از Visual Studio و .NET Framework پیشرفت ها و نوآوری هایی را در بخش کتابخانه ای, زمان اجرای زبان مشترک (CLR)، زبان های برنامه نویسی و محیط های توسعه یکپارچه (IDE) ، ارائه می دهد.علاوه بر آن، این محصول به طور کامل قابلیت نوشتن stored procedure با استفاده از VB.NET و C# را برای نسخه جدید SQL Server با اسم رمز (YUKON) فراهم آورده است.

Visual Studio 2005 با اسم رمز (Orcas)

این نسخه از Visual Studio و .NET Framework یک سری ابزارهای پشتیبانی برای سیستم عامل ویندوز Longhorn فراهم کرده است.

با راه اندازی Visual Vtudio .NET 2002 و .NET Framework 1.0 شرکت مایکروسافت مدلهای برنامه نویسی به هم پیوسته، زبانهای برنامه نویسی پیشرفته و جدید و قدرتمندترین و یکپارچه ترین ابزارهای ارتقا سیستم خود تا به امروز معرفی کرده است.

یک سال بعد Visual Studio .NET 2003 و .NET Framework جهت بهبود نسخه اولیه آن عرضه می شود و ترکیبی بی سابقه را به همراه سیستم عامل ویندوز 2003 را بوجود می آورد. با این حرکت رو به جلو، مایکروسافت تمایل خود جهت تکمیل کدهای مدیریت شده (Managed Code) را نشان می دهد که این کدها در اکثر محصولات، نخست در SQL Server Yukon و سپس در سیستم عامل ویندوز سرور 2003 مورد تایید و حمایت قرار گرفته است.

در کنار این نقشه راه، مایکروسافت همواره جریان نوآوری در زمینه ابزار ها را دنبال می کند که این اقدامات به مشاغل امروزی و آینده این امکان را می دهد تا با استفاده از ابزاری بهتر نیازهای خود را مرتفع سازند.

منبع : kurdit.com
نظر شما لينک مطلب
1383/06/28
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آيا شما بيننده هاي سايت خود را فراري مي دهيد؟

آيا تا بحال فكر كرده ايد چرا سايت زيبايي كه طراحي كرده ايد به اندازه اي كه فكر ميكرديد بازديد كننده ندارد ؟ خوب شايد طراحي سايت شما مشكل داره … چيه ؟ بهتون برخورد ؟ زياد ناراحت نباشيد . چون ايرادات سايت شما رو الان بررسي ميكنيم . اين ايرادات باعث رنجيده خاطر شدن بازديد كننده هاي نازنينتون ميشه و درنهايت اونا كم كم اسم سايت شما رو فراموش ميكنند .(شما هم كه حساس ! )

1- PAGE CANNOT BE FOUND : بدترين چيز وجود لينك هاي شكسته در سايت است . هيچ چيز آدمو اينقدر عصباني نميكنه كه لينكي رو كليك كنه و با پيام PAGE CANNOT BE FOUND روبرو شه .

2- PAGE UNDER CONSTRUCTION : بهتره تا وقتي صفحه در حال ساخته لينك بهش ندين . چون باعث ميشه كه وقت بيننده شما در سايت تلف بشه !

3- MULTIPLE POP UPS : استفاده از پنجره هاي تبليغاتي بازشو بايد در زمان مناسب خودش باشه ، نه اينكه تا بيننده وارد سايت ميشه چند تا پنجره با هم باز شن و نذارن صفحه مورد نظرش رو ببينه . بيننده هاي سايتتون هيچ وقت شما رو بخاطر وقتي كه از اونا براي بستن اين پنجره ها تلف كردين نمي بخشند .

4- زمينه سياه : استفاده از زمينه سياه علاوه بر اينكه باعث ميشه متون داخل صفحه بسختي خونده بشن ، باعث ميشن سايت شما در حافظه نهان بيننده سايتي غير قانونمند و يا مزاحم بنظر بياد ( نكته روان شناسي ! )

5- متن ناخوانا : استفاده از متن هاي نامفهوم و پاراگراف هاي طولاني ذهن را خسته ميكند . هميشه از فونت هاي خوانا و با اندازه مناسب استفاده كنيد تا چشم در خواندن خسته نشود . استفاده از حالت هاي بولد و زير خط دار در جاي مناسب باعث خواناتر شدن متن شما ميشود .

6- عكس هاي بسيار بزرگ : استفاده از تصوير در طراحي سايت اهميت ويژه اي دارد . اما گاهي اين عكس ها بعلت حجم زياد مانع لود شدن سريع صفحه سايت شما ميشود و بيننده را ترغيب به بستن پنجره سايت شما ميكند ! هنگام استفاده از عكس حتما آن را با برنامه هايي مانند photoshop براي استفاده در وب بهينه كنيد تا از كمترين حجم ممكن بهره بگيريد .

7- فلش هاي ورودي سايت بدون دكمه skip : اگر دوست داريد در ورودي سايتتان يك فلش زيبا بگذاريد اشكالي ندارد . اما يادتان باشد كه حتما دكمه SKIP INTRO را در آن فلش تعبيه كنيد تا بيننده هايي كه ميخواهند مستقيم به اطلاعات سايتتان دسترسي بيابند پشت در هاي بسته فلش معطل نشوند .

8- عرض صفحه سايت بزرگتر از عرض مرورگر : اين مورد خيلي اهميت دارد . چون همه عادت دارند براي ديدن ادامه مطالب سايت بسمت پايين حركت كنند . نه چپ و راست . حالا اگه ميخواهيد بيننده خود را زجركش كنيد عرض سايتتون رو تنظيم نكنيد .

9- عكس هايي كه لود نميشوند : فرض كنيد وارد يك صفحه وب ميشويد تا مطلبي را بخوانيد . عكس مطلب مورد نظر لود نميشود ، چرا ؟ به هر دليلي . همين كافيست تا اعتبار سايت شما زير سوال برود .
نظر شما لينک مطلب
1383/07/02
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟

اين مدرك به عنوان مهندسي نرم افزار مايكروسافت مطرح شده و در تمامي دنيا داراي ارزش بسيار بالايي است . طبق گزارش سايت MCPmag ( سايت مجله الكترونيك مهندسان مايكروسافت) ميانگين درآمد سالانه مهندسان MCSD در آمريكا در سال گذشته حدود 75’000$ دلار بوده است.

چه درس هايي را براي دريافت MCSD.net بايد پاس كرد؟

هر درسي كه شما در امتحان پاس ميكنيد به عنوان يك كورس محسوب ميشود و مدركي كه به شما براي هر كورس اعطا ميشود MCP نام دارد . براي مدرك MCSD شما بايد 5 درس زير را بگذرانيد :

1- Windows application (VB.net)

2- Web application (ASP.net)

3- SQL Server

4- XML Web servicves

5- Solution Artchitecture

مدرك ديگري نيز بنام MCAD وجود دارد كه قبل از دريافت مدرك MCSD آن را دريافت ميكنيد . اگر شما 3 درس خاص از 5 درس بالارا بگذرانيد ، مدرك MCAD ميگيريد . حال با گذراندن 2 درس ديگر ميتوانيد مدرك خود را از MCAD به MCSD ارتقا دهيد .

3 درس مورد نظر براي مدرك MCAD عبارتند از :

1- Windows application (VB.net)

2- SQL Server

3- XML Web servicves

براي يادگيري دروس دات نت چه بايد كرد؟

در صورتي كه سررشته اي از برنامه نويسي داريد ، ميتوانيد در يكي از كلاس هاي معتبر VB.net در موسساتي كه هم اكنون در ايران اين دوره ها را برگزار ميكنند شركت كنيد (موسساتي مانند مجتمع فني تهران و شركت MIT و ...) . اگر تا كنون برنامه نويس نبوده ايد بهتر است يك دوره ويژوال بيسيك يا ويژوال بيسيك دات نت مقدماتي برويد تا كمي با برنامه نويسي آشنا شويد و توانايي شركت در اولين دوره را پيدا كنيد .

تعداد ساعات و هزينه كلاس ها و امتحان هاي دات نت :

هر كلاس دات نت حدود 50 ساعت است و حدود 150000 تومان هزينه بر ميدارد . هر امتحان دات نت 125 دلار آمريكا هزينه دارد (البته اگر در دبي امتحان دهيد) . در ايران چند شركت اين امتحان را برگزار ميكنند كه 185000 تومان بابت هر امتحان از شما ميگيرند (چون امتحان در ايران غير مجاز برگزار ميشود ، بعلت تحريم اطلاعاتي ايران).

امتحانات مايكروسافت به 2 حالت برگزار ميشود :

1- S tandard : 50 سوال دارد . امكان برگشت به سوالات جواب نداده هست و امتياز قبولي 720 از هزار مي باشد.

2- A daptive : تعداد سوالات بين 30 تا 70 متغير است. امكان برگشت به سوالات بعد از رد شدن از آنها وجود ندارد و امتياز قبولي 600 از هزار است . در اين حالت سوالات ، نسبت به جواب دادن هاي شما تغيير ميكنند . مثلا اگر سوال يك را جواب ندهيد سوال دو آسان ميشود . وقتي دومي را جواب بدهيد سومي سخت ميشود ....

تا وقتي كه شما سر جلسه امتحان ننشسته باشيد نميتوان نوع امتحان شما را حدس زد و نميتوانيد تعيين كنيد كه امتحان چگونه برگزار ميشود . امتحانات تحت اينترنت و بصورت آنلاين برگزار ميشود . مدت امتحان 90 دقيقه است . در صورتي كه زبان مادري شما غير از انگليسي باشد ميتوانيد درخواست 30 دقيقه خاطر زبانتان بدهيد كه ميشود 120 دقيقه .

پيشنهاد ما : قبل از امتحان حتما با نمونه تست هايي كه توسط اساتيد يا اينترنت در دسترس شما قرار ميگيرد خود را امتحان كنيد تا الكي پول خود را با قبول نشدن هدر نداده باشيد . بهتر است اولين امتحانتان را در تهران با هزينه 185000 تومان امتحان دهيد تا طرز امتحان و دلهره آن برايتان عادي شود . براي امتحانات بعدي هر 2 درس را كه خوانديد به دبي برويد و آنجا امتحان دهيد . چون هزينه 2 امتحان در دبي برابر با هزينه 2 امتحان در تهران است. اما يك امتحان در تهران بيشتر صرف ميكند .

(هر امتحان 125 دلاري مساوي با 100 هزار تومان كه دوتاي آن ميشه 200 هزار تومان و يك تور 170 هزار توماني سه روزه دبي هم بگيريد . روي هم 370 هزار تومان . درصورتي كه در تهران دوتا 185 هزار تومان ميشود 370 هزار تومان . كدام براي شما صرف ميكند ؟)

موفق باشيد.
نظر شما لينک مطلب
1383/07/11
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


چرا شما به يك سايت نياز داريد ؟

زاويه اول: شما براي خريدن مثلا يك كتاب تخصصي درباره فيزيك به چند جا سر ميزنيد ؟ چقدر براي رفتن به كتاب فروشي ها هزينه مي كنيد ؟ چقدر از وقت شما در ترافيك و گشت و گذار در پشت ويترين ها هدر مي رود ؟ چقدر خسته ميشويد ؟ چقدر CO2 تنفس مي كنيد ؟ و . . .

حال فرض كنيد بخواهيد آخرين نسخه برنامه winamp را داشته باشيد . در عرض 2 دقيقه كار انجام شده است . اتصال به اينترنت ، جستجو در وب و سپس دانلود برنامه مربوطه . خوب كدام راه بهتر است ؟

زاويه دوم : شما يك نويسنده هستيد. من كتاب قبلي شما را خريده ام و خوشم اومده . حالا شما كتاب دوم خود را نوشته ايد . چطور من را مطلع مي كنيد ؟ درسته . تبليغات. اما امروزه تبليغات در رسانه هاي عمومي بسيار هزينه بالايي را مي طلبد و براي شما كه يك نويسنده هستيد صرف نمي كند . پس چه مي كنيد ؟

زاويه سوم : توي اين دنيايي كه هزاران هزار محصول متنوع و جديد هر روز به بازار مياد و از هر جنس حداقل 1000 مدل داره توليد ميشه ، اسم شما هم بايد جايي در اين بازار ثبت شده باشه .شايد يه نفر دقيقا دنبال محصول شماست . توي يه منبع اطلاعاتي بزرگ كه همه شركت ها و صنايع در كنار هم ثبت ميشوند . يه منبعي كه همه بهش مراجعه مي كنند . مثل كتاب اول . مثل 118 . مثل كتاب زرد مثل . . . اينترنت.

افتتاح يك سايت چه مزايايي دارد ؟

1- شما علاوه بر تلفن و آدرس پستي يك راه ارتباطي ديگر نيز با مشتريان خود داريد : ايميل

2- نمايشگاه محصولات شما هميشه برپاست با كمترين هزينه . بدون اينكه قبض آب و برق و ماليات و ... داشته باشه

3- وقتي كسي در اينترنت مثلا بدنبال كتاب فيزيكي مي گردد كه شما آن را نوشته ايد يا ناشر آن هستيد در جستجوگري مثل گوگل خيلي راحت شما را پيدا مي كند .

4- مشتري براي دفعات بعدي خيلي بيشتر به فروشگاه آنلاين شما مراجعه ميكند ، چون فاصله مشتري تا آنجا فقط يك كليك است و هزينه اي هم ندارد!

5- هزينه تبليغات محصولات در اينترنت بسيار كمتر از رسانه هاي ديگر مانند تلويزيون و رايدو است . پس مي توانيد سايت خود را با هزينه اي بسيار جزئي در سايت هاي همكار تبليغ كنيد .

6- اظهار نظر در محيط شبكه براي همه آسان تر از گفتگوي تلفني يا نوشتن نامه است . پس خيلي بيشتر با مشتريان خود در تماس خواهيد بود .

7- مشترياني كه نمي توانند بصورت حضوري از شركت يا فروشگاه شما بازديد كنند ، حال ميتوانند حداقل محصولات شما را در سايتتان ببينند . اين مشتري ممكن است حتي در جزاير قناري باشد !

8- اگر محصولي توليد مي كنيد كه طيف وسيعي از نسل جوان از آن استفاده مي كنند ، مثلا يك كتاب يا نرم افزار ، كم كم وبلاگ ها و سايت هايي درباره محصول شما مطلب مي نويسند و باعث معروف تر شدن آن ميشوند . بدون اينكه حتي روح شما هم خبر داشته باشد .

9- براي اينكه در مقابل همكارانتان در محدوده كاري كم نياوريد ايجاد يك سايت از نون شب هم واجب تره .

10- تجارت الكترونيك در جهان يك چيز كاملا ساده و جا افتاده است . اما در ايران بعلل گوناگون ( از جمله نبودن كارت هاي اعتباري ) اين مورد هنوز براي مردم ما امري نا آشناست . اما تا دو سال آينده اوضاع عوض خواهد شد . اما اگر آن روز بخواهيد تازه شروع كنيد ، ديگر به پاي كساني كه امروز شروع كرده اند نمي رسيد . پس همين امروز براي برپايي سايت خود اقدام كنيد .

سايت طراح وب شما را در اين راه از لحظه آغاز تا به مقصد رسيدن همراهي و پشتيباني ميكند .

نظر شما لينک مطلب
1383/07/15
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


چگونه يك طراح وب پيدا كنيم ؟
خوب . حالا كه تصميم گرفتيد تا يك وب سايت داشته باشيد يك سوال مهم برايتان پيش مي آيد : چه كسي وب سايت من را طراحي كند ؟

مثال : خيلي ها هستند كه گيتار يا ارگ مينوازند و با كمي وقت و پيدا كردن يك شعر خوب ميتونند روي اون يه آهنگ بذارند و بخونند . اما آيا اونا آهنگساز هستند ؟!

طراحي وب نيز بهمين صورت است . گرچه برنامه هاي بسياري هستند كه كار طراحي صفحات وب را ساده كرده اند . اما هر كسي كه يك صفحه وب ساخت كه طراح وب نميشه ! ساخت يك وب سايت تاثير گذار و قدرتمند نيازمند تجربه و درك مسائل گوناگوني است كه در بالا بردن كيفيت سايت شما تاثير دارند . از جمله :

v بهينه سازي گرافيك هاي سايت

v طراحي براساس اصول maketing

v طراحي بر پايه قوانين موتور هاي جستجو

v طراحي براي تمام browser ها و سيستم عامل ها

v بالا بردن سرعت لود شدن سايت

v روان شناسي جذب مشتري در سايت

v ...

نكات مهم ديگر در طراحي سايت شما دخيلاند كه مستقيم به خود طراح بر ميگردد :

  • آيا طراح وب شغل شما را و علت طراحي اين سايت را براي شما مي داند؟
  • آيا سايت هاي همكاران خود را ديده ايد ؟ آيا طراح سايت شما ميتواند ايده هاي قدرتمندي براي پيشرفت سايت شما نسبت به رقباي شما ارائه دهد كه آنها تا كنون انجام نداده باشند ؟
  • آيا او ميتواند براحتي منظور شما را در طول طراحي سايت متوجه شود و با شما ارتباط ذهني يكساني برقرار كند ؟
  • آيا كار هاي قبلي او را ديده ايد ؟ آيا تمام سايت ها شبيه هم هستند ؟ يا هر گدام طرحي جداگانه دارند ؟
  • آيا او هر سايت را جداگانه طراحي ميكند ؟ يا شما بايد سايت خود را از يكي از قالب هاي پيش ساخته اش انتخاب كنيد ؟
نظر شما لينک مطلب
1383/07/24
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


يك سيستم مديريت محتوا (cms) چيست ؟

اين سيستم ها كه امروزه در وب بنام CMS شناخته ميشوند، مخفف Content Management System ميباشند كه يك برنامه نرم افزاري روي سرور هستند و به مدير سايت اجازه ميدهند تا محتواي سايت را تغيير دهد بدون نياز به طراحي دوباره سايت .

در واقع طراح اوليه سايت يكبار سيستم CMS را طراحي ميكند و تعدادي قالب آماده براي صفحات طراحي كرده و آن را روي سايت شما نصب ميكند .و حال شما براحتي ميتوانيد صفحات ديگري را به آن كم يا اضافه يا ويرايش كنيد .

چرا شما يك CMS لازم داريد ؟

اگر سايت شما هر چند وقت يكبار (مثلا هر دو هفته) به روز ميشود ميتوانيد بجاي اينكه هر بار به يك شركت طراحي وب مراجعه كنيد ، خودتان با نصب يكي از اين برنامه هاي مديريت محتوا ، تغييراتتان را روي سايت اعمال كنيد .

اگر شما سايت خود را اصلا بروز نميكنيد ، بايد كم كم به فكر بيافتيد ، چون بيننده هاي شما وقتي هميشه با يك صفحه هميشگي روبرو شوند كم كم شما را فراموش ميكنند ، چون چيز جديدي براي عرضه نداريد .

يك CMS چه امكاناتي دارد ؟

طيف وسيعي از امكانات . اكثر CMS ها در ورژن هاي مختلف و با قابليت هاي مختلف به بازار عرضه ميشوند . البته قابليت بروز كردن اطلاعات در همه مشترك است اما قابليت هاي ويژه ديگري دارند كه با قيمت هاي مختلف بشما پيشنهاد ميدهند . از جمله:

1- مديريت اطلاعات فرستاده شده توسط كاربران و تاييد اطلاعات

2- چند زبانه بودن

3- ايجاد نقشه سايت دايناميك

4- امكان ايجاد تجارت الكترونيك يا فروشگاه مجازي

5- ايجاد فرم براي دريافت اطلاعات كاربران

6- بهينه سازي تصاوير آپلود شده

7- ايجاد و بروز كردن متا تگ ها

8- امكان جستجو در مطالب سايت

9- امنيت بيشتر

10- گزارش آمار بازديد از صفحات

11- و ....

CMS هاي اطلاعاتي:

اين سيستم ها معمولا كار طراحي صفحات سايت را انجام نميدهند . بلكه كارشان مديريت اطلاعات يك سايت است . امكاناتي كه اين سيستم ها دارند تقريبا بشرح زير است :

1- امكان فرستادن اطلاعات به سايت توسط چند كاربر

2- آرشيو بندي اتوماتيك اطلاعات بر اساس تاريخ و موضوع

3- ايجاد امكان جستجو در اطلاعات قبلي

4- ايجاد لينك دائم براي هر مطلب و متا تگ براي آن

5- و امكانات جانبي ديگر مثلا ايجاد يك صفحه بعنوان لينكستان و ...

CMS هاي اطلاعاتي معروف :

MovableType

PHPnuke

php bb

ASP-rider يك سيستم فارسي

mmx سيستم سايت ما ( هنوز نسخه آزمايشي است )

…
نظر شما لينک مطلب
1383/08/01
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


گوگل در حال طراحی یک مرورگر وب

Go to Google Home

گوگل با فروش سهام خود 1700 میلیون دلار ثروتمند تر شده و از آن برای ربودن مغزهای صنعت IT استفاده کرده است . با استخدام هاو آقدامات کنونی ای که گوگل انجام داده بنظر می آید که گوگل در فکر ایجاد یک مرورگر وب باشد .زیرا :

1- گوگل "جوشوا بلاچ" – را که یکی از زبده ترین برنامه سازان زبانJAVA است- از چنگ شرکت سان در آورده است .

2- گوگل در 24 آوریل گذشته یک دامنه بانامGbrowser.com ثبت کرده است.

3- گوگل 4 تا از برنامه نویسان internet explorer را که دیگر در مایکروسافت کار نمیکنند به استخدام خود درآورده . یکی از آنان بنام "آدام باسوورث" در طراحی بانک اکسس مایکروسافت هم نقش مهمی داشته است .

4- گوگل "جو بدا" را که رئیس تیم برنامه نویسی رابط کاربر جدید ویندوز لانگهرن بود را نیز جذب کرده است.

5- گوگل در ماه گذشته میزبان مراسم "سالروز برنامه نویسان موزیلا" بود که در آن برنامه نویسان دنباله روی نت اسکیپ گرد هم میایند . (موزیلا یک مرورگر اوپن سورس است). احتمالا مرورگر فاير فاکس بزودي با نام گوگل عرضه خواهد شد .

6- گوگل چندین برنامه نویس جاوا اسکریپت و مرورگر و چندین گرافیست حرفه ای استخدام کرده است .گوگل بفکر تصاحب دنياي وب است تا بتواند کم کم مايکروسافت را از عرصه رقابت آنلاين خارج کند . چون کامپيوترهاي آينده فقط يک مرورگر لازم دارند تا بتوانند با دنياي الکترونيک ارتباط داشته باشند .
نظر شما لينک مطلب
1383/08/08
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


علت تاخیر شما در آپدیت از VB به VB.net

آیا برنامه نویس VB یا VC++ یا ASP هستید ؟ پس چرا بسوی دات نت نمیرین ؟ احتمالا یکی ازدلایل زیر هست که شما رو از رفتن بسوی تکنولوژیِ جدید بازداشته :

  • ترس از یاد گیری یک زبان کاملا متفاوت
  • مشکلات انطباق برنامه های نوشته شده در VB6 با VB.net
  • نداشتن تجربه در زبان جدید
  • نبود ابزار های مورد نیاز بصورت قبل در زبان جدید
  • نداشتن وقت مطالعه و یادگیری Syntax جدید
  • ....

دراین مقاله ما با معرفی دات نت و ویژگی ها و قدرت آن و شباهت های بسیاری که در سینتکس و منطق آن با Visual Studio وجود دارد شما را به یادگیری زبان جدید دعوت میکنیم .

اول از همه اینکه شعار تکنولوژی دات نت اینه :keep it simple یعنی سادگی را حفظ کن . تمام وجود دات نت بر اساس سادگی کار برنامه نویس طراحی شده تا مبادا برنامه نویسای محترم احساس ملال کنند ! و از گردونه برنامه نویسای مایکروسافتی بیرون بروند و به جمع برنامه نویسای زبان های رقیب مایکروسافت بپیوندند .

  • از اسم دات نت نترسید . کماکان همه چیز مثل ویژوال استودیو است .فرم های پروژه و افزودن فرم و ماژول، کنترل های تولبار ، طرز اجرای interpret ، ایجاد کلاس و ...
  • عملگر ها هنوز هم در VB.net به همان صورت+ - * / And , OR , Xor , \ هستند و روش استفاده هم مانند قبل . البته عملگر های جدیدی هم اضافه شده که از آنها لذت خواهید برد .
  • روش تعریف نوع داده ها و اشیاء و آرایه ها بصورت قبل است مانند :

Dim x as integer

Dim cnn as new connection

Dim mycube ( , ,) as integer

Dim cal as new collection

  • در بخش شیی گرایی و وراثت، دات نت خیلی پیشرفت کرده است . در VB6 چیز زیادی برای وراثت وجود نداشت و اصولا نیمه شیی گرا بود . اما این موضوع در دات نت بصورت کامل پشتیبانی میشود . مثلا وقتی برنامه شما 20 فرم تقریبا یکسان داره که در هر کدام فقط یک دکمه آن با بقیه متفاوته لازم نیست شما 20 فرم بسازید . بلکه یکی میسازین و بقیه رو از روی اون شبیه سازی میکنید و کمی تغییر میدین . این موضوع وقت شما را خیلی حفظ میکنه ( اسم شیی گرایی خیلی بزرگه . اما آنقدر ساده است که خودتان هم تعجب خواهید کرد .اگه ازش میترسین اصلا ازش استفاده نکنین ، غیر از راحت تر شدن برنامه نویسی چیزی رو از دست نمیدین ).
  • در دات نت رویدادها مانند گذشته است و تقریبا فرقی نکرده در ظاهر . پس اینم چیزی برای ترسیدن نداره !
  • در طراحی رابط کاربر نیز غیر از راحتی چیزی به آن افزوده نشده که برای شما ناشناخته باشه . مثلا یادتان هست که برای مرتب کردن tabindex در VB6 چه مشکلاتی بود ؟ در دات نت یک ابزار مخصوص این کار طراحی شده که کارتان را خیلی را حت میکنید. چند ابزار روی فرم بچینید و سپس به منوی view بروید و TabOrder را بزنید . حالا بترتیب روی کنترل ها کلیک کنید تا Tabindexآنها بر اساس کلیک شما مرتب شود. از این راحت تر ؟ نکنه میخواهید دیگه یه کلیک هم نکنین !
  • در زمینه Error Handling کار ساده تر شده و بجای اینکه از on error goto استفاده کنید از یک سینتکس ساده تر بصورت زیر استفاده میکنید . همانطور که میبینید کد اصلی در قسمت زیر try و کد هنگام ایجاد ایراد در زیر catch نوشته میشود ، بهمین سادگی .

Try

Your main code

Catch ex as system.exception

Code for error time

End try

  • در زمینهADO کار چندان تفاوتی نکرده است جز راحت تر شدن . طرز تعریف کانکشن و دیتا ست و ... تقریبا یکسان است :

Dim cmd1 As NEW oledb.oledbConnection

Cmd1.connectionstring= "provider=Microsoft.jet.oledb.4.0; datasource=c:\mydatabase.mdb"

خوب . پس برای ورود به دنیای دات نت شما مثل کسی هستید که تافل داره و میخواد وارد لندن بشه . ممکنه کمی لهجه انگیلسی غلیظ نداشته باشید ، اما میتونید براحتی با همه صحبت کنید . پس وارد این دنیای جدید بشید و بقول برنامه نویسا بگین : Hello World.
نظر شما لينک مطلب
1383/09/03
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


دات نت فریم ورک چیست؟

وقتی شما یک برنامه نصب میکنید علاوه بر فایل های اصلی برنامه که در ProgramFiles نصب میشود ، تعدادی هم فایل هستند که در شاخه ویندوز نصب میشوند . این فایل ها همان درایور های مورد نیاز ویندوز برای اجرای برنامه شما هستند که توسط برنامه نویس برنامه نوشته نمیشوند، بلکه آنها قبلا تعریف شده اند و برنامه نویس از قابلیت های آن در برنامه خود استفاده میکند . پس برای اینکه برنامه شما کارکند باید آن فایل ها به ویندوز شما اضافه شوند .

Framework مجموعه ای از فایل های مورد نیاز سیستم عامل (شامل فایل های DLL و رجیستری و واسطه های استاندارد ارتباط برنامه ها بایکدیگر) است که برای اجرای برنامه های نوشته شده تحت دات نت ضروری میباشد (توجه: برای اجرای برنامه های تحت جاوا نیز نیاز به نصب JAVA virtual machine دارید).

چون دات نت میخواهد از فلسفه سادگی “keep it simple” پشتیبانی کند بهمین دلیل، اساس کار نصب برنامه ها copy-only installation میباشد . یعنی دیگر نیازی به پکیج کردن برنامه ها توسط برنامه نویس و نصب توسط کاربر نیست . بلکه تمامی فایل های کتابخانه ای مورد نیاز را فریم ورک تامین میکند و برنامه ها با روش فقط کپی در ویندوز کار میکنند.

CLR چه کمکی به برنامه نویسان میکند ؟

برنامه نویسان زبان VB دیگر محدود به محیط سیستمی ویندوز نیستند و میتوانند مانند برنامه سازان زبان C/C++ برنامه خود را روی سیستم های دیگری که فریم ورک دارند نیز ببینند . و همچنین بخاطر قابلیت های چند زبانه بودن محیط دات نت برنامه نویسان C و VB براحتی کد های نوشته شده توسط دیگری را درک میکنند.
نظر شما لينک مطلب
1383/09/07
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


معرفی نرم افزار Capative

Macromedia Captivate Product Package

اين برنامه جهت ساخت فلش هاي مولتي مديا از روي صفحه مانيتور تهيه شده است . نسخه کوچکتر اين برنامه RoboDemo نام دارد که توسط همين شرکت عرضه شده است . براحتي و فقط با کليک روي اشيا پس از ضبط تصاوير ميتوانيد به آنها عنوان يا صدا و ... اضافه کنيد . اين برنامه تمام حرکات موس را ضبط ميکند. بهمين دليل کيفيت و حجم فلش صادره از برنامه بطرز مطلوبي دلخواه شماست . هم اکنون از اين برنامه براي ساخت cd هاي مولتي مديا استفاده ميشود . منبع

Download trial
نظر شما لينک مطلب
1383/09/09
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


تاریخچه استانداردهای تبادل داده مایکروسافت

وقتی ویندوز 3 توسط مایکروسافت معرفی شد روش اولیه برای برقراری ارتباط بین application ها تبادل داده داینامیک یا DDE نام داشت . DDE غیر قابل انعطاف بود و باعث کرش کردن سیستم نیز میشد و در یک دستگاه قابل استفاده بود. چندین سال برنامه ها برای ارتباط با هم در یک دستگاه از DDE استفاده می کردند .

بعد از این سال ها مایکروسافت کم کم DDE را کنار گذاشت و استفاده از مدل شیئ مشترک (COM) و DCOM را پیشنهاد کرد . COM برای ارتباط برنامه ها در یک دستگاه با هم و DCOM که نوع توزیع یافته ای از COM بود ، برای ارتباط دستگاه با سرور دور دست استفاده میشد . ضمنا یک ائتلاف از چند شرکت فروشنده متحد ( شامل IBM و SUN و Apple ) یک رابط تبادل داده متفاوت بنام CORBA ایجاد کردند . برخلاف COM ، CORBA در فرستادن پیام بین ماشین های مختلف بهتر عمل میکرد . اما متاسفانه در برنامه نویسی بسیار مشکل بود و زمان استفاده کوتاهش اجازه گسترش به آن نداد . در طول این مدت مایکروسافت تکنولوژی خود را گسترش میداد و COM+ و MTS و DNA را معرفی کرد .

Common object Model plus (COM+)

Microsoft Transaction Server (MTS)

Distributed Network Architecture (DNA)

این تکنولوژی ها اجازه بیشتری را در ارتباط پیچیده میان کامپوننت ها مقدور میساختند مانند: Dada pooling و transaction، متاسفانه این تکنولوژی ها نیاز داشتند که هر برنامه اطلاعات کاملی از برنامه مقابل داشته باشد ، بنابراین وقتی سیستم عامل ها متفاوت بودند (مثل لینوکس و ویندوز) این سیستم ها بخوبی کار نمی کردند . این حالت تا سال 2001 (یعنی تا آغاز تکنولوژی دات نت که تلفیقی از تکنولوژی COM و انعطاف CORBA است) ادامه داشت .

گرچه تکنولوژی دات نت اصولا عضوی از مایکروسافت است ، اما بنظر میاید که انعطاف پذیری آن بزودی قابل استفاده در سیستم های عامل دیگر خواهد بود .

دات نت فریم ورک روی تمامی سیستم های عامل مایکروسافت از ویندوز 95 به بعد قابل اجراست و یک نسخه بنام compact framework مخصوص ویندوز CE نیز در حال آماده سازی است . تمام سعی دات نت این است که سادگی خود را حفظ کند. (در ضمن: شرکت بورلند آخرین نسخه دلفی را بر اساس تکنولوژی دات نت پایه ریزی کرده است. )

مقاله از کتاب VB.net developer's guide از انتشارات SYNGRESS.
نظر شما لينک مطلب
1383/09/14
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


دستورهای شرطی در ColdFusion

برای تصميم گيری بر اساس شرايط مختلف می توان از ساخت if/else/elseif استفاده کرد :

<cfif condition>

<!--- Some code to go if condition is TRUE --->

</cfif>

ColdFusion چک می کند که آيا شرط condition دارای مقدار True می باشد يا False . اگر اين مقدار True باشد کد بين جفت تق را اجرا می کند. مانند مثال زير :

<CFIF myVar EQ MyOtherVar>

Two Variables are equal to eachother .

</CFIF>

اگر بخواهيد coldfusion يک کد خاص برای مواقعی که شرط False می باشد را اجرا کند از ساختار زير استفاده می کنيم :

<CFIF myVar EQ MyOtherVar>

Two variables are equal to eachother.

<CFELSE>

<!--- This part will be executed if the condition is FALSE --->

Two variables are not equal.

</CFIF>

شما می توانيد اين ساخت شرطی را با افزودن cfelseif گسترش دهيد :

<CFIF myVar Greater Than MyOtherVar>

<cfoutput>#myvar# > #myotherVar# </cfoutput>

<CFELSEIF myVar EQ MyOtherVar>

<cfoutput> #myVar# = #MyOtherVar# </cfoutput>

<CFELSE>

<cfoutput> #myVar# < #myOtherVar# </cfoutput>

</CFIF>

اگر شرط موجود در cfif صحيح نباشد شرط مجود در cfelseif های موجود به ترتيب چک می شود. اگر هيچ کدام درست نباشند ٬ کد موجود پس از cfelse اجرا می شود .
نظر شما لينک مطلب
1383/09/20
هادی مشیدی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


درك و رفع نقص پيام هاي error در كلد فيوژن

Macromedia ColdFusion MX

پيام خطاي : ColdFusion—Access Denied

اين پيام خطا هنگام كار با يكي از پايگاه هاي داده فايلي مايكروسافت (مانند Access و يا FoxPro) رخ ميدهد .هنگامي كه كلدفيوژن در حال دسترسي به پايگاه داده ها از طريق Data Source باشد . اين ايراد معمولا زماني رخ ميدهد كه شما مشغول رونويسي بانك داده ها از طريق FTP و يا كپي روي آن هستيد .

بهترين راه حل اين مشكل كنار گذاشتن coldfusion services و يا غير فعال كردن Maintain Database Connection از بخش data source در ColdFusion Administrator است .

پيام خطاي : ColdFusion—Operation must use an updateable query error

اين ايراد زماني رخ مي دهد كه سعي در اجراي يك صفحه كلد فيوژن داريد كه كارش آپديت يا پاك كردن ركوردي از يك بانك اطلاعاتي مايكروسافت مثل اكسس است.اين ايراد بصورت معمول زياد رخ ميدهد . چون كلدفيوژن اجازه دسترسي گسترده در سطح سيستم عامل شبكه براي نوشتن روي بانك اطلاعاتي ندارد .

براي حل اين مسئله در ويندوز NT به آدرس زير برويد :

Start > Settings > Control Panel > Services و روي ColdFusion Application Server service كليك كنيد و start-up account را بخاطر بسپاريد . در حالت پيش فرض بايد System Account باشد .بعد به پوشه اي برويد كه فايل بانك اطلاعاتي در آن است و به آن account اجازه دسترسي به پوشه مورد نظر را بدهيد. حتي اگر كنترل پوشه ميگويد همه (everyone) حق دسترسي دارند باز هم بايد اكانت ColdFusion startup را اضافه كنيد.

نظر شما لينک مطلب
1383/10/02
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


معرفی نرم افزار FlashPaper 2

توسط اين برنامه ميتوانيد فايل هاي قابل پرينت خود را تبديل به PDF و يا SWF کنيد . اين برنامه هر دو حالت را يکجا پشتيباني ميکند . با توجه به کاربرد زياد فلش روي وب و استفاده عموم کاربران از آن شما ميتوانيد براي انتشار مقالات و کتب خود روي اينترنت از اين فرمت عمومي استفاده کنيد . اين نسخه از برنامه امکان ساخت حالت مرور کردن صفحات را دارد . مثلا بازديد کنندگان ميتوانند فلشي را که شما توسط اين برنامه ساخته ايد مانند يک کتاب ورق بزنند و آنرا مرور کنند .

متن توليد شده توسط اين برنامه قابليت جستجو و انتخاب شدن و کپي و چسبانده شدن در تمامي برنامه هاي ويندوز و مکينتاش را داراست . همچنين ميتوانيد در فلش ساخته شده از انواع bookmark و link نيز استفاده کنيد . اين برنامه با آفيس مايکروسافت همخواني کاملي دارد که تبديل فايل هاي برنامه هاي آفيس را به فلش هاي زيبا مقدور ميسازد . حتي ميتوانيد ارائه هاي برنامه powerpoint را نيز به فلش تبديل کنيد . با نصب برنامه يک منوي اضافي به برنامه هاي آفيس شما اضافه ميشود که امکانات تبديل را در اختيارتان مي گذارد .

دانلود ۳۰ روزه رايگان نمونه کاغذ فلش
نظر شما لينک مطلب
1383/10/06
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش کلد فیوژن: انواع داده پيچيده : ليست ها

ليست ها در حقيقت رشته هايي هستند که مقادير در آن به وسيله ي يک کاراکتر خاص از هم جدا شده اند. مانند مثال هاي زير :

<cfset List_of_employees="Hadi Moshayedi,Hossein Sharafi,Ben Forta">
<cfset List_of_animals="Elephant;Horse;Monkey">
<cfset List_of_salaries="12000,1300,5000,4000">

به کاراکتري که مقادير را از هم جدا مي کند، Delimiter گويند. مثلا , (کاما) در مثال اول و ; در مثال دوم.
همانطور که در مثال هاي بالا ديديد، براي ايجاد ليست ها از <cfset ... > استفاده مي کنيم و مقادير اوليه را تنظيم مي کنيم.

افزودن مقادير به يک ليست :
ساده ترين راه براي افزودن يک مقدار به يک ليست استفاده از تابع ListAppend به صورت زير مي باشد :

<cfset myList="hadi,coldfusion,something">
<cfset myList = ListAppend(myList,"php")>

مثال بالا مقدار جديد "php" را به انتهاي ليست اضافه مي کند. اين تابع، داراي پارامتر سومي مي باشد که اختياري مي باشد و مي تواند مانند مثال بالا ذکر نشود. اين پارامتر سوم، Delimiter ليست را مشخص مي کند و به صورت پيش فرض مقدار آن کاما مي باشد. اگر در ليست از Delimiter ي به غير از کاما استفاده کرده باشيم، براي افزودن يک مقدار به انتهاي ليست به صورت زير عمل مي کنيم :

<cfset myList="hadi;coldfusion;something">
<cfset myList = ListAppend(myList,"php",";")>

ListAppend مقدار جديد را به انتهاي ليست اضافه مي کرد. براي افزودن يک مقدار به ابتداي ليست، از تابع ListPrepend ، به همان صورت که از ListAppend استفاده مي کرديم، استفاده مي کنيم. به مثال هاي زير توجه فرمائيد :

<cfset myList="a,b,c,d">
<cfset myList = ListPrepend(myList,"0")>
<!--- Now, myList contains "0,a,b,c,d" --->

<cfset myList="a;b;c;d">
<cfset myList = ListPrepend(myList,"0",";")>
<!--- Now, myList contains "0;a;b;c;d" --->

براي افزودن مقداري به ليست در يک مکان مشخص، از تابع ListInsertAt استفاده مي کنيم. به صورت زير :

<cfset myList="a,b,c,d">
<cfset myList = ListInsertAt(myList,3,"h")>

در مثال بالا، مقدار "h" سومين عنصر از ليست خواهد شد. مانند توابع ديگري که در اين مقاله معرفي گرديد، اين تابع نيز داراي پارامتر اختياري چهارمي هست که Delimiter ليست را مشخص مي کند و مقدار پيش فرض آن کاما مي باشد.

استخراج مقداري از ليست با استفاده از انديس آن
براي استخراج مقدار عنصري از ليست با استفاده از انديس آن، از تابع ListGetAt استفاده مي کنيم. به صورت زير :

<cfset myList="a,b,c,d">
<cfset second_item=ListGetAt(myList,2)>

کد بالا مقدار عنصر دوم ليست myList را در متغير second_item قرار مي دهد.
اين تابع نيز داراي پارامتر اختياري مشخص کننده Delimiter مي باشد.

توابع ListFirst و ListLast به ترتيب مقدار عنصر اول، و مقدار عنصر آخر ليست را مي دهند. تابع ListRest تمام عناصر يک ليست به غير از عنصر اول را به عنوان خروجي مي دهد.

<cfset myList="a,b,c,d">
<cfset first_item = ListFirst(myList)>
<!--- first_item contains "a" now --->
<cfset last_item = ListLast(myList)>
<!--- last_item contains "d" now --->
<cfset rest_items = ListRest(myList)>
<!--- rest_items contains "b,c,d" now --->

براي بدست آوردن تعداد عناصر يک ليست از تابع ListLen به صورت زير استفاده مي کنيم :

<cfset myList="a,b,c,d">
<cfset myListLen = ListLen(myList)>
<!---Now, myListLen Equals 4 --->
<cfset myList="a;b;c;d">
<cfset myListLen = ListLen(myList,";")>
<!---Now, myListLen Equals 4 --->

براي حذف عنصري از ليست، از تابع ListDeleteAt به صورت زير استفاده مي کنيم :

<cfset myList="a,b,c,d">
<cfset myList = ListDeleteAt(myList,2)>

کد بالا عنصر دوم ليست را حذف مي کند.

جستجو در ليست ها
براي پيدا کردن مقداري در ليست، از تابع ListFind استفاده مي کنيم. اين تابع موقعيت اولين عنصري که داراي مقدار دلخواه باشد را به عنوان خروجي بر مي گرداند.

<cfset myList="Hadi,Hossein,Ben">
<cfset Pos1 = ListFind(myList,"Ben")>
<!--- Pos1 equals 3 now --->

تابع ListContains موقعيت اولين عنصري که داراي مقدار شامل عبارت مورد نظر را به عنوان خروجي بر مي گرداند.

<cfset myList="Hadi,Hossein,Ben">
<cfset Pos2 = ListContains(myList,"se")>
<!--- Pos2 equals 2 now --->

کد بالا مقدار ۲ را در متغير Pos2 قرار مي دهد، زيرا عبارت Hossein شامل عبارت se مي باشد.
ListFind و ListContains بين حروف بزرگ و کوچک تفاوت قائل مي شوند. براي اينکه در جستجو حروف بزرگ و کوچک يکسان باشند به جاي توابع بالا از توابع ListFindNoCase و ListContainsNoCase استفاده مي کنيم.

ليست هاي داراي عناصر خالي
عناصر خالي، عناصري از ليست هستند که داراي هيچ مقداري نمي باشند. براي درک چگونگي کار با آن ها به مثال زير توجه کنيد :

<cfset myList = "Hadi,,Hossein,Ben,,">

فکر مي کنيد ليست myList داراي چند عنصر مي باشد؟ شايد فکر کنيد که اين ليست داراي شش عنصر مي باشد، ولي کلدفيوژن عناصر داراي مقدار خالي را حساب نمي کند ... پس ليست بالا از نظر کلدفيوژن سه عنصر دارد و "Ben" مقدار عنصر سوم آن مي باشد.
براي ايجاد عناصر خالي، از کاراکتر فاصله به جاي مقدار خالي استفاده کنيد، مانند مثال زير :

<cfset myList = "Hadi, ,Hossein,Ben, , ">

ليست بالا از نظر کلدفيوژن شش عنصر دارد.

براي تغيير مقدار عنصري از ليست از تابع ListSetAt مانند مثال زير استفاده مي کنيم :

<cfset myList = "Hadi,Hossein,Ben">
<cfset myList = ListSetAt(myList,1,"Good Boy")>
<!--- myList = "Good Boy,Hossein,Ben" --->

کد بالا مقدار عنصر اول ليست را از Hadi به Good Boy تغيير مي دهد.

مرتب سازي عناصر ليست
براي مرتب سازي عناصر يک ليست از تابع ListSort استفاده مي کنيم. اين تابع داراي دو پارامتر اجباري که اولي مشخص کننده ليست، و دومي مشخص کننده نوع مرتب سازي مي باشد، مي باشد.

<cfset myList = "a,d,c,v">
<cfset myList = ListSort(myList,"text")>

مقادير قابل قبول براي پارامتر دوم عبارتند از "text"، "textnocase"، و "numeric". مرتب سازي "text" بين حروف بزرگ و کوچک تفاوت قائل مي باشد و در مرتب سازي حروف بزرگتر اول تر قرار مي گيرند ... "textnocase" براي حروف بزرگ و کوچک ارزش يکساني قائل مي باشد. "numeric" عناصر بر اساس ارزش عددي آن ها مرتب مي سازد.
پارانتر سوم که اختياري مي باشد، ترتيب مرتب سازي را مشخص مي سازد. "asc" (مقدار پيش فرض) مشخص مي کند که مرتب سازي از ارزش کمتر به ارزش بيشتر باشد . "desc" براي مرتب سازي از ارزش بيشتر به ارزش کمتر به کار مي رود. به مثال هاي زير توجه کنيد :

<cfset myList = "a,d,c,v">
<cfset myList = ListSort(myList,"text")>
<!--- myList = "a,c,d,v" --->
<cfset myList = "a,B,c,d">
<cfset myList = ListSort(myList, "textnocase", "desc")>
<!--- myList = "d,c,B,a" --->

Delimiter هاي يک ليست
توابعي که براي کار با ليست ها به کار مي روند تقريبا همه شان يک پارامتر آخري اختياري دارند که Delimiter ليست را مشخص مي سازد. Delimiter هايي که اکثرا مورد استفاده قرار مي گيرند، عبارتند از : کاما، ;، |، ~ .
براي تغيير Delimiter يک ليست از تابع ListChangeDelims به صورت زير استفاده مي کنيم :

<cfset myList = "a;b;c;d">
<cfset myList = ListChangeDelims(myList, ",", ";")>
<!--- myList = "a,b,c,d" --->

پارامتر دوم مشخص کننده Delimiter جديد و پارامتر سوم مشخص کننده Delimiter قبلي مي باشد. پارامتر سوم اختياري مي باشد و داراي مقدار پيش فرض کاما مي باشد.

ايجاد حلقه(Loop) روي عناصر ليست
براي ايجاد حلقه روي عناصر يک ليست، به صورت زير عمل مي کنيم :

<cfset myList = "a;b;c;d">
<cfoutput>
<cfloop list="#myList#" index="theElement" delimiters=";" >
#theElement#<br>
</cfloop>
</cfoutput>

در کد بالا، theElement ابتدا مقدار "a" ، سپس مقدار "b" ، سپس مقدار "c" و در آخر مقدار "d" مي گيرد و در هر مرحله کد بين <cfloop ...></cfloop> را براي مقادير theElement اجرا مي کند. delimiters اختياري مي باشد و داراي مقدار پيش فرض کاما مي باشد.

مناسب سازي يک ليست براي عبارات SQL
ليست زير را در نظر بگيريد :

<cfset myList = "pear,lemon,orange,citron">

و حال مي خواهيد ليست بالا در Query زير استفاده کنيد :

SELECT *
FROM Fruit
WHERE FruitName IN ('pear','lemon','orange','citron')

شما نمي توانيد از ليست به اين صورت استفاده کنيد :

SELECT *
FROM Fruit
WHERE FruitName IN (#myList#)

زيرا عناصر ليست داراي ' (single quote) در دو طرفشان نمي باشند. براي اين منظور، از تابع ListQualify استفاده مي کنيم. مانند مثال زير :

SELECT *
FROM Fruit
WHERE FruitName IN (#ListQualify(myList,"'")#))

موارد استفاده از ليست ها
اينکه کجا از ليست ها استفاده کنيد، بستگي به خودتان و خلاقيت و نحوه ي تفکر شما دارد. اما من شخصا از ليست ها در موارد زير استفاده مي کنم :

  1. وقتي مي خواهم در يک متغير کوکي (cookie) بيش از يک مقدار قرار دهم. زيرا نمي توان به کوکي ها مقادير آرايه اي داد، ليست ها در اين جا يکي از انتخاب هاي خوب براي استفاده مي باشد. روش ديگري هم وجود دارد که بعدا در باره ي آن صحبت خواهم کرد.
  2. هنگامي مي خواهم ليستي از مقادير را در يک فيلد از يک رکورد در پايگاه داده ذخيره کنم. در اين مورد نيز نمي توان از آرايه ها استفاده کرد.
نظر شما لينک مطلب
1383/10/11
هادی مشیدی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش فلش : لود کردن عکس بصورت داینامیک

هنگامی که شما یک عکس را در فلش هنگام طراحی قرار میدهید ،این فایل بهمراه بقیه جزئیات در فایل SWF نهایی شما کامپایل میشود . این کار حجم فایل شما را بالا میبرد . اما میتوانید اینکار را توسط کد های اکشن اسکریپت انجام دهید تا فایل عکس شما در فایل فلش جاسازی نشود .بلکه در زمان اجرا از یک آدرس لود شود .

  • برای لود کردن تصاویر jpeg در زمان اجرا در یک LEVEL ، باید از متد LoadmovieNum و برای لود کردن عکس در یک Movieclip باید از متد loadmovie متعلق به شیئ Movieclip استفاده کنید . هنگامی که عکسی را در Movieclip لود میکنید این عکس جایگزین تمام محتویات Movieclip میشود.
  • برای بدست آوردن مقدار بایت های دانلود شده از متد getbytesLoaded متعلق به شیئ Movieclip استفاده میکنیم.
  • فلش برای فایل های عکس فلش فقط فرمت Standard Jpeg را ساپورت میکند و حالت Progressive jpeg را قبول نمیکند .
  • مثال : کد زیر یک عکس را در Movieclip لود میکند . جای آن روی timeline جاییست که Movieclip مربوطه قرار دارد :

myMC.loadmovie("http://www.Persianyahoo.com/index/logo.jpg")
نظر شما لينک مطلب
1383/10/18
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


JavaScript چيست؟

The JavaScript Source - Cut and Paste JavaScript Library

در اولين روزهاي تاسيس وب دستورات HTML بسيار ساده بود، ولي هنگامي که Web، شروع به پيشرفت نمود، طراحان خواستار کنترل بيشتري شده و در نتيجه مجموعه دستورات مورد نياز تهيه گرديد.سپس از آنجاييکه صفحات وب، بهتر است به صورت ديناميک و متحرک باشند، طراحان نيز خواستار ارتباط بين بينندگان سايت و صاحبان آن شدند، در نتيجه استفاده از دستورات HTML به تنهايي نياز آنها را برطرف نکرد و سپس شرکت Netscape براي ايجاد و کنترل ارتباط بين صاحبان سايت و بينندگان آن در صفحات Web از JavaScript کمک گرفت.

JavaScript يک زبان برنامه نويسي است که به وسيله آن ميتوان بين کاربر و سايت ارتباط برقرار نمود . زبان JavaScript به حروف بزرگ و کوچک حساس ميباشد. برخلاف شباهت اسمي موجود برنامه Java و JavaScript، هيچگونه شباهتي بين اين دو برنامه وجود ندارد. Java يک زبان برنامه نويسي بسيار کامل پيشرفته اي است که توسط شرکت sun microsystem تهيه شده و جاوا اسکریپت توسط شرکت netscape.( اساس Java در برنامه هاي client-side براي ايجاد appletها ميباشد، اين برنامه هاي کوچک توسط شبکه اينترنت دريافت شده و درون خود browserها اجرا ميشوند بطوريکه بعلت وجود قابليت همه گير Java، اين برنامه در تمامي browserهايي که قابليت اجراي Java را دارند، کار ميکنند). زبان JavaScript يک زبان برنامه نويسي "شي گرا" ميباشد. از آنجا که JavaScript يک متن ساده ميباشد، در نتيجه ميتوان از هر ويرايشگر متن کمک گرفت، در سيستم ويندوز اغلب کاربران از برنامه notepad استفاده ميکنند.امروزه کدهاي جاوا در صفحات وب براي زيبا نمايي يا افزايش پويايي صفحات کاربرد زيادي دارد.

منابع جاوا اسکريپت جاوا اسکريپت دات آي آر javascript.internet.com javascriptkit.com
نظر شما لينک مطلب
1383/10/22
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش فلش : لود کردن صدا بصورت داینامیک
  • برای لود کردن MP3 در فلش در زمان اجرا از متد Loadsound متعلق به شی Sound استفاده کنید . برای اینکار شما باید یک نمونه از روی شیی sound بسازید تا بتوانید از متد آن برای لود کردن صدا در event یا در حالت streaming استفاده کنید.
  • صداهای event اول کامل لود شده و بعد اجرا میشوند . صداهای حالت streaming در حین دانلود شدن اجرا میشوند. شما میتوانید از پارامتر IsStreaming در متد Loadsound برای تعیین کردن نوع لود شدن صدا استفاده کنید. وقتی یک صدای event را بارگذاری میکنید ، برای اجرایش باید متد START مربوط به شیی Sound را اجرا کنید . برای اجرای صداهای نوع streaming نیاز به کد START نیست ، چون وقتی به مقدار کافی از آن دانلود شود شروع به اجرا میکند .
  • برای بدست آوردن مقدار بایت های دانلود شده از متد  GetbytesTotalمتعلق به شیء Sound استفاده میکنیم.
  • فلش فقط فایل های MP3 را ساپورت میکند .

برای لود کردن یک صدا بصورت داینامیک :

یک شیئ یا فریم را برای صدا دادن به آن انتخاب کنید و کد زیر را به آن اضافه کنید . mysound نام شیئ ساخته شده توسط ما از روی شیئ sound است. true در آخر خط دوم نشان دهنده streaming نبودن صداست و تا لود نشود نمیتوان اجرایش کرد (برای حالت streaming باید TRUE بنویسید ) .در نهایت در خط سوم آهنگ شروع به اجرا میکند .

mysound = new sound();

mysound.loadsound("http://www.music.com/s2.mp3", false);

mysound.start();
نظر شما لينک مطلب
1383/10/28
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


تفاوت های برنامه Authorware و Director

هر دو برنامه میتوانند کارهای مشابه بسیاری را انجام دهند . اما هر یک، از یک روش خاص و GUI مربوط به خود استفاده میکنند .

دایرکتور ( که معنی کارگردان هم میده )در کنترل صدا و انیمیشن بهره وری زیادی دارد . در حالیکه Authorware برای ساخت برنامه های متعاملی ( interactive ) که نیاز به دنبال کردن عکس العمل کاربر توسط برنامه میباشد قوی تر عمل میکند .

نقاط قوت Director :

· انیمیشن : دایرکتور بخاطر ساخت انیمیشن های دقیق و کار آمد همیشه بعنوان یک ابرقدرت در این زمینه مطرح بوده است.

· صدا : دایرکتور میتواند تا هشت صدا را بصورت همزمان در سیستم عامل ویندوز و مکینتاش پخش کند. وقتی شما صدایی را در دایرکتور اجرا میکنید کنترل بیشتری بر روی صدا ، ولوم و نقاط ابتدایی و انتهایی آن دارید .

· همگام بودن صدا و گرافیک ها : قدرت دایرکتور در کنترل صدا و تصویر این قابلیت را برایتان فراهم میکند تا دقیق تر از همیشه آنها را با هم تنظیم کنید .

· کنترل توسط Lingo : با استفاده از فرمان های زبان اسکریپتی لینگو شما میتوانید کنترل محسوس تری روی اشیاء داشته باشید .مثلا اشیایی بعنوان sprite میسازید که با استفاده از زبان لینگو میتوانید اندازه و محل آنها را در پاسخ به کلیک کاربر تغییر دهید یا از یک شیی که قبلا ساخته اید چندین با ر کپی کنید .

نقاط قوت AuthorWare )ازین پس میگوییم AW ):

· Navigation : AW ابزارهای قدرتمندی برای مرورکردن فیلم های دایرکتور دارد .

· راه اندازی اکشن ها : ساختار خط جریان (flowLine) در AW و اکشن ها طوری طراحی شده اند که امکان راه اندازی انواع متنوعی از interaction ها را ممکن میسازند .

· دستور دادن به اشیاء و رویداد ها (events): خط جریان برنامه AW به شما این امکان را میدهد تا دستورات لازم برای اجرای انواع فرمان ها را مثل ناپدید شدن اشیاء در زمان وقوع یک event در اختیار بگیرید تا کاربر حس کند برنامه شما نسبت به کارهای او عکس العمل نشان میدهد .

· دنبال کردن اعمال کاربر : شما درحین کار با AW متغیر های بسیاری برای ضبط اعمال کاربر در اختیار دارید . وقتی یک فیلم دایرکتور در یک قطعه از AW اجرا میشود کاربر میتواند با هر دوی آنها ارتباز برقرار کند . همچنین آن دو نیز میتوانند با یکدیگر در ارتباط باشند .
نظر شما لينک مطلب
1383/11/13
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


ColdFusion MX 7 به بازار آمد

شرکت ماکرومدیا که قدرتمند ترین ابزارهای ساخت برنامه های تحت وب را عرضه میکند همچنان به نوآوری هایش ادامه میدهد و این بار بیش از همیشه فلش را در کنار کلدفیوژن 7 به کار گرفته تا کمی رقبا را بترساند !

قابلیت هایی نسخه 7 بشرح زیر است :

· تولید فرم های پر محتوای فلش : بصورت پویا با یک تگ کلدفیوژن با امکاناتی نظیر تغییر پوسته فرم !

· تولید پویای مقالات قابل پرینت در فلش و امکان تبدیل آنها به فایل های PDF و FlashPaper

· امکان ساخت گزارش های تصویری مانند نرم افزار excelبر روی وب

· امکان ساخت برنامه هایی برای برقراری ارتباط با کاربر از طریق SMS و مسنجر ها .

· استفاده از extension های جدید در دریم ویور

· امکام پکیج کردن یک برنامه بهمراه فایل های runtime کلدفیوژن در یک آرشیو جاوا (WAR or EAR) برای گسترش آسان و سریع روی سرور های J2EE

· امکان محافظت از کد های کلدفیوژن: با تبدیل آنها به بایت کد های جاوا برای گسترش روی وب و اجرا آنها.

· امکان جستجوی قدرتمند تر : فعال کردن شرایط جستجوی بیشتر . امکان جستجو در یک Resault Set . (یعنی جستجویی در میان نتایج یک جستجوی دیگر ) و ...
نظر شما لينک مطلب
1383/11/20
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید

macromediaX نوکیا و ماکرومدیا در اوایل سال 2005 خبر از امضای قراردادی دادند که تکنولوژی فلش ماکرومدیا در سری 60 گوشی های نوکیا و سری 80 مدل های communicator بکار گرفته میشود وگوشی های سری 60 نوکیا بعنوان استانداردی برای گسترش تکنولوژی فلش روی گوشی ها خواهد بود .نوکیا همچنین قبول کرده است که تکنولوژی فلش را روی سایر نرم افزار های دستگاه هایش نیز بکار گیرد.این قرارداد باعث ایجاد فرصت برای 1.8 میلیون نفر از طراحان فروم های نوکیا و یک میلیون نفر طراحان فلش سراسر جهان برای ایجاد برنامه هایی برای گوشی های موبایل میشود .

برنامه ای که روی گوشی باید نصب شود برنامه Flash Lite 1.1 player میباشد که با پرداخت 10 دلار از سایت ماکرومدیا قابل دریافت و نصب روی گوشی است . گوشی هایی که در حال حاضر قادر به استفاده ازین تکنولوژی هستند عبارتند از :

Nokia 3600, 3620, 3650, 3660, 6260, 6600, 6620, 6630, 6670, 7610

Nokia N-Gage, N-Gage QD

Sendo X
Siemens SX1
SonyEricsson P900, P910

هنگام خرید نرم افزار شما باید نوع گوشی خود را از یک منوی بازشو انخاب کنید و شماره سریال دستگاه خود را که 15 رقمی است وارد کنید . برای اینکه شماره روی دستگاه ظاهر شود میتوانید دکمه های *#06# را فشار دهید . هر Flash lite player با یک شماره سریال دستگاه تولید میشود و بنابراین فقط روی دستگاه شما کار میکند . فلش لايت نسخه کوچک شده اي از فلش است که داراي آبجکت هاي ورژن ۵ فلش و اکشن اسکريپت ورژن ۴ فلش ميباشد.

. در صورت داشتن سوالات بیشتر میتوانید به آدرس Flash Lite FAQ page مراجعه کنید. منبع خبر
نظر شما لينک مطلب
1383/11/28
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد

macromedia on mobile Devices ماکرومدیا که به تازگی نسخه جدیدی از کلدفیوژن را عرضه کرده ، با راه یافتن به دنیای موبایل، قصد دارد دیوار بین اینترنت و دستگاه های بی سیم را از بین بردارد! ColdFusion به برنامه نویسان اجازه میدهد تا نتیحه برنامه های خود را روی تلفن های موبایل بصورت پیام کوتاه SMS و یا پیام های متنی روی مسنجرها تحویل دهند .

کلدفیوژن روی چه سرور هایی اجرا میشود ؟

  • یک سرور تکی اوراکل
  • سرورهای J2EE مانند macromedia JRUN
  • سرور WebSphere متعلق به IBM
  • سرور WebLogic متعلق به BEA

این گسترگی به برنامه نویسان وب دست بازی برای نوشتن و اجرای برنامه ها بر روی سیستم های عاملی مانند یونیکس و لینوکس و ویندوز میدهد .

شرکت ماکرومدیا که تمام معروفیت خود را مدیون فلش میباشد در چند سال اخیر کار خود را روی برنامه های تحت وب و مولتی مدیا متمرکز کرده است و امروزه میتوان محصولات ماکرومدیا را جعبه ابزار طراحان وب دانست.تعدادی از این ابزار ها عبارتند از :

  • DreamWeaver : ویرایشگر صفحات وب (حتی صفحات پویا)
  • FireWork : ویرایشگر تصاویر برای استفاده در وب
  • Flash : ایجاد تصاویر متحرک و برداری روی وب
  • Contribute :ابزاری برای ساخت وب سایت های خانگی
  • ColdFusion : یک سرورافزار سایت های پویا (مانند ASP , PHP)
  • JRUN : یک سرور افزار بر اساس تکنولوژی J2EE
نظر شما لينک مطلب
1383/12/05
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


انتخاب بهترین رنگ برای طراحی وب سایت

طراح وب ماکرومدیا آیا شما بهترین رنگ را برای وب سایت خود بکار گرفته اید ؟ هنگام انتخاب رنگ در زمان طراحی باید به نکات زیر توجه کنید :

1- اثر روان شناسی رنگ

2- قابلیت خواندن متون صفحات سایت

3- رنگ متمم رنگهای انتخابی برای بک گراند ، گرافیک ها ، لینک ها و متون

لیست زیر مشخصه هایی از رنگ ها را که هنگام طراحی باید مدنظر داشته باشید بیان میکند:

1- رنگ ها اثر زیادی روی احساسات ما در 90 ثانیه اول دیدن میگذارند .

2- اثر رنگ میتواند بیننده را ترغیب به خرید یک جنس از شما کند.

3- رنگ ها رفتار ما را در برابر یک موضوع فقط تشدید نمیکنند ، بلکه اثر خود را کاملا در رفتار ما نشان میدهند .

4- اثر گذاری رنگ در فرهنگ های مختلف گوناگون است !

5- هر رنگ به تنهایی یک پیام مخصوص به چشم بیننده میفرستد .

در فرهنگ آمریکای شمالی رنگ های زیر به احساسات یا مشخصه های زیر مربوطند:

  • سفید : اشاره دارد به صداقت ، پاکیزگی ، صمیمیت ، ملایمت و معاصر بود ن چیزی . سفید بهترین رنگ برای بک گراند های وب است . در تجارت سفید رنگ خستگی گیر و انرژی بخش است .
  • سیاه : اشاره دارد به ظرافت ، قدرت ، دلیری ، شهامت ، فریبندگی ، شیطان ، مهارت و باستان . مشکی برای رنگ متن روی یک پس زمینه روشن ایده آل است. این رنگ بعنوان رنگ پس زمینه چشم را خسته میکند .
  • قرمز : توانایی ، سکس ، هیجان ، احساسات شدید ، سرعت ، خطر و تهاجم . این رنگ از بیننده توجه به خود را طلب میکند . در تجارت بمعنی وام و بدهی است . این رنگ شدید ترین رنگ احساس است و ضربان قلب و تنفس را تسریع میکند .
  • آبی : امنیت ، اعتماد ، مسئولیت پذیری ، سرما ، ایمان ، وفاداری ، وابستگی وجاه و جلال . آبی دومین رنگ عوام پسند است . در تجارت بمعنای ضمانت مالی است .
  • سبز : تندرستی ، فراوانی ، حاصلخیزی ، آزادی ، شفا و بهبودی ، طبیعت ، پیشرفت ، حسادت و خونسردی . در تجارت بیانگر مقام و ثروت است. این رنگ در چشم ها راحت تر از همه دیده میشود .
  • قهوه ای : تاثیر گذاری ، متانت ، توانگری مالی و کمک کننده بودن . قهوه ای رنگ کره خاکی ماست و در طبیعت بسیار فراوان است .
  • خاکستری : صمیمیت زیاد ، اعتبار و نفوذ و عملی بودن . در تجارت بمعنای سنت گرایی است .
  • صورتی : ملایمت ، شیرینی ، ظرافت و زنانگی ، خوب بودن ، بی گناهی و پرورش کودک .
  • بنفش : وقار ، معنویت ، شاهانه بودن ، عیش و نعمت ، دارایی ، اعتبار و نفوذ ، سوگواری و مهارت . در تجارت بزرگ نشان دادن است . بنفش طرفداری از سبک های هنرمندانه است.
  • نارنجی : سرزندگی و شوخی ، لذت و خوشگذرانی ، تعادل گرمایی ، تشویق کردن ، چالاکی و نیرو ، تحمل و بلند همتی .
  • زرد : نور خورشید ، گرمی ، خوشی ، نامردی ، ترسویی و حسادت . در تجارت درخواست از نوع روشنفکرانه است و برای تاکید نیز خوب است . زرد باعث افزایش تمرکز شده ، سوخت و ساز را زیاد میکند و سخت ترین رنگ برای چشم هاست .
  • طلایی : نشانگر گران بودن و پرستیژ است .
  • نقره ای : سرما ، علمی بودن و اعتبار و پرستیژ است .

پس وقتی میخواهید رنگی انتخاب کنید باید درباره بازار نهایی کار خود باندیشید . چه احساساتی را میخواهید برانگیخته کنید ؟ اول کمی درباره چشم انداز احساسی هدفتان فکر کنید و نیز پیامی که از راه دید میخواهید منتقل کنید . بعد رنگ خود را انتخاب کنید !
نظر شما لينک مطلب
1383/12/08
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


مقایسه Coldfusion و ASP
  • ASP بر مبنای ISAPI بنا شده است . ASP یک DLL است بنام ASP.DLL که معمولا در دایرکتوری های سیستمی ویندوز یافت میشود . IIS فایل های ASP را به ASP.DLL راهنمایی میکند ، در اینجا موتور ASP فایل ها را پردازش میکند و سپس نتایج را برای کلاینت میفرستد. کلدفیوژن از پسوند CFM استفاده میکند . iis ازین پسوند برای تعیین مسیر درخواست هاو راهنمایی آنها به کلدفیوژن توسط ارتباط دهنده ISAPI استفاده میکند.
  • ASP از کد های اسکریپتی سرور ساید مانند VBSCRIPT استفاده میکند و همچنین کد های کلاینت ساید جاوا اسکریپت .کلدفیوژن هم از فایل هی CFML برای عملیات سرور ساید و از جاوا اسکریپت جهت اعمال کلاینت ساید استفاده میکند . اما کلدفیوژن با asp فرق دارد . چون کلدفیوژن فقط یک DLL نیست که توسط IIS لود شود بلکه کلدفیوژن یک سرویس است که روی ویندوز اجرا میشود وشما میتوانید آن را مانند هر سرویس دیگر (مثلا SQL ) بحالت START و STOP در آورید .
  • پس نحوه کار ASP و Coldfusion با IIS یکسان است . نحوه برنامه نویسی در هر دو یکسان است ( استفاده همزمان سرور ساید و کلاینت ساید) و تفاوت آنها در پسوند فایل ها و زبان استفاده شده در اسکریپت نویسی آنهاست.

دات نت قدم بعدی ASP :

  • ASP.NET برای کار با دات نت فریم ورک مایکروسافت طراحی شده . برخلاف ASP که یک زبان اینترپرتری (مفسری) است ،ASP.NET قبل از اجرا در همان لحظه درخواست به زبان MSIL (Microsoft Intermediate Language ) ترجمه میشود . کدهای ترجمه شده ASP.NET که معمولا کدVB.NET یا C# هستند در محیط CLR ترجمه میشود . کلدفیوژن زبان کامپایلری است که در لحظه اجرا کد هایش به بایت کد جاوا تبدیل میشوندو کد تبدیل شده در محیطی بنام Java Virtual Machine اجرا میشود.
  • ASP.NET از منابع و آبجکت ها و API های دات نت استفاده میکند که در CLR هستند . مدیریت حافظه و اجرا و همه چیز بعهده CLR میباشد . ASP.net بجای پردازش در یک فایل dll تنها، از CLR استفاده میکند -- اما کلدفیوژن بجای اینکه فقط در محیط دات نت مایکروسافت اجرا شود روی تمام محیط های J2EE اجرا میشود و از ابجکت ها و منابع و API های جاوا و J2EE که داخل java VM است استفاده میکند. و مدیریت حافظه و اجرا و بقیه بعهده VM است .
نظر شما لينک مطلب
1383/12/11
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


مقایسه مرورگر های وب با یکدیگر

در این مقاله مبنای ما برای مقایسه مرورگر ها با هم، توصیه های W3C میباشد .

OPERA : بالاترین سرعت لود در بین مرورگرهای وب امروزی را بخود اختصاص داده و قابلیت های خوبی برای تعیین نوع لود صفحات دارد. مثلا میتوانید تعیین کنید که عکس های صفحه لود شود یا خیر که این مورد سرعت شما را افزایش می بخشد. اما کمی دنباله روی IE شده است - ما از این برنامه کیفیت میخواهیم ، نه یک نسخه دیگر از IE را . در مورد پیروی از استاندارد های W3C نیز خوب عمل کرده است .

MOZILLA : یک مرورگر کدباز که امروزه پشتیبانی گوگل را با خود دارد و چندین مرورگر بر اساس آن ساخته شده . این مرورگر گاهی متن ها را روی لبه های جداول میاورد که باعث کم شدن کیفیت تصاویر میشود . سرعت باز شدن برنامه نسبتا سریع است .

FireFox : قبلا بنام fireBird بود – این مرورگر از خانواده مرورگر موزیلا میباشد . فقط گاهی لینک های Anchor را اشتباه پیدا میکند . سرعت لود مناسبی دارد و از پدر خود یعنی موزیلا معروف تر شده است .

Internet Explorer : این برنامه که همراه ویندوز اجبارا نصب میشه، کلی مشکل و باگ داره و مایکروسافت هم این مشکلات رو خیلی دیر به دیر برطرف میکنه .IE بدون table میمیره ! و تا حرفی از استاندارد های W3C به میدون میاد میخواد فرار کنه !

Touchnet : مرورگری برپایه IE - با قابلیت چند صفحه وب در یک پنجره – همچنین یک برنامه ضد فیلتر دارد که لیست پورت های پروکسی را خودش از اینترنت آپدیت میکند ( این بخش برنامه در ایران بخاطر فیلترینگ خیلی کاربرد دارد)

Netscape : این برنامه که روزی رهبر مروگرهای وب بود امروزه از میان مرورگرها نامش حذف شده و شرکت نت اسکیپ در صدد اعلام مرگ این مرورگر است .
نظر شما لينک مطلب
1383/12/18
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا

MacromediaX در این روزها خیلی می بینیم که بعضی ها میگن از کلدفیوژن به جاوا اسباب کشی کنید . چرا ؟ یکی از دلایل کمبود شناخت درباره کلدفیوژن و طرز کارشه . بیاید با یک رابطه بین این دو برنامه شروع کنیم :

برنامه های نوشته شده در CF اصالتا جاوا هستند یا مقدار خیلی کمی فرق دارند .CF روی یک سرورJ2EE اجرا میشود که یک برنامه تایید شده توسط شرکت سان میباشد که کدبایت جاوا را اجرا میکند . این کدبایت جاوا از کامپایل کد های CFML نوشته شده توسط شما برجود میاید. به زبان ساده تر میشه گفت که CFML یک ساختار زبان برای برنامه نویس است، نه برای سرور . در هنگام اجرا کلدفیوژن برنامه را به جاوا کامپایل کرده و بنام CF اجرا میکند . در این لحظه هیچ CFML ای وجود ندارد و کدی که اجرا میشود تماما جاوا است . نه بیشتر و نه کمتر ! بهمین سادگی .

برنامه کلدفیوژن شما یک برنامه جاوا است که با کد های ساده تر کلدفیوژن آنرا نوشته اید . در اصل کلدفیوژن یکی از ابزارهای کمکی جاوا بحساب میاید .مثلا در جاوا برای وصل شده به پایگاه داده باید 10 خط کد بنویسید ، در حالیکه این کار با یک تگ کلدفیوژن قابل انجام است . یا در جاوا برای فرستادن ایمیل SMTP با استفاده از JAVAMail API باید کلی خودتونو برای نوشتن کد خسته کنید ، در حالیکه اینکار با یک تگ تنها در کلدفیوژن انجام میشود . خوب دوباره نویسی را پس کنار بگذارید .

پس cf برنامه نویسی جاوا راگسترش داده و ساده تر میکند . وبرنامه های CF نوعی جاوا هستند و با برنامه هایی که در زبان سطح پایین تر جاوا نوشته شده اند فرقی ندارند .کلدفیوژن همچنین میتواند از API های جاوا ، class های جاوا ، تگ های JSP و JavaBeans نیز استفاده کند .چون خودش فرزند جاواست.
نظر شما لينک مطلب
1383/12/24
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


علت خراب شدن قالب وبلاگ ها

روی یک لینک کلیک میکنید . منتظرید تا وبلاگی باز شه . 10 ثانیه ، 20 ثانیه ، 1 دقیقه ، دو دقیقه ....خلاصه بالاخره باز میشه ، اما در کمتر از زمانیکه صبر کردید باز شه اونو میبندین . چرا ؟ بیاید ببینیم چرا بعضی وبلاگ ها یه بار مصرفند ؟

سرعت ، زیبایی ، خوانایی ، مطالب گیرا ، ارتباط ذهنی با خواننده و ... همه و همه در خوب جلوه دادن وبلاگ شما دخیلند .

ایرادات معمول وبلاگ های فارسی بشرح زیرند :

1- زیاد کردن تعداد پست (post) های هنگام لود شدن وبلاگ – 7 پست در صفحه مناسبه و بیشتر فقط حوصله بیننده رو سر میبره .

2- قرار دادن عکس به تعداد زیاد : این کار سرعت باز شدن وبلا گ را شدیدا کم میکند.

3- قرار دادن عکس با عرض بزرگتر از عرض قالب وبلاگ : اینکار باعث میشود اسکرول افقی صفحات استفاده شود که کاربران را خسته میکند . عرض عکس بیش از 400 پیکسل معمولا مشکل زا میشود .

4- استفاده از بک گراند مشکی و بطور کلی تیره : که باعث خسته شدن چشم بیننده میشود و اشتیاق او را به خواندن وبلاگ کم میکند .

5- استفاده از فونت با سایز بزرگ و رنگارنگ : کلاس وبلاگ را پایین میاره و پرستیژ سایت شما رو از بین میبره . سایت کودکانه بنظر میرسه.

6- استفاده از عکس هایی که لود نمیشوند : بعضی از سایت هایی که فضای رایگان ارائه میدهند مانند سایت AngelFire اجازه لینک دادن خارجی را بشما نمیدهند . به این معنا که شما اجازه ندارید عکسی را در آنجا قرار دهید و بعد با استفاده از لینک آن را در وبلاگتان نشان دهید . در صورت انجام این کار یک عکس با عنوان Remote linking Forbidden بجای عکس اصلی در وبلاگ نشان داده میشود و خود وبلاگ نویس هم این عکس را در وبلاگش معمولا نمیبیند و عکس خودش را میبیند . چون او یکبار عکس را در سایت اصلی دیده و آن فایل عکس در کامپیوتر شخصی اش قرار دارد ولی کاربران عکس را بصورتی که گفته شد میبینند .

7- لینک های باطله : لینک هایی که هنگام کلیک باز نمیشوند نا امید کننده هستند. در ضمن این لینک ها امتیاز شما را در pagerank گوگل پایین میاورند .

8- چپ چین بودن متن : اگر قالب وبلاگ شما مخصوص وبلاگ های فارسی طراحی نشده باشد (مانند قالب های اصلی بلاگر) ، این ایراد رخ میدهد .

9- کد های جاوا اسکریپت : بعضی ازین کد ها واقعا خسته کننده است و وقت بیننده را تلف میکند . مثل کدی که از شما اسمتان را میخواهد تا بالای صفحه نمایش دهد یا باز شدن یک پنجره هنگام بستن وبلاگ. ....

10- کپی برداری از وبلاگ ها و سایت ها : با اینکار بیننده اعتماد خود را نسبت به مطالب شما از دست میدهد .

علاوه بر رعایت نکات فوق ، چه چیزهایی وبلاگ شما را بهتر میسازد ؟

1- معرفی و لینک دادن به سایت هایی که در زمینه وبلاگ شما مطلب دارند .

2- تبادل لینک با دوستانی که مطالبی شبیه شما مینویسند .

3- ثبت نام در سیستم های تاپ سایت جهت تبلیغ وبلاگتان

4- ثبت وبلاگ در لینکستان ها و لیست وبلاگ های فارسی

5- قرار دادن لینک آرشیو مقالات مهم خودتان در صفحه اول وبلاگ

6- استفاده از قالب و رنگ های متناسب با مطالب وبلاگتان

7- اهمیت دادن به نظرات خوانندگان درباره نوشته هایتان
نظر شما لينک مطلب
1384/01/02
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


محصولات فلش ساز Sothink

Glanda : یک فلش ساز بر مبنای قالب های آماده کار : فقط در چند کلیک شما میتوانید صفحات فلشی جالب با دکمه و لوچو و انیمیشن بسازید . بدون آنکه کد های اکشن اسکریپت یا حتی طراحی فلش بلد باشید ، میتوانید فلش های جذابی برای خود طراحی کنید

SWF quicker:این برنامه ابزاری برای طراحان وب میباشد که میتوانید در آن فایل های فلش مورد نیازتان را از همان صفحه خالی یا با استفاده از قالب های آماده آن بسازید . تقریبا نسخه لایتی از نرم افزار Flash MX میباشد . در ضمن میتواند فایل های فلش swf را نیز باز کند و سورس آن را به شما بدهد . البته فایل سورس را به شما میدهد ، اما نمیتوانید سورس را در flash MX ببرید . چون پسوند ذخیره سازی آن SQF است .

SWF Decompiler : یکی از قوی ترین برنامه های باز کردن کد فایل های SWF در وب . این نرم افزار فایل های فلش شما را رمزگشایی کرده و سورس آن را بصورت FLA بشما تحویل میدهد .

نظر شما لينک مطلب
1384/01/12
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آشنايي با زبان لينگو لايت و انقلاب فلش

برای خواندن قسمت اول این مقاله باید اینجا کلیک کنید .

صدا در در وب :

در گذشته در صفحات HTML فقط از دو نوع فرمت صدا بیشتر استفاده نمیشد . که یکی WAV بود که البته این هم برای کسانی بود که با Internet Explorer و تحت ویندوز کار میکردند و کسانی که با Netscape Navigator از شرکت Sun Micro System تحت Mac Os یا Mac OsX کار میکردند اساسا فایلهای WAV را نمیتوانستند پخش کنند و به جای آن از RIF استفاده میکردند.اینها تنها فرمتهایی بودند که برای صفحات وب استفاده میشدند. این فرمتها یک مشکلی داشتند و آن هم این بود که کمی بزرگ بودند.

  • برای اینکه بدانیم این فرمتها چقدر بزرگ بودند باید بگم که فرمت WAV با کیفیت CD ، یک دقیقه برابر 10 مگابایت میشود . یعنی اینکه اگر قرار بود شما مثلا 20 ثانیه موزیک روی صفحه وب خود قرار میدادید ، میشد 3/3 مگابایت که با سرعت اینترنتی که هم اکنون در ایران استفاده میکنیم (حدود 3 کیلو بایت در ثانیه) ، 1100 ثانیه که تقریبا 20 دقیقه طول میکشید که موزیک دانلود شود و پخش شود .

نوع دیگر فرمتهای صوتی MIDI که این نه دیگر مشکل حجم داشت و نه مشکل اینکه روی سیستم عاملهای مختلف اجرا نشود ، ولی مشکل دیگری داشت که از WAV بدتر بود . اجرای فرمت Midi به سینتی سایزر دستگاه کارت صوتی شخص بستگی دارد . یعنی اگر کارت صدایی که روی دستگاه کاربر بود اگر که در سینتی سایزر آن این آلت موسیقی که باهاش موسیقی خود را زده بودید ، بود که بود ، اگر نبود با یک آلت موسیقی دیگر پخش میکند . به طور مثال فرض کنید که یک نوت خاص را با ساکسیفون زده اید را روی دستگاه کاربر با ترومپت (Trompet) پخش کند . و اساسا اسن روشها نه روشهای مطمئنی بود و نه امکان پذیر .

فلش با MP3 جان تازه ای به وب میدهد .

MP3 شدن Sound در فلش، دو حسن داشت ، یکی اینکه دیگر هیچ ربطی به سینتی سایزر دستگاه کارت صوت کاربر ندارد و دیگری اینکه حجم آن حداقل یک دهم حجم فایل WAV است . علتی که میگویم حداقل یک دهم این است که چون فرمت MP3 خیلی هوشمندانه Compress میشود . شما Quality های خیلی پایین تر از CD Quality را هم تفاوت چندانی نمیتوانید حس کنید با موزیکی که با کیفیت CD ذخیره شده باشد . به عنوان مثال اگر کیفیت 128Kbps (کیلو بیت در ثانیه ) را به عنوان CD Quality در نظر بگیرید ، به راحتی شما تا 32Kbps هم میتوانید Quality را پایین بیاورید بدون اینکه افت خیلی محسوسی حس کنید . این بدیم معنی است که حجم فایل جدیدتان را یک چهلم فایل WAV خود کردید . به زبان عامیانه یعنی اون 20 دقیقه را کردید 30 ثانیه . وقتی این اتفاق افتاد حالا دیگر امکان استفاده از موزیک و Sound در وب امکان پذیر شد .

اسکریپت به فلش اضافه شد :

در ورژن 3 فلش ، یک زبان برنامه نویسی برای Flash ساخته شد به نام Lingo LE یا Lingo Light Edition .

Lingo LE چیست ؟

شرکت مکرومدیا یک نرم افزار دیگر دارد به نام Director که دوستم حسین مقاله ای را در مورد Director بر روی سایت گذاشته است . که این نرم افزار برای ساخت CD های MultiMedia است . که آن هم به صورت Vector کار میکند . نرم افزار Director یک زبان برنامه نویسی دارد به نام Lingo .

  • سازنده نرم افزار دایرکتور شخصی است به نام گری لوزنویک (Gary Lozenvik) ؛ این شخص وقتی میخواهد در مورد Lingo صحبت کند میگوید : << برای اینکه بفهمید یک شخص تا چه حد Lingo بلد است ازش بپرسید که چه کارهایی با Lingo نمیشود کرد، اگر گفت که کاری هست که نمیشود کرد بدونید که Lingo بلد نیست >>.

زبان لینگو بسیار شدید قدرتمند است . منتها دیگه زیادی قوی شده و به تمام Resource ها دسترسی دارد . میتواند فایل طرف را Rename کند ، دستگاه طرف را Format کند . یعنی فکر کنید در یک Level ، هر کاری که با زبان برنامه نویسی C میتوانید انجام دهید با Lingo هم میتوانید بکنید . پس این زبان برنامه نویسی اصلا به درد وب نمیخورد . بنابراین آمدند و بسیاری از قابلیتهایش را ازش گرفتند ، جاهایی که میتوانست Resource های کاربر را خراب کند را حذف کردند و یک زبان جدید ساختند به نام Lingo Light Edition ، لینگوی سبک شده ، و این زبان برنامه نویسی ، زبان برنامه نویسی Flash شد در زمان Flash 3 . این داستان ادامه داشت تا Flash 5 که اساسا میگویند انقلاب Flash در این ورژن اتفاق افتاده است .

انقلاب Flash در Flash 5 اتفاق افتاد یعنی چی ؟

شرکت Macromedia بررسی کرد که آقا این آدمهایی که از Flash استفاده میکنند ، هیچ کدومشون Director کار نیستند . این آدمها آدمهایی هستند که کارشون Web Designing است .و هیچ لزومی ندارد کسی که Web Designing میکند قبلا Director کار باشد . کسانی هم که میخواستند بیایند و این زبان را یاد بگیرند دیدند که یک زبان برنامه نویسی جدید یا یک عالمه کد و Syntax های مسخره جدید که باید همه را راد بگیرند .به این دلیل از Lingo LE استقبال نشد .

چیزی که معمولا Web Designer ها به عنوان زبان برنامه نویسی بلد هستند ، زبان برنامه نویسی JavaScript است . آنها آمدند و یک زبان برنامه نویسی جدید ساختند به نام Action Script که این زبان برنامه نویسی از لحاظ ساختار و از لحاظ Syntax بسیار بسیار نزدیک است به JavaScript . یعنی اگر کسی که JavaScript کار میکند بخواهد بیاید ActionScript یاد بگیرد زمان زیادی لازم ندارد که وقت بگذارد . و این را در Flash 5 گذاشتند و این قضیه باعث اقبال عامه شد .

  • من در یکی از کلاسهای Flash که درس میدادم ، یکی از دانشجویان سوال زیبایی کرد که : << بابا جون شما که اینقدر در مورد Flash میگویید که Flash سبک است ، سبک است ، ما که هر وقتی رفتیم یک سایتی که با Flash طراحی شده ببینیم ، مجبور شدیم نیم ساعت بشینیم جلوی مانیتور تا این نوار به تدریج پر شود و فقط نوشته : Please Wait Movies Loading >> . درست میگوید ؛ درسته ، دلیلشم این است که زمانی که نهایت امکانات فیلمبرداری و فیلمسازی در این حد بود که یک طناب نا مرئی ببندند و یک چیزی به آن آویزان کنند ، بشقاب پرنده ها را به آن شکل می ساختند . حالا نیز با تکنولوژی Z-CAM و Virtual Studio به این شکل می سازند . هنوز هم کار به همون شکل مشکل است ، فقط امکانات بیشتر شده و فضا ها زیباتر . طراح وب وقتی ببیند میتواند انیمیشن بسازد ، موزیک بگذارد ، فیل هوا کند ، همه این کار ها را با هم میکند ، نتیجه آن این میشود که حجم فایل وب خیلی کوچک نمیشه . ولی حالا چقدر از این امکانات با HTML فراهم بود و یا اگر هم کسی این کار را انجام میداد دیگر این سایت روی CD جا میشد ؟ من که فکر میکنم روی CD هم جا نمیشد .

پس ببینید ما داریم با نرم افزاری کار میکنیم که یک سری محسناتی دارد :

1 – امکان ساخت انیمیشن را به ما میدهد .

2 – امکان استفاده از موزیک را در وب برای ما فراهم میکند .

3 – گرافیک آن گرافیک Vector است ، پس Quality خودش را از دست نمیدهد .

4 – این نرم افزار ، زبان برنامه نویسی آن َActionScript است که بسیار شبیه JavaScript است و برای طراحان وب یادگیری آن خیلی مشکل نخواهد بود .

5 – این یکی خیلی مهم است . Flash Player ، آن چیزی که Flash را Play یا اجرا میکند ، روی مرورگر IE روی مرورگر NetScape ، روی Linux RedHat ، روی مرورگر Lindows ، روی همه این مرورگرها یک Player واحد است . بنابراین شما نگرانی این را نخواهید داشت که مثلا این صفحه را که میخواهد باز شود داخل NetScape کار میکند ولی توی IE کار نمیکند . یا اینکه توی IE کار میکند ولی تو اون یکی کار نمیکند . یکی از بزرگترین گرفتاریهای طراحان وب عدم وجود استانداردهای واحد است . و چون این یک Player واحد دارد که روی مرورگرهای مختلف کار میکند ، پس شما تمامی آن نگرانیها را هم از دست داده اید .
نظر شما لينک مطلب
1384/01/17
رامين خوشحال

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


ابزار های رایگان ASP برای سایت شما

Web Wiz Guide Free ASP Applications

در این سایت شما می توانید مقالات بسیار ارزشمندی درباره ASP بیابید . علاوه بر آن برنامه هایی که توسط اعضای سایت نوشته شده نیز در دسترس شماست تا بطور رایگان دانلود کنید و در سایت خود از آن استفاده کنید . تعدادی از این برنامه ها بصورت زیر هستند:

Web Wiz Forums v7.9

این برنامه یک تابلوی اعلانات آماده اجرا میباشد که امکان سفارشی کردن آن با خصوصیات مختلف امکان پذیرست . ادیتور WYSIWYG و آیکون های صورت و چندین پوسته (skin) ، امکان ساخت چندین گروه اعضا ، پیغام های خصوصی ، تعریف moderator ها ، آپلود کننده عکس و فایل ، سصولت جستجو ، بستن IP و فایل های زبان بخشی از امکانات این سیستم فوروم میباشد . نسخه های بانک اطلاعاتی Access 2000/2002 و SQL 7.0/2000 آماده دانلود میباشد .

Web Wiz Mailing List v4.6

برنامه پیشرفته ارسال ایمیل و خبرنامه شامل : ادیتور خبرنامه WYSIWYG ، مشاهده ایمیل ها قبل از ارسال، ابزار import ، آمارگیر ، پشتیبانی از کامپوننت های حرفه ای ایمیل . در دو نسخه Access و SQL server

Web Wiz Guestbook v7.01

دفتر ارسال نظرات برای سایت ها : سادگی در نصب ، اعلان توسط ایمیل ، آنتی اسپم ، آیکون های صورتک و بخش محافظت شده برای ورود ادمین بخشی از امکانات آن میباشد .

Site Search Engine v1.70

جستجوگر مطالب سایت شما . امکان جستجو در مطالب سایت را برای بینندگان سایت فراهم میکند .

Web Wiz Rich Text Editor (RTE) v3.0

ویراشگر متن مانند برنامه word وبصورت WYSIWYG – فرم های سایت خود را که با کد textarea ساخته اید با این برنامه به ویراشگری قدرتمند بدل سازید. امکانات : تعویض پوسته ، پالت رنگ ، فرمت متن ، آپلود عکس و فایل ، ساخت لینک ، جداول ، صورتک های متحرک ، چک کننده متن انگلیسی ، امکان مشاهده سورس کد HTML ، امکانpreview و ...

Web Wiz Site News v3.06

سیستم خبر – ادیتور WYSIWYG برای ویرایش اخبار و نمایش آنها در هر صفحه ای از وب سایت شما .

Web Wiz Journal (Blog) v1.0

امکان ساخت یک وبلاگ روی سایت شخصی تان با یک ویرایشگر WYSIWYG برای نوشتن مقالات و رویدادهای روزانه خود .

Web Wiz Polls v3.06

سیستم رای گیری گرافیکی برای آمارگیری از کاربرانتان درباره یک موضوع خاص.

Internet Search Engine v3.02

چیز جدیدی به سایت خود اضافه کنید با افزودن این جستجوگر گوگل مانند کوچولو .

Whois Lookup v3.21

برنامه کوچکی که به بینندگان سایت شما اجاطه میدهد تا دامنه های .com, .net, .biz, info, .org, .co.uk, org.uk, net.uk, plc.uk, ltd.uk. را چک کنند.

Hit Counter v1.03

برنامه شمارنده بازدید کنندگان سایت .

Web Based Email Using CDONTS v2.9

برنامه ای برای ارسال ایمیل با استفاده از شیء CDONTS از یک فرم "ارتباط با ما " در سایت شما . شامل 4 فرم بطور نمونه برای استفاده در سایتتان

Web Based Email Using JMail v1.0

برنامه ای برای ارسال ایمیل با استفاده از شیء JMail از یک فرم "ارتباط با ما " در سایت شما . شامل 4 فرم بطور نمونه برای استفاده در سایتتان

Active Users Counter v1.0

نشان میدهد چندنفر در همین لحظه در حال بازدید از سایت شما هستند .
نظر شما لينک مطلب
1384/01/20
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


ارائه IE 7.0 توسط مایکروسافت و CSS 2

نسخه جدید مرورگر مایکروسافت که قراره برای ویندوز xp تابستان 2005 به بازار بیاد به گفته متخصصان دارای سطح امنیتی بالاتری از نسخه های قبلی است . گرچه با وجود مرورگر هایی مانند FireFox که در حال دست گذاردن در سهام بازار مرورگر ها هستند ، مردم تصور میکنند که نسخه جدید IE بجز امنیت بالاتر، امکانات زیادی نیز باید داشته باشد .

امکان مرورکردن چند صفحه وب در یک پنجره بصورت Tab (مانند اوپرا) ،نرم افزار ضد جاسوسی داخلی برنامه و اجتماع RSS احتمالا از امکانات اصلی مرورگر 7 مایکروسافت خواهد بود .

مایکروسافت CSS 2 را ساپورت میکند ؟

نسخه کنونی IE تمام فانکشن های css 2 را پشتیبانی نمیکند و این برای طراحان مشکل زاست . چون باید سایت ها را طوری طراحی کنند که همه با هر مرورگری که دارند ، چهره سایت رو یکسان ببینند. اما بالاخره مایکروسافت از css 2 پشتیبانی خواهد کرد ؟ فکر نکنم !مایکروسافت ناسازگاری مرورگرش را با بقیه بعنوان یه امتیاز در مسابقه مرورگر ها می پندارد ! چون معمولا طراحان اکثرا سایت ها را طوری طراحی میکنن که اول در مرورگر IE درست نشون داده شود و بعد در بقیه مرورگر ها . چرا ؟ چون 90 درصد مردم از IE برای مرور کردن صفحات وب استفاده میکنند.

چرا از FireFox استفاده کنیم ؟

اکثر مردم از مرورگر IE استفاده میکنند و این باعث میشه تا ویروس نویسان و سازندگان برنامه های جاسوس نیز کار اصلی خودشونو روی این دسته 90 درصدی از مردم متمرکر کنند. خراب کاران معمولا روی نقاط آسیب پذیر IE کار میکنند و استفاده کنندگان از این مرورگر چندین برابر بیش از کسانی که از مرور گر های دیگر استفاده می کنند در معرض خطرند .

دوم اینکه فایر فاکس امکان مرور چندین صفحه را در یک پنجره میدهد (new tab ) . بنابرین دیگه هنگام گشت و گذار در وب taskbar شما پر نمیشه !

سوم : سرعت لود صفحات در فایر فاکس بیش از IE میباشد . پس وقت کمتری را هم تلف خواهید کرد.

نظر شما لينک مطلب
1384/01/25
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL SERVER

برای کار با اطلاعات در بانک های اطلاعاتی زبانی مخصوص همان بانک وجود دارد که از آن زبان برای دستکاری اطلاعات و مرتب کردن آنها در بانک استفاده میشود.بانک اطلاعاتی Sql server و همچنین Access و نیز Oracle (البته تا حدودی) از یک زبان واحد برای اینکار استفاده میکنند . در این سری مقالات دستورات ساده SQL را خواهید آموخت . تعدادی ازین دستورات به قرار زیر است که زیر هر کدام از آنها قالب دستوری شان نیز نوشته شده که بزودی بصورت کامل شرح داده خواهند شد . یادگیری هر یک از این دستورات پیش نیاز بعدی میباشد . پس با ما همراه باشید .

Select

SELECT "column_name" FROM "table_name"

Distinct

SELECT DISTINCT "column_name"

FROM "table_name"

Where

SELECT "column_name"

FROM "table_name"

WHERE "condition"

And/Or

SELECT "column_name"

FROM "table_name"

WHERE "simple condition"

{[AND|OR] "simple condition"}+

In

SELECT "column_name"

FROM "table_name"

WHERE "column_name" IN ('value1', 'value2', ...)

Between

SELECT "column_name"

FROM "table_name"

WHERE "column_name" BETWEEN 'value1' AND 'value2'

Like

SELECT "column_name"

FROM "table_name"

WHERE "column_name" LIKE {PATTERN}

Order By

SELECT "column_name"

FROM "table_name"

[WHERE "condition"]

ORDER BY "column_name" [ASC, DESC]

Count

SELECT COUNT("column_name")

FROM "table_name"

Group By

SELECT "column_name1", SUM("column_name2")

FROM "table_name"

GROUP BY "column_name1"

Having

SELECT "column_name1", SUM("column_name2")

FROM "table_name"

GROUP BY "column_name1"

HAVING (arithematic function condition)

Create Table

CREATE TABLE "table_name"

("column 1" "data_type_for_column_1",

"column 2" "data_type_for_column_2",

... )

Drop Table

DROP TABLE "table_name"

Truncate Table

TRUNCATE TABLE "table_name"

Insert Into

INSERT INTO "table_name" ("column1", "column2", ...)

VALUES ("value1", "value2", ...)

Update

UPDATE "table_name"

SET "column_1" = [new value]

WHERE {condition}

Delete From

DELETE FROM "table_name"

WHERE {condition}

تعریف های اولیه :

Query : به معنای درخواست است و در sql به کد جستجویی می گویند که شما برای بدست آوردن نتیجه ای آن را مینویسید و اجرا می کنید .

Resault set : نتیجه بدست آمده از یک Query را میگویند.

Database : پایگاه داده را دیتابیس میگویند که میتواند شامل جداول و ماژول های ما باشد

بزودي تمامي کد هاي بالا را در دروس مختلف مي آموزيد .
نظر شما لينک مطلب
1384/01/27
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور SELECT و Where

دستور SELECT :

اولین نیاز ما انتخاب اطلاعات از یک جدول است . در دستور زیر یک ستون از یک جدول را انتخاب میکنیم .

قالب دستور : SELECT "column_name" FROM "table_name"

مثال :فرض کنید جدولی مانند زیر داریم :

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT store_name FROM Store_Information

نتیحه

Los Angeles

San Diego

Los Angeles

Boston

دستور WHERE :

ممکن است گاهی بخواهیم اطلاعات را طبق پارامتر خاصی استخراج کنیم :

SELECT "column_name"
FROM "table_name"
WHERE "condition"

مثال :فرض کنید جدولی مانند زیر داریم . جاهایی که فروش بیش از هزار دلار است را می خواهیم:

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT store_name
FROM Store_Information
WHERE Sales > 1000

نتیجه

store_name

Los Angeles
نظر شما لينک مطلب
1384/02/14
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور AND OR

AND OR :

در فرمان where دیدید که چگونه اطلاعات را بر حسب یه شرط فیلتر کردیم . حال اگر چند شرط داشته باشیم میتوانیم بکمک AND یا OR آنها را بهم وصل کنیم تا در فرمان where از آن استفاده کنیم .

SELECT "column_name"
FROM "table_name"
WHERE "simple condition"
{[AND|OR] "simple condition"}+

علامات {}+ بدین معنی است که اطلاعات داخل براکت ممکن است یک یا چند بار تکرار شود . ما میتوانیم از پرانتز ها نیز برای جدا کردن اولویت عمل کردن AND و OR استفاده کنیم.

مثال :فرض کنید جدولی مانند زیر داریم . جاهایی که فروش بیش از هزار دلار است یا بین 275 و 500 است را می خواهیم:

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT store_name
FROM Store_Information
WHERE Sales > 1000
OR (Sales < 500 AND Sales > 275)

نتیجه

store_name

Los Angeles

San Francisco
نظر شما لينک مطلب
1384/02/14
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور IN

IN :

در SQL دو استفاده از کلمه کلیدی IN میشود . این بخش قسمت اول آنرا که در ارتباط با کلمه کلیدی where است توضیح می دهد . ما ازین کلمه کلیدی وقتی استفاده می کنیم که مقدار یکی از فیلد ها را دقیقا تعیین کنیم . شما میتوانید بیش از یک مقدار را برای فیلد ها تعیین کنید و بین هر مقدار یک کاما بگذارید . مقادیر می توانند کاراکتر و عددی باشیند . اگر فقط یک مقدار میگذارید نیازی به پرانتز نیست .

SELECT "column_name"
FROM "table_name"
WHERE "column_name" IN ('value1', 'value2', ...)

مثال :فرض کنید جدولی مانند زیر داریم .رکوردهایی که مربوط به لوس آنجلس و سان دیگو است را میخواهیم انتخاب کنیم .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT *
FROM Store_Information
WHERE store_name IN ('Los Angeles', 'San Diego')

نتیجه

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
نظر شما لينک مطلب
1384/02/16
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور BETWEEN

BETWEEN :

همانطور که کلمه IN به ما کمک میکند تا محدوده انتخاب را به یک یا چند مقدار محدود کنیم ، کلمه BETWEEN کمک میکند تا محدوده را یک بازه تعریف کنیم . در این حال تمام مقادیری که بین value1 و value2 باشند انتخاب میشوند .

SELECT "column_name"
FROM "table_name"
WHERE "column_name" BETWEEN 'value1' AND 'value2'

مثال :فرض کنید جدولی مانند زیر داریم .رکوردهایی که تاریخ آنها بین January 6, 1999 و January 10, 1999 است را میخواهیم .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT * FROM Store_Information WHERE Date BETWEEN 'Jan-06-1999' AND 'Jan-10-1999'

نتیجه

store_name | Sales | Date
San Diego | $250 | Jan-07-1999
San Francisco | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999
نظر شما لينک مطلب
1384/02/17
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور LIKE

این کلمه نیز با کلمه where بکار میرود . اساسا like به شما اجازه میدهد که جستجویی را بر مبنای یک پیش زمینه ای که دارید انجام دهید . (مثلا انتخاب رکوردهایی که یکی از فیلدهایش با کلمه خاصی شروع میشود .)

SELECT "column_name"
FROM "table_name"
WHERE "column_name" LIKE {PATTERN}

روش ساخت پترن بکمک مثال:

'ABC%' : تمام کلماتی که با ABC شروع میشوند.

'%XYZ' : تمام کلماتی که به XYZ خاتمه می یابند.

'%AN%' : تمام کلماتی که شامل عبارت AN هستند .

مثال :فرض کنید جدولی مانند زیر داریم . نتیحه را طبق دستور داده شده مشاهده کنید .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT * FROM Store_Information WHERE store_name LIKE '%AN%'

نتیجه

· store_name | Sales | Date
LOS ANGELES | $1500 | Jan-05-1999
SAN FRANCISCO | $300 | Jan-08-1999
SAN DIEGO | $250 | Jan-07-1999
نظر شما لينک مطلب
1384/02/17
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور ORDER BY

تا کنون دیدیم که چگونه اطلاعات را از جداول استخراج می کردیم . حال برای مرتب سازی اطلاعات بر حسب حروف یا اعداد بر روی یکی از فیلد ها ازین کلمه استفاده میکنیم .

SELECT "column_name"

FROM "table_name"

WHERE "condition"

ORDER BY "column_name" [ASC, DESC]

علامات [] در اطراف where بدین معناست که میتوانید where را بکار نبرید. اما اگر بکار بردید حتما باید قبل از order باشد . ASC به معنای صعودی بودن (a to z)و DESC به معنای نزولی بودن است (z to a).پیش فرضش ACS است.

همچنین این نیز امکان پذیرست که مرتب سازی را بر مبنای بیش از یک ستون انجام دهید .برای این منظور بخش مرتب سازی کد بالا بصورت زیر در میاید :

ORDER BY "column_name1" [ASC, DESC], "column_name2" [ASC, DESC

مثال :فرض کنید جدولی مانند زیر داریم . نتیحه را طبق دستور داده شده مشاهده کنید .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT * FROM Store_Information ORDER BY Sales DESC
نتیجه

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
Boston | $700 | Jan-08-1999
San Francisco | $300 | Jan-08-1999
San Diego | $250 | Jan-07-1999
نظر شما لينک مطلب
1384/02/17
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور FUNCTIONS

از وقتی ما در حال کار با اعداد هستیم سوالی که در مرحله دوم برای ما پیش میاید اینه که آیا میشه اعمال حسابی روی این اعداد انجام داد ؟ مثلا میانگین اعداد رو بگیریم .جواب مثبته .SQL چندین عملگر ریاضی داره از جمله SUM و AVG .

SELECT function type(column_name") FROM table_name

مثال: اگر ما بخواهیم جمع کل فروش های جدول را بدست آوریم بصورت زیر عمل میکنیم.

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT SUM(Sales) FROM Store_Information

نتیجه

SUM : Sales

$2750
نظر شما لينک مطلب
1384/02/18
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور COUNT

یکی دیگر از فانکشن ها COUNT است . این به ما اجازه میدهد تا تعداد سطرهای یک جدول را بشماریم . گرامر دستوری بصورت زیر است .

SELECT COUNT("column_name") FROM table_name

مثال: شمردن سطر های جدول فروش :

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT COUNT(store_name) FROM Store_Information

نتیجه

count(store_name)

4

COUNT و DISTINCT را میتوان برای بدست آوردن مقادیر خاص جدول، با هم در یک عبارت نوشت . مثلا اگر ما بخواهیم تعداد فروش های ویژه جدول را بشماریم باید تایپ کنیم :

SELECT COUNT(DISTINCT store_name) FROM Store_Information

نتیجه:

Count(DISTINCT store_name)

3
نظر شما لينک مطلب
1384/02/18
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور GROUP BY

حالا ما بسوی فانکشن های جمع بندی میریم . یادتون هست که از فانکشن SUM برای محاسبه کل فروش استفاده کردیم ؟ حالا اگر بخواهیم کل فروش فروشگاه های هر شهر را بدست آوریم چه باید بکنیم ؟ اینجا 2 چیز لازم است. اول باید نام فروشگاه ها را مانند کل فروش جمع ببندیم و سپس باید مطمئن شویم که تمام فروش ها طبق نام فروشگاه ها باید دسته بندی شود .

SELECT "column_name1", SUM("column_name2") FROM "table_name" GROUP BY "column_name1"

مثال: جدول زیر را در نظر بگیرید .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT store_name, SUM(Sales) FROM Store_Information GROUP BY store_name

نتیجه

store_name | SUM(Sales)
Los Angeles | $1800
San Diego | $250
Boston | $700

کلمه کلیدی Group By وقتی استفاده میشود که ما در حال انتخاب چند ستون هستیم و حداقل یک عملگر محاسباتی در عبارت select داریم . در این زمان ما باید تمام ستونهای دیگر را گروه کنیم.
نظر شما لينک مطلب
1384/02/18
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور HAVING

یکی دیگر از چیزهایی که ممکنه در استخراج اطلاعات نیاز داشته باشیم گزیدن اطلاعات بر اساس یک مقیاس است . بطور مثال ممکنه بخواهیم فروشگاه هایی که بیش از 1500 دلار فروش دارند را استخراج کنیم . بجای استفاده از where ما باید از HAVING استفاده کنیم که برای فانکشن های جمعی استفاده میشه . Having معمولا در انتهای جمله query شما استفاده میشود . جمله ای که having دارد میتواند group by هم داشته باشد .

SELECT "column_name1", SUM("column_name2")
FROM "table_name"
GROUP BY "column_name1"
HAVING (arithematic function condition)

مثال: جدول زیر را در نظر بگیرید .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT store_name, SUM(sales) FROM Store_Information GROUP BY store_name HAVING SUM(sales) > 1500

نتیجه

store_name | SUM(Sales)
Los Angeles | $1800
نظر شما لينک مطلب
1384/02/19
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور ALIAS

دو نوع نام مستعار وجود دارند که اکثرا استفاده میشود . یکی نام مستعار ستون و یکی نام مستعار جدول .

بطور خلاصه نام مستعار ستون برای سامان دادن به خروجی استفاده میشود . یعنی نام بالای ستون ها در خروجی قابل تغییر است .

نوع دوم نام مستعار جداول است : با نوشتن نام مستعار درست بعد از نام جدول بعد از From انجام میشود. راحتی استفاده از این کلمه کلیدی در هنگام استفاده از دو جدول در استخراج جداول است که اطلاعات توسط کلمه join متحد و سپس استخراج می گردد .قبل از اینکه به Join برسیم بیایید نگاهی به alias بیندازیم .

SELECT "table_alias"."column_name1" "column_alias"
FROM "table_name" "table_alias"

بطور خلاصه هر دو نوع مستعار ها بعد از آیتمی میایند که نام مستعارش هستند . البته با یک فاصله .

مثال: جدول زیر را در نظر بگیرید .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

SELECT A1.store_name Store, SUM(A1.Sales) "Total Sales" FROM Store_Information A1 GROUP BY A1.store_name

نتیجه

Store | Total Sales
Los Angeles | $1800
San Diego | $250
Boston | $700
نظر شما لينک مطلب
1384/02/19
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور JOIN

در این بخش برای یادگیری join نیاز به بسیاری از کلمات کلیدی ای داریم که در دروس قبل آموختیم. به دو جدول زیر توجه کنید .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

Table Geography

region_name | store_name
East | Boston
East | New York
West | Los Angeles
West | San Diego

چیزی که ما نیاز داریم اینه که میخواهیم فروش را در هر منطقه جغرافیایی بدست بیاریم . می بینیم که جدول Geography اطلاعات مناطق جغرافیایی را در بر دارد و جدول Store_Information اطلاعات فروش شهر ها را . برای بدست آوردن فروش در هر منطقه ، ما باید اطلاعات بدست آمده از هر منطقه را در هم ترکیب کنیم . با نگاهی به دو جدول می فهمیم که یک فیلد مشترک در هر دو موجود است و آن store_name میباشد که با یک کاما بهم وصل میشوند .

کد زیر را ببینید تا توضیحات را شرح دهیم .

SELECT A1.region_name REGION, SUM(A2.Sales) SALES
FROM Geography A1, Store_Information A2
WHERE A1.store_name = A2.store_name
GROUP BY A1.region_name

نتیجه :

REGION | SALES
East | $700
West | $2050

دو خط اول کد به sql میگوید که دو فیلد را انتخاب کند . اولین خط فیلد region_name است از جدول Geography که نام مستعار REGION گرفته است . و دومین خط حاصل فیلد sales از جدول Store_Information که نام مستعار sales گرفته است . دقت کنید که چگونه مستعار های جدول در اینجا بکار گرفته شده . Geography بعنوان A1 مستعار شده و Store_information بنام A2 . بدون استفاده از مستعار ها خط اول بصورت زیر در میاید .

SELECT Geography.region_name REGION, SUM(Store_Information.Sales) SALES

اساسا کار مستعار ها قابل درک کردن کد های طولانی SQL است . بخصوص هنگامی که چند جدول در کار است .

حال بخط سوم کد اصلی توجه کنید ،یعنی کلمه where . اینجا جائیست که join کارش معلوم میشود . در این حالت ما میخواهیم مطمئن شویم که محتوای "store_name" در جدول Geography با مقادیر آن در جدول Store_Information نظیر میشود و راهش اینه که آنها را برابر هم قرار دهیم . کلمه where لازمه که مطمئن شویم که اطلاعات درست بدست میاید . بدون یک کلمه where درست ، یک نتیجه join دکارتی بدست میاید . نتیحه دکارتی در اصل ترکیبی از تمام حالات بوجود آمده از دو جدول را ارائه میکند . یعنی نتیجه برابر میشه با 4 x 4 = 16
نظر شما لينک مطلب
1384/02/19
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور OUTER JOIN

قبلا دیدیم که چطور اطلاعات را با ایجاد اتصال بین دو جدول استخراج کردیم . در این حالت می خواهیم اطلاعات را از جدولی انتخاب کنیم صرفنظر ازینکه آنها در جدول دیگر ارائه شده اند یا خیر . برای اینکار باید از outer join استفاده کنیم .

این دستور در دیتابیس ها ، وابسته به نوع دیتابیس است . بطور مثال در اوراکل ما باید یک علامت "(+)" در کلمه where قرار دهیم .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

Table Geography

region_name | store_name
East | Boston
East | New York
West | Los Angeles
West | San Diego

جداول بالا موجود است و ما میخواهیم فروش تمام فروشگاه ها را که در جدول Geography آمده بدست آوریم . اگر مااز حالت join معمولی استفاده کنیم اطلاعات درستی بدست نمی آوریم ، چون مقدار New York را در جدول دوم به ما نشان نخواهد داد . چرا ؟ چون این مقدار در جدول اولی موجود نیست .

SELECT A1.store_name, SUM(A2.Sales) SALES
FROM Georgraphy A1, Store_Information A2
WHERE A1.store_name = A2.store_name (+)
GROUP BY A1.store_name

توجه کنید که در کد بالا ما در حال استفاده از گرامر دستوری oracle هستیم .

نتیجه :

store_name | SALES
Boston | $700
New York |
Los Angeles | $1800
San Diego | $250

نکته : وقتی که رکوردی در جدول دوم همتایش موجود نباشد NULL برگردانده میشود . در این حالت New York در جدول Store_Information موجود نمی باشد .
نظر شما لينک مطلب
1384/02/19
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور UNION

هدف دستور Union ترکیب کردن نتایج حاصل از دو query با یکدیگر میباشد. در این رابطه میتوان گفت که union چیزی شبیه به join میباشد . چون هر دوی آنها برای ایجاد رابطه بین اطلاعات جداول مختلف استفاده میشوند . یکی از محدودیت های union این است که این ستون های متناظر با هم باید از یک نوع داده اطلاعات باشند. همچنین هنگام استفاده ار union فقط مقدار های متمایز انتخاب میشوند .(مانند select Distinct ) .

قالب دستوری :

[SQL Statement 1]
UNION
[SQL Statement 2]

مثال : جداول زیر را در نظر بگیرید . ما میخواهیم تمام تاریخ هایی را که در آن معامله ای انجام شده است استخراج کنیم . بنابرین از کد زیر استفاده میکنیم .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

Table Internet Sales

Date | Sales
Jan-07-1999 | $250
Jan-10-1999 | $535
Jan-11-1999 | $320
Jan-12-1999 | $750

SELECT Date FROM Store_Information
UNION
SELECT Date FROM Internet_Sales

نتیجه :

Date

Jan-05-1999

Jan-07-1999

Jan-08-1999

Jan-10-1999

Jan-11-1999

Jan-12-1999

توجه کنید که اگر ما از SELECT DISTINCT Date استفاده کنیم ، برای یکی یا هر دو عبارت، ما نتایج یکسانی را بدست خواهیم آورد .
نظر شما لينک مطلب
1384/01/19
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور UNION ALL

هدف دستور Union all نیز ترکیب کردن نتایج حاصل از دو query با یکدیگر میباشد . اما فرقی که با union دارد این است که هنگام استفاده از union فقط مقادیر متمایز نشان داده میشود ، اما با union all تمام مقادیر برگردانده میشود.

قالب دستوری :

[SQL Statement 1]
UNION ALL
[SQL Statement 2]

مثال : جداول زیر را در نظر بگیرید . ما میخواهیم تمام تاریخ هایی را که در آن معامله ای انجام شده است استخراج کنیم . بنابرین از کد زیر استفاده میکنیم . تفاوت را با union مقایشه کنید .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

Table Internet Sales

Date | Sales
Jan-07-1999 | $250
Jan-10-1999 | $535
Jan-11-1999 | $320
Jan-12-1999 | $750

SELECT Date FROM Store_Information
UNION ALL
SELECT Date FROM Internet_Sales

نتیجه :

Date

Jan-05-1999

Jan-07-1999

Jan-08-1999

Jan-08-1999

Jan-07-1999

Jan-10-1999

Jan-11-1999

Jan-12-1999
نظر شما لينک مطلب
1384/02/19
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور INTERSECT

مانند دستور union این دستور نیز با دو جمله SQL کار میکند . اما تفاوت اینجاست که دستور union در اصل مانند یک OR کار میکند و تمام رکوردهای غیر تکراری را بر میدارد . اما این دستور مانند AND کار میکند و رکورد های مشترک را بر میدارد .

قالب دستوری :

[SQL Statement 1]
INTERSECT
[SQL Statement 2]

مثال : جداول زیر را در نظر بگیرید . ما میخواهیم تمام تاریخ هایی را که در آن معامله ای انجام شده است استخراج کنیم . بنابرین از کد زیر استفاده میکنیم . تفاوت را با union مقایشه کنید .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

Table Internet Sales

Date | Sales
Jan-07-1999 | $250
Jan-10-1999 | $535
Jan-11-1999 | $320
Jan-12-1999 | $750

SELECT Date FROM Store_Information
INTERSECT
SELECT Date FROM Internet_Sales

نتیجه :

Date

Jan-07-1999
نظر شما لينک مطلب
1384/02/23
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش SQL server - دستور MINUS

این دستور نیز با دو جمله SQL کار میکند. در ابتدا تمام نتایج query اول را میگیرد و سپس از میان نتایج ، آنهایی را که در query دوم هستند حذف میکند .

قالب دستوری :

[SQL Statement 1]
MINUS
[SQL Statement 2]

در اینجا میخواهیم تاریخ هایی را که در آنها فقط فروش در فروشگاه داشته این بیابیم.(فروش روی اینترنتی اصلا نمیخواهیم)

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

Table Internet Sales

Date | Sales
Jan-07-1999 | $250
Jan-10-1999 | $535
Jan-11-1999 | $320
Jan-12-1999 | $750

SELECT Date FROM Store_Information
MINUS
SELECT Date FROM Internet_Sales

نتیجه :

Date

Jan-05-1999

Jan-08-1999
نظر شما لينک مطلب
1384/02/23
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


دستکاری جدول های بانک اطلاعاتي SQL

CREATE TABLE: جداول ساختمان بندی پایه یک بانک اطلاعاتی اند که اطلاعات را در خود جای میدهند . برنامه های بسیاری هستند که بدون استفاده از کد های sql برای شما جدول میسازند . اما یادگیری این دستورات برای کسی که با جداول و دیتابیس کار میکند ضروری است.

قبل از یادگیری گرامر دستوری ساخت جدول ، باید منطق و اصول ساخت جدول را بیاموزید . جداول به سطرها (ROW) و ستون ها (COLUMN) تقسیم میشوند . هر سطر یک رکورد از اطلاعات را در خود جای داده است.هر سطر چند فیلد دارد .

مثال : مثلا کارنامه مدارس را در نظر بگیرید .مثلا 3 ستون دروس ، نمره و تاریخ دارد و سطر های آن هر کدام شامل سه بخش هستند طبق دسته بندی ستون هایش .

سطر اول : ریاضی – 12 - 12/3/1384

سطر دوم : فیزیک – 14 - 16/3/1384

و بهمین ترتیب .پس هر سطر جدول را یک رکورد می نامیم . هر ستون جدول (فیلد) دارای یک نوع داده است . در مثال فوق ستون دروس از نوع string و ستون نمرات از نوع integer و ستون تاریخ از نوع date است . هنگام ساخت جدول که فیلد هایش را مشخص میکنید باید نوع داده ای فیلد ها نیز مشخص گردد. کد ساخت جدول بصورت زیر میباشد :

CREATE TABLE "table_name"
("column 1" "data_type_for_column_1",
"column 2" "data_type_for_column_2",
... )

کد ساخت یک جدول نمونه :

CREATE TABLE customer
(First_Name char(50),
Last_Name char(50),
Address char(50),
City char(50),
Country char(25),
Birth_Date date)

DROP TABLE : گاهی ما دلمون میخواد که بهر دلیلی از دست یک جدول در پایگاه داده خود راحت شویم . SQL این امکان رو برای ما فراهم کرده و ما میتونیم برای پاک کردنش از کد زیر استفاده کنیم .

DROP TABLE "table_name"

مثال :

DROP TABLE customer.

TRUBCATE TABLE : گاهی ما میخواهیم که اطلاعات داخل یک جدول رو پاک کنیم . اما نمیخواهیم خود جدول پاک شود. برای اینکار ازین دستور کمک میگیریم

TRUNCATE TABLE "table_name"

مثال :

TRUNCATE TABLE customer.

INSERT INTO : برای ورود اطلاعات داخل یک جدول دو راه وجود دارد. یکی اینکه رکورد ها را تک تک وارد کنیم (سطر به سطر) و یکی اینکه یکدفعه چندین سطر را وارد جدول کنیم . برای وارد کردن اطلاعات بصورت سطر به سطر با کد زیر عمل میکنیم .

INSERT INTO "table_name" ("column1", "column2", ...)
VALUES ("value1", "value2", ...)

فرض کنید جدول با ساختار زیر داریم .

Table Store_Information

نام ستون ها | نوع داده ستون
store_name | char(50)
Sales | float
Date | datetime

و حالا ما میخواهیم یک رکورد(سطر) اطلاعات وارد جدول فروش کنیم . با مشخصات ذیل : لوس آنجلس – 10 ژانویه 1999 و فروش 900$ . بنابرین کد زیر را استفاده میکنیم.

INSERT INTO Store_Information (store_name, Sales, Date)
VALUES ('Los Angeles', 900, 'Jan-10-1999')

نوع دوم از ورود اطلاعات وارد کردن چندین سطر با هم میباشد . بر خلاف بخش قبلی ، ما از کلمه SELECT برای مشخص کردن داده هایی که میخواهیم وارد جدول کنیم استفاده میکنیم . اگر فکر کرده اید که این اطلاعات از جدول دیگری در حال کپی در این جدول است درست فکر کرده اید.

INSERT INTO "table_name" ("column1", "column2", ...)
SELECT "column1", "column2", ...
FROM "table1"

توجه کنید که کد بالا ساده ترین حالت ممکن بود .جمله select شما می تواند دارای کلمات where , Group by , Having باشد .

بطور مثال اگر ما جدولی داشته باشیم که بخواهیم اطلاعات فروش سال 1998 را بگیرد و هم اکنون جدول دیگری دارید که اطلاعات تمام سال های 1995 تا 2000 را شامل میشود و اگر ساختار دو جدول یکسان باشد باید تایپ کنید :

INSERT INTO Store_Information (store_name, Sales, Date)
SELECT store_name, Sales, Date
FROM Sales_Information
WHERE Year(Date) = 1998

در اینجا من اطلاعات را بر اساس یک تاریخ استخراج کردم و در جدول دیگری کپی کردم. اگر رابطه ها را در حالات دیگر بسازید کمی با این حالت فرق دارد . برای مثال در اوراکل تکه آخر کد بصورت زیر در میاید :

WHERE to_char(date,'yyyy')=1998

UPDATE : گاهی ما در یک جدول اطلاعاتی داریم و میخواهیم مقداری را در جدول تغییر دهیم .برای اینکار از دستور UPDATE استفاده می کنیم .

UPDATE "table_name"
SET "column_1" = [new value]
WHERE {condition}

مثال : ما جدول زیر را داریم .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

مثلا ما متوجه میشویم که مقدار فروش فروشگاه لوس آنجلس در تاریخ 01/08/1999 در اصل 500$ بوده و باید این مقدار را در جدول تصحیح کنیم . برای اینکار از کد زیر استفاده میکنیم.

UPDATE Store_Information
SET Sales = 500
WHERE store_name = "Los Angeles"
AND Date = "Jan-08-1999"

بعد از اجرای کد بالا مقادیر جدول بصورت زیر در میاید .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $500 | Jan-08-1999
Boston | $700 | Jan-08-1999

در جدول مذکور فقط یک رکورد بود که تاریخش Jan-08-1999 و نام فروشگاهش Los Angeles باشد . اگر لچند رکورد با این مشخصات وجود داشت نیز تمام آنها مقدارشان تغییر میکرد . در مثال فوق فوق یک رکورد وجود داشت با مشخصاتی که ما دادیم و فقط هم یک فیلدش را تغییر دادیم .

این امکان وجود دارد که مقدار چند فیلد را به یکباره تغییر دهیم . برای اینکار از گرامر کد زیر استفاده میشود .

UPDATE TABLE "table_name"
SET ("column_1", "column_2") = ([new value 1], [new value 2])
WHERE {condition}

UPDATE : برای پاک کردن یک رکورد از جدول ازین کد استفاده میکنیم .

DELETE FROM "table_name"
WHERE {condition}

مثال : جدول زیر را داریم .

Table Store_Information

store_name | Sales | Date
Los Angeles | $1500 | Jan-05-1999
San Diego | $250 | Jan-07-1999
Los Angeles | $300 | Jan-08-1999
Boston | $700 | Jan-08-1999

فرض کنید بخواهیم اطلاعات فروشگاه لوس آنجلس را پاک کنیم . برای اینکار از کد زیر استفاده میکنیم .

DELETE FROM Store_Information
WHERE store_name = "Los Angeles"

نتیجه:

Table Store_Information

store_name | Sales | Date
San Diego | $250 | Jan-07-1999
Boston | $700 | Jan-08-1999
نظر شما لينک مطلب
1384/02/23
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


ادغام شرکت ماکرومدیا و ادوبی

شرکت Adobe در یک معامله 3.4 میلیارد دلاری شرکت macromedia را خرید . این معامله انحصار برنامه های طراحی وب را در دست ادوبی قرار خواهد داد . زیرا پیوستن ماکرومدیا به ادوبي قدرت دو چندانی را در دست ادوبی قرار میدهد .

کارشناسان نرم افزار این قرار داد را چیزی بیش از یک ادغام معمولی خوانده اند . زیرا با این اقدام ادوبی میتواند در برابر شرکت مایکروسافت بایستد. زیرا برنامه دریم ویور که رقیب اصلی فرانت پیج مایکروسافت است ، امروز در دست ادوبی است و تکنولوژی های jrun و coldfusion و Breeze نیز توان مقالبه در برابر تکنولوژی دات نت مایکروسافت را دارند . در زمینه گرافیک هم که گرافیک بیت مپ فتوشاپ پیشتاز گرافیک دیجیتال است . و ازین پس قدرت فلش و PDF نیز در ترکیب تازه ای با هم گوی سبقت را از مایکروسافت می ربایند و در دست ادوبی می نهند .
نظر شما لينک مطلب
1384/02/23
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش ساخت فانکشن Query Command

معرفی مقاله :

این مقاله نحوه ایجاد قابلیتی را می آموزد که ; ضوابط فیلتر کردن را از طریق یک فرم جدولی اکسس 2000 وارد کنید و دکمه ای بنام Query داشته باشید تا فیلتر اعمال شود.

این فیلتر 4 تکست باکس دارد بنام های txtFirstName, txtMiddleInitial, txtLastName, و txtSSN .جدول دیتابیس member نام دارد و فیلد هایی بنام های First, Mi,Last, و SSN دارد .

فانکشن AttachAnd برای ساخت جمله فیلتر کننده SQL استفاده میشود .

"First='David' and Last='Nishimoto'".

ساخت فانکشن :

Option Compare Database

    Dim ssql

1- کاربر دکمه query را فشار داد

2-یا اینکه شما میتوانید یک دکمه برای رویداد exit قرار دهید.

    Private Sub cmdQuery_Click()

        BuildQueryCommand

    End Sub

3- فانکشن BuildQueryCommand یک فیلتر با ضوابطی که از تکست باکس ها دریافت کرده میسازد

4 – قوانین فیلتر اعمال شد .

    Private Function BuildQueryCommand()

        sSQL = ""

        Call AttachAnd("First", "'" & txtFirstName & "'")

        Call AttachAnd("Mi", "'" & txtMiddleInitial & "'")

        Call AttachAnd("Last", "'" & txtLastName & "'")

        Call AttachAnd("SSN", "'" & txtSSN & "'")

        Filter = sSQL

        FilterOn = True

    End Function

ضوابط چندگانه یا تکی را بررسی کنید
 Single: "first='David'"

Multiple:"First='David' and Last='Nishimoto'"

    Private Function AttachAnd(sField, sValue)

        If sValue = "''" Or sValue = "" Then

            Exit Function

        End If

        If Occurances(sSQL, "=") = 0 Then

            sSQL = sSQL & sField & "=" & sValue

        Else

            sSQL = sSQL & " and " & sField & "=" & sValue

        End If

    End Function

رخدادهای یک طرح را در عبارت sql بشمارید

    Private Function Occurances(sSQL, sOperator)

    Dim offset

    Dim iCount

        offset = 1

        While offset <> 0

               offset = InStr(offset + 1, sSQL, sOperator)

               If offset > 1 Then

                       iCount = iCount + 1

               End If

        Wend

        Occurances = iCount

    End Function
نظر شما لينک مطلب
1384/02/29
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


معرفی سرویس های گوگل
  • Google groups : usenet یک شبکه جهانی برای گروه های مباحثه است . گوگل مباحث usenet در 20 سال اخیر را که بیش از 700 میلیون پیغام است جمع آوری کرده و در آدرس groups.google.com یکجا فراهم کرده است . مقالات علمی و تخصصی بسیاری در این بخش از گوگل وجود دارد که همچون گنجینه ای گران بها برای دوست داران علم و تکنولوژی است .
  • Images : آرشیوی از 350 میلیون عکس که از سرتا سر وب گلچین شده اند . در این بخش شما براحتی میتوانید حتی بصورت فارسی دنبال عکس مورد نظرتان بگردید . آدرس images.google.com را باز کنید و کلمه فارسی نوروز را در آن جستجو کنید تا نتایج جالب گوگل را ببینید .
  • NEWS : در این بخش عناوین 4000 منبع خبری که بر اساس موضوع دسته بندی شده اند در آدرس news.google.com دسته بندی شده اند .
  • Gmail : ایمیل دو گیگا بایتی گوگل است که در آدرس Gmail.com قابل دسترس است و شما بطور عادی نمیتوانید در آن عضویت یابید مگر اینکه یکی از اعضایش برای شما دعوت نامه بفرستد .
  • FireFox : مرورگر روباه آتش یک مرورگر کد باز است که بنیاد نرم افزارهای موزیلا آنرا طراحی کرده است . اما گوگل نیز آن را پشتیبانی میکند و بعید نیست که بزودی بنام گوگل عرضه شود. www.GetFirefox.com
  • Scholar : جستجوی علمی گوگل که برای جستجوی مقالات علمی طراحی شده است در این آدرس قرار دارد . و فقط مقالات مرتبط با رشته های علوم را نمایش میدهد . scholar.google.com
  • Directory : لیست سایت ها بر اساس موضوع . این بخش گوگل بر اساس پروژه Dmoz مرتب شده است که شامل شاخه ها و زیر شاخه هایی است که 1.5 میلیون سایت را در آن دسته بندی کرده است .
  • ORKUT : یک شبکه از دوستان شناخته شده . در این سایت مانند gmail کسی باید برایتان دعوتنامه بفرستد تا شما هم جزو دوستان او شوید .این شبکه شامل گروه های بسیاری در تمام زمینه هاست که می توانید در آنها عضو شده و فعالیت کنید . از گروه طرفداران تام و جری تا مهندسان نرم افزار دانشگاه استنفورد!www.orkut.com

بعد از گوگل شرکت های زیادی از جمله یاهو سعی در راه اندازی سرویسی مانند ارکات کردند ، اما موفقیت هیچ کدام مانند ارکات نبوده . زیرا گوگلی ها میدانند که شما چه چیزی میخواهید ! سرویس هایی که سعی در رقابت با گوگل دارند به قرار زیرند :

www.hi5.com

360.yahoo.com

www.multiply.com

www.ringo.com

www.gazzag.com

…
نظر شما لينک مطلب
1384/02/30
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


مقایسه ای بین SQL server 2000 و ACCESS 2000

در گروه های خبری و فروم ها خیلی ها ازم پرسیدند که بالاخره پایگاه داده های Sql بهتره یا بانک اطلاعاتی اکسس. در این مقاله سعی دارم تا مقایسه ای بین این دو دیتابیس مایکروسافت انجام بدم تا شما راحت تر بتونید دیتابیس لازم برای نوشتن برنامه وب سایت خود انتخاب کنید .در این مقایسه نیاز های نرم افزار ها ، قیمت ، قابلیت های هر بانک و محدودیت های هر محصول بررسی میشود .

محیط اجرا :

SQL 2000 فقط روی محیط های ویندوزی قابل اجراست مانند ویندوز 9x و NT و 2000 و CE .

ACCESS روی سیستم های زیر قابل نصب است : ویندوز 95 و 98 و 98SE و me و NT4 با سرویس پک 6 و ویندوز 2000 و XP و ویندوزهایی بعد آن .

نیازهای سخت افزاری :

برای نصب SQL 2000 شما باید سی پی یو اینتل و یا مدل سازگار با آن داشته باشید بعلاوه مشخصات زیر

Hardware | Requirements
Processor | Pentium 166 MHz or higher
Memory | 32 MB RAM (minimum for Desktop Engine), 64 MB RAM (minimum for all other editions), 128 MB RAM or more recommended
Hard disk space | 270 MB (full installation), 250 MB (typical), 95 MB (minimum), Desktop Engine: 44 MB Analysis Services: 50 MB minimum and 130 MB typical English Query: 80 MB

برای نصب اکسس 2000 شما دو انتخاب دارید. نصب نسخه pro یا نصب نسخه developer . برای نصب اکسس شما نیاز به سخت افزار های زیر دارید .

Hardware | Requirements
Processor | Pentium 75 MHz or higher
Memory | 8 MB of RAM required for Access 2000, plus 4 MB of RAM for each application running simultaneously, plus memory for the operation system: · 16 MB of RAM for Windows 95 or Windows 98 · 32 MB of RAM for Windows Me or Windows NT · 64 MB of RAM for Windows 2000 · 128 MB of RAM for Windows XP
Hard disk space | Access 2000 requires over 30 MB of hard disk space

نیازهای نرم افزاری :

SQL server 2000 دارای شش نسخه میباشد : Enterprise, Standard, Personal, Developer, Desktop Engine and SQL Server CE و برای اجرا به نرم افزار های زیر نیاز دارد .

Operating System | Enterprise Edition | Standard Edition | Personal Edition | Developer Edition | Desktop Engine | SQL Server CE
Windows CE | No | No | No | No | No | Yes
Windows 9x | No | No | Yes | No | Yes | No
Windows NT 4.0 Workstation with Service Pack 5 | No | No | Yes | Yes | Yes | No
Windows NT 4.0 Server with Service Pack 5 | Yes | Yes | Yes | Yes | Yes | No
Windows NT 4.0 Server Enterprise Edition with Service Pack 5 | Yes | Yes | Yes | Yes | Yes | No
Windows 2000 Professional | No | No | Yes | Yes | Yes | No
Windows 2000 Server | Yes | Yes | Yes | Yes | Yes | No
Windows 2000 Advanced Server | Yes | Yes | Yes | Yes | Yes | No
Windows 2000 DataCenter | Yes | Yes | Yes | Yes | Yes | No
Windows XP Professional | No | No | Yes | Yes | Yes | No

در مقایسه با SQL server 2000 بانک اکسس در اصل یک ورژن بیشتر ندارد و میتواند روی سیستم های زیر نصب شود . : ویندوز 95 و 98 و 98SE و me و NT4 با سرویس پک 6 و ویندوز 2000 و XP و ویندوزهایی بعد آن .

مقایسه قیمت ها :

SQL 2000 در حال حاضر دو مجوز برای نصب روس سرور ها دارد.

  • Processor license.
  • Server/per-seat client access license (CAL).

در حالت پروسسور برای هر CPU نیاز به یک مجوز میباشد و تعداد دسترسی نا محدود کلاینت ها را داریم . اگر تعداد کلاینت ها نامعلوم است میتوان ازین نوع مجوز استفاده کرد . برای تعداد نفرات بالای کلاینت این مجوز ارزان تر تمام میشود .

در حالت CAL یک مجوز برای یک سرور باید اخذ کنید و به ازای هر کلاینت هم یک مجوز جداگانه . این حالت وقتی کلاینتها حدود 30 تا باشند به صرفه است .

Licensing Options | SQL Server 2000 Standard Edition | SQL Server 2000 Enterprise Edition
Processor | $4,999 per processor | $19,999 per processor
Server/Per-Seat CAL | with 5 CALs - $1,489 with 10 CALs - $2,249 | with 25 CALs - $11,099

بانک اکسس 2000 مانند آفیس 2000 هم اکنون در خرده فروشی ها قابل یافت نیست و نسخه های جدید این محصولات مانند نسخه XP قابل خریداری است . ( در آمریکا به خرید محصولات قدیمی مایکروسافت بجای نسخه جدید آن ، DownGrading یا کم ارزش پنداشتن گفته میشود و چندان کار جالبی نیست)

Products | New User Price | Upgrade Price
Microsoft Access 2002 | $339 | $109
Office XP Professional Edition | $579 | $329
Office XP Developer Edition | $799 | $549

مقایسه قابلیت ها :

  • بانک اطلاعاتی اکسس 2000 بعنوان برنامه های دسکتاپ ارزیابی میشوند و برای کار با چندین مگابایت اطلاعات خوب کار میکنند . اما SQL بانکی برای کار با چندید گیگابایت اطلاعات است .
  • بانک اکسس از سیستم معماری فایلی بهره میگیرد . اما SQL از سیستم کلاینت سرور استفاده میکند.
  • بانک اکسس محدودیت های زیادی نسبت به SQL server دارد و در محیط هایی که چندین کاربر با هم میخواهند بصورت همزمان و بهینه کار کنند گاهی توان کار ندارد.

تعدادی از قابلیت های این دو بانک اطلاعاتی :

Feature | Access 2000 | SQL Server 2000
SMP support | Not Supported | Supported
Tables | Relational tables | Relational tables, Temporary tables
Triggers | Not Supported | AFTER triggers, INSTEAD OF triggers
Procedures | Not Supported | Microsoft T-SQL statements
User-defined functions | Not Supported | Scalar functions, Inline table-valued functions, Multistatement table-valued functions
Views | Not Supported | Supported
Transaction logging | Not Supported | Supported
Recovery | Recovery to last backup | Recovery to last backup, recovery to the point of failure, recovery to a specific point in time
Integration with Windows NT security | Not Supported | Supported

مقایسه محدودیت ها :

تعدادی ازین محدودیت ها به قرار زیر است

Feature | SQL Server 2000 | Access 2000
database size | 1,048,516 TB | 2 GB plus linked tables size
objects in a database | 2,147,483,647 | 32,768
user name length | 128 | 20
password length | 128 | 14
table name length | 128 | 64
column name length | 128 | 64
index name length | 128 | 64
Number of concurrent users | limited by available memory | 255
columns per table | 1024 | 255
table size | limited by available storage | 1 GB
number of indexes in a table | 250 | 32
number of columns in an index | 16 | 10
bytes per row | 8060 | 2000
number of tables in a query | 256 | 32
columns per SELECT statement | 4096 | 255
nested subqueries | 32 | 50
number of enforced relationships | 253 | 32
SQL statement size | 65,536 * Network packet size (4 KB, by default) | approximately 64,000

نتیجه گیری :

اگر شما میخواهید یک سیستم قوی هیکل ، با امنیت و کارا بسازیر باید از SQL استفاده کنید زیرا:

  • اکسس از transaction های خیلی ریز پشتیبانی نمیکند .
  • اکسس انتقال اطلاعات را در بانک ها و یا حالات ROLL back را تضمین نمیکند.
  • SQL server با بخش امنیت ویندوز NT یکپارچه شده است . اما اکسس خیر.
  • در اکسس نمیتوان هنگام بروز خطا به نقاط point بازگشت ، اما در SQL میتوان.

منابع این مقاله

http://www.mssqlcity.com/Articles/Compare/sql_server_vs_access.htm

Office 2000 System Requirements
Maximum Capacity Specifications
Microsoft Access 2000 Maximum Capacities
Microsoft SQL Server: Microsoft Access 2000 Data Engine Options

نظر شما لينک مطلب
1384/03/04
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها

بیایید به روزهای اولیه وب برگردیم . هیچ استانداردی نبود و هر مرورگر هر روز یه تگ جدید معرفی میکرد. بالاخره یه موسسه همه مرورگر ها رو سر یه میز جمع کرد و با هم استانداردی بنام W3C را تصویب کردند . در این زمان نیاز عمده ای حس میشد که محتویات سایت از طراحی جدا شود . در اینجا بود که سر و کله CSS پیدا شد و مسئولیت نمایش نمای صفحات را بعهده گرفت و XHTML نیز برای نمایش اطلاعات بگار گرفته شد .

چرا باید بجای جدول از کد CSS استفاده کرد ؟

  • اول اینکه کد شما خیلی کوتاه تر میشه ، حتی نصف !
  • دوم اینکه سرعت لودینگ سایت شما بیشتر میشه .
  • راحت تر تغییر مییابد : شما یک فایل CSS را تغییر می دهید و کل سایت شما تغییر می یابد .
  • مطالب از قالب سایت میشود .

در این مقاله شما یاد میگیرید چگونه بجای جداول از CSS وکلاس های آن استفاده کنید .

ساخت کلاسی برای عناصر تگ <div> : اولین قدم ساخت کلاس CSS است که المنت های تگ <DIV> از آن استفاده میکنند . بصورت زیر :

div.leftnav{

background: white;

color: black;

/* other display information here */

/* add Positioning information here */

}

این کلاس بسیار ساده است و در اصل الان کاری انجام نمیدهد . فقط متن سیاه را روی زمینه سفید تعریف میکند . شما باید از این المنت در جایی از صفحه استفاده کنید .

موقعیت یابی وابسته ساده :

این بدین معناست که ما فقط هر عنصر را در موقعیتش قرار میدهیم و بدین تعریف کردن جای دقیق آن در صفحه .

div.leftnav{

background: white;

color: black;

/* Other display information here */

width: 15%;

}

خوب . ما چه انجام دادیم ؟ ما گفتیم که هدایتگر چپ باید در سمت چپ باشه ، جاییکه در صفحه قرار میگیرد . این بد نیست ، اما برای انعطاف بیشتر ممکنه شما به موقعیت یابی مطلقی نیاز داشته باشید . همچنین این خیلی مهمه که بدونین که چیزی که شما تا حالا انجام دادید موقیت نمایی اصلی نیست . تمام چیزی که تعریف کردید Width بود . بنابرین یک المنت با پهنای 15% ساخته خواهد شد .

موقعیت نمایی مطلق . اضافه کردن border و margin :

موقعیت نمایی مطلق به معنای این است که شما بگویید دقیقا المنت های شما کجای صفحه ظاهر شوند . اینکار با تعریف خاصیت های top , bottom, left , right امکان پذیر میشود :

div.content{

background: white;

color: black;

position: absolute; /* Says which positioning we are using */

left: 17%; /* 17% from the left side of the screen */

width: 69%; /* This is the width */

}

نکته اینجاست که در کد بالا فقط خاصیت left تعریف شده، این کافیه ! نیازی نیست که شما تمامی تمام خاصیت هایش را تعریف کنید . اما برای انعطاف پذیری بیشتر ممکنه خودتون بخواهید اینکارو بکنید . بطور مثال ممکنه شما بخواهید یک منو در سمت راست اضافه کنید:

div.rightnav{

background: white;

color: black;

position: absolute;

left: 83%;

width: 10%;

top: 80px; /* 80 pixels from the top */

}

اساسا در موقعیت نمایی مطلق این المنت ها معانی زیر را دارند:

Left : فاصله از چپ صفحه ، معمولا بر حسب درصد

Right : فاصله از راست صفحه ، معمولا بر حسب درصد

Top: فاصله از بالای صفحه ، معمولا بر حسب پیکسل

Bottom : فاصله از پایین صفحه ، معمولا بر حسب پیکسل

نکته اینکه bottom به ندرت استفاده میشود ، اما گاهی لازم میشود . اگر شما از 4 یا 3 تا پراپرتی با هم استفاده کنید ،باید قادر به قرار دادن تگ DIV در هر کجا که میخواهید باشید . همچنین در نظر داشتن این نکته مهم است که راه های بیشتری نیز برای موقعیت نمایی یک المنت در کنار موقعیت نمایی مطلق وجود دارد . اما تمام مرورگر های وب آن راه ها را پشتیبانی نمیکنند .

افزودن Border :

ممکنه شما بخواهید کمی عناصرصفحه را با لبه کنار صفحه یا هر چیز دیگر فاصله دهید ، border ها برای این امر مناسبند . اما صفحه خود را در مرورگر های مختلف تست کنید تا نتیجه درستی دریافت کنید . و حال طرز ساخت حاشیه ها:

div.rightnav{

background: white;

color: black;

position: absolute;

left: 83%;

width: 10%;

top: 80px; /* 80 pixels from the top */

border-color: white; /* Keep the border invisible */

border-style: solid; /* It is a solid invisible line which is fine */

border-bottom-width: 2px; /* These attributes are pretty self-explanatory */

border-top-width: 2px;

border-left-width: 3px;

border-right-width: 4px;

}

افزودن حاشیه یا margin :

Margin ها ابزار های قدرتمندی در سایت های css میباشند .در مقدمه میبینید که شما میتوانید چیزی را بکمک تعیین فاصله درصدی از طرفین margin ها در وسط قرار دهید .

div.content{

background: white;

color: black;

margin-left: 20%; /* 20% from the left side of the screen */

margin-right: 20%; /* 20% from the right side of the screen */

}

نقصان وجود پشتیبانی مرورگر ها :

پشتیبانی نشدن تمام دستورات css توسط تمامی مرورگر ها مشکلات زیادی را برای طراحان پیش آورده . Mozilla ( و مرورگر های زیر مجموعه آن مانند FireFox ) و Opera بروز رسانی بسیار خوبی در پشتیبانی دستورات css دارند . اما Internet Explorer کمی عقب مانده است . کد هایی که در این مقاله نوشتیم توسط تمامی مرورگر ها پشتیبانی میشود .

ناسازگاری بین مرورگر ها :

بیشتر مردم از آخرین نسخه مرورگرها استفاده می کنند. مرورگر های گوناگون کد css شما را بگونه های مختلف تفسیر میکنند . اصلی ترین مرورگر در این زمینه IE است که ممکنه کد های border را بگونه دیگری نشان دهد .

افزودن تگ DIV :

افزودن تگ DIV برای گره زدن تمام اطلاعات بسادگی زیر انجام پذیر است :

<div class = "leftnav">

// Insert Links

</div>

همانطور که می بینید خیلی ساده اینکار انجام شد و بیشتر کار در فایل CSS انجام میشود . شما میتوانید از تگ DIV در هرجای صفحه استفاده کنید . در انتها اینجا یک صفحه XHTML ساده را می بینید که کد css آنرا سافته و نمای آن سه ستون دارد :

<div class = "content">

// Content

</div>

<div class = "leftnav">

// Links

</div>

<div class = "rightnav">

// Links

</div>
نظر شما لينک مطلب
1384/03/11
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


طراحی سایت داینامیک در دریم ویور

برای اینکه دریم ویور با زدن کلید F12 صفحات ASP و مانند آنرا بصورت داینامیک لود کند باید فایل های سایت خود را در یک پوشه ریخته باشید و بعد در IIS یک دایرکتوری مجازی با آدرسی که فایل ها در آن است بسازید .

ساخت دایرکتوری مجازی :

وارد کنترل پنل شده و سپس وارد Administrative Tools شوید. Internet Information Services را باز کنید .در سمت چپ پنجره ای که باز میشود نام کامپیوتر شما را نوشته و جلوی آن local computer نوشته شده .+ بعلاوه کنارش را بزنید تا باز شود و سپس web sites را باز کنید و روی default web site کلیک کنید . حال به منوی ACTION بروید و از زیرمنوی NEW باید Virtual Directory را بزنید . با زدن ای گزینه مراحل ساخت دایرکتوری مجازی باز میشود . در بخش Alias نامی را بعنوان نام مجازی آن انتخاب کنید . مثلا را برگزینید و به صفحه بعدی بروید .در اینجا از شما Directory را میخواهد . با زدن browse یک پوشه را انتخاب کنید .در صفحه بعدی 5 گزینه است که اجازه های دسترسی را باید معین کنید .

  • گزینه Read اجازه خواندن فایل ها را ازین دایرکتوری میدهد .
  • گزینه Run Scripts اجازه اجرای کد هایASP را توسط سرور که همان رایانه شخصی شماست می دهد .
  • Execute برای اجرای CGI است که امروزه کاربر زیادی ندارد .
  • Write به شما اجازه نوشتن روی فایل های شاخه مذکور را می دهد .
  • Browse : آیا تا کنون شده وارد سایتی شوید و بجای اینکه صفحه باز شود ، لیست فایل های موجود در آن بصورت یک windows Explorer بشما نشان داده شود ؟ اگر این گزینه را تیک بزنید این امکان برای بازدید کنندگان سایت شما فراهم میشود که در صورتی که یک پوشه شامل فایل HTML پیش فرض برای باز شدن نبود ، بازدید کننده فایل های موجود در آن پوشه را ببیند . تیک زدن این گزینه بخصوص در سرور ها کار خطرناکی است . چون هکر ها را در کارشان یاری میکنید .

بازدن Finish کار تمام شده و حال در زیر شاخه default web site شما یک پوشه مجازی بنام mysite می بینید. برای بازکردن فایل های داخل این پوشه (مثلا فایل index.asp ) روی فایل کلیک راست کنید و browse را بزنید . یک پنجره مرورگر با آدرسی مانند http://localhost/mysite/index.asp باز میشود .

تعریف سایت داینامیک در دریم ویور :

در پنجره site گزینه Edit sites را بزنید و new را برای تعریف سایت داینامیک برگزینید . نامی وارد کنید و بصفحه بعد بروید .در اینجا گزینه YES,I want to use a server technology را برگزینید و از پنجره زیرین نوع تکنولوژی مورد نظرتان مانند ASP یا CF را انتخاب کنید .در صفحه بعد آدرس پوشه مجازی را باید بدهید. d:\inetpub\wwwroot\Unnamed Site 1 این آدرس بصورت پیش فرض انتخاب شده . چرا ؟ چون در IIS پوشه مذکور بعنوان یک پوشه مجازی تعریف شده است . اما شما آدرس خودتان را از روی هارد وارد کنید . در صفحه بعد هم باید آدرس مجازی همان پوشه قبلی را بدهید که http://localhost/mysite است . در صفحه بعد از شما می پرسد که آیا هنگام اتمام ویرایش صفحات شما فایل ها را در پوشه دیگری کپی میکنید ؟ گزینه NO انتخاب شده است . بهمین صورت رهایش کنید .در صفحه بعد Done را بزنید و کار تمام شد .
نظر شما لينک مطلب
1384/03/25
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


انواع حلقه ها در فلش

فلش سه نوع حلقه را در زبان اکشن اسکریپت جای داده است که هر کدام برای قصد خاصی طراحی شده اند :

  • While : حلقه ای که شرطی در بالای حلقه دارد . اگر شرط درست باشد دستورات حلقه اجرا میشند . اینکار تا زمانیکه شرط درست است ادامه پیدا میکند .
  • Do While : شرط در این حلقه بعد از دستورات میاد . یعنی حداقل یکبار دستورات حلقه اجرا میشوند تا نوبت به شرط می رسد . حال اگر شرط برقرار بود دوباره دستورات اجرا میشوند .
  • FOR : این نوع حلقه شرطش بصورت چک کردن یک عدد است . م برای تکرار حلقه به تعداد معین باید ازین حلقه کمک گرفت .

اجرای حلقه While :

While(شرط  ){

   //دستورات //

   }

اجرای حلقه Do While :

Do{

   //دستورات //

   }while(  شرط  );

اجرای حلقه FOR :

for(i=0 ; i<=5 ; i++){

   //دستورات //

    }

دراین جلقه در ابتدا i=0 است و هر بار با کد i++ یک واحد اضافه میشد و شطر ایستادن حلقه این است که i<=5 باشد .
نظر شما لينک مطلب
1384/04/14
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


Alexa دوست طراحان وب

اگر میخواهید ببینید سایت شما در بین سایت های رقیب چقدر جلوتره چی کار میکند ؟ طبق چه چیزی خودتونو با بقیه مقایسه میکنید ؟

سایت الکسا که قدرت جستجوشو از گوگل قرض کرده در این زمینه ابزار های بسیار پیشرفته ای داره که شما رو قادر میکنه تا با بقیه خودتونو مقایسه کنید و تعداد طرفدارانتون رو هم بفهمید . وارد سایت الکسا بشین و بالای صفحه روی گزینه Traffic Ranking کلیک کنید . اسم سایت یا وبلاگتون رو بدید و enter کنید . امتیاز رنکینگ شما و سایت های مرتبط با سایت شما را در این صفحه به شما نشون میده . دکمه traffix details را اگر بزنید میتوانید امتیاز خود را در 6 ماهه گذشته در بین 100000 سایت تاپ دنیا ببینید . همچنین در همین بخش یک کادر زیر نمودار هست که امکان اینو به شما میده که اسم یه سایت دیگه رو وارد کنید تا اون سایت رو با سایت شما مقایسه کنه .

سایت مارکت لیپ نیز این امکان رو به شما میده که سایت خودتونو با 3 سایت دیگر مقایسه کنید . این سایت امتیاز شما رو در سایت های yahoo , msn , google, hotbot , AOL ,altavista با رقبای شما مقایسه میکنه و تعداد لینک داده ها به شما رو هم مشخص میکنه . همچنین میتونین خودتونو در یک زمینه خاص مثلا در زمینه آموزشی با بقیه مقایسه کنید .

برای اینکه همیشه امتیاز خودتونو در سایت گوگل و الکسا بدونین :

اگه کاربر IE هستید میتونین تولبار های این دو سایت رو بگیرین و نصب کنید . تولبار گوگل تولبار الکسا

اگر کاربر فایر فاکس هستید یه extension برای این دو تا نوشته شده که با نصب اون میتونی در فایر فاکس خودتون همیشه امتیازتون رو در این دو سایت ببینید .

SearchStatus in Action

نظر شما لينک مطلب
1384/04/14
حسین شرفی

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


سیمبیان چیست ؟

symbian OS سیمبیان یک سیستم عامل کوچک برای دستگاه های موبایل و کامپیوتر های جیبی است . امروزه اکثر گوشی های جدید شرکت هایی مانند نوکیا و زیمنس از این سیستم عامل در گوشی های خود استفاده میکنند . این سیستم عامل با زبان C++ نوشته شده است و بهمین دلیل برنامه هایی که شما تحت آن مینویسید اگر با C++ باشند بهترین کارایی را خواهند داشت . چون از زبان native خود سیستم استفاده میکنند .

مشخصات سیمبیان ورژن 7:

  • داشتن ابزارهایی مانند contacts, schedule, messaging, browsing, office, utility and system control
  • موتور مرورگر وب برای پشتیبانی کامل مرورگرهای وب و WAP
  • پشتیبانی از سیستم های MMS وSMS و EMS و همچنین POP3, IMAP4, SMTP, MHTML
  • دسترسی اشتراکی به صفحه ، کیبورد ، فونت ها و عکس ها ، ضبط و پخش صدا و فرمت های تصاویر ، شامل API برای اعمال گرافیکی
  • امکان برقراری ارتباط توسطTCP/IP , WAP , InfraRed ,Bluetooth , USB , Wireless systems
  • پشتیبانی از Unicode و فونت ها و فرمت های متن اضافی تایلندی و عربی و عبری.
  • انتقال فایل توسط SyncML و تبدیل فایل ها .
  • امکان برنامه نویسی تحت سیستم عامل با c++ و java

نسخه های ورژن 8 و 9 این سیستم عامل برای گوشی های نوکیا سری N عرضه شده است که دارای امکانات بیشتری می باشد.

گوشی هایی که از سیمبیان استفاده میکنند :

Available | Available | Coming soon
Motorola A1000 | FOMA F880iES | Arima U300
BenQ P30 | FOMA F900iC | Lenovo P930
Sony Ericsson P910 | FOMA F901iC | Panasonic X800
Nokia 7610 | Panasonic X700 | Nokia 6680
FOMA F900i | FOMA F900iT | Nokia 6681
Sendo X | Nokia 6260 | Nokia 6682
Motorola A925 | Nokia 9500 | Sendo X2
Siemens SX1 | Nokia 6620 | Nokia N70
Sony Ericsson P900 | Nokia 9300 | Nokia N90
Nokia 6600 | FOMA F700i | Nokia N91
Nokia N-Gage QD | FOMA D901iS |
Nokia 3660/3620 | FOMA F901iS |
Nokia N-Gage |  |
Nokia 3650/3600 | Discontinued |
Nokia 9290 Communicator | Nokia 9210 Communicators |
Nokia 6670 | Nokia 7650 |
Nokia 6630 | Sony Ericsson P800 |
FOMA D901i | Motorola A920 |
Nokia 3230 | FOMA F2051 |
Nokia 7710 | FOMA F2102V |
Nokia 6680 |  |

مشخصات نسخه های دیگر این سیستم عامل

نظر شما لينک مطلب
1384/04/21
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


زبان های برنامه نویسی در سیستم عامل symbian

سیمبیان توسط چند شرکت توليد کننده موبايل از جمله نوکيا و زيمنس و سامسونگ و اريکسون و پاناسونيک و سوني اريکسون سرمايه گذاري و ساخته شد . در تصوير زير صاحبان اين شرکت و درصد سرمايه هرکدام در سيستم عامل سيمبيان را مي بينيد. سيمبيان چندین زبان را برای برنامه نویسی در خود جای داده است که در این مقاله به بررسی آنها می پردازیم :

C++

سیستم عامل symbian با زبان c++ نوشته شده و بهمین دلیل این زبان بعنوان زبان اولیه برای برنامه نویسی در آن انتخاب شده است .C++ بیشترین امکان دسترسی به API های سیستم عامل سیمبیان را فراهم میکند و بهترین کارکرد در حافظه و سرعت اجرا را داراست. اما در گزینه های زیر باید ازین زبان استفاده شود :

  • برنامه هایی که مانند سرور عمل میکنند مانند برنامه هایی که در پشت صحتنه کار میکنند و یکی از بخش های سیستم را مدیریت میکنند. مانند پورت های COM
  • PLUG in ها که محیطی را بر پایه سیستم عامل ایجاد میکنند . بطور مثال برنامه ای که فایل های html را به فایل های word سیمبیان تبدیل میکند از کتابخانه مبدل سیستم عامل استفاده میکند .
  • درایور های دستگاه که با Kernel کار متعامل میکنند.

استفاده از زبان C++ در سیستم عامل سیمبیان بر روی مناسب بودن کارکرد گوشی ها متمرکز شده است ، که بدین معناست که چند تا از عملگرهای استاندارد زبان C++ مانند exception handling قابل استفاده در برنامه نویسی سیمبیان نیستند .

JAVA

جاوا اکثرا بعنوان زبان برادر c++ و جایگزین آن در سیمبیان کاربرد دارد. سیستم عامل symbian یک MIDP (Mobile Information Device Profile)را فراهم کرده است که MIDP یک گروه از API های جاوا را در خود جای داده که این API ها برای استفاده در گوشی های موبایل طراحی شده اند . مثلا برای مقاصد طراحی واسط کاربر ، شبکه و برنامه ها . MIDP تحت کلاس های ایجاد شده توسط CLDC اجرا میشود و از ماشین مجازی K استفاده میکند که یک ماشین مجازی طراحی شده برای گوشی های موبایل است.پشتیبانی سیمبیان از نصب و اجرای برنامه های MIDP در راهنمای MIDP جاوا توضیح داده شده است.

PersonalJava 1.1.1 و JavaPhone که در سیمبیان ورژن 6 آمدند در ورژن 7 دیگر بخشی از سیستم عامل نیستند.

Assembler

اکثر مقاصد برنامه نویسی با زبان C++ مرتفع میگردد . چون این زبان به اندازه کافی دسترسی به بخش های سطح پایین سیستم را فراهم میکند و نیاز به اسمبلر حس نمیشود. سیمبیان در موارد خاص که بیشترین کارایی مطرح است از اسمبلر استفاده میکند مانند برنامه های scheduler.

JavaScript

جاوا اسکریپت پروسس کلاینت ساید روی صفحات html را بر عهده دارد و اکثرا برای بررسی درستی ورودی کاربر استفاده میشود .

WML Script

این زبان یک زبان اسکریپتی WAP است که با جاوا اسکریپت اهداف یکسانی را دنبال میکنند. اما در یک مرورگر WAP استفاده میشود .

C

این زبان بطور نرمال برای نوشتن برنامه های جدید سیمبیان استفاده نمیشه ، اما میتونه یک انتخاب برای شما باشه هنگامی که میخواهید کد C را به سیمبیان تبدیل کنید . برای این هدف سیمبیان شامل یک جعبه ابزار از کتابخانه استاندارد C می باشد.

OPL

یک زبان مانند بیسیک است که روی PDA ها فعال شده بود . اما در سیمبیان ورژن 7 ساپورت نمیشود .
نظر شما لينک مطلب
1384/04/28
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


ساخت theme برای گوشی های موبایل

ساخت تم برای گوشی های سری 60 نوکیا

نرم افزار Theme Studio برای سیستم عامل های سیمبیان به شما این امکان را میدهد که تم هایی برای گوشیهای موبایل نوکیا سری 60 بسازید که روی تمام گوشی ها سری 60 قابل اجراست . با استفاده ازین نرم افزار علاوه بر ساخت تم های جدید میتوانید تم هایی را که دارید را ویرایش کنید و همچنین میتوانید آیکون ها و کاغذ دیواری و شم های آن را در محیط شبیه سازی شده روی کامپیوتر ببینید . بعد از آماده شدن یک تم ، این برنامه تم را بصورت فایل اجرایی نصب برای گوشی های نوکیا در می آورد و برنامه آماده استفاده خواهد بود .

Series 60 Theme Studio 1.2

این برنامه یک ابزار برای ساخت تم های گوشی های نوکیا سری 60 ورژن 2 میباشد. گوشیهای جدید نوکیا اکثرا سری 60 هستند مانند : Nokia 3230, Nokia 6600, Nokia 6260, Nokia 6630, Nokia 6670, Nokia 6680 and Nokia 7610

Series 60 Theme Studio 2.0

این برنامه یک ابزار برای ساخت تم های گوشی های نوکیا سری 60 ورژن 2 میباشد. همچنین پشتیبانی از نسخه سوم گوشی ها را داراست مانند گوشی های سری N .

امکانات جدید :

  • پشتیبانی از پوسته با قابلیت تغییر اندازه
  • پشتیبانی از گرافیک برداری
  • پشتیبانی از عکس های چند لایه
  • پشتیبانی از جدول افکت های عکس

برای بدست آوردن اطلاعات بیشتر و دانلود این برنامه به فروم نوکیا مراجعه کنید.

ساخت تم برای گوشی های سری 40 نوکیا:

برای ساخت تم برای گوشی های سری 40 به اینجا مراجعه کنید . تعدادی از گوشی های سری 40 عبارتند از : 3220, 3155, 5140i, 6020, 6021, 6030, 6101, 6102, 6170, 6230i, 7260, 7270, 7280, 8800.

ساخت تم برای گوشی های سونی اریکسون :

برای این گوشی ها نرم افزار Theme Creator عرضه شده است که امکان ساخت تم را به شما روی کامپیوتر خودتان میدهد .
نظر شما لينک مطلب
1384/05/11
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


نتایج مسابقه seo امسال اعلام شد

چند بار شده تو گوگل یه چیزی رو درباره طراحی وب بصورت فارسی جستجو کنی و بیای اینجا ؟ما سایتمون رو طوری طراحی و بهینه سازی میکنیم که بتونیم اولین نتایج جستجوی گوگل و یاهو را درباره موضوع سایتمون به خودمون اختصاص بدیم . این همون چیزیه که بهش میگن SEO. مخفف search engine optimization

آمارها نشان می دهند که موتورهای جستجوگر مهمترین ابزار کاربران برای دسترسی به اطلاعات هستند. بنابراین اگر سایتها بتوانند حضور موثرتری در موتورهای جستجوگر داشته باشند، محتوای ارزشمند سایتها در دسترس جویندگان اطلاعات قرار خواهد گرفت.

سایت iranseo هر ساله مسابقه ای با عنوان ذره بین طلایی برگزار میکنه که در اون معیار برگزیده شدن سایت ها امتیاز آنها موتور های جستجوگر است. ذره بین طلایی، جایزه ای است که با بررسی سایتها از دیدگاه موتورهای جستجوگر و SEO و رتبه های مناسب، میزان صفحات بایگانی شده و محبوبیت پیوندی سایت به همراه ارزشمند بودن محتوای منتشر شده به سایتها اعطا می گردد. جایزه ذره بین طلایی با اهداف زیر به برندگان اعطا می گردد:

1. تشویق فهرستها و موتورهای جستجوگر ایرانی به فعالیت و نوآوری بیشتر

2. تشویق سایت ها و افراد به استفاده از تکنیکهای SEO

3. بالا بردن ضریب نفوذ سایتهای ایرانی در اینترنت

4. قدردانی از سایتها و افرادی که نقشی در پررنگ تر کردن اهمیت "محتوای ارزشمند" داشته اند.

سایتهای زیر در مسابقه شرکت داده نمی شوند:

1. سایتهای غیر اخلاقی

2. سایتهای فاقد جذابیت بصری

3. سایتهایی که در آنها از تکنیکهای تقلب برای بهبودی رتبه ها، استفاده شده است.

دومین دوره مسابقه ذره بین طلایی با انتخاب سایت و جست‏وجوگر برتر ایرانی پایان یافت. در این دوره در مجموع 160 سایت‏ و جست‏و جوگر مورد بررسی قرار گرفت و در نهایت برندگان نهایی و ویژه معرفی شدند.سایت‏های ماکرومدیا ایکس، هارمونی تاک، وبولوژی، ایران سانگ، مجید آنلاین، فراکارانت، محمود بی و سایت ایران داک به عنوان برندگان نهایی برگزیده شدند که سایت Irandoc.ac.ir مربوط به مرکز اطلاعات و مدارک علمی ایران، جایزه ویژه را به خود اختصاص داد. همچنین در این مراسم از جست‏وجوگر پارسیک به عنوان تنها جست‏وجوگر برتر تقدیر شد.

رزومه برندگان جایزه ذره بین طلایی :

  1. مرکز اطلاعات و مدارک علمی ایران
  2. موتور جستحوگر پارسیک
  3. طراح وب - ماکرومدیا
  4. گفتگوی هارمونیک
  5. ایران ترانه
  6. وبولوژی
  7. محمود بشاش
  8. مجید آنلاین
  9. فراکارانت

منبع خبر : سایت ایران سئو
نظر شما لينک مطلب
1384/05/16
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


Flash 8 با امکانات گرافیکی فوق العاده

ماکرومدیا نسخه بتای فلش 8 را عرضه کرده و اینطور که پیداست تمامی جوانب بازار را میخواهد . هم گرافیک ، هم سرور ساید و هم player-side بودن .و امروز ویدئوی تحت وب را نیز میخواهد !

Player Side بودن :

در نسخه فلش پلیر 8 تعدادی ماژول به برنامه اضافه شده که باعث میشود حجم فایل های swf به شدت کاهش یابد . این ماژول ها که اکثرا گرافیکی هستند کارهای خاصی را از جمله اعمال فیلتر های drop shadow, blur, glow, bevel, gradient bevel, and color adjustو مانند آن را در سمت کلاینت (یا همون(player بعهده میگیرند . بهمین دلیل هنگام طراحی نیازی به استفاده از چند عکس در لایه های گوناگون برای نشان دادن این گونه فیلتر ها نیست و با نوشتن چند خط کد نشان دادن فیلتر بلور روی عکس امکان پذیر میشود .

پخش ویدئوی قوی تر :

در نسخه فلش 8 استاندارد کد کردن تصاویر از H.283 به تکنولوژی ON2 VP6 ارتقاء یافته که کیفیتی بهتر از windows media را با 15% کاهش سایز عرضه میکند . عرضه ویدئوی با کیفیت در فلش خطری جدی برای برنامه های real و quickTime اپل و WinMedia مایکروسافت بحساب میاید. چون Flash player روی 98% از کامپیوتر های جهان نصب میباشد که چیزی در حدود 600 میلیون دستگاه را در بر میگیرد . در ضمن فلش خیلی راحت تر از فیلم های quickTime و WinMedia قابل دریافت است و کاربران را بسرعت بسوی خود جذب میکند .

همچنین امکان جدیدی با عنوان آلفا روی فیلم به فلش اضافه شده که بشما اجازه میدهد یک رنگ خاص از ویدئوی در حالپخش را در زمان اجرا حذف کنید . پس براحتی میتوانید از حقه سینمایی پرده آبی برای فیلم های فلش خود استفاده کنید تا مثلا دود سیگار را در فیلم خود اضافه کنید .

تصاویر برداری :

وقتی قرار باشه یه برنامه را تحت چند محیط اجرا کنید و همش مجبور باشید از تصاویر بیت مپی استفاده کنید باید اون برنامه را چند بار و برای هر محیط بطور جداگانه بنویسید . یکی ازین محیط ها موبایل ها هستند که با صفحه خود در ابعاد گوناگون طراحان را خسته میکنند . اما با استفاده از فلش نیازی به چند بار نوشتن نیست . چون تصاویر برداری فلش براحتی تغییر سایز می دهند بدون اینکه کیفیت آنها پایین بیاید .

امکان جدیدی هم دراین بخش اضافه شده که بشما اجازه میدهد داخل یک طرح برداری را با عکس بیت مپی پر کنید ( در حین اجرا) بدون اینکه تصویر برداری شما به بیت مپ تبدیل شود .

کد نویسی آسان :

حالت normal mode که در ورژن 2004 حذف شده بود دوباره به فلش اضافه شده است . البته با امکانات بهتری از جمله کامل کننده دستورات در حین تایپ !

متا تگ برای فلش :

یک خاصیت متا تگ برای فایل های SWF معرفی شده است که باعث میشود تا موتور های جستجو مانند گوگل و یاهو بتوانند محتویات فلش های شما را شناسایی کنند و به جستجو کنندگان معرفی کنند .

شبیه ساز موبایل:

برای موبایل طراحی کنید و سپس طرح خود را در شبیه ساز گوشی هایی که flash Lite را پشتیبانی تست کنید . این emulator در فلش گنجانده شده تا شما راحت تر از قبل بتوانید برای گوشی های موبایل فلش بسازید . همچنین Script Assist شما را در نوشتن اکشن اسکریپت برای گوشی ها یاری میکند .

منبع

نظر شما لينک مطلب
1384/05/21
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


قالب هاي رايگان براي طراحي نماي سايت

قالب های وبلاگ قالب های رایگان یکی از ابزار های مفیدی است که هر طراح وب به آنها نیاز دارد. البته بنظر من این اصلا خوب نیست که شما سایت خودتونو همیشه از روی دیگران کپی کنید . اما این قالب ها گاهی ایده های خوبی به آدم میدن تا یه قالب مطابق آنچه در ذهنتونه طراحی کنید . اینم چند تا از این سایت ها که قالب ها رو با سورس در اختبارتون میذارن :

http://www.101webtemplate.com

http://www.4layouts.com

http://www.adamssite.com

http://www.adesdesign.net

http://www.bestclipart.com

http://www.best-templates.net

http://www.boxedart.com

http://www.easytemplates.com

http://www.effex-media.com

http://www.elated.com

http://www.finetemplates.com

http://www.flashburger.com

http://www.flasheasy.com

http://www.flashfair.com

http://www.freebieland.net

http://www.free-flash-template.com

http://www.freelayouts.com

http://www.freephotoshoptemplates.com

http://www.freepsd.com

http://www.freesitetemplates.com

http://www.freetemplates.ca/templates

http://www.freetemplates.co.uk

http://www.freetemplates4u.com

http://www.free-templates-layouts.com

http://www.free-web-layouts.com

http://www.freewebsitetemplates.com

http://www.freewebtemplates.com

http://www.freewebtemplatesnow.com

http://www.freshtemplates.com

http://www.hooverwebdesign.com/templates/

http://www.interspire.com/templates

http://www.kiwisgraphics.com

http://www.layoutbank.com

http://www.mastertemplates.com

http://www.myfreetemplates.com

http://www.mytemplatestorage.com

http://www.notemplates.com

http://www.pro-templates.net

http://www.pro-templates.net/free.html

http://www.rickyswebtemplates.com

http://www.snakeyewebtemplates.com

http://www.specialtemplates.com

http://www.steves-templates.com

http://www.template-empire.com

http://www.templateexpert.com

http://www.templatehunter.com

http://www.templatemonster.com

http://www.templatepark.com

http://www.templatesbox.com

http://www.templatesdownload.net

http://www.templatesheaven.com

http://www.templatesking.com

http://www.templatesland.com

http://www.templatestop.com

http://www.templatesweb.com

http://www.templateworkz.com

http://www.templateyes.com

http://www.thewebbrains.com

http://www.trendytemplates.com

http://www.buytemplates.net

http://www.w3templates.com

http://www.weballey.net/templates/

http://www.web-templates.nl

http://www.webtemplateszone.com

http://www.webzonetemplates.com

http://www.winkletwebdesign.com

http://www.wyomingwebdesign.com

http://www.zerodollartemplates.com

http://www.zymic.com

نظر شما لينک مطلب
1384/05/26
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


راهنمایی های گوگل به طراحان وب سایت ها

هرچه امتیاز شما در گوگل افزایش یابد باعث میشود تا گوگل شما را در صفحه جستجو در رتبه بالاتری نمایش دهد. برای افزایش رتبه خود در گوگل به نکات زیر توجه کنید . حتی اگر بالا رفتن امتیاز گوگل برایتان مهم نیست نکات کلیدی را بکار گیرید . زیرا گوگل سایت هایی را که این نکات را رعایت نکرده اند از لیست جستجویش حذف میکند و دیگر در هیچ یک از سایت های شرکای گوگل نیز نام شما نشان داده نمی شود .

نکات طراحی و محتوای سایت :

  • سایت را با یک سلسله لینک های واضح طراحی کنید . هر صفحه حداقل باید از طریق یک لینک متنی ساده در دسترس باشد.
  • برای سایت یک صفحه map یا همون نقشه طراحی کنید که لینک های صفحات مهم را دارد. اگر لینک ها بیش از 100 تاست صفحه نقشه را به چند صفحه تقسیم کنید.
  • درباره لغاتی که کاربران برای دسترسی به سایت شما در موتورهای جستجو تایپ میکنند فکر کنید و مطمئن باشید که مطالبی درباره این لغات در سایت شما هست .
  • برای نمایش کلمات و لینک های مهم از متن بجای عکس استفاده کنید ، زیرا جستجوگر خزنده گوگل متون نوشته شده در عکس را تشخیص نمیدهد .
  • برای لینک ها و عکس ها حتما از تگ های title و Alt بصورت دقیق و درست استفاده کنید.
  • لینک های شکسته ( لینک هایی که به جای درستی اشاره نمی کنند) را درست کنید.
  • اگر شما از طراحی سایت های داینامیک استفاده میکنید (یعنی دنبال اسم صفحه یک آدرس بصورت کاراکتر “?” هست ) باید بدانید که کل موتور های جستجو نمیتوانند این صفحات را بخوبی صفحات static پیدا کنند .
  • لینک هایی که هر صفحه دارد باید حداکثر تعداد قابل قبولی باشد ، حدود 100 لینک.

نکات فنی :

  • از یک مرورگر متن مانند Lynx برای تست کردن سایت خود استفاده کنید . چون اکثر جستجوگر ها سایت شما را همانند چشمان Lynx می بینند . اگر شما در سایتتان از جاوا اسکریپت ، کوکی ها ، اشیاء session ، frame یا فلش یا هر چیزی که جلوی دید برنامه های خزنده (Crawler) را بگیرد استفاده کرده باشید ممکن است این جستجوگر ها نتوانند صفحات سایت شما را بخوبی ببینند و index کنند .
  • استفاده از SessionID جلوی برنامه های خزنده موتور های جستجوگر را میگیرد و چون آنها نمیتوانند در سایت شما ثبت نام کنند تا صفحات را ببینند بنابرین تعدادی از صفحات شما هرگز در این جستجوگر ها ثبت نمیشوند
  • اگر از سیستم های CMS استفاده میکنید مطمئن شوید که این سیستم توانایی ساخت صفحاتی که گوگل می یابد را داراست .
  • از پارامتر هایی مانند "&id=" در لینک های صفحاتتان استفاده نکنید . چون گوگل این آدرس ها را index نمیکند .

وقتی سایتتان آماده شد :

  • از سایت های مرتبط بخواهید به شما لینک دهند .
  • سایت خود را در http://www.google.com/addurl/?continue=/addurl ثبت کنید .
  • نقشه سایت خود را در Google Sitemaps ثبت کنید .
  • سایت خود را در موتور های جستجوگر و دایرکتوری های دیگر از جمله یاهو ثبت کنید . یکی ازین جاها dmoz.org است .

نکات کلیدی :

  • صفحات را برای کاربر طراحی کنید نه جستجوگر ها : یعنی چیزی را که برای جستجوگر میفرستید همانی باشد که در سایت دارید و به کاربر نشان می دهید.
  • از روش های حقه زدن به موتور های جستجو برای بالا بردن pageRank استفاده نکنید . چون اولین مشتریان شما بازدید کنندگان شما هستند نه جستجوگر ها . اگر جستجوگر ها اصلا وجود نداشتند شما اصلا این کارا رو میکردین ؟!
  • از برنامه های تائید نشده برای ثبت صفحات و چک کردن امتیاز خود در گوگل بهره نبرید . زیرا این برنامه ها قوانین گوگل را زیر پا میگذارند . مانند برنامه WebPosition Gold که درخواست سایت شما را بچند مدل به گوگل می فرستد ( برای گول زدن موتور جستجوگر – با این حرکت جستجوگر های معمولی گول میخورندو فکر میکند سایت شما پر طرفدار است . اما گوگل آنها را پیدا میکند). این برنامه ها ممکن است باعث شوند گوگل اسم شما را بطور کلی از لیست سایت های جستجو حذف کند !!!

توصیه های ایمنی :

  • از لینک ها یا متن های مخفی استفاده نکنید .
  • از cloak redirect استفاده نکنید .
  • Query های برنامه ریزی شده به گوگل نفرستید .
  • صفحه را با کلمات نا مربوط به سایتتان لود نکنید.
  • صفحات تکراری در دایرکتوری ها و ساب دومین های سایتتان نسازید.

Query های برنامه ریزی شده چیست ؟

هر چه کاربران کلمه ای را در گوگل جستجو کنند که نام شما در صفحه اول ظاهر شود و اگر رویش هم کلیک کنند در امتیاز گوگل شما تاثیر دارد . اما اگر گوگل متوجه شود که این درخواست ها همگی ساختگی و توسط برنامه هایی مانند WebPosition Gold فرستاده میشوند سایت شما را از لیست جستجویش حذف میکند . پس مواظب باشید تقلب نکنید !
نظر شما لينک مطلب
1384/05/30
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


گوگل مسنجر خود را بنام Talk عرضه کرد

این برنامه که Google Talk نام دارد مسنجر گوگل است که هنوز نسخه بتاست . اما بالاخره پشت جعبه اش اسم گوگل خورده! پس نمیشه ازش گذشت . همچون سایر معجزات گوگل ظاهری ساده داره و با حجمی معادل 900 کیلوبایت که در 3 دقیقه دانلود میشود. نیاز به ویندوز 2000 یا XP برای نصب دارد و مودم 56K .

امکانات گوگل تاک :

· Sign in : برای ورود از اکانت جیمیل استفاده میکنه . همچنین دوستانتونو با اکانت جیمیلشون در لیست اضافه میکنید . در ضمن هنگام نصب از شما میخواد که برنامه Gmail Notifier رو پاک کنید ، چون این برنامه خودش کار چک کردن ایمیل های شما رو انجام میده .

· Add Friends : برای اضافه کردن دوستانتان در لیست خودتان باید اکانت جیمیل آنها را در بخش invite وارد کنید . اگر دوستتان Gmail ندارد ایمیل معمولی او را وارد کنید . با اینکار یک دعوت نامه جیمیل هم برای او ارسال میشود. وقتی دوستی را در لیست اضافه کنید تا وقتی که او اجازه افزودن اسمش را در لیست شما بدهد ، کلمه invite جلوی نام او در گوگل تاک شما دیده میشود .

· در این مسنجر در کنار اسم دوستانتان آیکون های رنگی ای دیده میشود که هر کدام معنی خاصی دارد و دوستانی هم که کنار اسمشون آیکون ندارند یعنی هنوز برنامه talk رو نصب نکرده اند .

● سبز : یعنی آنلاین

● زرد : یعنی بیکار (Idle)

● قرمز : یعنی مشغول (busy)

● طوسی : یعنی آفلاین

· توسط این مسنجر شما 3 امکان ارتباط با دوستان خود را در اختیار دارید :

1- گپ آنلاین

2- ارسال ایمیل با کلیک روی آیکون M برای دوستتان

3- تماس شنیداری با کلیک روی آیکون Å

· امکان آرشیو کردن گفتگو ها نيز مانند یاهو مسنجر فراهم است .

دانلود برنامه گوگل تاک

منبع گوگل

نظر شما لينک مطلب
1384/06/03
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


رفع مشکل فارسی نویسی در فلش با Flash RTL

Flash RTL component مشکل کجاست ؟

اگر شما هم از فلش برای طراحی برنامه های تحت وب استفاده میکنید، احتمالا به مشکل فارسی نویسی در فلش برخورد کرده اید. مشکل از اونجا نشات میگیره که شرکت ماکرومدیا هنوز امکانات زبان فارسی رو در نرم افزار هاش بهینه نکرده و این مشکل در فلش بیش از سایر نرم افزار ها به چشم میاد . چون محصول نهایی یک فایل SWF است و نه یک HTML .

این مشکل زمانی به اوج میرسه که شما در فلشی که طراحی کرده اید بخواهید از یک بانک اطلاعاتی یا فایل XML اطلاعاتی رو بخونید که شامل کلمات فارسی و انگلیسی بطور درهم باشه. و سپس اونا رو در فلش بصورت راست به چپ نمایش بدید . در این موقع هست که کلمات فارسی و انگلیسی جابجا نشون داده میشن و شما حس میکنید تمام زحمتی که کشیدید بر باد رفته .

و اما راه حل :

ایرانی برقراره همیشه ! بله : دو تا از دوستای خوب من بنام پدرام پور حسین از سایت PedyMX و فرید عرض پیما از IFlashDes که در زمینه فلش توی ایران کمیاب هستند با همکاری هم یک کامپوننت فلشی بنام FlashRTL ساخته اند که این مشکل رو در فلش برطرف میکنه . این کامپوننت که در آدرس FlashRTL.com قرار داده شده دارای 8 متد است که کلیه امور زبان فارسی رو در فلش بعهده میگیره . از جمله متد تبدیل تاریخ گروگوریان به تاریخ جلالی ، متد درست کردن نمایش حرف ی . متد فارسی نویسی right to left . و چند متد مفید دیگر .

برای دانلود این کامپوننت به بخش دانلود این سایت بروید .

دیگه چه خبر :

اما گفتن این مطلب هم خالی از لطف نیست که شما میتوانید به زودی در کنار همین پروژه کاری دیگر را ببینید که به شما امکان استفاده از تمامی Font های فارسی را در فلش به صورت پویا (Dynamic) میدهد و دیگر احتیاجی نیست که برای نمایش متون داینامیک خود در فلش از فونت های Arial, Tahoma, Times و... استفاده کنید. این پروژه نیز بزودی از همین تیم عرضه خواهد شد .

تشکر :

سایت ماکرومدیا ایکس وظیفه خودش میدنه که ازین دو طراح ایرانی بخاطر زحمتی که در گسترش زبان فارسی در محیط وب – اونهم بدون هیچگونه چشم داشتی - کشیده اند تشکر کنه و با معرفی این برنامه نویسان کمکی در گسترش فعالیت های این دوستان کرده باشه .

و اما مسئولین محترم در سازمانهای مرتبط با مقوله گسترش زبان فارسی در اینترنت ، اصلا لازم نیست خودتونو نگران کنید ، خیلی وقته که محققان ایرانی از شما طلب یاری نمیکنند . زیرا همه میدونن هیچ وقت از شما آبی گرم نشده و در اینترنت هم جز فیلترینگ چیز دیگه ای بلد نیستید .
نظر شما لينک مطلب
1384/06/15
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


محصولات طراحی وب مایکروسافت

Microsoft Sparkle شرکت مایکروسافت اعلام کرده است که محصولات طراحی وب قدرتمندی را در رقابت با شرکت ادوبی و ماکرومدیا عرضه خواهد کرد . این بسته که Microsoft Expression نام دارد شامل 3 نرم افزار برای انجام کلیه امور طراحی وب میباشد و بیشتر برای رقابت با بسته نرم افزاری استودیو ی شرکت ماکرومدیا عرضه خواهد شد :

· Acrylic : یک ابزار طراحی گرافیک تحت وب که به طراحان اجازه میدهد تا تصاویر برداری و بیت مپی را بطور همزمان در این برنامه ویرایش کنند. این برنامه رقیبی برای نرم افزار فایرورکس ماکرومدیا است .

· Quartz : ابزار ساخت صفحات وب که پشتیبانی تکنولوژی CSS را نیز داراست . مایکروسافت این برنامه را در رقابت با نرم افزار دریم ویور محصول شرکت مایکرومدیا عرضه کرده است.

· Sparkle : ابزار طراحی چند رسانه : این نرم افزار طراحان را در ساخت انیمیشن های 2 بعدی و 3 بعدی یاری میکند و رقیبی برای نرم افزار فلش شرکت ماکرومدیا به شمار میرود . بطوریکه عده ای آن را قاتل فلش می نامند. اما آنچه فلش را در صدر نگه می دارد طرفداران گسترده این برنامه است ، که هم شامل کاربران و هم طراحان میشود .نکته دیگر اینکه هم اکنون برنامه Flash Player روی 98% کامپیوتر های جهان نصب است و استفاده ار فلش در طراحی صفحات وب یک امر معمول است . اما استفاده از sparkle علاوه بر مشکلات طراحی و کار با یک نرم افزار جدید برای طراح ، مشکل دانلود برنامه اجراکننده را هم برای کاربران دارد.

لینک در سایت مایکروسافت
نظر شما لينک مطلب
1384/06/20
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


2005 Studio MX توسط ماکرومدیا عرضه شد.

نسخه جدید بسته نرم افزاری Studio MXکه شامل پرطرفدارترین نرم افزارهای طراحی وب از جمله فلش ، دریم ویور و فایر ورکس میباشد توسط ماکرومدیا به بازار عرضه شد . ماکرومدیا که نسخه هشتم این بسته نرم افزاری را عرضه کرده است ، نرم افزار FreeHand را ازین بسته جدا کرده و این برنامه دیگر بهمراه Studio MX عرضه نمیشود . زیرا نرم افزار FreeHand برای امور طراحی وب کاربرد بسیار کمی دارد و اکثرا در صنعت چاپ و گرافیک بکار گرفته میشود .

این بسته نرم افزاری در نسخه 2005 ، دو نرم افزار دیگر شرکت ماکرومدیا را بنام Contribute و Flashpaper در خود جای داده است که در نسخه 2004 وجود نداشتند و بصورت جداگانه فروخته میشدند .

قابلیت های هر یک از برنامه های Studio MX بشرح زیر میباشد :

· DreamWeaver : این برنامه که جهت طراحی صفحات وب بکار می رود دارای امکان کد نویسی سمت سرور ASP , ASP.net , PHP , CF, JSP میباشد. از جمله امکانات جدید آن قدرت بیشتر در کار با CSS ، ارتباط ساده تر برنامه با فایل های XML، امکان مقایسه دو فایل در سمت کلاینت یا سرور ، پشتیبانی از PHP 5 و Coldfusion mx 7 میباشد .یک امکان Paste Special هم به برنامه اضافه شده که در کپی مطالبتان از برنامه word به صفحات وب در دریم ویور شما را یاری خواهد کرد .

· Flash MX : در نسخه فلش 8 استاندارد کد کردن تصاویر از H.283 به تکنولوژی ON2 VP6 ارتقاء یافته که کیفیتی بهتر از windows media را با 15% کاهش سایز عرضه میکند. حالت normal mode در کدنویسی که در ورژن 2004 حذف شده بود دوباره به فلش اضافه شده است . البته با امکانات بهتری از جمله کامل کننده دستورات در حین تایپ ! یک خاصیت متاتگ برای فایل های SWF معرفی شده است که باعث میشود تا موتور های جستجو مانند گوگل و یاهو بتوانند محتویات فلش های شما را شناسایی کنند و به جستجو کنندگان معرفی کنند .

· FlashPaper : توسط اين برنامه ميتوانيد فايل هاي قابل پرينت خود را تبديل به PDF و يا SWF کنيد. متن توليد شده توسط اين برنامه قابليت جستجو و انتخاب شدن و کپي و چسبانده شدن در تمامي برنامه هاي ويندوز و مکينتاش را داراست . همچنين ميتوانيد در فلش ساخته شده از انواع bookmark و link نيز استفاده کنيد . اين برنامه با آفيس مايکروسافت همخواني کاملي دارد که تبديل فايل هاي برنامه هاي آفيس را به فلش هاي زيبا مقدور ميسازد . حتي ميتوانيد ارائه هاي برنامه powerpoint را نيز به فلش تبديل کنيد .

· FireWorks : گرافیک سایت خود را به این برنامه بسپارید . بهترین کیفیت و کمترین حجم عکس را برای استفاده در وب تولید میکند . این برنامه علاوه بر امور گرافیکی کار ساخت منوهای پایین افتادنی جاوا را هم با چند کلیک برایتان انجام میدهد. همچنین Slice کردن تصاویر و قرار دادن slice ها در جدول یکی از قابلیت های مفید این برنامه است .

· Contribute : یک دریم ویور کوچک شده برای کسانی که میخواهند طراحی وب را با محصولات ماکرومدیا شروع کنند . استفاده از CSS دریم ویور ، امکان کپی مطالب از کلیه محصولات آفیس در صفحات وب و ویرایش کد با موتور کدساز دریم ویور از جمله امکانات قوی این نرم افزار است.
نظر شما لينک مطلب
1384/06/27
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


PDF چیست ؟ حضور PDF در آفيس 12

PDF چیست ؟

فرمت PDF توسط شرکت Adobe طراحی شده و مخفف Portable Document Format است ، به معنای فرمت سند قابل انتقال. بدین معنی که شما یک فایل را با این فرمت ذخیره میکنید و آنرا میان هزاران نفر به اشتراک میگذارید. . امروزه اکثر کتاب های الکترونیکی با این فرمت عرضه میشوند . فایل های PDF دقیقا همانگونه ای چاپ میشوند که شما آن را در مانیتور میبینید ، با همان صفحه بندی ، فونت و عکس های موجود . بدون اینکه وابسته به محیطی باشند که در آن ساخته شده اند. علاوه بر این امنیت در این فایل ها نسبت به سایر فرمت های موجود بسیار بالاتر است و حتی امکان رمزگزاری روی فایل جهت امنیت بیشتر نیز ممکن است . در این حالت کاربر برای باز کردن و ویرایش این فایل ها نیاز به رمز عبور خواهد داشت .

سهولت استفاده :

برای باز کردن PDF به برنامه Adobe Reader نیاز دارید که بصورت رایگان میباشد . این برنامه امکان خواندن فایل های PDF را فراهم می سازد . اما برای ساخت یا ویرایش یک فایل PDF نمی توان از آن استفاده کرد. در این برنامه همچنین میتوانید از امکان Find جهت پویش متن استفاده کنید .

ساخت فایل های PDF :

برای ساخت فایل هایی با این فرمت باید از یکی از برنامه هایی که کار ساخت فرمت PDF را انجام میدهند استفاده کنید مانند :

  • Adobe Acrobat
  • PDF Creator
  • PrimoPDF
  • PDF 995
  • CutePDF

نحوه کار این برنامه ها بدین صورت است که یک پرینتر مجازی برای شما تعریف میکنند. بعد از اینکه کار ویرایش سند خود را در برنامه مورد نظرتان انجام دادید دکمه پرینت را بزنید. پرینتر مجازی PDF را انتخاب کنید و تنظیمات چاپ را مانند چاپ روی کاغذ انجام دهید. در نهایت با زدن دکمه Print بجای اینکه پرینتر شما مشغول چاپ شود، یک پنجره باز میشود و از شما آدرس ذخیره سازی فایل را می پرسد تا فایل را روی درایو هارد شما ذخیره کند . بنابرین هر چیزی که قابلیت چاپ را داشته باشد میتواند بصورت PDF نیز در آید .

امکان جدید آفیس 12 :

طبق گفته مایکروسافت ، نسخه جدید آفیس قابلیت ذخیره فایل های برنامه های دسته آفیس را با پسوند PDF در خود دارد و و اگر از برنامه های PDF ساز فقط جهت تبدیل اسناد آفیس بهره میگیرید، دیگر نیازی نیست یکی ازین برنامه ها را خریداری کنید. زیرا این قابلیت در نسخه آفیس 12 جزیی از نرم افزار های این بسته نرم افزاری است .

ساخت یک PDF فوری :

اگر بخواهید همین الان بدون نصب هیچ یک ازین برنامه ها سند خود را به PDF تبدیل کنید میتوانید با مراجعه با آدرس http://createpdf.adobe.com در سایت ادوبی ، یک اکانت رایگان از این شرکت بگیرید و 5 فایل pdf بصورت رایگان از اسناد خود درست کنید .
نظر شما لينک مطلب
1384/07/11
حسين شرفي

آرشيو مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• محصولات طراحی وب مایکروسافت
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• قالب هاي رايگان براي طراحي نماي سايت
• Flash 8 با امکانات گرافیکی فوق العاده
• نتایج مسابقه seo امسال اعلام شد
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• Alexa دوست طراحان وب
• انواع حلقه ها در فلش
• طراحی سایت داینامیک در دریم ویور
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• معرفی سرویس های گوگل
• آموزش ساخت فانکشن Query Command
• ادغام شرکت ماکرومدیا و ادوبی
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• علت خراب شدن قالب وبلاگ ها
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه مرورگر های وب با یکدیگر
• مقایسه Coldfusion و ASP
• انتخاب بهترین رنگ برای طراحی وب سایت
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
• ColdFusion MX 7 به بازار آمد
• تفاوت های برنامه Authorware و Director
• آموزش فلش : لود کردن صدا بصورت داینامیک
• JavaScript چيست؟
• آموزش فلش : لود کردن عکس بصورت داینامیک
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• معرفی نرم افزار FlashPaper 2
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• تاریخچه استانداردهای تبادل داده مایکروسافت
• معرفی نرم افزار Capative
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• گوگل در حال طراحی یک مرورگر وب
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• ويژوال استوديو 2005 در راه است
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• دریم ویور : رویاباف طراحان وب
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• معرفي پايگاه داده SQL Server 2000
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• اهميت رنگ در طراحي وب
• اكشن اسكريپت - متغير ها در فلش
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• معرفی Macromedia Fireworks
• آموزش ColdFusion ، ساختار Switch/Case
• ارکات ; فراکتالی از انسان ها
• اكشن اسكريپت : كنترل در زمان اجرا
• نرم افزار Macromedia Director
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آموزش کلد فیوژن : متغیر های Client و Session
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
• کار با پایگاه داده ها در کلدفیوژن
• اکشن اسکریپت ، یک زبان شیئ گرا
• متاتگ چیست ؟
• ColdFusion مقدماتی، قسمت اول
• The search key was not found in any record
• آشنايي با زبان اسکريپتي جاوا اسکریپت
• مدارک بین المللی مایکروسافت
• Join کردن بيش از ۲ جدول براي Database هاي Access
• Microsoft InfoPath 2003 چیست ؟
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
• مقالات طراحی وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


access مقالات
• مقایسه ای بین SQL server 2000 و ACCESS 2000
• آموزش ساخت فانکشن Query Command
• The search key was not found in any record
• Join کردن بيش از ۲ جدول براي Database هاي Access
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت
حسين شرفي


coldfusion مقالات
• دفاع از کلدفیوژن در برابر پدرخوانده اش : جاوا
• مقایسه Coldfusion و ASP
• شرکت ماکرومدیا با کلدفیوژن 7 به دنیای موبایل راه می یابد
• ColdFusion MX 7 به بازار آمد
• آموزش کلد فیوژن: انواع داده پيچيده : ليست ها
• درك و رفع نقص پيام هاي error در كلد فيوژن
• دستورهای شرطی در ColdFusion
• آموزش ColdFusion ،انواع داده ي پيچيده : آرايه ها
• آموزش ColdFusion ، ساختار Switch/Case
• آموزش کلد فیوژن : متغیر های Client و Session
• کار با پایگاه داده ها در کلدفیوژن
• ColdFusion مقدماتی، قسمت اول
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


dotnet مقالات
• دات نت فریم ورک چیست؟
• علت تاخیر شما در آپدیت از VB به VB.net
• براي دريافت مدرك MCSD.net از كجا شروع كنيم ؟
• ويژوال استوديو 2005 در راه است
• برای نصب ویژوال استودیو دات نت چه کنیم ؟
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


dreamweaver مقالات
• طراحی سایت داینامیک در دریم ویور
• دریم ویور : رویاباف طراحان وب
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


flash مقالات
• رفع مشکل فارسی نویسی در فلش با Flash RTL
• Flash 8 با امکانات گرافیکی فوق العاده
• انواع حلقه ها در فلش
• آشنايي با زبان لينگو لايت و انقلاب فلش
• محصولات فلش ساز Sothink
• آموزش فلش : لود کردن صدا بصورت داینامیک
• آموزش فلش : لود کردن عکس بصورت داینامیک
• Flash برای چه بوجود آمد ؟
• اکشن اسکریپت : اولويت عملگر هاي فلش
• اكشن اسكريپت : استفاده از عملگرها براي دستكاري مقادير عبارت ها
• اكشن اسكريپت - متغير ها در فلش
• اكشن اسكريپت : كنترل در زمان اجرا
• اكشن اسكريپت : متغير هاي رشته اي ، عددي و بولين و نال
• اکشن اسکریپت ، یک زبان شیئ گرا
• سرور افزار Macromedia Flex
• سرور افزار Macromedia Breeze
• سرور افزار Flash Communication Server MX
• Action Script - FScommand
• آشنایی با سمبل ها در فلش
• قالب دستوري اكشن اسكريپت
• اسکریپت چیست ؟
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


google مقالات
• گوگل مسنجر خود را بنام Talk عرضه کرد
• راهنمایی های گوگل به طراحان وب سایت ها
• نتایج مسابقه seo امسال اعلام شد
• Alexa دوست طراحان وب
• معرفی سرویس های گوگل
• گوگل در حال طراحی یک مرورگر وب
• چگونه در گوگل نتایج جستجوی بهتری بدست آوریم
• سایت خود را مطابق تکنولوژی جستجوگر ها طراحی کنید
• PageRank گوگل چیست ؟ چگونه افزایش می یابد؟
• ارکات ; فراکتالی از انسان ها
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


html مقالات
• آموزش CSS - طراحی یک سایت بدون استفاده از جدول ها
• متاتگ چیست ؟
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


javascript مقالات
• JavaScript چيست؟
• تفاوت هاي اكشن اسكريپت و جاوا اسكريپت
• آشنايي با زبان اسکريپتي جاوا اسکریپت
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


macromedia مقالات
• 2005 Studio MX توسط ماکرومدیا عرضه شد.
• ادغام شرکت ماکرومدیا و ادوبی
• تفاوت های برنامه Authorware و Director
• معرفی نرم افزار FlashPaper 2
• معرفی نرم افزار Capative
• معرفی Macromedia Fireworks
• نرم افزار Macromedia Director
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


microsoft مقالات
• PDF چیست ؟ حضور PDF در آفيس 12
• محصولات طراحی وب مایکروسافت
• ارائه IE 7.0 توسط مایکروسافت و CSS 2
• ابزار های رایگان ASP برای سایت شما
• تاریخچه استانداردهای تبادل داده مایکروسافت
• مدارک بین المللی مایکروسافت
• Microsoft InfoPath 2003 چیست ؟
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


mobile مقالات
• ساخت theme برای گوشی های موبایل
• زبان های برنامه نویسی در سیستم عامل symbian
• سیمبیان چیست ؟
• نوکیا تکنولوژی فلش ماکرومدیا را برای گوشی های سری 60 برگزید
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


sqlserver مقالات
• دستکاری جدول های بانک اطلاعاتي SQL
• آموزش SQL server - دستور MINUS
• آموزش SQL server - دستور INTERSECT
• آموزش SQL server - دستور UNION ALL
• آموزش SQL server - دستور UNION
• آموزش SQL server - دستور OUTER JOIN
• آموزش SQL server - دستور JOIN
• آموزش SQL server - دستور ALIAS
• آموزش SQL server - دستور HAVING
• آموزش SQL server - دستور GROUP BY
• آموزش SQL server - دستور COUNT
• آموزش SQL server - دستور FUNCTIONS
• آموزش SQL server - دستور ORDER BY
• آموزش SQL server - دستور LIKE
• آموزش SQL server - دستور BETWEEN
• آموزش SQL server - دستور IN
• آموزش SQL server - دستور AND OR
• آموزش SQL server - دستور SELECT و Where
• آموزش SQL SERVER
• معرفي پايگاه داده SQL Server 2000
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


web-design مقالات
• قالب هاي رايگان براي طراحي نماي سايت
• علت خراب شدن قالب وبلاگ ها
• مقایسه مرورگر های وب با یکدیگر
• انتخاب بهترین رنگ برای طراحی وب سایت
• يك سيستم مديريت محتوا (cms) چيست ؟
• چگونه يك طراح وب پيدا كنيم ؟
• چرا شما به يك سايت نياز داريد ؟
• آيا شما بيننده هاي سايت خود را فراري مي دهيد؟
• اهميت رنگ در طراحي وب
• هفت اشکال بزرگ در طراحی قالب وبلاگ‌
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


نظرات دوستان

:نام
:ايميل
:آي دي ياهو
:سايت شما

:متن
زهرا
salam man ek weblag daram mekhastam dar mord weblagam ax bendazam ama nemeyad az ghaleb shoma estefadeh kardam nemedonam chera nemeyadesh fekr konam menzoramo fahmedeh bashe

zahra
salam web sait ghashange hastesh az lahaz mohtava mataleb amozandehe khobe dare movafagh bashed

student
استخدام مهندس و فوق دیپلم کامپیوتر در كانادا به تعدادی مهندس و فوق دیپلم کامپیوتر (ترجیحاً در زمینه IT) ترجیحاً آشنا به زبان انگليسي برای استخدام (تضمینی) با حقوق در حدود 4000$ در کشور کانادا نیازمندیم .علاقه مندان برای اخذ اطلاعات کاملتر لطفاً با شماره های 23981 (پنج رقمی) با داخلی 141 (مجانی) مستقیماً از تهران به تورنتو_کانادا) و یا شماره دفتر تورنتو 0050-915-416-001 تماس بگیرید . و يا با ايميل زير مكاتبه داشته باشند. student_canada_toronto@yahoo.com

آزاد خادم
مطالب شما بسيار جالب و مفيد هستند. ما يگ گروه هستيم در شهرستان سقز از استان كردستان اما تازه كار و علاقه مند اميداورم ما را كمك كنيد.

NSNA
سلام ممنون از مطالب پرمحتواتون.... من یه مشکلی دارم میخوام از شما کمک بگیرم..... من با اینکه تو سایت نوکیا رجیستر شدم ولی نمیتوم theme studioرو دانلود کنم...........این errorرو میده: Download Failure Request information: Request ID: 23504 URI: http://sw.nokia.com/id/98a4970d-c344-40c0-9744-292d0a0b94f2/Series_60_Theme_Studio_1_2.1.zip Error Message: Downloader's country group below file's required rating (ADCG)! Required: B, downloader's: C اگه بتونین کمکم کنین خیلی ممنون میشم

fgj
سلام . ممنون از خبراتون . خیلی خوبین

8mGZgWOwEq8DRtJ
8mGZgWOwEq8DRtJ
Hi! Great site! Thanks! Check my site too: [url=http://anime.adult-fantasy.name]anime[/url]

0GR8q8fi3xBY3vI
0GR8q8fi3xBY3vI
Hi! Great site! Thanks! Check my site too: [url=http://hentai.adult-fantasy.name]hentai[/url]

amir
az nazare man ke khobe

faroogh
lotfan nahveye gharar dadane adrese web dar ghesmate searche yahoo va google ra tozih dahin mamnoon bye

فاروق
lotfan nahveye gharar dadane adrese web dar ghesmate searche yahoo va google ra tozih dahin mamnoon bye

gqXeBbuuOYnIFkB
gqXeBbuuOYnIFkB
Hi! Great site! Thanks! Check my site too: [url=http://cialis-commercial.best-pharmacy.name/]cialis commercial[/url]

1u7BL5zw7acPBNO
1u7BL5zw7acPBNO
Hi! Great site! Thanks! Check my site too: [url=http://soma-carisoprodol.best-pharmacy.name/]soma carisoprodol[/url]

Mohsen
salam , man parsal az site shoma ye code ra bardashtam ke baraye hazfe tablighaye balaye persianblog neveshte boodin lotfan age mitonid dobare benevisid chon jadidan dige kar nemikone oun code ehtemalan bar alayhesh neveshtan , mamnoon

ناصر
خیلی خیلی دست شما درد نکنه واقعا کارتون حرف نداره و امیدوارم که مطالبتون رو مفید تر و بیشتر کنید دستتون درد نکنه

منک
سلام -موش بخوره شما رو خبر ماکرومدیا تون خیلی خوب بود -

GiD11WRDBqTDWSV
GiD11WRDBqTDWSV
Hi! Great site! Thanks! Check my site too: [url=http://soft-tabs-cialis.best-pharmacy.name/]soft tabs cialis[/url]

v37YBun95zTxfnZ
v37YBun95zTxfnZ
Hi! Great site! Thanks! Check my site too: [url=http://fioricet-texas-holdem.best-pharmacy.name/]fioricet texas holdem[/url]

bQrSrl95LE6my7O
bQrSrl95LE6my7O
Hi! Great site! Thanks! Check my site too: [url=http://carisoprodol-use.best-pharmacy.name/]carisoprodol use[/url]

رضا
سلام! من كه لينكي نديدم! ميشه بگيد كجا لينك قرار داديد؟ موفق باشيد!

سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

ارتباط با ما
صفحه اصلي سايت


طراح وب - ماکرومديا

PDF چیست ؟ حضور PDF در آفيس 12

PDF چیست ؟

فرمت PDF توسط شرکت Adobe طراحی شده و مخفف Portable Document Format است ، به معنای فرمت سند قابل انتقال. بدین معنی که شما یک فایل را با این فرمت ذخیره میکنید و آنرا میان هزاران نفر به اشتراک میگذارید. . امروزه اکثر کتاب های الکترونیکی با این فرمت عرضه میشوند . فایل های PDF دقیقا همانگونه ای چاپ میشوند که شما آن را در مانیتور میبینید ، با همان صفحه بندی ، فونت و عکس های موجود . بدون اینکه وابسته به محیطی باشند که در آن ساخته شده اند. علاوه بر این امنیت در این فایل ها نسبت به سایر فرمت های موجود بسیار بالاتر است و حتی امکان رمزگزاری روی فایل جهت امنیت بیشتر نیز ممکن است . در این حالت کاربر برای باز کردن و ویرایش این فایل ها نیاز به رمز عبور خواهد داشت .

سهولت استفاده :

برای باز کردن PDF به برنامه Adobe Reader نیاز دارید که بصورت رایگان میباشد . این برنامه امکان خواندن فایل های PDF را فراهم می سازد . اما برای ساخت یا ویرایش یک فایل PDF نمی توان از آن استفاده کرد. در این برنامه همچنین میتوانید از امکان Find جهت پویش متن استفاده کنید .

ساخت فایل های PDF :

برای ساخت فایل هایی با این فرمت باید از یکی از برنامه هایی که کار ساخت فرمت PDF را انجام میدهند استفاده کنید مانند :

  • Adobe Acrobat
  • PDF Creator
  • PrimoPDF
  • PDF 995
  • CutePDF

نحوه کار این برنامه ها بدین صورت است که یک پرینتر مجازی برای شما تعریف میکنند. بعد از اینکه کار ویرایش سند خود را در برنامه مورد نظرتان انجام دادید دکمه پرینت را بزنید. پرینتر مجازی PDF را انتخاب کنید و تنظیمات چاپ را مانند چاپ روی کاغذ انجام دهید. در نهایت با زدن دکمه Print بجای اینکه پرینتر شما مشغول چاپ شود، یک پنجره باز میشود و از شما آدرس ذخیره سازی فایل را می پرسد تا فایل را روی درایو هارد شما ذخیره کند . بنابرین هر چیزی که قابلیت چاپ را داشته باشد میتواند بصورت PDF نیز در آید .

امکان جدید آفیس 12 :

طبق گفته مایکروسافت ، نسخه جدید آفیس قابلیت ذخیره فایل های برنامه های دسته آفیس را با پسوند PDF در خود دارد و و اگر از برنامه های PDF ساز فقط جهت تبدیل اسناد آفیس بهره میگیرید، دیگر نیازی نیست یکی ازین برنامه ها را خریداری کنید. زیرا این قابلیت در نسخه آفیس 12 جزیی از نرم افزار های این بسته نرم افزاری است .

ساخت یک PDF فوری :

اگر بخواهید همین الان بدون نصب هیچ یک ازین برنامه ها سند خود را به PDF تبدیل کنید میتوانید با مراجعه با آدرس http://createpdf.adobe.com در سایت ادوبی ، یک اکانت رایگان از این شرکت بگیرید و 5 فایل pdf بصورت رایگان از اسناد خود درست کنید .
نظر شما لينک مطلب
1384/07/11
حسين شرفي

2005 Studio MX توسط ماکرومدیا عرضه شد.

نسخه جدید بسته نرم افزاری Studio MXکه شامل پرطرفدارترین نرم افزارهای طراحی وب از جمله فلش ، دریم ویور و فایر ورکس میباشد توسط ماکرومدیا به بازار عرضه شد . ماکرومدیا که نسخه هشتم این بسته نرم افزاری را عرضه کرده است ، نرم افزار FreeHand را ازین بسته جدا کرده و این برنامه دیگر بهمراه Studio MX عرضه نمیشود . زیرا نرم افزار FreeHand برای امور طراحی وب کاربرد بسیار کمی دارد و اکثرا در صنعت چاپ و گرافیک بکار گرفته میشود .

این بسته نرم افزاری در نسخه 2005 ، دو نرم افزار دیگر شرکت ماکرومدیا را بنام Contribute و Flashpaper در خود جای داده است که در نسخه 2004 وجود نداشتند و بصورت جداگانه فروخته میشدند .

قابلیت های هر یک از برنامه های Studio MX بشرح زیر میباشد :

· DreamWeaver : این برنامه که جهت طراحی صفحات وب بکار می رود دارای امکان کد نویسی سمت سرور ASP , ASP.net , PHP , CF, JSP میباشد. از جمله امکانات جدید آن قدرت بیشتر در کار با CSS ، ارتباط ساده تر برنامه با فایل های XML، امکان مقایسه دو فایل در سمت کلاینت یا سرور ، پشتیبانی از PHP 5 و Coldfusion mx 7 میباشد .یک امکان Paste Special هم به برنامه اضافه شده که در کپی مطالبتان از برنامه word به صفحات وب در دریم ویور شما را یاری خواهد کرد .

· Flash MX : در نسخه فلش 8 استاندارد کد کردن تصاویر از H.283 به تکنولوژی ON2 VP6 ارتقاء یافته که کیفیتی بهتر از windows media را با 15% کاهش سایز عرضه میکند. حالت normal mode در کدنویسی که در ورژن 2004 حذف شده بود دوباره به فلش اضافه شده است . البته با امکانات بهتری از جمله کامل کننده دستورات در حین تایپ ! یک خاصیت متاتگ برای فایل های SWF معرفی شده است که باعث میشود تا موتور های جستجو مانند گوگل و یاهو بتوانند محتویات فلش های شما را شناسایی کنند و به جستجو کنندگان معرفی کنند .

· FlashPaper : توسط اين برنامه ميتوانيد فايل هاي قابل پرينت خود را تبديل به PDF و يا SWF کنيد. متن توليد شده توسط اين برنامه قابليت جستجو و انتخاب شدن و کپي و چسبانده شدن در تمامي برنامه هاي ويندوز و مکينتاش را داراست . همچنين ميتوانيد در فلش ساخته شده از انواع bookmark و link نيز استفاده کنيد . اين برنامه با آفيس مايکروسافت همخواني کاملي دارد که تبديل فايل هاي برنامه هاي آفيس را به فلش هاي زيبا مقدور ميسازد . حتي ميتوانيد ارائه هاي برنامه powerpoint را نيز به فلش تبديل کنيد .

· FireWorks : گرافیک سایت خود را به این برنامه بسپارید . بهترین کیفیت و کمترین حجم عکس را برای استفاده در وب تولید میکند . این برنامه علاوه بر امور گرافیکی کار ساخت منوهای پایین افتادنی جاوا را هم با چند کلیک برایتان انجام میدهد. همچنین Slice کردن تصاویر و قرار دادن slice ها در جدول یکی از قابلیت های مفید این برنامه است .

· Contribute : یک دریم ویور کوچک شده برای کسانی که میخواهند طراحی وب را با محصولات ماکرومدیا شروع کنند . استفاده از CSS دریم ویور ، امکان کپی مطالب از کلیه محصولات آفیس در صفحات وب و ویرایش کد با موتور کدساز دریم ویور از جمله امکانات قوی این نرم افزار است.
نظر شما لينک مطلب
1384/06/27
حسين شرفي

محصولات طراحی وب مایکروسافت

Microsoft Sparkle شرکت مایکروسافت اعلام کرده است که محصولات طراحی وب قدرتمندی را در رقابت با شرکت ادوبی و ماکرومدیا عرضه خواهد کرد . این بسته که Microsoft Expression نام دارد شامل 3 نرم افزار برای انجام کلیه امور طراحی وب میباشد و بیشتر برای رقابت با بسته نرم افزاری استودیو ی شرکت ماکرومدیا عرضه خواهد شد :

· Acrylic : یک ابزار طراحی گرافیک تحت وب که به طراحان اجازه میدهد تا تصاویر برداری و بیت مپی را بطور همزمان در این برنامه ویرایش کنند. این برنامه رقیبی برای نرم افزار فایرورکس ماکرومدیا است .

· Quartz : ابزار ساخت صفحات وب که پشتیبانی تکنولوژی CSS را نیز داراست . مایکروسافت این برنامه را در رقابت با نرم افزار دریم ویور محصول شرکت مایکرومدیا عرضه کرده است.

· Sparkle : ابزار طراحی چند رسانه : این نرم افزار طراحان را در ساخت انیمیشن های 2 بعدی و 3 بعدی یاری میکند و رقیبی برای نرم افزار فلش شرکت ماکرومدیا به شمار میرود . بطوریکه عده ای آن را قاتل فلش می نامند. اما آنچه فلش را در صدر نگه می دارد طرفداران گسترده این برنامه است ، که هم شامل کاربران و هم طراحان میشود .نکته دیگر اینکه هم اکنون برنامه Flash Player روی 98% کامپیوتر های جهان نصب است و استفاده ار فلش در طراحی صفحات وب یک امر معمول است . اما استفاده از sparkle علاوه بر مشکلات طراحی و کار با یک نرم افزار جدید برای طراح ، مشکل دانلود برنامه اجراکننده را هم برای کاربران دارد.

لینک در سایت مایکروسافت
نظر شما لينک مطلب
1384/06/20
حسين شرفي

رفع مشکل فارسی نویسی در فلش با Flash RTL

Flash RTL component مشکل کجاست ؟

اگر شما هم از فلش برای طراحی برنامه های تحت وب استفاده میکنید، احتمالا به مشکل فارسی نویسی در فلش برخورد کرده اید. مشکل از اونجا نشات میگیره که شرکت ماکرومدیا هنوز امکانات زبان فارسی رو در نرم افزار هاش بهینه نکرده و این مشکل در فلش بیش از سایر نرم افزار ها به چشم میاد . چون محصول نهایی یک فایل SWF است و نه یک HTML .

این مشکل زمانی به اوج میرسه که شما در فلشی که طراحی کرده اید بخواهید از یک بانک اطلاعاتی یا فایل XML اطلاعاتی رو بخونید که شامل کلمات فارسی و انگلیسی بطور درهم باشه. و سپس اونا رو در فلش بصورت راست به چپ نمایش بدید . در این موقع هست که کلمات فارسی و انگلیسی جابجا نشون داده میشن و شما حس میکنید تمام زحمتی که کشیدید بر باد رفته .

و اما راه حل :

ایرانی برقراره همیشه ! بله : دو تا از دوستای خوب من بنام پدرام پور حسین از سایت PedyMX و فرید عرض پیما از IFlashDes که در زمینه فلش توی ایران کمیاب هستند با همکاری هم یک کامپوننت فلشی بنام FlashRTL ساخته اند که این مشکل رو در فلش برطرف میکنه . این کامپوننت که در آدرس FlashRTL.com قرار داده شده دارای 8 متد است که کلیه امور زبان فارسی رو در فلش بعهده میگیره . از جمله متد تبدیل تاریخ گروگوریان به تاریخ جلالی ، متد درست کردن نمایش حرف ی . متد فارسی نویسی right to left . و چند متد مفید دیگر .

برای دانلود این کامپوننت به بخش دانلود این سایت بروید .

دیگه چه خبر :

اما گفتن این مطلب هم خالی از لطف نیست که شما میتوانید به زودی در کنار همین پروژه کاری دیگر را ببینید که به شما امکان استفاده از تمامی Font های فارسی را در فلش به صورت پویا (Dynamic) میدهد و دیگر احتیاجی نیست که برای نمایش متون داینامیک خود در فلش از فونت های Arial, Tahoma, Times و... استفاده کنید. این پروژه نیز بزودی از همین تیم عرضه خواهد شد .

تشکر :

سایت ماکرومدیا ایکس وظیفه خودش میدنه که ازین دو طراح ایرانی بخاطر زحمتی که در گسترش زبان فارسی در محیط وب – اونهم بدون هیچگونه چشم داشتی - کشیده اند تشکر کنه و با معرفی این برنامه نویسان کمکی در گسترش فعالیت های این دوستان کرده باشه .

و اما مسئولین محترم در سازمانهای مرتبط با مقوله گسترش زبان فارسی در اینترنت ، اصلا لازم نیست خودتونو نگران کنید ، خیلی وقته که محققان ایرانی از شما طلب یاری نمیکنند . زیرا همه میدونن هیچ وقت از شما آبی گرم نشده و در اینترنت هم جز فیلترینگ چیز دیگه ای بلد نیستید .
نظر شما لينک مطلب
1384/06/15
حسين شرفي

سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب

تبلیغات

مدیر سایت
ارتباط با ما
حسين شرفي

آرشيو مقالات
Flash mx
Dream weaver
Cold Fusion
Dot Net
HTML
Java Script
web Design
Access database
SQL server
Mobile
Microsoft
macromedia
Google
تمام مقالات

لينک

! نوعي ديگر

محصولات ماکرومديا

سايت هاي آموزشي
macromedia weblogs
W3 Schools
Dev Articles
ASP Free
Dev shed
web wiz guide
sql-server-vb-asp
Hot Scripts
Flash Kit Tutorials
Flash-mx.com
GoArticles
flash-db.com
director-online
Action Script
learn ASP
Learn SQL
VB.net Heaven
Learn Coldfusion
Pixel 2 Life

همکاران ما در وب
www.DEV.ir
iDevCenter
Iran Developers
Iran ASP.net
Iran PHP.net
IRANVIG
Sakha ravesh
Barnamenevis
MajidOnLine
MajidOnLine Forum
Flash source (FLA)

دوستان
پرشين ياهو
دانلود
ظابط
2nya
آفساید - فوتبال
FLash RTL
آی فلش دز
IransBs
افق رایانه
قالب ساز بلاگفا
جاويدان
بهروز پی سی
اقتراحیه


MacromediaX - contact us

جهت سفارش هاست ، دامين ، طراحي سايت ميتوانيد از فرم زير براي ارسال سفارشات خود استفاده کنيد .در صورت تمايل شماره تلفن خود را هم درج کنيد تا در اسرع وقت با شما تماس گرفته شود . اطلاعاتي که در اينجا ثبت ميکنيد بصورت خصوصي و فقط توسط اعضاي سايت ديده خواهد شد . پيشاپيش از ارتباط شما ممنونيم

:نام
:ايميل
:سايت شما

:متن

سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب
هم اکنون سفارش دهید

صفحه اصلي سايت
حسين شرفي
رامين خوشحال
هادي مشيدي


MacromediaX Web Hosting Services

MY S QL & MS SQL Server Database prices

Disk Space | MY SQL Price/Year | MS SQL Price/Year
10 MB | 200,000 | 250,000
20 MB | 350,000 | 400,000
50 MB | 600,000 | 800,000
100 MB | 1,000,000 | 1,500,000
Web Server | Linux | Windows

Each extra MB/Year MY SQL: 20,000 Rls

Each extra MB/Year MS SQL: 25,000 Rls
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب
هم اکنون سفارش دهید

صفحه اصلي سايت


MacromediaX Domain Registeration Service

Registrar | OnlineNIC.com | Bulkregister.com | Verisign.com | Duration
com, net, org | 80,000 | 120,000 | 350,000 | 1 yr
biz | 200,000 | 240,000 | 550,000 | 2 yrs
info | 240,000 | 240,000 | 550,000 | 2 yrs
name | 220,000 | 220,000 | 350,000 | 1 yr
tv | 380,000 | - | 350,000 | 1 yr
cc | 290,000 | 450,000 | 350,000 | 1 yr
ir | 150,000 |  |  | 1 yr
User Agreement | OnlineNIC.com | Bulkregister.com | Verisign.com |
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب
هم اکنون سفارش دهید

صفحه اصلي سايت

توضيحات
NEW.net Domain extensions are available

NEW.net, the availability of domain names with new extensions that offer greater relevance and meaning than current Web site addresses ending in .com, .net, and other existing top-level domains.

More than 169 million Internet users currently have access to these domain extensions - through partnerships with leading ISPs or by using a free plug-in available here.
.GAME .INC .CLUB .MP3 .CHAT

.MED .LTD .SHOP .FREE .LAW

.FAMILY .AUCTION .GOLF ...


MacromediaX Web Hosting Services

Plans | L0 | L1 | L2 | L3 | L4 | L5 | L6
Price (Rls/Year) | 150,000 | 250,000 | 350,000 | 600,000 | 900,000 | 1,650,000 | 2,600,000
Disk Space | 10 MB | 20 MB | 50 MB | 100 MB | 200 MB | 500 MB | 1000 MB
Monthly Traffic | 1 GB | 2 GB | 5 GB | 10 GB | 15 GB | 20 GB | 30 GB
Subdomain | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited
Control panel | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Sitebuilder | No | Yes | Yes | Yes | Yes | Yes | Yes
Access to log file | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Web Stats | No | No | Yes | Yes | Yes | Yes | Yes
Pre-Installed App. | No | Yes | Yes | Yes | Yes | Yes | Yes
POP3/SMTP Accounts | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited
Spam Filtering | No | No | No | Yes | Yes | Yes | Yes
Webmail | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Protected Folders | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Real Video/Audio | Optional | Optional | Optional | Optional | Optional | Optional | Optional
Perl, Python, PHP4 ... | Yes | Yes | Yes | Yes | Yes | Yes | Yes
Tomcat JSP | No | No | No | Optional | Optional | Optional | Optional
FrontPage Ext. | Yes | Yes | Yes | Yes | Yes | Yes | Yes
MySQL | Yes | Yes | Yes | Yes | Yes | Yes | Yes
PostgreSQL | No | No | No | Yes | Yes | Yes | Yes
Support | 24x7x365 | 24x7x365 | 24x7x365 | 24x7x365 | 24x7x365 | 24x7x365 | 24x7x365
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب
هم اکنون سفارش دهید

صفحه اصلي سايت

مشخصات سرور
* | RedHat Linux Fedora
* | Apache 1.3.4
* | RAID 5, Full Server Backups -Weekly
* | Multiple High Speed Lines (OC-3)
* | UPS Power Back Up
* | Real Time Full Control Panel
* | 24x7 FTP Access
* | Firewall Protected
* | 99.9% Uptime guarantee


MacromediaX Web Design Services - طراحی وب سایت های تجاری

www.PersianYahoo.com

Customer : Mr H.Sharafi
Design Tools : | DreamWeaver MX
 | ASP Classic

www.DEV.ir

Customer : Mr H.Sharafi
Design Tools : | DreamWeaver MX
 | ASP Classic

www.Gassoco.com

Customer : Gasso Co ltd.
Design Tools : | DreamWeaver MX
 | Flash MX

www.Sinano.ir

Customer :sinano institute
Design Tools : | DreamWeaver MX
 | ASP classic

www.7Honar.ir

Customer : Mrs A.Rashtiani
Design Tools : | DreamWeaver MX
 | ASP Classic

www.offside.ir

Customer : Mr sha'r baaf
Design Tools : | DreamWeaver MX
 | ASP Classic

www.kitex.ir

Customer : PersianYahoo
Design Tools : | DreamWeaver MX
 | ASP Classic

Flash center

Customer : PersianYahoo
Design Tools : | DreamWeaver MX
 | Flash MX

www.eshgh.ir

Customer :Eshgh e-Magazine
Design Tools : | DreamWeaver MX
 | ASP Classic
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب
هم اکنون سفارش دهید

صفحه اصلي سايت


MacromediaX Web Hosting Services

Plans | Plan 1 | Plan 2 | Plan 3 | Plan 4 | Plan 5 | Plan 6
Price (Rls/Year) | 250,000 | 350,000 | 500,000 | 800,000 | 1,100,000 | 2,000,000
Disk Space | 10 MB | 20 MB | 50 MB | 100 MB | 200 MB | 500 MB
SubDomain | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited
Monthly Traffic | 1 GB | 2 GB | 5 GB | 10 GB | 15 GB | 3020 GB
Control panel | Yes | Yes | Yes | Yes | Yes | Yes
Access to log file | Yes | Yes | Yes | Yes | Yes | Yes
AW Stats | - | Yes | Yes | Yes | Yes | Yes
POP3 Account | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited | Unlimited
Web Mail | Yes | Yes | Yes | Yes | Yes | Yes
Spam Filtering | Yes | Yes | Yes | Yes | Yes | Yes
protected Folders | Yes | Yes | Yes | Yes | Yes | Yes
Media streaming | Optional | Optional | Optional | Optional | Optional | Optional
.NET Framework | Yes | Yes | Yes | Yes | Yes | Yes
Frontpage Ext. | Yes | Yes | Yes | Yes | Yes | Yes
ODBC (Windows) | Yes | Yes | Yes | Yes | Yes | Yes
MSSQL (more...) | Optional | Optional | Optional | Optional | Optional | Optional
24x7 Support | Email | Email | Email | Email | Email | Email
Plans | Plan 1 | Plan 2 | Plan 3 | Plan 4 | Plan 5 | Plan 6
سرويس هاي وب
ميزباني وب - سرور ویندوز
ميزباني وب - سرور لینوکس
ثبت دامين
نمونه طراحي وب
هم اکنون سفارش دهید

صفحه اصلي سايت

مشخصات سرور
* | Location: America
* | Multiple Internet links with over 400 MB/s total bandwidth available
* | Windows 2003 Servers : We use only the latest Intel Windows 2003 servers with IIS 6.0 and full support for ASP, Perl, CGI, ISAPI, SHTML and IHTML scripting technologies.
* | Unlimited Email Forwarding
* | Unlimited Email Aliases
* | Unlimited Auto responder
* | 99.9% Uptime guarantee